[Ffmpeg-devel-irc] ffmpeg.log.20111111

burek burek021 at gmail.com
Sat Nov 12 02:05:03 CET 2011

[00:00] <pasteeater> kanzure: then try -profile baseline, but i have no idea how old your ffmpeg is
[00:19] <kanzure> pasteeater: my ffmpeg is from nov6
[00:19] <kiol> Would someone please give me the ffmpeg command for adding 2 mp4 files together to make one long mp4 file?
[00:19] <sacarasc> kiol: It's better if you use MP4Box for that job.
[00:20] <kiol> No idea where to get it.
[00:20] <kiol> Is there a Gui for Ubuntu?
[00:21] <sacarasc> It's part of GPAC, there might be a GUI, I have no idea.
[00:21] <kiol> That's pretty sad.
[00:21] <kiol> Have you ever used it?
[00:21] <sacarasc> Never needed to.
[00:22] <kiol> Then why recommend it?
[00:22] <sacarasc> Because ffmpeg can't do this task well at all and others have reported success with MP4Box.
[00:24] <kiol> I just downloaded Gpac from Synaptic.....no idea how to even start Gpac
[00:24] <sacarasc> MP4Box is the binary you need.
[00:24] <kiol> I'm no good at compiling software.
[00:25] <kiol> Well, thanks anyway.
[00:25] <sacarasc> If you installed GPAC, you have MP4Box installed.
[00:25] <kiol> I used Kdenlive and it worked very well but wanted something better.
[00:25] <kiol> No idea how to run it.
[00:25] <sacarasc> Open a shell and type in: MP4Box
[00:26] <kiol> Doesn't work
[00:26] <kiol> Oh well
[00:27] <kiol> By "shell" do you mean "terminal"?
[00:27] <sacarasc> Yes.
[00:27] <kiol> Oh
[00:27] <kiol> The thing tells me for help type "MP4Box -h"   but nothing happens
[00:28] <sacarasc> That's because it's a command line programme...
[01:27] <dekozo> how can i make a screencast using the internal audio ? i mean, if i play a video on the screencast the result video would play the sound as well?
[01:35] <pasteeater> dekozo: you can try "How can I control PulseAudio input? (e.g. capture application audio instead of mic)"
[01:35] <pasteeater> http://ubuntuforums.org/showthread.php?t=1392026
[01:35] <pasteeater> also see: What do I do if my system does not use the PulseAudio sound server?
[01:35] <dekozo> i tried that link
[01:35] <dekozo> but it didnt work, but i'll look more into that
[01:35] <dekozo> thanks
[01:48] <teratorn> I'm processing a video, and for each frame I'm overlaying am image (a watermark). could anyone tell me why there are so many artifacts trailing behind my watermark as it bounces around in this video? http://teratorn.org/code/mpg_overlay/ (see out.mpg)
[03:44] <AlexWaters> I have a video broadcaster called xsplit, it outputs .flv files with h.264+aac. I want to bring these into adobe premiere... does anyone know how I can do this? I tried converting to .mp4 with vlc - but premiere is only letting me use the .mp4 import as a video segment, and isn't letting me drop it in the audio section
[04:20] <uiojki> Anyone have a ffmpeg code/instruction for converting videos (like you get off of youtube) for an iPod Classic?
[13:38] <aladdin> hi
[13:38] <aladdin>  is somebody is interesting in added Openmax IL support in FFmpeg ?
[13:39] <aladdin> Gstreamer has already integrate it : http://www.freedesktop.org/wiki/GstOpenMAX
[13:39] <aladdin> OpenMAX" is a royalty-free
[13:46] <sasishiju> Hi, I am using ffmpeg in my Windows video application. The rendered images are heavily pixellated and the issue is identified to be in my decoding pipeline. I have a couple of doubts. 1 - I am using av_parser_parse2 to decode x264 encoded buffers. I am passing in &m_avpkt.data, &m_avpkt.size as 3rd and 4th params, where m_avpkt is AVPacket type, and I have called just av_init_packet(&m_avpkt) 
[13:46] <sasishiju> before parse. Is this correct usage? Later I am using this packet in avcodec_decode_video2. The documentation says - The input buffer must be FF_INPUT_BUFFER_PADDING_SIZE larger than the actual read bytes. How can I make sure that? Is it by av_grow_packet? 
[13:47] <sasishiju> Sorry, one edit - av_parser_parse2 to "parse" x264 encoded buffers.
[15:30] <kriegerod> Hi. i want to save my decoded AVFrames into large queue, and then encode them later. Is there an extablished practice on this?
[16:39] <LexSfX> ffmpeg is converting my 60 fps video (yes, it's ACTUALLY supposed to be 60 fps) to 59.94 fps.  is there a way i can circumvent this odd behavior?  "-r 60" doesn't seem to work
[16:57] <alyawn> does specifying 2 -i's on the CLI add 2 inputs for filters or do you have to use the movie src filter? For overlay, for example.
[16:59] <alyawn> I suspect it doesn't
[19:42] <chilicuil> hi there, I've just compiled the last version of ffmpeg in order to get access to the last features of x11grab (--follow-mouse) and I'm getting a weird error when trying to record alsa input to a matroska file (.mkv), the following command $ ffmpeg -f alsa -ac 2 -i hw:0,0 -acodec pcm_s16le -y output.mkv fails with the following msg: http://pastebin.com/tZ4SKvfF has enyone find similar behaviour?
[20:06] <Ecco> Hi everyone
[20:06] <chilicuil> hi Ecco 
[20:06] <Ecco> Quick question : I've a file containing raw Speex data. Is it possible to encapsulate it in an Ogg container using FFmpeg ?
[20:06] <Ecco> (my ffmpeg version is built with speex support)
[20:10] <sacarasc> ffmpeg -i input -acodec copy output.ogg
[20:10] <sacarasc> That might work... Might not.
[20:10] Action: sacarasc shrugs.
[20:12] <Ecco> Gave that a try
[20:12] <Ecco> "[mp3 @ 0x1ed0480]Could not find codec parameters (Audio: mp3, 0 channels, s16)"
[20:13] <sacarasc> ffmpeg -acodec speex -i input -acodec copy output.ogg ?
[20:17] <Ecco> oh, you can specify multiple "acodec" options ?
[20:18] <Ecco> so, actually it's getting slightly better
[20:18] <Ecco> the name of the codec should be "libspeex", not just "speex"
[20:18] <Ecco> I now have "[mp3 @ 0x25074a0]Could not find codec parameters (Audio: libspeex, 0 channels, s16)"
[20:18] <Ecco> (my file contains mono audio data)
[20:22] <sacarasc> Before -i is the specifying what the input file is.
[20:23] <Ecco> all right. Makes sense
[20:32] <pasteeater> chilicuil: yes. for now i recommend splitting the output into two streams: one audio in wav, and one video into whatever (mkv probably), and then muxing them. i can give example if you need one.
[20:34] <pasteeater> example: http://pastebin.com/bm54khCU
[21:01] <clemz> hey
[21:03] <Rickk> hi clemz
[21:06] <Freakshow>     Student: Kostya Shiskov
[21:06] <Freakshow>     Mentor: Ronald Bultje
[21:07] <clemz> I'd like to use a specific cross compiler to compile the whole ffmpeg source code, but I didn't find a good documentation to know how to set the correct parameters...  Does someone have a link or something  ? thx :)
[21:08] <pasteeater> Freakshow: how does one pronounce "Bultje"?
[21:09] <Freakshow> I do not know... 
[21:09] <Freakshow> are either of them still on the dev team?
[21:09] <Freakshow> they're listed under rtmp support
[21:09] <Freakshow> :P
[21:10] <Freakshow> pasteeater: I'm going to bump things up to 0.8.6 to see if I can eliminate that zero sized function bug...
[21:11] <pasteeater> they work on libav now I think, but their contributions are merged into FFmpeg.
[21:11] <pasteeater> i'm not familiar with that bug
[21:11] <Freakshow> I've been asking about it for the last month
[21:11] <Freakshow> :(
[21:12] <Freakshow> I've got tcpdumps that I'm swimming through to isolate where the problem is occurring
[21:12] <Freakshow> I'll be going through the process listed for bug reports this afternoon
[21:12] <Freakshow> I can reproduce it at will almost...
[21:13] <pasteeater> is there a bug report for it?
[21:13] <Freakshow> I haven't been able to find one
[21:14] <pasteeater> does Git head behave buggy too?
[21:14] <pasteeater> 1. try git head
[21:14] <pasteeater> 2. if it works use it, or
[21:14] <pasteeater> 2b. make a bug report
[21:14] <pasteeater> or maybe that should be 3.
[21:15] <Freakshow> probably
[21:15] <Freakshow> ;)
[21:15] <Freakshow> lu_zero and spd666 both came across this last year
[21:15] <pasteeater> do you have a link?
[21:15] <Freakshow> http://mplayerhq.hu/pipermail/ffmpeg-devel-irc/2010-June/000124.html
[21:16] <pasteeater> shit. i missed 11-11-11 11:11:11.
[21:16] <Freakshow> the only difference is that the reference there is to rtsp
[21:16] <Freakshow> but the error is the same
[21:16] <Freakshow> [14:54:31] <spd666> RROR server comment - Zero sized function (client:253253728:unknown): type:20 size:0 index:595:
[21:17] <Freakshow> I've seen this in everything from 0.6.3 up to 0.8.2 so far
[21:17] Action: iive looks at the topic, 0.8.6
[21:17] <pasteeater> first step is to try git head.
[21:17] <Freakshow> np
[21:17] <Freakshow> pulling that down now
[21:17] <pasteeater> to eliminate the possibility that it has been fixed
[21:18] <iive> but I don't think i've seen any recent rtsp changes...
[21:18] Action: pasteeater doesn't pay much attention to rtsp
[21:18] <Freakshow> well, I really don't care much about rtsp either, my issue is specifically with rtmp
[21:18] <Freakshow> I'm seeing the same thing from dveo encoders as well
[21:18] <iive> have you tried with librtmp ?
[21:19] <Freakshow> crap! late for a meeting, brb
[21:19] <pasteeater> anyway, cehoyos will request git head in trac probably if you report a bug
[23:20] <Met4physica> would someone please direct me how to make a working ffmpeg command into a script that loops through all files in a directory (linux) and gives me some idea about what's going on - or, recommend a gui?
[23:21] <pasteeater> Met4physica: what do you mean by, "gives me some idea about what's going on"?
[23:22] <Met4physica> if i have 20 files in a dir, i want to know if its on 1, 2, or 12 so i generally speaking know when it will be done
[23:22] <pasteeater> "on 1, 2, or 12" as in encoding 1, 2, or 12?
[23:23] <Met4physica> yes, which one is encoding
[23:27] <pasteeater> use a for loop to encode the files. you can see which file is being encoded in the ffmpeg console output
[00:00] --- Sat Nov 12 2011

More information about the Ffmpeg-devel-irc mailing list