[Ffmpeg-devel-irc] ffmpeg.log.20120103

burek burek021 at gmail.com
Wed Jan 4 02:05:01 CET 2012

[00:02] <relaxed> works fine using avconv
[00:02] <cbsrobot> works using ffmpeg too
[00:03] <iiu7> Then what's wrong at my place? 
[00:03] <cbsrobot> compile it yourself
[00:03] <cbsrobot> with latest git head
[00:03] <iiu7> Yeah, I think I'll have to do that!
[00:04] <iiu7> Thanks all! Great help! :)
[00:54] <SteveTheCat> how do you change a video encoding of a file with ffmpeg?
[00:59] <SteveTheCat> I'm trying to do ffmpeg -i file.avi -vcodec h264 OutputFile.avi but i'm getting    file.avi: Invalid data found when processing input
[01:11] <iiu7> I compiled ffmpeg from the latest source and everything is working now! Thanks again for all the help!
[01:26] <SteveTheCat> how do you skip a stream in your file?
[01:26] <SteveTheCat> i'm having problems converting a file that has vorb in it but I don't need that audio track
[01:28] <cbsrobot> -an
[01:29] <SteveTheCat> also how do you view what codecs the file is using?
[01:30] <SteveTheCat> nevermind
[01:30] <SteveTheCat> it didn't show before for some reason
[01:41] <SteveTheCat> anyone know where i can grab a source of aacplus devel?
[01:58] <dp_> is there a way to tell ffmpeg to create the output with the same name (save the extension) as the input file?
[02:04] <pasteeater> dp_: no, but it can be done easily in bash
[02:08] <dp_> pasteeater: that's what I figured. which means I'm going to have to figure out when rtorrent triggers the move properly
[02:08] <pasteeater> SteveTheCat: here i think: http://tipok.org.ua/node/17
[02:08] <SteveTheCat> thanks pasteeater
[02:09] <pasteeater>
[02:09] <pasteeater> also, -vcodec h264 is the name of the H.264 decoder. the encoder is libx264
[02:30] <SteveTheCat> I'm getting ./ffmpeg: error while loading shared libraries: libavdevice.so.53: cannot open shared object file: No such file or directory
[02:30] <SteveTheCat> but i also compiled libav, how do i get ffmpeg to use my compiled libav instead of the older version i used yum install on?
[02:48] <SteveTheCat> what libav would be compatible with ffmpeg 0.9? 
[02:48] <SteveTheCat> to compile with?
[02:50] <pasteeater> https://ffmpeg.org/trac/ffmpeg/wiki/CentosCompilationGuide
[02:51] <pasteeater> or just trying running "ldconfig" and then "ffmpeg" again
[02:51] <pasteeater> libav and ffmpeg will conflict if you install them in the same places
[02:52] <pasteeater> ffmpeg won't "use" the libav fork.
[02:52] <pasteeater> if that's what you're talking about
[02:52] <SteveTheCat> this is what I get: # ffmpeg ffmpeg: error while loading shared libraries: libswresample.so.0: cannot open shared object file: No such file or directory
[02:52] <pasteeater> did you run ldconfig?
[02:53] <SteveTheCat> but i have libswscale.so.2.1.0
[02:53] <SteveTheCat> yes
[02:53] <SteveTheCat> wrong file
[02:53] <pasteeater> i don't know how you compiled anything, or if you're mixing repo stuff with compiled stuff
[02:53] <SteveTheCat> it seems i really odn't have it
[02:54] <SteveTheCat> i probably am mixing repo stuff with compiled stuff
[02:56] <SteveTheCat> I deleted some of the repo stuff that was conflicting I believe but now I'm getting a different lib problem:    ./ffmpeg: error while loading shared libraries: libpostproc.so.51: cannot open shared object file: No such file or directory
[02:57] <SteveTheCat> is it becaues I didn't ./configure libav properly?
[02:58] <pasteeater> i don't know. might want to ask in #libav if that's what you're using
[02:58] <pasteeater> how did you configure it?
[02:59] <SteveTheCat> like so: ./configure --enable-shared --prefix=/usr/local/customvlc/libav
[03:12] <SteveTheCat> got it all working
[03:12] <SteveTheCat> thanks for the advice pasteeater
[03:13] <pasteeater> SteveTheCat: what did you do?
[03:13] <SteveTheCat> got rid of repos that i made compilations of before, was conflicting with eachother
[03:14] <SteveTheCat> and added the compiled ffmpef lib folder to ld.so.conf
[03:14] <SteveTheCat> echo "/usr/local/customvlc/ffmpeg/lib/" >> /etc/ld.so.conf
[03:19] <SteveTheCat> now i'm getting this error though trying to encode with h264 ./ffmpeg: relocation error: ./ffmpeg: symbol avformat_alloc_output_context2, version LIBAVFORMAT_53 not defined in file libavformat.so.53 with link time reference
[06:15] <lluvia> is there support for splicing ogg videos?
[06:16] <lluvia> files*
[08:23] <Ginks> is there a way to do say "-aspect 4:3 -s *x480"
[08:23] <Ginks> ?
[08:26] <ubitux> -vf scale=-1:480 maybe
[11:49] <swkide> Happy new year and hello! I am trying out the new segmenter feature of the ffmpeg 0.9 - Can anyone help me with the parameters or how to create segments?
[12:40] <hellop> Hello.  Do you think it would be possible to add audio from my microphone to an RTSP stream, then restream the RTSP stream with Audio and Video?
[12:48] <hellop> Another question I've had, how do I determine the name of my microphone for ffmpeg input when I am using a new computer?  For linux I have found: "-f oss -i /dev/dsp"  But, what about Windows?  I have seen commands where it was some long string specific to that computer.  How do I discover the name?   
[13:05] <eightfold> hi. i wonder if ffmpeg manages to join two aac files?
[13:14] <hellop> eightfold: I'm also looking for that answer.  I've found how to add audio to a video stream, or replace the audio in a video stream.
[13:22] <eightfold> hellop: i think that's is where i am right now, too :)
[13:23] <hellop> You could also try mencoder, or mp4box to mux streams together.
[13:23] <eightfold> hellop: let'see if anyone knows. the manual does not seem to be speaking of "join".
[13:26] <hellop> I am able to get info about my camera using: ffmpeg -list_options true -f dshow -i video="Integrated Webcam"
[13:27] <hellop> I did this by looking at capture devices in the VLC GUI.  It shows "Microphone (Realtek High Definition Audio)", but that string doesn't work as an ffmpeg input.  Any suggestions how to capture my mic in windows with ffmpeg?
[13:52] <hellop> Ok, I was able to find my audio device using the VLC GUI by clcking "more options" in the capture screen, my mic is called: "Microphone (Realtek High Defini"  and works in ffmpeg.
[14:04] <hellop> sorta
[15:20] <MrJones> how can I make an AVFormatContext use a custom AVIOContext? I have read a code example that simply sets AVFormatContext->pb and then uses it with avformat_open_input with an empty filename. is that the right way to do it? setting something on a struct directly seemed a bit hackish to me
[17:32] <qubodup> hi
[17:33] <qubodup> I have archlinux,  vorbis installed (1.3.2) and ffmpeg 20111211-1 (ffmpeg version N-35681-g16abd68)
[17:33] <qubodup> running the following line leads to [libvorbis @ 0x7fda84003e00] oggvorbis_encode_init: init_encoder failed
[17:33] <qubodup> ffmpeg -f alsa -i pulse -f x11grab -acodec pcm_s16le -r 30 -s $CAPWIN_DIM -i :0.0+$CAPWIN_XPOS,$CAPWIN_YPOS -vcodec libvpx -vpre libvpx-720p -threads 0 capwin-$DATE.mkv -ab 96k
[17:33] <qubodup> (with $CAPWIN_ variables being correct parameters)
[17:41] <qubodup> if I remove -i pulse, it works, but no sound gets recorded
[17:41] <kollapse> Hi. x264 problem. I get `File for preset 'libx264-fastfirstpass' not found`
[17:42] <qubodup> kollapse: that's because the presets are missing.
[17:42] <kollapse> Yep, how do I get them ?
[17:42] <qubodup> kollapse: I don't know how to make or get compatible ones for recent versions
[17:42] <kollapse> Well then how do I x264 encode :?
[17:43] <qubodup> kollapse: my way is switching to other presets
[17:43] <microchip_> kollapse: are you on a recent ffmpeg?
[17:43] <kollapse> version 0.9
[17:43] <qubodup> kollapse: ls /usr/share/ffmpeg/
[17:43] <qubodup> kollapse: using a different preset might save your day
[17:44] <microchip_> kollapse: use -preset <name_of_x264_preset>
[17:44] <microchip_> kollapse: recent versions of ffmpeg use x264's presets directly
[17:44] <kollapse> Not good. I only have libx264-ipod320.ffpreset and libx264-ipod640.ffpreset
[17:44] <qubodup> same here for libx264
[17:44] <qubodup> libx264-ipod640.ffpreset is not bad
[17:45] <qubodup> kollapse: you could probably edit the file to tweak the values you want (save as new file)
[17:45] <kollapse> I'm not an x264 wizard. I just need the `fastfirstpass` and `hq` presets. No way to get them ?
[17:46] <qubodup> kollapse: there is, but I'm afraid they don't work with the latest version
[17:46] <JEEB> fast first pass is used by default by libx264 in case first pass is specified
[17:46] <JEEB> (and slow-firstpass isn't set)
[17:46] <kollapse> JEEB: and `hq` ?
[17:47] <JEEB> whatever is of similar speed in libx264's internal presets
[17:47] <JEEB> http://mewiki.project357.com/wiki/X264_Settings#preset
[17:47] <JEEB> ^ a listing
[17:48] <JEEB> everything but placebo doesn't set slow-firstpass so if you set first pass as-is you will get "fast first pass" settings
[17:49] <vcs> hi, in the latest ffmpeg I get "unrecognized option 'newvideo'
[17:49] <vcs> anyone know what that was replaced with
[17:50] <JEEB> what did it do to begin with?
[17:50] <vcs> added a new video stream (if the source file had multiple video streams for example, by default only 1 was added)
[17:50] <vcs> so if i used -newvideo twice, 3 streams would be copied from the source
[17:51] <JEEB> oh, nowadays you IIRC have better control on which streams get passed
[17:51] <JEEB> -map was it?
[17:51] <vcs> ill check it out, thanks
[17:52] <relaxed> vcs: I don't think you need -newvideo. Use -map for each stream you want in the output.
[17:53] <JEEB> http://ffmpeg.org/ffmpeg.html#Advanced-options <- first one in this spot is -map
[17:53] <vcs> wow, the syntax makes sense now, thats great.
[17:53] <vcs> thanks guys
[17:53] <JEEB> aye
[17:53] <JEEB> the capability of using libx264's defaults as well as internal presets/tunes, mapping system...
[17:54] <JEEB> I used to be one of those people who wouldn't recommend ffmpeg for encoding because of this, but nowadays my mind has changed somewhat
[17:54] <qubodup> mikobuntu: I don't understand how to set x264's presets in ffmpeg (if possible?)
[17:55] <kollapse> Any way to sharpen using ffmpeg ?
[17:55] <JEEB> qubodup, -preset after -vcodec
[17:55] <JEEB> -vcodec libx264 -preset veryslow for example
[17:55] <qubodup> JEEB: and then the name of the preset, which has to be in /usr/share/ffmpeg/ ?
[17:55] <JEEB> doesn't have to be if you have a new enough ffmpeg/libx264
[17:55] <qubodup> 'x264' has no preset files installed
[17:56] <JEEB> ffmpeg now can use libx264's internal presets :P
[17:56] <JEEB> thus I linked you a listing of them a few dozen lines upwards
[17:56] <qubodup> File for preset 'lossless_ultrafast' not found
[17:56] <JEEB> lossless would be crf 0 with 8bit H.264 with libx264
[17:56] <qubodup> JEEB: yeah, an interesting link, but I don't understand how these exist
[17:56] <JEEB> they exist in the library?
[17:56] <qubodup> I guess internal means in-code/binary
[17:57] <JEEB> they are given out by libx264 as libx264 itself needs a way to set different speed/compression levels easily enough :V
[17:57] <qubodup> oh wait. that one doesn't exist :)
[17:57] <JEEB> for lossless + fast you can use -vcodec libx264 -crf 0 -preset ultrafast ?
[17:57] <qubodup> hm. using "ultrafast" also does not exist
[17:58] <JEEB> are you sure you are applying it in the range of where video settings are?
[17:58] <qubodup> oh
[17:58] <qubodup> -crf 0 helped
[17:58] <qubodup> thanks!
[17:58] <qubodup> oh dog it works!
[17:59] <JEEB> basically libx264 has two ways of setting lossless encoding, either crf 0 (that now works only with 8bit H.264) that keeps users out of the qp setting, and then qp 0 which works with all bit depths
[17:59] <JEEB> I don't know how to set qp encoding with ffmpeg and I think you are using a 8bit H.264 (as 99% of the whole user population), so crf 0 seemed practical
[18:00] <JEEB> also, the presets should work even without crf 0
[18:00] <JEEB> (libx264's internal ones)
[18:00] <JEEB> as they set the defaults
[18:00] <JEEB> you were probably having a PEBKAC
[18:24] <vcs> wow, -map is the greatest thing to ever happen to ffmpeg
[19:53] <SteveTheCat> I seem to be getting this error after I compiled ffmpeg
[19:53] <SteveTheCat> ./ffmpeg: relocation error: ./ffmpeg: symbol avformat_alloc_output_context2, version LIBAVFORMAT_53 not defined in file libavformat.so.53 with link time reference
[20:18] <aca20031> I have a h.264 in an mkv container, and id like to change its container to avi or something that adobe encore will recognize
[20:18] <aca20031> apparently its not as simple as -i in.mkv out.avi ;)
[20:18] <JEEB> you don't want it in avi
[20:18] <JEEB> at least if it contains b-frames
[20:19] <JEEB> -i derp.mkv -vcodec copy -an (or -acodec copy if you want the original audio) out.mp4
[20:19] <SteveTheCat> b-frames?
[20:19] <aca20031> avi wmv or mxf are its suggested formats
[20:20] <JEEB> aca20031, I'd be surprised if it couldn't take in mov or mp4 :P
[20:20] <JEEB> and avi isn't exactly a container that properly supports B-frames
[20:20] <SteveTheCat> move suck imo
[20:20] <aca20031> im just going by the extensions when i select Video File from the dropdown of types
[20:20] <aca20031> the actual problem is, is that i can import the .avi
[20:20] <aca20031> but Encore only sees the audio track
[20:20] <aca20031> not the video track
[20:20] <aca20031> it think its an audio only file lol
[20:20] <SteveTheCat> then it's a problem with the video encoding
[20:20] Action: JEEB sighs
[20:21] <SteveTheCat> did you have problems with importing h264 before?
[20:21] <JEEB> SteveTheCat, as a container it's better than avi tho
[20:21] <aca20031> this is my first time trying
[20:21] <aca20031> it says it supports it though
[20:21] <SteveTheCat> for the program you're importing with?
[20:21] <aca20031> the video is: H264 - MPEG-4 AVC
[20:21] <aca20031> according to VLC
[20:21] <SteveTheCat> what OS you running?
[20:21] <aca20031> windows 7
[20:21] <JEEB> nothing official takes in H.264 in AVI without extra vfw codecs, so no -- that's not how you do it
[20:21] <JEEB> dang it
[20:21] <JEEB> just try mov and mp4 :P
[20:21] <JEEB> in the way I said
[20:22] <aca20031> lol
[20:22] <aca20031> im doing that now
[20:22] Action: JEEB sighs
[20:22] <SteveTheCat> go in command line and type vlc -l > modules.txt
[20:22] <aca20031> just thought id point out the original problem while it transcodes
[20:22] <SteveTheCat> vlc being where your vlc.exe is
[20:22] <aca20031> just in case my assessment was wrong
[20:22] <JEEB> aca20031, it shouldn't transcode >_>
[20:22] <JEEB> -vcodec copy copies the stream
[20:22] <aca20031> oh
[20:22] <aca20031> well that explains why its done
[20:22] <aca20031> let me try it ;)
[20:23] <aca20031> hmm
[20:23] <JEEB> of course personally I would dump the thing into ut video or ffvhuff or something in AVI, of course that'd be pretty huge
[20:23] <aca20031> more than two audio channelsfor this type of encoding is not supported"
[20:23] <JEEB> I don't think I anywhere said for you to re-encode the audio >_>
[20:23] <aca20031> i didnt
[20:23] <JEEB> <JEEB> -i derp.mkv -vcodec copy -an (or -acodec copy if you want the original audio) out.mp4
[20:23] <aca20031> i typed -acodec copy
[20:23] <JEEB> hm
[20:24] <aca20031> D:\Downloads\PE HD\Planet.Earth.S01E02.Mountains.1080p.BluRay.x264-CULTHD>ffmpeg
[20:24] <aca20031>  -i Mountains.mkv -vcodec copy -acodec copy out.mp4
[20:24] <JEEB> probably because the audio in it isn't supported in mp4
[20:24] <aca20031> further suggestion?
[20:24] <JEEB> but test video first >_>
[20:24] <JEEB> with -an
[20:25] <aca20031> video works in vlc
[20:25] <aca20031> actually
[20:25] <JEEB> and that says nothing
[20:26] <aca20031> audio works in vlc too
[20:26] <aca20031> lol
[20:26] <JEEB> and that says nothing
[20:26] <aca20031> how would you like me to test it then
[20:26] <aca20031> it wont import into encore at all so i cant really test there
[20:26] <JEEB> -vcodec copy -an
[20:26] <aca20031> mm 
[20:26] <JEEB> ok
[20:26] <aca20031> oh
[20:26] <JEEB> it doesn't read it?
[20:26] <aca20031> i thought -an was the same as -acodec copy
[20:26] <JEEB> nope
[20:26] <JEEB> that's AudioNone
[20:26] <aca20031> i misread your original statement
[20:26] <aca20031> let me test that
[20:26] <JEEB> also test both mov and mp4
[20:26] <JEEB> and if neither work blame the maker of the app >_>
[20:27] <aca20031> blame adobe? :P
[20:27] <JEEB> yeh
[20:27] <aca20031> its a professional dvd creator, i imagine its as good as i can get
[20:27] <JEEB> not really
[20:27] <JEEB> you'd be surprised
[20:27] <aca20031> im open to suggestions, i just want control enough to make a custom menu and burn more than one videos to one dvd
[20:27] <aca20031> tried Roxio, it doesnt give you much control
[20:27] <SteveTheCat> i don't understand if you're using windows, why not use something specialized for windows?
[20:28] <aca20031> ..such as?
[20:28] <aca20031> i did my googling
[20:28] <JEEB> SteveTheCat, just stay silent for a moment
[20:28] <SteveTheCat> here:
[20:28] <JEEB> thank you
[20:28] <aca20031> version with -an works
[20:28] <JEEB> aca20031, if you want to make a menu it'd mean that you'd be making a normal DVD, thus re-encoding the thing in any case. Am I correct?
[20:29] <JEEB> oh
[20:29] <JEEB> great
[20:29] <aca20031> trying .mov copy then i guess
[20:29] <JEEB> with mov I think you can also decode the audio into raw pcm and mux it there
[20:29] <JEEB> if nothing else works :P
[20:29] <JEEB> as if it is something like DTS there's a rather big chance it won't be read
[20:29] <aca20031> if i have to, the original mkv audio worked in encore and the video didnt
[20:29] <aca20031> lol
[20:30] <aca20031> i can combine them
[20:30] <JEEB> sure
[20:30] <JEEB> that works too
[20:31] <aca20031> hmm
[20:31] <JEEB> also, talking about DVD/BD mastering the last thing I tested was Scenarist, it was pretty good. Didn't do extra transcoding, just let me work with pre-done stuff if I had done things by the DVD/BD spec video and audio-wise.
[20:31] <aca20031> cant import move, "Quicktime and/or the appropriate codec appears not the be installed"
[20:31] <JEEB> Of course, scenarist is nothing I can personally afford >_>
[20:32] <JEEB> lol
[20:32] <aca20031> quicktime is definitely installed :(
[20:32] <aca20031> s/move/mov/
[20:32] <JEEB> funny how they use QT for mov, while parsing mp4 by themselves :P
[20:32] <JEEB> given the fact that the formats are very close
[20:32] <JEEB> anyways, could it be that the editor is now 64bit or something?
[20:33] <JEEB> because QT for Windows is 32bit only
[20:33] <JEEB> (and apps of different bitness on windows can't link against each other etc.)
[20:33] <aca20031> nah encore is 32 bit, only premiere and photoshop in the adobe CS5 is 64 bit
[20:33] <JEEB> k
[20:33] <JEEB> is the audio DTS or something?
[20:33] <JEEB> because that could be only in QT Pro or whatever
[20:34] <JEEB> so it's just easier to decode it with ffmpeg
[20:34] <JEEB> and get out 16bit little endian pcm
[20:34] <aca20031> Codec: A52 Audio (aka AC3) (a52 )
[20:34] <JEEB> oh
[20:34] <aca20031> dunno what that is
[20:34] <JEEB> well that's usually premium as well
[20:34] <JEEB> lol
[20:35] Action: aca20031 facepalms
[20:35] <JEEB> (although less often than with DTS, because the licensing costs DTS wants are lulzy)
[20:35] <JEEB> (never mind that AC3 is actually better than DTS format-wise)
[20:36] <JEEB> so yeah, use whatever way you want to use to load that one in
[20:36] <JEEB> heck, depending on the type of the AC3 track you might be able to put it out on a DVD as-is
[20:36] <JEEB> but not sure if that adobe thingy will let you
[20:36] <SteveTheCat> why am i getting Unknown encoder 'h264' when I compiled with --enable-libx264 .....
[20:36] <aca20031> still need encore to not refuse to import it, so i can make the dvd menu
[20:36] <JEEB> SteveTheCat, h264 is the decoder, libx264 is libx264
[20:37] <JEEB> aca20031, just decode to lpcm 16bit little endian?
[20:37] <JEEB> switch -acodec to it
[20:37] <aca20031> yep yep
[20:37] <JEEB> also, ac3 in mp4 is "new" (although was specified a few year(s) ago already, so I'm not surprised if something couldn't read it)
[20:38] <SteveTheCat> ohhh
[20:38] <SteveTheCat> i see JEEB
[20:38] <SteveTheCat> Thanks
[20:39] <aca20031> avi freezes encore, time to transcode the audio
[20:39] Action: aca20031 slaps adobe
[20:39] <SteveTheCat> I think I went through the trouble of compiling ffmpeg without reading the codecs lol
[20:40] <JEEB> well, external libraries more often or not do have the notation of lib<something> ;)
[20:40] <JEEB> so it should be rather understandable to try that first :)
[20:40] <JEEB> but great if you got it to work
[20:40] <JEEB> aca20031, for avi I bet it tries to use vfw
[20:40] <JEEB> you do not want that
[20:40] <SteveTheCat> I'm getting Error while opening encoder for output stream #0:1 - maybe incorrect parameters such as bit_rate, rate, width or height    for    Stream #0:1 -> #0:1 (aac -> libvorbis)
[20:40] <aca20031> just wanted to give it a try and see what it looked like
[20:40] <aca20031> freezing is bad though
[20:40] <JEEB> b-frames + avi + vfw = not a good combo
[20:40] <SteveTheCat> when i'm not even transcoding the audio
[20:41] <JEEB> SteveTheCat, you seemingly are
[20:41] <JEEB> -acodec copy for audio copy
[20:41] <SteveTheCat> oh, assumed it was on by default
[20:41] <JEEB> nope
[20:42] <SteveTheCat> on second thought, i only saw the h264 before compiling
[20:42] <SteveTheCat> i don't think i saw lib264
[20:42] <aca20031> whats the -acodec for lpcm 16 bit LE?
[20:42] <SteveTheCat> not sure what is the l before pcm means
[20:42] <aca20031> pcm_s16le?
[20:43] <JEEB> yeah
[20:43] <JEEB> that should be it
[20:43] <SteveTheCat> did you get my query aca20031?
[20:43] <aca20031> yes steve, but my problem isnt a lack of a good converter
[20:43] <SteveTheCat> alright
[20:43] <aca20031> thank you though
[20:43] <JEEB> SteveTheCat, http://wiki.multimedia.cx/index.php?title=PCM#Linear_PCM
[20:44] <JEEB> the default type of PCM I guess as it has nothing written in the area >_>
[20:45] <aca20031> ffs
[20:45] <aca20031> audio track is freaking empty
[20:45] <JEEB> <(^o^)
[20:45] <SteveTheCat> did you use -an?
[20:46] <SteveTheCat> just checking? :P
[20:46] <aca20031> even in vlc :/
[20:46] <SteveTheCat> finding the right codec is where the fun is
[20:46] <aca20031> D:\Downloads\PE HD\Planet.Earth.S01E02.Mountains.1080p.BluRay.x264-CULTHD>ffmpeg
[20:46] <aca20031>  -i Mountains.mkv -vcodec copy -acodec pcm_s16le out.mp4
[20:46] <aca20031> track 1: could not find tag, codec not currently supported in container
[20:47] <JEEB> oh
[20:47] <JEEB> derp
[20:47] <JEEB> mp4 doesn't officially support LPCM
[20:47] <JEEB> you'll have to output it to a separate wav or something
[20:47] <JEEB> ffmpeg -i input.derp -vn -acodec pcm_s16le derp.wav
[20:47] <JEEB> this should do
[20:48] <aca20031> phew what a pain
[20:48] <aca20031> lol
[20:48] <SteveTheCat> can't you use a different audio encoding
[20:48] <aca20031> gotta do this with 10 other ones too
[20:48] <SteveTheCat> like mp3?
[20:48] <JEEB> SteveTheCat, lossy -> lossy?
[20:48] <JEEB> U MAD?
[20:49] <SteveTheCat> :(
[20:49] <SteveTheCat> i dunno
[20:49] <SteveTheCat> wait
[20:49] <JEEB> of course he will most probably be encoding it to lossy afterwards for the DVD
[20:49] <JEEB> but that'd be just lossy->lossless->lossy
[20:49] <aca20031> yeah exactly
[20:49] <aca20031> lol
[20:49] <JEEB> in your case it'd be lossy->lossy->lossy
[20:49] <JEEB> 3x lossy encoding, ho
[20:51] <aca20031> sigh
[20:51] <aca20031> more than two audio channels not supported for this type of encoding :(
[20:51] <JEEB> yeah, generally
[20:51] <JEEB> I think if it was 5.1 AC3 I'd prolly just extract it out once
[20:52] <JEEB> and then mux it when doing the final mux for the DVD
[20:52] <JEEB> but I don't know if Adobe wants you to have such luxury
[20:52] <SteveTheCat> wish me luck
[20:52] <SteveTheCat> about to test if i can finally stream a converted video
[20:52] <JEEB> if it's flv it should work, if it's mp4 you'd have to put the index part into the beginning
[20:53] <JEEB> mpeg-ts should work as-is as well
[20:54] <aca20031> so not worth this much bullshit
[20:54] <JEEB> welcome to the world of "easy solutions"
[20:55] <JEEB> oh
[20:55] Action: JEEB wonders if that pcm in avi would work
[20:55] <aca20031> media encoding and the web
[20:55] <aca20031> 2 things that need to be wiped out
[20:55] <JEEB> lol
[20:55] <aca20031> and done again in one universal format
[20:55] <JEEB> Never gonna happen because technology keeps leaping forward
[20:55] <JEEB> not to mention that video-wise we pretty much are already set
[20:56] <JEEB> what's limiting you is adobe, nothing else atm
[20:56] <JEEB> no idea how it wants possible 5.1 audio
[20:57] <JEEB> and what I was listing were different containers that SteveTheCat might be using -- some of them don't need anything special, other types like mp4 (and mov) need some special care
[20:57] <JEEB> although there's a feature in mp4 that makes such unneeded
[20:59] <aca20031> wish it would use vlc player to decode it :P
[20:59] <aca20031> it never has these issues
[21:05] <aca20031> meh, its being burned for my mother on a 27 inch stereo tv
[21:05] Action: aca20031 goes lossless
[21:05] <aca20031> lossy*
[22:14] <Bizzeh> hi. im trying to build ffmpeg with mingw32 (4.2.1-sjlj), and i keep getting LOADS of "error: no previous prototype for..." errors
[22:14] <Bizzeh> anyone any idea how i would fix this?
[22:46] <Moral_> Good afternoon. I am trying to convert a file from mp4/flv to ust mp3. I use ffmpeg -i videofile output.mp3, however no matter what the bitrate of the audio in the video file, the mp3 is 128kb/s even if the audio bitrate is higher in the video file. I want the audio bitrate of the mp3 to match that of the video file. Any options?
[22:47] <Bizzeh> also, is it a known bug that you cannot downsample 5.1 to stereo using the new build in aac encoder
[23:03] <SteveTheCat> I seem to be getting 'FF_MM_MMX' undeclared (first use in this function) while compiling VLC but from /usr/local/customvlc/ffmpeg/include/libavcodec/avcodec.h:3986
[23:10] <pasteeater> Moral_: if the input is flv the audio is probably already mp3
[23:10] <Moral_> True, but for .mp4 it's not.
[23:10] <pasteeater> use a pastebin site to show your ffmpeg command and the complete console output
[23:11] <Moral_> one moment. Please.
[23:16] <Moral_> http://pastebin.com/NkDsw47V
[23:18] <Moral_> That may not be a good example, a previous video was telling me it was 152kb/s orig, and output was 128
[23:19] <Moral_> http://pastebin.com/LkDu1vG8
[23:19] <Moral_> there's what I was talking about earlier.
[23:24] <Bizzeh> is there a build bug in ffmpeg at the minute?
[23:24] <Bizzeh> even a basic build is giving me 100's of linking errors. loads of _ff_* undefined
[23:28] <pasteeater> Moral_: if you do not declare a bitrate for the output ffmpeg will choose 128k by default.
[23:30] <Moral_> pasteeater, is there a way to tell ffmpeg to use the audio bitrate of the original file?
[23:30] <pasteeater> not with any ffmpeg option other than '-b:a', such as '-b:a 192k'
[23:31] <pasteeater> so no, unless you use a script or something
[23:31] <pasteeater> why do you want to match the bitrate?
[23:32] <pasteeater> why not just use a constant quality option? 
[23:32] <pasteeater> ffmpeg -i input -c:a libmp3lame -q:a 4 output.mp3
[23:33] <pasteeater> which is about the same as using 'lame -V4' which will give VBR audio instead of CBR or ABR
[23:33] <Moral_> I just wanted the best quality for each video
[23:34] <pasteeater> if you must re-encode, and want "best quality", then use -q:a instead of -b:a
[23:36] <pasteeater> with -b:a the output quality will be ambiguous, but with -q:a you will always have a consistent quality shared between your videos
[23:36] <pasteeater> i mean audio files, not videos
[00:00] --- Wed Jan  4 2012

More information about the Ffmpeg-devel-irc mailing list