[Ffmpeg-devel-irc] ffmpeg.log.20160210

burek burek021 at gmail.com
Thu Feb 11 02:05:01 CET 2016

[00:00:25 CET] <relaxed> lee: great, so it worked? If so, I'm going to add a blurb to the ffmpeg vp8 wiki.
[00:00:48 CET] <lee> yep, it worked great
[00:04:00 CET] <J_Darnley> Ha.  What a stupid format.
[00:11:16 CET] <explodes_> Hello! - After an av_seek_frame, I'll still (sometimes) av_read_frame(..) a video frame at the previous position instead of only getting frames from the new positio
[00:19:49 CET] <kadiro> hello, can i convert an encrypted (drm) wmv to any other format ?
[00:23:21 CET] <kadiro> I mean, Is it possible
[00:41:03 CET] <FilipeMaia> Does anyone know of a good cmake FindFFMPEG module?
[01:10:47 CET] <mzbotr> Hi, I'm trying to recode some video streams to fit a display aspect ratio of 16:9 for DVD playback without stretchiness... when I'm doing this, I'm getting errors saying the data is not aligned. Is this worth troubling myself over?
[01:10:55 CET] <mzbotr> [swscaler @ 0xe9fc80] Warning: data is not aligned! This can lead to a speedloss
[01:12:28 CET] <J_Darnley> I should submit a message to silence that warning
[01:12:48 CET] <J_Darnley> uha patch
[01:12:56 CET] <mzbotr> ain't nothing?
[01:15:27 CET] <J_Darnley> It just means assembly can't use movdqa but rather movdqu
[01:15:56 CET] <J_Darnley> Unaligned moves aren't that slow (anymore) and metters less today with copious cpu poer.
[01:16:00 CET] <J_Darnley> *power
[01:29:24 CET] <dugz> Hello everybody! I have some hundreds of random video files, and I want to transcode them into a Roku-friendly format for streaming over minidlna. Any thoughts on what my target format should be?
[01:29:51 CET] <dugz> I'm planning on using find and ffmpeg to do the conversion
[01:30:02 CET] <ThomQ> Hi all. I´m trying to render a transparent WebM video, from a series of transparent.png´s. The video I´m getting does not contain any transparency, nor does it play well in certain players (while other transparent .webm videos I downloaded do work in those players)
[01:30:16 CET] <kadiro> just googled about "Tunebite" can remove drm, wonder if i can do same with ffmpeg like -c:v copy -c:a copy ?
[01:30:42 CET] <ThomQ> Im using ffmpeg -f image2 -i wow%3d.png -vf fps output.webm as a command. As a n00bie to FFMPEG I think I might have missed something. Anyone any idea?
[01:32:08 CET] <ThomQ> I would like to add that Im not bound to WebM, the transparency is the most important part
[01:33:24 CET] <furq> is it transparent video day today
[01:33:56 CET] <furq> 21:21:23 ( relaxed) lee: try, -pix_fmt yuva420p -metadata:s:v:0  alpha_mode="1"
[01:33:58 CET] <furq> ThomQ: ^
[01:34:53 CET] <ThomQ> Is transparent video all the hype? ;)
[01:34:58 CET] <ThomQ> Thanks, trying it now.
[01:35:05 CET] <furq> this is the second time someone's asked this exact question today
[01:35:10 CET] <furq> and also the second time i've seen it asked ever
[01:38:13 CET] <furq> dugz: from a brief google, the only worthwhile video codec the roku supports is h264
[01:38:27 CET] <furq> so x264+aac i guess
[01:38:38 CET] <furq> in mkv
[01:38:41 CET] <dugz> furq, I saw that too, but mine seems to choke on matroska files
[01:38:51 CET] <ThomQ> ffmpeg -f image2 -i wow%3d.png -vf fps output.webm -pix_fmt yuva420p -metadata:s:v:0  alpha_mode="1" doesnt seem to work for me
[01:39:00 CET] <furq> ThomQ: where are you playing the video
[01:39:13 CET] <ThomQ> its not transparent and just black in one player
[01:39:15 CET] <furq> afaik it needs to be in a video tag with background: transparent;
[01:39:28 CET] <furq> if you just load the video up in chrome it'll have a coloured background
[01:39:31 CET] <ThomQ> Furq: Chrome among other things
[01:39:56 CET] <furq> also afaik it'll only work in chrome, it doesn't work in firefox
[01:40:02 CET] <furq> and i doubt it works in safari or IE
[01:40:12 CET] <ThomQ> im loading it on a simple php page that does load another webm video correctly
[01:40:23 CET] <ThomQ> the rendered one still has the black background though
[01:40:51 CET] <ThomQ> yeah it only works in Chrome / Chromium and other forks
[01:41:28 CET] <furq> oh
[01:41:34 CET] <furq> you need to specify those options before the output filename
[01:44:22 CET] <ThomQ> ffmpeg -f image2 -i wow%3d.png -vf fps -pix_fmt yuva420p -metadata:s:v:0  alpha_mode="1" output.webm gets the same results. It is playing in all players im using though
[01:44:34 CET] <ThomQ> PNGs are confirmed transparent btw :D
[01:45:09 CET] <furq> pastebin the ffmpeg command and full output
[01:45:13 CET] <furq> maybe someone will know better than i do
[01:47:27 CET] <ThomQ> okok
[01:47:28 CET] <ThomQ> http://pastebin.com/HDTM3yKv
[01:47:31 CET] <lee> ThomQ: the exact line that I used (which worked for me): ffmpeg -i zt%04d.png -c:v libvpx -pix_fmt yuva420p -metadata:s:v:0 alpha_mode="1" -b:v 1000k output.webm
[01:48:00 CET] <furq> oh weird, it's using vp9
[01:48:06 CET] <furq> `-c:v libvpx` should fix it then
[01:48:11 CET] <furq> i thought vp8 was still the default for webm
[01:48:29 CET] <kadiro> hola hello allo
[01:48:40 CET] <ThomQ> Thanks Lee! Testing it now
[01:48:52 CET] <ThomQ> Furq, where do i put that? Also in front of the output name?
[01:48:57 CET] <furq> yeah
[01:49:07 CET] <ThomQ> Trying them both :)
[01:49:13 CET] <furq> also you will want to specify a bitrate (-b:v) because the default is 200kbps, which is probably less than you want for 720p
[01:49:18 CET] <lee> ThomQ: -b:v 1000k <-- target bitrate, adjust as necessary
[01:49:26 CET] <furq> -b:v 0 -crf 30 is probably better
[01:50:22 CET] <furq> or whatever the equivalent of x264 crf 21 is (the best crf)
[01:51:21 CET] <relaxed> ThomQ: https://trac.ffmpeg.org/wiki/Encode/VP8
[01:51:47 CET] <ThomQ> Ahh k thanks guys. Yeah i was planning on fiddling with the bitrate and adding audio as soon as I had the base. Im too n00b for crf though
[01:53:25 CET] <furq> crf is easier than specifying a bitrate
[01:53:58 CET] <lee> furq: thanks, I'll try that next time (having read relaxed's explanation of it on the wiki page)
[01:54:14 CET] <ThomQ> furq: Thanks, it worked!
[01:54:18 CET] <furq> i think low 30s are roughly analogous to low 20s in x264 but don't take my word for it
[01:54:43 CET] <ThomQ> i compared it to lee´s command and fixed my typo
[01:55:01 CET] <furq> yeah alpha isn't supported in vp9 yet for some reason
[01:55:15 CET] <ThomQ> Trying CRF now, it did look a lot worse then what i rendered before
[01:55:33 CET] <ThomQ> -b:v 0 -crf 30 instead of -b:v?
[01:55:44 CET] <DeHackEd> that's vp or h264?
[01:55:46 CET] <ThomQ> -c:v i mean
[01:55:48 CET] <furq> vp8
[01:56:00 CET] <furq> -b:v 0 -crf 30 is correct
[01:56:04 CET] <furq> lower crf values are higher quality
[01:56:07 CET] <ThomQ> and thanks Relaxed, that page helps alot
[01:56:41 CET] <furq> also you still need -c:v libvpx in case that wasn't clear
[01:57:01 CET] <relaxed> I only added the alpha section to the wiki page, fyi
[01:57:09 CET] <ThomQ> it wasnt, but it was already erroring
[01:57:17 CET] <ThomQ> added it now :)
[01:59:00 CET] <ThomQ> yeah it looks great furq, thanks
[01:59:29 CET] <xbloodhound> one day my head is just gonna pop with all these video encoding stuff
[02:00:07 CET] <lee> it's not just encoding, it's all the cool shit you can do with ffmpeg
[02:00:21 CET] <xbloodhound> yea
[02:00:49 CET] <lee> I could do with a matrix-style "woah! I know ffmpeg" moment though, to just know what options to use (or even what they all are, then work on when to apply them)
[02:04:57 CET] <ThomQ> another question: if I add audio (-i wow.wav) it seems to be a little out of sync (audio is about half a second too early)
[02:05:25 CET] <ThomQ> Im thinking it probably has something to do with framerate, that would be logical, right?|
[02:05:46 CET] <ThomQ> the source is 29.97fps, but i havent declared that anywhere in the command line for FFMPEG
[02:06:03 CET] <kadiro> hello, can i convert an encrypted (drm) wmv to any other format or copy just video/audio stream ?
[02:07:49 CET] <furq> ThomQ: if it's consistently half a second out then it's nothing to do with framerate
[02:08:01 CET] <ThomQ> its too short too really tell furq
[02:08:19 CET] <furq> `-af adelay=500` or something
[02:08:44 CET] <ThomQ> does -crf 30 set the frame rate btw?
[02:08:47 CET] <furq> no
[02:08:58 CET] <xbloodhound> hell no
[02:09:02 CET] <furq> for the image demuxer you'd set -framerate 30 before the input file
[02:09:08 CET] <kadiro> furq,  can you help?
[02:09:11 CET] <ThomQ> ahh k, so I added -r 30, which should theoraticly rule out delay due to difference in fps
[02:09:22 CET] <ThomQ> Ahh k, thanks furq
[02:10:14 CET] <ThomQ> Aaand it fixed it, it´s perfect now
[02:10:21 CET] <ThomQ> thank you guys so much, Furq you in particular
[02:10:47 CET] <furq> it beats working
[02:11:16 CET] <dugz> i'm trying to use winff with ffmpeg, but i can't seem to find a preset for 16:9 480p. am I just being retarded?
[02:13:10 CET] <kadiro> personne ?
[02:14:09 CET] <kadiro> can i resume that ffmpeg can't do that?
[02:15:36 CET] <kadiro> furq,  did you hear me? see me, me vois ??
[02:16:17 CET] <kadiro> !test
[02:16:58 CET] <relaxed> kadiro: ffmpeg won't work with encrypted files
[02:17:17 CET] <kadiro> relaxed,  thank you man you saved my time
[02:17:59 CET] <kadiro> relaxed,  any open source can you suggess to do that?
[02:19:04 CET] <relaxed> I don't know of any
[02:19:14 CET] <kadiro> ok thank you
[02:22:36 CET] <xbloodhound> can anyone tell me whats difference between -crf and -qp?
[02:22:57 CET] <xbloodhound> or rather what used more for
[02:25:11 CET] <furq> xbloodhound: http://slhck.info/articles/crf
[03:18:03 CET] <pingpong1109> So I am trying to stream to a livestreaming service. This is the command I am doing and the output http://pasteben.benbaptist.com/?id=2270181225612
[03:18:35 CET] <pingpong1109> Also I would like to be able to stream the video to two destinations
[03:20:04 CET] <furq> [flv @ 0x24e6c30] Video codec rawvideo not compatible with flv
[03:20:12 CET] <furq> there's a hint for you
[03:20:40 CET] <pingpong1109> I see that but can't find a solution. Unless I am missing something
[03:21:09 CET] <furq> you're doing -vcodec copy with /dev/video0
[03:21:18 CET] <furq> you need to reencode it to a format that is compatible with flv
[03:21:24 CET] <furq> such as -c:v libx264
[03:21:44 CET] <furq> (vcodec is deprecated, use c:v)
[03:22:02 CET] <pingpong1109> Ah ok I think it worked. Let me verify
[03:23:26 CET] <pingpong1109> All it is doing is buffering
[03:25:00 CET] <pingpong1109> Yeah it crashed, I think a pi 2 isn't pwoerful enough to do this
[03:26:08 CET] <furq> the pi 2 has a builtin h264 encoder but you can't use it from ffmpeg
[03:26:20 CET] <furq> i believe gstreamer can use it
[03:26:43 CET] <furq> you could maybe try -c:v libx264 -preset ultrafast
[03:27:38 CET] <pingpong1109> .5 FPS ftw
[03:28:27 CET] <pingpong1109> No that didnt work
[03:28:55 CET] <furq> you should get more than .5 fps at 480p
[03:29:19 CET] <pingpong1109> How do I define a resolution?
[03:29:27 CET] <furq> it's already using 480p
[03:29:47 CET] <furq> if you want something smaller then -vf scale=320:240
[03:29:52 CET] <pingpong1109> https://gyazo.com/a1692a360020a94090d4b5b456d16015
[03:30:35 CET] <relaxed> pingpong1109: -c:v flv1 might be faster
[03:31:37 CET] <furq> i suspect something else is wrong
[03:31:54 CET] <pingpong1109> http://pasteben.benbaptist.com/?id=3971927114762
[03:31:58 CET] <pingpong1109> Yeah it didn't work
[03:32:15 CET] <pingpong1109> Guess this site doesnt like that
[03:33:01 CET] <relaxed> don't cherry pick errors, pastebin the command and all output
[03:33:26 CET] <furq> is that command actually fully loading the cpu
[03:34:08 CET] <pingpong1109> http://pasteben.benbaptist.com/?id=6144378073513
[03:34:44 CET] <furq> "./stream.sh" isn't a command line which is useful to us
[03:34:52 CET] <furq> Codec AVOption preset (Set the encoding preset (cf. x264 --fullhelp)) specified for output file #0 (rtmp://ingest.wdc01.beam.pro:1935/beam/) has not been used for any stream. The most likely reason is either wrong type (e.g. a video option with no video streams) or that it is a private option of some encoder which was not actually used for any stream.
[03:35:06 CET] <pingpong1109> working on copying the actual command
[03:35:23 CET] <pingpong1109> ffmpeg -i /dev/video0 -c:v libx264 -preset ultrafast -an -r 10 -f flv -metadata streamName=player1 rtmp://ingest.wdc01.beam.pro:1935/beam/
[03:35:49 CET] <relaxed> that's not the command you used
[03:35:49 CET] <pingpong1109> ffmpeg is only using 5%ish
[03:36:35 CET] <pingpong1109> ffmpeg -i /dev/video0 -c:v flv1 -preset ultrafast -an -r 10 -f flv -metadata streamName=player1 rtmp://ingest.wdc01.beam.pro:1935/beam/
[03:37:02 CET] <relaxed> ok, now omit -preset ultrafast (which is a libx264 option)
[03:37:09 CET] <furq> if i had to guess i'd say there's a problem with your webcam or whatever you're using
[03:38:22 CET] <pingpong1109> I am using an old webcam but it works in other computers, I can just use an old laptop since this isn't working
[11:49:59 CET] <maziar> i have a problem in concept , i want to create a web site like youtube, and i configure nginx with rtmp and mp4 and pseudo-streaming as my web server, but for converting i don't know how should i do? should i use ffserver ? is ffserver good for me for serving 240, 780 and 1080 quality ?
[12:23:13 CET] <xbloodhound> I am getting Hardware accelerated decoding with frame threading is not supported when I try it am I missing something or it just won't do it with what I have setup?
[12:27:42 CET] <durandal_1707> xbloodhound: hw acceleartion doesn't make sense with multithreading
[12:32:04 CET] <xbloodhound> guess I can't take load off CPU then
[12:38:01 CET] <Filarius> hello, is here demuxer in FFMPEG what will allow me to make easy muxing in my application and send fo FFMPEG video and audio in single annon pipe ?
[12:38:45 CET] <Filarius> like, packet = video-frame, audio-frame
[12:38:59 CET] <jkqxz> xbloodhound:  What are you actually trying to do?  Hardware accelerated decoding (necessarily with no threading) may still be faster than fully-threaded software decoding using all of the CPU.
[12:39:33 CET] <Filarius> I want to develop application what will send raw video and mp3(or raw) sound to ffmpeg for encoding
[12:40:20 CET] <Filarius> but with annon pipe I can send only one - or video or audio, and I need to send both at realtime
[12:41:06 CET] <Filarius> I'm curious if it is possible with single pipe, to not use 2 names pipes
[12:41:12 CET] <Filarius> *named pipes
[12:41:42 CET] <votz> Filarius: ffmpeg only has one stdin
[12:42:18 CET] <jkqxz> Filarius:  You will need to pack it into some container.  Most of the supported ones are pipe-friendly.
[12:43:07 CET] <Filarius> yep, stdin, thats what i'm talking about, just i'm not sure in words so I name it "annon pipe"
[12:43:32 CET] <votz> Filarius: if you can't touch the filesyste, you could always use the network. ffmpeg -i http://localhost:8080 -i http://localhost:8081
[12:43:46 CET] <Filarius> i'm not sure if here friendly packing modules, need to search for one
[12:44:11 CET] <Filarius> yeh, I had this idea too
[12:44:37 CET] <Filarius> its will be my "back door"
[12:44:49 CET] <Filarius> if i will not find way with pipe
[12:45:57 CET] <durandal_1707> you could use multiple pipes
[12:47:26 CET] <votz> durandal_1707: if I understand Filarius correctly, he doesn't want to use multiple pipes: I'm curious if it is possible with single pipe, to not use 2 names pipes
[12:47:50 CET] <xbloodhound> jkqxz: I was converting video here is gist of what I am using "ffmpeg -hwaccel dxva2 -i INPUT -c:v h264 -c:a aac OUTPUT" I was hoping to be able to convert in same way some of my recording software using GUI to convert video files but I guess with what you told me its just not possible with ffmpeg
[13:26:41 CET] <Ccdc_DuckZ> hello, I'm having a segfault in avcodec_encode_video2(), this is the code I have http://pastebin.com/TijqCnJy
[13:27:19 CET] <Ccdc_DuckZ> I'm not sure I initialized all I had to, I wrote that following the sample code in the docs
[13:27:35 CET] <Ccdc_DuckZ> or maybe I'm passing in the wrong thing? any clue?
[14:41:33 CET] <FilipeMaia> Hi. Im trying to compress some frames to h264. Im using -qp 0 and -preset medium for lossless encoding. Whenever I encode less than 100 frames the compression is much worse than when I encode 100 or more. There is a discontiniuty at 100. Any idea why?
[14:42:43 CET] <furq> FilipeMaia: does the same thing happen with other source videos
[14:43:56 CET] <FilipeMaia> With the videos I have available, yes
[14:44:50 CET] <FilipeMaia> It looks like internally something changes when I encode more than 99 frames
[14:46:57 CET] <FilipeMaia> Ok Ill continue to dig, around. I might be messing up something else
[15:21:16 CET] <J_Darnley> FilipeMaia: are you saying that 101 frames makes a smaller video than 100 frames?
[15:21:40 CET] <J_Darnley> I might understand compression improving from the Nth frame depending on lookahead and frame threads
[15:21:40 CET] <FilipeMaia> J_Darnley: yes, but theres probably a bug somewhere in my code
[15:22:03 CET] <J_Darnley> Oh, you mean I can't checkwith ffmpeg?
[15:22:26 CET] <J_Darnley> I will try anyway
[15:22:37 CET] <FilipeMaia> Im having problems reproducing it myself now
[15:22:49 CET] <FilipeMaia> Now I always get the larger sizes
[15:23:58 CET] <FilipeMaia> Does anyone know if av_image_alloc zeros the allocated memory?
[15:26:51 CET] <J_Darnley> Heh.  I guess "read the source" is the answer
[15:27:07 CET] <FilipeMaia> I guess so
[15:27:16 CET] <FilipeMaia> Looks like it doesnt. That could explain it
[15:28:22 CET] <Bluez_> hi guys
[15:28:57 CET] <Bluez_> im using libav apis to put raw AAC into a container, but the sound is choppy, any ideas what it might be?  Ive checked my timestamps and they seem ok
[15:29:18 CET] <J_Darnley> No encoding?
[15:29:45 CET] <J_Darnley> Does AAC need one of the bitstream filters?
[15:32:10 CET] <Bluez_> oh maybe it does duh!
[15:33:04 CET] <FilipeMaia> J_Darnley: my problem was uninitialized Cb and Cr
[15:42:15 CET] <J_Darnley> Ah "random noise" is hard to compress
[20:24:03 CET] <furkan> is there any way that i can debug why i get this behaviour when streaming high bit-rate h264 over a LAN? https://www.dropbox.com/s/8s6m1ssi1wowbky/IMAG0096.jpg?dl=0
[20:24:13 CET] <furkan> it only happens over UDP, not TCP
[20:40:48 CET] <TD-Linux> furkan, that's just packet loss and ffmpeg's plain UDP has no way to fix it
[20:43:45 CET] <furkan> TD-Linux: but there's no packet loss on the network, it's on a LAN
[20:43:57 CET] <furkan> i've tried iperf
[20:44:24 CET] <TD-Linux> furkan, how do you know there's no packet loss?
[20:44:35 CET] <furkan> because i've tested with iperf
[20:45:23 CET] <TD-Linux> and it's always 0% packet loss at the rates you are using with h264?
[20:45:24 CET] <furkan> i can run other tests if necessary, but based on iperf the packets arrive in correct order
[20:46:08 CET] <furkan> is there any way to tell if there are re-transmissions when using TCP?
[20:46:34 CET] <explodes> Anyone familiar with the lib? I'm still having problems seeking to the position I specify. I want to av_seek_frame to AVSEEK_FLAG_BACKWARD and then read ahead until I'm at the frame I need to be: http://pastebin.com/TyX2kEBt
[20:46:54 CET] <TD-Linux> I believe wireshark can tell you, but I've never done it personally
[20:48:45 CET] <furkan> ok so i just ran another test
[20:49:11 CET] <furkan> sent 28987 datagrams (40.6MB), 0% packet loss, 1 datagram received out of order
[20:49:26 CET] <furkan> 34.1Mbit/sec
[20:50:16 CET] <furkan> same results at 80Mbps
[20:50:39 CET] <furkan> 57476 datagrams, 80.6MB total, 1 datagram received out of order
[20:54:09 CET] <jkqxz> Are packets being thrown away on the sender because your instantaneous spikes of packets (per-frame?) are larger than the UDP buffering on your system?
[20:56:07 CET] <furkan> jkqxz: i did find some discussion about that online so i tried increasing the kernel's UDP buffer size but that didn't help
[20:56:26 CET] <furkan> i'm trying to find out if i can increase any of ffmpeg's buffers
[20:58:49 CET] <explodes> After I read a video frame do I *have* to call "avcodec_decode_video2" every time to avoid a future avcodec_decode_video2 call to receive busted images?
[21:01:02 CET] <kepstin> for modern video codecs, predicted frames rely on having the decoded versions of previous frames available
[21:01:44 CET] <jkqxz> furkan:  Similarly the receive buffer on the receive side, then?
[21:02:22 CET] <furkan> jkqxz: actually yeah it's the receive side i'm looking at, the sending side is an IP camera
[21:03:22 CET] <kepstin> explodes: so for the seeking case, you have to seek to a keyframe (intra-frame), then decode frames and discard the result until you're at the frame you want.
[21:04:05 CET] <explodes> nice, that's a solid plan. Do I "decode frames and discard" by putting "av_read_frame" in a while loop?
[21:04:09 CET] <explodes> or is it some other function?
[21:04:25 CET] <jkqxz> And you are definitely getting all of the packets on the receive-side?  (That is, something else can receive the UDP stream and decode it completely, so the camera send isn't the problem.)
[21:06:56 CET] <furkan> jkqxz: could i figure that out with tcpdump?
[21:07:25 CET] <kepstin> explodes: interestingly, the ffmpeg command-line tool does it by inserting a trim filter
[21:08:59 CET] <explodes> kepstin: hmmm strange
[21:09:04 CET] <explodes> or maybe not strange
[21:09:59 CET] <jkqxz> What is the UDP format?  If it's RTP, for example, they have sequence numbers in and you can easily tell whether some are missing.
[21:10:02 CET] <explodes> what do you call it when video frames aren't "fully" rendered, glitching?
[21:10:47 CET] <FastJack_> hi
[21:12:13 CET] <kepstin> explodes: I guess so. there's certainly people who do that on purpose to create "glitch art" :)
[21:12:49 CET] <DHE> "bad" frames?
[21:12:51 CET] <explodes> this works flawlessly for advancing the video, except that the video frame are glitched until the next keyframe: http://pastebin.com/ZyJW5MJU
[21:12:59 CET] <explodes> DHE let me record a video for yaaa
[21:13:16 CET] <furkan> jkqxz: it's RTSP, but i could do RTP as well, if i can capture the data with tcpdump and inspect it that way it would be ideal
[21:13:19 CET] <DHE> oh I know what it looks like. I've made bad seek indexes in the past for fun
[21:13:22 CET] <explodes> oh wait nvm, I think you know what I'm talking about
[21:13:25 CET] <explodes> hehe
[21:13:28 CET] <furkan> or actually i suppose i could always import the dump into wireshark on my PC
[21:13:37 CET] <kepstin> explodes: yeah, that's the normal behaviour if you start decoding at a frame that's not a keyframe. You get fun motion prediction artifacts :)
[21:14:00 CET] <explodes> kepstin: well first I av_seek_frame(...., AVSEEK_FLAG_BACKWARD) then advance forward :(
[21:14:20 CET] <explodes> it theoretically shouldn't be full of glitches like at all
[21:14:37 CET] <jkqxz> furkan:  I don't think tcpdump can show the right information without difficulty, but importing it into wireshark would definitely be able to show it.
[21:15:40 CET] <furkan> jkqxz: great thanks for the tip, i'll collect some data next time and hopefully it sheds some light on what's going on
[21:16:20 CET] <kepstin> explodes: it doesn't look like you're actually decoding all the frames?
[21:16:58 CET] <kepstin> reading the packets isn't sufficient, you actually have to run them through the decoder before discarding them.
[21:17:03 CET] <explodes> oh shit- do i have to call avcoded_decode_video2 and avcoded_decode_audio4 ?
[21:17:08 CET] <explodes> gotcha
[21:18:16 CET] <kepstin> you also might have to account for out-of-order frames (dts != pts)
[21:18:34 CET] <kepstin> I think you should be checking the pts on the frames after decoding, since I think the decoder will reorder them?
[21:19:35 CET] <explodes> ok
[21:36:06 CET] <explodes> Here it is, completed. http://pastebin.com/ydk0cPAH I'm using packet.dts because the frame's PTS was coming back unset, i'd be using pkt_pts/pkt_dts anyways
[21:37:32 CET] <explodes> Thanks for the help! I've been working on this for a while now
[21:59:53 CET] <effractur> hi
[22:00:11 CET] <effractur> i am trying to use the libdc1394
[22:00:17 CET] <effractur> to connect to a firewire camera
[22:00:22 CET] <effractur> but i get the following error
[22:00:30 CET] <effractur> Can't find matching camera format for uyvy422, 320x240 at 10000:1000fps
[22:00:46 CET] <effractur> any idea how to get it working?
[00:00:00 CET] --- Thu Feb 11 2016

More information about the Ffmpeg-devel-irc mailing list