[Ffmpeg-devel-irc] ffmpeg-devel.log.20160212

burek burek021 at gmail.com
Sat Feb 13 02:05:03 CET 2016

[00:34:21 CET] <cone-576> ffmpeg 03Michael Niedermayer 07master:9313fb6a3e90: avfilter/vf_zoompan: Remove dead store
[00:44:31 CET] <J_Darnley> Oh lord.  That's a messy patch (gdi mouse cursor).
[00:44:53 CET] <J_Darnley> tabs, whitespace changes, unrelated changes.
[00:45:23 CET] <nevcairiel> corporate junior level developer spotted? :d
[00:48:29 CET] <drv> it also deletes the call to GetIconInfo() but still uses the data that it was supposed to fill out?
[00:48:48 CET] <J_Darnley> I think so
[00:49:04 CET] <J_Darnley> I was just applying the patch to see what the real changes are
[00:51:20 CET] <J_Darnley> I decided I shouldn't send a complaint-only email
[00:51:41 CET] <nevcairiel> i posted a mail about the style  problems
[00:51:41 CET] <wm4> isn't there a much better capture method with d3d
[00:51:47 CET] <nevcairiel> there is
[00:52:02 CET] <furkan> i'm trying to re-build omxplayer and whenever i try "make ffmpeg" after modifying something, it tells me "make: 'ffmpeg' is up to date."
[00:52:03 CET] <nevcairiel> i even implemented it once for another project
[00:52:08 CET] <furkan> does anybody have any tips as to why that might be?
[00:53:16 CET] <drv> i think the actual change is probably bogus too, unless windows only allows integer scaling factors
[00:53:35 CET] <nevcairiel> i think the scaling things are in dpi
[00:54:06 CET] <drv> in 'pos.x = pos.x * desktopvertres / vertres;', the two vertres things are ints
[00:54:23 CET] <nevcairiel> it might overflow, but if it doesnt it should be accurate
[00:54:45 CET] <drv> hmm, yeah, i guess that is OK since the multiply is done first
[00:55:54 CET] <J_Darnley> My spacebar is getting worse.
[00:55:59 CET] <jamrial> huh, fate-source went bananas
[00:56:34 CET] <jamrial> "sed: 1: "/\/\|^ff/!{s/\(.*\)/ffm ...": bad flag in substitute command: '}'"
[00:56:36 CET] <nevcairiel> jamrial: i bet that new check for inclusion guards just doesnt work everywhere
[00:56:46 CET] <jamrial> fails with every single header now
[00:56:46 CET] <nevcairiel> f'ing source checks
[00:56:47 CET] <cone-576> ffmpeg 03Michael Niedermayer 07master:43bf15d1a425: avfilter/avf_showfreqs: assert that variables are initialized by switch()
[00:56:48 CET] <cone-576> ffmpeg 03Michael Niedermayer 07master:156013111a33: avfilter/avf_ahistogram: assert that variables are initialized by switch()
[00:57:41 CET] <jamrial> Timothy_Gu: ^
[00:58:56 CET] <jamrial> seems to be free/net/openbsd only
[01:53:20 CET] <cone-576> ffmpeg 03Michael Niedermayer 07master:bbc4d069d0ef: avcodec/cfhd: Check the number of tag/value pairs
[02:00:55 CET] <cone-576> ffmpeg 03Kieran Kunhya 07master:1e2fd57fc096: avcodec/cfhd: Fix errors with valid files.
[02:10:21 CET] <michaelni> rcombs, what should be done about the sidx regressions caused by your commit ? (https://trac.ffmpeg.org/ticket/5090 https://trac.ffmpeg.org/ticket/5216) 
[02:10:50 CET] <rcombs> oh yeah, I keep forgetting about that
[02:10:54 CET] <rcombs> lemme take another look
[02:11:25 CET] <michaelni> please do and thanks
[03:55:37 CET] <furkan> is it possible to disable pthreads without recompiling ffmeg?
[03:55:44 CET] <furkan> *ffmpeg, of course
[03:56:28 CET] <J_Darnley> Set -threads maybe?
[03:56:42 CET] <furkan> it's on a raspberry pi so compiling takes ages heh
[03:56:46 CET] <J_Darnley> Where the fuck did my "1" go?
[03:57:05 CET] <J_Darnley> POS keyboard
[03:57:23 CET] <furkan> any function i can use in the omxplayer source similar to how i used av_dict_set_int to set the buffer size?
[03:58:09 CET] <furkan> since i can't pass any command-line arguments
[03:59:26 CET] <jamrial> you should cross compile from a desktop
[03:59:27 CET] <furkan> looks like i should probably be able to do av_dict_set_int(&d, "threads", 1, 0)
[04:00:02 CET] <furkan> jamrial: i suppose i could
[04:02:18 CET] <furkan> hmm i think -threads is only for encoding
[04:05:18 CET] <furkan> kierank: i'm 99% sure that the circular buffer w/ pthreads enabled is what's causing my problem... i just need to rebuild with pthreads disabled to confirm
[04:05:46 CET] <furkan> earlier today it was working fine with pthreads disabled, but then i forgot to disable it when rebuilding again
[04:15:09 CET] <furkan> michaelni: seems like you're the one who implemented the circular buffer, any ideas why that might be happening?
[04:15:34 CET] <furkan> i'll get a screenshot hold on
[04:16:55 CET] <furkan> michaelni: this is what happens https://www.dropbox.com/s/8s6m1ssi1wowbky/IMAG0096.jpg?dl=0
[04:17:23 CET] <furkan> with pthreads disabled and by increasing my buffer_size, the corruption is solved
[04:17:38 CET] <furkan> but with pthreads enabled i can't seem to find any way to fix it
[04:18:23 CET] <furkan> i've tried increasing the kernel's UDP receive buffer size, increasing both buffer_size and the fifo buffer size
[04:18:48 CET] <furkan> but basically what's happening is that the kernel is dropping UDP packets because the application isn't processing them fast enough
[04:20:26 CET] <furkan> i confirmed that via the "RcvbufErrors" row with netstat -s
[04:27:37 CET] <bbfan> Hi there! I have a ffmpeg installation issue. Can anybody please help me?
[04:37:10 CET] <J_Darnley> No because you haven't said anything specific
[04:37:46 CET] <J_Darnley> Also you should be asking thatsort of question in #ffmpeg
[04:41:06 CET] <bbfan> Nobody's answering at #ffmpeg. I just re-run the ./configure with the --enable-libass option, it ends with no errors but when i execute ffmpeg there is no libass compiled, so i guess it's the old version. How do i update it?
[04:42:06 CET] <J_Darnley> After you run configure you need to run make
[04:42:31 CET] <cone-576> ffmpeg 03Michael Niedermayer 07master:6c6f2e49e40a: avcodec/h264_slice: remove duplicate unconditional picture_structure setting code
[04:42:32 CET] <cone-576> ffmpeg 03Michael Niedermayer 07master:873158fd76f3: avcodec/h264_slice: assert relation between current_slice ans slice_ctx
[04:42:33 CET] <cone-576> ffmpeg 03Michael Niedermayer 07master:69738466189a: avcodec/h264_slice: Fix dequant table init with field pictures
[04:43:23 CET] <bbfan> yes, i run make, make install, make distclean and hash -r, but it happens what i told. 
[04:43:47 CET] <J_Darnley> Why can't you just run it out the the directory you built it in?
[04:44:04 CET] <bbfan> I executed find / -name ffmpeg and the new ffmpeg binary is at /root/binary (my build root is /root/ffmpeg_build/)
[04:44:12 CET] <bbfan> i don't know, that's the question
[04:44:21 CET] <J_Darnley> Just run ./ffmpeg and be done with it.
[04:46:15 CET] <bbfan> not found
[04:46:37 CET] <J_Darnley> Oh yes.  You got rid of it by running make distclean
[04:46:45 CET] <J_Darnley> Why would you do that?
[04:47:04 CET] <bbfan> ok, let me try
[04:58:59 CET] <bbfan> Now this is the error
[04:59:00 CET] <bbfan> ./ffmpeg: error while loading shared libraries: libass.so.5: cannot open shared object file: No such file or directory
[04:59:32 CET] <bbfan> i looked for it and it's located on /root/ffmpeg_build/lib/
[05:01:57 CET] <J_Darnley> Then either set LD_LIBRARY_PATH, move it, or stop building shared libraries.
[05:02:08 CET] Action: J_Darnley sleeps
[06:06:29 CET] <cone-576> ffmpeg 03James Almer 07master:0abdf7030eeb: avcodec/vc2enc_dwt: add missing header
[07:09:41 CET] <Timothy_Gu> damn sed
[07:28:42 CET] <Timothy_Gu> anybody with an *bsd set up i could use to test the patch I just sent on sed usage?
[07:52:08 CET] <relaxed> Timothy_Gu: there's http://sdf.lonestar.org/
[08:41:07 CET] <furkan> michaelni: yeah i've confirmed, i built 2 copies of ffmpeg, one with pthreads enabled and one with disabled. with the copy that has pthreads enabled, i can't seem to do anything to eliminate the corruption
[08:41:36 CET] <furkan> but of course CPU load is much higher with pthreads disabled
[08:44:01 CET] <furkan> michaelni: and i only seem to have this problem on the raspberry pi... seems to work fine on my laptop with ffplay. if there's any further tests that i could run to help isolate the issue i'd be very interested in trying them out since i'd really like to solve this issue
[09:11:41 CET] <furkan> i will run some more tests tomorrow and report back
[11:25:08 CET] <nevcairiel> AVFilter is crazy, it has a init_opaque function which can take a struct to initialize the filter, and it also defines such a struct in the header file .... but the public init function and this init_opaque  function do not actually forward said init structure
[11:31:32 CET] <durandal21707> nevcairiel: what init structure?
[11:31:55 CET] <nevcairiel> AVBufferSinkParams and AVABufferSinkParams
[11:32:10 CET] <nevcairiel> they cant effectively be used because no public function properly accepts them
[11:34:57 CET] <durandal21707> it is just hack around to give list of pix_fmts/sample_fmts/...
[11:36:12 CET] <wm4> so the struct and av_abuffersink_params_alloc are useless?
[11:36:21 CET] <nevcairiel> pretty much
[11:36:26 CET] <wm4> fascinating
[11:36:26 CET] <nevcairiel> you cant pass it to the filter
[11:36:45 CET] <nevcairiel> from what i gather, it supposed to be passed to avfilter_graph_create_filter in the opaque parameter
[11:36:50 CET] <nevcairiel> but that function doesnt do anything with it
[11:37:38 CET] <durandal21707> report it to saste
[12:17:52 CET] <atomnuker> so in what order are the entries in doc/encoders.texi arranged?
[12:18:09 CET] <atomnuker> doesn't seem to be alphabetical
[12:20:48 CET] <rcombs> the order in which people put them
[12:21:35 CET] <rcombs> tbh I don't think doc/encoders, doc/filters, etc& should be single monolithic files
[12:22:28 CET] <rcombs> have an autogenerated file a la ffmpeg-all that shows all the <insert components>' docs, sure, but having one big source file is awkward
[12:44:35 CET] <wm4> why does Mats have to ALWAYS reply to himself at least a few times
[12:47:33 CET] <kierank> https://forums.xilinx.com/t5/Xcell-Daily-Blog/One-minute-shows-you-how-to-integrate-FPGA-accelerated-OpenCL/ba-p/680503
[12:47:37 CET] <kierank> fpga accelerated ffmpeg
[13:08:42 CET] <wm4> jkqxz: so I guess we wait until Libav pushes the hwcontext patchset?
[13:09:59 CET] <jkqxz> It seems easier to just work on libav.  (Also stops there being any nasty collision later.)
[13:12:24 CET] <jkqxz> Unless this is already colliding in some way which I don't know about, and will not all be merged?
[13:13:26 CET] <wm4> so, that should be fine and would make it easier for everyone
[13:13:41 CET] <wm4> s/so/no/
[13:16:35 CET] <iive> or just don't have about Libav
[13:16:49 CET] <iive> pushing patches there is no fun.
[13:17:20 CET] <durandal21707> you must vertically align everything
[13:17:23 CET] <iive> ops... don't care ..
[13:17:43 CET] <iive> aligning and sorting alphabetically is easy...
[14:40:53 CET] <wm4> nevcairiel: so about this main10 dxva patch (I'm already getting afraid of asking)
[14:57:32 CET] <Timothy_Gu> relaxed: do you have an account on sdf?
[15:04:40 CET] <Compn> sdf still around? :)
[15:17:25 CET] <durandal21707> rcombs: why you rescale loop_start in brstm/bfstm?
[15:18:07 CET] <rcombs> durandal21707: because it's set on the container, not the stream
[15:18:25 CET] <durandal21707> but its sample accurate
[15:18:58 CET] <durandal21707> it sets exact sample where to seek
[15:19:25 CET] <rcombs> the container doesn't have a time base
[15:20:24 CET] <durandal21707> container time base is sample rate
[15:25:21 CET] <rcombs> durandal21707: hmm? That's on the stream
[15:25:45 CET] <rcombs> in the actual brstm format, yes, the time base is the sample rate
[15:26:06 CET] <rcombs> but AVFormatContext's time base is AV_TIME_BASE
[15:46:16 CET] <durandal21707> no yet candidates from outreachy?
[15:52:33 CET] <relaxed> Timothy_Gu: no, but I know it's free and they use netbsd
[16:00:16 CET] <cone-415> ffmpeg 03Michael Niedermayer 07master:03b26a2514c5: avfilter/vf_zoompan: Fix use of uninitialized variables
[16:00:17 CET] <cone-415> ffmpeg 03Michael Niedermayer 07master:f9f684c0fb8c: avfilter/vf_zoompan: Initialize ret
[16:00:18 CET] <cone-415> ffmpeg 03Michael Niedermayer 07master:817bf8483e13: avfilter/af_anequalizer: Avoid loss of precision when calculating nyquist frequency
[16:59:06 CET] <JEEB> ok, so how much stream selection logic can there be in filter_complex and how simply can one put conditionals there? I know that -map supports conditionals at least
[16:59:11 CET] <JEEB> (by appending ?)
[16:59:22 CET] <JEEB> but if I have to do filter_complex I can't use -map IIRC
[17:00:15 CET] <JEEB> like, "pick swedish if exists, otherwise something lavf outputs as '???' otherwise anything else"
[17:01:02 CET] <ubitux> lavfi doesn't have much knowledge on stream information unfortunately
[17:01:14 CET] <JEEB> well you can do [0:v:0] etc
[17:01:26 CET] <JEEB> so I guess the mapping way of language data should be similar to how -map works?
[17:01:38 CET] <ubitux> yeah, but unfortunately, iirc the lavfi source doesn't import the metadata of the stream
[17:01:43 CET] <JEEB> ok
[17:01:47 CET] <ubitux> so you won't for instance have a meta on the lang
[17:01:49 CET] <nevcairiel> i dont think lavfi gets any information beyond the stream numbers
[17:01:56 CET] <ubitux> i'd love to have stream info injected in lavfi btw
[17:02:22 CET] <JEEB> ok... so that's one thing that is yet to have been done
[17:02:37 CET] <JEEB> then there's the question of the conditional stream selection
[17:02:50 CET] <JEEB> which -map seems to work with, but -map + filter_complex doesn't seem to work together
[17:02:58 CET] <JEEB> unless I did something fabulously wrong
[17:03:26 CET] <wm4> in theory ffmpeg.c could do the mapping?
[17:03:47 CET] <JEEB> I guess so
[17:06:17 CET] <Daemon404> "It works here with a repo I found on my hard disc"
[17:06:20 CET] Action: Daemon404 sighs
[17:07:55 CET] <durandal21707> libavcodec/x86/h264_qpel.c:388:1: warning: unused function 'ff_avg_h264_qpel8or16_hv1_lowpass_mmxext' [-Wunused-function]
[17:16:26 CET] <cone-415> ffmpeg 03Paul B Mahol 07master:13ea7c978057: avfilter/avf_showspectrum: improve pts handling
[17:50:16 CET] <cone-415> ffmpeg 03Rostislav Pehlivanov 07master:0384e3d5dfe1: doc/encoders: add documentation for the VC-2 encoder
[17:58:08 CET] <BBB> Daemon404: wbs: do you guys want to review the c99toc89 patch that came in?
[17:58:27 CET] <BBB> (I cant believe people use that stuff, I mean, isnt msvs 2015 out?)
[17:59:39 CET] <nevcairiel> some people are even so crazy to use it for other projects than ffmpeg/libav
[18:01:12 CET] <JEEB> BBB: has been for a while now
[18:02:05 CET] <BBB> nevcairiel: well, thats not unthinkable, although the reasons for its existence were indeed kinda highly politically related to ffmpeg specifics :-p
[18:02:47 CET] <Daemon404> BBB, yeah saw
[18:02:52 CET] <Daemon404> wbs wants a bit of time to try it out
[18:02:59 CET] <BBB> ah okiedokie, cool
[18:03:02 CET] <wm4> I'm glad you made c99toc89, thank you
[18:03:05 CET] <BBB> just wanted to make sure it wouldnt get lost
[18:29:12 CET] <jamrial> why do we still support msvc 2012? it even miscompiles ffmpeg
[18:42:46 CET] <jamrial> "No code is (ever) committed that we believe isn't fit to release" mmh...
[18:43:04 CET] <nevcairiel> and yet we let him commit things
[18:43:05 CET] <nevcairiel> :D
[18:43:13 CET] <kierank> let who?
[18:44:27 CET] <jamrial> cehoyos sure likes to talk as if he was the project's spokeman
[18:44:36 CET] <j-b> lol
[18:45:12 CET] <wm4> cehoyos is pretending a tricycle with broken wheels is a sports car herew
[18:45:45 CET] <wm4> even the guy who tried to maintain the lib completely agrees that it's a lost cause
[18:55:03 CET] <RiCON> atomnuker: tasts?
[18:57:59 CET] <Daemon404> i have an easy fix for myself...
[18:58:08 CET] <cone-415> ffmpeg 03Derek Buitenhuis 07master:5da6bed1e025: MAINTAINERS: Remove myself as libutvideo maintainer
[18:58:35 CET] <wm4> why didn't you replace it with cehoyos' name
[18:58:45 CET] <wm4> blunder
[18:58:51 CET] <Daemon404> that would be trolling
[18:58:56 CET] <Daemon404> whereas nobody can argue agains this
[18:59:05 CET] <Daemon404> i dont need approval to NOT maintain something
[18:59:38 CET] <durandal21707> yea
[19:00:57 CET] <jamrial> just remove it. nobody except him wants that thing in the tree
[19:01:08 CET] <Daemon404> btw
[19:01:09 CET] <Daemon404>    libx264.c                             Mans Rullgard, Jason Garrett-Glaser
[19:01:12 CET] <Daemon404> this is a gem
[19:01:15 CET] <Daemon404> one of them is long gone
[19:01:19 CET] <Daemon404> and one of them literally no longer exists
[19:01:46 CET] <durandal21707> michaelni: is there a way to disable rescaling when input resolution changes?
[19:02:11 CET] <durandal21707> ffmpeg will auto-insert scale filter to  rescale to previous resolution
[19:02:13 CET] <wm4> jamrial: still kind of needs a civil resolution I guess
[19:02:24 CET] <RiCON> atomnuker: https://j.fsbn.eu/r7FO.txt could only find these two
[19:02:38 CET] <wm4> durandal21707: lavfi doesn't support dynamic changes, even if you pretend it does
[19:03:00 CET] <durandal21707> wm4: lavfi auto-inserts scale filter
[19:03:17 CET] <Daemon404> even via api?
[19:19:35 CET] <JEEB> wow
[19:19:41 CET] <JEEB> the "discussion" regarding libutvideo
[19:19:48 CET] <Daemon404> tl;dr car
[19:19:48 CET] <Daemon404> l
[19:19:49 CET] <JEEB> aka everyone vs carl
[19:20:37 CET] <Daemon404> maybe i should add 10bit to the native decoder. but im so lazy.
[19:20:44 CET] <Daemon404> and then itll still be "but it's faster"
[19:20:51 CET] <JEEB> except it isn't
[19:22:13 CET] <jamrial> Daemon404: it's used http://lucy.pkh.me/ffmpeg-coverage-snapshots/1455242957/src/libswscale/slice.c.gcov.html
[19:22:30 CET] <Daemon404> by what
[19:24:12 CET] <kierank> Daemon404: just push it
[19:24:14 CET] <kierank> fuck carl
[19:24:17 CET] <jamrial> no idea
[19:24:36 CET] <Daemon404> kierank, no im not, because i: a) value sanity b) am not going to start flame/revert wars
[19:24:52 CET] <wm4> so uh let's use this vote thingy?
[19:26:04 CET] <Daemon404> jamrial, ill wait for the author
[19:26:10 CET] <Daemon404> because i really dont get how it worked
[19:26:35 CET] <jamrial> wm4: sure. start a new thread and call for a vote. give it a week deadline or so
[19:26:59 CET] <Daemon404> er
[19:27:12 CET] <Daemon404> wasnt carl one of the people who didnt agree to teh entire concept of voting
[19:27:21 CET] <nevcairiel> who cares what he thinks
[19:27:24 CET] <Daemon404> anyway
[19:27:27 CET] <Daemon404> ENOTMYPROBLEM
[19:27:29 CET] <Daemon404> no longer maintainer
[19:30:33 CET] <jamrial> Daemon404: too bad for him, the rest agree and that's what was decided in the last meeting
[19:33:58 CET] <atomnuker> RiCON: thanks
[19:36:48 CET] <durandal_1707> I will start thread, no libutvideo maintainer - removal
[19:42:38 CET] <cone-415> ffmpeg 03Rostislav Pehlivanov 07master:d119268ed23b: doc/encoders: fix typos in the vc2 encoder documentation
[19:42:39 CET] <cone-415> ffmpeg 03Rostislav Pehlivanov 07master:f0a8212436c4: aacenc: make a better estimate for the audio bitrate if not provided
[19:58:46 CET] <cone-415> ffmpeg 03Lou Logan 07master:0b0121d7f209: doc/filters: add geq diagonal split screen example
[20:08:26 CET] <wm4> so should I create a drama... I mean vote thread about the libutvideo issue, or do we just forget about it
[20:14:19 CET] <wm4> durandal_1707: couldn't filters have nicer names than "Parsed_asplit_0"
[20:14:59 CET] <nevcairiel> you can add them explicitly in API and then name them =p
[20:15:03 CET] <durandal_1707> what you propose?
[20:15:55 CET] <wm4> nevcairiel: this is about graph strings
[20:16:07 CET] <wm4> durandal_1707: dunno, maybe just "asplit", and the second "asplit_1" etc.
[20:36:44 CET] <jamrial> wm4: create it
[20:56:06 CET] <JEEB> anyone else can replicate issues with https://kuroko.fushizen.eu/videos/sppl_01_demo_640x360.wmv ?
[21:06:55 CET] <wm4> what issues?
[21:12:46 CET] <JEEB> mpv on windows at least seems to get a lot of various artifacts
[21:13:10 CET] <JEEB> and on ffmpeg I see tons of timestamp errors
[21:14:10 CET] <wm4> huh why does ffprobe -show_frames not show any audio frames
[21:14:55 CET] <JEEB> probably because of "Audio: WMA Lossless 44100Hz stereo"
[21:15:04 CET] <Compn> lossless ,,,
[21:15:11 CET] <Compn> JEEB : does new asf demuxer work on it ?
[21:15:17 CET] <Compn> asf_o or whatnot
[21:15:18 CET] <JEEB> is that under another name?
[21:15:19 CET] <JEEB> oh
[21:15:29 CET] <wm4> JEEB: most of the time it seems to skip audio frame timestamps, and when it doesn't they seem to be inconsistent
[21:15:29 CET] <JEEB> let me see
[21:15:33 CET] Action: Compn downloading
[21:16:20 CET] <JEEB> hmm
[21:16:31 CET] <Compn> if not, also report bug to them ;p
[21:16:57 CET] <JEEB> yea, just checking the switch to mpv to switch demuxer
[21:17:19 CET] <wm4> JEEB: that's complicated
[21:17:30 CET] <Compn> in mplayer it would be -demuxer lavf -lavfdopts format=asf_o 
[21:17:34 CET] <Compn> but mpv? no clue...
[21:17:38 CET] <wm4> --demuxer-lavf-format=asf_o
[21:17:46 CET] <JEEB> dänks
[21:17:49 CET] <durandal_1707> why lines looks like but deinterlacer was used?
[21:18:03 CET] <durandal_1707> *bad
[21:18:16 CET] <JEEB> downscaling by a random games company
[21:18:17 CET] <JEEB> most probably
[21:18:30 CET] <JEEB> meanwhile using wma lossless :D
[21:18:32 CET] <wm4> doesn't look like asf_o works better
[21:18:45 CET] <wm4> this is probably a parser problem of some sort anyway
[21:18:46 CET] <Compn> do other wma lossless files work (regression?)
[21:18:53 CET] <Compn> yes, curious about parsing...
[21:19:25 CET] <JEEB> seems to work after I seek to 1:25
[21:19:48 CET] <Compn> http://samples.ffmpeg.org/A-codecs/lossless/luckynight.wma
[21:19:50 CET] <JEEB> so it could have something to do with the automagical VFR that MS did
[21:20:03 CET] <JEEB> since the first pictures have little actual motion
[21:20:41 CET] <Compn> seems to work ok with mplayer asf demuxer
[21:20:52 CET] <Compn> and binary audio decoder :P
[21:21:51 CET] <Compn> not seeing artifacts with ffplay version N-68788-g37b35fe Copyright (c) 2003-2014
[21:22:36 CET] <wm4> JEEB: actually mpv does some gross shit on pts resets, this could cause the video corruption
[21:22:45 CET] <JEEB> oh, ok
[21:23:50 CET] <durandal_1707> I see no corruptions
[21:26:17 CET] <Compn> did you enable framedropping ?
[21:28:48 CET] <durandal_1707> disabling dropping fixes it
[21:29:04 CET] <durandal_1707> sync issues
[22:22:08 CET] <cone-415> ffmpeg 03Paul B Mahol 07master:f80b4750b9e7: doc/filters: add one more blend example
[00:00:00 CET] --- Sat Feb 13 2016

More information about the Ffmpeg-devel-irc mailing list