[Ffmpeg-devel-irc] ffmpeg.log.20160215

burek burek021 at gmail.com
Tue Feb 16 02:05:01 CET 2016

[03:24:00 CET] <parrot> hello. where can i find the exact command that links x86 asm utilities with the regular C file in libavutil ? thanks
[03:27:19 CET] <J_Darnley> Huh?
[03:27:43 CET] <J_Darnley> Are you looking for the compile commands?
[03:28:14 CET] <J_Darnley> You can use V=1 when running make to have it print the commands it runs.
[03:34:08 CET] <parrot> J_Darnley: thanks. Can I just compile libavutil alone? make libavutil V=1 returns "nothing to be done for 'libavutil'"
[03:34:31 CET] <parrot> I then cd to libavutil and type make V=1 but it says no targets
[03:34:31 CET] <J_Darnley> Try asking for the actual file
[03:34:43 CET] <J_Darnley> libavutil/libavutil.a
[03:46:58 CET] <parrot> ok..now I see yasm commands so I think I might have gotten what I want. So I take yasm generates an object file from the asm file?
[03:47:17 CET] <J_Darnley> Yes.
[03:48:13 CET] <J_Darnley> It is the assembler we use for external x86 assembly
[03:49:12 CET] <J_Darnley> I use it often so if you have more questions feel free to ask.
[03:51:56 CET] <lawrence_>  who has what mic  pid issue on stabilizer no dit no monitor   focus anger     Vacation.  How can you do this to me?  I burned my car to get us out here.  I maxed out my credit cards to get us this far.  What? Am I supposed  to go back by myself?  for f in $(find .  -type f -follow -name *.MXF); do ffmpeg -i $f  -vcodec libx264 -pix_fmt yuv420p  -acodec copy  $f.mov  ; done    I am trying to burn subtitles and cant seem to get it 
[03:52:23 CET] <lawrence_> I am trying to burn subtitles and cant seem to get it to work.  The finished output has no subtitles on it.  It basically just rewrapped.   I have compiled the necessary modules and the .ass file works in VLC.  I am hopping it is operator error.  Does anyone know what I am doing wrong?
[03:53:25 CET] <J_Darnley> From what you posted it looks like you are doing nothing with subtitles.
[03:53:36 CET] <lawrence_> http://pastie.org/10722086
[03:54:49 CET] <lawrence_> ./ffmpeg_g -i test.mov  -vf "ass=subtitle.ass" outerlimits.avi
[03:55:45 CET] <J_Darnley> Are you sure that the 1 line it has actually comes before the end of the video?
[03:55:58 CET] <lawrence_> it works in vlc
[03:56:58 CET] Action: J_Darnley notes that site as being poor for cutting off lines.
[03:57:35 CET] <furq> http://pastie.org/pastes/10722086/text?key=4oixbcim6jdmuglzz7hyzw
[03:57:50 CET] <furq> why does it need a key to view raw? who knows
[03:57:52 CET] <parrot> J_Darnley: Thanks so much :-) I wonder if ffmpeg does have ssim asm code
[03:58:26 CET] <J_Darnley> try looking in libavfilter.  I think there's an ssim filter there.
[03:59:47 CET] <J_Darnley> furq: I just went to delete the stupid "overflow" style option they have.
[04:00:34 CET] <J_Darnley> lawrence_: try increasing the loglevel and see if it prints anything more useful.
[04:01:33 CET] <furq> it's fine i'm sure nobody will ever need word wrap
[04:01:55 CET] <J_Darnley> better a horizontal scroll than cutting off.
[04:02:11 CET] <furq> it does have horizontal scroll but only at the bottom of the div
[04:02:47 CET] <furq> actually it's ruby so they're probably using some made up "semantic" html5 element like <paste>
[04:03:30 CET] <J_Darnley> Ah.  good that I would needto scroll to the bottom before I can scroll across.
[04:04:08 CET] <furq> but look at the rounded corners. that's good UX
[04:04:25 CET] <J_Darnley> That so 2006!
[04:04:53 CET] <furq> check out that pattern on the top bar which is so subtle that you actually can't see it
[04:05:18 CET] <furq> but it must be there or else why would it be an 84KB image
[04:06:56 CET] <J_Darnley> We plebs probably need to calibrate out displays
[04:07:00 CET] <lawrence_> what params do I need to increase the log level to what you need to see?
[04:07:10 CET] <furq> -v debug
[04:07:16 CET] <lawrence_> OK thanks!
[04:07:16 CET] <J_Darnley> try -loglevel verbose first
[04:07:23 CET] <furq> yeah verbose is probably better
[04:07:29 CET] <furq> i forgot what was between info and debug
[04:07:53 CET] <J_Darnley> Some things are a little too verbose on debug.  (I'm looking at you matroska muxer.)
[04:08:05 CET] <lawrence_> thanks I will do that when I get into work tomorrow
[04:08:26 CET] <J_Darnley> If you still have problems you should post the ass file too
[04:10:15 CET] <J_Darnley> Ha.  100K page, 85K is that image.
[04:10:59 CET] <furq> if only it were possible to create a smaller noise.png
[04:11:01 CET] <furq> but it isn't.
[04:11:24 CET] <furq> the 3KB one i use on every website is a pale imitation of pastie's artistry
[06:12:21 CET] <Shirudo> Hey, is anyone available to help me with an audio conversion problem I'm having?
[06:16:41 CET] <TD-Linux> just ask your question
[06:19:31 CET] <Shirudo> I'm trying to convert some .dsf files to .flac, an example of the command I was using is ffmpeg -i 01\ -\ Camel\ -\ Aristillus.dsf "01 - Aristillus.flac"  .  It converts successfully, but the resultant flac files are unplayable.  I'm thinking that I may have to change the sample rate possibly, since the .dsf sample rate is 352800 Hz, far above any rate I've seen a flac file have.
[06:21:54 CET] <Shirudo> The complete output of that command was ffmpeg version 2.6.8 Copyright (c) 2000-2016 the FFmpeg developers
[06:21:56 CET] <Shirudo>   built with gcc 5.3.1 (GCC) 20151207 (Red Hat 5.3.1-2)
[06:21:57 CET] <Shirudo>   configuration: --prefix=/usr --bindir=/usr/bin --datadir=/usr/share/ffmpeg --incdir=/usr/include/ffmpeg --libdir=/usr/lib64 --mandir=/usr/share/man --arch=x86_64 --optflags='-O2 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches -m64 -mtune=generic' --enable-bzlib --disable-crystalhd --enable-frei0r
[06:21:59 CET] <Shirudo>  --enable-gnutls --enable-ladspa --enable-libass --enable-libcdio --enable-libdc1394 --disable-indev=jack --enable-libfreetype --enable-libgsm --enable-libmp3lame --enable-openal --enable-libopencv --enable-libopenjpeg --enable-libopus --enable-libpulse --enable-libschroedinger --enable-libsoxr --enable-libspeex --enable-libtheora --enable-libvorbis --enable-libv4l2 --enable-libvpx --enable-libx26
[06:22:00 CET] <Shirudo> 4 --enable-libx265 --enable-libxvid --enable-x11grab --enable-avfilter --enable-avresample --enable-postproc --enable-pthreads --disable-static --enable-shared --enable-gpl --disable-debug --disable-stripping --shlibdir=/usr/lib64 --enable-runtime-cpudetect
[06:22:02 CET] <Shirudo>   libavutil      54. 20.100 / 54. 20.100
[06:22:03 CET] <Shirudo>   libavcodec     56. 26.100 / 56. 26.100
[06:22:05 CET] <Shirudo>   libavformat    56. 25.101 / 56. 25.101
[06:22:06 CET] <Shirudo>   libavdevice    56.  4.100 / 56.  4.100
[06:22:08 CET] <Shirudo>   libavfilter     5. 11.102 /  5. 11.102
[06:22:09 CET] <Shirudo>   libavresample   2.  1.  0 /  2.  1.  0
[06:22:11 CET] <Shirudo>   libswscale      3.  1.101 /  3.  1.101
[06:22:12 CET] <Shirudo>   libswresample   1.  1.100 /  1.  1.100
[06:22:14 CET] <Shirudo>   libpostproc    53.  3.100 / 53.  3.100
[06:22:15 CET] <Shirudo> [dsf @ 0x1ce75c0] Estimating duration from bitrate, this may be inaccurate
[06:22:17 CET] <Shirudo> Input #0, dsf, from '01 - Camel - Aristillus.dsf':
[06:22:18 CET] <Shirudo>   Metadata:
[06:22:20 CET] <Shirudo>     title           : Aristillus
[06:22:21 CET] <Shirudo>     artist          : Camel
[06:22:23 CET] <Shirudo>     album           : Moonmadness
[06:22:24 CET] <Shirudo>     genre           : Other
[06:22:26 CET] <Shirudo>     track           : 1
[06:22:27 CET] <Shirudo>     date            : 2014-13-02
[06:22:29 CET] <Shirudo>   Duration: 00:01:58.48, bitrate: 5644 kb/s
[06:22:30 CET] <Shirudo>     Stream #0:0: Audio: dsd_lsbf_planar, 352800 Hz, stereo, fltp, 5644 kb/s
[06:22:32 CET] <Shirudo> [flac @ 0x1d5ab60] encoding as 24 bits-per-sample
[06:22:33 CET] <Shirudo> Output #0, flac, to '01 - Aristillus.flac':
[06:22:35 CET] <Shirudo>   Metadata:
[06:22:36 CET] <Shirudo>     title           : Aristillus
[06:22:38 CET] <Shirudo>     artist          : Camel
[06:22:39 CET] <Shirudo>     album           : Moonmadness
[06:22:41 CET] <Shirudo>     genre           : Other
[06:22:42 CET] <Shirudo>     TRACKNUMBER     : 1
[06:22:44 CET] <Shirudo>     date            : 2014-13-02
[06:22:45 CET] <Shirudo>     encoder         : Lavf56.25.101
[06:22:47 CET] <Shirudo>     Stream #0:0: Audio: flac, 352800 Hz, stereo, s32 (24 bit), 128 kb/s
[06:22:48 CET] <Shirudo>     Metadata:
[06:22:50 CET] <Shirudo>       encoder         : Lavc56.26.100 flac
[06:22:51 CET] <Shirudo> Stream mapping:
[06:22:53 CET] <Shirudo>   Stream #0:0 -> #0:0 (dsd_lsbf_planar (native) -> flac (native))
[06:22:54 CET] <Shirudo> Press [q] to stop, [?] for help
[06:22:56 CET] <Shirudo> size=  196254kB time=00:01:58.47 bitrate=13569.5kbits/s
[06:22:57 CET] <Shirudo> video:0kB audio:196246kB subtitle:0kB other streams:0kB global headers:0kB muxing overhead: 0.004178%
[06:27:39 CET] <luzie> thank you
[06:30:14 CET] <situation> wow
[06:30:19 CET] <situation> dude, pastebin that shit
[06:33:27 CET] <Shirudo> I apologize if I'm causing any problems, I have never used IRC before and am unfamiliar with the procedures here.
[06:34:47 CET] <FireFly> Generally for pasting anything longer than a line or two, you'd want to use a pastebin service
[06:35:51 CET] <Shirudo> Thanks, I'll keep that in mind.
[06:42:53 CET] <Shirudo> I have made a paste at this location, http://pastebin.com/PmhCga3R
[06:44:06 CET] <Shirudo> At least I've gotten a new skill out of this, I never knew such websites existed.
[06:50:53 CET] <dystopia> your command is wrong
[06:51:07 CET] <dystopia> ffmpeg -i "in_filename" -acodec flac -compression_level 12 -y "out_filename.flac"
[06:51:18 CET] <dystopia> so in your example
[06:51:45 CET] <dystopia> ffmpeg -i "01\ -\ Camel\ -\ Aristillus.dsf" -acodec flac -compression_level 12 -y "01 - Aristillus.flac"
[06:52:35 CET] <Shirudo> Thank you, I will amend my command and check whether the result is playable.
[07:07:25 CET] <Shirudo> The file I get is still unplayable both in the Exaile audio player, which gives the error "streaming stopped, reason not-negotiated " and the Totem video/audio player, which gives a similar error.
[07:08:29 CET] <Shirudo> I tried opening it in Audacity though as an experiment, and it did play.  I do not know why it would play only in Audacity and in no conventional audio player.
[07:10:52 CET] <Shirudo> The paste for the amended command's output is http://pastebin.com/n5EtAtae
[08:03:41 CET] <Shirudo> In Audacity I exported the file as 16-bit 48000 Hz, and it successfully played in Exaile.  That lends credence to my theory that the issue was the enormous sample rate of the original converted flac file.  Thanks dystopia for taking the time to help me.
[08:07:22 CET] <relaxed> Anyone have a recent intel cpu that supports h264_qsv running linux?
[08:35:00 CET] <test123`> a
[08:41:21 CET] <GreaseMonkey> currently trying to get libavformat/libavcodec/libswscale to behave, it works fine EXCEPT when i try to decode h264 in which case i get the "no frame!" error on every single frame
[08:41:42 CET] <GreaseMonkey> i have tried several different approaches and it refuses to work
[08:42:37 CET] <GreaseMonkey> vp8's fine, flv video's fine, h264 fails in both mp4 and mkv containers
[09:33:14 CET] <GreaseMonkey> ah, got it working now
[09:33:55 CET] <GreaseMonkey> protip: it's better to rip the context from the stream than use avcodec_alloc_context3
[11:47:47 CET] <termos> I sometimes get these messages "Buffer queue overflow, dropping." and then my audio/video is out of sync! Is it possible to detect this in the C API?
[11:48:21 CET] <termos> av_buffersrc_add_frame_flags does not return <0 when this is happening, very strange
[13:03:42 CET] <foolishmonkey> hi, I'm seraching the Internet for the different languages codes list but I faile to find one
[13:03:49 CET] <foolishmonkey> does someone have a list?
[13:39:35 CET] <dystopia> what do you mean foolishmonkey?
[13:40:03 CET] <foolishmonkey> dystopia, to set up metadata, -metadata:s:1 language=eng
[13:40:15 CET] <foolishmonkey> I'm searching the code for Cantonese
[13:45:31 CET] <J_Darnley> heh
[13:45:42 CET] <J_Darnley> The internet suggests there isn't one
[13:45:51 CET] <J_Darnley> at leastnot a 3-char one
[13:46:19 CET] <foolishmonkey> There is zho for Chinese, but Chinese could be Mandarin or Cantonese or...
[13:50:58 CET] <J_Darnley> ISO 639-3 has half a dozen English variants but not Cantonese.  LOL
[16:48:50 CET] <smdrz> trying to convert with h264_qsv, compains  Error initializing an internal MFX session
[16:49:01 CET] <smdrz> using ffmpeg 3.0
[17:15:12 CET] <shincodex> if av_read_frame returns < -1 cause i disconnect network... is it save to keep calling av_read_frame? Lets say i pull plug to network stream then plug it back in... Will av_read_frame eventually figure out it has network data? Or because of connection reset by peer i have to redo entire av format connection process?
[17:15:18 CET] <smdrz> http://pastebin.com/tiQ0BHWn
[17:24:09 CET] <shincodex> so yeah
[17:24:16 CET] <shincodex> anyone answer that before i peered myself?
[17:25:01 CET] <shincodex> I just tested av_read_frame by plug pull peer
[17:25:14 CET] <shincodex> waited 10 minutes
[17:25:30 CET] <shincodex> put plug back in and av_read_frame started to return good values
[17:25:36 CET] <shincodex> and my video stream doesnt seem corrupted
[17:44:02 CET] <smdrz> not using intel media studio
[17:52:56 CET] <jkqxz> smdrz:  That's basically the "not found" message.  What did you do to make that binary?  (You built and linked with libmfx?)
[18:16:03 CET] <salviadud> I was performing a render operation that involved stretching and changing the aspect ratio from a mp4 file coded in h264
[18:16:21 CET] <salviadud> into the same library, h264
[18:16:53 CET] <salviadud> unfortunately, I left my computer at a stop where my leg unplugged it from the ac/dc adapter
[18:17:09 CET] <salviadud> and even more dumb, I didn't reconnect it after 3 hours of laptop battery.
[18:17:31 CET] <salviadud> I checked the incomplete .mp4 file and I couldn't open it.
[18:17:41 CET] <salviadud> Is that normal? shouldn't I see some sort of progress?
[18:19:58 CET] <jkqxz> Yes, that's normal.  mp4 files have to be written whole because they write vital data at the end of the process.
[18:22:13 CET] <salviadud> Well, I decided to render it again.
[18:22:14 CET] <jkqxz> If you want to be able to use a partially-written file you will need a different container, such as mkv.
[18:22:18 CET] <salviadud> But I changed the settings abit.
[18:22:48 CET] <salviadud> I recompiled the x264 library so that it would support SSE, but not ASM
[18:23:00 CET] <salviadud> and I recompiled ffmpeg so that it would only use the SSE flag
[18:23:14 CET] <salviadud> I wonder if ffmpeg is able to force ASM
[18:23:21 CET] <salviadud> or if that is library dependant
[18:23:52 CET] <salviadud> My guess is that it is library dependant, after coding 30 seconds of frames in 27 minutes, I calcuated that it would take about 4 to 5 days
[18:24:18 CET] <salviadud> rendering without both sse and asm makes that render take like a month
[18:24:27 CET] <salviadud> Maybe I should be glad I stopped it.
[18:28:16 CET] <jkqxz> Why are you recompiling it to disable assembly?  It is faster and the output is bit-identical: disabling those things is only meaningful for testing.
[18:30:12 CET] <Mavrik> O.o
[18:30:20 CET] <Mavrik> Also disabling ASM and enabling SSE makes no sense.
[18:30:35 CET] <furq> what are you doing that takes 27 minutes to encode 30 seconds of video
[18:31:31 CET] <furq> http://s3media.247sports.com/Uploads/Boards/191/22191/153683.jpg
[18:31:33 CET] <furq> is this your laptop
[18:31:35 CET] <jkqxz> The compiler might be able to autovectorise some of the C code, so it's possible some sse options can help without assembly.
[18:33:36 CET] <salviadud> I'll tell you what happens in 4 days.
[18:33:41 CET] <salviadud> or 5
[18:33:53 CET] <furq> oh wait are you the guy who's trying to unlock a hidden message in porn using a bucket
[18:34:04 CET] <salviadud> sorta, yeah
[18:34:06 CET] <furq> there's not much point trying to make sense of your actions then
[18:34:21 CET] <durandal_1707> just ignore
[18:34:51 CET] <furq> it's been broadly entertaining thus far
[18:34:54 CET] <salviadud> I think that my asm question referring to ffmpeg is legit
[18:35:32 CET] <furq> well as jkqxz said the output should be bit-identical so there's no point disabling it
[18:35:35 CET] <furq> even for your crazy mission
[18:35:42 CET] <salviadud> and there are several videos which don't contain a hidden message which can be rendered with all optmizations
[18:36:41 CET] <salviadud> oh, and with asm and sse on, it takes like 2 days.
[18:36:50 CET] <salviadud> but, I can't decipher it
[18:37:57 CET] <furq> haven't you been at this for months
[18:38:02 CET] <furq> this hidden message had better be good
[18:38:07 CET] <salviadud> it is
[18:38:12 CET] <salviadud> it involves sasha grey
[18:38:15 CET] <furq> like so good that indiana jones turns up at your house
[19:08:07 CET] <xeons> http://stackoverflow.com/questions/35416110/ffmpeg-concat-video-and-audio-out-of-sync
[20:06:27 CET] <thecount12> Hello I am receiving an ERROR: libzvbi not found when I run ./configure --enable-libzvbi --enable-gpl --enable-memalign-hack --arch=x86 --target-os=mingw32 --cross-prefix=i686-w64-mingw32- --pkg-config=pkg-config
[20:06:51 CET] <J_Darnley> Did you install it?
[20:06:58 CET] <thecount12> yes
[20:07:04 CET] <thecount12> it works when I don't cross compile
[20:07:21 CET] <J_Darnley> Did you build it for the right platform?
[20:07:35 CET] <thecount12> interesting
[20:07:45 CET] <thecount12> i did an apt-get on libzvbi
[20:08:08 CET] <J_Darnley> I wonder why that didn't give you a Windows library(!)
[20:08:16 CET] <thecount12> doh!
[20:08:34 CET] <thecount12> silly
[20:38:28 CET] <cyphix> Hi! I'm trying to reproduce the ffmpeg command my mediacrush server is using to encode uploaded videos. According to 'ps aux', this is the run command: 'ffmpeg -y -i /tmp/tmpSXdVCo.mkv -c:v libvpx -c:a libvorbis -q:a 5 -pix_fmt yuv420p -quality good -b:v 5M -crf 5 -vf scale=trunc(in_w/2)*2:trunc(in_h/2)*2 -map 0:v:0 -map 0:a:0 /var/www/server.com/MediaCrush/storage/h18uoUjcQ6o6.webm'. But when I try to run it
[20:38:29 CET] <cyphix> manually from a shell, it returns "bash: syntax error near unexpected token `(' ". Would anybody have an idea why the copied command doesn't work?
[20:39:19 CET] <BtbN> Because there is an unexpected token near (
[20:39:33 CET] <pzich> Try putting the stuff after -vf in single quotes, like 'scale=trunc(in_w/2)*2:trunc(in_h/2)*2'
[20:39:45 CET] <podman> cyphix: what pzich said
[20:42:18 CET] <J_Darnley> cyphix: you need to quote or escape special characters
[20:42:51 CET] <J_Darnley> And that is a dumb command
[20:42:57 CET] <pzich> hah
[20:43:49 CET] <cyphix> Oh ok, thanks. Now I have a "Unable to parse option value "0 -map 0" as boolean", but I guess it's an improvement...
[20:45:17 CET] <cyphix> J_Darnley: I use the command given by mediacrush. I don't have the knowledge to evaluate this command, but any improvement would be much appreciated, the encoding process is insanely slow...
[20:45:38 CET] <J_Darnley> Start with the full output.
[20:45:44 CET] <J_Darnley> That might tell us why its slow
[20:46:45 CET] <doub__> I'm trying to use ffmpeg to decode/resize a video, and feed it raw-ish to another program through stdout, but after a few hundred frames (exactly how many depending mostly on input video), ffmpeg stops with a broken pipe error. Do I need special options to have it wait for consumption of frames on stdout?
[20:46:51 CET] <cyphix> here is the result of my command: https://p.cyphix.org/view/2f3ad3aa
[20:47:36 CET] <J_Darnley> You have quoted too much
[20:47:40 CET] <pzich> note what I showed you should quote
[20:47:43 CET] <pzich> not the -map stuff
[20:47:50 CET] <pzich> up to the second *2
[20:48:00 CET] Action: J_Darnley must have missed that
[20:48:18 CET] <pzich> > Try putting the stuff after -vf in single quotes, like 'scale=trunc(in_w/2)*2:trunc(in_h/2)*2'
[20:48:32 CET] <pzich> granted, "the stuff after -vf" can be confusing
[20:48:44 CET] <cyphix> oh ok
[20:49:12 CET] <J_Darnley> doub__: I would expect write to block by default but I am no expert.
[20:49:15 CET] <pzich> and I did say single quotes, but I think double should work fine in this case too
[20:49:37 CET] <pzich> doub__: have you tried writing your raw output to a file, then piping that in with cat to the second program?
[20:49:45 CET] <pzich> just to ensure that it's the pipe that's the issue, not either command
[20:49:48 CET] <doub__> pzich: dumping to a file works fine
[20:50:01 CET] <doub__> and then reading the file, it's in the correct format
[20:50:11 CET] <doub__> piping to a file works fine too
[20:50:30 CET] <doub__> i also tried piping to cat, and then to a file, and it works fine too (all on Winows)
[20:50:44 CET] <pzich> ah, sorry, I'm no help on windows
[20:50:57 CET] <pzich> I do something fairly similar at quite a large scale, but on linux
[20:51:37 CET] <J_Darnley> Have you set stdin to be binary mode?
[20:51:57 CET] <doub__> no, i'm not sure how to do that
[20:52:24 CET] <J_Darnley> I'm not sure either so I'll go look at something that does do it.
[20:52:33 CET] <J_Darnley> (x264)
[20:52:34 CET] <cyphix> ok, the command works, but it encodes at 0.4 fps... Any idea what's slowing it that much?
[20:53:07 CET] <J_Darnley> doub__: _setmode( _fileno( stdin ),  _O_BINARY );
[20:53:44 CET] <J_Darnley> cyphix: again, we want the whole output.
[20:54:03 CET] <doub__> J_Darnley: ok, i'll test that, but it could take a little while, i'm using Lua at the moment and that's not exposed AFAIK
[20:54:29 CET] <J_Darnley> :) I was wondering if you were.
[20:54:37 CET] <cyphix> J_Darnley: yeah sorry, it's coming. I've issues pasting a moving output
[20:54:46 CET] <J_Darnley> ah okay
[20:55:19 CET] <J_Darnley> cyphix: stop it then copy
[20:57:00 CET] <cyphix> J_Darnley: Yeah but then the last line is all recovered
[20:57:05 CET] <cyphix> https://cyphix.org/2016-02-15_20-56-31_scrot.png
[20:58:50 CET] <J_Darnley> The progress line really doesn't tell us all that much.
[20:59:14 CET] <J_Darnley> I'm going to blame how you compiled ffmpeg and probably libvpx too
[21:00:19 CET] <J_Darnley> A mess of a configure line hiding disable-runtime-cpudetect
[21:00:31 CET] <cyphix> J_Darnley: Oh you can. I did my best, but it's probably not much. Any advice on that matter would be welcome.
[21:01:18 CET] <J_Darnley> Start by dopping every option
[21:01:29 CET] <J_Darnley> Then enable what you need.
[21:01:42 CET] <doub__> J_Darnley: that works with a basic pipe, now I need to figure out how to do that with a popen
[21:01:58 CET] <J_Darnley> The "b" option?
[21:02:33 CET] <doub__> i think the Lua binding doesn't let that through, probably time for a patch, thankfully i build my lua interpreter myself
[21:02:48 CET] <doub__> do you know why the text mode causes the issue?
[21:03:10 CET] <J_Darnley> One of the ascii control chars signals end-fo-stream
[21:03:13 CET] <J_Darnley> *of
[21:03:28 CET] <J_Darnley> then windows closes the file/pipe/whatever
[21:03:41 CET] <cyphix> J_Darnley: I tried to compile it with the minimum required by mediacrush, which are libtheora, libvorbis, libx264, libfdk_aac, and libvpx. But I couldn't encode wmv files. So I have to admit I used a configure file I found somewhere :/ So I don't know what to use...
[21:03:46 CET] <J_Darnley> then ffmpeg fails to write
[21:04:37 CET] <J_Darnley> Does ffmpeg even have *any* WMV encoders?
[21:05:02 CET] <J_Darnley> oh it has versions 1 and 2
[21:05:06 CET] <cyphix> Ah. That I have no idea...
[21:05:16 CET] <doub__> J_Darnley: ah, ok, thanks for the info, and rb works in popen, so problem fixed :D
[21:05:22 CET] <J_Darnley> :)
[21:07:10 CET] <cyphix> J_Darnley: So do you advice me to go back to the version including the minimal requirements, and work from there?
[21:07:20 CET] <J_Darnley> Yes.
[21:07:42 CET] <J_Darnley> If you have a problem with a specific file we are willing to help.
[21:07:59 CET] <cyphix> Ok, I'll do that and see what happens in more details.
[21:08:07 CET] <J_Darnley> I would also suggest recompiling libvpx to make sure you didn't do something silly there.
[21:10:02 CET] <cyphix> J_Darnley: Hem.... I don't know how to do that :/
[21:10:22 CET] <J_Darnley> Did you not do it before?
[21:10:43 CET] <J_Darnley> Or did you just use the version provided by your OS?
[21:11:16 CET] <cyphix> Apparently not. I can't find the libvpx package on my debian system.
[21:12:02 CET] <cyphix> Oh, I have libvpx1 installed
[21:12:18 CET] <cyphix> From the official debian repos.
[21:12:33 CET] <cyphix> And I didn't touch it, so I guess it's intact
[21:13:58 CET] <cyphix> Is it fine as it is, or should I do something about it?
[21:21:23 CET] <J_Darnley> Perhaps the packer did manage to compile it correctly
[21:21:29 CET] <J_Darnley> leave it be for now.
[21:21:40 CET] <satviewer> Is there some problem with the mailing list?  I signed up today and attempted to post a message twice and it never got posted (and I did make sure it came from the same email address I used when signing up).
[21:22:04 CET] <J_Darnley> Did you confirm your subscription?
[21:22:09 CET] <cyphix> J_Darnley: Ok. I'm compiling the cleaner version now. I'll see what it does.
[21:23:53 CET] <satviewer> Anyway I was just wondering if the syntax changed in ffmpeg 3.0.  I have been using the technique I found in this article to receive a satellite channel:
[21:23:56 CET] <satviewer> https://freetoairamerica.wordpress.com/2015/09/03/fixing-the-audio-on-live-tv-from-a-certain-network-which-shall-remain-nameless/
[21:24:32 CET] <satviewer> But after I installed 3.0 I got no audio at all.  Reverting back to 2.8.2 made it work again.
[21:25:35 CET] <J_Darnley> odd
[21:25:38 CET] <satviewer> It is a pipe command in TVHeadEnd of this form: pipe:///usr/local/bin/ffmpeg -loglevel fatal -i -c:v copy -c:s copy -c:d copy -c:t copy -filter_complex [0:1][0:2][0:3]amerge=inputs=3,pan=5.1|FL=c0|FR=c1|FC=c2|LFE=c3|BL=c4|BR=c5 -c:a eac3 -f mpegts pipe:1
[21:25:59 CET] <satviewer> I see now they note in the article that it doesn't work in 3.0!
[21:26:35 CET] <durandal_1707> what error you get?
[21:26:43 CET] <J_Darnley> Perhaps someone with the problem should file a bug.
[21:27:16 CET] <satviewer> So I was just wondering if there might have been some change in syntax that would cause that not to work under 3.0.
[21:29:34 CET] <satviewer> If you were asking me, I don't see any errors but then because it is run from within TVHeadEnd I wouldn't.  I don't really know how or why this works, I just followed the instructions in the article and it does as long as I don't use ffmpeg 3.0
[21:30:18 CET] <J_Darnley> Perhaps you should drop the loglevel option and look at stderr.
[21:30:23 CET] <satviewer> Oh and yes I did confirm my subscription.
[21:31:51 CET] <satviewer> Well I have already uninstalled 3.0 and put 2.8.2 back.  I just wondered if there was anything obvious about the syntax where someone would look at it and say "oh we changed that" or something.
[21:32:17 CET] <durandal_1707> nothing changed
[21:33:42 CET] <durandal_1707> satviewer: do you know how much channels each stream have?
[21:34:29 CET] <satviewer> Well that is weird then.  I used the static build of ffmpeg from http://johnvansickle.com/ffmpeg/ which is what I have been using all along, and it's just strange because the video still passes through with no problem in 3.0 but the audio is gone.
[21:35:47 CET] <satviewer> That's why I posted thie link, it is a really weird stream.  Actually hold on a second I can get you better information.
[21:37:03 CET] <satviewer> This earlier article from that site describes the streams in the first couple of paragraphs:  https://freetoairamerica.wordpress.com/2014/09/30/fixing-the-audio-on-recorded-programs-from-a-certain-network-which-shall-remain-nameless/
[21:37:33 CET] <satviewer> Basicall it appears there are four audio streans with two channels in each
[21:37:52 CET] <satviewer> And only the first three streams are used to get 5.1 audio.
[21:39:18 CET] <satviewer> Also the entire full stream is a "Transport Stream", whatever that is.
[21:40:24 CET] <durandal_1707> well perhaps the order of streams changed
[21:40:39 CET] <furq> he said it still works in 2.8
[21:41:03 CET] <satviewer> Not in the original, as I said it immediately starts working again if I revert to 2.8.2
[21:41:26 CET] <durandal_1707> mpegts have underdone some changes
[21:42:15 CET] <durandal_1707> so you should use ffprobe to report stream numbers
[21:42:32 CET] <satviewer> Oh, so does that mean this can't be done anymore in 3.0?
[21:42:57 CET] <satviewer> brb door
[21:43:01 CET] <durandal_1707> or use better command, 0:a:1 or smth like that
[21:43:42 CET] <durandal_1707> it can be done, just info is missing
[21:44:32 CET] <durandal_1707> using 0:1 as stream selection is bad idea as order can change
[21:47:14 CET] <satviewer> Okay well unfortunately I don't understand any of that., I am just using what was posted on that site and have no idea how they came up with it.  And I just found out I need to leave for a while.
[21:47:40 CET] <furq> satviewer: replace [0:1] with [0:a:1] etc
[21:47:57 CET] <furq> the mpegts demuxer might have changed the way it orders input streams in the update
[21:48:15 CET] <satviewer> But I will leave this up while I am gone in case anyone has any other thoughts, but I am so clueless about this I would need a complete url to try similar to what I posted.
[21:48:33 CET] <satviewer> Thank you.
[21:49:46 CET] <satviewer> furq "replace [0:1] with [0:a:1] etc" doesn't help me unless you can spell out what "etc" means, as I said I am totally clueless about this.
[21:49:58 CET] <furq> -filter_complex
[21:50:02 CET] <satviewer> Back later.
[21:50:03 CET] <furq> ugh
[21:50:14 CET] <furq> in -filter_complex [0:1][0:2][0:3]...
[21:50:34 CET] <furq> change all the [0:n] to [0:a:n]
[22:40:07 CET] <satviewer> furq thank you, I think I understand, I will give that a try later but I will have to install 3.0 again so I can't do it right this second, but I will give it a try.  Thank you.
[22:51:12 CET] <adc> I've written some code to add sounds to an audio file at a number of given points (example command/output: http://pastebin.com/m6TLauek) and I've gotten it working correctly, but the process seems slow (say, 60-70 minutes for the addition of 1,000~ sounds across an hour of playback time). I was wondering if there was a faster way to do this, or if my expectations are unrealistic and this is the cost of so much re-encoding
[23:19:52 CET] <Plorkyeran_> decoding then reencoding flac should be doable at >100x realtime unless you're running it on a toaster
[23:20:45 CET] <adc> Running it on a 4790k, so that shouldn't be an issue
[23:22:10 CET] <Plorkyeran_> a baseless guess: your filter may be seeking between the insertion points by decoding from the beginning of the file, resulting in it being decoded 1000 times
[23:25:18 CET] <adc> That would make sense - I run the command once per delay amount
[23:26:32 CET] <adc> Would there be any way to get around that? I don't know much about ffmpeg, and this was the best I could find on Google
[23:28:39 CET] <Plorkyeran_> lazy solution is to just decode to pcm first, do all the modifications to that, then only encode to flac at the end
[23:30:24 CET] <adc> Is pcm lossless? My original files are in "pcm_s16le" but running that command a few hundred times ended up with massive issues in the output
[23:30:46 CET] <adc> With the most recently encoded files sounding fine, but the first ones added sounding horrible
[23:31:14 CET] <J_Darnley> If you don't do anything to the audio then it should remain the same data
[23:32:51 CET] <Plorkyeran_> as long as you don't do any accidental format conversion or anything it'll literally just be a dump of the decoded audio data with some headers
[23:32:51 CET] <adc> I decode it, add a delay to the start and reencode
[23:37:19 CET] <eksrow> Hi I just read about 3.0. If I want to compile ffmpeg with mp3 support can I still use this guide (https://trac.ffmpeg.org/wiki/CompilationGuide/Ubuntu)? I read about the native aac encoder now being the reccomended one, so I should skip the 'libfdk-aac' step?
[23:37:52 CET] <J_Darnley> huh?  mp3 is not aac
[23:38:29 CET] <J_Darnley> While I'm not sure, I think libfdk is still better than the internal encoder.
[23:39:37 CET] <JEEB> eksrow: if you only need LC-AAC encoding, just use the internal one
[23:39:49 CET] <JEEB> if you need HE-AAC, then you still need fdk-aac
[23:40:02 CET] <J_Darnley> ah, noted.
[23:43:26 CET] <furq> fdk is better for vbr as well iirc
[23:46:25 CET] <eksrow> JEEB: thank you! J_Darnley: I mentioned mp3 support as the reason for compiling, I read on HN about the 3.0 release and in the 'patch-notes' as internal aac encoder being recommended over the others, the compiling step has a step where you add another AAC lib. so I was a bit confused
[23:46:45 CET] <furq> eksrow: do you need mp3 encoding support or just decoding
[23:47:47 CET] <furq> actually if you're on ubuntu/debian it doesn't matter because 3.0 isn't in the repos yet
[23:48:10 CET] <eksrow> furq: decoding definitely, encoding I can do without(I just need to send the output to Youtube)
[23:48:27 CET] <furq> ffmpeg from repos can decode mp3
[23:48:40 CET] <furq> the mp3 decoder is builtin
[23:49:01 CET] <J_Darnley> have the linux retard s stopped disabling mp3 in everything
[23:49:03 CET] <J_Darnley> ?
[23:49:21 CET] <furq> iirc the freebsd package doesn't include mp3
[23:49:40 CET] <furq> although at least they make it easy to build it with lame
[23:50:34 CET] <furq> oh
[23:50:43 CET] <furq> apparently lame is included in the debian package now
[23:50:57 CET] <J_Darnley> Wow(!)
[23:51:31 CET] <eksrow> furq: do the static binaries on the ffmpeg website also provide mp3 decoding (or only from the repo's)?
[23:54:10 CET] <furq> probably? i've never used them
[23:54:15 CET] <furq> oh, decoding
[23:54:18 CET] <furq> almost certainly then
[23:58:26 CET] <eksrow> alright, thank you!
[00:00:00 CET] --- Tue Feb 16 2016

More information about the Ffmpeg-devel-irc mailing list