[Ffmpeg-devel-irc] ffmpeg.log.20160221

burek burek021 at gmail.com
Mon Feb 22 02:05:01 CET 2016

[00:05:00 CET] <qwertzsqwert> JEEB: nothing there I'm afraid.
[00:05:08 CET] <qwertzsqwert> Never mind.
[00:05:52 CET] <DHE> If I want to specify multiple text-style flags for an option, how do I separate them? commas didn't work.
[00:05:54 CET] <J_Darnley> Isn't it a system lib that will get auto detected?
[00:06:07 CET] <qwertzsqwert> My laptop speakers are dead. Is there a way I can use ffmpeg to tap the playback device and set up an RTP stream?
[00:06:24 CET] <J_Darnley> DHE: depends on the option I'm afraid, some take colons
[00:06:41 CET] <DHE> that didn't work either
[00:07:00 CET] <DHE> I'm using -hls_flags. I need multiple options. specifying -hls_flags multiple times seems to disable previous options
[00:07:18 CET] <J_Darnley> oh, those flags might be + and - ones
[00:07:52 CET] <J_Darnley> as in: -hls_flags +a+b+c-d-e-f
[00:07:56 CET] <qwertzsqwert> J_Darnley: Jack is installed. libjack.so is present on the system.
[00:08:10 CET] <DHE> J_Darnley: that did it...
[00:08:10 CET] <J_Darnley> And the headers?
[00:08:16 CET] <DHE> qwertzsqwert: and the -devel package?
[00:08:23 CET] <DHE> J_Darnley: thx
[00:08:33 CET] <J_Darnley> DHE: isn't the amount of different syntax here just amazing?
[00:09:37 CET] <qwertzsqwert> DHE: Are you talking about *devel package for Jack or ffmpeg. I'm using Arch, neither packages have a devel build in the repo.
[00:11:59 CET] <DHE> qwertzsqwert: on my system (centos 6) there's a package called jack-audio-connection-kit-devel
[00:12:11 CET] <DHE> which you would need to build ffmpeg with JACK support
[00:13:13 CET] <furq> i don't think arch uses -dev packages, the headers should come with the library itself
[00:13:31 CET] <J_Darnley> neat!
[00:13:49 CET] <J_Darnley> i made the right choice then
[00:13:58 CET] <furq> what, to not use arch?
[00:14:03 CET] <J_Darnley> no to use it
[00:14:08 CET] <furq> oh
[00:14:13 CET] <furq> you have my condolences
[00:15:42 CET] <qwertzsqwert> DHE: these are the Jack specific packages in the Arch repo - https://ptpb.pw/cQO2. No devel releated.
[00:16:08 CET] <qwertzsqwert> DHE: It's cool. It doesn't matter.
[00:16:33 CET] <DHE> hmm.. interesting
[00:16:57 CET] <J_Darnley> What does "ffmpeg -devices" list?
[00:18:44 CET] <qwertzsqwert> J_Darnley: Already tried that. Nothing Jack is listed - https://ptpb.pw/JlMn
[00:19:11 CET] <J_Darnley> Then it is time to stop fumbling in the dark.  Please post the full output.
[00:19:46 CET] <qwertzsqwert> Full output of ffmpeg -f jack -i ffmpeg -y out.wav ?
[00:19:58 CET] <J_Darnley> That will do
[00:20:18 CET] <furq> if you're using pulse then you can have that broadcast an rtp stream
[00:20:45 CET] <furq> https://www.freedesktop.org/wiki/Software/PulseAudio/Documentation/User/Network/#index3h2
[00:22:02 CET] <qwertzsqwert> J_Darnley: It's irrelevant. I explained above. I think the devs @ Arch haven't built ffmpeg with jack support, as durandal_170 mentioned.
[00:22:08 CET] <J_Darnley> No it isn't
[00:22:19 CET] <J_Darnley> oh that might be
[00:22:21 CET] <qwertzsqwert> furq: I was hoping I wouldn't need to install PulseAudio.
[00:22:27 CET] <J_Darnley> I thought you were compiling yourself
[00:22:32 CET] <qwertzsqwert> Just a quit ffmpeg one liner.
[00:23:17 CET] <qwertzsqwert> J_Darnley: I was going to, but having now pulled the source there's no mention of Jack in the ./configure --help
[00:23:26 CET] <qwertzsqwert> For the switch.
[00:23:29 CET] <J_Darnley> ./configure --list-indevs
[00:23:45 CET] <J_Darnley> as I said
[00:23:46 CET] <J_Darnley> [Sun 00:05] <J_Darnley> Isn't it a system lib that will get auto detected?
[00:26:34 CET] <qwertzsqwert> I'm leaving it. Are you aware of a way to set up an RTP stream with ffmpeg for the default playback device?
[00:26:54 CET] <J_Darnley> not me, sorry
[00:27:36 CET] <qwertzsqwert> OK.
[00:28:20 CET] <furq> https://trac.ffmpeg.org/wiki/Capture/ALSA#Recordaudiofromanapplication
[00:28:22 CET] <furq> there's that
[00:28:29 CET] <furq> idk if that really does what you want though
[00:37:43 CET] <qwertzsqwert> I'll give pulseaudio a look.
[00:57:32 CET] <Interrogator> is there any ffmpeg app [ COMPILED ] with all known Libs : in a past session i got just the url of src code of ffmpeg ?
[00:58:39 CET] <JEEB> no
[00:58:49 CET] <JEEB> not to mention that that request is impossible from the get-go
[00:58:56 CET] <JEEB> since some libraries are OS-specific
[01:00:13 CET] <Interrogator> i understand thanks
[01:01:14 CET] <JEEB> also generally the stuff you require is generally well known to you before :P (esp. since you get pretty much all the decoders in FFmpeg itself)
[01:01:14 CET] <jkqxz> Also, were someone to make the most complete set possible for a given platform, the result would probably not be distributable at all due to conflicting licence requirements.
[01:12:16 CET] <Interrogator> how to hide the console when using OR creating a ffmpeg UI ?
[04:17:14 CET] <cortexman_> where can i find an example .raw file
[04:26:31 CET] <cortexman_> which audio file is a list of floats?
[04:26:34 CET] <cortexman_> *format
[04:27:41 CET] <fahadash> How do I install mpeg4 codec?
[04:40:12 CET] <fahadash> Encoder (coded mpeg4) not found for output stream #0:0
[04:40:21 CET] <fahadash> What does this mean?
[04:40:47 CET] <fahadash> Trying to copy mpeg4 file as mkv
[05:52:56 CET] <fahadash_> Here is my output, http://pastebin.com/n94pcuZk
[05:53:06 CET] <fahadash_> I am trying to convert one format to the other
[09:13:11 CET] <fengshaun> is it possible to have ffmpeg transcode a particular byte-range rather than time-range?
[09:13:52 CET] <fengshaun> I'm trying to do on the fly transcoding while avoiding having to use libavcodec and libavformat directly
[09:14:09 CET] <fengshaun> I can't find anything on this
[12:52:44 CET] <PlanC> I'm using ffprobe to get info about a few MP3s
[12:52:56 CET] <PlanC> one of the things I'm looking for is the bitrate
[12:52:59 CET] <PlanC> but I'm seeing two bitrates
[12:53:39 CET] <PlanC> one is in the duration line
[12:53:52 CET] <PlanC> Duration: 00:01:11.26, start: 0.021057, bitrate: 132 kb/s
[12:54:00 CET] <PlanC> the other is in the line below
[12:54:06 CET] <PlanC> Stream #0:0: Audio: mp3, 44100 Hz, stereo, s16p, 128 kb/s
[12:54:15 CET] <PlanC> one says 128 kb/s the other says 132 kb/s
[12:54:22 CET] <PlanC> does anyone know which one is the right one?
[12:58:04 CET] <__jack__> PlanC: what command line ?
[13:00:01 CET] <jkqxz> PlanC:  It depends what you want it for and how the file was encoded.  The 132 is the total size of everything divided by the total time.  The 128 is the intended bitrate of the encoded data, which need not be exactly correct if it was encoded with some form of variable bitrate.
[13:00:35 CET] <__jack__> isn't it some overhead, due to the container or something ?
[13:02:53 CET] <PlanC> jack: just "ffprobe $MP3_LOCATION"
[13:03:13 CET] <PlanC> jkqxz: ah, that's a perfect explanation
[13:03:14 CET] <PlanC> thanks
[13:03:47 CET] <__jack__> PlanC: you may like ffprobe -show_streams -print_format json file.mp3, maybe more precise ?
[13:08:19 CET] <jkqxz> The distinction between the two in ffprobe output is easier to see if you look at a file with both audio and video.  It will tell you the total bitrate (total size / total time, including the container overhead), the audio bitrate, and the video bitrate separately.
[13:10:55 CET] <PlanC> jack: ah, it's pretty useful to see it in JSON
[13:11:01 CET] <PlanC> now I can just parse it with a script, thanks
[14:28:39 CET] <TuxOholic> hello, ffmpeg 3.0 question: when I convert a video to vp8/webm I lose the metainfo tag "bitrate", ffprobe then shows "bitrate N/A" insead of the new bitrate in kbit/s ... how can I add it again? Is it possible to use -metadata bitrate="1024 kbit/s" ?
[14:32:45 CET] <J_Darnley> Most formats don't explicitly store a bitrate anywhere
[14:33:15 CET] <J_Darnley> While you could add arbitrary metadata it wouldn't be accurate ot shown whereever you want it.
[14:35:13 CET] <TuxOholic> J_Darnley: I use vp8/cbr encoding, so could I set a bitrate value that is correct by average, right?
[14:35:52 CET] <J_Darnley> No there is no guarantee the that encoder can get near what you ask
[14:36:11 CET] <TuxOholic> true, but it is close enough
[14:36:35 CET] <JEEB> the only way is to write the info after the fact by looking at how many bits were used for the whole clip's each stream. that way you get the abr for each of them
[14:37:07 CET] <TuxOholic> that would be nice, can you point me to an example?
[14:37:19 CET] <JEEB> nfi if ffmpeg can do it for you :P
[14:37:33 CET] <BtbN> why do you care about the exact bitrate? Nothing needs it
[14:37:54 CET] <JEEB> and if you just want the abr of the whole file with all tracks and container overhead, just use the file size and the length of the thing in seconds
[14:37:56 CET] <BtbN> Even CBR mode doesn't strictly stick to a certain bitrate, so that info is pretty much useless anyway
[14:38:37 CET] <JEEB> BtbN: if you are doing actual CBR (you need more than one parameter with most encoders since you don't generally want real CBR), then it should stick to such
[14:39:01 CET] <JEEB> within some limitation of course depending on your VBV/HRD calculation blargh blargh
[14:39:25 CET] <TuxOholic> all true, most meta info tools I use don't calculate the bitrate , they use the bitrate flag
[14:41:13 CET] <JEEB> which is generally useless other than being "some value a user can see and feel happy even though it could be off by whatever"
[14:41:29 CET] <TuxOholic> it' s all about getting a quick summary in konqueror file/info , so I can quickly see what video what frame rate
[14:41:33 CET] <J_Darnley> How can a tool be so lazy?
[14:41:41 CET] <J_Darnley> bitrate = filesize / length
[14:41:49 CET] <JEEB> ^ this, for all tracks
[14:41:58 CET] <JEEB> like, you get an overall bit rate
[14:42:06 CET] <JEEB> not perfect for shit like mpeg-ts, but fuck it
[14:42:08 CET] <JEEB> :D
[14:42:20 CET] <JEEB> (things where you just don't have the length basically)
[14:42:52 CET] <J_Darnley> Only shit-tier streaming formats suffer from that.
[14:43:05 CET] <JEEB> and the one audio format that was picked without a container
[14:43:10 CET] <JEEB> for whatever reason
[14:43:20 CET] <J_Darnley> oh yes
[14:43:40 CET] <JEEB> which is why most audio players actually play mp3 files in the background before showing the info on screen
[14:43:58 CET] <JEEB> (you can do it N times realtime so they kind of get away with it)
[14:44:25 CET] <JEEB> or at least I hope most players do that, har har - otherwise you are just going to have "fun"
[14:45:01 CET] <JEEB> and of course seeking in such is fun as well unless you index it in some way
[14:45:08 CET] <J_Darnley> I bet the xing header stores the length
[14:45:20 CET] <JEEB> true that
[14:45:47 CET] <J_Darnley> Just tack more data on.  It'll fix everything(!)
[14:45:56 CET] <JEEB> but it still never ceases to amaze me that something as unwieldly was decided to be The Thing for audio for so many years
[14:46:14 CET] <J_Darnley> I guess it was good enough
[14:47:17 CET] <JEEB> it was good enough for absolute CBR
[14:47:30 CET] <JEEB> that way you got the length and seeking kind of right
[14:47:41 CET] <JEEB> otherwise it was happy indexing time
[14:47:52 CET] <JEEB> (or just playing from the beginning each time you seeked)
[14:49:09 CET] <JEEB> also this reminds me that in 2016 mp3 in ISOBMFF (what we colloquially call "mp4", and which is a container) is still a point of discussion on mp4-sys
[14:49:53 CET] <bencoh> :]
[14:50:50 CET] <JEEB> http://up-cat.net/p/0bb3a4e6
[14:51:16 CET] <BtbN> JEEB, never seen libvpx do that. x264, yes.
[14:51:34 CET] <JEEB> BtbN: yes, I was speaking on a general level
[14:51:52 CET] <JEEB> libvpx rate control has sucked for years
[14:52:57 CET] <TuxOholic> okay, it can't do it, that's fine  with me ... I have another problem with the vidstabtransform and the deshake filter: they both are not working  enough on my dash cam recordings ... can I upload a sample somewhere and show you the results?
[15:00:20 CET] <JEEB> that sounds like a case of the default parameters not working for you
[15:00:44 CET] <JEEB> welcome to the wonderful world of poking at some switches that look like they might do something for you
[15:01:10 CET] <JEEB> https://www.ffmpeg.org/ffmpeg-all.html#vidstabtransform-1
[15:01:23 CET] <JEEB> and https://www.ffmpeg.org/ffmpeg-all.html#deshake
[15:01:28 CET] <JEEB> glhf
[15:04:06 CET] <TuxOholic> JEEB: I've been through most of these parameters (zoom/optzoom in particular) and the did not help much
[15:04:55 CET] <JEEB> also for debugging why something doesn't work too well the output is often much less useful than your input
[15:07:06 CET] <JEEB> you might possibly be helped by making an issue with the source @ the trac, but it could just be that the filters are just bad with whatever you're throwing at them
[15:08:53 CET] <TuxOholic> i've seen several youtube videos where it worked quite okay, but my dash cam videos just don't improve in the same way
[15:09:58 CET] <JEEB> how do you know that those videos went through the same filter chain?
[15:09:58 CET] <TuxOholic> I might try filing a mailing list question after I've uploaded a sample to upload.ffmpeg.org
[15:11:07 CET] <TuxOholic> I havw two videos before/after > downloaded before and followed the OP's recommended parameters and I got good results similiar with them th OP has got
[15:11:20 CET] <JEEB> ok
[15:12:17 CET] <TuxOholic> okay thank you , bye ...
[15:21:18 CET] <ghartz> hi
[15:35:43 CET] <ghartz> since version 3, I can't anymore use "http source file" as input for the concat protocol
[15:36:07 CET] <ghartz> the following error is pop-up: Protocol not on whitelist 'concat,file,subfile'!
[15:36:09 CET] <dystopia_> yeah lots of things broke in v3 :|
[15:36:13 CET] <ghartz> :(
[15:36:32 CET] <dystopia_> im using old versioin for http stuff, and v3 for encoding
[15:36:47 CET] <ghartz> I was able to "-i "concat:http://<my url>|http://<url2..>"
[15:37:25 CET] <ghartz> dystopia_, there are doing something about that or they don't care ?
[15:37:47 CET] <ghartz> using "http" as source file is not really an exotic usecase
[15:41:20 CET] <durandal_1707> because it is security issue, set whitelist
[15:41:45 CET] <ghartz> I tried but don't understand which value I should set
[15:42:00 CET] <durandal_1707> its selfrevelating if you have enough IQ
[15:42:06 CET] <ghartz> ....
[15:42:12 CET] <ghartz> really ?
[15:43:27 CET] <durandal_1707> -protocol_whitelist
[15:43:31 CET] <ghartz> yep
[15:44:15 CET] <ghartz> I already found this argument but when I set to -protocol_whitelist http still not working
[17:01:44 CET] <durandal_1707> ghartz: you need to add all protocols nit just one
[17:04:48 CET] <ghartz> durandal_1707, "all" is not working, nor "concat,http"... I ended up by comment the line https://github.com/FFmpeg/FFmpeg/blob/fe3fed0b143ef6bf2d9b65ce05d55aba4224429e/libavformat/concat.c#L196
[17:04:54 CET] <ghartz> and it's working fine..
[21:05:50 CET] <Fyr> guys, has anybody compared quality of ffmpeg AAC and Fraunhofer AAC?
[21:06:04 CET] <Fyr> or QAAC?
[21:06:44 CET] <Mavrik> I think there are some graphs in the ticket
[21:06:55 CET] <Mavrik> FDK is still better in quite a few cases.
[21:07:03 CET] <Fyr> oh
[21:08:06 CET] <JEEB> Mavrik: the general consensus with the latest master is that you might as well use ffaac for LC-AAC and fdk-aac in case of HE-AAC needs
[21:08:16 CET] <Mavrik> mhm
[21:08:46 CET] <JEEB> of course if you've already got systems in production with fdk-aac it's not something you have to change right away
[21:09:07 CET] <JEEB> just that if you're setting up new things you might not need fdk-aac for LC-AAC any more
[00:00:00 CET] --- Mon Feb 22 2016

More information about the Ffmpeg-devel-irc mailing list