[Ffmpeg-devel-irc] ffmpeg.log.20160228

burek burek021 at gmail.com
Mon Feb 29 02:05:01 CET 2016

[00:43:57 CET] <postmodern> is it possible to join multiple mkv files together which have different aspect ratios and resolutions?
[00:44:28 CET] <wiak> would think so yes
[00:44:53 CET] <wiak> but dunno
[01:00:53 CET] <postmodern> hmm, trying to figure out how i can tell the player that the aspect ratio changes in the middle of the mkv
[01:01:26 CET] <postmodern> mpv seems to default to using the container aspect ratio, which stretches or squeezes the image
[01:01:39 CET] <postmodern> first mkv is 16:9 and the others are 4:3
[01:01:45 CET] <JEEB> make sure the parameter sets are taken into mention
[01:01:54 CET] <JEEB> poke #mpv for mpv specifics
[02:15:15 CET] <Nanashi> Hahahahaha I found it. It contained gamma metadata which made it a little brighter than the screenshots I find online since they have it stripped.
[02:15:39 CET] <Nanashi> (pains me as a man of consistency though)
[03:30:15 CET] <logic_> hello
[03:30:21 CET] <logic_> i need some help
[03:31:27 CET] <logic_> ffmpeg -i LJ3.wmv -vcodec copy -acodec copy LJ3.mkv
[03:31:43 CET] <logic_> how do i convert the audio to AAC 128kb?
[03:31:50 CET] <logic_> instead of copying the audio stream
[03:38:16 CET] <Nanashi> -c:a aac -b:a 128k
[03:39:05 CET] <Nanashi> more information: https://trac.ffmpeg.org/wiki/Encode/AAC
[05:01:54 CET] <kevmitch_> according to http://pastebin.com/Bay9wetL
[05:02:03 CET] <kevmitch_> ignore that
[07:05:34 CET] <Jesperhead> Hello all, trying to record my desktop with ffmpeg using the test example: ffmpeg -video_size 1366x768 -framerate 25 -f x11grab :0.0 output.mp4 only to receive a null error stating "Requested output format 'x11grab' is not a suitable output format" I appreciate any assistance while I continue googling this.
[07:29:48 CET] <Jesperhead> additional note I omitted: ":0.0: Invalid argument" is one line below the earlier noted error message
[07:38:15 CET] <Jesperhead> ffmpeg's suggested string was not suitable for my linux distribution
[07:38:36 CET] <Jesperhead> i tried a test string from arch's wiki and all appears to work. Thank you all for.. listening?
[08:17:15 CET] <LJHSLDJH1DLJH> how to know the codecs info of a .webm file under ubuntu?
[08:18:07 CET] <furq> ffprobe
[08:18:28 CET] <LJHSLDJH1DLJH> I can't seek (forward / backward)
[08:18:50 CET] <LJHSLDJH1DLJH> tried to cut but this is the error I get pastebin.com/pK9CPaq7
[08:19:30 CET] <furq> av_interleaved_write_frame(): No space left on device
[08:20:43 CET] <LJHSLDJH1DLJH> furq: yeah but it doesn't make any sense to me
[08:21:01 CET] <LJHSLDJH1DLJH> what that supposed to mean and how to fix it?
[08:21:23 CET] <furq> it means your disk is full
[08:26:01 CET] <LJHSLDJH1DLJH> stupid me :((
[08:26:05 CET] <LJHSLDJH1DLJH> thanks furq
[08:26:26 CET] <LJHSLDJH1DLJH> but still the same problem of not able to play this file properly
[08:26:59 CET] <LJHSLDJH1DLJH> I actually was able to play with mplayer from command line but it crashes at certain point
[08:27:11 CET] <LJHSLDJH1DLJH> then it's possible to forward or backword
[12:51:16 CET] <Polochon_street> hi! I'm trying to decode songs into an array, but sometimes I have extra zeroes in it, and I don't know why...
[12:51:40 CET] <Polochon_street> I'm allocating an array of size int8_t, as described here http://pastebin.com/DReryLar
[12:52:30 CET] <Polochon_street> I use a while(av_read_frame(context, &avkpt)), and sometimes, it seems that I receive « extra frames » (I don't know why), and I must realloc my sample array
[12:53:31 CET] <Polochon_street> I think that's where my extra zeros come from, but I don't know how to avoid it... How can I have more samples than duration*sample_rate*nb_bytes_per_samples*channels/AV_TIME_BASE ?
[12:54:40 CET] <Polochon_street> (here's the full code: https://github.com/Polochon-street/bliss/blob/63bede0e4d6f0ab0caa22ab49f1f720f3c532048/src/decode.c)
[15:21:19 CET] <Polochon_street> okay, I solved my problem. Turns out getting the number of samples via a duration computation is good to approximate, but not to determine the exact number
[15:23:46 CET] <grublet> Polochon_street: afaik the duration thing will always be innacurate to some degree
[17:33:56 CET] <YaMoonSun> I should be able to record my screen and main audio output using ffmpeg and output as HEVC right?
[17:41:41 CET] <kepstin_> YaMoonSun, in theory yeah, but you have to have a really fast computer or use really low-quality settings to get realtime hevc encoding.
[17:45:57 CET] <YaMoonSun> I was using an application on ubuntu once that allowed me to record the screen and it would output it as a massive .avi, I think it was muxing the screen capture. Can I do that and then just convert to hevc later?
[17:46:20 CET] <YaMoonSun> windows currently
[17:47:29 CET] <furq> sure
[17:48:55 CET] <kepstin_> couple options - if you've got a lot of disk space, you could use a video codec like ffvhuff; if not, try x264 with a fast profile; could also try a hardware encoder (nvenc?) and just use a really high bitrate.
[17:50:02 CET] <furq> if you want a massive uncompressed screen capture then use rawvideo
[17:50:45 CET] <kepstin_> rawvideo can be fun tho; your bottleneck is often the speed of your hard drive writing :)
[17:51:04 CET] <YaMoonSun> If I use that to record let's say an hour, what do you think the output size will be?
[17:51:34 CET] <furq> depends on the resolution
[17:51:40 CET] <YaMoonSun> I've got the samsung 840 evo, speed is no problem, but size is 250gb
[17:51:41 CET] <furq> unless "massive" is specific enough
[17:51:53 CET] <YaMoonSun> 1080p
[17:52:51 CET] <furq> what framerate
[17:53:36 CET] <furq> at 60fps that'd be close to 700GB
[17:53:41 CET] <furq> unless i've forgotten how to work this out
[17:53:57 CET] <furq> assuming you use yuv420, rgb would be even bigger
[17:54:18 CET] <YaMoonSun> well ffs
[17:54:44 CET] <YaMoonSun> I'd need x4 1tb drives on raid 0
[17:54:48 CET] <furq> you could use a fast hevc profile but then there isn't much point using hevc over avc
[17:55:24 CET] <YaMoonSun> Quite disappointing.
[17:55:30 CET] <YaMoonSun> Thanks for the input
[17:55:46 CET] <furq> there are lossless codecs if you specifically want to use hevc
[17:57:23 CET] <furq> but unless you have a specific requirement to use hevc then i'd just stick with x264
[17:57:37 CET] <furq> x265 is overrated anyway
[17:58:34 CET] <YaMoonSun> Not even
[17:59:25 CET] <tp__> its not overrated for 4K
[18:13:16 CET] <anddam> i have a 1280x720 video that I want to rescale vertically to a 480p size, I tried -vf scale=-1:480 as in https://gist.github.com/anddam/3ccf9893b7a1b2d38931 but I'm getting "Error while opening encoder for output stream #0:0 - maybe incorrect parameters such as bit_rate, rate, width or height"
[18:13:29 CET] <anddam> how can I check what the incorrect parameter is?
[18:13:48 CET] <BtbN> read what it outputs
[18:13:49 CET] <furq> [libx264 @ 0x7fb2a2830e00] width not divisible by 2 (853x480)
[18:43:07 CET] <anddam> oh, that line I missed
[18:43:51 CET] <anddam> actually I didn't _need_ 480p but the 720 point was a bit higher for an old ipad that was skipping frames so I wanted to scale it
[18:47:00 CET] <anddam> I went for a close 864:486
[18:47:16 CET] <anddam> thanks
[18:50:52 CET] <jackhold>  hej anyone that could help me with a little problem i got trying to send udp stream and capture pictures every 30sek from a webcam??
[18:52:11 CET] <anddam> mmm "[mp4 @ 0x7fb2e5000000] Application provided invalid, non monotonically increasing dts to muxer in stream 2: 575609 >= 513977 av_interleaved_write_frame(): Invalid argument"
[18:52:57 CET] <anddam> I figure that's stream in input file
[18:54:25 CET] <firewated> i had a similar problem with an iPad, just re-encoding the audio to 2 channel aac and copying the video stream into an mp4 gave me smooth playback
[18:54:57 CET] <YaMoonSun> -i "Input.mov" -vf scale=-2=480 -c:v libx264 -b:v 2M -c:a copy "Output.mp4" ?
[18:55:42 CET] <anddam> what does -2 mean in the scale argument?
[18:55:56 CET] <furq> same as -1 but mod2
[18:56:27 CET] <anddam> furq: I cannot find mod2 in the man page
[18:56:51 CET] <anddam> firewated: I'll try, why 2 channels?
[18:57:14 CET] <anddam> I got a lot of
[18:57:16 CET] <anddam> [mp4 @ 0x7f9343820c00] Non-monotonous DTS in output stream 0:1; previous: 13412354, current: 13412344; changing to 13412355. This may result in incorrect timestamps in the output file.
[18:57:45 CET] <anddam> this is the audio stream, I worked around the previous error on stream 2, that was subtitle, by just stripping it out
[18:58:52 CET] <YaMoonSun> Sounds like it's being a dingleberry. Are you using the latest build?
[18:59:06 CET] <firewated> I can't remember if there was a specific reason, does the iPad have more than 2 speakers?
[18:59:40 CET] <firewated> Also, does the mp4 container event support DTS?
[18:59:46 CET] <firewated> even*
[19:02:15 CET] <jackhold> Why do this just overwrite the output and not auto incrementing??  ffmpeg -v info -r 25 -s 1280x720 -f video4linux2 -vcodec mjpeg  -i /dev/video1 -f image2 -r 1/30 ~/indput/out%20d.png -vcodec copy -f mjpeg udp://test.eu:33333
[19:05:37 CET] <anddam> YaMoonSun: nope
[19:05:54 CET] <anddam> firewated: I think the iPad has just the one speaker
[19:06:09 CET] <firewated> So why do you want DTS audio
[19:10:06 CET] <anddam> I don't, I don't even know what that is
[19:10:37 CET] <anddam> I'm just copying the audio stream to avoid recoding
[19:13:18 CET] <firewated> try this: ffmpeg -i in.mkv -c:s mov_text -ac 2 -b:a 320K -c:v copy out.mp4
[19:18:26 CET] <eksrow> Hi, i'm using the overlay filter to slide an image across a video(with overlay=x=-'(t*20) - 50') and it's working great. but the animation looks 30fps ish while the framerate of the video itself is 60. is it possible to get this animation to 60?
[19:44:28 CET] <kepstin> eksrow: that should be recalculated every frame. Perhaps make sure both inputs to the overlay filter are the same framerate?
[20:09:39 CET] <eksrow> kepstin: good to know it's possible, i'l keep trying. each input has -r 60, that should be correct right?
[20:12:01 CET] <anddam> firewated: lots of those "Non-monotonous DTS in output stream 0:1; " then again the error "Application provided invalid, non monotonically increasing dts to muxer in stream 2: 575609 >= 513977 av_interleaved_write_frame(): Invalid argument"
[20:13:19 CET] <firewated> can you post the full output from ffmpeg, i don't see how DTS is getting to the output, it should be getting re-encoded
[20:21:08 CET] <anddam> sure, give one moment
[20:23:48 CET] <anddam> it's _very_ long
[20:23:59 CET] <anddam> I figure you just want to see the start and the end
[20:24:16 CET] <firewated> sure, in a gist
[20:28:53 CET] <anddam> https://gist.github.com/anddam/3ccf9893b7a1b2d38931 updated
[20:29:47 CET] <anddam> notice the massive "[mp4 @ 0x7fb0bb01fa00]" starting line cut at L105
[20:30:58 CET] <firewated> hmm your input audio is aac, not sure why there's references to DTS at all
[20:33:34 CET] <furq> firewated: decoding timestamp
[20:34:36 CET] <firewated> oh, right
[20:34:51 CET] <firewated> ffmpeg version is recent too, not sure
[20:35:03 CET] <furq> anddam: try -fix_sub_duration as an input option
[20:39:42 CET] <firewated> and you probably don't need to re-encode the audio either as it's already aac
[20:45:02 CET] <anddam> "ffmpeg -y -fix_sub_duration -i in.mkv -c:s mov_text -c:a copy -c:v copy out.mp4" results in the same error
[20:45:10 CET] <anddam> [mp4 @ 0x7f9159802600] Application provided invalid, non monotonically increasing dts to muxer in stream 2: 573373 >= 513977
[20:45:18 CET] <anddam> av_interleaved_write_frame(): Invalid argument
[20:45:58 CET] <anddam> I'm halfway scaling the video anyway
[20:46:49 CET] <firewated> do you also still get the timestamp out of range messages?
[20:49:58 CET] <anddam> not with the rescale, I dropped the sub stream, copied the audio and rescaled video using libx264,
[20:51:36 CET] <firewated> may be because of the sub stream
[20:55:30 CET] <jookiyaya> anybody here? mirc
[21:10:34 CET] <anddam> what does that even mean?
[00:00:00 CET] --- Mon Feb 29 2016

More information about the Ffmpeg-devel-irc mailing list