[Ffmpeg-devel-irc] ffmpeg.log.20180121

burek burek021 at gmail.com
Mon Jan 22 03:05:02 EET 2018

[00:04:10 CET] <relaxed> SilenceDogood: maybe, -disposition:a:0 0 -disposition:a:1 default
[00:09:13 CET] <SilenceDogood> relaxed doesn't work
[00:09:15 CET] <SilenceDogood> :(
[00:11:14 CET] <relaxed> does it now list the stream as default?
[00:11:28 CET] <relaxed> pastebin the command and output
[00:14:33 CET] <SilenceDogood> ffmpeg -i oz.mkv -f concat -i floyd-loop.txt -map 0:v -map 1:a -map 0:a -c:v copy -c:a:0 aac -c:a:1 copy -shortest -metadata:s:v:0 stereo_mode=1 -metadata:s:a:0 language=eng -metadata:s:a:0 title="Pink Floyd: The Dark Side of the Moon Immersion Edition (2011) 5.1 Surround Mix" -metadata:s:a:1 title="The Wizard of Oz 3D (2013) 5.1 Surround Mix" -metadata title="The Dark Side of Oz 3D" -disposition:a:0 default -disposition:a:1 0 -
[00:14:40 CET] <SilenceDogood> That's the command
[00:15:14 CET] <SilenceDogood> VLC opens with the Wizard of Oz video default
[00:15:28 CET] <SilenceDogood> I meant audio
[00:15:36 CET] <SilenceDogood> VLC opens with the Wizard of Oz audio by default
[00:15:45 CET] <SilenceDogood> However, MPV opens with the Pink Floyd audio by default like it's supposed to.
[00:16:35 CET] <relaxed> that's becuase mpv is a much better player
[00:17:05 CET] <relaxed> *because
[00:17:22 CET] <SilenceDogood> OK
[00:17:27 CET] <SilenceDogood> now what about subtitles
[00:17:40 CET] <SilenceDogood> I want it to come with the subtitles from the Wizard of Oz 3D blu ray
[00:18:44 CET] <SilenceDogood> They come out as SUB files from mkvtoolnix
[00:19:02 CET] <SilenceDogood> but when I try to name them filename.English.sub, they don't show up
[00:20:19 CET] <SilenceDogood> I'm probably encountering the same problem as this guy https://ffmpeg.zeranoe.com/forum/viewtopic.php?f=17&t=4846
[00:23:44 CET] <relaxed> add -i subtitles.sub and after all the inputs -disposition:s:0 default
[00:25:48 CET] <relaxed> oh, and -c:s copy
[00:35:24 CET] <SilenceDogood> relaxed, no, that doesn't work. this was discussed earlier in the channel
[00:36:02 CET] <SilenceDogood> ffmpeg has some kind of bug where it only supports certain kinds of subtitles
[00:36:20 CET] <SilenceDogood> if you try to direct copy subtitle streams which ffmpeg doesn't support, it screws up the audio
[00:36:30 CET] <JEEB> uhh I don't know how you read into that
[00:36:41 CET] <JEEB> I told you that it might be broken input, or a bug in FFmpeg
[00:36:52 CET] <JEEB> the format itself was supported just fine
[00:38:03 CET] <manuelg> I've tried to make a 2x2 mosaic here, anyone know what I've done wrong? https://imgur.com/a/rzGFb
[00:38:13 CET] <SilenceDogood> JEEB, well I know the input's fine
[00:38:26 CET] <JEEB> no you don't
[00:38:28 CET] <SilenceDogood> or at least as much as I can know, since you haven't specified any way to test for errors
[00:38:46 CET] <SilenceDogood> I can watch the movie with subtitles in oz.mkv and they show up fine.
[00:39:25 CET] <manuelg> ffmpeg command I used: https://pastebin.com/K7t6qQQ1
[00:39:33 CET] <JEEB> you can check the timestamps of packets in a track with mkvinfo (for matroska) or ffprobe -show_packets -show_streams -show_format -of json FILE
[00:39:39 CET] <JEEB> if you really want to start going into that
[00:39:52 CET] <JEEB> but I guessed you are just not interested in actually looking at if everything else is just ignoring broken data
[00:39:57 CET] <JEEB> or if it's a bug in FFmpeg
[00:40:39 CET] <JEEB> also if you have a relevant sample (can be just the subtitles) then please just report a bug with the sample; in the worst case you will just get told that your sample is broken
[00:40:53 CET] <SilenceDogood> OK I want to look into that
[00:41:06 CET] <SilenceDogood> But I got no errors going from MakeMKV to BD3D2MK3D to that mkv
[00:41:12 CET] <JEEB> well d'uh
[00:41:44 CET] <JEEB> the latter could just fine be ignoring those things and makemkv of course wouldn't be noting anything if for it it's "everything as usual"
[00:42:03 CET] <JEEB> but at this point without any extra info it can be either a broken sample or a bug, that one I'm not going one way or another
[00:42:39 CET] <JEEB> thus if you don't want or cannot look into it further you can use something to separate just the subtitle track, and then check if the same thing happens with the separated subtitle track as well
[00:42:50 CET] <JEEB> (or if you want you can just cut the first 100MiB of your mkv or something)
[00:43:02 CET] <JEEB> as long as it has enough data to make the issue happen
[00:43:22 CET] <SilenceDogood> JEEB OK. Where would I send the data?
[00:44:23 CET] <JEEB> there's an FTP for that stuff IIRC, but I never remember the credentials to it :P so in my opinion you could just upload the sample somewhere sane (doesn't require registration or multiple hoops or contain malware)
[00:44:32 CET] <JEEB> and then link that over at the issue tracker (trac.ffmpeg.org)
[00:44:35 CET] <SilenceDogood> OK
[00:45:28 CET] <SilenceDogood> I will do that soon, thank you.
[00:45:33 CET] <manuelg> JEEB are you able to take a look at my issue? i would appreciate the help :)
[00:46:07 CET] <SilenceDogood> OK I've gotta go do other stuff. Thanks JEEB, furq, everyone who helped. :)
[00:47:46 CET] <furq> manuelg: use hstack and vstack
[00:49:04 CET] <furq> [0:v][1:v]vstack[l];[2:v][3:v]vstack[r];[l][r]hstack[out]
[00:49:14 CET] <furq> you'll probably need to setpts them all separately before that
[00:49:31 CET] <manuelg> do you need to setpts if they're mjpegs?
[00:49:39 CET] <furq> that has nothing to do with it
[00:49:43 CET] <manuelg> i'm not sure i understand what i'm actually doing haha
[00:49:50 CET] <furq> but if these are network streams then the pts values will probably be desynced
[00:50:02 CET] <manuelg> okay
[00:50:06 CET] <manuelg> I'll try h/vstack
[00:50:08 CET] <furq> i mean you can try it without that and see if it works
[00:50:31 CET] <manuelg> i'll give it a try
[00:50:39 CET] <furq> nullsrc[n];[0:v][1:v]vstack[l];[2:v][n]vstack[r];[l][r]hstack[out]
[00:50:48 CET] <furq> i didn't notice you only actually have three inputs
[00:50:58 CET] <manuelg> Yeah
[00:51:07 CET] <manuelg> Oh wait
[00:51:14 CET] <manuelg> I had a filter turned on in VLC
[00:51:49 CET] <manuelg> okay - the file renders fine... but I get "stream number does not match registered feed" on ffserver
[00:52:04 CET] <furq> oh, ffserver
[00:52:12 CET] <furq> good luck getting help with that, it's basically unsupported at this point
[00:52:22 CET] <furq> and it's actually been removed from 3.4 onwards iirc
[00:52:28 CET] <manuelg> ah.
[00:52:33 CET] <manuelg> is there any replacement?
[00:52:41 CET] <furq> not in ffmpeg
[00:52:52 CET] <relaxed> ffmpeg can stream, correct?
[00:52:55 CET] <JEEB> there are various media servers that handle actual streaming, like nginx-rtmp
[00:52:56 CET] <furq> if you just need any streaming server then most people in here are using nginx-rtmp for that now
[00:53:06 CET] <furq> if you specifically need rtsp or something then i wouldn't know what to recommend
[00:53:07 CET] <JEEB> FFmpeg can feed streaming servers or output UDP streams etc
[00:53:30 CET] <manuelg> i haven't got any need for a specific protocol, just something that vlc can play really
[00:53:37 CET] <furq> yeah nginx-rtmp will do a fine job then
[00:53:48 CET] <manuelg> i'll have a look at nginx
[00:53:53 CET] <manuelg> thank you!
[00:54:00 CET] <furq> the rtmp module isn't builtin so you'll need to build nginx yourself
[00:54:06 CET] <furq> it's not too difficult though
[00:54:27 CET] <manuelg> damn, there's not just a nice package I can install?
[00:54:36 CET] <furq> unless they finally got the dynamic module thing figured out
[01:08:56 CET] <relaxed> manuelg: is this only for your local network?
[01:10:21 CET] <manuelg> Yeah
[01:11:12 CET] <relaxed> oh! then write a script that uses mpv to play the streams
[01:12:13 CET] <relaxed> it can use ffmpeg's filters too, so you can achieve the same thing
[01:12:21 CET] <manuelg> sadly i cant install mpv on the clients
[01:13:20 CET] <manuelg> my plan is to just distribute a single link to those that need it, to enter into vlc
[01:13:41 CET] <furq> yeah if this is for multiple users then you'll need a server
[01:13:52 CET] <manuelg> it is on a server
[01:14:11 CET] <furq> i meant a streaming server
[01:14:16 CET] <furq> ffmpeg itself is very unsuitable for that
[01:14:22 CET] <relaxed> streaming rtp wouldn't work?
[01:14:41 CET] <furq> can that server multiple clients
[01:14:43 CET] <furq> serve
[01:14:55 CET] <relaxed> good question, I don't know
[01:14:59 CET] <furq> all of ffmpeg's server stuff will only serve one client afaik
[01:15:06 CET] <furq> and then kill the process when they disconnect
[01:15:39 CET] <manuelg> ffserver seemed to do it, although if its unsupported I'd rather not use it
[01:16:20 CET] <relaxed> ffmpeg + nginx-rtmp is probably the way to go
[04:05:15 CET] <hiihiii> hello
[04:05:25 CET] <hiihiii> is any one here on a windows machine
[04:06:40 CET] <hiihiii> I'm trying to setup ffmpeg to be a invoked as an encoder in programs screen capturing programs like hypercam and whatnot
[04:07:24 CET] <hiihiii> I'm aware that ffmpeg on itself can capture desktop
[04:07:48 CET] <hiihiii> but I'm wondering if I can do it the other way that would be better
[04:08:23 CET] <BtbN> Just use OBS?
[04:09:05 CET] <hiihiii> I'm sorry I didn't want to make the question longer but I think I might need to
[04:09:35 CET] <BtbN> There is absolutely no reason to deal with hypercam and stuff, OBS does it better and is free
[04:12:05 CET] <hiihiii> what I really wan't is to be able to invoke ffmpeg as an encoder from within another program similarly to "ffdshow VFW", "Xvid", "x264 VFW", etc on OBS and Heypercam
[04:13:02 CET] <hiihiii> I have an simulator in which I need to capture the output without frame loss and with 60fps
[04:13:40 CET] <BtbN> OBS uses ffmpeg/x264 as a library. It does not invoke a commandline utility.
[04:14:09 CET] <hiihiii> oh, can you configure it with a command line?
[04:14:16 CET] <BtbN> what?
[04:14:34 CET] <hiihiii> I mean can it axcept additional options/filters in its gui
[04:14:54 CET] <BtbN> to some very limited degree
[04:15:07 CET] <BtbN> it does not mimic full ffmpeg.c
[04:15:11 CET] <hiihiii> so can I set something like -vsync 1
[04:15:45 CET] <hiihiii> anyway OBS is not an option because I can't use that with the simulator
[04:16:01 CET] <BtbN> why not? It can capture pretty much everything
[04:16:27 CET] <hiihiii> but it runs as a separate process
[04:17:28 CET] <hiihiii> the simulator has that window which lets you pick an encoder and that runs hand in hand with the simulator
[04:17:33 CET] <c3r1c3-Win> Why is that an issue? (Also wouldn't ffmpeg run as a separarte process as well?)
[04:18:04 CET] <c3r1c3-Win> Hmm...interesting.
[04:20:16 CET] <hiihiii> i.e. the simulator outputs the result as frame(image) then waits for the encoder to do its thing before rendering the next frame
[04:20:49 CET] <hiihiii> I can't run the simulator and a screen capturing program separately
[04:21:20 CET] <hiihiii> but I also don't get quite the results that I wan't from the video output I get
[04:21:33 CET] <hiihiii> they are 59.18fps
[04:21:51 CET] <hiihiii> and I'm not sure how many frame were duplicated or dropped
[04:23:08 CET] <hiihiii> and these encoders are old with not much options
[04:37:48 CET] <hiihiii> in other words can I list ffmpeg as one of windows' encoders in the "video compression" window drop list https://i.imgur.com/GoZl5rf.png
[04:39:15 CET] <hiihiii> when you click configure you get to set other stuff https://i.imgur.com/CfuV11N.png
[06:21:34 CET] <Fyr> guys, is it possible to sort metadata? I see title, NUMBER_OF_FRAMES, BPS etc. I want: title, DURATION, NUMBER_OF_FRAMES, NUMBER_OF_BYTES etc.
[07:08:30 CET] <ddubya> has cuda, nvenc, opencl been dropped, I don't see the options anymore in ./configure
[07:10:58 CET] <ddubya> nvm wrong branch doh
[07:47:01 CET] <Sean5512> Hello wondering if anybody can help me with a quick newbie question re: ffmpeg and homebrew. I need to reinstall ffmpeg with ssl support. I was told to use "brew reinstall ffmpeg --with-openssl" but does this erase all of my other settings?
[08:10:50 CET] <Fyr> JEEB, long time ago you showed a snippet in which you added too much options to FFMPEG. were you using bash?
[08:11:37 CET] <Fyr> I need FFMPEG to process >8192 characters and I'm stuck in Windows CMD/PowerShell command line limit.
[08:11:44 CET] <Fyr> sometimes it expands, though.
[08:12:23 CET] <Fyr> I tried ffmpeg $(Get-Content parameters.txt)
[08:12:55 CET] <Fyr> it works, only returns fucked up codepage.
[09:30:39 CET] <garyserj> why does this ffmpeg -ss 192 -i inputfile.mp4 -c copy -t 1 output3.mp4    <-- creates a file that is 6 seconds long!
[09:32:30 CET] <furq> garyserj: -c copy cuts the video stream at the closest keyframes
[09:33:14 CET] <garyserj> it's a video of a sports game.. there are lots of frames a second!
[09:37:09 CET] <garyserj> I guess maybe I don't understand the difference between frames and keyframes?
[11:13:28 CET] <cousin_luigi> Greetings.
[11:13:40 CET] <cousin_luigi> What are the plans for the next release?
[11:15:13 CET] <furq> https://github.com/FFmpeg/FFmpeg/blob/master/Changelog#L4
[11:15:48 CET] <cousin_luigi> I'll rephrase the question: what are the blockers for 3.5 ?
[13:06:58 CET] <foo> If I want to get the highest quality audio from a video, in mono, is this what I want? ffmpeg -i native.mp4 -ac 1 mono.flac
[13:25:17 CET] <BtbN> Just use -c copy
[13:25:26 CET] <BtbN> There is no point in re-encoding lossy audio as something lossless
[13:25:32 CET] <BtbN> the lost information won't come bac
[13:25:35 CET] <BtbN> k
[13:27:26 CET] <furq> i don't think that works if you want to downmix to mono
[13:29:36 CET] <foo> hmm, throws Could not write header for output file #0 (incorrect codec parameters ?): Invalid argument with ffmpeg -i native.mp4 -c copy -ac 1 mono.flac
[13:29:46 CET] <foo> BtbN / furq - thanks for chiming in :)
[13:32:45 CET] <BtbN> Why downmix to mono though? If you re-encode mono to flac it's most likely going to end up WAY bigger than the original stereo or whatever
[13:33:07 CET] <BtbN> So just keeping the original encode and letting the player downmix to mono if it needs to is still better
[13:33:11 CET] <foo> BtbN: The API I'm passing this to requires mono :(
[14:08:23 CET] <Fyr> guys, when muxing with MKVToolnix, it adds so much metadata, like BPS, NUMBER_OF_FRAMES etc. what are they for?
[14:08:51 CET] <Fyr> I don't know which players use those data.
[14:09:05 CET] <JEEB> that's a really good question, since as it's just metadata you can't really trust it
[14:09:21 CET] <JEEB> for frames you can just parse the clusters
[14:09:37 CET] <Fyr> yes, moreover, this toolset can't find the right data.
[14:10:00 CET] <Fyr> MKVToolnix doesn't set the right FPS for VC-1.
[14:10:34 CET] <JEEB> do remember that currently matroska can't handle a lot of frame rates (such as the /1001 ones) exactly
[14:10:35 CET] <Fyr> it sets it to 24 .05, while it's really 24000/1001. =)
[14:10:49 CET] <JEEB> but yes, as it should be the average 24.05 sounds weird
[14:11:08 CET] <JEEB> not that I know how mkvtoolnix calculates it
[14:11:17 CET] <JEEB> effectively everything sane ignores that metadata
[14:11:27 CET] <JEEB> at most passing it through "because it's metadata"
[14:11:31 CET] <JEEB> (as metadata)
[14:15:34 CET] <JEEB> I hear people are finally adding a fractional number type into matroska which would fix the /1001 stuff I'd say
[14:24:49 CET] <Fyr> can FFMPEG make use of chapters in xml?
[14:25:19 CET] <JEEB> nope
[14:25:30 CET] <Fyr> =(
[14:25:30 CET] <Fyr> the toolnix keep the chapters in this format, it would be wonderful if FFMPEG can reading when muxing.
[14:25:51 CET] <JEEB> I mean, the first XML parser usage in FFmpeg was added with the DASH "demuxer" some time ago :P XML parsing in general tends to be messy so people generally keep away from it
[14:26:16 CET] <JEEB> but sure, if someone puts in a patch for ffmpeg.c implementing that it might get accepted
[14:26:33 CET] <JEEB> the matroska specifics in there are a thing, though
[14:26:49 CET] <JEEB> since it's actually the virtual timeline that can have segment links etc
[14:28:42 CET] <Fyr> JEEB, do you have Linux on your workstation?
[14:29:07 CET] <Fyr> I was stuck in 8192-characters limit on Windows.
[14:29:16 CET] <JEEB> at home I use windows and then use a linux vm for development purposes
[14:29:38 CET] <Fyr> I had to install a Linux onto VM to mux a file.
[14:30:09 CET] <Fyr> can FFMPEG read parameters from a file?
[14:30:17 CET] <JEEB> ffmpeg.c you mean
[14:30:24 CET] <Fyr> =(
[14:30:27 CET] <JEEB> dunno :P
[14:30:30 CET] <JEEB> probably not
[14:30:52 CET] <JEEB> anyways, this seems to be the limit you're hitting https://support.microsoft.com/en-us/help/830473/command-prompt-cmd--exe-command-line-string-limitation
[14:31:01 CET] <Fyr> yes
[14:32:04 CET] <Fyr> using PowerShell I can add ininite options, however, it doesn't fully support UTF-8.
[16:17:08 CET] <OneSploit> I am trying to recompile ffmpeg with the same parameters as Debian had, plus enabled nvenc but I get error ERROR: libiec61883 not found
[16:17:16 CET] <OneSploit> though libiec61...dev is installed
[16:17:18 CET] <OneSploit> any help?
[16:18:57 CET] <JEEB> see ffbuild/config.log
[16:19:11 CET] <OneSploit> nvm error message was not correct config.log pointed the missing library
[16:19:18 CET] <OneSploit> JEEB: yes, thanks :)
[16:22:33 CET] <b0bby__> hello
[16:23:26 CET] <b0bby__> I have a complex filter that does some stuff with a video and and image(no audio stuff) but I need to map the audio stream from input 1 to my output. How should I do this??
[16:24:37 CET] <OneSploit> JEEB: test.c:(.text+0x151d): undefined reference to `cvRound'
[16:24:40 CET] <OneSploit> opencv fails
[16:24:52 CET] <OneSploit> I wonder maybe some version mismatch
[16:25:03 CET] <JEEB> yes, newer opencv versions broke C support IIRC
[16:25:26 CET] <JEEB> not sure if debian patched something to get through that, or just disabled opencv?
[16:26:12 CET] <OneSploit> ah I downloaded from git, but you are right I should download the source with Debian patches and just add extra flags there
[16:27:15 CET] <JEEB> but yea, officially opencv just said that they only support C++ now so C API clients like FFmpeg just broke with new enough versions
[16:28:19 CET] <OneSploit> I just want Nvidia acceleration to stream desktop with ffmpeg
[16:28:32 CET] <OneSploit> suprisingly it seems like something not standard
[16:29:08 CET] <JEEB> if you don't need f.ex. opencv I think it's OK to just disable it :P
[16:29:19 CET] <OneSploit> f.ex ?
[16:29:26 CET] <JEEB> after all, you don't need to replace the kitchen sink FFmpeg binaries
[16:29:35 CET] <JEEB> esp. if you're using the command line thing only
[16:29:48 CET] <OneSploit> I am using simple screen recorder
[16:30:04 CET] <OneSploit> with optirun to preload optimus nvidia 960M
[16:30:24 CET] <OneSploit> if that makes sense to you...
[16:33:53 CET] <OneSploit> seems to be compiling.. will see
[16:35:17 CET] <sfan5> I'd suggest just using OBS
[16:48:25 CET] <OneSploit> dunno if OBS has short keys to start recording and what is worst it crashes at every possible step
[16:49:48 CET] <OneSploit> sfan5: its not build for Debian packages, so probably has some issues no one wanted to package it... I usually stay away from software that cannot be packaged..
[16:52:10 CET] <sfan5> I wouldn't assume that just from the fact that there's no debian package
[16:53:06 CET] <OneSploit> sfan5: I build it and tried it
[16:53:15 CET] <sfan5> besides, there's a PPA for ubuntu; by using debian you're limiting yourself quite severely
[16:53:27 CET] <OneSploit> sfan5: worst experience I ever had so far with open software
[16:54:11 CET] <sfan5> let me guess: it required a newer FFmpeg version, which is absolute hell to get working on debian?
[16:54:29 CET] <therage3> the thing with Debian and its package repos for the stable branch is that everything is woefully outdated
[16:54:33 CET] <OneSploit> sfan5: dunno, it was just crashing when I tried to click wizard or properties
[16:54:44 CET] <therage3> that's why I don't use that distro for non-server scenarios
[16:55:02 CET] <OneSploit> therage3: I am using sid since 1996, no reason to switch to other distro beause some people opinion online
[16:55:10 CET] <Fyr> guys, I'm trying to extract chapters with:
[16:55:10 CET] <Fyr> $ ffmpeg -i video.mkv -f ffmetadata metadata.txt
[16:55:10 CET] <Fyr> I get:
[16:55:10 CET] <Fyr> >>Output file is empty, nothing was encoded
[16:55:18 CET] <Fyr> how to extract the metadata?
[16:55:34 CET] <sfan5> Fyr: use mkvextract for that, much simpler
[16:55:50 CET] <JEEB> yea, but ffmpeg.c doesn't take that in :P
[16:55:57 CET] <sfan5> right
[16:55:59 CET] <JEEB> wow, didn't even know that ffmetadata was a thing
[16:56:02 CET] <JEEB> rip
[16:56:11 CET] <sfan5> what I'd do in this case is write a python script to convert the XML to something else
[16:56:11 CET] <therage3> well, you can see how well it's going for you, OneSploit. I'm just saying, the issue you're having could be due to what I pointed out
[16:56:24 CET] <JEEB> well he's on sid at least
[16:56:28 CET] <JEEB> which is the rolling part
[16:56:34 CET] <OneSploit> openvc was too new
[16:56:49 CET] <therage3> still nowhere near as updated as other rolling releases like Fedora rawhide or Arch-based distros
[16:56:55 CET] <OneSploit> therage3: OBS wasnt' crashing because ffmpeg
[16:56:57 CET] <OneSploit> it was GUI crashing
[16:57:09 CET] <JEEB> yea, opencv just decided they'd drop all of the C API clients
[16:57:12 CET] <therage3> same diff, something else which needed a newer version, perhaps
[16:57:24 CET] <therage3> who knows. I'd run it in CLI and see what error it reports
[16:57:26 CET] <JEEB> and not like anyone maintains the opencv stack in FFmpeg anyways
[16:57:28 CET] <therage3> that helps to debug that
[16:57:46 CET] <JEEB> (some student got the filters in and that's pretty much the end of it)
[16:58:15 CET] <OneSploit> my ffmpeg is still compiling
[16:58:19 CET] <OneSploit> will see how it works
[16:58:27 CET] <therage3> hm
[16:58:28 CET] <OneSploit> just trying to have this nvidia part enabled
[16:59:20 CET] <JEEB> Fyr: but yea no idea about how that thing works or why it told you it had no metadata in the input :P enable -v verbose or so and start checking the logging?
[16:59:32 CET] <Fyr> ok
[17:01:58 CET] <OneSploit> therage3: I came here to get help on compiling ffmpeg and not advices which distro is better ;-)
[17:02:46 CET] <therage3> i'm not telling you which distro is better, i told what could be the root cause of the issue and how to debug your problem.
[17:02:55 CET] <therage3> Use whatever distro you want.
[17:11:27 CET] <OneSploit> JEEB: it compiled with these options with debian patches ! :)
[17:11:29 CET] <OneSploit> and works :)
[17:31:41 CET] <bburky> If I am using an image sequence as input, is there any way I can specify a different crop per frame?
[17:33:08 CET] <bburky> Or the same thing I thing: can I specify frame numbers in a filter?
[17:35:46 CET] <OneSploit> sfan5: h264_nvenc also works just fine with simplescreenrecorder, and that software is at least not crashing in GUI
[17:36:03 CET] <OneSploit> sfan5: I recommend to use it, its really good, much better than OBS
[17:36:14 CET] <sfan5> lmao
[17:37:27 CET] <sfan5> you don't even seem to know what OBS does beyond "screen recording", yet you are convinced that some random application is better
[17:40:50 CET] <OneSploit> sfan5: you should try it out, maybe it's not brewing coffe, but at least it's not crashing and does this simple thing its intended to do, screen recording and screen casting
[17:41:07 CET] <OneSploit> or simply, it just works :)
[17:51:42 CET] <skyfmww> Hello all. Anyone can help with streaming mosaic from 3 ip cameras to youtube?
[17:59:22 CET] <DHE> ffmpeg -i input1 -i input2 -i input3 -filter_complex "[0:v][1:v][2:v]hstack[outvideo]" -map [outvideo]   (codec_options) (youtube_output)
[18:35:01 CET] <bburky> Also, is there any chance image metadata is accessible in from a filter?
[18:36:34 CET] <skyfmww> Thanks for reply. Found that example already but can't manage to put it all together with all that parameters I have for input streams. IPCs have 640x382 on substream while its being detected as 640x360 on ffmpeg/probe that shows garbage in resulting frame
[18:42:47 CET] <skyfmww> This string seems to be working for 1 channel (there's issues YT reporting about stream quality) ffmpeg.exe -f lavfi -i anullsrc -rtsp_transport tcp -i rtsp://stream -t 1:00:00 -pix_fmt yuv420p -profile:v baseline -s 640x386 -bufsize 2048k -vb 500k -maxrate 1000k -deinterlace -c:v libx264 -c:a aac -strict experimental -f flv rtmp://a.rtmp.youtube.com/live2/KEY
[19:23:42 CET] <stsbqm> x265 "preset" behaves differently than described and expected.
[19:24:01 CET] <stsbqm> Until now, I assumed that the Preset option did not change the quality of the result in conjunction with CRF.
[19:24:12 CET] <stsbqm> Only the file size should increase due to reduced compression.
[19:24:20 CET] <JEEB> that's not true for either x264 or x265
[19:24:36 CET] <JEEB> because the presets can change how the encoder "sees" the input
[19:24:46 CET] <JEEB> due to enabling/disabling things as well as changing algorithms
[19:25:01 CET] <JEEB> so you never got the same quality with the same CRF value across presets
[19:25:13 CET] <ddubya> when encoding audio, is it necessary to pad the end with zeros out to a full frame to avoid losing any samples at the end
[19:26:01 CET] <JEEB> audio encoders tend to only take audio frames of a certain sample count
[19:26:09 CET] <JEEB> and bark at you if you push in more or less
[19:26:21 CET] <ddubya> even at end of stream?
[19:26:33 CET] <JEEB> well, any non-null avframe :P
[19:26:38 CET] <JEEB> which you push into an encoder
[19:26:52 CET] <ddubya> ok
[19:27:32 CET] <louisc> I'm trying to stream a cropped section of my screen to an rtmp server using ffmpeg. I've adapted a command I found on the "EncodingForStreamingSites" examples on the ffmpeg wiki, but when I run it, ffmpeg says video filters cannot be applied to input url: https://pastebin.com/nWX173qe
[19:28:20 CET] <JEEB> louisc: your -vf option ends up being applied to the second input because you have an -i INPUT after it
[19:28:52 CET] <JEEB> you should first define all inputs and then give parameters for the first output, and then the output path/url
[19:30:41 CET] <stsbqm> JEEB: But the deviations are considerable and behave exactly the opposite.  See also https://trac.ffmpeg.org/wiki/Encode/H.265 "& The visual quality will be the same."
[19:30:57 CET] <JEEB> that's bullshit then
[19:31:01 CET] <JEEB> it was never true
[19:31:23 CET] <louisc> JEEB: so the order should be like, input 1, input 2, vf 1, vf 2, output?
[19:31:23 CET] <JEEB> same CRF with different presets never gave same visual output nor did it ever promise to do that
[19:31:49 CET] <JEEB> louisc: you can only have one -vf if I recall correctly
[19:32:02 CET] <JEEB> do you only want to apply filtering to specific streams?
[19:32:48 CET] <louisc> I think the -vf on the first line is to crop the screen capture, and the -vf on the third line is to format the libx264 output?
[19:33:00 CET] <JEEB> uhh
[19:33:10 CET] <JEEB> do you only have one video input?
[19:33:17 CET] <JEEB> or is the other one video as well?
[19:33:23 CET] <JEEB> do you want to apply the filters to both?
[19:34:13 CET] <JEEB> if you only have a single video input then you can get through with a single vf chain
[19:34:29 CET] <JEEB> -vf "crop=400:400:0:0,format=yuv420p"
[19:34:47 CET] <louisc> JEEB: -f avfoundation -i "1:1" is my screen and my microphone. the first -vf is for cropping the screen input to a 400x400 box. but yeah, I've kind of just mashed two different scripts together. so now what you're saying makes sense
[19:34:51 CET] <louisc> I can only do one -vf
[19:36:43 CET] <louisc> maybe it's the "-i :0.0+0,0" thing that's throwing it off. I'm not actually sure what that is
[19:37:30 CET] <JEEB> all I see is that you have two inputs there and I was asking if you had a single video input or multiple
[19:37:42 CET] <JEEB> and if you had multiple if you needed to filter only one of them or all of them
[19:37:51 CET] <JEEB> because -vf would apply the video filter to all selected video tracks
[19:38:09 CET] <louisc> JEEB: only wanting a single video input, the screen capture from avfoundation
[19:38:29 CET] <JEEB> ok, then the -vf I posted back there with both crop and the yuv420p'ification should work :P
[19:39:15 CET] <Fyr> guys, ffmpeg ignores metadata from the metadata file.
[19:39:15 CET] <Fyr> https://pastebin.com/Zawy6TvU
[19:39:15 CET] <Fyr> how do I to make him not to?
[19:40:00 CET] <JEEB> didn't you have to specify what to apply -map_metadata to ?
[19:40:41 CET] <Fyr> JEEB, I gave the link to the -report log.
[19:41:09 CET] <JEEB> -map_metadata[:metadata_spec_out] infile[:metadata_spec_in] (output,per-metadata)
[19:41:31 CET] <Fyr> JEEB, what options should I set?
[19:41:34 CET] <JEEB> Fyr: I looked at that but I'm just not sure if that's how it worked
[19:41:50 CET] <JEEB> I've once used that option so don't expect me to remember every little thing in ffmpeg.c by heart :P
[19:41:53 CET] <Fyr> I used the options like in the example from the ofical help.
[19:42:03 CET] <JEEB> https://www.ffmpeg.org/ffmpeg-all.html
[19:42:05 CET] <JEEB> has some examples
[19:42:29 CET] <JEEB> too bad it has no link to the option so I can't link straight to it
[19:44:02 CET] <JEEB> also wasn't map_chapters a separate thing from map_metadata? at least it's the next thing in help
[19:44:15 CET] <JEEB> although as I noted I'm not even sure if you're setting the parameters right to map_metadata
[19:44:28 CET] <JEEB> since I remember it had some funkiness
[19:44:37 CET] <JEEB> regarding which is the input and which is the output
[20:10:06 CET] <GyrosGeier> hi
[20:10:14 CET] <GyrosGeier> I have a stream dump off a DVD
[20:10:31 CET] <GyrosGeier> now I'd like to encode this with a better codec to get better compression
[20:10:43 CET] <GyrosGeier> default settings are useless
[20:11:21 CET] <GyrosGeier> My first thought is to leave the interlacing, and the manual mentions -ilme, but the version in Debian complains about that option
[20:24:22 CET] <furq> GyrosGeier: what do you mean by default settings
[20:26:35 CET] <furq> if you just mean ffmpeg -i foo.mkv bar.mkv then that doesn't do any deinterlacing at all
[20:26:55 CET] <GyrosGeier> yes, and it encodes to ~800kbps
[20:27:18 CET] <furq> well yeah you're going to want to set -crf and -preset
[20:27:19 CET] <GyrosGeier> which doesn't resolve anything finer than a macroblock
[20:28:40 CET] <GyrosGeier> hmm
[20:29:02 CET] <GyrosGeier> what's a sensible preset for 720x480 NTSC?
[20:35:36 CET] <stockstandard> Can anyone in here please help diagnose a problem with ffmpeg? I am trying to set "-preset, ultrafast" but getting the following error: Codec AVOption preset (Configuration preset) specified for input file #0 (/library/Movies/Harry Potter and the Chamber of Secrets (2002)/Harry Potter and the Chamber of Secrets (2002) Bluray-2160p.mkv) is not a decoding option.
[20:36:14 CET] <c_14> put -preset after the input video
[20:36:19 CET] <c_14> (and before the output video)
[20:36:28 CET] <c_14> options go before the things they affect
[20:36:39 CET] <stockstandard> Am using the following script: https://github.com/mdhiggins/sickbeard_mp4_automator/blob/master/README.md with the following command "python /sickbeard_mp4_automator/manual.py -i "/library/Movies/Baywatch (2017)" -a;"
[21:22:35 CET] <Cu5tosLimen> hi
[21:22:51 CET] <Cu5tosLimen> I want to cut multiple parts from video
[21:22:53 CET] <ddubya> aac has CODEC_CAP_SMALL_LAST_FRAME and yet truncates my file
[21:22:54 CET] <Cu5tosLimen> with timecodes
[21:23:10 CET] <Cu5tosLimen> like from 1:00 to 2:00 and then 2:30 to 3:00 etc
[21:23:40 CET] <JEEB> ddubya: have you gotten everything from the encoder?
[21:23:51 CET] <JEEB> the encoder might still be buffering data
[21:24:55 CET] <ddubya> JEEP, yeah, I'm submitting a small last frame and then flushing with null frame
[21:26:03 CET] <JEEB> have you then called the receive function until it says it has no more data around?
[21:26:12 CET] <JEEB> (I hope you are using the push/pull API)
[21:28:31 CET] <ddubya> JEEB, not my code... I'm figuring it out. I think I see their mistake now
[21:29:49 CET] <JEEB> https://www.ffmpeg.org/doxygen/trunk/group__lavc__encdec.html
[21:29:50 CET] <ddubya> nvm still at a lost :-P
[21:30:14 CET] <JEEB> this is the base documentation on the "new" (not really new at this point) dec/enc API grouping
[21:33:56 CET] <therage3> Is Lavf some form of encoder ffmpeg uses?
[21:34:46 CET] <ddubya> argh I send a full frame and still the truncation
[21:35:11 CET] <ddubya> maybe not flushing right
[21:37:16 CET] <furq> therage3: libavformat
[21:37:28 CET] <furq> if you're asking why that's in the tool metadata in mkvs
[21:37:48 CET] <therage3> That's why I asked, because I didn't use any encoder of that name
[21:37:51 CET] <therage3> Yet that's in the metadata
[21:37:56 CET] <therage3> I was massively confused
[22:45:12 CET] <ddubya> if a codec as CODEC_CAP_SMALL_LAST_FRAME will it always also have CODEC_CAP_VARIABLE_FRAME_SIZE
[22:45:32 CET] <ddubya> it seems to me one has nothing to do with the other
[23:10:40 CET] <garyserj> One crazily case is this one $ffmpeg -ss 191 -i vid.mp4 -c copy -t 6 someoutput2.mp4<ENTER>  produces a file that is 10s 403ms.  Even though I specified 6 seconds. So it is just over 4 seconds too long! It is almost 50% longer than I specified.  Why? And what can I do about it?
[23:12:53 CET] <ddubya> transcode it. Your start or end time doesn't fall on an I-Frame so you get the nearest one, which can be quite far away from the desired location
[23:13:20 CET] <ddubya> -c copy is your problem
[23:15:11 CET] <ddubya> any codec with interframe compression is going to have that issue
[23:15:55 CET] <s``> Hi! Do you know what can cause if a h264 mp4 video isnt playing well on chromium or ios? It is good on vlc and firefox. here is it: http://irl.hu/dl/out.mp4
[23:16:38 CET] <mooyoul> Hello guys!\
[23:17:29 CET] <garyserj> ddubya: That mp4 is AVC/AAC.  What codec vcodec and acodec should I change it to?
[23:17:31 CET] <ddubya> s``, nice cat video. Try disabling B-frames
[23:17:46 CET] <mooyoul> I have an question about re-encoding segmented audio
[23:18:44 CET] <mooyoul> I have about 3 minutes 30 seconds video, i segmented an audio with 'segment' muxer with segment_time 5 option.
[23:18:51 CET] <ddubya> garyserj, I'm no expert but there should be some I-frames only AVC profile for you
[23:19:41 CET] <mooyoul> if i concat segmented audio without re-encoding them, it plays without hearing "gap" (or "silence")
[23:20:10 CET] <ddubya> garyserj, if you are willing to transcode the outpu t(don't use -c copy) it doesn't really matter what codec you use
[23:20:24 CET] <mooyoul> but if i re-encode these segments and concat re-encoded audios, i can hear "gap" on each segment point (e.g. 5 sec)
[23:20:29 CET] <ddubya> for the *input* you would want some iframes-only codec/profile
[23:21:17 CET] <garyserj> ddubya: can you show me an example ffmpeg command for a file e.g. blah.mp4 ?
[23:21:42 CET] <ddubya> mooyoul, the re-encode isn't guaranteed to preserve the file length exactly. It might add more to conform with the code
[23:21:46 CET] <ddubya> code/codec
[23:22:36 CET] <mooyoul> I just want to split audio to small chunks and re-encoded them in individual servers, and concat them without hearing gaps
[23:24:16 CET] <mooyoul> ah yeah, duration of output was quite different with input. output was a little bit shorter than input (about < 1s)
[23:26:11 CET] <foo> If I want to get the highest quality audio from a video, in mono, is this what I want? ffmpeg -i native.mp4 -ac 1 mono.flac - I asked this earlier and there was some talk about -c copy, but I couldn't get that to work properly. I unfortunately need it to be mono audio for an API I'm passing this to
[23:26:15 CET] <garyserj> ddubya: ah thanks. i see this works ffmpeg -ss 191 -i vid.mp4 -vcodec libx264 -acodec libmp3lame -t 6 someoutput3.mp4
[23:29:56 CET] <s``> ddubya: thanks! its working without b-frames.
[23:31:24 CET] <ddubya> mooyoul, if you carefully select a codec you can get the desired result
[23:31:51 CET] <ddubya> not sure what. I recently found aac would match length exactly provided that I used recent ff version.
[23:32:54 CET] <mooyoul> ah yeah, if i encode segments to self-container format like pcm, i can hear audio without gaps
[23:33:14 CET] <mooyoul> but if i encode segments to aac or mp3, it produces "gap" between segments. weird...
[23:33:38 CET] <furq> foo: that won't work at all with -c copy
[23:33:47 CET] <furq> if this is just to pass it to an api then that command is fine
[23:33:54 CET] <foo> furq: ok, so great - thank you!
[23:33:55 CET] <furq> the objection was because that isn't very efficient
[23:34:22 CET] <furq> there are a lot of germans in this channel and efficiency is very important to them
[23:35:00 CET] <foo> furq: I value efficiency too, thank you. :) "efficiency" in that transcoding isn't necessary, right?
[23:35:15 CET] <furq> it is necessary if you need to downmix it
[23:35:22 CET] <furq> that would normally be a stupid thing to do but obviously not in this case
[23:35:50 CET] <ddubya> mooyoul, it might work with aac/mp3 if you cut the files precisely to a mulitple of the codec frame size (I think aac is 1024 samples)
[23:37:58 CET] <furq> foo: fwiw you could use -map_channels with -c copy to just get the left or right channel
[23:38:13 CET] <furq> emphasis on "could" because that's not going to give good results a lot of the time
[23:38:34 CET] <furq> -map_channel rather
[23:38:42 CET] <foo> furq: oh, interesting, how does it currently know which channel to use?
[23:38:50 CET] <furq> it doesn't, -ac does a proper downmix
[23:38:57 CET] <foo> ah, downmix
[23:39:05 CET] <furq> map_channel just copies a single channel
[23:39:08 CET] <foo> What's strange is the resulting audio seems to have more background noise than the main video
[23:39:14 CET] <foo> (but that may just be due to it being mono?)
[23:39:17 CET] Action: foo still learning audio ropes
[23:39:32 CET] <furq> yeah that might just be some stereo separation thing
[23:39:39 CET] <JEEB> https://play.google.com/store/apps/details?id=com.YoStarJP.AzurLane&hl=ja
[23:40:30 CET] <foo> furq: ok, thanks
[23:41:11 CET] <JEEB> did I really post that URL here or is my backlog showing weird things?
[23:41:19 CET] <furq> you really posted it
[23:41:25 CET] <JEEB> I dun good
[23:59:47 CET] <mooyoul> ddubya, how can i cut audio safely? I know segment muxer handles video safely by reference i-frame internally, but i can't sure that segment muxer handles audio safely like video.
[00:00:00 CET] --- Mon Jan 22 2018

More information about the Ffmpeg-devel-irc mailing list