8 Oct
2007
8 Oct
'07
5:33 p.m.
On Mon, 8 Oct 2007, Michael Niedermayer wrote:
forget my comment ... i have confused FIELD_PICTURE with a constant but this brings up another issue, i and probably other devels as well tend to think of upper case names as constants
maybe it would be cleaner if we would use code like #define FRAME_MBAFF(h) h->mb_aff_frame instead of the current #define FRAME_MBAFF h->mb_aff_frame
that of course is seperate from this patch ... ill retry reviewing it :)
I would certainly not be opposed to that -- makes sense to me. I can probably contribute something to this effect after we get through this stuff. There's some other cleanup things that I'll be posting later anyway (previously mentioned in this thread). -Jeff