[FFmpeg-cvslog] r24827 - in trunk: libavcore/avcore.h libavcore/imgutils.c libavcore/imgutils.h libavfilter/vf_crop.c libavfilter/vf_hflip.c

Stefano Sabatini stefano.sabatini-lala
Thu Aug 19 10:30:14 CEST 2010

On date Wednesday 2010-08-18 23:02:38 +0200, stefano wrote:
> Author: stefano
> Date: Wed Aug 18 23:02:38 2010
> New Revision: 24827
> Log:
> Implement inline function av_fill_image_max_pixstep() and use it for
> factorizing code.

If possible I'd like to change the name of the function, from
av_fill_image_max_pixstep() to av_get_image_max_pixstep().

"fill" sounds like a setter so it was a bad choice, "get" is also
shorter, and is also consistent with av_get_image_linesize().

It is OK just do it, or do I have to add a backward-compatibility
layer? Since there is no risk of breaking apps then I'd just bump
micro and consider it like an API bugfix.


More information about the ffmpeg-cvslog mailing list