[FFmpeg-cvslog] ffmpeg: prefer "dec" over "ist->st->codec" in do_video_out() snippet
Stefano Sabatini
git at videolan.org
Thu May 12 04:55:08 CEST 2011
ffmpeg | branch: master | Stefano Sabatini <stefano.sabatini-lala at poste.it> | Sun Apr 17 01:38:09 2011 +0200| [c29c2eea8fb35682fdfdcb64c4890e8a25137b2a] | committer: Anton Khirnov
ffmpeg: prefer "dec" over "ist->st->codec" in do_video_out() snippet
Simplify, ease readability.
Signed-off-by: Stefano Sabatini <stefano.sabatini-lala at poste.it>
Signed-off-by: Anton Khirnov <anton at khirnov.net>
> http://git.videolan.org/gitweb.cgi/ffmpeg.git/?a=commit;h=c29c2eea8fb35682fdfdcb64c4890e8a25137b2a
---
ffmpeg.c | 4 ++--
1 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/ffmpeg.c b/ffmpeg.c
index 8975586..a5d877a 100644
--- a/ffmpeg.c
+++ b/ffmpeg.c
@@ -1132,8 +1132,8 @@ static void do_video_out(AVFormatContext *s,
av_log(NULL, AV_LOG_INFO,
"Input stream #%d.%d frame changed from size:%dx%d fmt:%s to size:%dx%d fmt:%s\n",
ist->file_index, ist->index,
- ost->resample_width , ost->resample_height , avcodec_get_pix_fmt_name(ost->resample_pix_fmt),
- ist->st->codec->width, ist->st->codec->height, avcodec_get_pix_fmt_name(ist->st->codec->pix_fmt));
+ ost->resample_width, ost->resample_height, avcodec_get_pix_fmt_name(ost->resample_pix_fmt),
+ dec->width , dec->height , avcodec_get_pix_fmt_name(dec->pix_fmt));
if(!ost->video_resample)
ffmpeg_exit(1);
}
More information about the ffmpeg-cvslog
mailing list