[Ffmpeg-devel-irc] ffmpeg-devel.log.20111116

burek burek021 at gmail.com
Thu Nov 17 02:05:03 CET 2011


[00:23] <CIA-41> ffmpeg: 03Michael Niedermayer 07master * r7776091b9f 10ffmpeg/libavcodec/x86/diracdsp_yasm.asm: 
[00:23] <CIA-41> ffmpeg: diracdec: obmc accesses arent aligned for all files.
[00:23] <CIA-41> ffmpeg: Thus use unaligned accesses.
[00:23] <CIA-41> ffmpeg: Signed-off-by: Michael Niedermayer <michaelni at gmx.at>
[00:33] <CIA-41> ffmpeg: 03Stefano Sabatini 07master * r0491a2a07a 10ffmpeg/ffprobe.c: (log message trimmed)
[00:33] <CIA-41> ffmpeg: ffprobe: force display of missing fields, depending on writer.flags
[00:33] <CIA-41> ffmpeg: Add flags field to Writer, and define the
[00:33] <CIA-41> ffmpeg: WRITER_FLAG_DISPLAY_OPTIONAL_FIELDS flag which forces the display of
[00:33] <CIA-41> ffmpeg: optional fields, for example non-available or invalid fields.
[00:33] <CIA-41> ffmpeg: Also set the flag in the default writer.
[00:33] <CIA-41> ffmpeg: This change is required as for some writers it is preferable to show all
[00:33] <CIA-41> ffmpeg: 03Stefano Sabatini 07master * r1c43713e57 10ffmpeg/ (Changelog doc/ffprobe.texi ffprobe.c): ffprobe: add compact writer
[00:36] <ubitux> saste: \o/
[00:36] <ubitux> awesome :)
[00:43] <ubitux> michaelni: is there a special reason for the swr_alloc* split? 
[00:45] <michaelni> ubitux, you mean alloc vs alloc2 ?
[00:45] <michaelni> its just for convenience
[00:45] <ubitux> do we have use case for the export of the two functions?
[00:46] <michaelni> you might want to allocate before you know all the arguments that alloc2 has
[00:46] <michaelni> and if you know all alloc2 is more convenient
[00:46] <ubitux> ok, then it is badly named imo :p
[00:46] <michaelni> yes
[00:46] <michaelni> :)
[00:46] <ubitux> the '2' might indicates an API change
[00:46] <ubitux> so it's confusing
[00:48] <ubitux> i would propose sth like  swr_alloc ’ swr_prealloc and swr_alloc2 ’ swr_alloc
[00:50] <michaelni> that is confusing in a different way :)
[00:50] <michaelni> on first look one would think that both might be needed or possible
[00:50] <michaelni> pre meaning before alloc ...
[00:50] <ubitux> both are possible actually
[00:51] <ubitux> how would you remove the "needed" feeling?
[00:51] <ubitux> swr_alloc ’ swr_partial_alloc and swr_alloc2 ’ swr_alloc ? :p
[00:52] <ubitux> also, i'm willing to doxycomment a bit the library when the function names are fixed
[00:53] <michaelni> ideal would be to name both swr_alloc(), pitty C doesnt allow this ;)
[00:55] <michaelni> swr_alloc() and swr_alloc_with_parameters() but its too long maybe
[00:56] <ubitux> swr_alloc() and swr_alloc_set_opts() ?
[00:56] <michaelni> sounds quite good to me
[00:56] <ubitux> ok
[00:57] <ubitux> ok, new bikeshed subject
[00:57] <ubitux> about the API export, concerning struct
[00:57] <ubitux> i see there are some AV prefixes, and some Swr
[00:57] <ubitux> i'd like to have it consistent if possible
[00:58] <ubitux> do you prefer Swr over AV for everything (that should be exported)?
[00:58] <ubitux> for instance there is SwrContext, but AVResampleContext
[00:58] <michaelni> Swr is better 
[00:59] <ubitux> there is also AudioData
[00:59] <ubitux> since it is needed it swr public API it should be renamed too
[00:59] <ubitux> ok
[00:59] <michaelni> AudioData is internal
[01:00] <ubitux> swr_resample* functions aren't
[01:00] <ubitux> and need AudioData parameter
[01:01] <ubitux> (even if it could be opaque)
[01:01] <michaelni> why do you think swr_resample* is public API ?
[01:01] <michaelni> they are in swresample_internal.h
[01:01] <ubitux> oh.
[01:01] <ubitux> so there is no naming prefix difference between public and private functions?
[01:02] <ubitux> swr_alloc() is public, but swr_resample_free() isn't?
[01:02] <michaelni> yes
[01:02] <michaelni> iam not against adding different prefixes ...
[01:02] <ubitux> swrpriv? swri? (i for internal)
[01:02] <michaelni> shorter is better
[01:02] <ubitux> ok
[01:05] <ubitux> i'll do that tomorrow, but before i start, do you mind all the changes we just discussed?
[01:11] <michaelni> swri & alloc_opts is fine, was there something else? 
[01:13] <ubitux> and AV -> Swr for public stuff
[01:13] <ubitux> (AVResampleContext at least)
[01:13] <michaelni> sure ok
[01:13] <ubitux> i'll send a patchset for all of this, maybe with the doxygen, and some doc improvements
[01:13] <michaelni> thx :)
[01:14] <ubitux> it will be easier for everyone to use the library in the audio filter
[01:14] <ubitux> +s
[01:16] <ubitux> oh btw, swresample doesn't appear on http://ffmpeg.org/about.html
[01:16] <ubitux> you might want to add it
[01:16] <michaelni> yes, thx
[01:17] <ubitux> (it feels really weird to have that list in the "about" page though)
[01:28] <CIA-41> ffmpeg: 03Michael Niedermayer 07master * rcd6851c5ef 10ffmpeg/libavformat/utils.c: 
[01:28] <CIA-41> ffmpeg: lavf: if timestamps are invalid (pts=dts) only drop dts.
[01:28] <CIA-41> ffmpeg: Because if we drop both we have no timestamps at all for some files.
[01:28] <CIA-41> ffmpeg: Fixes Ticket344
[01:28] <CIA-41> ffmpeg: Signed-off-by: Michael Niedermayer <michaelni at gmx.at>
[02:40] <CIA-41> ffmpeg: 03Justin Ruggles 07master * rf1d1516e55 10ffmpeg/libavcodec/mpegaudiodec.c: cosmetics: indentation
[02:40] <CIA-41> ffmpeg: 03Mans Rullgard 07master * r52767d891c 10ffmpeg/libavformat/utils.c: 
[02:40] <CIA-41> ffmpeg: lavf: fix multiplication overflow in avformat_find_stream_info()
[02:40] <CIA-41> ffmpeg: Converting to double before the multiplication rather than after
[02:40] <CIA-41> ffmpeg: avoids an integer overflow in some cases.
[02:40] <CIA-41> ffmpeg: Signed-off-by: Mans Rullgard <mans at mansr.com>
[02:40] <CIA-41> ffmpeg: 03Michael Niedermayer 07master * rc1c836d9eb 10ffmpeg/: (log message trimmed)
[02:40] <CIA-41> ffmpeg: Merge remote-tracking branch 'qatar/master'
[02:40] <CIA-41> ffmpeg: * qatar/master:
[02:40] <CIA-41> ffmpeg:  lavf: fix multiplication overflow in avformat_find_stream_info()
[02:40] <CIA-41> ffmpeg:  cosmetics: indentation
[02:40] <CIA-41> ffmpeg:  mpegaudiodec: init static tables in AVCodec.init_static_data()
[02:40] <CIA-41> ffmpeg: Conflicts:
[02:40] <CIA-41> ffmpeg: 03Justin Ruggles 07master * r1158745a2d 10ffmpeg/libavcodec/ (mpegaudiodec.c mpegaudiodec_float.c): mpegaudiodec: init static tables in AVCodec.init_static_data()
[03:45] <CIA-41> ffmpeg: 03Michael Niedermayer 07master * r20431a9982 10ffmpeg/libavcodec/wmadec.c: 
[03:45] <CIA-41> ffmpeg: wma: Check channel number before init.
[03:45] <CIA-41> ffmpeg: Fixes Ticket240
[03:45] <CIA-41> ffmpeg: Based on patch by ami_stuff
[03:45] <CIA-41> ffmpeg: Signed-off-by: Michael Niedermayer <michaelni at gmx.at>
[07:19] <pasteeater> i'm going to be gone until friday, so someone should clean out the ML spam tank once or twice a day
[07:27] <CIA-41> ffmpeg: 03Clément BSsch 07master * r7e516a11ca 10ffmpeg/libswresample/ (Makefile resample2.c): swr: rename resample2 to resample.
[07:27] <CIA-41> ffmpeg: 03Clément BSsch 07master * rfc42550097 10ffmpeg/libswresample/audioconvert.c: 
[07:27] <CIA-41> ffmpeg: swr: move format convert code to dedicated functions.
[07:27] <CIA-41> ffmpeg: This should easier common case optimizations.
[07:27] <CIA-41> ffmpeg: 03Clément BSsch 07master * rf9368466c4 10ffmpeg/libswresample/swresample.c: swr: use designated initializers for the class.
[07:27] <CIA-41> ffmpeg: 03Clément BSsch 07master * r180aa82c1d 10ffmpeg/libswresample/swresample.c: swr: replace deprecated av_get_bits_per_sample_fmt() with av_get_bytes_per_sample().
[07:27] <CIA-41> ffmpeg: 03Clément BSsch 07master * rad561b5707 10ffmpeg/libswresample/swresample.c: swr: replace deprecated av_opt_set_defaults2() with av_opt_set_defaults().
[07:28] <CIA-41> ffmpeg: 03Clément BSsch 07master * rdf72ae673f 10ffmpeg/libswresample/swresample.c: swr: replace deprecated av_set_int() with av_opt_set_int().
[07:47] <CIA-41> ffmpeg: 03Clément BSsch 07master * r4da45aff28 10ffmpeg/ (6 files in 4 dirs): cleanup: remove various double end ';' all over the code.
[08:01] <ubitux> michaelni: you don't want the resample code to be made public?
[08:01] <ubitux> (maybe it could be used in libavfilter/af_aresample.c)
[08:01] <ubitux> mmh or maybe the main interface is enough.
[09:47] <ubitux> any idea why one of the build wasn't able to cleanup the libswresample/resample2.o object dep properly?
[09:48] <ubitux> it seems to break the build for this one
[09:48] <ubitux> i'm not sure if the rename commit is at fault or if it's something broken in the way fate or build is run
[09:55] <CIA-41> ffmpeg: 03Clément BSsch 07master * r16b809ce8e 10ffmpeg/libavfilter/avfilter.h: lavfi: fix misc typo in avfilter.h header.
[09:59] <jar616> i've asked on #ffmpeg without success. I'm trying to decode h264 bitstream with ffmpeg.
[10:00] <jar616> when i'm trying to decode file with h264 bitstream av_read_frame returns -32
[10:00] <jar616> but when i encapsulate that in mkv file evryting works fine
[10:01] <jar616> maybe someone knows how to decode pure bitstream with ffmpeg ?
[10:41] <pisto> could someone import this in ffmpeg? http://git.libav.org/?p=libav.git;a=commit;h=2625b621ce7eb2d5f2f42d2a6dff37bffce3c726
[10:42] <Tjoppen> pisto: michaelni pulls libav quite regularly, so you can probably expect it quite soon
[10:42] <pisto> he pulls in the main repo, doesn't he?
[10:43] <Tjoppen> ah, that's a backported patch?
[10:44] <pisto> hm, wait, I mean, he pulls here git://git.videolan.org/ffmpeg.git ?
[10:44] <pisto> (I'm not very sure about the meaning of backport in this context)
[10:44] <av500> he pulls a lot of weight
[10:45] <pisto> :/
[10:46] <Tjoppen> that commit is in libav/master, so it'll probably get pulled
[10:46] <pisto> fine, thanks.
[10:48] <j-b> I thought the name was qatar/master
[10:48] <j-b> av500: :)
[10:49] <Tjoppen> right
[10:51] <ubitux> the commit is already in btw.
[11:41] <uau> i got queued ffmpeg list mails last night, so i suppose the mcafee blacklisting has been removed
[14:57] <jermy> I'm writing some handling for a format that is basically a bunch of TS (immutable separate files) concatenated together via an index file
[14:58] <jermy> it's similar, but not exactly, to HLS (applehttp)
[14:59] <jermy> Are there any other formats that are similar to this? I'm about to handle seeking, and just wondering how other formats have handled it
[15:00] <jermy> (annoyingly, my index doesn't contain any timestamp knowledge, so I'll have to do a bisect on the files I have)
[15:04] <av500> if its real TS, timestamps can wrap around
[15:05] <jermy> This is also true
[15:06] <jermy> any idea how often a commercial encoder might wrap?
[15:06] <av500> once every MAX_TIMESTAMP :)
[15:07] <jermy> This is really going to make bisecting annoying
[15:08] <av500> probably they wont roll over more than once in a segment
[15:14] <jermy> I really hope it doesn't 
[15:15] <jermy> Otherwise seeking will be screwed
[15:15] <jermy> Baptiste will probably know :)
[15:15] <jermy> How often does a typical MPEG-TS timestamp roll over?
[15:18] <bcoudurier> not often
[15:18] <bcoudurier> broadcast rips roll overs sometimes
[15:18] <kierank> iirc once a day
[15:18] <kierank> but i forget
[15:19] <bcoudurier> field is 33 bits
[15:20] <jermy> Is that normally storing something in a timebase suitable for the audio? (48k?)
[15:21] <bcoudurier> 90khz
[15:21] <jermy> 26 hours would suggest its something suitable for PAL&NTSC - 90k...
[15:21] <jermy> what you said :)
[15:22] <bcoudurier> 1 day 2 hours approx
[15:22] <bcoudurier> yes 26 :)
[18:41] <CIA-41> ffmpeg: 03Stefano Sabatini 07master * r1f0d937f77 10ffmpeg/ (Changelog doc/ffprobe.texi ffprobe.c): ffprobe: add csv writer
[18:41] <CIA-41> ffmpeg: 03Stefano Sabatini 07master * rf0db05008d 10ffmpeg/ffprobe.c: ffprobe: apply misc cosmetics to compact writer definition
[18:46] <Compn> i'm surprised there are still cinepak samples that cause problems
[18:48] <Compn> but i guess there are many many games that used the codec 
[18:48] <Compn> lots of samples
[19:23] <ubitux> saste: where is it specified long long must be at least 64bits long?
[19:25] <saste> ubitux: standard specifies the required *minimum* value for MAX_LLONG_INT, which is 2^63-1
[19:25] <nevcairiel> C99 defines long long to be 64-bit minimum
[19:26] <nevcairiel> earlier standards dont define it that way
[19:27] <ubitux> oh, ok
[19:36] <CIA-41> ffmpeg: 03Clément BSsch 07master * r9813af259a 10ffmpeg/ffprobe.c: ffprobe: make Writers constant.
[19:37] <CIA-41> ffmpeg: 03Clément BSsch 07master * r69a501e6a1 10ffmpeg/ffprobe.c: ffprobe: small align cosmetic in json writer struct init.
[20:16] <ubitux> michaelni: what does resample_in_constraint mean?
[20:45] <michaelni> ubitux, it seperates the case where the end was reached because of lack of input from the lack of remaining output space
[20:58] <CIA-41> ffmpeg: 03Michael Niedermayer 07master * r111ffa55b7 10ffmpeg/libavcodec/cinepak.c: 
[20:58] <CIA-41> ffmpeg: cinepak: simplify, use FFMIN()
[20:58] <CIA-41> ffmpeg: Signed-off-by: Michael Niedermayer <michaelni at gmx.at>
[20:58] <CIA-41> ffmpeg: 03Michael Niedermayer 07master * rf35f50b311 10ffmpeg/libavcodec/cinepak.c: 
[20:58] <CIA-41> ffmpeg: cinepak, simplify, use AV_RB24()
[20:58] <CIA-41> ffmpeg: Signed-off-by: Michael Niedermayer <michaelni at gmx.at>
[20:58] <CIA-41> ffmpeg: 03Michael Niedermayer 07master * rcea0c82d9b 10ffmpeg/libavcodec/cinepak.c: 
[20:58] <CIA-41> ffmpeg: cinepak: check strip_size
[20:58] <CIA-41> ffmpeg: Signed-off-by: Michael Niedermayer <michaelni at gmx.at>
[20:58] <CIA-41> ffmpeg: 03Michael Niedermayer 07master * r7056f13a89 10ffmpeg/libavcodec/cinepak.c: 
[20:58] <CIA-41> ffmpeg: cinepak: remove redundant coordinate checks
[20:58] <CIA-41> ffmpeg: Signed-off-by: Michael Niedermayer <michaelni at gmx.at>
[21:20] <ubitux> michaelni: so if resample_in_constraint is set, it means the input end was reach first?
[21:36] <michaelni> ubitux, yes
[21:36] <ubitux> ok thank you
[21:38] <ubitux> michaelni: i have 10 swr patches, do you want me to send them on the ml or you prefer another way?
[21:38] <ubitux> since the patchset is pretty long and not very interesting, i'm not sure about polluting the ml
[21:47] <michaelni> i see no harm in posting them ...
[21:49] <ubitux> ok
[22:35] <ubitux> btw michaelni, swr_audio_convert is considered public, right?
[22:35] <ubitux> if not i should use swri and Swri instead
[22:36] <ubitux> but if it is indeed public, AudioData must be exported too
[22:36] <ubitux> (needed in the swr_audio_convert prototype)
[22:55] <michaelni> ubitux, only what is in swresample.h is supposed to be public ATM
[22:57] <ubitux> ok, so actually, patch 02 should just AVAudioConvert ’ AudioConvert
[22:57] <ubitux> and swr_audio_convert* funcs renamed to swri_...?
[23:11] <michaelni> yes
[23:11] <ubitux> ok
[23:15] <michaelni> and sorry for my slow replies ...
[23:15] <ubitux> np :)
[23:15] <ubitux> i can wait a few days you know& :p
[23:22] <michaelni> its just iam working on something and so only check IRC every 10-15min :)
[23:23] <ubitux> oh, irc, ok, no worry :)
[00:00] --- Thu Nov 17 2011


More information about the Ffmpeg-devel-irc mailing list