[Ffmpeg-devel-irc] ffmpeg.log.20120101

burek burek021 at gmail.com
Mon Jan 2 02:05:01 CET 2012

[00:00] <defaultro> hey folks, check out this hdr test video I made. Of course, ffmpeg was used about 90% during the processing :) http://www.youtube.com/watch?v=s44o8MBfGg0 please let me know
[00:05] <defaultro> btw, can ffmpeg do what twixtor does?
[00:07] <pasteeater> ffmpeg can slow down or speed up, but by dropping or duping frames, and it can't do it on a "curve" (maybe programatically) like twixtor appears to be doing
[00:08] <Granjow> pasteeater: no, but you can use my program for this
[00:08] <Granjow> http://slowmovideo.granjow.net/index.html
[00:08] <defaultro> ok
[00:08] <Granjow> happy new year and so on, good night
[00:09] <defaultro> WOW!!!!!!!!!!
[00:09] <defaultro> That is amazing Granjow!!!!!!
[00:10] <defaultro> Thanks for sharing :) Happy New Year too!!!
[00:14] <pasteeater> defaultro: what is the input format from the camera?
[00:16] <defaultro> mov file
[00:16] <defaultro> let me ffmpeg it
[00:16] <defaultro> Stream #0.0(eng): Video: h264, yuvj420p, 1920x1088, 71887 kb/s, 30 fps, 30 tbr, 3k tbn, 6k tbc
[00:17] <defaultro> that's the format that Magic Lantern on my Canon 50D created
[00:17] <defaultro> what do you think about my hdr test? does it look good?
[00:21] <pasteeater> i would call it faux HDR because you are using one input with one "range".
[00:21] <defaultro> yup
[00:21] <defaultro> does it look bad?
[00:22] <defaultro> magic lantern's real hdr implementation is based on iso. It records frames at iso 800 and iso 1600
[00:23] <defaultro> the recording is frame 1 at iso 800, frame 2 at iso 1600, frame 3 is at iso 800 and so on
[00:23] <defaultro> magic lantern's hdr support on my camera is still buggy that's why I made that faux hdr solution
[00:24] <defaultro> if there was a raw recording like when we take still pictures, that would be awesome
[00:24] <pasteeater> the original looks better to me.
[00:24] <defaultro> :D
[00:25] <defaultro> it's dark, can't see the cabinet
[00:25] <pasteeater> interesting experiment though
[00:25] <defaultro> yup
[00:25] <defaultro> it's my first time, I'll use a different tool next time
[00:26] <pasteeater> i just installed CHDK on a SD940. i want to make some time lapse on a rail dolly.
[00:26] <defaultro> awesome
[00:26] <defaultro> i've been wanting to create a motorized dolly but I haven't started
[00:27] <defaultro> i already have the stepper motor. Hopefully, I'll be able to start it next year
[00:27] <pasteeater> arduino?
[00:27] <defaultro> not arduino, i was told another one
[00:27] <defaultro> i forgot
[00:27] <defaultro> i'll have to look up from my bookmark
[00:28] <defaultro> brb, need to grab something from CostCo
[01:56] <qxt> Is there a reason that ffmpeg is only using on of my i7 2600k cores? 
[01:56] <qxt> one
[01:57] <qxt> The cmd I am running is..
[01:57] <qxt> ffmpeg -i Drive.2011.BluRay.1080p.x264.DTS-LTT.mkv -pass 1 -vcodec libx264 -preset veryslow -b:v 1119k -f mp4 -an -y /dev/null && ffmpeg -i Drive.2011.BluRay.1080p.x264.DTS-LTT.mkv -pass 2 -vcodec libx264 -preset veryslow -b:v 1119k -acodec libfaac -ab 128k -ac 2 drive.mkv
[01:59] <qxt> also I am wondering if using that -f mp4 is OK. I tried with -f mkv but I was got a msg saying that was a no go.
[02:07] <qxt> Do I need to set threads manually in the above cmd?
[02:31] <pasteeater> qxt: you can try '-threads 0' if you're using an older ffmpeg for it to auto choose an appropriate value, otherwise it's now default, IIRC
[02:32] <pasteeater> you should use -f matroska
[02:32] <pasteeater> but hopefully it won't care
[02:33] <qxt> pasteeater I compiled it about a week ago on a debian machine. So I write the whole word matroska not just mkv?
[02:33] <pasteeater> yeah. see 'ffmpeg -formats' for a list of available -f options
[02:35] <qxt> there it is  "E matroska        Matroska file format"
[02:37] <pasteeater> for 1st pass (on the very rare occasion i use it) i make the -f the same as the 2nd pass output format.
[02:39] <qxt> pasteeater seems like it got sentimental and tossed out "Decoder (codec text) not found for input stream #0:2" when I used the -f matroska cmd ?
[02:40] <pasteeater> use a pastebin site to show your ffmpeg command and the complete console output
[02:40] <qxt> sure one sec
[02:44] <qxt> pasteeater http://pastebin.com/A3hyKhxi
[02:45] <pasteeater> you're applying -threads 0 as an input option, not an output option
[02:45] <qxt> lol that might have something to do with it !
[02:45] <pasteeater> and your ffmpeg is probably new enough that you don't even need -threads 0
[02:46] <pasteeater> add -sn to ignore subtitles
[02:46] <pasteeater> as an output option to both passes
[02:47] <qxt> pasteeater OK I removed the thread 0 but I still got the error. Ill try the -sn. Looking at the error it looks like your right on the money.
[02:50] <qxt> pasteeater coolio got rid of the error. Oddly I can not use more then one core though? Could it be that I am using veryslow?
[02:54] <pasteeater> look at the ffmpeg output. see the x264 options. does it show threads=12?
[02:54] <pasteeater> (assuming you've removed -threads 0)
[02:55] <pasteeater> line 29 in your last paste is an example of the x264 option output
[02:58] <qxt> Yeah I was just looking at that. Even without the -threads 0 I am getting this "threads=12 sliced_threads=0 nr=0 " so it seems to detect something at least. 
[02:58] <qxt> Just that I am only using about 20-25% of my cpu 
[02:59] <pasteeater> i don't know, but if it is showing "threads=12", which is the number that -threads 0 chose (i7 i'm guessing?) then you know it's not "user error".
[03:00] <pasteeater> ohm duh, you mentioned i7
[03:01] <pasteeater> i have to go now. good luck with that.
[03:02] <qxt> Yeah a SB i7 with HT. Thx for your help. All the best
[04:47] <grap3_ap3> Please help me understand. Recorded .ogv file looks/sounds just fine. Converted to .mkv for YouTube upload. Resolution of video gets munged. Text in terminal/browser unreadable but bigger text (in word processor) while still showing pixelation, is better and actually can be read. This pastebin has the command line input/output (http://pastebin.com/x7a8ZvSN). How can I improve the resolution issues during conversion?
[08:15] <llappy> so, I have THP files at 608x480
[08:16] <llappy> they're meant to be displayed in 16:9 by stretching, but I can't figure out how to change the aspect ratio without cropping
[08:54] <llappy> never mind, figured it out
[10:27] <upvar> i'm calling the ffmpeg binary from another process and with some inputs i get a spam of '[libx264 @ 0x25afa60] VBV underflow ...' and as a result the encoder doesn't seem to terminate, i can't really put a timeout on the encoding task because the input videos vary wildly and i can't guess how long a task should take, can i tell ffmpeg some how to terminate if something goes wrong?
[12:49] <funyun> hi. i'm trying to convert a movie with DTS audio to AC3 audio with ffmpeg but i get this error http://pastebin.com/pDvMzisA . can anyone help me?
[12:58] <cbsrobot> funyun: not sure if it's an audio problem - try to convert the audio without the video
[12:58] <cbsrobot> like:
[12:58] <cbsrobot> ffmpeg -i input.mkv -acodec ac3 -ab 640k -ac 6 -vn output.mkv
[13:13] <funyun> cbsrobot: that works. but how do i get the audio and the vid together?
[13:38] <cbsrobot> funyun: I'm not sure how to fix this: [matroska @ 0x14dd7c0] pts < dts in stream 0
[13:38] <cbsrobot> but try 
[13:38] <cbsrobot> ffmpeg -i input.mkv -vcodec copy -an output.mkv
[13:39] <cbsrobot> and then you can try to merge the two files
[13:39] <cbsrobot> or maybe you have to transcode the video stream aswell
[13:39] <cbsrobot> It's just some wild guessing
[14:19] <qxt> Is there a tool out there that will calculate the right bit rates needed for a predetermined size video?
[14:37] <Agiofws> http://www.youtube.com/watch?v=kwhkU4-FI-U
[14:44] <qxt> Agiofws "Robo bunny flock of birds" Nice video ... ?
[14:46] <Agiofws> ?
[15:38] <funyun> join mw3
[16:03] <qxt> How do I copy a subtitle stream from a video and save it as a srt file?
[16:06] <Matty> If the subtitles are part of the video stream(part of the image) then there is no way. If they are separate stream then something like "ffmpeg -i video subs.srt".
[16:08] <Matty> Unfortunetly this is broken for mkv files at the moment, not sure about other.
[16:08] <qxt> Matty Yeah they are part of the video stream. Was hoping there might be a way to map the stream and dump it to a file...
[16:08] <qxt> Matty but there would be issues about font type etc I suppose.
[16:10] <grap3_ap3> Please help me understand. Recorded .ogv file looks/sounds just fine. Converted to .mkv for YouTube upload. Resolution of video gets munged. Text in terminal/browser unreadable but bigger text (in word processor) while still showing pixelation, is better and actually can be read. This pastebin has the command line input/output (http://pastebin.com/x7a8ZvSN). How can I improve the resolution issues during conversion?
[16:36] <Mavrik> grap3_ap3, for starters, stop encoding a 3360x1040 video to just 1.5Mbit/s
[16:37] <Mavrik> that kind of resolutions are usually encoded in something closer to 20-40Mbit/s
[16:37] <grap3_ap3> Mavrik, thank you! Didn't do it intentionally, likely due to my dual monitor setup. 
[16:38] <Mavrik> second of all, set -vcodec libx264 -preset slow to explicitly set preset for h.264 encoding
[16:38] <Mavrik> grap3_ap3, maybe you should downsample the video to 1080p or some such, Youtube is going to do this anyway
[16:38] <Mavrik> and you won't have to wait for several GB of video to upload
[16:39] <grap3_ap3> Mavrik, I'm a video noob, can you point me toward resources on learning how to do this downsampling? 
[16:39] <Mavrik> grap3_ap3, just tell ffmpeg to resize your video, e.g. "-vf  scale=-1:1080"
[16:39] <Mavrik> grap3_ap3, this will make small text blurry since you're actually resizing the actual picture
[16:40] <Mavrik> grap3_ap3, so use something like "ffmpeg -i <yourile> -vcodec libx264 -preset slow -vf scale=-1:1080 -b:v 8000k -acodec libmp3lame out.mkv"
[16:41] <grap3_ap3> Mavrik, thank you so much for your help. You confirmed what I was thinking since I started this project- that the recording resolution is the problem.
[16:41] <Mavrik> grap3_ap3, play with the -b:v parameter for quality - higher is better quality + larger file
[16:42] <grap3_ap3> Mavrik, trying your suggestion now, Thanks again! I really need clear text on this video so will look at ways to change the recording resolution without changing the system resolution- I thought I was combating that by selecting only the deisred recording area but apparently that was the first of several incorrect presumptions on my part here :(
[16:43] <Mavrik> grap3_ap3, recording only part of the screen is your only option really - if you lower the resolution of video (while keeping screen resolution the same) it'll make the text blurry
[16:43] <Mavrik> grap3_ap3, you can also use video editing tools to actually crop the video
[16:44] <grap3_ap3> Mavrik, this was supposed to be a 20minute project- turned into 2 days so far because of this stupid encoding issue.. I'd like to avoid having to actually edit the vid if possible. \
[16:45] <Mavrik> well, is there really any reason for you to use such a high res? instead of switching you screen to 1280x720 or something like that?
[16:45] <Mavrik> you'll have all kinds of problem getting video of 3300xsomething resolution around
[16:46] <grap3_ap3> only because that's what fits best for this dual monitor setup. 
[16:47] <Mavrik> well, turn off one monitor, switch the other to lower res, record what you need to record
[16:47] <Mavrik> that'll save you tons of trouble
[16:47] <grap3_ap3> Guess I'm not sure why I didn't try that. 
[16:47] <grap3_ap3> I was really just thinking it would work as-is
[16:48] <grap3_ap3> thanks for the help. 
[16:52] <qxt> Going to do a 2 pass video. Wanted to know if this is the right way to get the sound size in MB
[16:52] <qxt> (128 [kilobits] * 6047 [time sec]) / 8192  = size MB
[16:53] <qxt> Was thinking about the 8192 part mostly.
[16:54] <Mavrik> ((kbit /s * time sec) / 8) / 1024
[16:54] <Mavrik> so yea, about right
[16:55] <qxt> Mavrik nice thx
[17:40] <qxt> Is there a cmd to get the time duration of a video?
[17:40] <alesan> hi... I have this 5.1 audio in my movie, how can I correctly transform it in normal stereo?
[17:40] <qxt> -acodec libfaac -ab 128k -ac 2
[17:41] <qxt> if you have a bunch of streams add -sn
[17:41] <relaxed> qxt: ffprobe
[17:41] <qxt> thx relaxed
[17:43] <qxt> alesan if you just want to do this fast "ffmpeg -i input -vcodec copy -acodec libfaac -ab 128k -ac 2 output.mkv
[17:44] <alesan> thanks!
[17:44] <alesan> I'll try
[17:44] <qxt> np
[17:45] <alesan> so 128k is enough for a stereo signal?
[17:46] <alesan> what is -sn for??
[17:47] <qxt> alesan that is in case you have a bunch of stream it will not toss an error. Try it without the -sn. If you get a warning then use -sn (streams no)
[17:47] <alesan> well I do get that error
[17:47] <alesan> with it, it works correctly it seems... let me try again
[17:48] <qxt> alesan =)
[17:48] <alesan> I am uploading a video of yesterday's party to my mom...
[17:48] <alesan> I need to recompress it a bit, scale it down, and stereo sound is more than enough
[17:49] <alesan> she could not attend my son's first birthday party :(
[17:49] <qxt> alesan for a home video I find 128k to be just fine. Its up to you though.
[17:52] <qxt> alesan what size do you want to compress your video to?
[17:53] <alesan> I just want it to be more easily transferable with scp
[17:53] <alesan> the original is...
[17:54] <alesan> 190MB
[17:54] <alesan> recompressing it with cfr 24, converting to 30fps and scaling to 1280x720, it's 11MB apparently
[17:55] <alesan> for 64 seconds
[17:56] <qxt> alesan Does it look OK?
[17:56] <alesan> I think it does.
[17:56] <alesan> it's that the original, 1920x1080p 60fps, with 5.1 audio, is just too big
[17:57] <qxt> alesan I find about a crf of about 18-27 to be OK
[17:57] <qxt> depends on what I am encoding.
[17:57] <alesan> using 24 for now, maybe I should lower it a little
[17:58] <alesan> but my mom does not care too much I suppose
[17:58] <qxt> 5.1 audio on a home video to be sent over the net is silly. The sound cmd above is more appropriate.
[18:00] <qxt> Unless you want to hear the maids baby crying in surround..
[18:07] <qxt> Is there a reason that pass 1 is not using threading - ffmpeg -i movie.mkv -pass 1 -vcodec libx264 -preset veryslow -b:v 1226.72134943k -f matroska -sn -an -y /dev/null 
[18:08] <Mavrik> it's just an analysis phase
[18:08] <Mavrik> probably nothing to do in multiple threads
[18:09] <qxt> Mavrik yeah this is just the analysis but it is only doing 18 fps on a Sandy Bridge i7 2600k 
[18:10] <qxt> Mavrik the next phase does thread though.
[18:10] <Mavrik> that's normal.
[18:11] <qxt> Mavrik thx good to know I did not fudge the cmd. 
[20:15] <aca20031> So if I want to convert to h.264 in a .mp4 do I do -vcodec h264, or -vcodec mp4 or something entirely different?
[20:17] <relaxed> libx264 is a h264 encoder and mp4 is a container
[20:18] <aca20031> so...
[20:18] <aca20031> -f mp4 -vcodec h264?
[20:18] <relaxed> so, ffmpeg -i input -vcodec libx264 -preset slow -crf 18 output.mp4
[20:19] <aca20031> ok, ffmpeg -formats doesnt list "libx264" - how does one list them?
[20:19] <relaxed> because it's a codec "ffmpeg -codecs"
[20:20] <aca20031> then what is h264 as a "format"?
[20:20] <aca20031> sorry, im a bit slow on this media stuff.
[20:20] <relaxed> h264 format is the raw video
[20:21] Action: aca20031 has a headache
[20:21] <relaxed> what is your goal? targeting a specific device?
[20:22] <aca20031> yeah, i want to convert all my videos to h264 in mp4 so it doesnt have to be transcoded on the fly for the PS3 and future media clients
[20:24] <relaxed> which version do you have?
[20:24] <aca20031> of ps3?
[20:24] <relaxed> no, ffmpeg
[20:24] <aca20031> oh the latest built binary for windows, let me see
[20:25] <aca20031> FFmpeg git-f514695 64-bit Shared (Latest) 
[20:25] <aca20031> ffmpeg N-36193-gf514695
[20:28] <relaxed> aca20031: this will create a 2 minute sample to test. ffmpeg -i input -vcodec libx264 -profile high -preset slow -threads 0 -crf 18 -level 42 -maxrate 25000k -bufsize 25000k -acodec libvo_aacenc -ab 192k -ac 2 output-sample.mp4
[20:28] <relaxed> oh, add "-t 120" after input
[20:28] <aca20031> so very many switches
[20:30] <relaxed> devices require specific settings
[20:31] <aca20031> do you know of a better future proof format? I dont want the PS4 or the Xbox 720 to refuse to play them once i convert them :P
[20:32] <relaxed> future devices will be able to play it.
[20:33] <relaxed> you may need to limit refs, so if the above doesn't work try adding "-refs 3"
[20:37] <relaxed> aca20031: there's handbrake if you ned something clicky http://handbrake.fr
[20:37] <relaxed> s/ned/need/
[20:46] <aca20031> command lines will probably be faster, it just doesnt help that i dont fully understand the millions of different encodings vs codecs vs containers vs 'raw video' lol
[20:47] <aca20031> nevermind that audio has its own crap
[21:23] <defaultro> hey folks, does it matter which format we use? Is .mov better than .mts?
[22:04] <qxt> Was wondering if there is a way to see if TurboBoost is running on my i7 2600. On Debian kenel 3.1.0-1-amd64, ffmpeg compiled a week ago. 
[22:06] <qxt> cat /proc/cpuinfo I hear does not show TurboBoost info
[22:58] <linuxstony> Hello ladies and gentlemen - i am trying to build ffmpeg-git together with x264-git on arch linux. x264 complained about a missing libavformat.so.52 so i thought about recompiling ffmpeg from git together with the latest x264. Sadly ffmpeg does not build because of the following error: ERROR: libx264 version must be >= 0.118. and I should come here for help.The installed x264 version is "x264-git 20120101-1"   if that is of 
[22:58] <linuxstony> any help. 
[22:59] <linuxstony> Does anyone have an advice for me - as i need to create some Savage2 videos that users are waiting for :) - and sorry if this is a noobish question - i tried google and the some boards to find a solution for that - sadly i didnt find anything that indicated something i could try.
[23:25] <Matty> linuxstony: I do not know what is your problem, but ffmpeg depends on x264. So x264 should be build first and should not complain about missing ffmpeg while compiling.
[00:00] --- Mon Jan  2 2012

More information about the Ffmpeg-devel-irc mailing list