[Ffmpeg-devel-irc] ffmpeg.log.20120102

burek burek021 at gmail.com
Tue Jan 3 02:05:01 CET 2012

[00:57] <grap3_ap3> Please help me understand. Recorded .ogv file looks/sounds just fine. Converted to .mkv for YouTube upload & resolution of video gets munged. Text in terminal/browser appears to have been partially rendered. This pastebin has the command line input/output (http://pastebin.com/x7a8ZvSN). How can I improve the resolution issues during conversion?
[03:50] <SteveTheCat> hey
[03:51] <SteveTheCat> I'm trying to compile 0.5.2
[03:51] <SteveTheCat> and i'm getting problems with this configuration
[03:51] <SteveTheCat> http://pastebin.com/b8zTW9CD
[03:52] <sacarasc> Why are you trying to compile one so ancient?
[03:53] <SteveTheCat> i'm following this forum post that says his stream is working with these builds
[03:53] <SteveTheCat> http://ntp1.centos.org/modules/newbb/viewtopic.php?viewmode=flat&order=ASC&topic_id=30776&forum=38&move=prev&topic_time=1301857472
[03:54] <SteveTheCat> basically having problems with using x264 in VLC
[04:05] <SteveTheCat> anyone?
[05:46] <metvik> is there anyway to extract subtitles from a dvb ts with ffmpeg?
[05:47] <mystica555_> i'd bet there is, but as ive never done it, i can't explain how. ffmpeg does do many wonderful things however. 
[06:13] <upvar> does ffmpeg write to pipes other than stderr? i am trying to catch some errors with ffmpeg and they don't seem to be going to stderr
[06:14] <upvar> getting a VBV underflow error and i want to terminate ffmpeg if that happens
[06:14] <upvar> but it doesn't seem to be getting sent to the stderr like everything else
[06:15] <mystica555_> is it perhaps going to stdout instead?
[06:15] <upvar> nope
[06:15] <upvar> i am reading stdout and stderr and everything seems to come from stderr
[06:15] <upvar> [libx264 @ 0x122da60] VBV underflow (frame 1582, -92 bits)
[06:15] <upvar> that's the kind of thing, so i assume the libx264 module is writing to some other pipe?
[06:16] <upvar> i don't know enough about POSIX to grasp this properly
[06:16] <relaxed> it should all go to stderr
[06:17] <upvar> yeah it's totally not
[06:18] <upvar> i have a wrapper script reading stderr and writing it to a file
[06:18] <upvar> and those lines are not going through
[06:18] <upvar> everything else is
[06:18] <upvar> wonder if it's a buffering thing
[06:20] <relaxed> How are you reading stderr?
[06:20] <upvar> looks like it's a buffering thing
[06:21] <upvar> using fgets()
[06:25] <upvar> oh well waiting for the buffer to fill up sure beats ffmpeg hanging the box for 2 hours :)
[06:42] <kcm1700> ffmpeg blahblah 2>&1 
[06:42] <kcm1700> stderr to stdout redirection.
[06:46] <upvar> yeah that's not what i was asking
[06:46] <upvar> since i'm reading stderr directly with fgets
[06:47] <upvar> this is why i was asking
[06:47] <upvar> Note that in case stdin is associated with a terminal, there may also be input buffering in the terminal driver, entirely unrelated to stdio buffering. (Indeed, normally terminal input is line buffered in the kernel.)
[06:47] <upvar> http://linux.about.com/library/cmd/blcmdl3_stderr.htm
[09:22] <meero> Hi, how to mixdown video from stereou sound to mono "-ac 1" is not working with error like av_interleaved_write_frame(): Operation not permitted
[13:35] <upvar> hey, i'm getting this warning from both libx264 and ogg on different input videos
[13:35] <upvar> [ogg @ 0xd649e0] Frame rate very high for a muxer not effciciently supporting it.
[13:35] <upvar> Please consider specifiying a lower framerate, a different muxer or -vsync 2
[13:35] <upvar> it looks like each time that error is mentioned the transcode takes forever or fucks out completely
[13:36] <upvar> could i safely assume if that error comes up the video is bad and kill the ffmpeg process?
[13:39] <Mavrik> hmm
[13:39] <Mavrik> you can safely assume your framerate is wrongly set :)
[13:39] <upvar> same typo on both of them too
[13:40] <upvar> this is the command, no framerate specified /usr/bin/ffmpeg -i VID_20111231_171746.mp4 -acodec libvorbis -y -ss 0 -ac 2 -b 2000k 'video-hd.ogv'
[13:44] <Mavrik> why aren't you setting any properties for the video?
[13:44] <Mavrik> that just forces ffmpeg to guess (and it's pretty bad at it :P)
[13:45] <MrJones> are there any precompiled LGPL ffmpeg dlls out there?
[13:47] <upvar> Mavrik: back story, this company has given me a bunch of ffmpeg strings for different handheld devices, and i'm trying to batch convert a lot of their data for all these devices
[13:47] <upvar> but i'm pretty sure these ffmpeg strings are crackheaded
[13:47] <upvar> but short of getting a copy of all of the devices in question, not sure what i can do
[14:03] <eightfold> isn't it possible to set -s (size) in ffmpeg to something other than the presets?
[14:04] <Mavrik> it is.
[14:04] <Mavrik> well... depends on the codec actually
[14:04] <Mavrik> using scale= filter is the preferred way now though
[14:12] <eightfold> Mavrik: okay, i want to use it with libx264. are you talking about https://ffmpeg.org/ffmpeg.html#scale ?
[14:13] <Mavrik> eightfold, libx264 supports pretty much arbitrary resolution as long as it is divisible by 2
[14:13] <Mavrik> so -s 482x844 or -vf scale=482:844 should not be problematic
[14:14] <eightfold> Mavrik: thanks. is it in any way possible to specify only width or height and "lock" the aspect ratio from the source file?
[14:15] <Mavrik> eightfold, if you use the scale filter, yes
[14:15] <Mavrik> -vf scale=-1:720
[14:15] <Mavrik> for 720p :)
[14:15] <Mavrik> eightfold, check the documentation you linked :)
[14:32] <eightfold> Mavrik: ah, great. i will :) 
[15:18] <fris> im having an issue compiling ffmpeg and h264 http://pastie.org/3112490 anyone have any ideas?
[15:28] <relaxed> fris: are you using the latest git source from both?
[15:35] <fris> using 0.9 and x264 0.120.x
[15:38] <relaxed> use git source
[15:39] <fris> ffmpeg?
[15:39] <fris> or x264
[15:43] <relaxed> both
[18:51] <hiexpo> morning all compiling ffmpeg and am getting and error libx264 not found and i have x264 installed
[18:51] <Hyperi> Well apparently it can't find it
[18:52] <Hyperi> Can you define the path to x264 with configure script ?
[18:52] <hiexpo> is it looking for x264 in which i compiled or does it actually need libx264  
[18:54] <hiexpo> i am looking in my packages and i have x264 and libx264-85 installed
[19:10] <relaxed> it needs libx264 and a version recent to the ffmpeg version you're compiling.
[19:11] <relaxed> download the latest source via git for both and you'll be good to go.
[19:11] <hiexpo> relaxed, yes i got  it 
[22:24] <dericed> I'm trying to create a quicktime file with pcm_s24be audio using the fourcc 'in24'. But -atag in24 has no effect. http://pastebin.com/nFyhDNpS  Is there a way to force the codecid to in24?
[22:25] <dericed> Looks like ffmbc respects "-atag in24" but ffmpeg doesn't.
[22:40] <iiu7> I have a MKV movie with this set of streams: http://pastebin.com/ANgXtBHr, I want to convert the audio stream to mp3 instead of dts because it isn't support on my tv.
[22:41] <iiu7> I have tried using this command: "ffmpeg -i foo.mkv -map 0:0 -map 0:1 -sameq -vcodec copy -acodec libmp3lame foo-new.mk" but I get the error: "Number of stream maps must match number of output streams"
[22:41] <iiu7> What am I doing wrong?
[22:42] <relaxed> iiu7: 1) never use -sameq 2) -acodec libmp3lame -aq 0 -ac 2
[22:42] <iiu7> why not sameq?
[22:43] <iiu7> ah, because vcodec copy ofcourse
[22:45] <iiu7> Alright, with the above change into this: "ffmpeg -i foo.mkv -vcodec copy -acodec libmp3lame -aq 0 -ac 2 foo-new.mkv", get this error: "Encoder (codec id 94210) not found for output stream #0.2"
[22:46] <iiu7> I don't understand that error.
[22:48] <relaxed> pastebin
[22:51] <iiu7> http://pastebin.com/ghjWXTiP
[22:52] <ubitux> you need to map only a & v streams, or specify a scodec for the subtitle stream
[22:52] <ubitux> such as -scodec copy
[22:54] <iiu7> ubitux, thanks! If I only wanted 1 subtitle stream how would I do that? Using -map 0:1 -map 0:2 -map 0:5 for example?
[22:54] <ubitux> yes
[22:55] <ubitux> -map also has some stream type specifiers
[22:55] <ubitux> 'v' for video, 'a' for audio, 's' for subtitles, & check the documentation
[22:55] <ubitux> you might find a simpler way
[22:56] <iiu7> Thanks!
[23:03] <iiu7> I'm now trying to strip the Chinese subs and keep the english ones only using this command: "ffmpeg -i foo.mkv -vcodec copy -acodec libmp3lame -ac 2 -map 0:0 -map 0:1 -map 0:2 -map 0:3 -map 0:4 foo-new.mkv" then I get the error "Number of stream maps must match number of output streams"
[23:03] <iiu7> Maybe I haven't understood the streams part or how to map correctly.
[23:11] <relaxed> iiu7: To keep things organized, use -map [stream] [encoding options for that stream] -map [stream 2] [etc...]
[23:12] <relaxed> I only see 3 streams in your pastebin.
[23:13] <iiu7> There are 5.
[23:13] <iiu7> http://pastebin.com/sSP4dFmS
[23:14] <iiu7> Actually 6, sorry
[23:14] <iiu7> 1 video, 1 audio, and 4 subs
[23:14] <relaxed> you only want english subs?
[23:15] <iiu7> yes, I'm trying with this (reorganized) "ffmpeg -i foo.mkv -vcodec copy -acodec libmp3lame -map 0:0 -map 0:1 -map 0:2 -map 0:3 foo-new.mkv "
[23:15] <iiu7> But this gives me: Numbers of streams..
[23:16] <relaxed> ffmpeg -i foo.mkv -map 0:0 -vcodec copy -map 0:1 -acodec libmp3lame -aq 0 -ac 1 -map 0:2 -scodec copy -map 0:3 -scodec copy output.mkv
[23:18] <iiu7> Using the one you just make I still get "Number of stream maps must match number of output streams"
[23:18] <iiu7> However I see your point about the organizing.
[23:18] <relaxed> pastebin your command and all output
[23:19] <iiu7> http://pastebin.com/gRfqYhJd
[23:22] <cbsrobot> iiu7: what version is that ?
[23:22] <cbsrobot> ffmpeg version , Copyright (c) 2000-2011 the FFmpeg developers
[23:23] <iiu7> It's the one from debian-multimedia for squeeze.
[23:23] <relaxed> hmm, that command should work
[23:25] <relaxed> iiu7: try -map 0:v -vcodec copy -map 0:a -acodec libmp3lame -aq 0 -ac 1 -map 0:s:0 -scodec copy -map 0:s:1 -scodec copy output.mkv
[23:27] <iiu7> Same error: Number of streams..
[23:28] <relaxed> this is the only thing it said, "Number of stream maps must match number of output streams"? You didn't omit anything?
[23:29] <iiu7> yes, only that!
[23:31] <relaxed> I'm out of ideas
[23:32] <iiu7> relaxed, thanks for your time!! I'll just have to keep those subs in then. At least I got the conversion of the audio.
[23:35] <iiu7> It does the same even if I use -scodec copy for all the subtitle stream.
[23:35] <iiu7> Just to try.
[23:38] <cbsrobot> iiu7: try: ffmpeg -i foo.mkv map 0:0 -map 0:1 -map 0:2 -vcodec copy -acodec libmp3lame -aq 0 -ac 2  output.mkv -scodec copy -newsubtitle 
[23:40] <iiu7> Same error: Number of streams..
[23:41] <cbsrobot> ffmpeg -i foo.mkv map 0:0 -map 0:1 -map 0:2 -vcodec copy -acodec libmp3lame -aq 0 -ac 2 -scodec copy output.mkv -newsubtitle
[23:43] <iiu7> I tried that myself, that gives me "At least one output file must be specified".
[23:43] <iiu7> From what I understand, the following command should work and just copy ALL subtitles.
[23:43] <iiu7> ffmpeg -i foo.mkv -map 0:0 -vcodec copy -map 0:1 -acodec libmp3lame -aq 0 -ac 2 -map 0:2 -scodec copy -map 0:3 -scodec copy -map 0:4 -scodec copy -map 0:5 -scodec copy output.mkv
[23:43] <iiu7> I tried this to make sure all streams are covered.. but.. this also gives me Number of streams..
[23:44] <iiu7> I don't get that!
[23:47] <relaxed> iiu7: run, dd if=foo.mkv of=output.mkv bs=10M count=1
[23:48] <relaxed> and stick a sample up somewhere
[23:51] <iiu7> Is there a place to stick it without registration?
[23:51] <cbsrobot> megaupload
[23:51] <cbsrobot> iiu7: last try - without reencoding:
[23:51] <cbsrobot> ffmpeg -i foo.mkv -vcodec copy -map 0.0 -acodec copy -map 0.1 output.mkv -scodec copy -map 0.2 -newsubtitle
[23:52] <iiu7> Number of streams.. :)
[23:52] <cbsrobot> wtf
[23:53] <iiu7> 1 sec, I'll upload the sample
[23:54] <relaxed> iiu7: get a dropbox account for 2gb of free storage http://db.tt/cDWPLzP
[23:54] <iiu7> I have another box posting something to usenet, so it's a bit slow in the upload.. 2 min
[23:58] <iiu7> I made it smaller, only 1 MB, here: http://www.megaupload.com/?d=SPLV9RPC
[00:00] --- Tue Jan  3 2012

More information about the Ffmpeg-devel-irc mailing list