[Ffmpeg-devel-irc] ffmpeg.log.20120104

burek burek021 at gmail.com
Thu Jan 5 02:05:01 CET 2012

[00:04] <upvar> hey i'm trying to do a slice of an old episode of startrek and the output file (i only want 10-20 seconds) has some audio lag of about a second
[00:04] <upvar> tried a variety of things, not sure what i can do to get the best sync
[00:06] <pasteeater> Amok time.
[01:25] <acerimmer> command line question: need to (1) convert .bmp image sequence to video and (2) overlay a logo on the video.  Prefer to do this in one pass as multiple renders degrade video.
[01:27] <pasteeater> acerimmer: two things to get you started: http://ffmpeg.org/faq.html#How-do-I-encode-single-pictures-into-movies_003f
[01:27] <pasteeater> http://ffmpeg.org/libavfilter.html#overlay-1
[01:29] <acerimmer> pasteeater: thanks.
[01:32] <acerimmer> I've successfully rendered a .mp4 from .bmp image sequence.  Then rendered the mp4 AGAIN to overlay a .png logo.  .mp4 is now visibly degraded.  How do I render both image sequence and logo in  a single pass?
[01:34] <pasteeater> ffmpeg -i input%d.bmp -vf overlay="your over stuff goes here" -c:v libx264 -preset medium -crf 22 output.mp4
[01:42] <acerimmer> pasteeater: You Da Man!  I'll try it.  Thanks!
[01:47] <pasteeater> your syntax can vary depending on how old your ffmpeg is
[01:48] <acerimmer> pasteeater: seems to be missing a step - I need the .bmp's to render at 24 fps.
[01:51] <acerimmer> pasteeater: http://pastebin.com/14K4Aawk for the present two step proces
[01:54] Action: newl hasn't seen a bmp in 15 years
[01:56] <acerimmer> newl: used Star Wars Crawl Text Creator on my ihackintosh to create the video intro.  It only outputs .bmp
[02:13] <pasteeater> acerimmer: then add '-r 24' before -i
[02:14] <pasteeater> you don't need to do this in two steps
[02:15] <acerimmer> pasteeater: that was my hope
[03:00] <tlvince> I have ten images names 0{0..9}.jpg, using "ffmpeg -f image2 -r 5 -i %02d.jpg -s 640x480 output.mp4" seems to use only half the images?
[03:02] <newl> half the images ie 5 or half the image in the image?   is the image really there - check with feh
[03:04] <tlvince> newl: half the images ie 5
[03:04] <tlvince> they show up in feh
[03:05] <newl> do the script using ls instead of ffmpeg until you figure out the problem
[03:05] <newl> pastbin the exact script
[03:11] <tlvince> newl: https://gist.github.com/1558087
[03:12] <xxthink> are there some audio de-noise filter?
[03:13] <tlvince> xxthink: not that I've specified
[03:14] <newl> for i in *.jpg; do
[03:14] <newl>   if [ $i == \*.jpg ]; then
[03:14] <newl>     echo no jpg files
[03:14] <newl>    else
[03:14] <newl>      {
[03:14] <newl>      echo ffmpeg command using $i for files
[03:14] <newl>      ffmpeg command using $i for files
[03:14] <newl>      }
[03:14] <newl>   fi
[03:14] <newl> done     ^^ tlvince
[03:16] <xxthink> tlvince: you mean there are not audio denoise filter in ffmpeg now?
[03:28] <metvik> can ffmpeg normalise audio or do dynamic range compression? if not, is there any plan to implement this?
[03:56] <SteveTheCat> I don't see x264 in my ffmpeg -codecs
[03:57] <SteveTheCat> but i put --enable-libx264
[03:57] <SteveTheCat> in the ./configure
[03:58] <newl> you don't see 113: D V D  h264            H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10
[03:58] <newl> 133:  EV    libx264         libx264 H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10
[04:00] <SteveTheCat> newl I don't see libx264 
[04:00] <SteveTheCat> but I do see h264
[04:02] <mystica555_> SteveTheCat: you do have the libraryt installed, right?
[04:02] <mystica555_> *library
[04:02] <SteveTheCat> yes
[04:03] <mystica555_> did the ./configure script error on any of the libx264 tests?
[04:03] <newl> yea check the config.log to see what happened when it looked for the libx264
[04:03] <SteveTheCat> i used --extra-cflags=-I/usr/local/customvlc/x264/include --extra-ldflags=-L/usr/local/customvlc/x264/lib
[04:03] <SteveTheCat> i can't find any search results for missing
[04:04] <SteveTheCat> I don't seen any errors for libx264 http://pastebin.com/DSzjXkzj
[04:04] <SteveTheCat> see*
[04:07] <mystica555_> hmmm
[04:09] <SteveTheCat> what repos could be conflicting with this?
[04:09] <SteveTheCat> it's probably some repo i have
[04:11] <mystica555_> not certain; what i usually end up doing is putting all my third-party (locally done) stuff all in /usr/local;  by default i find ./configure without a --prefix moves everything there. you may want to try this with your additional libraries; then, configuring ffmpeg to use /usr/local as its prefix should find your dependencies 
[04:13] <stpere> hi!
[04:13] <stpere> quick question
[04:13] <stpere> http://ffmpeg.org/doxygen/trunk/alsdec_8c-source.html#l01009
[04:13] <stpere> wouldn't zero_remaining() would contain an infinite loop? :P
[04:18] <SteveTheCat> --prefix works for libs too?
[04:21] <newl> SteveTheCat: prefix is just where it is to be installed - so yes
[04:22] <newl> SteveTheCat: does the entries in /etc/ld.so.conf  or  cpp -v   show where your custom include and libs for x264 are?
[04:23] <SteveTheCat> i thought --extra-cflags=-I/usr/local/customvlc/x264/include --extra-ldflags=-L/usr/local/customvlc/x264/lib  is okay
[04:23] <mystica555_> SteveTheCat: --prefix i believe sets the entire prefix for default code searching of anything being compiled/installed
[04:23] <SteveTheCat> i'll try it out now
[04:24] <newl> mystica555_: just for install
[04:24] <mystica555_> only install?
[04:24] <mystica555_> hrmf
[04:24] <SteveTheCat> :(
[04:24] <newl> if not just for install then i've been mislead for 15 years ;)
[04:24] <SteveTheCat> but honestly i think a repo is interferring
[04:24] <mystica555_> so it doesnt make any bearing on where includes are?
[04:24] <mystica555_> or where the compilation process finds said includes?
[04:25] <newl> mystica555_: do a search on the system for the libs   you have locate/slocate?
[04:25] <mystica555_> yes
[04:25] <mystica555_> although, im not the one with the unfindable libs problem today
[04:26] <newl> lol /s/ mystica555_ / SteveTheCat    ... unfindable libs problem 'TODAY' ? ;)
[04:26] <mystica555_> ive had a few in the past due to pkg-config not finding its files ;)
[04:27] <SteveTheCat> but i'm not getting an unfindable x264 lib
[04:27] <mystica555_> well the includes for the local version seem to not be found..
[04:28] <maximumHAX> how can I get vhooks? do I have to compile ffmpeg a certain way.. I remember on slackware I had vhook/drawtext.so on gentoo I don't what happened?
[04:28] <mystica555_> sort of similar, but i didnt use the best wording
[04:29] <maximumHAX> seems my fedora machine has no drawtext.so either
[04:30] <newl> that might be a devel lib - do you have the dev lib package installed
[04:30] <maximumHAX> on gentoo I believe all would be dev.. but fedora no.. just ffmpeg
[04:32] <newl> the so is a 'dev' link to the 'real' lib used in compiling - not running the app
[04:33] <SteveTheCat> libavdevice.so.53: cannot open shared object file: No such file or directory
[04:33] <SteveTheCat> now we have progresss my friends
[04:34] <newl> that lib is created when you compile ffmpeg
[04:34] <SteveTheCat> well apparently it works when i used yum install for libav
[04:35] <SteveTheCat> and now i have x264 after deleting some repos and installing libav and compiling
[04:38] <newl> magic
[04:42] <aca20031> offtopic - for burning dvds for use on standard american dvd players - PAL or NTSC?
[04:44] <newl> america is ntsc - but where are you getting the choice?
[04:45] <aca20031> nero
[04:45] <mystica555_> all of north america, parts of south america, japan, a few other countries
[04:45] <mystica555_> use ntsc
[04:45] <aca20031> dvd refuses to play in dvd player, windows media players the menu then says Unknown DVD when you make a choice :(
[04:45] <aca20031> I was hoping that was the issue
[04:45] <aca20031> apparently its not
[04:47] <newl> aca20031: growisofs is kinda easy from command line - and ntsc vs pal ain't your problem
[04:47] <aca20031> yeah well i need a program that creates a decent dvd menu that i can customize, took me all day to find that nero works fine (encore: failed, roxio: failed)
[04:47] <aca20031> finally get nero, make my menus and dvd covers, and the damn thing wont play
[04:48] <aca20031> freaking rediculous
[04:48] <newl> try  mplayer dvd://
[04:49] <aca20031> i kinda need it to play on a dvd player, if i just wanted to view it on a computer i wouldnt be burning :P
[04:49] <aca20031> thanks though
[04:49] <mystica555_> well if mplayer barfs on it, perhaps nero is doing something reallly wrong
[04:50] <aca20031> it plays in my ps3
[04:50] <aca20031> windows media player plays the menu, but the film, and a dvd player doesnt play shit lol
[04:50] <aca20031> its rediculous
[04:50] <aca20031> feel like i live in bizzaro world
[04:50] <newl> is it encrypted? libdvdcss needed?
[04:50] <aca20031> erm, im not sure why nero would encrypt anything
[05:30] <SteveTheCat> i'm currently converting with ffmpeg
[05:30] <SteveTheCat> does time=01:53:55.42 mean 1 hour and 53 minutes left?
[05:59] <Skaag> how do I find out what qmin and qmax mean when I encode a clip with libx264?
[06:03] <defaultro> cat it then grep x264
[06:04] <Skaag> I'm experimenting with those params, to achieve better encoding quality
[06:04] <Skaag> right now I've set qmin to 8 and qmax to 10
[06:05] <Skaag> I wonder if there's a tool for Mac that analyzes mp4 files to show bit rate behavior in VBR streams
[06:05] <Skaag> I think I saw something like that for Windows
[06:31] <Skaag> can ffmpeg do auto key framing on scene change?
[06:49] <Skaag> ok I found the scene cut parameter
[08:42] <severnaya> hi, i'm trying to compile ffmpeg but it keeps breaking with the error: libmpcodecs/vd_ffmpeg.c:833:10: error: 'AVCodecContext' has no member named 'hurry_up'. and then vd_ffmpeg.o fails to build
[08:43] <severnaya> can anyone point me in the right direction?
[09:44] <simon> hello, someone here? i have a question regarding MPEG-TS muxing
[09:51] <sprayd> hello michaelni 
[09:54] <sprayd> i hope you remember this task michaelni http://www.google-melange.com/gci/task/view/google/gci2011/7185251
[09:58] <sprayd> i never got reply to the letters i sent to the iso authorities
[12:55] <MrChrisDruif> Hello everyone, just a quick question: how do you use the verbosity level with ffmpeg? Is it -v verbose or what should the proper syntax be
[12:57] <MrChrisDruif> The question I asked is for smile4ever, who just joined this channel
[12:57] <smile4ever> :)
[13:10] <MrChrisDruif> No one?
[13:12] <smile4ever> please help me :)
[15:36] <egoc> hi. i'm trying to encode an avi video to mkv or mp4 but i keep getting this error. can anyone help? http://pastebin.com/BuDDWrbe
[15:39] <relaxed> egoc: -ab 128k
[15:40] <JEEB> yeah, you haven't set a bitrate for audio
[15:40] <JEEB> also personally I would just use the highest crf that still looks good for you instead of an arbitrary bitrate
[15:41] <egoc> i still get the same error
[15:41] <relaxed> rm -bt 1000k
[15:42] <egoc> relaxed: still not working
[15:42] <JEEB> re-pastebin pl0x
[15:43] <relaxed> I see "[libfaac @ 0x14ef700] libfaac doesn't support this output format!" but don't know what it's referring to.
[15:43] <egoc> http://pastebin.com/WxYXf5sz
[15:44] <j^> ffmpeg -h lists  "ffmpeg -vf filter list" as a command to list filters
[15:44] <j^> that does not work, anyone knows how to list the filters?
[15:46] <egoc> that's what i get when i remove -bt and add -ab
[15:46] <relaxed> egoc: It's tripping up on the audio. run, "dd if=input.avi of=sample.avi bs=5M count=1" and upload the sample somewhere. 
[15:47] <egoc> relaxed: where should i upload it?
[15:48] <relaxed> egoc: get a dropbox account for 2gb free storage http://db.tt/cDWPLzP 
[15:52] <relaxed> j^: ffmpeg -filters
[15:54] <egoc> relaxed: http://www.mediafire.com/download.php?9psd6fvukyc92r3
[15:58] <relaxed> egoc: Works here although I'm using libvo_aacenc instead of libfaac. Compiling a recent version ffmpeg will probably fix it.
[16:11] <egoc> relaxed: still not working. how do i use libvo_aacenc? i get Unknown encoder 'libvo_aacenc'
[16:12] <relaxed> It should be available through your distro.
[16:13] <relaxed> Install the -dev pacakge and configure ffmpeg with --enable-libvo-aacenc, then use -acodec libvo_aacenc
[17:30] <gtaylor> I'm doing a 2-pass encoding of an AVI that appears to be about 10 years old. The AVI file's audio/video are fine, but when I 2-pass encode it with h264 and libfaac to mp4, I get slowed down audio and a ton of static.
[17:30] <gtaylor> Here is the output of ffmpeg -i and my encoding settings for the first and second pass, respectively: http://pastebin.com/XdD0XcR3
[17:31] <gtaylor> There are warnings about packets/times being invalid for the audio and video streams in ffmpeg -i.
[17:40] <raven> hi
[17:41] <silverrocker> Hi, I have a question for the ffmpeg community. I have my bachelor thesis comming up (which will start in about a month). I'm intressted in videocompression and things that are related to multimedia compression. I'm still quite unsure what my subject will be. I thought it might be a good place to ask here. I have read some of the SoC project proposals but still I feel quite lost.
[17:45] <raven> 80gb raw dv file freezes at a point and ffplay is not controllable any more while time is still running. what could that be? other tools tell me about eof at this point
[17:57] <raven> hi
[18:16] <sgfgdf> hello, guys! i'm trying to convert vob file to mp4 or mov file, but when using ffmpeg -i file.vob -vcodec copy -acodec copy file.mp4 i got erros -- http://cl.ly/190X1Q2k2k3G113V3f0j . can onyone help, please?
[18:24] <Nagy> will open_codec now automatically start threads? even if thread_count is set to 0?
[18:25] <relaxed> sgfgdf: why would you want to copy it into mp4?
[18:26] <sgfgdf> relaxed: i need to convert that vob to format that Final Cut Pro opens (which i hope mp4 is one of it).
[18:27] <vivienschilis_> quick question why is there a ffpresets and presets folder?
[18:27] <vivienschilis_> in the git
[18:31] <relaxed> sgfgdf: change the filename from file.vob to file.mpeg and see if it will open
[18:35] <sgfgdf> relaxed: no it doesn't want to open.
[18:38] <relaxed> sgfgdf: ntsc or pal?
[18:40] <relaxed> ffmpeg -i file.vob -target ntsc-dv output.dv (output will be HUGE)
[18:42] <sgfgdf> relaxed: so what the .dv file means?
[18:42] <relaxed> http://en.wikipedia.org/wiki/DV
[18:47] <sgfgdf> relaxed: does only because of the uncompressed audio the file is going to be so big?
[18:51] <sgfgdf> relaxed: anyway, probably it will work. thank you!
[20:10] <_sascha> i, is it possible to switch audio channels (example switch audio channel 1 (german) with channel 2 (englisch)) so that the new channel 1 is english and channel 2 is german ?
[20:24] <cbreak> _sascha: in a stereo audio track?
[20:25] <cbreak> mplayer can do that with -af pan or -af channels
[20:25] <cbreak> but it'll need reencoding of the audio
[20:40] <relaxed> ls
[20:40] <relaxed> sorry
[20:43] <MrJones> hi
[20:44] <MrJones> is it actually possible to replace a program's dynamically linked FFmpeg with another without issues? due to libavcodec/avconf.h
[20:45] <MrJones> so will a program compiled with one particular set of FFmpeg features reflected through that header file actually recognise another FFmpeg dll with another featureset properly?
[20:47] <pasteeater> _sascha: i think you can use the map option to arrange desired stream
[20:51] <pasteeater> as in: ffmpeg -i input -map 0:0 -map 0:4 -map 0:1 -c copy output
[20:54] <Freakshow> hmm... is -strict experimental still used by anyone?
[20:55] <pasteeater> Freakshow: -acodec aac, -acodec vorbis, probably some more
[20:58] <cbreak> MrJones: that's the point of dynamic libs :) As long as they are binary compatible, there's no problem from the pure linking perspective
[20:59] <MrJones> cbreak: so are things like the available codecs and other stuff, despite surely being stored in that avconf.h aswell, still taken out of the runtime lib?
[20:59] <JEEB> cbreak, you for get one thing
[20:59] <JEEB> that works as long as the ABI is the same
[20:59] <MrJones> yea, and do different options alter the ABI for FFmpeg?
[20:59] <cbreak> the ABI is decided on by the compiler/operating system vendor
[20:59] <cbreak> I included it in binary compatibility
[20:59] <JEEB> and the application at hand >_>
[21:00] <JEEB> if you have made something with ffmpeg 0.6
[21:00] <JEEB> it might not work as-is with ffmpeg 0.9
[21:00] <JEEB> :P
[21:00] <MrJones> well it is surely obvious that FFmpeg has enough possibilities to ruin the ABI
[21:00] <MrJones> which is why I am asking if it does with different options
[21:00] <JEEB> anyways, not sure but it's mostly safe in case you're linking against a similar'ish version
[21:00] <cbreak> options should not affect binary compatibility
[21:00] <MrJones> so same version, vastly different options (like, LGPL with no output devices, no input devices, no protocols) will still be compatible with a GPL dll with output devices?
[21:00] <cbreak> unless you do something stupid like microsoft
[21:01] <MrJones> and be able to use them?
[21:01] <cbreak> and change the size of types that you pass by value
[21:02] <MrJones> doesn't it change with the choice of audio codecs?
[21:02] <MrJones> or is it always the worst case of all audio codecs I could have chosen
[21:03] <JEEB> I would guess the latter
[21:07] <MrJones> hm
[21:08] <MrJones> the avconf.h file apparently contains only whether it is a big endian system or fast unaligned is available
[21:08] <MrJones> so not terribly much :)
[21:37] <_sascha> Hi, I got an error and dont know what to do
[21:37] <_sascha> command: ffmpeg -i in.mkv -vcodec copy -acodec copy -scodec copy -y out.mkv
[21:37] <_sascha> error: [matroska @ 0x2028f00] Application provided invalid, non monotonically increasing dts to muxer in stream 0: 82 >= 42
[21:39] <relaxed> _sascha: are you using a recent version of ffmpeg?
[21:41] <_sascha> yes... 0.9 from a ppa
[21:46] <_sascha> relaxed: first I tried it with an older version, but an upgrade didn't solve the problem
[21:51] <basilgohar> I see reference to -lameopts in some documentation in the ffmpeg source tree, but there does not appear to be any actual -lameopts parameter used, even when used in conjuction with -acodec libmp3lame.
[21:51] <basilgohar> I'd like to use features like LAME's presets, which I believe are only accessible through -lametops.
[21:51] <basilgohar> (opts
[21:51] <basilgohar> Any ideas?
[22:02] <pasteeater> basilgohar: the only private libmp3lame option i see is -reservoir 
[22:03] <basilgohar> pasteeater: Okay.  But I believe there used to be -lameopts, and that is referenced all over the place, but it does not seem to be valid anymore.
[22:04] <relaxed> _sascha: use mkvmerge
[22:05] <pasteeater> basilgohar: ah, i see it's in libavfilter/libmpcodecs/help_mp.h
[22:05] <pasteeater> must be a mencoder option
[22:05] <_sascha> ok, thx
[22:05] <basilgohar> pasteeater: Yes, I see it.  I just did a git log -S and found ti was introduced only in documentation about MPLayer.
[22:06] <basilgohar> So, it's not something ffmpeg itself has ever had.
[22:06] <pasteeater> you could add a feature request on the bug tracker
[22:07] <basilgohar> Okay.  Thanks!
[22:07] <basilgohar> ffmpeg handles tags nicely from FLAC to MP3, which is why I'm interested.
[22:07] <pasteeater> what lame options are you interested in?
[22:07] <basilgohar> Only because my cell phone and, it seems, many car audio head units only support MP3.
[22:07] <basilgohar> pasteeater: Mainly -preset standard
[22:08] <basilgohar> I don't think that's the same as just VBR encoding, so just using -aq whatever won't be the same.
[22:10] <pasteeater> preset standard appears to be VBR
[22:11] <pasteeater> md5sum of '-V2' and '--preset standard' are the same
[22:11] <pasteeater> so i guess use -q:a 2
[22:12] <basilgohar> pasteeater: That's interesting...I'll have to compare the two and see for myself.
[22:12] <basilgohar> It could be source-dependent, as well.
[22:12] <basilgohar> I know, for example, -preset standard doesn't go below 128kbps, for example.
[22:12] <basilgohar> At least, it once was like that.
[00:00] --- Thu Jan  5 2012

More information about the Ffmpeg-devel-irc mailing list