[Ffmpeg-devel-irc] ffmpeg.log.20120105

burek burek021 at gmail.com
Fri Jan 6 02:05:01 CET 2012

[01:21] <Freakshow> curiously I'm seeing this in my log output
[01:21] <Freakshow> h264_mp4toannexb failed for stream 0, codec libx264: Invalid data found when processing input
[01:21] <Freakshow> with this cmd line
[01:22] <Freakshow> ffmpeg -i "/usr/local/bin/sample.mp4" -threads 0 -re -vcodec libx264 -profile high -preset medium -g 30 -acodec libfaac -ab 128000 -ar 48000 -ac 2 -vbsf h264_mp4toannexb -f flv
[01:22] <Freakshow> shooting to rtmp://
[01:22] <Freakshow> the sample.mp4 is from wowzamediaserver-2.2.4
[01:24] <Freakshow> google doesn't really give me much info on that log output
[01:27] <Freakshow> is there something wrong with the command line that I'm using that would produce that wonky output?
[01:57] <maximumHAX> probably a stupid question.. but when using ffmpeg to add text overlay why does the 1st part of video look great, then 5 sec into it degrades, compute performance? or setting?
[01:59] <maximumHAX> in and out video is same format.. no settings passed except input video output name and -vf drawtext
[03:17] <relaxed> Freakshow: I think you only need "-vbsf h264_mp4toannexb" if you're copying from mp4. Did you try without it?
[04:49] <Soul_keeper> Does -vb not work with libvpx encoding ?
[05:02] <Soul_keeper> appears that ffmpeg encodes to about 2x the specified bitrate
[05:25] <kcm1700> ffmpeg 0.9.1 released?
[05:33] <noisymouse> hi, how can I export a video as jpeg with the number of each frame added?
[05:36] <drv> noisymouse: http://ffmpeg.org/faq.html#How-do-I-encode-movie-to-single-pictures_003f
[05:42] <noisymouse> ok, I guess I can use that and have the image printer add the frame number/file name
[05:42] <noisymouse> I'd like the image itself to have the frame number embedded
[05:45] <relaxed> noisymouse: it could be done with two passes but I'm not sure about one pass.
[05:57] <noisymouse> two passes with ffmpeg?
[05:59] <Soul_keeper> I'm getting slight a/v sync issues with the following:  ffmpeg -i dvd-01.vob -threads 8 -f webm -vcodec libvpx -aspect 16:9 -vb 400k -r 30000/1001 -acodec libvorbis -ab 192k -y test.webm
[05:59] <Soul_keeper> any recommendations ?
[06:00] <Soul_keeper> seems that the audio is a few seconds ahead of the video
[06:01] <relaxed> noisymouse: Yes. Output all the frames to %06d.png, then run a for loop extracting the number from the filename and writing it to the frame.
[06:02] <noisymouse> ok, do you have a link for how to do the for loop?
[06:02] <relaxed> No, I just thought of it.
[06:03] <noisymouse> ok np
[06:06] <relaxed> something like, for i in *png; do ffmpeg -i $i -vf "drawtext=... text=${i%.*}" anotherdir/$i
[06:07] <relaxed> ; done
[06:07] <relaxed> ^^^^ should go on the end
[06:10] <shifter1> I have problem with ffmpeg and input buffering
[06:10] <relaxed> Soul_keeper: why are you changing the framerate?
[06:11] <shifter1> is there any way to increase the amount of input buffering ffmpeg can do?
[06:16] <Soul_keeper> relaxed, it appeared to be auto changing it to 60fps,  yet the original appears to be 25.80 fps
[06:16] <Soul_keeper> is 25.80 fps a common standard ?
[06:16] <relaxed> no, 25 would be pal
[06:17] <Soul_keeper> Stream #0:0[0x1e0]: Video: mpeg2video (Main), yuv420p, 720x480 [SAR 32:27 DAR 16:9], 8500 kb/s, 25.80 fps, 59.94 tbr, 90k tbn, 59.94 tbc
[06:17] <Soul_keeper> that is what ffmpeg spits out during the transcoding
[06:20] <Soul_keeper> i'll try without forcing it
[06:41] <chrisballinger> hey guys
[06:44] <chrisballinger> does anyone have any experience with the libavformat code for decoding Core Audio (.caf) files that contain AAC?
[06:44] <chrisballinger> http://www.hydrogenaudio.org/forums/index.php?showtopic=89889
[06:46] <relaxed> chrisballinger: ffmpeg can decode it if that's what you're wondering
[06:46] <chrisballinger> oh no i have a specific problem with a malformed file
[06:47] <chrisballinger> [caf @ 0x7fbee284ac00] Missing packet table. It is required when block size or frame size are variable.
[06:47] <chrisballinger> It is because the file didn't get "closed" properly when the recording was stopped
[06:48] <chrisballinger> so it is missing the packet table chunk: http://developer.apple.com/library/mac/#documentation/MusicAudio/Reference/CAFSpec/CAF_spec/CAF_spec.html#//apple_ref/doc/uid/TP40001862-CH210-DontLinkElementID_64
[06:49] <chrisballinger> the AAC contained inside the CAF is CBR, so hopefully that would help us reclaim the lost data
[06:49] <relaxed> There are some audio devs that hang out in #libav, try asking there.
[06:49] <chrisballinger> by rewriting a new packet table
[06:49] <chrisballinger> cool thanks!
[06:57] <darkstarbyte> Is there a way to cut parts of a video out without reconverting it?
[06:59] <relaxed> darkstarbyte: look at mkvmerge's --split
[07:18] <darkstarbyte> Anything a little more advanced?
[07:19] <darkstarbyte> That does not have all of the stuff I need
[07:38] <sam1> hi guys,i use ffmpeg to convert *.srt  to *.ass  but the last text always on top of video.
[08:05] <Skaag> I'm trying to crop a 16:9 clip to 4:3 
[08:05] <Skaag> (I don't mind losing the left & right sides)
[08:06] <Skaag> I tried setting the dimensions, and setting the -aspect to 16:9
[08:06] <Skaag> (doesn't work)
[08:14] <Skaag> how do I set the source aspect to something other than 1:1
[09:07] <kcm1700> it'd be better if topic is changed from 0.9 to 0.9.1 maybe?
[11:33] <silverrocker> I have some questions concerning Google Summer of Code and ffmpeg project proposals. Where should I go with my questions
[11:35] <Mavrik> silverrocker, mailing lists most likely
[11:35] <Mavrik> -dev?
[11:35] <silverrocker> just noticed that there was an ffmpeg-devel channel :) I will go there thanks
[13:22] <iOOO9> i'm trying to get my head around this... what is mpeg-4? if something tells me they've sent me a mpeg-4 file, what does that actually say?
[13:24] <Soul_keeper> iOOO9, http://en.wikipedia.org/wiki/MPEG-4
[13:27] <iOOO9> Soul_keeper: didn't make me much saner. but from what i understand now it can be many things. a container format is one of them
[13:27] <keeperofdakeys> iOOO9: there are many parts to MPEG4
[13:28] <keeperofdakeys> there is the container, and three video specifications
[13:28] <Kuukunen> (or more, depends on who's counting)
[13:28] <keeperofdakeys> yeah, but what you actually encounter
[13:28] <keeperofdakeys> and not hidden away
[13:29] <Kuukunen> there's bunch of profiles :P
[13:30] <Kuukunen> iOOO9: usually it means it's something like .avi or .mp4 file with XviD or DivX (MPEG-4 ASP)
[13:30] <keeperofdakeys> "The key parts to be aware of are MPEG-4 part 2 (including Advanced Simple Profile, used by codecs such as DivX, Xvid, Nero Digital and 3ivx and by Quicktime 6) and MPEG-4 part 10 (MPEG-4 AVC/H.264 or Advanced Video Coding, used by the x264 encoder, by Nero Digital AVC, by Quicktime 7, and by high-definition video media like Blu-ray Disc)."
[13:30] <keeperofdakeys> of course H264 is usually never called mpeg4
[13:31] <keeperofdakeys> some later forms of WMV are based on mpeg4 too
[13:31] <Kuukunen> iOOO9: but if they're stupid, it might as well be something totally random renamed to something.mp4 :P
[13:32] <iOOO9> so part 10 seems to be h.264. but is there anything that specifies the combination of a audio + video codec?
[13:32] <iOOO9> like aac and h.264
[13:32] <Kuukunen> keeperofdakeys: the other ones aren't really "hidden", they're just not used
[13:32] <iOOO9> Kuukunen: not used? you mean the other parts except for part 2 and 10?
[13:33] <keeperofdakeys> Kuukunen: or, oblivous to normal users
[13:33] <Kuukunen> iOOO9: well MPEG-4 Part 14 is the "mp4" container...
[13:33] <Kuukunen> iOOO9: the profiles are included in Part 2
[13:33] <Kuukunen> "MPEG-4 Part 2 has approximately 21 profiles, including profiles called Simple, Advanced Simple, Main, Core, Advanced Coding Efficiency, Advanced Real Time Simple, etc"
[13:33] <keeperofdakeys> actually, more not used now I look at them
[13:33] <iOOO9> Kuukunen: and those profiles can be applied to both audio and video?
[13:33] <iOOO9> Kuukunen: or are those only for video?
[13:34] <keeperofdakeys> iOOO9: AAC is part 3
[13:34] <Kuukunen> iOOO9: those are video, but don't worry about them :P
[13:34] <keeperofdakeys> look at the wikipedia link, it clearly lists the parts
[13:34] <iOOO9> keeperofdakeys: yes
[13:34] <Kuukunen> and in case you're wondering: no, most of the weird parts are not really used
[13:35] <iOOO9> :)
[13:35] <keeperofdakeys> iOOO9: as for your original question, I guess you can say mpeg4 is usually mpeg4 video, not h264 video, mpeg2 video, or other types
[13:35] <keeperofdakeys> and depending on whether it uses b frames depends on whether it is simple profile or advanced simple profile
[13:35] <iOOO9> so when divx or xvid where written, they were written according to the mpeg-4 standard?
[13:36] <keeperofdakeys> iOOO9: divx used to be based on mpeg4 part 2, simple profile
[13:36] <keeperofdakeys> then some of the devs took it closed source, and others made xvid as an open source project
[13:36] <keeperofdakeys> and they both made codecs based on advanced simple profile (divx 5+)
[13:37] <keeperofdakeys> now divx 7 is h264, but divx isn't that popular anymore
[13:37] <keeperofdakeys> oh, I forgot to say divx used to be an opensource project
[13:39] <iOOO9> keeperofdakeys: divx 7 IS h.264? how can it be? doesn't h.264 have license that restricts that?
[13:40] <keeperofdakeys> iOOO9: the point is you pay money to use that license
[13:40] <iOOO9> keeperofdakeys: so that's why it is no longer open source?
[13:40] <keeperofdakeys> iOOO9: no, that occured long ago
[13:40] <iOOO9> ok
[13:44] <keeperofdakeys> ah, looks like divx has a project called "opendivx", but they stopped it, so people forked into xvid
[13:44] <keeperofdakeys> that was around version 4, which was only simple profile
[13:48] <Kuukunen> (and just in case you were wondering, there never was DivX 2, and the DivX 3 was just a hack and was never really fully MPEG-4 compatible anyway)
[13:48] <Kuukunen> at least afaik =P
[13:59] <iOOO9> am i right if i say that mpeg-4 opens for more variants of implementations than mpeg-2?
[14:00] <iOOO9> for video and audio stream in a container format
[14:00] <cbreak> mpeg-4 defines one container format based on QuickTime's Mov
[14:01] <cbreak> and a video codec with a bunch of versions
[14:03] <iOOO9> cbreak: and with a bunch of versions you mean divx, xvid etc
[14:03] <iOOO9> too
[14:03] <cbreak> I mean mpeg4 asp, mpeg4 avc
[14:03] <iOOO9> cbreak: and what does mpeg-2 offer compared to that
[14:03] <cbreak> mpeg4 also has levels
[14:04] <iOOO9> cbreak: ah, ok. and xvid/divx are built according to asp or avc
[14:04] <cbreak> with hardware decoders supporting less features than software decoders
[14:04] <cbreak> those limit the maximal bit rate, the number of reference frames, consecutive b frames
[14:04] <bigzed> Hello, I'm trying to demux some AVID media files with ffmpeg but actually I'm kind of lost and need a hint how to do it because I always get a file without a stream as an output
[14:04] <cbreak> the size of the frame and a whole bunch of other things
[14:04] <bigzed> here is a pastebin http://pastebin.com/ZnhbqvLL
[14:05] <bigzed> The whole idea is just to remove the AVID mxf container and get the stream out of the avid file
[14:05] <bigzed> has anyone a hint?
[14:07] <iOOO9> from a preservation and archival point of view mpeg-2 still seems to be the recommended format with the motivation that possible implementations are relatively more constrained.
[14:07] <iOOO9> does that seem logical to you people?
[14:17] <keeperofdakeys> iOOO9: mpeg4 and h264 are quite well standardised
[14:17] <keeperofdakeys> it just happens there are 'spinoffs'
[14:18] <indicator> is there anything in particular that would make the following have very bad audio quality? ffmpeg -loop_input -aq 1 -ab 256k -ar 22050 -qscale 1 -s 720x480 -b 300k -r 10 -i bwp.jpg -i Music/530.ogg -shortest bwp.mp4
[14:19] <keeperofdakeys> but h264 approaches reasonable-sized lossless video, so in that respect it is probably prefered
[14:34] <iOOO9> keeperofdakeys: does ffmpeg offer support of http://en.wikipedia.org/wiki/ProRes_422 as an input format?
[14:35] <keeperofdakeys> iOOO9: I have no idea, check ffmpeg -formats
[14:35] <keeperofdakeys> D is decode, E is encode
[14:35] <iOOO9> thanks
[14:35] <iOOO9> and thanks for all the great explanations :)
[15:15] <cbreak> for archival, I'd use h.264, it just has better quality than alternatives
[15:15] <cbreak> of course, if you want lossless, there are others
[15:26] <iOOO9> are mpeg-4 profiles and parts the same thing?
[15:42] <cryptopsy> in ffprobe some_vbr.mp3 , what do each kb/s mean ?
[15:42] <cryptopsy>   Duration: 00:11:19.23, start: 0.000000, bitrate: 252 kb/s
[15:42] <cryptopsy>     Stream #0:0: Audio: mp3, 44100 Hz, stereo, s16, 320 kb/s
[15:57] <Freakshow> relaxed: no I did not try that, let me give that a shot... 
[15:57] <Freakshow> oh, not here
[15:58] <relaxed> I'm here
[15:58] <Freakshow> irssi is acting strange. ok, yes... I'll give that a go
[15:58] <Freakshow> thanks!
[16:12] <simon_> hello there, does anybody has experience with ffmpeg on iOS and muxing / streaming the arc from the apple encoder?
[16:12] <simon_> *arc = aac
[16:17] <simon_> we are muxing an h264 and an aac stream into an mpeg-ts stream, but we get lots of errors regarding the audio stream at the receiving end, even the PID from the audio stream is going crazy
[17:43] <mkoch> hiho! is it possible to compile an universal binary from ffmpeg on os x lion? I need the static libs in a plugin which should also be compatible with both 32 and 64bit archs
[18:04] <tjholowaychuk> yo. I need to extract the audio from an flv and add it to an mp4
[18:04] <tjholowaychuk> i currently have two commands
[18:04] <tjholowaychuk> is it possible to do with one?
[18:27] <bigzed> Is it possible to encode DNX HD 120 and DNX HD 185 with ffmpeg?
[18:28] <bigzed> And is it possible to decode DNX HD 120 and DNX HD 185 with ffmpeg, because I was successfull for DNX HD 60, 90 and 90x but not for other formats 
[18:29] <bcoudurier> yes and yes
[18:31] <sangcn> Hello, Based on ffmpeg, Can we create the same program with http://www.photodvdcreator.com/ ?
[18:41] <lavluda> is it possible to send/stream a file through rtmp (red5 server)
[18:43] <relaxed> sangcn: yes
[18:43] <bigzed> bcoudurier: So, how would you decode it? Because I have some Avid Mediafiles here with those codecs and I'm trying to get a mpeg4 out of these. Can you help me with that?  Here the command I just up until know, which succeeds with codecs below 120 http://pastebin.com/rHUvdxJD
[18:44] <bigzed> Oh, I forgot input is 'something.mxf'
[18:45] <sangcn> relaxed: thanks
[19:00] <mkoch> is it possible that the configure script is broken? if I set --arch=x86_32 the script ignores it and in config.mak ARCH_X86_64=yes is the active one
[19:00] <bigzed> bcoudurier: Isn't it exactly this issue http://roundup.libav.org/issue2160? Because I'm trying to convert MXF files, too.
[19:03] <cbreak> mkoch: that's an invalid architecture string
[19:03] <mkoch> cbreak: what are the valid ones then?
[19:03] <cbreak> mkoch: maybe you want to use i386?
[19:03] <cbreak> read the config script :D
[19:04] <mkoch> well, the best would be to have universal binary on my mac os x lion
[19:04] <cbreak> not sure if it supports universal
[19:04] <cbreak> but if you're on a mac, there are really no reasons to use 32bit code unless you have deps you can't recompile
[19:05] <mkoch> cbreak: that's what I did, "x86_32" is in the ARCH_LIST
[19:05] <mkoch> cbreak: I need to use the lib in a browser plugin and chrome doesn't support 64bit plugins yet :(
[19:06] <cbreak> if you compile with gcc and give it -arch x86_64 -arch i386, you get a fat binary
[19:06] <cbreak> but I think ffmpeg has lots of special stuff that needs more
[19:06] <cbreak> so you can try to compile the libs for the architectures separately
[19:06] <cbreak> and then stitch them together with lipo
[19:08] <mkoch> cbreak: that's what I wanted to try but for that I need the 32bit version first. so why is x86_32 an invalid string? it's in ARCH_LIST (line 1113 in the latest version in the configure script)?
[19:08] <cbreak> use i386
[19:09] <cbreak> it's one of the standard gcc architectures
[19:09] <mkoch> trying...
[19:10] <mkoch> no luck...
[19:10] <mkoch> still the 64bit flag is active in config.mak
[19:11] <cbreak> does it matter?
[19:12] <cbreak> is the result 64 bit?
[19:12] <mkoch> sure, the linke complains that it can't find any symbols for the selected architecture (which is i386)
[19:14] <mkoch> (how can I find out the arch that a lib is build for form the .a file?)
[19:14] <cbreak> ask lipo or file
[19:14] <cbreak> lipo -info file
[19:14] <cbreak> or file file
[19:15] <cbreak> you can also check the .o files the compiler made
[19:15] <mkoch> thx
[19:16] <mkoch> ../ffmpeg/libavcodec/inverse.o: Mach-O 64-bit object x86_64
[19:16] <mkoch> so yes, the linker has right :(
[19:18] <mkoch> cbreak: any other idea maybe?
[19:18] <cbreak> trying it here
[19:18] <cbreak> the ffmpeg git is huge
[19:18] <mkoch> thanks!
[19:20] <cbreak> I am on 10.6 though
[19:21] <mkoch> (mine is 10.7.1 but i hope it doesn't matter)
[19:23] <cbreak> hmm... it's still 64 bit here too, with --arch
[19:25] <mkoch> re
[19:25] <cbreak> maybe you can get something to work with -m32 or so in CFLAGS and LDFLAGS
[19:26] <cbreak> have to cook now, but the -m32 should give you 32 bit builds... but it won't affect ffmpeg's self-recognition, so it might have 64 bit asm enabled and fail in spectacular ways or so...
[19:26] <cbreak> I'll try some more later
[19:26] <mkoch> cbreak: may I ask you to throw me a mail if you find out any useful?
[19:26] <mkoch> and thanks for the help so far
[19:28] <mkoch> I sent my address in priv
[19:28] <mkoch> I must leave now too, thx and bye
[19:31] <setuid> I'm trying to convert xmas video from my FLiP camera to something I can email/send/Dropbox to my girlfriend. The videos are coming out -larger- than the original source. 
[19:31] <setuid> I'm using ffmpeg -acodec mp2 -sameq 
[19:31] <setuid> Is there some other combination of options which will give me great quality but smaller file size, and be compatible with most Windows/Mac players? 
[19:40] <relaxed> setuid: ffmpeg -i input -vcodec libx264 -preset veryslow -threads 0 -crf 18 -acodec libvo_aacenc -ab 128k output.mp4
[19:40] <relaxed> If it complains about libvo_aacenc, try libfaac
[19:47] <setuid> giving that a go now
[19:48] <setuid> It doesn't like -preset or libx264
[19:48] <setuid> I'm using: FFmpeg version SVN-r0.5.1-4:0.5.1-1ubuntu1.1, Copyright (c) 2000-2009 Fabrice Bellard, et al.
[19:49] Action: setuid pulls an update and tries that
[19:50] <relaxed> yeah, builds from 2009 aren't going to work.
[20:00] <maujhsn> Anybody in this chat an expert with FFmpeg version SVN-r0.5.1-4:0.5.1-1ubuntu1.2?
[20:00] <maujhsn> smukherjee
[20:01] <maujhsn> crytopsy
[20:03] <pasteeater> that's ancient
[20:03] <pasteeater> maujhsn: what's your question?
[20:05] <maujhsn> pasteeater great hearing from you again!
[20:06] <maujhsn> pasteeater I am using ffmpeg on a liveUSB! I get some interesting results!
[20:07] <pasteeater> i never used one of those before
[20:08] <maujhsn> pasteeater my question : I am having a hard time finding the source directory so that I can re-compile ffmpeg!
[20:09] <maujhsn> pasteeater the liveUSB experience is very interesting!
[20:09] <pasteeater> did you already download the source?
[20:11] <maujhsn> pasteeater I downloaded ffmpeg from my synaptic package manager!
[20:11] <maujhsn> pasteeater FFmpeg version SVN-r0.5.1-4:0.5.1-1ubuntu1.2
[20:11] <pasteeater> do you want to compile recent ffmpeg or the old ffmpeg source that ubuntu provides?
[20:12] <maujhsn> pasteeater the old version that installed on my liveUSB.
[20:13] <setuid> relaxed, latest version in Ubuntu is: FFmpeg version SVN-r0.5.1-4:0.5.1-1ubuntu1.2, Copyright (c) 2000-2009 Fabrice Bellard, et al.
[20:13] <setuid> I just updated
[20:14] <maujhsn> setuid I had no idea that this was the latest version!
[20:14] <pasteeater> maujhsn: i think you can just: apt-get source ffmpeg
[20:14] <pasteeater> setuid: that may be the latest ubuntu provides for your ubuntu version
[20:15] <maujhsn> pasteeater what will this command do?
[20:15] <pasteeater> it will download the ffmpeg source that ubuntu used to create their ffmpeg package
[20:16] <pasteeater> setuid: but it's not the latest ffmpeg version and 0.5 isn't the latest that ubuntu provides for recent ubuntu
[20:16] <pasteeater> see topic in this channel for ubuntu ffmpeg compile guide if you want the newest you can get
[20:17] <maujhsn> pasteeater I will check that out as well!
[20:18] <setuid> pasteeater, sure is... 
[20:19] <setuid> relaxed, I'm pulling from git, building from HEAD now
[20:21] <maujhsn> pasteeater I am currently downloading kdenlive the video editor to a new liveUSB, and ffmpeg along with various other packages!
[20:22] <maujhsn> pasteeater It is going to be interesting to see how this experiment works out!
[20:31] <maujhsn> pasteeater Single photo to a 10 second .mpg movie is there a better command than this: ffmpeg -loop_input -i cab.png -r 29.97 -t 00:00:15 -qscale 4 cab_A.mpg? 
[20:33] <maujhsn> setuid any thoughts about my query?
[20:38] <pasteeater> maujhsn: that's 15 seconds
[20:39] <pasteeater> ffmpeg -loop_input -r 30000/1001 -i input -t 10 -qscale 4 output.mpg
[20:39] <pasteeater> or -r ntsc
[20:40] <maujhsn> pasteeater kdenlive & ffmpeg downloaded successfully onto my liveUSB! Question Why would I need to go sudo apt-get source ffmpeg?
[20:40] <pasteeater> you won't. i thought you wanted the source files for some reason
[20:40] <maujhsn> pasteeater "Your the best"!
[20:41] <pasteeater> your example will, by default, read the input file at 25fps and your output will be 29.97. better to tell it to read input at your desired output fps.
[20:41] <setuid> ERROR: libx264 version must be >= 0.118.
[20:41] <setuid> yuck
[20:42] <pasteeater> setuid: http://ubuntuforums.org/showthread.php?t=786095
[20:42] Action: setuid fetches more source
[20:42] <pasteeater> step-by-step, copy and paste instructions
[20:42] <pasteeater> there is a guide for each suported ubuntu version
[20:42] <maujhsn> pasteeater The only packages that I need to download are the medubuntu non-free extras! 
[20:51] <maujhsn> pasteeater In the previous example -r ntsc, can the ntsc-dv, ntsc-dvd switches apply as well?
[20:53] <pasteeater> not for -r, those are for -target
[20:55] <maujhsn> pasteeater "Ouch! Your right!"
[21:18] <defaultro> will this command make a proper mpg file? cat orig1.mpg orig2.mpg | ffmpeg -f mpeg -i - -vcodec copy -acodec copy merged.mpg
[21:20] <ubitux> it should; you also have ffmpeg concat: protocol
[21:21] <ubitux> ffmpeg -i concat:orig1.mpg,orig2.mpg -c copy merged.mpg should do the trick
[21:21] <defaultro> ok
[21:21] <defaultro> i'll use yours instead
[21:21] <defaultro> thanks
[21:35] <JetJaguarXP> Is there an option in FFmpeg to convert multiple files into one file?
[21:38] <JetJaguarXP> And I'm not talking about the joining of files.  I mean encode multiple files directly into one media file.
[21:39] <ubitux> you mean multiple a/v streams?
[21:39] <JetJaguarXP> No.
[21:40] <ubitux> the same video stream composed of multiple ones then?
[21:40] <ubitux> scale+overlay filters?
[21:41] <JetJaguarXP> I have to convert DVD's created by a court reporter to MPEG 1.  FFmpeg will read the VOB's on the DVD but there are multiple VOBs.  I want to convert them to one MPEG 1 file.
[21:41] <maujhsn> ubitux I going to experiment with that concat command!
[21:42] <ubitux> JetJaguarXP: then why are you telling it's not about joining them?...
[21:43] <JetJaguarXP> Because I'm not talking about using CAT to join files.  I'm wondering if FFmpeg can actually encode multiple source files into one output file.
[21:44] <maujhsn> ubitux Can you point to documentation that gives details about what you have just stated?
[21:45] <JetJaguarXP> http://ffmpeg.org/faq.html#How-can-I-join-video-files_003f
[21:45] <ubitux> JetJaguarXP: concat: then?
[21:45] <ubitux> maujhsn: yes just a second
[21:46] <ubitux> maujhsn, JetJaguarXP http://ffmpeg.org/ffmpeg.html#concat
[21:47] <JetJaguarXP> Is that just for ffplay?
[21:47] <ubitux> no
[21:47] <ubitux> protocols are supported by all the tools
[21:48] <maujhsn> ubitux Thanks!
[21:48] <maujhsn> jetjaguarxp Thanks!
[21:49] <ubitux> it's strange to see 3 random ppl asking the exact same thing at the same moment
[21:50] <maujhsn> ubitux "Silly question what is ppl?
[21:50] <ubitux> people
[21:52] <JetJaguarXP> Ok.  I'll give that a shot.
[21:52] <maujhsn> ubitux OK!
[21:53] <setuid> relaxed, Seems to be working now
[21:54] <setuid> rebuilt everything from source
[21:54] <setuid> it didn't like libvo_aacenc, but libfaac works
[21:56] <JetJaguarXP> ubitux  So...  /usr/bin/ffmpeg -i concat <files>  or take out the -i  ?
[21:57] <ubitux> ffmpeg -i concat:a.vob\|b.vob\|c.vob
[21:57] <JetJaguarXP> Cool thanks.
[21:57] <ubitux> defaultro: sorry btw, the sep is |, not a comma
[22:06] <maujhsn> I am extending this invitation to all of you in chat today! to subscribe to http://www.youtube.com/telesismedia "Practical applications of ffmpeg!
[22:07] <maujhsn> Learning ffmpeg is a continual work in progress!
[22:12] <JetJaguarXP> ubitux  concat worked like a charm
[22:15] <maujhsn> JetJaguarXP When using the "ffmpeg -i concat:a.vob\|b.vob\|c.vob" command does it have to be in /usr/bin/ffmpeg?
[22:16] <maujhsn> '/usr/bin/ffmpeg"
[22:16] <maujhsn> "/usr/bin/ffmpeg" correction!
[22:25] <EOF-sensei> why is it that ffmpeg -V doesn't return the version of libpostproc?
[22:27] <EOF-sensei> is this normal or am I doing something wrong at compile time?
[22:38] <JetJaguarXP> maujhsn  I just posted it that way.  It doesn't have to be.
[22:40] <maujhsn> JetJaguarXP "Thats good to know! I might still use your conventions!"
[22:41] <cbreak> mkoch: ./configure --arch=i386 --extra-cflags=-m32 --extra-ldflags=-m32
[22:41] <cbreak> hmm...
[22:49] <setuid> These vids are still converting to the same size as their original 
[23:04] <setuid> How do I shrink the aspect ratio of a given video when converting? -aspect 0.75 isn't doing what the docs claim it should
[23:04] <relaxed> setuid: you can scale the video down
[23:05] <blauefuesse> hi. If i was to convert a .flv file to .avi with this script: ffmpeg -i INPUT.flv -sameq OUTPUT.avi   ,then burn it to a CD, will i be able to watch it on a Televison DVD-Player ?
[23:08] <setuid> relaxed, with -vf scale, I see that, but what if I don't know the size of the original, to be able to do the math to get it to 0.75% of that size? Can I supply one value, like -vf scale=900? 
[23:08] <setuid> I don't want to squash the aspect ratio
[23:09] <relaxed> setuid: try this, ffmpeg -i input -vf scale=640:-1 ....
[23:10] <setuid> Ok, that worked 
[23:37] <praedo> hello
[23:38] <praedo> i need help with presets
[23:38] <praedo> in one computer it works and not in the other
[23:38] <praedo> i get this error:
[23:38] <praedo> File for preset 'ultrafast' not found
[23:38] <praedo> and on the comptuer where it works, i have the presets in /usr/local/share/ffmpeg
[23:38] <praedo> i would say the ffmpeg package installed is the same
[23:38] <praedo> i'm running archlinux
[23:39] <praedo> what should i do to have presets working there?
[23:54] <praedo> i have ffmpeg-git
[23:56] <sacarasc> praedo: -preset ultrafast rather than -vpre ultrafast
[23:59] <maujhsn> praedo -preset ultrafast has worked for me more often than not!
[00:00] --- Fri Jan  6 2012

More information about the Ffmpeg-devel-irc mailing list