[Ffmpeg-devel-irc] ffmpeg.log.20120108

burek burek021 at gmail.com
Mon Jan 9 02:05:02 CET 2012

[00:03] <relaxed> greentemik: did you try ffmpeg-devel in /usr/ports?
[00:03] <greentemik> the thing is I am using pfSense, it is not quite the same as FreeBSD, but based on it
[00:03] <greentemik> it does not have ports
[00:04] <greentemik> I use pkg_add - r instead
[00:04] <greentemik> but when I try to get it from ftp, I have an old bersion, and there is no v4l support
[00:10] <relaxed> look at the freebsd port and see how it's compiled with v4l or ask in ##freebsd
[00:10] <greentemik> well..
[00:10] <greentemik> still do not understand
[00:11] <greentemik> where to look? I am new, sorry, plz give me a link
[00:13] <ubitux> freebsd with v4l? huh?
[00:13] <ubitux> freebsd has a v4l support?
[00:14] <relaxed> yes
[00:15] <relaxed> through its linuxulator
[00:16] <greentemik> any ideas? May be some body allready trier?
[00:33] <greentemik> may be I can add new formats to the listning of the command ffmpeg -formas
[00:33] <greentemik> >
[00:33] <greentemik> ?
[02:10] <john_doe_jr> I'd like to make the current Google Chrome in Windows be able to play mp4s...I realize that chrome is using avcodec-52.dll found @ C:\Documents and Settings\Owner\Local Settings\Application Data\Google\Chrome\Application\16.0.912.75 ...I've tried to drop in previous dlls avcodec.dll files into that folder but it's not working
[02:14] <john_doe_jr> Any body there?
[02:24] <darkstarbyte> Is jkramer on?
[02:55] <hi117> john_doe_jr you might be able to do it with chromium.... im not sure how you would do it with chrome
[02:56] <john_doe_jr> hi117, well, I tried w/ chromium 
[02:56] <john_doe_jr> hi117, not working
[02:56] <hi117> also it should be able to play mp4s, it might not be ably to play whats in them though, mp4 is just a container IIRC
[02:57] <john_doe_jr> hi117, Google chrome ended support for mp4s
[02:58] <hi117> hmm, im running chromium and i can play mp4 on linux
[02:58] <hi117> its the dev channel though
[03:00] <hi117> looks like a known issue was found and support was removed pending an update http://www.google.com/support/forum/p/Chrome/thread?tid=789de9c795e81ce1&hl=en
[03:01] <hi117> maybe?
[03:07] <hi117> looking into it a little deeper, though its probably coded to look only at avcodec-52.dll, need to see if its possible to overwrite with a better dll ut i wouldnt go blindly changing your libraries
[03:08] <hi117> you could switch to the dev channel which seems to include support
[03:08] <hi117> but it will mess up your user settings
[03:16] <john_doe_jr> hi117, well, Google Chrome dropped it on purpose though...it's not a bug
[03:16] <hi117> it doesnt make sense to drop probably the most popular video container format unless theres a problem with it
[03:17] <john_doe_jr> hi117, its propertiery 
[03:17] <john_doe_jr> hi117, it does make since if they are going to have to pay
[03:18] <hi117> idk but it seems chromium has mp4 support in dev channel
[04:07] <darkstarbyte> Why does this happen when I take one format to another format [matroska @ 0x1e8f1c0] Can't write packet with unknown timestamp
[04:08] <darkstarbyte> I did it with ffmpeg
[04:09] <john_doe_jr> well, that is a memory location...
[04:11] <darkstarbyte> How would I bypass it?
[05:12] <_klk_> hi all.  i'm using VLC to export a raw http stream of an mkv file with x264 video.  i'm trying to access this video either using ffplay or avformat_open_input with filename .  however, i'm getting an error value -1094995529 from avformat_open_input.
[05:12] <_klk_> does anyone know why this might be happening
[05:41] <sangcn> hi everybody, anybody known what does the syntax to apply video filter
[05:43] <sangcn> example filter with fade effect by ffmpeg?
[06:47] <darkstarbyte> sangcn, You may want to use a video editor for special effects.
[07:01] <sangcn> @darkstarbyte: yes, I want to use ffmpeg because I want embed ffmpeg in my program, so I can use a video editor.
[07:33] <bony> how do i fast forward a video. In my case i too a 30 min shot of moon raising and i have to fast forward the video to 1 min or less than that
[10:08] <Peasley> hey, im using avcodec_decode_video with h264 format, is there a way I can send the frame directly into GPU and do scalin/rgb conversation there?
[10:09] <Peasley> I dont understand what type of AVFRame decode_video gives me?
[11:51] <OldManMagnus> hi. i've got a folder full of png files (rendered by blender) and i'm trying to turn them into a video file with ffmpeg.
[11:52] <OldManMagnus> ffmpeg -i %04d.png output.ogv
[11:52] <OldManMagnus> someone told me to use that but it tells me no such file or directory.
[11:52] <OldManMagnus> ffmpeg -i *.png output.ogv
[11:52] <OldManMagnus> that seems to get further, but then i get a core dump.
[11:53] <OldManMagnus> any suggestions?
[11:55] <OldManMagnus> my files are 0001.png, 0002.png etc
[12:08] <OldManMagnus> isn't %d a wildcard for numbers in a filename?
[12:10] <Peasley> OldManMagnus; did you read this? http://ffmpeg.org/faq.html#How-do-I-encode-single-pictures-into-movies_003f
[12:12] <OldManMagnus> Peasley: i've tried %d.png, but it tells me %d.png doesn't exist.
[12:14] <Peasley> did you try -f too
[12:14] <Peasley> are you in right directory?
[12:14] <OldManMagnus> http://pastebin.com/Q1r7GFBE
[12:14] <Peasley> see what happens if you rename files to have "i" in front of them
[12:14] <OldManMagnus> i'm definitely in the right directory.
[12:15] <OldManMagnus> i'll try putting something in front of the filename.
[12:17] <OldManMagnus> nope. doesn't work.
[12:17] <OldManMagnus> i've got a folder full of files called stuff like image0167.png
[12:17] <Peasley> what does ls show
[12:19] <OldManMagnus> http://pastebin.com/30GuRg7k
[12:19] <OldManMagnus> i'm wondering if i've got a buggy version of ffmpeg.
[12:19] <OldManMagnus> i'm using ubuntu 12.04 alpha 64bit.
[12:20] <OldManMagnus> but simple stuff like this should still work.
[12:20] <Peasley> try ffmpeg -i ./%d.png output.mpg
[12:20] <Peasley> if that doesnt work, try absolute paths
[12:21] <Peasley> if that doesnt work, try unistalling and download again
[12:21] <OldManMagnus> tried it. no such file or directory. :(
[12:21] <Peasley> i dont have more ideas ;)
[12:21] <OldManMagnus> ok. thanks. 
[12:21] <Peasley> you can try ' and " and ` too
[12:21] <OldManMagnus> i'll build it from source or something.
[12:21] <Peasley> (ive used linux only once in my life time, dunno what there is)
[12:21] <OldManMagnus> bbl
[12:31] <MrJones> http://www.homeofjones.de/temp/ffmpeg.txt someone around who can check this FFmpeg initialisation code and tell me what could be a reason for me getting sample rate 0 and 0 channels? I'd really like to get the real values :p
[12:39] <OldManMagnus> hmm. build ffmpeg from source. same issue. :(
[12:42] <MrJones> OldManMagnus: maybe your bash is interpreting % somehow? assuming that is supposed to go to FFmpeg, did you try %d to avoid that? or \%d
[12:42] <MrJones> the first was supposed to be a double-%, but my IRC client is also interpreting it it seems :P
[12:42] <MrJones> %%
[12:42] <MrJones> that worked
[12:42] <MrJones> so %%d or \%d
[12:42] <OldManMagnus> i'll try that.
[12:43] <MrJones> * is actually filled in by the bash with file names, so *.png should work
[12:43] <MrJones> assuming FFmpeg can take multiple names in a list
[12:44] <OldManMagnus> %%d, \%d, \%%d. none of these worked.
[12:45] <MrJones> did you try *.png again with your self compiled FFmpeg? does it still core dump?
[12:46] <OldManMagnus> ffmpeg -i *.png film.ogv
[12:46] <OldManMagnus> it doesn't core dump, but it produces an ogv with no data.
[12:46] <OldManMagnus> Input #0, image2, from 'image0061.png':
[12:47] <OldManMagnus> found that in the output.
[12:47] <MrJones> well I never used this feature so... I cannot comment any further :/
[12:47] <OldManMagnus> 0061.png is the last image. so i suspect *.png goes through them all and only gives the last one to ffmpeg.
[12:48] <OldManMagnus> MrJones: thanks anyway. :)
[15:16] <greentemik> Hi! My question is the same, anyone could pls help me to compile ffmpeg on freebsd with v4l support?
[17:10] <someone-noone> hello, i have a problem:
[17:10] <someone-noone>  ffmpeg -i rtmp://localhost/ses4/widgetmain/ -f test.mkv
[17:10] <someone-noone> on localhost i've runned crtmpserver
[17:11] <someone-noone> It should receive /ses4/widgetmain/ as URI, but receives only ses4/ as URI
[17:11] <someone-noone> Why it's happenning (other software, like flash player and lot of others doesn't have such problem)?
[17:11] <someone-noone> how can i specify full URI with ffmpeg ?
[17:11] <someone-noone> thanks, for attention
[18:01] <shadowcry> hi does anyone know how to fix this?
[18:01] <shadowcry> Encoder (codec id 86017) not found for output stream #0.0
[18:01] <shadowcry> been searching for about half and hour to no avail
[18:03] <shadowcry> I have to go its 4am here
[18:18] <Rodger> Does anyone here know much about the THP encapsulation format?
[18:19] <Rodger> I've been having trouble converting some THPs to H.264/MP3 .mov's.
[18:20] <Rodger> I got the files out of the Fire Emblem 9+10 ISOs
[18:20] <Rodger> The ones from 10 are working fine
[18:21] <Rodger> The ones from 9 are interlaced, but ffmpeg's deinterlacer is working well on them
[18:22] <Rodger> Most of the 9 ones are getting rainbow artifacts at the end of the video where they should dip to white, accompanied by ffmpeg spewing mjpeg bad bloc and unrecognized coding errors
[18:22] <Rodger> s/bloc/vlc/ (autocorrect)
[18:23] <Bugsbane> Hey, does anyone know a way of capturing the full screen resolution (across Linux distros) without installing extra stuff (like xrandr etc)?
[18:23] <Rodger> One file starts erroring very early in the video, so it's entirely unwatchable.
[18:23] <relaxed> Rodger: are you using the most recent ffmpeg version?
[18:24] <Rodger> relaxed: I got a prebuilt version for OSX, lemme check the rev
[18:25] <Rodger> Version 0.9 built dec 18 2011... Where's the rev number?
[18:27] <relaxed> that's recent enough
[18:27] <Rodger> OK, so probably not fixed in a later rev?
[18:28] <MrJones> http://www.homeofjones.de/temp/ffmpeg.txt can someone tell me why I get sample rate: 0 and 0 channels here? instead of proper values
[18:28] <MrJones> must have messed up some initialisation part, but I am not sure where/how
[18:28] <relaxed> Rodger: there may be a decoding bug
[18:29] <Rodger> I'll upload a working THP from FE10, a semi-working one from FE9, and the broken one from FE9 once I have wifi
[18:29] <Rodger> relaxed: Could a new rev have fixed it?
[18:29] <Rodger> I've been on a cruise for a week, so I haven't been able to do much
[18:30] <Rodger> ESP. On a laptop without gcc...
[18:30] <relaxed> sure, test with the latest git and if it still errors then file a bug report.
[18:30] <relaxed> I can test for you if you upload them somewhere.
[18:31] <Rodger> OK, I'll mediafire them as soon as I have wifi
[18:32] <Rodger> If they work for you, I'll ssh home and build latest git, then reeccode the broken files
[18:46] <Rodger> I'm going offline now to save battery; I'll be on later under the nick llrcombs
[18:47] <Bugsbane> Found my answer: ffmpeg -f x11grab -r 2 -s `xdpyinfo | grep 'dimensions:'|awk '{print $2}'` -i :0.0 Filename_%d.jpg
[18:48] <Bugsbane> Now I just need to figure out how to set the jpeg's to 90% quality
[18:56] <relaxed> Bugsbane: try -qscale 3
[18:56] <Bugsbane> relaxed: Thanks. I'll give that a shot....
[18:58] <Bugsbane> Looks like that did the trick relaxed! Thanks!
[19:16] <Fapencio> 12hello
[19:16] <Fapencio> 12i need some help with ffmpeg for windows please
[19:18] <Fapencio> 12hello, i need to convert flv to 3gp for mobile phone with h263 vcodec and amrnb acodec
[19:18] <Fapencio> 12`md iive ods15 superdump ubitux uau ]R[ _blister Agiofws Akira^^ Alasdairrr AnywhereIs Ave bahar BBonifield bcoudurier benpro beorn Big_Brother bigmoondawg blast_hardcheese blinky42 boiled_sugar Bombo Bugsbane buhman Buster cbreak cbsrobot CharlesD_ Chikuzen chris| Coderjoe colde crazed CruX| curfont cyndis D-ion darkstarbyte darth_raijin dashcloud defaultro dionoea dongs dotblank drv dv_ 
[19:18] <Fapencio> 12eightfold epitron EricAhn_ Extrems Fallenou Fapencio fflogger fierman Freakshow G ghoti grepper Guest82811 haakon__ hfb highzeth huglester Hyperi Igloo infojunky ircdearia ivanich_ j-b-r j^ JEEB JEEBsv jegade jesselang jfroebe Jikan jkramer JodaZ Jonno JonOomph jvolkman JY` kanzure kcm1700 keeperofdakeys kent11 kevin_b keyvan kloeri knneth kode54 kriegerod Kuukunen lahwran Leoneof LexSfX 
[19:19] <Fapencio> 12linuxstony Loof LRN Madtree Malmis masch mateo` matt5 mattg maujhsn mdsh merzo metvik michaelni microchip_ moser movax MP4_maniac MrBreeze MrJones MT` Muzer mzahariev NapHtaKeRoSene neli Nescafe Nikoli NOTaMango Nowak Orphis osearth P-l patrask peuhkura pfloyd pigeon plethora Plorkyeran pom praedo pron psykx rav0_ relaxed rexbron roman3x RV___ sacarasc ser ShadowJK skebcio slackmagic stein 
[19:19] <Fapencio> 12stump supercurio sw4 sybariten tchmiel teratorn thedj theholyduck TheRyuu Tjoppen tnelson tomaw tonsofpcs Trax`` Trax|wrk Unhelpful vcs vektor verma voidcoder Yoda---- zap0 zizzfizzix
[19:19] <MrJones> what the fuck
[19:19] <colde> What the fuck
[19:19] <osearth> neat
[19:19] <masch> what the fuck
[19:19] <MrJones> Fapencio: you just ensured noone will help you.
[19:19] <colde> Kick the idiot
[19:19] <Leoneof> someone called me, yay!
[19:19] <osearth> Fapencio type //say $ip
[19:19] Action: Leoneof going to sleep again.
[19:19] <roman3x> god morning to all :D
[19:19] <Leoneof> not good idea, really... let me sleep again.
[19:19] <osearth> i was fb stalking.. back to the highschool for me!
[19:20] <zap0> moron
[19:20] <masch> ubitux: thx!
[19:20] <MrJones> hm
[19:20] <roman3x> fb stalking? what exactly mean?
[19:20] <maujhsn> "Wow"!
[19:20] <MrJones> now that everyone is awake, can someone help me with a little libav* problem maybe? http://www.homeofjones.de/temp/ffmpeg.txt that is the initialisation code, and basically I get stream sample rate 0 and 0 channels from FFmpeg which seems to be.. wrong
[19:21] <Fapencio> 12lol
[19:21] <theholyduck> derp.
[19:21] <theholyduck> not sure if troll
[19:21] <theholyduck> or genuinly retarded
[19:21] <PhM> hello everyone
[19:21] <Hyperi> haha :D
[19:21] <Fapencio> i need help please, i want to convert a flv to 3gp, but it must be h263 vcodec and amrnb acodec
[19:22] <PhM> did someone experienced problems with sound sync encoding with libfaac and libx264 ?
[19:22] <Fapencio> theholyduck genuinly retarded
[19:22] <Fapencio> i need help please, i want to convert a flv to 3gp, but it must be h263 vcodec and amrnb acodec
[19:22] <ubitux> Fapencio: you're going to get banned if you continue
[19:22] <osearth> Fapencio easy
[19:23] <Bugsbane> Fapencio: pinging everyone in the channel is just shooting yourself in the foot, dude.
[19:23] <osearth> Fapencio: just type //say $ip
[19:23] <osearth> ;]
[19:23] <cbreak> can someone kick that spamming moron?
[19:24] <Fapencio> sorry everyone, it is just that i wanted someone to ansewer me
[19:24] <Fapencio> i wont do it again
[19:24] <MrJones> Fapencio: you can't have everything in life, sadly.
[19:24] <Bugsbane> MrJones: That's ok. I only want the good bits :)
[19:24] <BobLfoot> So do I read the topic correctly the old -vpreset has been repalced by -preset when encoding?
[19:24] <Fapencio> sorry
[19:25] <Fapencio> look, can somebody help me? i want to convert a video to .3gp with amr audio codec, (amrnb) but ffmpeg says the codec doesnt existe
[19:26] <ubitux> i guess you have to build ffmpeg with --enable-libopencore-amrnb
[19:26] <PhM> just try ffmpeg -codecs to have all available codecs with your configure options
[19:28] <Fapencio> phm i have already done that, and it appear in the list, so i asume it is supported, but when i try to ecnode it keep telling me it doesnt exxist
[19:29] <Fapencio> @ubitux im using windows, can i build it in windows? where can i get that library'?
[19:32] <maujhsn> osearth  What does this command do? "//say $ip"
[19:32] <osearth>
[19:32] <maujhsn> OK
[19:33] <maujhsn> ISP got it know!
[19:34] <maujhsn> urrrr "now"
[19:35] <osearth> whats the haps on the new ffmpeg sploit?
[19:38] <BobLfoot> sbca
[19:40] <ubitux> Fapencio: no idea, i don't use windows
[19:54] <maujhsn> ubitux I get a slight drop in quality when I go from a ".jpg" photo to a 10 second ".mpg" movie! Is there anyway to improve onthe  movie sharpness?
[19:55] <ubitux> -q:v 0 ?
[19:55] <ubitux> but why are you asking me?
[19:56] <ubitux> (-q sorry)
[19:56] <ubitux> not sure it will help actually
[19:56] <maujhsn> ubitux Thought you might have the answers!
[19:57] <maujhsn> ubitux Here is the command that I was using: "ffmpeg -loop_input -r 30000/1001 -i Horse_B.jpg -t 00:00:10 -qscale 3 horse.mpg".
[19:58] <PhM> I got an error when using  libx264 -profile and any sound encoding but everything is fine if I disable sound encoding, what's wrong ?
[19:59] <ubitux> maujhsn: i don't know
[20:01] <maujhsn> ubitux  What is this stuff then: "-q:v 0" ?
[20:02] <desti> hi, what's the video codec with the least cpu usage when encoding 1080p25 in real time? raw video is too much data for my hdd
[20:03] <ubitux> maujhsn: my imagination, just forget this :)
[20:04] <maujhsn> ubitux OK
[20:18] <Tjoppen> m-m-m-monsterhighlight
[20:34] <relaxed> maujhsn: -q:v 1 == -qscale 1  (0 won't work)
[20:38] <maujhsn> relaxed Would it look like this: "ffmpeg -loop_input -r 30000/1001 -i photo.jpg -t 00:00:10  -q:v 1 == -qscale 1 photo.mpg"!
[20:39] <relaxed> I meant they are the same command
[20:41] <maujhsn> relaxed Would it look like this: "ffmpeg -loop_input -r 30000/1001 -i photo.jpg -t 00:00:10  -q:v 1 == -qscale 1 photo.mpg"!
[20:42] <relaxed> ffmpeg -loop_input -r 30000/1001 -i photo.jpg -t 00:00:10 -q:v 3 photo.mpg
[20:45] <maujhsn> relaxed  ffmpeg: unrecognized option '-q:v'
[20:45] <ubitux> i said to forget the -q:v stuff :(
[20:45] <ubitux> use -q
[20:45] <ubitux> which is the same as -qscale
[20:48] <maujhsn> ubitux OK
[20:48] Action: relaxed steps on ubitux's toes
[22:35] <mcbaine1> hi there .. aloha
[23:29] <Rodger> relaxed: You still here?
[00:00] --- Mon Jan  9 2012

More information about the Ffmpeg-devel-irc mailing list