[Ffmpeg-devel-irc] ffmpeg.log.20120109

burek burek021 at gmail.com
Tue Jan 10 02:05:01 CET 2012

[00:36] <darkstarbyte> What is the best way to compress video with vp8? (the source is animation)
[01:06] <desti> how can i display the available presets for libx264?
[01:19] <darkstarbyte> desti, x264 --fullhelp
[01:21] <desti> hmmm....doesn't work 0.o
[01:29] <desti> ah, had to merge x264-encoder too
[01:57] <ibkanat> is there a way to luma key video and export alpha .pngs?
[01:58] <ibkanat> with ffmpeg
[01:59] <ibkanat> I wanting to key out snow and leave the skiier
[02:07] <Synthead> Hey, what options would you guys recommend to encode video for an iphone on 4.2.1 (3G) ?
[02:13] <ibkanat> is lutyuv what I am looking for?
[02:20] <ibkanat> anyone with any ideas on how to do this?
[02:21] <filam> ffmpeg -i audio.wma audio.wav brings up a warning about "wmalossless" and exits. Am I missing an option? I would like WAV not WMA lossless.
[03:02] <ibkanat> so can frei0r filter be used from the command line?
[04:19] <ibkanat> is there somewhere else I can get answer t ousing ffmpeg -vf lutyuv
[04:20] <acerimmer> ibkanat: https://lists.ffmpeg.org/mailman/listinfo/ffmpeg-user/
[04:21] <ibkanat> thanks I am really just trying to do one color to alpha
[04:21] <ibkanat> whiteish
[04:22] <acerimmer> ibkanat: I'm new to ffmpeg myself.  I signed up for the user list and it's VERY active.  Suggest you submit your query to them.
[04:22] <ibkanat> k
[04:36] <sam1> hi guys. What does it  mean  "New video filter 'sub' to burn ASS and SRT subtitles."  in FFmbc-0.7-rc4  ?
[05:18] <llrcombs> so, it turns out those THP files weren't fixed by building latest git
[05:19] <llrcombs> I mediafire'd a few, I'll link in a sec
[05:20] <Randy_T> Is it possible to specify the baseline profile for x264 in ffmpeg. I tried -vpre baseline  -profile baseline and -x264opts profile=baseline. Not a big deal since i can just specify the 4 options that baseline uses but if it exists, i'd like to use it.
[05:34] <llrcombs> http://www.mediafire.com/?w4d6rz648sg8y <-- Fire Emblem cutscene files. FE10 files transcode perfectly with ffmpeg; FE9 files get artifacts. I need some help!
[05:36] <llrcombs> relaxed: you here?
[05:39] <llrcombs> actually, one FE10 cutscene file doesn't transcode properly, but I think the filename "DUMMY" explains that...
[05:41] <relaxed> llrcombs: I'm here
[05:41] <llrcombs> relaxed: I posted those THPs
[05:41] <llrcombs> the latest git doesn't help
[05:41] Action: llrcombs is uploading a few more now
[05:42] <relaxed> I'm downloading s01.mov
[05:43] <llrcombs> that one's fine right up until the last few seconds
[05:43] <llrcombs> it started erroring in the last several frames, and it gets rainbows
[05:43] <llrcombs> the audio is fine on all of them
[05:43] <llrcombs> the s0x's are deinterlaced
[05:43] <llrcombs> (as are all the ones from FE9)
[05:44] <llrcombs> download the THP too; it's the original
[05:45] <llrcombs> and if Mist's voice actress bugs you, it's not just you. That's everyone.
[05:46] <llrcombs> the really bad one is s05
[05:52] <relaxed> is there an issue with s01.thp?
[05:52] <llrcombs> relaxed: last few seconds rainbowify
[05:52] <llrcombs> haven't tested that one with latest git, though
[05:53] <llrcombs> once I checked s05 with latest, I figured nothing had changed
[05:54] Action: llrcombs tries with latest git
[05:54] <relaxed> I see it
[05:55] <llrcombs> same with s03
[05:55] <llrcombs> it's not a bad gamerip; they all play fine in-game in Dolphin
[05:55] <relaxed> Are ytou sure the files aren't damaged?
[05:56] <relaxed> you*
[05:56] <llrcombs> ^
[05:56] <relaxed> oh
[05:56] <relaxed> Then, yeah, go ahead and file a bug report
[05:56] <llrcombs> I thought Dolphin might've screwed up the extraction, but I re-extracted them multiple times with different dolphin versions
[05:56] <llrcombs> and the other files extracted fine
[05:57] <llrcombs> do you know much about THPs?
[05:57] <relaxed> I do not
[05:57] <llrcombs> it's a format used only in Wii/GCN games
[05:57] <llrcombs> motion JPEG + some specific THP PCM audio
[05:58] <llrcombs> and a weird encapsulation
[05:58] <llrcombs> it's basically the wii/GCN equivalent of Bink
[05:59] <llrcombs> afaik, there's no official spec on it, so files extracted from wii/GCN titles are the definitively "valid" files that ffmpeg should be decoding properly
[05:59] <llrcombs> where do I file a bug report?
[06:01] <relaxed> llrcombs: http://ffmpeg.org/bugreports.html
[06:02] <llrcombs> thanks, reporting
[06:02] <relaxed> make sure you add links to the samples
[06:03] <llrcombs> should I just link to the main folder and list file paths within?
[06:05] <relaxed> sure
[06:06] <llrcombs> does mediafire count as ridiculous, bloated and span-filled crap?
[06:06] <llrcombs> I usually don't class it with megaupload/rapidshare
[06:06] <relaxed> right, I think it will be fine
[06:07] <darkstarbyte> Anyone know of a really good bench marking tool that can read the level of functions?
[06:07] <relaxed> llrcombs: or you could use dropbox http://db.tt/cDWPLzP
[06:20] <llrcombs> relaxed: does this go under FFmpeg, avcodec, or avformat?
[06:21] <darkstarbyte> ffmpeg will not take avi to mkv directly it complains there is no time stamp
[06:21] <darkstarbyte> , but
[06:21] <darkstarbyte> it will take avi to mp4 then mkv
[06:22] <llrcombs> darkstarbyte: tested with latest git?
[06:22] <darkstarbyte> Latest stable
[06:22] <llrcombs> try master
[06:22] <darkstarbyte> ok
[06:22] <darkstarbyte> It might take a while to compile
[06:23] <llrcombs> what platform?
[06:24] <darkstarbyte> pentium 4 ht 64 bit arch linux (not optimized for it though)
[06:26] <darkstarbyte> It seems that git ffmpeg requires it deps to be git
[06:27] <llrcombs> yeah, that happens sometimes with deps
[06:27] <llrcombs> grab the new deps too
[06:27] <darkstarbyte> I might as well
[06:27] <darkstarbyte> My arch system is broken and won't let me update
[06:28] <darkstarbyte> Are there any distos that have a decent tool chain and some what easy to make packages for?
[06:28] Action: llrcombs is on OSX, no idea
[06:29] <darkstarbyte> hackintosh?
[06:29] <llrcombs> yep
[06:30] <darkstarbyte> x264 does not take to long to compile
[06:30] <llrcombs> didn't take long here
[06:31] Action: llrcombs compiled latest git and some deps earlier today
[06:31] <darkstarbyte> done
[06:33] <darkstarbyte> ffmpeg takes my computer about 15 minutes to compile last I checked
[06:33] <llrcombs> sounds right
[06:33] <darkstarbyte> Last I checked I was running gentoo
[06:33] <darkstarbyte> Last time*
[06:34] <darkstarbyte> How much do you know about vp8?
[06:34] <llrcombs> a little
[06:35] <darkstarbyte> Do you know of any good settings for animation?
[06:35] <llrcombs> nope, sorry
[06:37] <darkstarbyte> I should get some sleep tonight.
[06:48] <llrcombs> http://www.mediafire.com/?a4j6s38nq6mz2 <-- can anyone identify these files?
[06:49] <llrcombs> the ones without extensions were .cms files; I extracted them with an LZ77 extractor python script. I have no idea what format they're in
[06:49] <llrcombs> I just know they're captions
[06:59] <darkstarbyte> I am going to be up for a little longer, but
[06:59] <darkstarbyte> I was wondering what I should use to copy the audio and video of another format
[07:00] <darkstarbyte> because -acodec copy and -vcodec copy no longer work with the git source
[07:04] <llrcombs> oh, I've been wondering that too
[07:04] Action: llrcombs gets unrecognized codec "copy"
[07:04] <llrcombs> or something alike
[07:09] <darkstarbyte> good night before I can't get any sleep.
[07:15] <llrcombs> relaxed: https://ffmpeg.org/trac/ffmpeg/ticket/903 <-- posted a bug report
[07:22] <relaxed> llrcombs: good. btw, -sameq doesn't work with libx264
[07:25] <llrcombs> relaxed: oh, thanks for the tip
[07:25] <llrcombs> does it work with libmp3lame?
[07:26] <llrcombs> and how can I set it to use the highest possible quality given the input?
[07:27] <relaxed> you can use a lossless codec or libx264 with -crf 16 should look lossless
[07:30] <llrcombs> what's crf?
[07:30] <llrcombs> (just out of curiosity)
[07:31] <llrcombs> also, does anyone know of any subtitle/caption format that would be binary data, rather than normal text?
[07:31] <relaxed> llrcombs: and to deinterlace use yadif, so ffmpeg -i input -vf yadif -vcodec libx264 -preset veryslow -threads 0 -crf 16 -acodec flac output.mkv
[07:31] <llrcombs> what, is -vf yadif better than -deinterlace?
[07:31] <relaxed> yes
[07:32] <relaxed> crf = constant rate factor (vbr)
[07:32] <llrcombs> gotcha
[08:03] <shevy> when I cut an avi file, like so
[08:03] <shevy>   ffmpeg -i input.avi -ss 50 -t 100 output.avi
[08:03] <shevy> does this have to be re-encoded?
[08:04] <sacarasc> If you tell it to copy, it might work.
[09:39] <Peasley> Can I take frame from AVCODEC_DECODE_VIDEO directly and display it?
[09:53] <Peasley> kind of confused what am getting from avcodec_decode_video
[09:54] <Peasley> data has 3 arrays, 16bytes, 128 bytes, 128 bytes
[11:42] <gst-kaps> is it possible to stream as well as record at same time using ffmpeg ?
[12:39] <Mavrik> huh
[12:39] <Mavrik> libvo-aacenc and libfaac have same function names -_-
[13:39] <artcontr> Hi everyone. I have a question about ffmpeg. Can someone explain in more details what mjpeg codec is used by the -vcodec mjpeg command ? What codec should I use to decode it ?
[14:01] <Mavrik> artcontr, mjpeg is Motion JPEG format
[14:01] <Mavrik> http://en.wikipedia.org/wiki/Motion_JPEG
[16:50] <apus> hi, i have an input file with stream Stream #0:3(eng): Subtitle: text (default) and i just want to take it with me (no options for subtitles), the mapping then says Stream #0:3 -> #0:2 (? -> ass) and i get the error Decoder (codec text) not found for input stream #0:3
[17:14] <saste> apus: -> http://ffmpeg.org/trac/ffmpeg
[17:14] <saste> you need to login in order to create a ticket
[17:15] <apus> saste: i found two pastebin entries having the same error in google, therefore i assumed it was perhaps already known (approx. 1 month ago)
[17:50] <Bombo> i got a DVB mpg file with 720x576 16:9 (SAR 64:45) i want to cut the borders off, top 61, bottom 62, left 4 and right 6, does this filter settings make any sense? -vf crop=in_w-(4+6):in_h-(62+61):4:61,scale=in_w:in_h/sar,scale=640:-1
[17:52] <Bombo> and the result looks ok to me, but i'm not sure about the two scales, can it be done in one scale only?
[17:58] <shevy> hmm ffmpeg -i is synonymous to ffmpeg -input ? can I use the long versions?
[18:04] <Bombo> shevy: does it work?
[18:05] <Bombo> never tried it
[18:07] <shevy> Bombo not sure either hehe
[18:07] <shevy> just my brain that likes to look at long names
[18:09] <Bombo> well lets wait for someone who tries it out for us then ;)
[18:50] <relaxed> Bombo: scale=640:out_w*(sar/dar)
[19:25] <Bombo> relaxed: nope, image is too high, long faces
[19:26] <Bombo> relaxed: i get 640x407 then
[19:26] <Bombo> with scale=in_w:in_h/sar,scale=640:-1 i get 640x286
[20:48] <khali> since I updated to the latest version of ffmpeg, -alang is no longer supported
[20:48] <khali> and I can't find the replacement
[20:48] <khali> does anyone know?
[20:56] <khali> found it... -metadata:s:1 language=eng
[20:57] <khali> now I need to find the replacement for -newaudio...
[20:58] <vcs> khali: one second, let me dig through my notes
[20:58] <vcs> i have it
[20:59] <vcs> what you need to do is use -map
[20:59] <vcs> example: ffmpeg -i input.avi -map 0:0 -acodec libmp3lame -map 0:1 -acodec aac out.avi
[21:03] <khali> it used to be 0:1...
[21:03] <khali> 0.1; sorry
[21:03] <khali> and now it's 0:1
[21:03] <khali> so man command line interface changes in one go...
[21:04] <vcs> it went from not making sense to making sense
[21:04] <vcs> can't complain about that :)
[21:05] <khali> vcs: oh, there certainly were good reasons for all these changes, I'm not questioning that
[21:05] <khali> and in one week I'll have forgotten the old names and I'll be happy
[21:06] <khali> but right at the moment, it's a pain to adjust my script with the new syntax
[21:06] <vcs> welcome to the club
[21:16] <tholm> hi, I'm trying to compile ffmpeg 0.9.1 for armv4,  I'm on debian lenny version but getting this error "Assembler messages:
[21:16] <tholm>  Error: bad immediate value for 8-bit offset (1032)"
[21:16] <tholm> But I made the compilation with these arguments --disable-asm and --disable-optimizations
[21:16] <tholm> Does it make sense? I mean when you compile for a  arm processor it needs disable the asm instruccion?
[22:00] <vostok4[nv]> hey guys i'm trying to do a rather straightforward cross compile of ffmpeg for windows, under archlinux. i'm running into the following when running configure: http://codepad.org/TqkTzASK
[22:01] <vostok4[nv]> its complaining about undefined references to _vpx_codec_control when linking the test vpx encoder
[00:00] --- Tue Jan 10 2012

More information about the Ffmpeg-devel-irc mailing list