[Ffmpeg-devel-irc] ffmpeg.log.20120110

burek burek021 at gmail.com
Wed Jan 11 02:05:01 CET 2012

[00:05] <darkstarbyte> What happened to the copy codec in ffmpeg?
[00:06] <shevy> it died a tragic death
[00:14] <Freakshow> :P
[00:14] <Freakshow> BUILDING 32-bit ffmpeg binary, please stand by...
[00:14] <Freakshow> ERROR: libx264 version must be >= 0.118.
[00:15] <Freakshow> I guess that's a problem
[00:15] <Freakshow> ... for me
[00:24] <xjrn> i used to have script that succeeded using newaudio/newvideo switches. id there a mention what has changed in head revision ?
[00:54] <pasteeater> Freakshow: use a newer x264
[00:54] <pasteeater> darkstarbyte: copy still exists.
[00:55] <darkstarbyte> I am using yesterday's git
[00:55] <pasteeater> use a pastebin site to show your ffmpeg command and the complete console output
[00:56] <darkstarbyte> sure
[00:57] <darkstarbyte> Crap
[00:57] <darkstarbyte> It worked after last nights reboot, but not before
[00:58] <darkstarbyte> Though I still get a lot of errors from the mp4 format when I transfer them
[00:58] <darkstarbyte> I mean muxing it
[00:59] <darkstarbyte> It reminds me of the time I broke gcc, and after a reboot it fixed it self
[01:00] <pasteeater> sounds like windows
[01:00] <darkstarbyte> I am using Linux but
[01:00] <pasteeater> i know
[01:01] <pasteeater> i mean i thought so
[01:01] <darkstarbyte> Well this is what I get for not hashing the isos from the internet
[01:02] <darkstarbyte> Maybe I should not use thepiratebay.org to get Linux distributions
[01:06] <pasteeater> was your iso smeggy?
[01:07] <darkstarbyte> smeggy?
[01:07] <pasteeater> bad
[01:07] <pasteeater> xjrn: newaudio/newvideo has been depreciated for a more capable map option
[01:07] <darkstarbyte> That or my cheep dvds I use because my computer will not take live usbs
[01:09] <darkstarbyte> I will be on here for at least another hour before I have to leave to give a presentation
[01:17] <Freakshow> thanks pasteeater. I thought I had put enough sarcasm on that statement
[01:17] <Freakshow> :P
[01:21] <mgeary> hi folks. i've got a source video (640x480) that has some garbage at the top and the bottom. I'm tying to trim off ~5 pixels from the top and bottom and output at some different sizes. I don't seem to have my command quite right.
[01:21] <mgeary> This is my latest:
[01:21] <mgeary> ffmpeg -y -i "in.mov" -vcodec libx264 -vpre lossless_fast -vf crop=in_w:in_h-4:0:0,scale=186:-1 out_186c.mp4
[01:22] <mgeary> well, that only crops from the top, but even that doesn't appear to actually do the trick
[01:22] <darkstarbyte> Anyone know a lot about vp8?
[01:42] <xjrn> somone please tell me there is a way to sepcify a PAR that creates borders
[01:42] <darkstarbyte> I have an error I can't get rid of when I switch containers with avi to mkv
[01:42] <darkstarbyte> [matroska @ 0x233ff20] Can't write packet with unknown timestamp
[02:03] <pasteeater> mgeary: try getting rid of the extra zeros in your crop.
[02:03] <pasteeater> crop=iw:ih-10,scale
[02:08] <relaxed> to always have the crop divided equally, crop=iw:ih-10:(in_w-out_w)/2:(in_h-out_h)/2,scale
[02:14] <pasteeater> for me "crop=iw:ih-10" is the same as "crop=iw:ih-10:(in_w-out_w)/2:(in_h-out_h)/2"
[02:20] <mgeary> pasteeater: that seems to work, thank you!
[02:22] <relaxed> pasteeater: you're right, I think it's pad that doesn't do that by default.
[02:25] Action: pasteeater kicks pad
[03:01] <_Ray_> Hey, I'm sure this is not the correct place to ask, but I couldn't think of a more suitable channel. If I have an audio source at 44.1KHz, and I convert it to 48KHz audio source, without making up data, does this mean that the result will be of shorter duration than the original? (Specifically, 100*44.1/48.0% of the original duration)
[03:11] <acerimmer> _Ray_: should be the same length as I understand it.
[03:14] <_Ray_> acerimmer, well, if I had 44.1k samples per second, and I had t seconds, I had t*44.1*1000 samples. If we call the output duration t' seconds, it has 48*1000*t' samples. But if I didn't make up samples, these two numbers must be the same. So  t*44.1*1000 = 48*1000*t', and thus t' = t * (44.1/48) < t, unless I'm thinking of something incorrectly here?
[03:14] <_Ray_> (Assuming I'm neither making up nor forgetting samples in the process.)
[04:50] <Austen> anybody with vorbis knowledge know how the duration is saved?
[06:44] <darkstarbyte> [matroska @ 0x233ff20] Can't write packet with unknown timestamp
[06:45] <darkstarbyte> anyone know what causes that when I try to switch containers from avi to mkv?
[06:46] <Ginks> can you invoke 2 -vf at the same time?
[06:47] <Ginks> I wanted to scale and do a overlay at the same time
[06:47] <Ginks> but what I tried only did the overlay, the last -vf I put in
[06:47] <Ginks> skipped the scale
[06:52] <relaxed> Ginks: -vf "[in]scale=640:-1,[wm]overlay=main_w-overlay_w-10:10:1[out];movie=logo.png[wm]"
[06:55] <darkstarbyte> ???
[06:56] <relaxed> darkstarbyte: did it error?
[06:56] <darkstarbyte> the vf thing?
[06:57] <Ginks> relaxed, I'll give that a go and report back
[06:57] <Ginks> thanks
[06:58] <darkstarbyte> My error was matroska Can't write packet with unknown timestamp
[06:58] <darkstarbyte> and
[06:58] <darkstarbyte> av_interleaved_write_frame(): Invalid argument
[06:58] <darkstarbyte> but I can take my file from avi to mp4 then mkv, but not avi to mkv
[06:59] <relaxed> pastebin your command and all output
[07:00] <darkstarbyte> http://pastebin.com/Ja0Ekf3G
[07:03] <darkstarbyte> You most likely were not talking to me
[07:03] <darkstarbyte> I thought I would post the darn thing anyways
[07:04] <relaxed> darkstarbyte: I was. There's already a bug report for the issue. http://roundup.libav.org/issue1719
[07:05] <relaxed> maybe you should add to it
[07:05] <darkstarbyte> That bug report looks really old
[07:05] <darkstarbyte> that makes me think it might not get fixed for a long time
[07:07] <relaxed> it might happen faster if you post there and upload a sample
[07:07] <darkstarbyte> I have to find something that does not have a copy right
[07:07] <darkstarbyte> Perhaps big buck bunny
[07:08] <relaxed> it's considered fair use to upload a small sample of the video
[07:09] <darkstarbyte> great
[07:09] <darkstarbyte> They have free downloads on the site
[07:13] <darkstarbyte> Good night.
[07:13] <darkstarbyte> and thanks for the help
[13:30] <carpediembaby> hi. is this a good place to ask questions about video editing? i want to edit a video so that i remove the 'silent' parts in it
[14:14] <cbreak> if I compile ffmpeg from git, will I get lgpl only or gpl tainted binaries?
[14:17] <Tjoppen> by default you get lgpl binaries
[14:18] <cbreak> excellent
[14:18] <Tjoppen> configure will tell you, and it'll fail unless you add --enable-gpl if any library you want to link with is GPL
[14:19] <cbreak> that's great. I used avformat_license() and it returned LGPL, so I guess that was true :)
[14:58] <gdp16> hello
[14:58] <gdp16> I have question to build ffmpeg library using cygiwn and mingw32 compiler
[14:59] <gdp16> when I set ./configure --target-os=mingw32 --arch=x86 --enable-cross-compile --cross-prefix=i686-pc-mingw32-
[14:59] <gdp16> I got error no i686-pc-mingw32-pkg-config
[14:59] <gdp16> do anyone have idea about this?
[15:02] <Milos_SD> Hi
[15:03] <Milos_SD> I have this error when I try to compile ffmpeg from lastest git: *** glibc detected *** /usr/lib/gcc/x86_64-linux-gnu/4.6.1/cc1: malloc(): smallbin double linked list corrupted: 0x000000000220cd70
[15:03] <GomGom> hi, trying to use libx264 as per webpage example "ffmpeg -i input -vcodec libx264 -preset fast -tune film -profile main -crf 22 -threads 0 output"
[15:04] <GomGom> i get this: http://pastie.org/3160339
[15:04] <GomGom> so it seems -profile -tune and -preset don't make it to libx264 module where private options are defined
[15:07] <Mavrik> GomGom, there's a parameter collision with libfaac and libx264 in last few versions
[15:07] <Mavrik> GomGom, use "-vprofile" for video profile settings
[15:08] <GomGom> cool, works ok
[15:08] <GomGom> thx Mavrik
[15:57] <dericed> why is the 'p' in yuv422p? Does this to progressive? If so where's yuv422i? just curious
[16:01] <Tjoppen> dericed: planar
[16:02] <dericed> Tjoppen: ah that makes more sense now
[16:31] <evil_andy> I wrote some code that uses ffmpeg to read mpegts from a UDP stream.  It works for a few seconds then I get: [udp @ 0x1502ca0] circular_buffer: OVERRUN  any clues what I might be doing wrong? (I will try to put together some code I can post)
[16:32] <evil_andy> rather, it seems like I've forgotten to start a thread, or I might be reading the data too slowly, or some such
[16:36] <evil_andy> http://pastebin.ca/2101907 is the code that grabs the frame from ffmpeg
[16:44] <cbreak> which format is best for piping raw audio/video between ffmpeg instances?
[17:04] <relaxed> cbreak: this should work well, -c:v rawvideo -c:a pcm_s16le -f flv
[17:04] <cbreak> you'd use flv?
[17:05] <relaxed> -f mpegts might be better
[17:07] <relaxed> well, neither work with rawvideo
[17:08] <relaxed> cbreak: -f nut works
[17:09] <cbreak> ok, thanks :)
[17:11] <cbreak> the sending end is an application I am writing with ffmpeg, so I can't test it until I have the video generation part written
[17:18] <Bombo> relaxed: with "scale=640:out_w*(sar/dar)" the resulting format is 640x407 and faces are too long, and with "scale=in_w:in_h/sar,scale=640:-1" i get 640x286, everything looks ok
[17:20] <relaxed> Bombo: yes, I wasn't taking into account your crop. What was the original sar?
[17:21] <Bombo> relaxed: 64:45
[17:21] <Bombo> this is the filters with crop: -vf crop=in_w-(4+6):in_h-(62+61):4:61,scale=in_w:in_h/sar,scale=640:-1
[17:22] <relaxed> echo "720*((64/45)/(16/9))" | bc -l
[17:25] <khali> relaxed: I didn't know bc -l, great feature, thanks :)
[17:25] <Bombo> looks like in_w*(sar/dar)
[17:26] <relaxed> sar = dar * h / w
[17:26] <Bombo> and its 576
[17:27] <Bombo> thats the original height
[17:27] <relaxed> right, I provided the original width
[17:28] <Bombo> what is the out_w in this anyway? 640? "scale=640:out_w*(sar/dar)"
[17:29] <relaxed> yes
[17:32] <Bombo> ok what does -1 do then?
[17:33] <Bombo> "If the value for width or height is -1, the scale filter will use, for the respective output size, a value that maintains the aspect ratio of the input image."
[17:33] <relaxed> maintains aspect ratio
[17:33] <Bombo> how do i calculate that, maybe that will help
[17:35] <relaxed> The formula for SAR is sar=(dar)*(h/w)
[17:37] <Bombo> ok but the sar!=-1 is it?
[17:37] <Bombo> (dar)*(h/w)=-1 ?
[17:38] <Bombo> scale=640:sar will do the same as scale=640:-1 ?
[17:39] <relaxed> I'm not sure, most of the video I deal with is 1:1
[17:39] <relaxed> stick a few seond sample up somewhere and I'll look into it
[17:39] <relaxed> second*
[17:43] <Bombo> hmmkay
[19:15] <BlackBishop> ffmpeg -i /dev/dsp1 rahat.wav just hangs .. http://pastebin.com/GTfzqz5G ..
[19:16] <BlackBishop> tried aac too :/ and others ( that I saw in -codecs | grep -i audio with E/D support ) .. just hangs...
[19:18] <BlackBishop> trying to record the sound from my webcam ( logitech c910 )
[19:19] <Mavrik> BlackBishop, I suggest you use ALSA instead: http://www.commandlinefu.com/commands/view/3513/record-mp3-audio-via-alsa-using-ffmpeg
[19:19] <Mavrik> you'll just have to find the hardware ID of your webcam
[19:34] <alex2> Hello, I am trying to implement HTTP-Live-Streaming on my Ubuntu Hardy slice so I can stream videos from the iPhone App I'm building. FFMPEG was recommended to me. FFMPEG + Segmenter works well on my Mac, but I can't get the segmenter part to work on my server. I tried a bunch of things but can't get it to work. Would anybody be able to advise me about the next steps?
[19:34] <slorbast> Quick question, multiple .flvs into one .mp4?
[19:44] <sebbu> hi
[19:45] <sebbu> when i try to run ffmpeg -i input.mpg -c:v copy -c:a copy out.mpg, i got an error after 141/163mb :
[19:45] <sebbu> Application provided invalid, non monotonically increasing dts to muxer in stream 0: 139351355 >= 139351355
[19:45] <sebbu> av_interleaved_write_frame(): Invalid argument
[19:45] <sebbu> any idea ?
[19:47] <Mavrik> input video timestamps are wrong
[19:52] <sebbu> Mavrik, any way of fixing that ?
[19:52] <sebbu> the video(&audio) plays fine, it has just problems with the seeking
[19:53] <Mavrik> I think mencoder can re-timestamp your video, but could cause sync issues
[19:53] <sebbu> both VLC & MPlayer read the video without problem (if not seeking)
[19:53] <Mavrik> yeah, you can't seek because timestamps are foo
[20:05] <vostok4[nv]> is there a "minimum" set of filters needed to output a video?
[20:05] <vostok4[nv]> i'm just trying to encode 1 png into a webm video: ffmpeg -i test1.png test.webm
[20:05] <vostok4[nv]> and i get the error "Error opening filters!"
[20:07] <pasteeater> vostok4[nv]: use a pastebin site to show your ffmpeg command and the complete console output
[20:08] <vostok4[nv]> http://pastie.org/3161847 there you go, its a win32 build crosscompiled from linux
[20:10] <pasteeater> i guess it has something to do with "--disable-everything". it is a troublesome option.
[20:11] <pasteeater> but i do not really know why it is giving you that message
[20:11] <vostok4[nv]> fair enough
[20:11] <vostok4[nv]> was planning on redistributing ffmpeg and i didn't want to deal with licensing issues with all the other codecs there
[20:11] <vostok4[nv]> so i thought i'd disable everything and start ground up
[20:12] <Mavrik> you're probably missing "pal8" pixel format converter
[20:14] <vostok4[nv]> that's a warning, not error, and from googling it doesn't look like it should be a problem (and i looked in config.mk and theres no option for anything pal8 related)
[20:15] <Mavrik> well, if you don't have the converter you'll get a filter error
[20:15] <Mavrik> since VP8 can't store video in that pixel format
[20:16] <pasteeater> configure options will determine your license: --enable-gpl, --enable-nonfree, --enable-version3, etc.
[20:18] <vostok4[nv]> hm, ok i can give it a shot to go gpl only (do i do --disable-everything and --enable-gpl or will --enable-gpl ensure i get *only* GPL features?)
[20:19] <vostok4[nv]> and Mavrik i had thought it would encode using yuv420p instead of pal8 as a safe fallback
[20:19] <JEEB> since default is lgpl
[20:19] <JEEB> and lgpl stuff can be licensed under GPL as well
[20:19] <JEEB> you can just do --enable-gpl
[20:19] <JEEB> to enable GPL parts (GPLv3)
[20:19] <JEEB> then there's --enable-version3 for some things
[20:20] <pasteeater> don't use --disable-everything
[20:20] <JEEB> and where I wrote GPLv3 I meant GPLv2
[20:20] <JEEB> --enable-version3 enables the GPLv3-only stuff
[20:20] <JEEB> (not much)
[20:21] <vostok4[nv]> alright, i'll give this a shot then, probably gonna need to compile a bunch more libs :)
[20:22] <pasteeater> JEEB: i went ice fishing recently and saw a "Derp Lake".
[20:25] <JEEB> pasteeater, lol
[21:03] <mgeary> hey folks
[21:03] <mgeary> wh
[21:04] <mgeary> why would "-vf crop=iw:ih-10" turn a 640x480 video into a 627x480 video? Why would it be cropping 13 pixels off instead of 10?
[21:07] <relaxed> mgeary: pastebin the command and output
[21:08] <mgeary> relaxed: http://dpaste.com/685480/
[21:09] <relaxed> the output is 640x470
[21:09] <mgeary> sorry, i did mistype above. I'm getting 627x470
[21:10] <mgeary> that's what i get when i open it in QuickTIme Pro
[21:10] <mgeary> so yeah, my bad on the height issue. But why would it be changing the width?
[21:12] <relaxed> to account for the PAR being 47:48
[21:13] <mgeary> is there something i can/should do to keep it at 640?
[21:15] <relaxed> try -vf crop=iw:ih-10,setdar=out_w:out_h
[21:16] <mgeary> [setdar @ 0x100f02790] Invalid string 'out_w:out_h' for aspect ratio.
[21:16] <mgeary> Error initializing filter 'setdar' with args 'out_w:out_h'
[21:17] <relaxed> -vf crop=iw:ih-10,setdar=640:470
[21:18] <mgeary> nope, still 627:470
[21:18] <relaxed> pastebin
[21:19] <mgeary> http://dpaste.com/685489/
[21:20] <relaxed> oh, remove setdar and use setsar=1:1
[21:21] <mgeary> still does it: http://dpaste.com/685491/
[21:21] <mgeary> :S
[21:23] <relaxed> upload a small sample
[21:27] <mgeary> http//dev.gearyweb.com/download/snip.mp4
[21:27] <relaxed> I meant the source
[21:27] <mgeary> well, i'm not sure how to clip out a small bit of the source
[21:28] <mgeary> and i probably can't post the whole thing
[21:28] <relaxed> hmm, mplayer plays it at 640x480
[21:28] <mgeary> that piece?
[21:28] <mgeary> that's the source
[21:29] <relaxed> oh
[21:32] <relaxed> mgeary: using setdar or setsar works here. "Stream #0.0(eng): Video: libx264, yuv420p, 640x470 [PAR 1:1 DAR 64:47], q=-1--1, 30k tbn, 29.97 tbc"
[21:32] <mgeary> hrm
[21:32] <relaxed> in fact omitting both still gives me a sar of 1:1
[21:33] <relaxed> I think you need to compile latest git and try that
[22:54] <shevy> hmm
[22:54] <shevy> when you have and use something like ...
[22:54] <shevy> ffmpeg -i movie.avi -ss 00:51:42 -t 00:03:30 clip.avi
[22:54] <shevy> is it possible to specify the end position too, like -ss, rather than the duration like with -t ?
[22:54] <shevy> something like ...
[22:55] <shevy> ffmpeg -i movie.avi -ss 00:51:42 -end 01:53:30 clip.avi
[23:05] <_Ray_> Hey. I'm reading that at 16 bit resolution, the dynamic range of an audio signal is this because 96 =~ 20 * log_10(2^16)? If so, I did the calculation correctly, but I don't know why I multiplied by 20 other than "to make the numbers match" :s
[23:12] Action: newl punches 9 then 6 then .... into xcalc
[23:12] <JEntrep> Hey how do ffservers time shift streams??
[23:13] <JEntrep> where can i find a source code for that?
[23:24] <hallowicked> hello guys can somebody tell me if theres away to brighten up my vides while encoding with ffmpeg
[23:27] <newl> brighten up videos?? angelina joile?
[23:27] <shevy> apply some makeup
[23:27] <hallowicked> meh its actually a legit question is it possible or not
[23:27] <shevy> hallowicked, I dont know... years ago I used avisynth + virtualdub for those modifications
[23:28] <shevy> I am using ffmpeg mostly for just plain conversion and cutting/remixing audio these days
[23:28] <hallowicked> do u prefer avisynth over ffmpeg for video
[23:28] <shevy> but I miss the avisynth filters :( switched to linux ~6 years ago
[23:28] <shevy> the idea behind avisynth is great
[23:29] <shevy> I dunno... ffmpeg kinda works, it is simple... and it does the things it wants to do
[23:29] <hallowicked> pm please shevy
[23:29] <shevy> with avisynth though I felt as if I was in total control over everything, and that feeling rocked
[23:30] <shevy> when I ever have enough time, I'll try to code an object orientated pipe, similar to bash, in syntax as well, but with the ability to pipe video and audio streams and modify them. a bit like a mixture of avisynth, bash fish shell and a few more ideas put together
[23:33] <newl> probably easier to just increase the brightness on the monitor ... if they still come with control adjustment knobs
[23:33] <shevy> lol
[23:34] <cbreak> might be easier to just calibrate the screen properly
[23:34] <shevy> there you go hallowicked ;) I suppose what they say is that it is not possible with ffmpeg
[23:35] <cbreak> I don't know.
[23:35] <cbreak> mplayer can do it
[23:35] <shevy> really? hmm
[23:36] <shevy> that's why I liked avisynth... one language to rule them all (do all manipulations)
[23:36] <cbreak> in my opinion, color changes can only make things worse
[23:39] <cbreak> so if you need it, do it on playback
[23:39] <relaxed> shevy: you can run avisynth with wine on linux
[23:39] <cbreak> (that is if you have a proper source of course, if you're cutting/mastering video, you'd use a real program anyway :)
[23:40] <shevy> relaxed hmm ok, will try that in the coming days
[23:40] <relaxed> shevy: http://akuvian.org/src/avisynth/avs2yuv/
[00:00] --- Wed Jan 11 2012

More information about the Ffmpeg-devel-irc mailing list