[Ffmpeg-devel-irc] ffmpeg.log.20120112

burek burek021 at gmail.com
Fri Jan 13 02:05:01 CET 2012

[00:38] <darkstarbyte> anyone know a lot about multithreading in ffmpeg?
[01:01] <Ginks> threads=0 or threads=auto I think
[01:12] <darkstarbyte> I was wondering how effective threads were on the mpeg2 codec
[02:00] <iive> darkstarbyte: not that much. I remember that things like reading from the same bitstream were memory hogs
[02:00] <iive> so even the bitstream should be copied for each thread.
[02:01] <naeluh> hey is there a way to install libfacc on ubuntu lucid ?
[02:02] <iive> naeluh: do you mean libfaac ?
[02:02] <naeluh> live: yes
[02:04] <naeluh> live: 1 sec I think it ma9y have installed
[02:21] <naeluh> hey so I am getting ERROR: libfaac not found
[02:21] <naeluh> live: is there a way to install it
[02:24] <shevy> naeluh http://downloads.sourceforge.net/faac/faac-1.28.tar.bz2
[02:24] <naeluh> awesome thanks let me try it !
[02:30] <naeluh> awesome worked how about libmp3lame
[02:32] <iive> you can download it from sf.net too
[02:34] <naeluh> awesome
[02:34] <naeluh> hows everyone doin today
[02:35] <naeluh> weird now it says I dont have libopencore_amrnb
[02:37] <naeluh> is there a place to download that
[02:37] <shevy> hmm that's an odd lib
[02:37] <naeluh> maybe I dont need it
[02:37] <shevy> I know libfaac, I know liblame but I never heard of that libopencore* before
[02:37] <naeluh> I will try with enablbing it
[02:37] <naeluh> enable
[02:38] <shevy> I think I found it... let me dig https://trac.pjsip.org/repos/changeset/3911/pjproject/trunk/pjmedia/src/pjmedia-codec/opencore_amrnb.c
[02:38] <shevy> it belongs to that project probably
[02:38] <shevy> http://www.pjsip.org/release/1.12/pjproject-1.12.tar.bz2 seems to be the stable one
[02:39] <naeluh> awesome!
[02:39] <naeluh> how bout libtheora
[02:39] <naeluh> is there one out there
[02:39] <naeluh> thanks again
[02:40] <shevy> libtheora is easy
[02:40] <shevy> works for me very well http://downloads.xiph.org/releases/theora/libtheora-1.2.0alpha1.tar.xz
[02:40] <shevy> or look for another version http://downloads.xiph.org/releases/theora/?C=M;O=D but the above should be the latest
[02:41] <naeluh> shevy: u r gr8
[02:41] <shevy> I have those things in local files
[02:42] <shevy> "compile libtheora" in bash compiles it for me. if it can not find it locally, it will download it and put it into SOURCE_DIRECTORY/name_of_program ... like /Depot/libtheora/
[02:42] <naeluh> cool thanks !!
[02:49] <naeluh> is there a way to untar a file like libogg-1.3.0.tar.xz
[02:50] <shevy> yes
[02:50] <shevy> the binary (or script is called)
[02:50] <shevy> "unxz"
[02:50] <shevy> it is bundled there http://tukaani.org/xz/xz-5.0.3.tar.bz2
[02:50] <shevy> .xz files usually have smaller size than .bz2, that's why they are used
[02:51] <shevy> you can however also download other formats naeluh like http://downloads.xiph.org/releases/ogg/libogg-1.3.0.tar.gz
[02:54] <naeluh> weird when I run ./configure --prefix=/usr && it wont configure ?
[02:54] <naeluh> \
[02:55] <naeluh> ls
[02:55] <naeluh> wrong diretory
[02:55] <naeluh> directory
[02:59] <shevy> hmm
[02:59] <shevy> you should not use the && I think
[02:59] <shevy> "./configure --prefix=/usr" should be enough
[02:59] <shevy> my alias to this is "cusr"
[02:59] <shevy> :)
[03:00] <shevy> or rather "doit"... as alias being ./configure --prefix=/usr, then make, then make install
[03:06] <naeluh> I got it I was in the wrong directory
[03:08] <darkstarbyte> Unrecognized option 'acodec'
[03:08] <darkstarbyte> Is ffmpeg broken on my computer?
[03:09] <durandal_1707> full cmd output
[03:10] <darkstarbyte> http://pastebin.com/QfEdu8ZR
[03:11] <relaxed> ffmpeg, not ffprobe
[03:11] <darkstarbyte> crap
[03:11] <darkstarbyte> a typo
[03:11] <relaxed> -profile:v high
[03:12] <darkstarbyte> oh
[03:14] <darkstarbyte> that explains that error
[03:14] <naeluh> I got it wrkin thanks
[03:15] <shevy> cool naeluh
[03:16] <naeluh> yeah its al configured but that one libopencore ? it still couldnt find it after I installed that one link
[03:17] <naeluh> shevy I am going to try it without and see how it goes
[03:24] <naeluh> shevy can you show me how to determine the Absolute path to ffmpeg executable?
[03:25] <naeluh> thanks again
[03:25] <newl> which
[03:25] <newl> which ffmpeg
[03:25] <naeluh> I installed using these instructions http://ubuntuforums.org/showpost.php?p=9868359&postcount=1289
[03:26] <naeluh> I guess the latest one
[03:26] <naeluh> newl does that make sense
[03:26] <newl> is your 'i guess the latest one' the answer to 'which ffmpeg'  (god i love that one ...)  no just type it in a terminal
[03:27] <naeluh> newl your a funny guy
[03:28] <naeluh> I found it thanks !!
[03:30] <naeluh> weird I used the which ffmpeg command it showed me a directory /usr/local/bin/ffmpeg then I tried to cd to it and it said that it didnt exist?
[03:30] <shevy> well
[03:30] <shevy> something is odd
[03:31] <naeluh> yeah
[03:31] <shevy> if you used --prefix=/usr then ffmpeg would be at /usr/bin/ffmpeg
[03:31] <shevy> also, that is a binary, not a directory, so you can't cd to a file
[03:31] <naeluh> oh okay
[03:31] <shevy> you can give the absolute path though and look what it outputs ./usr/local/bin/ffmpeg
[03:31] <shevy> hmm or without the .
[03:33] <naeluh> I am using a drupal installation which is asking for the path to ffmpeg executable I am trying to find it but no luck
[03:33] <newl> naeluh: which shows you the full path to the binary (man which)
[03:34] <naeluh> weird thats what I used and it is not recognizing it
[03:34] <shevy> drupal
[03:34] <shevy> isn't that some webserver thingy
[03:34] <naeluh> shevy drupal.org
[03:34] <naeluh> its a cms
[03:34] <shevy> perhaps it can not see your /usr/local/dir
[03:34] <shevy> because you have a base dir somewhere else
[03:35] <naeluh> I think it can
[03:35] <newl> try /usr/local/bin   maybe it just wants the dir it is in - anyway drupal should be using your system path to find stuff ?? I would hope
[03:35] <naeluh> can I create a sym link or somethin
[03:35] <shevy> naeluh hmm... my apache has a document root that is somewhere in /www/bla
[03:35] <shevy> and from there, it cant see my /usr/bin things
[03:36] <naeluh> maybe a symlink to the /www
[03:36] <shevy> sure, symlink into your root dir
[03:42] <naeluh> ln -s /usr/local/bin/ffmpeg /www/ffmpeg
[03:43] <naeluh> I used this but doesnt seem to wrk
[03:47] <newl> you need the symlink directive in your httpd.conf for that dir?
[03:49] <naeluh> I ran a check install on the ffmpeg folder and it output this
[03:49] <naeluh>  Done. The new package has been installed and saved to
[03:49] <naeluh>  /root/ffmpeg/ffmpeg_5:git-2012-01-11-4093d13-1_amd64.deb
[03:49] <naeluh>  You can remove it from your system anytime using:
[03:49] <naeluh>       dpkg -r ffmpeg
[03:49] <naeluh> does that mean its in the root directory?
[03:52] <newl> -> /root/ffmpeg more likely
[03:55] <shevy> naeluh when you use dpkg by default it would install into /usr/bin
[03:56] <shevy> if not, then tell the debian/ubuntu guys they are idiots
[03:56] <naeluh> is there a way to test if ffmpeg is installed
[03:56] <naeluh> or something
[03:56] <shevy> if you use shell, just type "ffmpeg -v"
[03:56] <naeluh> ffmpeg: error while loading shared libraries: libfaac.so.0: cannot open shared object file: No such file or directory
[03:57] <shevy> libfaac.so.0 is not existing on your system
[03:57] <shevy> also make sure to run "ldconfig"
[03:57] <shevy> and try again
[03:57] <shevy>  /usr/lib/ls *faac*
[03:57] <shevy> libfaac.a  libfaac.la  libfaac.so  libfaac.so.0  libfaac.so.0.0.0
[03:57] <shevy> stat libfaac.so.0
[03:57] <shevy> File: `libfaac.so.0' -> `libfaac.so.0.0.0'
[03:58] <shevy> I dont believe you naeluh
[03:58] <shevy> I compiled libfaac into /usr and it works fine here for me.
[03:58] <naeluh> wait shevy should I change that file
[03:58] <shevy> depends on what you did before
[03:58] <shevy> you probably did not compile libfaac into /usr prefix
[04:00] <naeluh> so I would have to recompile libfaac and then recompile ffmpeg ?
[04:05] <shevy> naeluh I dont think you compiled any of this either
[04:05] <shevy> you used apparently a .deb package
[04:05] <newl> what does ldd /usr/local/bin/ffmpeg | grep libfaac
[04:05] <shevy> it's bad to mix things. debian/ubuntu wants its users to stick to its schemata
[04:05] <naeluh> okay
[04:06] <naeluh> hey I gotta go go  am going to try again tomorrow and see if I can get it to work thanks for your help!!!
[04:18] <newl> why would drupal use ffmpeg any way
[10:27] <eightfold> is there a "plain" MPEG-4 ASP encoder, or is ASP only available as XviD, DivX etc?
[10:28] <Tjoppen> -vcodec mpeg4 perhaps?
[10:48] <upvar> how do i increase the contrast of my transcode slightly
[13:14] <libin_v> Hi All, I would like to create an IPhone app which allows me to send CMSampleBuffer to an ffmpeg client over the network. Any pointers as to how I can achieve this?
[13:17] <libin_v> After some amount of research .. I think I need to get the ImageBuffer from SampleBuffer. Put them into AVFrame and encode these frames using av_encode_video and then write them into a socket. .. am I right ??
[14:05] <chub_> anybody here knows about ffmpeg linking with quick sync's dlls and using quicksync for encoding/decoding?
[14:27] <abli> Hi! what units is the 'time' in, which is printed on the command line when converting a video?  I.e. there is a continously updating line like this: "size=   10826kB time=1316.57 bitrate=  67.4kbits/s". What units is the time part in?
[14:42] <Mavrik> abli, seconds
[14:43] <abli> ok, thanks
[15:38] <gdp16> Hi
[15:46] <gdp16> I have question
[15:58] <Mavrik> good for you ;)
[15:58] <gdp16> ^^
[15:59] <gdp16> currently I am building ffmpeg in cygwin environment
[15:59] <gdp16> and it's configured using below configuration
[16:00] <gdp16> --enable-cross-compile \         --cross-prefix=i686-pc-mingw32- \         --target-os=mingw32 \         --arch=x86 \         --sysroot=/usr/i686-pc-mingw32/sys-root/ \         --sysinclude=/usr/i686-pc-mingw32/sys-root/mingw/include/ \         --enable-static \         --disable-shared \         --enable-zlib \         --extra-cflags='-mno-cygwin -mms-bitfields' \
[16:00] <gdp16> when I run, ffmpeg
[16:00] <gdp16> ffmpeg can't load libz-1.dll
[16:00] <gdp16> does anyone have idea?
[16:03] <JEEB> you built/have a dynamic zlib installed and that got linked
[16:03] <JEEB> nothing more, nothing less
[16:03] <JEEB> also, I think newer gccs don't work with -mno-cygwin so you must be using something old
[16:03] <JEEB> but that's a separate problem :P
[16:05] <gdp16> I use i686-pc-mingw32-gcc version 4.5.2
[16:06] <gdp16> and how to avoid this error? is there any special configuration to not use zlib shared library?
[16:08] <JEEB> dunno, I just usually don't have the dynamic lib around .-.
[16:09] <gdp16> @JEEB, did you also build ffmpeg in cygwin, if you did, would you let me know your configuration?
[16:11] <JEEB> I use msys/mingw in most cases >_>
[16:11] <gdp16> owh...
[16:13] <Guest59107> hi guys, i'm trying make a image loop video with fade in and fade out. How can i make it to fade in & fade out from white ?
[16:13] <Guest59107> here is my command
[16:13] <Guest59107> http://pastebin.com/Ymn71cSj
[16:40] <gdp16> @JEEB, i try to build in msys/mingw environment.
[16:40] <gdp16> but I got warning, pkg-config not found..
[16:40] <gdp16> is that OK?
[16:40] Action: JEEB sighs
[16:41] <JEEB> if you don't understand that you could've just dealt with the dynamic lib of zlib and built a static lib I'm quite sure you're completely not sure what you're doing .-.
[16:42] <gdp16> hmmm..
[16:43] <gdp16> I am newbie in here ^^..
[16:50] <Guest59107> if anyone could help me, i will send you a pint of beer :)
[16:53] <Guest59107> oh well it was worth a try
[16:53] <cbreak-work> hmm... ffmpeg headers fail to compile on linux
[16:53] <cbreak-work> they worked fine on mac os
[16:54] <cbreak-work> error: /usr/local/include/libavutil/common.h:170:47: error: UINT64_C was not declared in this scope
[17:48] <dericed> maybe a dumb question: can I run latest git of ffmpeg with libx264 on Ubuntu 10.04. I have a project where I need both the latest ffmpeg and the LTS of Ubuntu
[17:51] <gdp16> yes
[17:51] <gdp16> I think you can use git command
[17:51] <dericed> thanks
[17:52] <thoro> Hello everyone - so, I'd like to decode a MPEG4-Video Stream from an ACTi Hardware Encoder (TCP Stream) and use the rendered frame in a .net Application - I already parse the tcp stream and filter out the raw MPEG4 data, I've initialized a AVIOContext with callbacks at read_packet and seek, but after the first 10 bytes i get 2 errors ( err{or,}_recognition separate: 193588380; 86261680, err{or,}_recognition combined: 193588380; 265008619) af
[17:54] <thoro> I'm currently initializing the stream with av_open_input_stream and a pre selected AVInputFormat (m4v)
[18:30] <thoro> okay got it working :) - used new instead of av_alloc_context
[18:41] <thoro> how can I reduce the cached time?
[18:44] <kriegerod> thoro: you can open your tcp socket as input, iirc
[18:48] <pasteeater> dericed: of course http://ubuntuforums.org/showpost.php?p=9868359&postcount=1289
[18:51] <Arthur_D> once again, I'll ask if anyone knows how to improve the resulting audio when recording video with glc and audio with ffmpeg. If anyone knows how to make the resulting audio not stutter, I'd be very grateful
[18:56] <pasteeater> Arthur_D: does the audio stutter when you do not record video at the same time?
[18:57] <pasteeater> also, use a pastebin site to show your ffmpeg command and the complete console output
[18:57] <thoro> kriegerod: but I need the data that's sent in the B2 headers and there's auth -- btw it already works :), just 800 ms delay - how do I minimize that?
[18:58] <kriegerod> thoro: do you _decode_ packets using libavcodec also? if so, probably there're options that can be tuned to speedup
[18:59] <kriegerod> for example, you can turn on decoding multithreading
[18:59] <kriegerod> although its better to check all the system, possibly several places can be enhanced in terms of performance
[19:00] <thoro> I don't think it's a performance problem
[19:00] <Arthur_D> pasteeater: no, it does not stutter when I don't record video at the same time. I'll put up a pastebin ASAP
[19:00] <thoro> it just just caches stuff like in vlc player where you can reduce the Caching
[19:01] <thoro> okay, it definitly caches a certain amount of KB (just reduced the Bitrate and now the lagg is much higher)
[19:01] <kriegerod> if you just give it data stream, and take back AVPacket's, it should not cache anything
[19:01] <thoro> yeah I do that
[19:05] <Arthur_D> pasteeater: http://pastebin.com/chERRADi
[19:10] <pasteeater> Arthur_D: i do not believe MP3 is officially supported in MP4.
[19:10] <pasteeater> is $fname.mp4 or $fname.wav stuttering?
[19:11] <Arthur_D> pasteeater: both, if I open the .wav in Audacity there are gaps in the file
[19:12] <pasteeater> where does $fname.wav come from? i don't see a ffmpeg command making that
[19:13] <Arthur_D> wait, I'll paste the whole file. Somehow I removed that part when I tried to remove the commented lines (there are lots :P)
[19:14] <Arthur_D> http://pastebin.com/TwrkcnQ0
[19:16] <zpmorgan> Is there a way to turn a video into a bunch of 1-second audio clips with associated screenshots?
[19:18] <zpmorgan> and what are the rawest formats for both images & audio??
[19:48] <zap0> PCM
[19:51] <pasteeater> Arthur_D: -threads 0 does nothing for audio
[20:08] <Megapixar> any advice on missing lpthread please? http://pastebin.ca/2102735
[20:13] <Megapixar> BTW, on ffmpeg.org is a spelling mistake, under News section: "Januar 5, 2012..."
[20:18] <dericed> BTW, on http://ffmpeg.org/libavfilter.html#scale there is a mistake. The sar argument is listed twice.
[20:21] <Arthur_D> pasteeater: OK, will remove that then. But I doubt it would matter for the stuttering
[20:25] <pasteeater> Arthur_D: same here. ping burek if you ever see him here. he knows more about audio capture than me.
[20:27] <Arthur_D> thanks. I've been trying to fix this for a couple days, but I've had no luck. Hopefully burek will know something of help
[20:28] <pasteeater> dericed: http://ffmpeg.org/pipermail/ffmpeg-devel/2012-January/119064.html
[20:30] <Megapixar> Any advice on missisng pthreads library? getting same arror with 0.9.1 as well. http://pastebin.ca/2102735
[20:31] <JEEB> Megapixar, does it work with -L/usr/lib64 ?
[20:33] <Arthur_D> pasteeater: one more thing: about the video output - will the parameters I'm using give the highest possible output quality? I will later edit videos together and I'd like to keep them as lossless as possible
[20:34] <pasteeater> if you're editing then use a lossless output that is edit friendly as an intermediate file.
[20:34] <pasteeater> i wonder if you can use '-c:a copy' with alsa/pulse input.
[20:35] <pasteeater> ...then output from editor as lossless too and re-encode with ffmpeg/x264 (or encode directly from editor if you trust it).
[20:36] <Arthur_D> so -acodec copy and -vcodec copy will output to an editor-friendly format? That's why I'm using libx264 since I know I can open it in editors
[20:36] <pasteeater> no
[20:36] <Arthur_D> what do you suggest to use?
[20:37] Action: pasteeater must go afk. tags JEEB into ring.
[20:37] Action: JEEB takes out the :effort: card
[20:37] <Arthur_D> :D
[20:38] <Arthur_D> as you can see, I'm by no means an expert. With audio, I know WAV and FLAC is lossless, but what to use for video I have no idea
[20:39] <JEEB> no "normal" H.264 decoder that is in some commercial editor supports lossless H.264, so libx264 is out of the question I guess
[20:39] <JEEB> if you're on windows you could use ffvhuff with WAV/PCM in avi
[20:39] <Arthur_D> I'm on Linux
[20:39] <JEEB> there are video editors on lunix?
[20:40] <Arthur_D> why would there not be?
[20:40] <JEEB> anyways, that then depends on what library is used to load the clips, and even more importantly -- how old
[20:41] <JEEB> anyways, ffvhuff + wav/pcm in avi is a safe bet
[20:41] <Arthur_D> I'm using a rolling-release distro, Arch Linux
[20:41] <JEEB> since even the old stuff supports that
[20:41] <Arthur_D> ok, what extension does it use?
[20:41] <JEEB> ?
[20:41] <Arthur_D> filename extension
[20:41] <JEEB> ffmpeg -i input.derp -vcodec ffvhuff -acodec pcm16lewhatever derp.avi
[20:42] <Arthur_D> ok, thanks :)
[20:42] <JEEB> you can also test crf 0 libx264 at some point of time with the editor to check if it supports lossless H.264
[20:43] <Arthur_D> alright, sounds good. Now I have two options, thanks :)
[20:44] <JEEB> if lossless H.264 works with the editor, you might want to make GOPs shorter, because usually editing means lots of seeking
[20:44] <JEEB> and the less frames you have to decode before getting a picture after seeking, the better
[20:45] <Arthur_D> um, okay
[20:47] <Arthur_D> any reason to use lossless H.264 instead of ffvhuff?
[20:48] <JEEB> it compresses better
[20:48] <Arthur_D> ok, I will try to see if I can use that then
[20:48] <JEEB> ffvhuff is just fast
[20:48] <JEEB> very fast
[20:48] <JEEB> in both decoding and encoding
[20:49] <Arthur_D> hm, well I think it's more compelling to use that then
[20:49] <Arthur_D> I've got plenty of disk space
[20:49] <Megapixar> JEEB: no, same error. I looked inside /usr/lib64/lpthread.so since its only 222 bytes. http://pastebin.ca/2102744  should I rebuild pthread, if so how would I do that?
[20:51] <JEEB> I don't know... haven't dealt with weird multilib distros
[21:49] <eightfold> can anyone recommend any more recent and good quality codec shoot-outs. i'm looking at a 2005 shoot-out at doom9. seems to be the latest.
[21:54] <pasteeater> eightfold: you might be interested by http://x264dev.multimedia.cx/archives/102
[21:54] <pasteeater> still old, but not as
[21:54] <pasteeater> or same time and just use x264
[21:57] <JEEB> s/same/save/
[22:33] <ircdearia> Is there a way I can use ffmpeg to create a v4l2 device so that I can stream/broadcast a video live over network/Internet?
[23:13] <eightfold> pasteeater: thanks. are those mighty settings lines necessary when using like ie mpeg-4 asp? isn't there something like lame's --preset or -Vx?
[23:14] <pasteeater> eightfold: not really. generally i just use -qscale if encoding with -c:v mpeg4
[23:15] <pasteeater> lower value is higher quality.
[23:15] <pasteeater> sane range is 3-5. consider 2 to be visually lossless, IIRC.
[23:17] <eightfold> pasteeater: sorry for a stupid question. but is there such a thing as "pure" mpeg-4 asp (as presented in this blog-post). i thought there was only implementations of mpeg-4 part 2 such as xvid divx etc.
[23:21] <kriegerod> when ffmpeg prints its stats on _new_ line, instead of rewriting old on the same line, it means it has reconnected? (applying to applehttp stream)
[23:46] <epsilon> I need a hint, I'm trying to record through the mic-in of the soundcard: http://paste.debian.net/152069
[23:47] <epsilon> I can hear the sound via alsa and headphone directly, but the recorded file is empty.
[23:47] <epsilon> I also tried different hw, codec, sample rate, no effect. Any ideas?
[23:55] <ircdearia> loopback is perhaps a useful keyword relative to my question
[00:00] --- Fri Jan 13 2012

More information about the Ffmpeg-devel-irc mailing list