[Ffmpeg-devel-irc] ffmpeg.log.20120113

burek burek021 at gmail.com
Sat Jan 14 02:05:02 CET 2012

[02:50] <kode54> is there any way to convert a left/right stereo video pair to a side by side video without using stupid hacks like converting all the videos to image files and assembling them with imagemagick?
[02:50] <kode54> I'd rather just use avisynth for that, except that's not portable
[03:08] <iive> kode54: ffmpeg support multiple input file and video filter system that can handle parallel branches.
[03:08] <iive> but i'm not sure about the exact syntax.
[03:19] <kode54> I see video filter options
[03:19] <kode54> what would be really handy would be if the input specifier could specify a stream id from existing inputs
[03:19] <kode54> since the input video I have is an AVI file with two video streams
[03:20] <kode54> ah, split option
[03:21] <kode54> no
[03:26] <kode54> http://ffmpeg-users.933282.n4.nabble.com/libavfilter-multiple-input-td3237343.html
[03:26] <kode54> I see nobody answered it
[03:30] <ubitux> -f lavfi -i "movie=a.mp4 [a]; movie=b.mp4 [b]; [a][b] overlay=..." ?
[03:46] <kode54> got it
[03:46] <llrcombs> anyone here know anything about weird caption formats?
[03:46] <kode54> ffmpeg -i HNI_0043.AVI -map 0:0 -map 0:1 -vf "[in]pad=iw*2:0:0:0:black, [T1]overlay=480:0, scale=0:ih*2[out]; movie=HNI_0043.AVI:si=2[T1]" -acodec libmp3lame -ab 192k -vcodec libx264 -crf 20 HNI_0043_sxs.mkv
[03:47] <kode54> to turn 3DS video into side by side format suitable for youtube
[03:47] <kode54> 3DS is AVI, with two 480x240 MJPEG streams sandwiching a 16KHz mono IMA ADPCM stream
[03:48] <kode54> video filter trickery to overlay and stretch the video
[03:48] <kode54> stretch is needed for youtube aspect handling after turning on 3D side by side mode
[05:07] <misslesbian> Hello
[05:25] <epsilon> what can be the reason, if ffmpeg is ignoring -acodec and -vcodec for output format?
[05:26] <epsilon> trying to grab video, but it's taking mpg4 video and mp2 audio whatever I say
[05:29] <relaxed> epsilon: pastebin.com
[05:32] <epsilon> http://paste.debian.net/152112 - I tell to use v/acodec, but in lines 27/28 they are ignored
[05:35] <drv> you need to put the output options after the input options
[05:35] <drv> move -acodec xyz and -vcodec xyz after /dev/video0
[05:37] <epsilon> ah better
[05:45] <epsilon> I was fooled cause -vcodec copy worked at the "wrong" position
[05:51] <relaxed> epsilon: Your output will be huge.
[05:52] <relaxed> -sameq does nothing in that command
[05:53] <epsilon> ok, it's leftover from earlier test, cause -vcdiec was ignored
[05:53] <relaxed> In fact if Zeus came down from heaven and made me king of the world, my first course of action would be to remove -sameq forever
[05:54] <relaxed> then world peace
[06:02] <epsilon> question is the bitrate... what should I take to encode analog PAL (720x480) into mpeg4, like ~8MBits as -sameq used?
[06:04] <relaxed> If you just want great quality I recommend -qscale 3.
[06:05] <Ginks> what would you recommend for a watermark overlay?
[06:05] <Ginks> -qscale or qmax?
[06:05] <relaxed> the qscale range is 1 (highest quality) - (lowest) 31
[06:05] <Ginks> I'm not even sure what qscale is
[06:06] <Ginks> vs qmax
[06:06] <Ginks> I'm not doing any scaling though
[06:06] <Ginks> lol
[06:06] <epsilon> qscale applies to VBR? I prefer CBR...
[06:07] <Ginks> cbr is actually what I think I should be doing since it's streaming
[06:07] <epsilon> I want to cut the grabbed video later with other tools, CBR vid and audio is better for that in my experience
[06:07] <epsilon> VBR often resulted in async audio
[06:07] <relaxed> keep it lossless if you're going to be editing
[06:08] <epsilon> I'l keep PCM for audio, but video I'd like to use mpeg4 due to size
[06:11] <relaxed> vbr should not affect sync in any way.
[06:42] <epsilon> zomg
[06:43] <epsilon> I wonder why I can't open libxvid encoded video in virtualdub in Windows -> I have to open hex editor and change manually "xvid" in the avi file to "XVID"
[06:47] <relaxed> ffmpeg has -vtag
[08:28] <burek> is there any ffmpeg based subtitle editor?
[08:28] <burek> or any subs editor that supports h264
[08:34] <cbreak-work> h264 does not support subtitles
[08:56] <jck_true_> burek: I think you're confusing with mp4
[08:57] <jck_true_> burek: Might wanna look at mp4box - http://gpac.wp.institut-telecom.fr/
[09:01] <cbreak-work> hmm... ffmpeg compiles fine on OS X, but somehow it fails to link on Ubuntu :(
[09:02] <burek> no, i have subtitleeditor which doesnt want to load h264 movie
[09:02] <burek> so im asking is there any other subtitle editor
[09:02] <burek> which can load h264 movie
[09:02] <burek> so i can edit my subtitles
[09:03] <jck_true_> burek: Extract them with mp4box
[09:03] <burek> and?
[09:03] <cbreak-work> h264 doesn't support subtitles
[09:03] <burek> :)
[09:03] <burek> ok you are seriously misunderstanding something
[09:03] <cbreak-work> if you have a movie that has subtitles, then it's most likely some container format that does
[09:03] <burek> i have my subtitles
[09:03] <burek> and a movie downloaded from the internet
[09:04] <burek> i need a movie as a ref. point to sync subs
[09:04] <burek> thats all
[09:04] <jck_true_> oh
[09:04] <jck_true_> no clue
[09:04] <jck_true_> sorry
[09:04] <burek> i dont need to embed/extract subs from a container :)
[09:22] <burek> i solved it by installing gstreamer0.10-ffmpeg package :) thanks to all for help :)
[09:25] <cbreak-work> I switched back from git master tip to n0.9.1
[09:26] <cbreak-work> but ffmpeg still doesn't compile on linux
[09:26] <cbreak-work> http://paste.the-color-black.net/224216
[09:26] <cbreak-work> well, linker error that is, not a compiler error
[09:31] <cbreak-work> well... seems all .o files are ... 0 bytes
[09:53] <cbreak-work> well, finally managed to compile ffmpeg, but now it doesn't link:
[09:53] <cbreak-work> http://paste.the-color-black.net/224219
[09:54] <cbreak-work> the same code does link on OS X
[12:24] <cjhmdm> hello, can the latest source for ffmpeg & x264 still be found at git://git.videolan.org/x264 & git://source.ffmpeg.org/ffmpeg ?
[12:25] <sacarasc> http://ffmpeg.org/download.html has the address for ffmpeg. http://www.videolan.org/developers/x264.html for x264.
[12:28] <JEEB> cjhmdm, yes -- the repository address for x264 hasn't changed for ages
[12:28] <JEEB> can be seen in the gitweb, too @ http://git.videolan.org/gitweb.cgi?p=x264.git
[12:29] <cjhmdm> JEEB: thanks
[13:08] <elkng> the smartphone supports natively "MP3/WMA/eAAC+" and "MP4/H.263/H.264", how can I convert video to supported format ?
[13:08] <elkng> this: "ffmpeg -i 1.flv -vcodec h263 -vb 2000k -s 320x240 -ab 128k -ar 44100 -ac 2 -acodec libmp3lame -y -f avi 1.avi" cant be played
[13:08] <elkng> and this: "mencoder 1.flv -o 2.avi -oac mp3lame -ovc xvid -xvidencopts bitrate=687" cant be played
[13:17] <dipanjan> hi, can someone please explain to me the syntax of padding using -vf?
[13:17] <dipanjan> -vf pad=width:height:x:y:color
[13:31] <cjhmdm> hello, if I'm setting the following options - -b:v 1200k -minrate 1200k -maxrate 1200k - what would the proper -bufsize be?
[13:32] <cjhmdm> or does it really matter? I'm not sure what this setting does exactly, so not sure how important it is
[13:43] <burek> does anyone have a working example of burning subtitles onto a video? :)
[13:43] <burek> using ffmpeg :)
[13:46] <ubitux> -vf ass=foobar.ass
[13:47] <burek> thx :) and how to convert txt/srt to ass? :)
[13:49] <ubitux> gaupol/subtitleseditor/aegisub ?
[13:49] <ubitux> maybe ffmpeg is able to do it btw
[13:49] <ubitux> maybe try ffmpeg -i foobar.ass foobar.srt (not sure it will work)
[13:49] <burek> subtitleeditor
[13:50] <burek> heh save as :) thanks :D
[13:52] <shroomM> anyone has any experience with ms's adaptive streaming solution - smooth streaming ?
[13:56] <burek> ms? :S
[13:56] <shroomM> microsoft ;)
[13:57] <burek> yeah, i was afraid you're gonna say that :/
[13:58] <shroomM> haha, lol
[13:58] <burek> :)
[14:04] <ideea> hi :) can any1 help me: i have source video in WMV format, but when i try to convert it, to, for example, flv with this command: http://pastie.org/3178088 i get this error: http://pix.am/bUbG/
[14:08] <ideea> friends, help :D
[14:13] <JEEB> first of all...
[14:13] <JEEB> lol old ffmpeg .-.
[14:13] <ideea> dunno, all from sid's rep
[14:14] <JEEB> also, damn at that libx264 stuff...
[14:14] <ideea> simplt apt-get :)
[14:14] <JEEB> just build current libx264 and ffmpeg and apt-get the faac devel/lib package if you need that >_>
[14:14] <ubitux> at least 3 years old
[14:14] <JEEB> oh, and you probably need current yasm for x264 so build that first, too
[14:15] <ideea> on other server: freebsd i have 0.8.5.git-9719f25 version
[14:15] <ideea> but there another error
[14:16] <ideea> http://pix.am/bNih/
[14:17] <ideea> input/output error with thw same command.
[14:17] <ideea> :(
[14:18] <ideea> well, here is full configured server for my task, but i can't get this convertation to work
[14:18] <JEEB> > gcc from 2007
[14:18] <JEEB> anyways
[14:18] <JEEB> minimize the command line
[14:19] <JEEB> also jesus fuck that configure line .-.
[14:19] <ideea> its important parameters for ffmpeg :)
[14:19] <ideea> that i need.
[14:19] <JEEB> ffmpeg -i input.wmv -vcodec libx264 -crf 20 -an out.flv
[14:19] <JEEB> try this first
[14:20] <ideea> same error
[14:20] <JEEB> then it's borked
[14:20] <JEEB> easy as that
[14:20] <JEEB> either the compile or the input file
[14:20] <JEEB> I'm going to bet on the compile first
[14:20] <ideea> maybe, there is some problem with wmv? cause i can convert flv to mpg, for example
[14:22] <JEEB> anyways, what gcc does the linux box have?
[14:22] <JEEB> (don't tell me it's older than that freebsd's 4.2)
[14:22] <ideea> 4.2.1
[14:22] <JEEB> .-.
[14:22] <JEEB> ok, I don't want to have anything to do with you, sorry
[14:22] <ideea> rofl :D
[14:23] <ideea> any1 other?:))
[14:23] <ideea> or, tell me what to write to admins, they will configure server for it
[14:23] <JEEB> in any case, build on some relatively sane set-up current yasm, current libx264 and ffmpeg with the minimal configure line (./configure --enable-gpl --enable-nonfree --enable-libx264 --enable-libfaac or so)
[14:23] <JEEB> and check if it still fails
[14:26] <ideea> ok, ty, i will tell support team of content srver to do this.
[14:26] <JEEB> also, make sure that the wmv has no drm on it :V
[14:27] <ideea> drm?
[14:28] <JEEB> "digital rights management"
[14:28] <JEEB> encrypted files in other words
[14:28] <JEEB> which will naturally fail
[14:28] <ideea> no, nothing with this. all videos are mine.
[14:28] <ideea> well, its for porno studio.. :)
[14:29] <JEEB> it seems like you just don't understand what I'm talking about at all .-.
[14:30] <JEEB> in any case, do what I said and try with current libx264 and ffmpeg
[14:30] <ideea> yes, i already wrote support team to do this, then i will try.
[14:30] <ideea> thank you.
[14:32] <JEEB> also, does this wmv file work? http://www.mediafire.com/?jllmmt3jtwh
[14:33] <JEEB> with something simple like ffmpeg -i input.wmv -vcodec libx264 -crf 20 -an out.flv
[14:49] <burek> I'm gonna build a generic big fat ffmpeg
[14:49] <burek> and let people download and use it
[14:49] <burek> (without non-free stuff)
[14:49] <burek> even better, i'll make a cron job to rebuild it every 7 days
[14:50] <burek> so they will have the latest binary all the time
[14:59] <Mavrik> for which OS? :)
[15:13] <ideea> JEEB, no. Also, with last ffmpeg, lib..etc same error.
[15:46] <arbn> On one particular Linux box, ffmpeg produces an empty mp3 when piped some webm video input. I have the verbose output:http://bpaste.net/show/21766/
[15:46] <arbn> Any ideas on why? I can provide more details.
[15:58] <relaxed> arbn: Works here. Maybe your ffmpeg is too old.
[15:59] <arbn> The thing is, it worked on another machine with the exact same ffmpeg package.
[16:01] <burek> Mavrik, debian most probably :)
[16:05] <relaxed> burek: I have big fat staic builds people can download. https://sites.google.com/site/linuxencoding/builds
[16:05] <relaxed> static*
[16:05] <burek> great :)
[16:06] <burek> we can make a list of OSes for download
[16:06] <burek> to save time for others
[16:06] <burek> i mean builds for different OSes :)
[16:07] <arbn> OK. Saving the data to the command-line works. It's only when I try to convert through a pipe that it produces empty output.
[16:10] <relaxed> arbn: you can cheat, ffmpeg -i input.webm -f nut - 2>/dev/null | ffmpeg -f nut -i - out.mp3
[16:11] <relaxed> actually, ffmpeg -i input.webm -vn -f nut - 2>/dev/null | ffmpeg -f nut -i - out.mp3
[16:17] <relaxed> arbn: er, that isn't lossless ^^, ffmpeg -i out.webm -vn -acodec pcm_s16le -f nut - 2>/dev/null | ffmpeg -f nut -i - -y out.mp3
[16:18] <relaxed> that's my final answer.
[16:20] <arbn> relaxed: my input is coming via a pipe, not a file.
[16:20] <arbn> It's raw piped video data.
[16:20] <arbn> [nut @ 0x8712880]EOF before video frames
[16:20] <arbn> pipe:: Operation not permitted
[16:23] <relaxed> if it's raw yuv you need to tell ffmpeg how to decode it. ... | ffmpeg -s WxH -r framerate -pix_fmt yuv420p -f rawvideo -i -
[16:25] <arbn> ffmpeg -loglevel quiet -i pipe:0 out.mp3
[16:26] <arbn> It works fine, expect on this one machine. Now raw video, but the WebM bytes. Sorry.
[16:26] <arbn> Not raw*
[16:28] <arbn> I am piping a WebM file byte-by-byte to stdin, and trying to encode into mp3.
[16:28] <relaxed> I don't think that's going to work
[16:28] <arbn> It does. On every machine I've tried it on, except this one.
[16:32] <relaxed> my mistake, it does work.
[16:34] <arbn> Yeah. Except that, in this one case, the mp3 output is empty. I wouldn't expect ffmpeg to stop reading the stream until EOF, though, so I don't understand at all.
[16:38] <arbn> Oh. The ffmpeg output is different...
[16:39] <arbn> Would the difference between "libmp3lame" and "mp3" be significant?
[16:41] <relaxed> what's different?
[16:42] <arbn> Stream #0.0: Audio: libmp3lame, 44100 Hz, stereo, s16, 64 kb/s
[16:42] <arbn> Under "metadata:"
[16:42] <arbn> The other machine has "mp3" there.
[16:44] <relaxed> Are you sure they're using the same packages? I think "mp3" is the old name for "libmp3lame"
[16:45] <arbn> Oh. No, these aren't the same packages. I'll try it on the machines that have the same packages, and then paste the output for both on bpaste.
[16:55] <arbn> http://bpaste.net/show/21774/
[16:55] <arbn> There. As you can see, the top output concludes with 0kb audio.
[16:56] <arbn> The command is the same.
[16:57] <relaxed> the solution would seem to be updating the other machines ffmpeg version
[16:59] <relaxed> it looks like 0.6.3 predates webm
[17:00] <arbn> Oh. Wow. No idea how I missed that. I need to sleep. Thanks for your help and patience.
[17:01] <relaxed> you're welcome
[17:07] <NapHtaKeRoSene> hi
[17:07] <NapHtaKeRoSene> i have invented area map in 8 hours, good time?
[18:16] <naeluh> Hi all having trouble installing yasm can anyone give me a hand I am on ubuntu
[18:22] <grepper> naeluh: if apt-get install yasm is failing you probably need help in #ubuntu
[18:22] <naeluh> grepper:okay cool
[18:56] <Budd> I'd like to decode video frames into RGB, but with layout of row > channel > column (in decreasing order of significance)
[18:57] <Budd> All the RGB formats I see listed put the three channels for one pixel together.
[18:57] <Budd> Is there a way to specify my own format for libavformat to use, or should I just suck it up and reorder the data myself?
[19:10] <teratorn> Budd: you mean planar rgb?
[19:10] <Budd> teratorn: not quite, but that would be better.
[19:11] <teratorn> see the GBRP* formats then, I guess
[19:13] <Budd> My layout goal is to have all the red values for one row contiguous, then group three of those to make one line.
[19:14] <Budd> I think my error was grepping for RGB, not GBR - thanks!
[19:15] <Budd> nope - not seeing GBRP in libavutil/pixfmt.h
[19:17] <Budd> I suppose learning to to the SSE shuffle will let me reorder pixels fast enough.
[19:17] <Budd> I may write a tune called the "SSE shuffle"
[19:19] <fris> trying to compile 0.9.1 and keep getting this error http://pastie.org/3179640 any ideas?
[19:40] <naeluh> hi is there documentation on installing libfaac? thanks!!
[20:03] <naeluh> cant install libfaac can some one help
[20:29] <arbn> naeluh: Give more detail than "can't install". What's happening?
[20:30] <naeluh> arbn: thanks
[20:31] <naeluh> arbn: I am on ubuntu lucid I used command sudo apt-get install faac should that be suffcient?
[20:31] <naeluh> it looked like it worked
[20:32] <relaxed> you will need the -dev package too
[20:32] <arbn> If you're compiling ffmpeg, you want libfaac-dev, yeah.
[20:32] <naeluh> like this sudo apt-get install libfaac-dev libfaac0
[20:32] <arbn> I think so. I don't use Ubuntu or Debian.
[20:33] <naeluh> I did that and it looks like it worked
[20:43] <naeluh> weird it still isnt wrking
[20:43] <naeluh> is there a way to find out if libfaac is installed ?
[20:44] <relaxed> are you running ./configure --enable-libfaac --enable-nonfree ?
[20:49] <naeluh> would I run that when I configure ffmpeg
[20:49] <relaxed> yes
[20:55] <naeluh> I think it might be a problem with an install script I am using its this one http://www.ffmpeginstaller.com/
[20:55] <naeluh> I think maybe I should try to compile it myself
[20:55] <naeluh> cause it seems to be screwing up
[21:18] <JEEB> [mp4 @ 0x1da33c0] malformated aac bitstream, use -absf aac_adtstoasc -> [aac @ 0xc13700] Multiple RDBs per frame with CRC is not implemented.
[21:18] <JEEB> normal behavior?
[21:19] <JEEB> (mp4 output with ffaac)
[21:19] <JEEB> (yes, the person I'm helping doesn't have any other aac encoders installed)
[21:26] <relaxed> you're stream copying aac to mp4
[21:27] <relaxed> ?
[21:27] <JEEB> nope
[21:27] <JEEB> -acodec aac
[21:27] <JEEB> (with strict experimental)
[21:27] <relaxed> that shouldn't happen
[21:28] <JEEB> ...yeah
[21:28] <relaxed> then your answer is no :)
[21:30] <JEEB> http://pastie.org/3180336 -> http://pastie.org/3180342
[21:30] <JEEB> some arch packaged ffmpeg
[21:30] <JEEB> ffmpeg -i input.derp -s 480x272 -vcodec libx264 -crf 22 -preset fast -profile main -level 3 -x264opts ref=3:b-pyramid=none:weightp=1 -acodec aac -strict experimental -ab 192k -absf aac_adtstoasc out.mp4
[21:30] <JEEB> s/profile/profile:v/
[21:30] <JEEB> should be the command line
[21:31] <JEEB> he can't paste it all because he seemingly is using his distro without a DE... and not through ssh .-.
[21:32] <ioni> maybe ffmpeg master requires a more newer x264?
[21:33] <JEEB> I don't see libx264 being the problem >_>
[21:33] <Milos_SD> Hello... I have a little problem with gstreamer-ffmpeg in Ubuntu 11.10 ... I have ffmpeg compiled from source from git. Today I compiled a new version of ffmpeg from latest git, and Totem and mozilla-totem can't play any videos. When I do "gst-inspect" I get this on the begining: http://pastebin.com/d698m1hT  How can I solve this?
[21:33] <ioni> that is a 2 days old snapshot
[21:34] <ioni> jeeB let me do another package
[21:34] <JEEB> oh, you're the guy responsible for this?
[21:34] <JEEB> lol
[21:34] <ioni> yeah :)
[21:34] <JEEB> also, add libvo_aacenc if you can... you're already at gplv3 anyways >_>
[21:34] <ioni> no
[21:34] <JEEB> aww
[21:35] <ioni> is not in the repos and i don't want to maintain yet another package
[21:35] <JEEB> oh well, for a mobile device ffaac should be good enough
[21:35] <JEEB> if it would work .-.
[21:35] <JEEB> anyways, a newer libx264 isn't a bad idea, but I just don't see why an older libx264 would be the problem here >_>
[21:36] <JEEB> libx264 seems to be working fine, but the audio part seems to herp a derp
[21:36] <ioni> i don't have time now to recompile all packages for new x264
[21:36] <JEEB> well, as I said I don't really think that error happens because of libx264 >_>
[21:37] <JEEB> at least it doesn't show itself anywhere
[21:37] <ioni> Milos_SD, gstreamer-ffmpeg doesn't use external ffmpeg
[21:37] <ioni> at least developers do not suggest using it
[21:38] <Milos_SD> ioni, so why does it segfault when I have ffmpeg from source, and not when I have ffmpeg from ubuntu repo?
[21:38] <ioni> JEEB i686 or x86_64?
[21:38] <ioni> Milos_SD, no idea, get a trace
[21:38] <JEEB> ioni, no idea -- I'll ask the guy >_>
[21:39] <ioni> cool
[21:41] <ioni> jeeB  http://pkgbuild.com/~ioni/ffmpeg/
[21:41] <JEEB> linked to the guy
[21:41] <Milos_SD> ioni, this: http://paste.ubuntu.com/803410/ ?
[21:41] <ioni> Milos_SD, no
[21:41] <ioni> gdb trace
[21:46] <Milos_SD> ioni, never mind, fixed it by compiling gstreamer-ffmpeg :D
[21:46] <ioni> jeeb any news?
[21:46] <JEEB> ioni, seems to do the same thing
[21:46] <ioni> ok
[21:47] <ioni> let me compile new x264+ffmpeg rebuild
[21:50] <relaxed> JEEB: If the preson you're helping is using 64bit linux: https://sites.google.com/site/linuxencoding/builds
[21:51] <ioni> relaxed, because using some random binary from internet helps a lot ?:)
[21:51] <ioni> while keeping the distro version broken
[21:53] <JEEB> relaxed, thanks but I have no idea about which arch he is even now. He never answered that question, just tried ioni's newer compile
[21:53] <JEEB> I actually asked the guy for ssh access to his box so I could handle compilation of multimedia stuff etc. for him... but it seems like he hasn't even installed openssh yet .-.
[21:54] <JEEB> no idea how the hell he's using arch without a DE and without using it externally via ssh
[21:54] <relaxed> ioni: I have no control over distro's broken ffmpeg packages and all the control over my own.
[21:55] <ioni> the point is that is better to fix the bug upstream rather that workaround the issue by using some random stuff
[21:55] <ioni> jeeB tell him to install the new packages
[21:55] <ioni> x264 and ffmpeg
[22:06] <ioni> jeeB don't forget to pacman -Suu after
[22:06] <ioni> x264 had a soname bump
[22:07] <JEEB> posted that to the guy... kind of herping a derp because I can't get access to the box so I can't exactly see what the heck he's doing .-.
[22:51] <ioni> jeeB any luck?
[23:21] <ValW> @find *air*supply*
[23:43] <gentt> Hello guys
[23:43] <gentt> I need some help with the commands
[23:44] <gentt> 'man' didn't help much
[23:44] <llrcombs> what are you having trouble with?
[23:44] <gentt> so i have video .mp4 which is in 1080p
[23:44] <gentt> i want to convert it into .avi with 480p
[23:44] <gentt> what command should i use?
[23:45] <gentt> llrcombs, ?
[23:46] <llrcombs> ffmpeg -i original.mp4 -acodec nameYourCodec -vcodec nameYourCodec -s 854x480 out.avi
[23:46] <llrcombs> throw in an -acodec and bitrate settings
[23:46] <llrcombs> (right now that command is incomplete)
[23:46] <llrcombs> or make it 720x480 if you want DVD quality
[23:47] <llrcombs> here, have a cheat sheet: http://rodrigopolo.com/ffmpeg/cheats.html
[23:55] <gentt> llrcombs, what nameYourCodec would be?
[23:57] <gentt> in the end i just used ffmpeg -i original.mp4  -sameq -s 854x480 out.flv
[23:59] <JEEB> > sameq
[23:59] <llrcombs> well, if you want an FLV, that works
[23:59] <JEEB> sameq does not do what you think it does
[23:59] <JEEB> the new ffmpeg help should properly say what it does
[23:59] <llrcombs> JEEB: I've been wondering, what exactly does it do?
[23:59] <llrcombs> (assuming I'm using latest git [I am])
[23:59] <JEEB> it has always done the same thing. it copies the qp values from source and uses them as-is.
[00:00] --- Sat Jan 14 2012

More information about the Ffmpeg-devel-irc mailing list