[Ffmpeg-devel-irc] ffmpeg.log.20120117

burek burek021 at gmail.com
Wed Jan 18 02:05:02 CET 2012

[00:00] <JEEBsv> Nah, not only that. I've just gotten used to the fact that most people who think they know something about these things (even people on committees) are people who can't think of anything else to check than PSNR.
[00:00] <EOF-sensei> right now nobody seems to know how to make it work for low-bandwidth human-optimized video
[00:00] <JEEBsv> yeah
[00:00] <EOF-sensei> but that doesn't make it a lost cause
[00:00] <JEEBsv> never said it is
[00:00] <EOF-sensei> in my opinion it's a diamond in the rough
[00:00] <EOF-sensei> err
[00:00] <EOF-sensei> better than a diamond
[00:01] <EOF-sensei> diamonds aren't worth nearly as much as the diamond cartels would have you believe
[00:01] <EOF-sensei> they're pretty easy to dig up
[00:01] <JEEBsv> It's an interesting area of development/research as far as I can see.
[00:01] <EOF-sensei> well
[00:01] <EOF-sensei> the issue is that there's not enough development and research
[00:02] <EOF-sensei> because people are all hung on 'which is better?' conversations
[00:03] <EOF-sensei> every paper about wavelet compression techniques I've been able to dig up is hiding behind IEEExplore
[00:03] <EOF-sensei> which is a very poor way to explore things
[00:03] <JEEBsv> Also, IIRC JPEG2K didn't take off very well either, did it?
[00:04] <EOF-sensei> as you will bankrupt a fortune 500 company if you do.
[00:04] <JEEBsv> for pictures
[00:04] <EOF-sensei> well
[00:04] <EOF-sensei> it's nice
[00:04] <EOF-sensei> though jpeg2k needs quite a bit of refining to be 'better' than jpeg
[00:04] <EOF-sensei> it does help for progressive loading though
[00:05] <JEEBsv> true
[00:05] <EOF-sensei> and if blocking is your main concern then it's a great standard
[00:05] <EOF-sensei> I hate going to filter a cheap point-and-shoot camera's photo
[00:05] <EOF-sensei> and noticing jpeg artifacts
[00:05] <EOF-sensei> it's especially shitty if you do inverting
[00:06] <EOF-sensei> or threshold
[00:06] <EOF-sensei> because the artifacts just pop right out and spray feces all over your image
[00:07] <EOF-sensei> I personally use JPEG2000 frequently
[00:07] <EOF-sensei> it does pretty good lossless encoding
[00:07] <JEEBsv> too bad it's not widely enough supported for general linkage as far as I know
[00:07] <JEEBsv> thus I tend to use PNG
[00:08] <EOF-sensei> libopenjpeg isn't so bad
[00:08] <EOF-sensei> and if you're used to unix
[00:09] <EOF-sensei> it's no issue
[00:09] <EOF-sensei> I have a script that handles my lossless transcoding
[00:09] <JEEBsv> try linking people lossless pictures in JPEG2000 on the internet :/
[00:09] <EOF-sensei> people go all 'fuck you' mode
[00:10] <EOF-sensei> although last I checked my browser supports jpeg2000
[00:10] <JEEBsv> lol, which do?
[00:10] <JEEBsv> I haven't even checked
[00:11] <EOF-sensei> huh
[00:12] <EOF-sensei> I guess not anymore
[00:12] <EOF-sensei> or maybe I'm just trippin'
[00:13] <EOF-sensei> I think firefox has jpeg2000 support somewhere
[00:13] <EOF-sensei> but it doesn't seem to be compiled into my version..
[00:13] <EOF-sensei> perhaps from patent thingies
[00:14] <EOF-sensei> hmm
[00:15] <EOF-sensei> nope
[00:15] <JEEBsv> there's a bug tracker entry at least, and patches there
[00:15] <EOF-sensei> jpeg2000 has been cleared by patent owners
[00:15] <JEEBsv> https://bugzilla.mozilla.org/show_bug.cgi?id=36351
[00:16] <EOF-sensei> that's convenient
[00:16] <JEEBsv> "RESOLVED WONTFIX" <- lulz tho
[01:47] <YellowOnion> I'm getting drops with CPU usage every now and then with -threads 6 ( I have 6 cores ) it's only loaded about 85% seems to improve with 12 threads 95% load anyone know how to get anymore without excessive amounts of threads.
[01:53] <frighty> could somebody tell me how i get ffmpeg output into a logfile
[02:00] <YellowOnion> frighty, ffmpeg > ffmpeg.log??
[02:01] <frighty> do i type that in my command line?
[02:01] <frighty> ffmpeg.log
[02:02] <frighty> or its there somewhwer
[02:02] <YellowOnion> frighty, what system are you using?
[02:02] <frighty> windows
[02:02] <YellowOnion> oh yep
[02:03] <YellowOnion> the ">" outputs the text to a file
[02:03] <frighty> example please
[02:03] <frighty> soo like
[02:03] <YellowOnion> ffmpeg.log is just a text file
[02:03] <frighty> ffmpeg -i  infile  options outfile ffmpeg.log
[02:03] <YellowOnion> try "echo blah > test.txt"
[02:03] <frighty> wait what lol
[02:03] Action: frighty noob sry
[02:04] <YellowOnion> the windows command prompt has a feature to redirect any commands output to a file
[02:05] <YellowOnion> use the ">" symbol then after it put the name of the output file
[02:05] <YellowOnion> ffmpeg -i  infile  options outfile > ffmpeg.log
[02:05] <YellowOnion> will work
[02:05] <YellowOnion> ffmpeg -i  infile  options outfile > ffmpeg.txt
[02:05] <YellowOnion> will also work
[02:06] <frighty> ok ty ill give that a shot ina few once im done attempting to write a irc bot heh
[02:07] <YellowOnion> frighty, http://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en-us/redirection.mspx?mfr=true
[02:08] <frighty> ty
[02:11] <YellowOnion> frighty, it's something microsoft pitched from Unix
[02:37] <sneakers> How would I convert a WebM contained VP8 encoded video into mpeg4?
[02:40] <llrcombs> sneakers: -i webmVideo.webm -vcodec mpeg4 mpeg4video.mp4
[02:40] <llrcombs> throw in some video settings and you're good
[02:40] <sneakers> llrcombs, bash: -i: command not found...
[02:40] <darkstarbyte> You may also want to use -acodec copy if you don't want to reconvert it
[02:40] <llrcombs> sneakers: those are the arguments to ffmpeg
[02:40] Action: llrcombs dies a little inside
[02:41] <llrcombs> sneakers: sudo shutdown -h now
[02:41] <llrcombs> type your password when asked
[02:41] <sneakers> llrcombs, Gimme a break.
[02:41] <sneakers> been using linux for 10 years.
[02:41] <sneakers> >8-]
[02:41] <llrcombs> >_>
[02:42] <sneakers> and I use Fedora 16 , so it would be su -c 'shutdown -h now'
[02:42] <darkstarbyte> I was talking about the audio
[02:43] <sneakers> its converting now, thanks.  oh, what would be the benefit of NOT reconverting it.
[02:43] <llrcombs> sneakers: saves time and keeps quality up
[02:43] <llrcombs> remuxing doesn't drop quality, transcoding does
[02:43] <sneakers> the file has no audio stream.
[02:43] <llrcombs> oh, well then
[02:43] <llrcombs> doesn't matter then
[02:43] <sneakers> kewl
[02:43] <sneakers> thanks again
[02:43] <llrcombs> welcome
[02:44] Action: llrcombs has never actually had anyone fall for a "type dis cmd it fixs ur problm hrr drr"
[02:46] <sneakers> worst thing that would happen is a shutdown and..................possible loss of unsaved data!!!!
[02:46] <llrcombs> true
[02:46] <llrcombs> if I know someone's a huge douchebag troll, I might counter troll with "sudo rm -rf /"
[02:46] <llrcombs> or dd'ing /dev/null to /dev/sda1
[02:47] <llrcombs> never had anyone fall for it though
[02:48] <sneakers> sudo dd if=/dev/zero of=/dev/sda1
[02:48] <sneakers> lol
[02:48] <llrcombs> yep
[02:48] <sneakers> messed up
[03:17] <darkstarbyte> I will be back after I install slackware 13.37
[03:38] <frighty> YellowOnion,
[03:38] <frighty> still here
[03:38] <frighty> i did  > logfile.txt
[03:38] <frighty> but it made it empty
[04:25] <frighty> mann somebody help please i make the logfile but it doesnt show nething its just empty
[04:25] <frighty> shoutldn it write every line that is encoded or something
[04:26] <darkstarbyte> If you want that I think you could just use ffmpeg [options] > file.log
[04:27] <frighty> i put
[04:27] <frighty> ffmpeg -i infile options outfile > c:\logfile.txt
[04:27] <frighty> thats wrong?
[04:27] <frighty> it make the logfile txt but its blank
[04:28] <darkstarbyte> oh Your using Windows
[04:28] <frighty> ya
[04:28] <darkstarbyte> I am not much help on this
[04:29] <frighty> and ive put  file.log now also just spits out blank
[04:29] <frighty> id like it to spit out every single info
[04:29] <frighty> like basically generate as it encodes
[04:29] <darkstarbyte> Someone else please help him
[04:30] <frighty> what i say is that what the logfile is suppose to do ?
[04:30] <frighty> generate as its encoding
[04:34] <frighty> -vstats_file file.txt   seemed to work but anyway to make that generate as its encoding
[04:34] <flipuhdelphia> hello
[04:36] <flipuhdelphia> can you guys see me type?  says this nickname is registered, etc. not sure if i am in the room or not.
[04:37] <frighty> yep we see
[04:40] <flipuhdelphia> cool!  i have a small q: I want to send live screen data (fullscreen or portion of screen) via USB to external device.  I was told ffmpeg could help in the X11 grabbing, which I tested out and it did.  However, it creates a file and grows pretty fast (raw MPEG).  Is there a way to write to a file that will keeps its size constant, recycling old frames?  I just need to stream the screen to an external device.  My approach is to c
[04:40] <flipuhdelphia> reate a /proc file entry and have ffmpeg write to it?  That way, a /proc module just takes the data and can send it to an external device.  Thoughts?     Thank you!
[07:08] <aaronpeterson> Should one expect -vf "transpose=1" to work with libvpx?  I have it working for libx264 but libvpx seems to ignore it.
[07:10] <aaronpeterson> Nevermind.  I'm a jackass.  I had -vf before -i.  Must sleep.
[07:23] <darkstarbyte> Anyone here use slackware?
[10:28] <Ti-CoeuR> hello
[10:29] <Ti-CoeuR> quelqu'un parle français ici
[12:46] <jsmax> Hi all.
[12:46] <jsmax> If i stream to udp with ffmpeg then stream mapping is working correctly
[12:46] <jsmax> but if i stream to ffm the mapping is wrong
[12:47] <jsmax> for example:
[12:48] <jsmax> #/opt/bin/ffmpeg -f mpegts -i udp://@ -map 0:22 -map 0:23
[12:48] <Ti-CoeuR> centos
[12:48] <jsmax> yes
[12:48] <jsmax> the result is:
[12:48] <jsmax> Stream mapping:
[12:48] <jsmax>   Stream #0:1 -> #0:0 (mp2 -> mp2)
[12:48] <jsmax>   Stream #0:0 -> #0:1 (mpeg2video -> mpeg1video)
[12:49] <jsmax> [root at iptv ~]# cat /etc/redhat-release
[12:49] <jsmax> CentOS release 6.2 (Final)
[12:51] <jsmax> Can you help me please ?
[12:53] <frighty> does anybody know any .tcl scripting and if so how would u make a bot say whats going on in realtime say every 10 mins whats going on with a file encoding on server  example  bitrate size etc
[13:10] <ph1b> hey, I'm trying to convert a video using:
[13:10] <ph1b> ffmpeg -i kkurz.avi -vcodec libx264 -acodec copy -b 1024 output.mkv
[13:10] <ph1b> but it just says:
[13:10] <ph1b> [buffer @ 0xb18b40] w:720 h:576 pixfmt:yuv420p
[13:10] <ph1b> [libx264 @ 0xb10040] broken ffmpeg default settings detected
[13:10] <ph1b> [libx264 @ 0xb10040] use an encoding preset (e.g. -vpre medium)
[13:10] <ph1b> [libx264 @ 0xb10040] preset usage: -vpre <speed> -vpre <profile>
[13:10] <ph1b> [libx264 @ 0xb10040] speed presets are listed in x264 --help
[13:10] <ph1b> [libx264 @ 0xb10040] profile is optional; x264 defaults to high
[13:13] <sacarasc> You're using a really old version, and it tells you what to do.
[13:14] <ph1b> how can I update it?
[13:15] <sacarasc> What OS/distro are you using?
[13:17] <ph1b> ubuntu 11.10
[13:17] <sacarasc> There's a guide in the topic for compiling on Ubuntu.
[15:08] <YellowOnion> anyone know how to get best multi processor/core performance?
[15:09] <YellowOnion> with Linux
[15:10] <YellowOnion> there's some problems with loading all cores, i have -threads 6 set but there's constant movement of load between cores and I'm only getting about 80% total load
[15:17] <haakon__> YellowOnion: x264?
[15:17] <YellowOnion> haakon__, yeah
[15:17] <haakon__> YellowOnion: Tried using -threads 0 ?
[15:19] <YellowOnion> haakon__, trying now, doesn't look any better
[15:19] <YellowOnion> anywhere between 79 and 95% load
[15:20] <YellowOnion> I've noticed that using 12 threads helps quite a lot
[15:20] <YellowOnion> but I'm trying to understand why
[15:20] <YellowOnion> threads 0 I'm getting 13 fps
[15:23] <YellowOnion> hmm, I'm piping the dvd in to ffmpeg via mplayer with fifo's
[15:30] <YellowOnion> haakon__, added 6 threads to mplayer
[15:30] <YellowOnion> haakon__, no help for -thread 0
[15:31] <haakon__> YellowOnion: http://mewiki.project357.com/wiki/X264_Settings#threads
[15:31] <haakon__> YellowOnion: Can you pastebin your complete command?
[15:33] <YellowOnion> haakon__, http://paste.pocoo.org/show/536202/
[15:33] <YellowOnion> comments might be a little wrong
[15:34] <berdario> Hello, I'm trying to play an rtp stream with ffmpeg (before trying to write a software to do it)
[15:34] <berdario> but I have a problem to get it working with ffplay
[15:34] <berdario> vlc works fine, but I read that vlc uses live555 for it's rtp client
[15:34] <berdario> I have an .sdp that describes the stream
[15:35] <berdario> but it complains that the data is invalid
[15:35] <berdario> increasing the verbosity doesn't yield further information
[15:35] <YellowOnion> haakon__, thing is I noticed this switching balancing problem with when running 3 instances of rubberband (2 threads per app) so I was thinking the Scheduler might be at fault
[15:36] <berdario> I don't know if it's possible to connect directly without the .sdp... I looked into the manual but I don't see some options I need
[15:37] <berdario> like the payload type: I have in fact read that ffmpeg is hardcoded to use payload type 96
[15:37] <YellowOnion> benpro, specifics or we can't help you, "it deosn't work" doesn't help us help you.
[15:37] <YellowOnion> berdario, , specifics or we can't help you, "it deosn't work" doesn't help us help you.
[15:37] <YellowOnion> sorry benpro
[15:37] <berdario> YellowOnion, what do you mean?
[15:37] <YellowOnion> berdario, error message?
[15:38] <berdario> YellowOnion, "the data is invalid" is the exact error message outputted by ffplay
[15:38] <berdario> I'll paste the whole output now
[15:38] <berdario> (ok, not actually the exact error message, 2 seconds and I'll paste it)
[15:39] <YellowOnion> berdario, oh whoops I missed the few comments that you said later sorry
[15:39] <YellowOnion> berdario, paste the stream URL as well
[15:40] <berdario> oh, ok... probably I should write fewer sentences, and longer... It's not the first time I have some problems communicating through irc :)
[15:40] <berdario> http://paste.pocoo.org/show/536205/
[15:40] <berdario> the stream is actually local
[15:40] <berdario> I can give you the dump I'm using to recreate it if needed
[15:41] <berdario> the point is, I'm not actually sure if what I'm planning to do is possible with ffmpeg
[15:41] <berdario> like I said, the payload type seems to be hardcoded... if that's the case I'll try to use directly some other library to receive rtp, and leave to ffmpeg only the decoding :)
[15:45] <berdario> I'm currently looking at libavformat/rtpdec.c but I never looked at the ffmpeg sources before :)
[15:46] <haakon__> YellowOnion: Thanks for the pastebin, see that threads 0 is correct, but unfortunately I do not know what might be the challenge here
[15:48] <YellowOnion> x264 is using 9 threads which seems correct
[16:00] <YellowOnion> haakon__, not sure why I'm piping from mplayer exactly I'm going to try dump the file and encode that
[16:04] <berdario> YellowOnion, ok, I found out that apparently, in september 2011 a private option was added to specify the payload type... do you have any more information on this?
[16:06] <haakon__> YellowOnion: Yeah I guess dumping and then encoding should free some resources
[16:06] <YellowOnion> berdario, find a tool that can inspect the .sdp file
[16:06] <Belial__> I am having problems converting a 3gp video into avi.  I've read different posted commands on websites but so far none of them work.  The one command that I got to work produced an avi with no sound.  What command in ffmpeg will convert a 3gp from a mobile phone into a working avi (with sound!)?
[16:07] <berdario> YellowOnion, an .sdp file is a plain text file... I have it open right now, and vlc parses it fine, any clue about some common problems with sdp files?
[16:08] <YellowOnion> Belial__, can you not just do ffmpeg -i file.3gp file.avi
[16:08] <Belial__> That apparently is too simple (I'll try it) - every command I found on websites were much more complex.  I'll let you know.
[16:09] <YellowOnion> Belial__, yeah there's a few settings to improve quality etc, but that should get some baseline working format
[16:10] <Belial__> YellowOnion: that worked.  Thanks.  I guess people posting the command string online must get paid by the character or something.
[16:10] <YellowOnion> heh
[16:10] <YellowOnion> Belial__, I would just be a bit careful on the quality though and size of the file
[16:12] <YellowOnion> Belial__, do you need .avi? you can get better quality compression ratio with a x264 stream in something like a .mkv
[16:12] <Belial__> YellowOnion: I want to send the vid to family and they use windows and I wanted something certain to work for them.
[16:13] <YellowOnion> Belial__, which version of windows?
[16:13] <Belial__> YellowOnion: Not sure, some are Windows 7 but some may be Vista
[16:16] <Belial__> YellowOnion: And here's another one.  I want to rotate the video clockwise 90 degrees.  I see a website with a simple command: 'ffmpeg -i input.avi -vf "transpose=1" output.avi' but naturally this command doesn't work.
[16:17] <YellowOnion> Belial__, that'll definitely play a x264 stream in a .mp4
[16:24] <YellowOnion> haakon__, well dumping file first didn't help
[16:24] <YellowOnion> default settings I get 11fps
[16:24] <YellowOnion> if I use 12threads I get 16-18fps
[16:26] <YellowOnion> Belial__, yeah that command should work. what's the error message?
[16:26] <Belial__> YellowOnion: Unrecognized option 'vf'
[16:27] <Belial__> YellowOnion: I rotated the video with mencoder and it doubled (almost) the size of the video.
[16:28] <YellowOnion> Belial__, after using ffmpeg?
[16:29] <Belial__> YellowOnion: the unrecognized option is ffmpeg and the video size doubled after rotating the original ffmpeg-produced video using mencoder.
[16:30] <YellowOnion> Belial__, yeah you don't want to reencode again I'm wondering why it thinks -vf is missing, can you copy paste the exact command you're using?
[16:30] <Belial__> YellowOnion: I would like to try a tighter/better compression video as you suggest but every single complex command string I've tried from other websites don't work (or produce errors about wrong bitrate or frame size).  How do I simply convert an avi to a tighter mp4 (with x264 stream)?
[16:31] <Belial__> YellowOnion: Sure...here it is: ffmpeg -i input.avi -vf "transpose=1" output.avi
[16:33] <YellowOnion> Belial__, I use ffmpeg -i file.ext -thread 0 -vprofile high -preset veryslow -x264opts level=3 -vf 'transpose=1' outfile.mp4
[16:34] <YellowOnion> Belial__, http://en.wikipedia.org/wiki/H.264/MPEG-4_AVC#Levels
[16:35] <YellowOnion> that's the only option that probably needs changing
[16:35] <Belial__> YellowOnion: Your command fails for me as well: unrecognized option 'thread'.  This is Mageia 1 linux with ffmpeg 0.6.4
[16:36] <YellowOnion> Belial__, sorry -threads
[16:38] <Belial__> YellowOnion: Thx but now new error: [NULL @ 0xbd6050]Unable to parse option value "high": undefined constant or missing ( followed by "Invalid value 'high' for option 'vprofile'".  Am i to assume I have a crippled ffmpeg?
[16:42] <YellowOnion> Belial__, there was a recent change I think where they removed a bunch of profiles and started using built in ones for x264
[16:44] <YellowOnion> Belial__, you on linux?
[16:44] <Belial__> YellowOnion: It appears that virtually all the options in your command string are defunct.  I remove each one in succession to see what message I get and every single option turns up "unknown option"
[16:44] <Belial__> YellowOnion: yes
[16:44] <YellowOnion> Belial__, some options require others I think
[16:45] <Belial__> YellowOnion: -vf is definitely defunct.  It always comes up as unrecognized.
[16:45] <YellowOnion> $ ls /usr/share/ffmpeg/ see if there's any libx264-high profiles
[16:46] <YellowOnion> Belial__, what's your distro?
[16:46] <Belial__> Mageia 1, a fork of Mandriva
[16:49] <Belial__> YellowOnion: I just did a quick conversion from avi to mp4 with mencoder and it worked but video size is identical and sound is delayed.  Cannot use mencoder and so far cannot use ffmpeg.
[16:56] <YellowOnion> Belial__, sorry lost internet, did you answer my question?
[16:58] <Belial__> YellowOnion: which question?  I am on linux - Mageia 1, a fork of Mandriva
[16:58] <YellowOnion> Belial__, you got your distro package of ffmpeg?
[16:58] <Belial__> YellowOnion: yes
[16:59] <YellowOnion> Belial__, try downloading x264
[17:00] <Belial__> YellowOnion: No libx264-high profiles.  Up to medium and then lossless
[17:00] <Belial__> YellowOnion: it is downloaded and installed
[17:02] <YellowOnion> Belial__, I assume you have mplayer?
[17:02] <Belial__> YellowOnion: yes
[17:04] <YellowOnion> Belial__, well you could try to re compile ffmpeg
[17:05] <YellowOnion> or you can decode then rotate with mencoder then encode with ffmpeg
[17:05] <Belial__> YellowOnion: Yeah...looking forward to that.  Haven't compiled much the last couple years because I inevitably run into a dependency hell.
[17:06] <YellowOnion> heh
[17:06] <Belial__> A straight convert from avi to mp4 in ffmpeg makes the same size video (double the size of the original unrotated avi).
[17:07] <YellowOnion> you were encoding a 4gp right?
[17:07] <Belial__> kdenlive is unstable as hell and crashes constantly so trying to edit down the converted video is impossible there.
[17:07] <YellowOnion> 3*
[17:07] <Belial__> YellowOnion: 3gp
[17:08] <YellowOnion> work with the original format
[17:08] <YellowOnion> each chain in the process destroys the quality
[17:09] <YellowOnion> Belial__, you probably want a format designed for editing
[17:11] <YellowOnion> Belial__, decoding frames in an editor can be a serious problem with formats like xvid and x264
[17:15] <berdario> YellowOnion, I'm quite sure that support for payload types has been added both to encoding and decoding
[17:16] <berdario> so, I think that the only problems lie to get ffmpeg to accept my sdp
[17:16] <berdario> do you know of any other alternative than doing a debug build and step through?
[17:18] <YellowOnion> berdario, not sure if it's a text file why not just pull the stream or what ever it is out of the text?
[17:18] <berdario> YellowOnion, an sdp contains the address of the server supplying the stream, plus some information on the video/audio codecs, timing and such
[17:19] <berdario> this is mine: http://paste.pocoo.org/show/536262/
[17:21] <YellowOnion> berdario, what does 99999 do?
[17:23] <berdario> "o" contains the originator and session identifier... I was under the assumption that besides "IP4 <ipaddress>" it wasn't really important
[17:23] <berdario> I'll look again at the spec
[17:24] <YellowOnion> perhaps the session ID has expired? I don't see a port specified anywhere
[17:24] <berdario> ok, it's an identifier... not really important since I'm testing on localhost
[17:24] <berdario> <sess-id> is a numeric string such that the tuple of <username>,
[17:24] <berdario>       <sess-id>, <nettype>, <addrtype>, and <unicast-address> forms a
[17:24] <berdario>       globally unique identifier for the session.  The method of
[17:24] <berdario>       <sess-id> allocation is up to the creating tool, but it has been
[17:24] <berdario>       suggested that a Network Time Protocol (NTP) format timestamp be
[17:24] <berdario>       used to ensure uniqueness
[17:24] <berdario> the port is 24104 (for video)
[17:25] <berdario> whoops, sorry... I pasted straight from the RFC... if it hadn't any hard newlines it wouldn't have been so messy
[17:26] <berdario> btw, ffmpeg doesn't even try to connect
[17:26] <YellowOnion> berdario, I like 80 char width limit personally
[17:26] <berdario> if I run the stream or not doesn't make any difference: it complains when reading the file
[17:27] <YellowOnion> hmm
[17:31] <berdario> uhm, I think that stepping through a debug build may be the fastet way to understand what's going wrong
[17:32] <berdario> since I've never done it (I used gdb sometimes, but that's it)... I'll look for some documentation
[17:33] <berdario> for further questions about debug builds maybe it's better off to ask in ffmpeg-devel ?
[17:34] <YellowOnion> yeah ask devel no idea why it's happening
[17:35] <YellowOnion> Belial__, report a bug to your distro, about the video filters being missing.
[18:35] <Mista_D> 0.9.1 ffprobe has no -show_frames option anymore. is there any way to extract video frames map for gop analysis?
[18:37] <dericed> Mista_D: Have you looked at -vf showinfo
[18:39] <Mista_D> dericed: same as `-i` by itself.
[18:39] <dericed> Mista_D: try `ffmpeg -i file -vf showinfo -f null -`
[18:43] <Mista_D> dericed: its a little slow.
[18:44] <dericed> Mista_D: it decodes the file so yeah
[18:45] <Mista_D> dericed: I don't need the entire frame decode, just the frame headers and extract frame type.
[18:45] <saste> Mista_D: -show_frames was recently added in ffmpeg master
[18:46] <saste> -show_frames was an option of ffprobe in sourceforge
[18:46] <dericed> saste: that's what i thought
[18:47] <Mista_D> saste: compiling rigth now. thanks!
[18:48] <Mista_D> dericed: thanks for the alternative, it actually has some additional data that I need as well.
[19:28] <terinjokes> I'm trying to -acodec copy to an RTMP server the following stream "Stream #0:1[0x1100]: Audio: aac ([15][0][0][0] / 0x000F), 48000 Hz, stereo, s16, 256 kb/s" but I get an error "[flv @ 0x7fc5f9024000] malformated aac bitstream, use -absf aac_adtstoasc av_interleaved_write_frame(): Operation not permitted"
[19:51] <Bombo> how does ffmpeg calculate the SAR? or is it a fixed value in the header somewhere? like DAR?
[19:53] <ayaka> does vdpau only can be used in  decode, not in encode?
[20:03] <Bombo> when i do "scale=640:ih*ow/sar/iw" i get 640x287 format, but when i use bc: "scale=640:455*640/(64/45)/710" (its 720x576, but with crop) i get echo "scale=2;455*640/(64/45)/710"|bc -> 288.83
[20:05] <Bombo> so it should be 289 if you round up
[20:06] <Bombo> i'm not sure if something is wrong here or i'm just missing something
[20:09] <saste> well actually the decimal part is just discarded when converting to int
[20:11] <Bombo> then it should be 288
[20:13] <Bombo> when i'm taking an image from the mpg, png, and resize it to correct aspect (16:9, it would be 1024x576 (anamorph)) remove the borders (crop) i get an image in 1014x455, and when i resize it with [x] keep aspect i get 640x287 too, so whats going wrong?
[20:24] <zap0> Bombo, whats the ratio of your crop?
[20:31] <Bombo> zap0: SAR before crop is 64:45 (720x576) i do crop top 60 bottom 61, left 4 right 6, not sure how to calculate the ratio then
[20:34] <cbreak> if you crop, you should always only crop to even numbers
[20:34] <zap0> for non-rgb that is requirement, but RGB too?
[20:35] <cbreak> no
[20:35] <cbreak> it's a requirement of video codecs (most have even more requirements)
[20:35] <cbreak> and the 4:2:0 or 4:2:2 color subsampling
[20:38] <Bombo> hmmmkay when i crop 60-60-4-6 i get 640x289
[20:58] <Bombo> so then ffmpeg adds something or subtracts when i crop odd crop numbers?
[21:02] <Bombo> its 455 with 61, so 455*640/(64/45)/710 == 288.83 and 453*640/(64/45)/710 == 287.56 so ffmpeg subtracts 2 pixels from the height hmmm
[21:08] <grimmace> does anyone know how to set the output video bitrate to the same as the input video bitrate. I can't use "-sameq" or "-vcodec copy" because some other parameters have to be different. thanks for any help
[00:00] --- Wed Jan 18 2012

More information about the Ffmpeg-devel-irc mailing list