[Ffmpeg-devel-irc] ffmpeg-devel.log.20120121

burek burek021 at gmail.com
Sun Jan 22 02:05:03 CET 2012

[00:34] <CIA-31> ffmpeg: 03Michael Niedermayer 07master * ra41687c2d6 10ffmpeg/libavutil/base64.c: 
[00:34] <CIA-31> ffmpeg: base64: add benchmark
[00:34] <CIA-31> ffmpeg: Signed-off-by: Michael Niedermayer <michaelni at gmx.at>
[00:34] <CIA-31> ffmpeg: 03Michael Niedermayer 07master * r112bca91b0 10ffmpeg/libavutil/base64.c: 
[00:34] <CIA-31> ffmpeg: base64: optimize av_base64_encode()
[00:34] <CIA-31> ffmpeg: This makes the code 2-3 times as fast
[00:34] <CIA-31> ffmpeg: Signed-off-by: Michael Niedermayer <michaelni at gmx.at>
[00:34] <CIA-31> ffmpeg: 03Michael Niedermayer 07master * rea4da94895 10ffmpeg/libavutil/base64.c: 
[00:34] <CIA-31> ffmpeg: base64: simplify end handling in av_base64_encode()
[00:34] <CIA-31> ffmpeg: Signed-off-by: Michael Niedermayer <michaelni at gmx.at>
[00:57] <CIA-31> ffmpeg: 03Michael Niedermayer 07master * r01084336b7 10ffmpeg/libavutil/base64.c: 
[00:57] <CIA-31> ffmpeg: base64: add a benchmark for a pure syntax check.
[00:57] <CIA-31> ffmpeg: Signed-off-by: Michael Niedermayer <michaelni at gmx.at>
[01:49] <CIA-31> ffmpeg: 03Anton Khirnov 07master * r8e1340abc3 10ffmpeg/avserver.c: avserver: fix build after the next bump.
[01:49] <CIA-31> ffmpeg: 03Dustin Brody 07master * rb89f8774f2 10ffmpeg/libavformat/avidec.c: 
[01:49] <CIA-31> ffmpeg: avidec: migrate last of lavf from FF_ER_* to AV_EF_*
[01:49] <CIA-31> ffmpeg: Signed-off-by: Anton Khirnov <anton at khirnov.net>
[01:49] <CIA-31> ffmpeg: 03Felipe Contreras 07master * rc3d5e290ca 10ffmpeg/libavcodec/arm/fft_init_arm.c: 
[01:49] <CIA-31> ffmpeg: ARM: fix build with FFT enabled and MDCT disabled
[01:49] <CIA-31> ffmpeg: Signed-off-by: Felipe Contreras <felipe.contreras at gmail.com>
[01:49] <CIA-31> ffmpeg: Signed-off-by: Mans Rullgard <mans at mansr.com>
[01:49] <CIA-31> ffmpeg: 03Michael Niedermayer 07master * r8f0768cc22 10ffmpeg/: (log message trimmed)
[01:49] <CIA-31> ffmpeg: Merge remote-tracking branch 'qatar/master'
[01:49] <CIA-31> ffmpeg: * qatar/master:
[01:49] <CIA-31> ffmpeg:  Add a tool that uses avio to read and write, doing a plain copy of data
[01:49] <CIA-31> ffmpeg:  ARM: fix build with FFT enabled and MDCT disabled
[01:49] <CIA-31> ffmpeg:  lavf: force single-threaded decoding in avformat_find_stream_info
[01:49] <CIA-31> ffmpeg:  avidec: migrate last of lavf from FF_ER_* to AV_EF_*
[01:49] <CIA-31> ffmpeg: 03Martin Storsjö 07master * r23e57d167a 10ffmpeg/ (libavformat/Makefile tools/aviocat.c): 
[01:49] <CIA-31> ffmpeg: Add a tool that uses avio to read and write, doing a plain copy of data
[01:49] <CIA-31> ffmpeg: It also optionally can throttle its operation to a particular
[01:49] <CIA-31> ffmpeg: speed, to simulate realtime writing.
[04:44] <CIA-31> ffmpeg: 03Michael Niedermayer 07master * r57822f0660 10ffmpeg/libavutil/base64.c: 
[04:44] <CIA-31> ffmpeg: base64: fix little typo
[04:44] <CIA-31> ffmpeg: Signed-off-by: Michael Niedermayer <michaelni at gmx.at>
[05:00] <piece3> Hiya all, has the matroska container for ffmpeg had bundelling subtitles implemented yet?
[05:22] <Compn> piece3 : you mean mkv embedded subtitle support ?
[05:22] <Compn> i dunno current sub support, theres been a lot of subtitle kerfuffle and i lost track
[05:22] <Compn> piece3: support for burning into video or remuxing or what?
[05:24] <piece3> yep, I mean muxing
[05:28] <piece3> Compn: I was trying to mux in x,y positioned subtitles from an RSTP feed laying down into a local mkv file, however even trying from a local file I was unable to add srt or ass subtitles following the man pages, so was unsure if support had been added yet, considering under the matroska section there is no mention of subtitles
[05:32] <Compn> what ffmpeg ver ?
[05:32] <Compn> michaelni : whats status of muxing subs in mkv ?
[05:32] <Compn> bcoudurier might also know
[05:33] <piece3> Compn: ffmpeg version 0.8.7
[05:33] <Compn> so old
[05:33] <Compn> so very very old
[05:34] <michaelni> for matroska, aurel would be best to ask also ubitux might know about subs
[05:34] <michaelni> iam not the mkv subs expert sadly ...
[05:35] <Compn> well i guess not too old, since its backported stuff
[05:35] <Compn> i remember a lot of flames to aurel about slow subtitle support ;\
[05:40] <piece3> Could upgrading to the latest version resolve the issues?, does aurel drop in most days?
[05:40] <CIA-31> ffmpeg: 03Michael Niedermayer 07master * rbdd739e91c 10ffmpeg/libavutil/base64.c: 
[05:40] <CIA-31> ffmpeg: base64: Only run benchmark when "-t" is specified.
[05:40] <CIA-31> ffmpeg: As the test is run during fate and the benchmark is useless for fate
[05:40] <CIA-31> ffmpeg: this very slightly speeds up fate. Its also consistent with the other
[05:40] <CIA-31> ffmpeg: tests.
[05:40] <CIA-31> ffmpeg: Signed-off-by: Michael Niedermayer <michaelni at gmx.at>
[05:40] <CIA-31> ffmpeg: 03Ray Simard 07master * r9ec39937f9 10ffmpeg/libavfilter/vf_deshake.c: (log message trimmed)
[05:40] <CIA-31> ffmpeg: deshake: variable used uninitialized
[05:40] <CIA-31> ffmpeg: Sometimes the scan finds nothing that qualifies for addition to
[05:40] <CIA-31> ffmpeg: the array and pos is zero after the loops. The code forces pos to
[05:40] <CIA-31> ffmpeg: 1 and the array is then processed as if it had one valid element in it,
[05:40] <CIA-31> ffmpeg: producing some amusing but not very useful results.
[05:40] <CIA-31> ffmpeg: I don't see the rationale for this. If pos is zero coming out of the
[05:40] <CIA-31> ffmpeg: 03Michael Niedermayer 07master * r99a42f3fa9 10ffmpeg/libavcodec/ (ac3_parser.c ac3dec.c): (log message trimmed)
[05:40] <CIA-31> ffmpeg: ac3dec: Move center&surround mix level tables to parser.
[05:40] <CIA-31> ffmpeg: That way all mix levels as exported by the parser
[05:41] <CIA-31> ffmpeg: will have the same meaning.
[05:41] <CIA-31> ffmpeg: Previously the 3bit center mix level for eac3 was
[05:41] <CIA-31> ffmpeg: used to index in a 4 entry table leading to out of array reads.
[05:41] <CIA-31> ffmpeg: this change removes the table and offsets the ac3 variable by 4
[05:42] <Compn> piece3 : erm, i havent seen aurel on irc in long time, you would do better to mail him i think
[05:42] <Compn> ubitux is here all the time tho
[05:42] <Compn> you can bug him here
[05:42] Action: Compn bugs ubitux
[05:45] <piece3> Excellent, thanks Compn, I'll try bugging ubitux when he's about
[05:59] <piece3> Ubitux: Are you about? and can I bug you?
[08:19] <ubitux> piece3: i won't be of much help unfortunately...
[08:20] <ubitux> subtitles are supported in matroska muxer afaik
[08:21] <ubitux> srt and ass at least
[08:22] <ubitux> but i'm not a mkv maintainer, and i didn't do much stuff on subtitles yet
[08:22] <ubitux> also, i have to run away for a while now...
[08:22] <piece3> Cheers, I was able to mux them in during post processing using mkvtoolnix, however I wanted to mux in, in real time
[08:23] <piece3> I'm going to have a look at another method, using smil instead, I'm having a look at the ffmpeg implementation now
[10:12] <OanaStratulat> michaelni: ping
[12:05] <CIA-31> ffmpeg: 03Reimar Döffinger 07master * r77b90f0cd0 10ffmpeg/ (configure tests/fate-valgrind.supp): 
[12:05] <CIA-31> ffmpeg: Add a --valgrind configure option.
[12:05] <CIA-31> ffmpeg: If specified runs "make fate" through valgrind using the
[12:05] <CIA-31> ffmpeg: given valgrind binary.
[12:05] <CIA-31> ffmpeg: Signed-off-by: Reimar Döffinger <Reimar.Doeffinger at gmx.de>
[12:05] <CIA-31> ffmpeg: 03Reimar Döffinger 07master * r8650d5faf9 10ffmpeg/libavutil/base64.c: 
[12:05] <CIA-31> ffmpeg: base64: more thorough decode tests.
[12:05] <CIA-31> ffmpeg: Signed-off-by: Reimar Döffinger <Reimar.Doeffinger at gmx.de>
[14:45] <CIA-31> ffmpeg: 03Stefano Sabatini 07master * ra9117c755e 10ffmpeg/libavfilter/ (vf_mp.c vsrc_mandelbrot.c): 
[14:45] <CIA-31> ffmpeg: lavfi: fix mp and mandelbrot descriptions to make them complete sentences
[14:45] <CIA-31> ffmpeg: This is consistent with the other filter descriptions.
[14:47] <OanaStratulat> can i use ffmpeg to transcode some video from an IP camera that is as a rtsp stream ?
[14:52] <CIA-31> ffmpeg: 03Reimar Döffinger 07master * rd41c824b23 10ffmpeg/configure: 
[14:52] <CIA-31> ffmpeg: Fix valgrind FATE for out-of-tree builds.
[14:52] <CIA-31> ffmpeg: Signed-off-by: Reimar Döffinger <Reimar.Doeffinger at gmx.de>
[15:02] <saste> OanaStratulat: rtsp should be supported, though i never used it, check protocols.texi docs
[16:14] <OanaStratulat> can someone guide me on how to configure ffserver using an ipcamera stream ?
[16:20] <durandal_1707> ffserver is unfortunately one big chunk of code nobody of devs cares for
[16:23] <OanaStratulat> all of my ipcameras work only on IE with activex plugin and i want to eliminate that
[16:26] <durandal_1707> ffserver is used for streaming not for receiving
[16:27] <durandal_1707> so elaborate more what ip camera does
[16:27] <OanaStratulat> i want to receive it with ffmpeg and then pass it to ffserver
[16:27] <OanaStratulat> can be done in this manner?
[16:27] <durandal_1707> you want to restream data from your camera?
[16:28] <OanaStratulat> yes
[16:28] <durandal_1707> well, you would first need to know in what container and codecs is data streamed from ip camera, is it raw?
[16:28] <OanaStratulat> no, it is h264
[16:28] <durandal_1707> what protocol and so on..
[16:29] <OanaStratulat> i can play it with ffplay
[16:29] <OanaStratulat> it is rtsp
[16:30] <durandal_1707> are you actually asking to watch that stream from another browser/OS?
[16:30] <OanaStratulat> yes that is right
[16:31] <durandal_1707> than ffserver is not needed
[16:31] <OanaStratulat> because if i want to watch it from another browser through the camers webserver i need some plugins and stuff like that
[16:31] <OanaStratulat> http://www.provideo.com.tw/MP%20Waterproof%20IP%20Camera_WC-117MP.htm
[16:31] <OanaStratulat> this is my camera
[16:32] <durandal_1707> i think some browsers use gstreamer for web multimedia: Web 5 come to mind
[16:32] <OanaStratulat> my target is IE but i want to watch the video from the camera in a webflash player something like that
[16:33] <OanaStratulat> when i searched about this matter i found http://www.daantje.nl/2007/05/07/convert-axis-webcam-stream-to-flash-swfflv/
[16:33] <durandal_1707> webflash - you mean macromedia flash crap and other stuff?
[16:34] <OanaStratulat> yes, my users use that. or in another easy way to be seen
[16:34] <OanaStratulat> or html 5 video
[16:34] <durandal_1707> there are plugins serverside and clientside for such stuff, but i'm not really in that area that much
[16:35] <durandal_1707> for ffserver transcoding rtsp you will need to have control over server
[16:36] <CIA-31> ffmpeg: 03Reimar Döffinger 07master * r523f676b51 10ffmpeg/libavutil/base64.c: 
[16:36] <CIA-31> ffmpeg: Use a full table for base64 decode.
[16:36] <CIA-31> ffmpeg: Also encodes error or end marker into table.
[16:36] <CIA-31> ffmpeg: About 20% faster.
[16:36] <CIA-31> ffmpeg: decode: 466491 -> 374139 decicycles
[16:36] <CIA-31> ffmpeg: syntax check: 236955 -> 161182 decicycles
[16:36] <CIA-31> ffmpeg: Signed-off-by: Reimar Döffinger <Reimar.Doeffinger at gmx.de>
[16:36] <CIA-31> ffmpeg: 03Reimar Döffinger 07master * rdef19c9036 10ffmpeg/libavutil/base64.c: 
[16:36] <CIA-31> ffmpeg: Unroll base64 decode loop.
[16:36] <CIA-31> ffmpeg: Around 50% faster.
[16:36] <CIA-31> ffmpeg: decode: 374139 -> 248852 decicycles
[16:36] <CIA-31> ffmpeg: syntax check: 236955 -> 123854 decicycles
[16:36] <CIA-31> ffmpeg: Signed-off-by: Reimar Döffinger <Reimar.Doeffinger at gmx.de>
[17:52] <michaelni> OanaStratulat, durandal_1707 it should be possible for ffmpeg to read a rtsp stream and push it to ffserver
[17:55] <OanaStratulat> michaelni: and how can i do that?
[17:59] <CIA-31> ffmpeg: 03Carl Eugen Hoyos 07master * r9e53f62be1 10ffmpeg/libavformat/isom.c: 
[17:59] <CIA-31> ffmpeg: Support decoding Avid DS Uncompressed (SUDS).
[17:59] <CIA-31> ffmpeg: Fixes ticket #934
[18:01] <michaelni> OanaStratulat, on the ffmpeg side you just use something like "" as output
[18:02] <michaelni> on the ffserver side you need to edit the ffserver.conf file
[18:02] <michaelni> i assume both ffmpeg & ffserver run on the same machine
[18:04] <michaelni> also as others have said this code path (ffmpeg->ffserver) needs a maintainer, it works last i tried but is far from bugfree
[20:25] <ubitux> michaelni: i made a quick patch to make use on libswr in af_aresample: http://blackhole.ubitux.fr/0001-lavfi-use-libswr-in-af_aresample.patch
[20:26] <ubitux> but i'm wondering if there is a need of flushing at some point
[20:27] <ubitux> i'm using "const int n_out = n_in * aresample->ratio;", but i'm wondering if there is no risk of needing a somehow different number of samples for some reason (approximation or sth)
[21:04] <ubitux> well, 'going to send it anyway
[21:06] <michaelni> ubitux, flushing is needed, sorry for my slow reaction was afk
[21:06] <michaelni> but its wrong as it is now and from a quick look your patch doesnt make it worse
[21:08] <michaelni> the code should implement request_frame() and pass it on and when this passon indicates the source is EOF then flush
[21:08] <ubitux> oh, too bad, just sent the patch
[21:08] <michaelni> :)
[21:08] <ubitux> ok
[21:09] <michaelni> the request_frame issue is independant of the patch anyway ...
[21:10] <ubitux> is there a risk of caching to much data in libswr if the number of output samples is not large enough?
[21:13] <michaelni> i dont think swr would have a problem with caching a few hunderead mb but i never tried
[21:13] <ubitux> ok
[21:14] <ubitux> another question: i noticed a small sample rate will make the init way slower
[21:14] <ubitux> swri_resample_init() gets very slow
[21:14] <ubitux> the "issue" is also present in the old audio api
[21:14] <ubitux> (same code i guess)
[21:15] <ubitux> anything that could be done to improve things?
[21:15] <michaelni> build_filter() probably
[21:15] <ubitux> yes
[21:15] <michaelni> look at the parameters to make sure they are sane
[21:15] <ubitux> maybe filter_size should be made configurable?
[21:15] <michaelni> yes
[21:16] <ubitux> factor=1.81406e-05 tap_count=882000 phase_count=1024 scale=32768 type=9
[21:17] <ubitux> the main difference with a "normal" call is the factor being too small
[21:18] <ubitux> oh and tap_count being to big.
[21:26] <michaelni> ubitux, my first guess would be that phase_count should be decreased when factor is very small
[21:29] <michaelni> maybe something like phase_count/factor ~ constant with phase_count being 2^x
[21:33] <ubitux> ok
[21:33] <ubitux> < michaelni> ubitux, the mp3 demuxer reads in fixed size amounts and only afterwards the parser splits into mp3 frames // what are you calling the parser here? (sorry, dumb question certainly)
[21:35] <ubitux> (btw, setting avioctx maxsize to -1 indeed fixes the warning)
[22:05] <michaelni> ubitux, the mpegaudio AVParser
[22:06] <ubitux> ok, thank you
[22:07] <ubitux> i'm still confused about the relationship between format/codec/codecparser
[22:07] <ubitux> i mean, format & codec i guess i get it, but the codecparser is a bit obscure
[22:08] <ubitux> anyway, 'going to investigate
[22:09] <nevcairiel> most parsers just take some random bitstream and try to find the frame start/end, some parsers also do a bit more and do header parsing of the data .. but thats about it
[22:13] <FedUs> Hello, I have some troubles with last git and/or ffmpeg-HEAD-9e53f62 - I always get exit 1 at ffserver.c
[22:15] <FedUs> gcc 4.6.2
[22:15] <ubitux> which line?
[22:16] <FedUs> main git, git://source.ffmpeg.org/ffmpeg.git
[22:17] <FedUs> Oh sorry, which line - a second
[22:18] <FedUs> I get warnings starting at ffserver.c:1479:32
[22:19] <FedUs> then ffserver.c:4224:17 , eventually I get ffserver.c:(.text.startup+0x1af7): undefined reference to `ffurl_write' and exit status 1.
[22:20] <ubitux> oh, it's a linking issue then...
[22:27] <ubitux> FedUs: can you share your ./configure options?
[22:28] <ubitux> i wonder if ffurl_* shouldn't be added to libavformat.v
[22:29] <ubitux> nevcairiel: i was wondering what calls what; thanks for the hint
[22:30] <nevcairiel> av_read_frame should call the demuxer and then call the parser, iirc
[22:33] <ubitux> ok so the demuxer split the stream in packets, and then the parser is a "second pass" before decoding?
[22:33] <ubitux> what is the purpose of splitting this?
[22:33] <nevcairiel> not every demuxer needs to know how to split h264 into frames
[22:33] <nevcairiel> mpegts for example doesnt really store stuff in "frames"
[22:34] <nevcairiel> mkv on the other hand stores everything neatly organized, the parsers usually dont get used (or only for header parsing)
[22:35] <FedUs> ./configure --prefix=/usr --bindir=/usr/bin --datadir=/usr/share/ffmpeg --incdir=/usr/include/ffmpeg --libdir=/usr/lib64 --mandir=/usr/share/man --arch=x86_64 --extra-cflags='-O2 -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -march=generic -fPIC' --enable-bzlib --enable-libcelt --enable-libdc1394 --enable-libdirac --enable-libfreetype --enable-libgsm --enable-libmp3lame --enable-frei0r --ena
[22:35] <FedUs> ble-libopenjpeg --enable-librtmp --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libfaac --enable-libvorbis --enable-libvpx --enable-libx264 --enable-libxvid --enable-x11grab --enable-avfilter --enable-postproc --enable-pthreads --disable-static --enable-shared --enable-gpl --disable-debug --shlibdir=/usr/lib64 --enable-runtime-cpudetect --enable-libopencore-amrnb --enable-libopencore-amrwb
[22:35] <FedUs> I've tried with fPIC too
[22:36] <ubitux> FedUs: removing --disable-static --enable-shared should fix your issue; also try adding ffurl_* in the globals ok libavformat.v and retry
[22:36] <FedUs> I did that?
[22:36] <FedUs> Right. Sorry.
[22:37] <ubitux> just a hotfix guess
[22:37] <ubitux> i didn't try
[22:37] <ubitux> nevcairiel: ok i see, thank you
[22:44] <ubitux> FedUs: i'll send a fix soon
[22:47] <FedUs> excellent - I tried removing --disable-static --enable-shared but still I get exit 1. I'll try with a minimal ./configure
[22:50] <ubitux> oh?
[22:55] <FedUs> I meant, excellent if you'll send a fix for this - I don't how to approach it exactly, I used the videolan git 'till December, maybe I have to review the build script too
[22:56] <ubitux> i'm trying to reproduce
[22:57] <FedUs> Now it worked. With ./configure --prefix=/usr --bindir=/usr/bin --datadir=/usr/share/ffmpeg --incdir=/usr/include/ffmpeg --libdir=/usr/lib64 --mandir=/usr/share/man --arch=x86_64 --extra-cflags='-O2 -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -march=native -mtune=native'
[22:57] <ubitux> adding --enable-shared to my build seems enough to reproduce the issue
[22:57] <nevcairiel> related? http://git.libav.org/?p=libav.git;a=commit;h=97e3f94b61abb4148bbd33eda1b2540ea4e7cbdf
[22:58] <FedUs> I'll try on my side to confirm
[22:58] <ubitux> nevcairiel: yes that's exactly that
[22:58] <ubitux> michaelni: i think a --enable-shared box would be welcome ;)
[22:58] <nevcairiel> will be fixed on next merge then, i guess. ;)
[23:00] <ubitux> yep :p
[23:07] <FedUs> yes, ./configure --prefix=/usr --bindir=/usr/bin --datadir=/usr/share/ffmpeg --incdir=/usr/include/ffmpeg --libdir=/usr/lib64 --mandir=/usr/share/man --arch=x86_64 --extra-cflags='-O2 -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -march=native -mtune=native' --enable-shared reproduce exactly the issue, I can confirm.
[23:10] <ubitux> a fix will be upstream in the next merge
[23:18] <michaelni> ubitux, you could add a --enable-shared fate box
[23:18] <michaelni> its MUCH faster without valgrind
[23:18] <michaelni> and with ccache
[23:19] <ubitux> can we have a build only box?
[23:19] <ubitux> and sure i was planning to add one
[23:19] <michaelni> :)
[23:19] <michaelni> and yes build only should do
[23:19] <michaelni> i guess with ccache it would take less than a minute
[23:19] <michaelni> per run
[23:20] <ubitux> yep
[23:20] <FedUs> I've tried re-adding the enables of the first configure (without --enable-shared --disable-static) and now it works. Probably I did something wrong the first time I tried removing them.
[23:21] <ubitux> btw, i'm having trouble with my box; i think it heats up too much
[23:21] <FedUs> Thank you very much for your accurate and prompt help
[23:21] <ubitux> FedUs: make distclean between your tests
[23:21] <CIA-31> ffmpeg: 03Martin Storsjö 07master * r6a73f3bbdf 10ffmpeg/tools/aviocat.c: 
[23:21] <CIA-31> ffmpeg: aviocat: Flush the output before closing
[23:21] <CIA-31> ffmpeg: Without this, the end of the file might not be transmitted/written.
[23:21] <CIA-31> ffmpeg: Signed-off-by: Martin Storsjö <martin at martin.st>
[23:21] <CIA-31> ffmpeg: 03John Brooks 07master * r9b6aafba6c 10ffmpeg/libavcodec/ (mpegvideo.c mpegvideo_common.h): (log message trimmed)
[23:21] <CIA-31> ffmpeg: mpegvideo: fix invalid memory access for small video dimensions
[23:21] <CIA-31> ffmpeg: When either video dimension is only one macroblock, subtractions
[23:21] <CIA-31> ffmpeg: based on v_edge_pos and the macroblock size may be negative. In
[23:21] <CIA-31> ffmpeg: that situation, an unsigned comparison isn't sufficent to test for
[23:21] <CIA-31> ffmpeg: MV overruns, because a limit of (unsigned)-1 will let any other
[23:21] <FedUs> yes, I did, but
[23:21] <CIA-31> ffmpeg: value pass.
[23:21] <CIA-31> ffmpeg: 03Martin Storsjö 07master * r5d95112d92 10ffmpeg/libavformat/movenc.h: (log message trimmed)
[23:21] <CIA-31> ffmpeg: movenc: Reorder entries in the MOVIentry struct, for tigheter packing
[23:21] <CIA-31> ffmpeg: Originally, sizeof(struct MOVIentry) was 48, after the reordering,
[23:21] <FedUs> who knows.
[23:21] <CIA-31> ffmpeg: it is 40 in my build configuration.
[23:21] <CIA-31> ffmpeg: When writing really long mov/mp4 files, this can make a difference
[23:21] <CIA-31> ffmpeg: - this saves a bit over 2 MB of memory per hour of video (down to
[23:21] <CIA-31> ffmpeg: 10.3 MB per hour from 12.3 MB per hour initially) for a video with
[23:21] <CIA-31> ffmpeg: 03Martin Storsjö 07master * r1f712e6a05 10ffmpeg/libavformat/rtsp.h: 
[23:21] <CIA-31> ffmpeg: rtsp: Remove extern declarations for variables that don't exist
[23:21] <CIA-31> ffmpeg: Signed-off-by: Martin Storsjö <martin at martin.st>
[23:21] <CIA-31> ffmpeg: 03Dustin Brody 07master * rf88949214c 10ffmpeg/libavcodec/options.c: 
[23:21] <CIA-31> ffmpeg: lavc: rename err_filter option to err_detect and document it
[23:21] <CIA-31> ffmpeg: Signed-off-by: Anton Khirnov <anton at khirnov.net>
[23:21] <ubitux> ok :)
[23:21] <CIA-31> ffmpeg: 03Dustin Brody 07master * rd2a0041c20 10ffmpeg/libavcodec/mpegaudiodec.c: 
[23:22] <michaelni> ubitux, what kind of box is that ?
[23:22] <ubitux> michaelni: cheap box :)
[23:22] <ubitux> i opened a ticket and going to see how things go
[23:22] <michaelni> put a fan in it :)
[23:22] <ubitux> well, i'm not hosting the box
[23:23] <ubitux> if things don't go better (i'm having 2 reboot per day now...), i'll check out a level up box :p
[23:27] <michaelni> 2 reboots a day is unacceptable no matter what price IMHO
[23:27] <ubitux> yes sure
[23:27] <michaelni> thats unless you signed a contract that says you are ok with that ;)
[23:27] <ubitux> i don't have enough time between reboots to get a full valgrind run :(
[23:28] <michaelni> is it a shared box ?
[23:28] <ubitux> no, i'm alone on it
[23:28] <michaelni> or dedicated ?
[23:29] <ubitux> dedicated, hard drive too
[23:29] <ubitux> but one single core cpu (a celeron..)
[23:29] <michaelni> maybe just some faulty component like ram chip ...
[23:29] <ubitux> possible yeah; as i said i opened a ticket and will see if they can get things better
[23:30] <ubitux> but i'll consider taking a less cheap box, i'd like to end the 1+ load average
[00:00] --- Sun Jan 22 2012

More information about the Ffmpeg-devel-irc mailing list