[Ffmpeg-devel-irc] ffmpeg.log.20120122

burek burek021 at gmail.com
Mon Jan 23 02:05:01 CET 2012

[01:20] <maujhsn> ubitux "It's been awhile...How are you?
[01:20] <ubitux> hi
[01:21] <ubitux> fine i guess...
[01:21] <maujhsn> Good
[01:21] <maujhsn> libfaad
[01:21] <maujhsn> What is it good for?
[01:23] <maujhsn> ubitux...Hard question isn't it?
[01:23] <ubitux> not useful anymore afaik
[01:24] <maujhsn> LjL Care to respond?
[01:24] <ubitux> since the native aac decoder is fine
[01:24] <ubitux> the wrapper was removed too iirc
[01:25] <maujhsn> ubitux While compling & enabling 14 switches "libfaad" did not enable!
[01:27] <ubitux> why do you want to enable it?
[01:28] <maujhsn> Transcoding with microsoft audio issues!
[01:28] <maujhsn> Rare however
[01:29] <maujhsn> Sorry don't have any real world instances with "libfaad"!
[01:30] <maujhsn> ubitux Perhaps I will leave it out all together!
[01:31] <ubitux> i don't understand your issue
[01:31] <ubitux> you're not specific enough, or i'm just totally braindead
[01:33] <maujhsn> ubitux Check this out: http://pastebin.com/S8avnBM0
[01:34] <ubitux> 01:23:54 <@ubitux> not useful anymore afaik
[01:34] <ubitux> just drop it
[01:35] <maujhsn> ubitux "libfaad" not useful? The rest of the configuration is sufficient?
[01:35] <ubitux> yes
[01:36] <ubitux> (--enable-zlib can be dropped too btw, it's implicit)
[01:36] <ubitux> maujhsn: 01:24:04 <@ubitux> since the native aac decoder is fine
[01:36] <ubitux> ffmpeg has a native aac decode support
[01:38] <maujhsn> ubitux "I learn something new with this stuff every week! Thanks to guys like yourself & Mavrik, & LjL!"
[01:40] <maujhsn> "Take Care Guys!"
[01:42] <maujhsn> LjL
[01:45] <maujhsn> "npviewer.bin" closed unexpectedly message flashes across my screen...any thoughts on the subject?
[02:06] <piercedwater> Can someone help me figure out why ffmpeg isn't using full cpu? Here is my command: ffmpeg -threads 4 -vcodec h264 -i  /media/spot/Halloween\ 2.mkv /media/spot/test.mp4
[02:08] <iive> shouldn't it be libx264 ?
[02:08] <piercedwater> i shows libx264 in -codecs, but it is still slow when i use it
[02:09] <piercedwater> actually
[02:09] <piercedwater> it is listed on -encoders
[02:09] <piercedwater> but is not found when i try it with -vcodec
[02:10] <piercedwater> Unknown decoder 'libx264'
[02:13] <JEEBsv> that's because you're setting it before the -i
[02:13] <JEEBsv> before the -i = for decoding
[02:13] <JEEBsv> after the -i = for encoding
[02:14] <piercedwater> ffmpeg -threads 4 -i /media/spot/Halloween\ 2.mkv /media/spot/test.mp4 -vcodec libx264
[02:14] <piercedwater> still ~ 20 fps
[02:14] <piercedwater> i get >100 with handbrakecli in linux
[02:15] <piercedwater> hmm
[02:15] <JEEBsv> set a preset?
[02:15] <JEEBsv> preset sets the defaults that control speed VS compression
[02:15] <JEEBsv> default is 'medium'
[02:16] <JEEBsv> http://mewiki.project357.com/wiki/X264_Settings#preset
[02:22] <piercedwater> Unrecognized option 'preset'
[02:22] <piercedwater> workswith vpreset
[02:22] <piercedwater> but still slow
[02:25] <JEEBsv> then you have an old ffmpeg
[02:25] <JEEBsv> and/or libx264
[02:27] <JEEBsv> anyways, go and check what handbrakecli is doing, check that your ffmpeg/libx264 isn't any older than that handbrakecli you have and try to match preset-wise, and maybe with some other settings :P
[02:27] <JEEBsv> after all
[02:27] <JEEBsv> handbrake on the background is using ffmpeg
[02:27] <JEEBsv> and libx264 via it
[02:27] <piercedwater> k
[02:30] <piercedwater> ty
[02:41] <CodeOfficer> I took a widescreen vid on my iphone4s that I want to shrink down a bit, when i run ffmpeg with these options its not keeping the aspect ratio. thoughts?
[02:41] <CodeOfficer> ffmpeg -i IMG_0314.MOV -s 640x480 -aspect 16:9 IMG_0314-640x480-16-9.MOV
[02:42] <CodeOfficer> oh, duh
[02:42] <CodeOfficer> wow i need sleep
[02:42] <CodeOfficer> pretend i wasnt here
[03:12] <Shazzamy> I have a .TOD video file that came from a JVC Everio camcorder. I'm trying to find the best settings to use that will provide the best quality file conversion. Mac OS X 10.6.8, ffmpegX (ffmpegX v0.0.9y Jan 26, 2008)
[05:18] <beastwick987> Could anyone assist me? I installed FFMPEG from the   debian multimedia repositories, but it appears it  cannot  find my libx264 parameter (even though this  version is  compiled with x264 support). I have  libx264-dev  installed. I am running Debian SID. I  have read a lot of  documentation, at this point I  am lost.
[06:09] <shevy> Hmm. When I have an .avi file, I want to add an audio track to it
[06:09] <shevy> that audio track is from a foo.mp3 file
[06:15] <shevy> how can I list all available options to -vcodec
[06:19] <composite> anyone know how to change the speed of an mp4 and make a new file?
[06:37] <Kuukunen> shevy: -codecs
[06:42] <shevy> thanks Kuukunen works nicely
[12:14] <rgl> is tehre a way to pipe multiple images into stdin and have a webm video file on the output?
[12:14] <Mavrik> hmm
[12:14] <Mavrik> not likely
[12:14] <Mavrik> maybe you should try "mjpeg" as input... but I doubt it's possible
[12:15] <cbreak> if ffmpeg can't do it natively, mplayer can read image sequences and output it in a format ffmpeg can likely read
[12:15] <cbreak> (mf://\*.png -vo yuv4mpeg ...)
[12:16] <Mavrik> ffmpeg can read image files
[12:16] <Mavrik> but not piped from something else
[12:16] <cbreak> well, then you can use ffmpeg to convert it into something that can be piped :)
[12:17] <Mavrik> I'm figuring he doesn't have files if he's asking that question ;)
[12:17] <cbreak> depending on the format of the image data, it might be easy to just write yuv4mpeg output directly
[12:18] <cbreak> in a program I worked on recently I use ffmpeg internally to pipe raw audio/video into a different process
[12:18] <cbreak> works nicely
[12:19] <cbreak> but it was a pain to get working nicely :)
[12:21] <rgl> humm will look at yuv4mpeg
[12:22] <cbreak> as the name says, it uses yuv and not rgb, not sure if there's a way to change that.
[12:22] <cbreak> or the color subsampling
[16:09] <hallowicked> Could somebody tell me is it possible to change the way the logfile prints or add TEXT to it
[16:10] <Mavrik-> logfile?
[16:10] <hallowicked> yes
[16:10] <hallowicked> like normally it would print like
[16:11] <hallowicked> frame=56265 fps= 49 q=30.0 size=  365582kB time=00:31:15.97 bitrate=1596.4kbits/s
[16:11] <hallowicked> can i make that say text instead of just this
[16:11] <Mavrik> huh
[16:11] <Mavrik> as far as I know that's hardcoded
[16:12] <hallowicked> ok like this
[16:12] <hallowicked> WWE.Vengeance.2006.DVDRip.x264 (res:576x432 crf:19.0 dur:35:00 fps:29.970 SIZE:445.83MB br:1490 Kbit/s)
[16:12] <hallowicked> possible to make the log print like that
[16:12] <Mavrik> no
[16:12] <Mavrik> you'll have to pipe output to some script that can reformat it
[16:12] <hallowicked> hmm could u point me into a direction to doing that
[16:19] <hallowicked> Mavrik,  got nething bud?
[16:19] <Mavrik> well, that depends on your OS, you're knowledge of scripting or programming languages etc.
[16:19] <hallowicked> windows is os
[16:19] <hallowicked> and my knowlege is very small but if sent to the right track i can figure it out with google i think
[16:20] <Mavrik> hmm
[16:20] <Mavrik> hallowicked, you'll have to find out how to read stderr output of ffmpeg and reformat it
[16:20] <Mavrik> don't know much about windows scripting/programming
[16:20] <Mavrik> you can also use something like python/etc to start ffmpeg and grab it's output
[16:20] <Mavrik> but... it's probably more work than it's worth
[16:20] <hallowicked> right
[16:21] <hallowicked> what about ina batch file if i put text will that change anything
[16:21] <hallowicked> right now im exactly getting
[16:21] <hallowicked> frame=85412 fps= 49 q=28.0 size=  552319kB time=00:47:28.51 bitrate=1588.4kbits/s
[16:21] <hallowicked> which is great after a week of work to get that sent to my irc channel
[16:21] <hallowicked> WWE.Vengeance.2006.DVDRip.x264 (res:576x432 crf:19.0 dur:35:00 fps:29.970 SIZE:445.83MB br:1490 Kbit/s)
[16:21] <hallowicked> that is ideal
[16:49] <omeone> Is anyone there?
[16:52] <omeone> please(
[17:05] <omeone> Nagy, are you alive?
[17:09] <omeone> I understand. It's a Sunday morning in USA
[17:19] <Nagy> I'm alive
[17:22] <newl> whew
[17:25] <omeone> ops...
[17:26] <nadav> Hi
[17:26] <omeone> I have problem: I use OpenCV to write videos...
[17:26] <nadav> Any1 has experiance with Compiling bambuser ffmeg on an Android device
[17:26] <nadav> ( using windows OS )
[17:27] <omeone> but when I try to write video to named pipe, I get another result
[17:27] <newl> nadav: have you tried mingw (or cygwin) environment>
[17:28] <nadav> yup, I am using cygdrive
[17:28] <nadav> I mean cygwin
[17:28] <nadav> I get "arm-linux-androideabi-gcc is unable to create an executable file"
[17:29] <nadav> "C compiler test failed"
[17:29] <newl> you probably need all the rest not just the gcc - install mingw it seems to be superior for this kind of thing
[17:30] <omeone> I already posted my problem here: http://stackoverflow.com/q/8952997/1161481
[17:30] <omeone> As I know OpenCV uses ffmpeg to read/write videos, wright?
[17:30] <nadav> using processmonitor I can C that there is no path mis-match, all env vars seem 2 B ok... ( as far as for the filesys hierarchy )
[17:31] <nadav> AFAIK, OpenCV is independent of ffmpeg, OpenCV is for machine vision kind of stuff while ffmpeg is more of a compression/streaming lib
[17:32] <omeone> but OpenCV can't write videos without ffmpeg...
[17:33] <nadav> correct, if U want to encode video ffmpeg isyour friend
[17:34] <nadav> if U want machine vision, eg. text extraction, no need for ffmpeg, only OpenCV
[17:34] <omeone> you haven't seen my link http://stackoverflow.com/q/8952997/1161481
[17:35] <newl> that opencv must really eat up cpu
[17:36] <omeone> As I know, OpenCV uses ffmepg to write videos. When I'm trying to write video in a named pipe it getting corrupted (sorry for English)
[17:37] <nadav> write the file to the disk and have apache read it from the disk
[17:37] <nadav> R U using Linux ?
[17:37] <omeone> yep
[17:37] <omeone> I need an-fly upload
[17:37] <omeone> *on fly
[17:38] <nadav> I am more of the windows guy though I know it is possible with Apache
[17:40] <omeone> Maybe, ffmpeg encodes video in a different way for named pipes???
[17:43] <omeone> Or ffmpeg rewrites some data which has been written (named pipes don't allow that)
[17:44] <nadav> ffmpeg get a raw video image and encodes it to whatever format U want
[17:45] <omeone> OpenCV only allows me to select a codec...
[17:46] <omeone> next interesting thing: in a "corrupted" video opened in hex-editor I can see this:"Lavf53.3.0"
[20:18] <mape> Hi, is there any way of dumping a series of frames into images in multiple formats while making sure they have the same %d ? Ie making one thumb and one full size.
[20:20] <Mavrik> mape, try specifying several outputs
[20:21] <mape> Mavrik: won't adding more -s overwrite the previous one?
[20:21] <Mavrik> -s?
[20:21] <Mavrik> -s seeks the input
[20:22] <mape> -s sets the size?
[20:22] <Mavrik> er, sorry
[20:22] <Mavrik> saw -ss -_-
[20:22] <Mavrik> mape, basically you have to do something like
[20:23] <Mavrik> ffmpeg -i <input> -codec:v <whatever> -vf scale=320:240 output1.jpg -codec:v <whatever2> -vf scale=640:480 output2.jpg
[20:23] <Mavrik> you need to repeat the whole encoding setup after the first output to define a second output
[20:23] <mape> hmm k
[20:23] <Mavrik> I'm not sure if it works with images though :)
[20:25] <mape> it does seem to work as in it is outputting two files with different sizes but the % doesn't seem to match.
[20:26] <mape> or that might just be me missing -r..
[20:26] <mape> Indeed it was, Mavrik thanks for your help :)
[20:27] <Mavrik> ^^ np
[20:47] <iiu7> Trying to convert from AAC2 to what would work, but I keep getting this error whether I'm trying AC3, MP3 or something else. http://pastebin.com/zcmA3nQE
[20:47] <iiu7> What's the deal with that?
[20:48] <Mavrik> usually the command line helps
[20:49] <Mavrik> it seems timestamps on input (or output?) are wrong
[20:51] <iiu7> ffmpeg -i foo.mkv -map 0:0 -vcodec copy -acodec ac3 bar.mkv
[20:53] <iiu7> I get the same error if I use -acodec copy
[20:53] <Mavrik> hmm, that shouldn't happen really
[20:54] <Mavrik> which ffmpeg version?
[20:54] <iiu7> ffmpeg version git-2012-01-02-0af34c4
[20:55] <iiu7> I build it about a month ago.
[20:56] <iiu7> The file I have has x264 as video, but then it has 2 audio streams 1 is ac3 and 2 is aac2, I just need to remove the second audio stream hence the "-acodec copy" for -map 0:1.
[20:56] <Mavrik> I suggest you try to find out which stream confuses the muxer and try to reencode it
[20:57] <iiu7> How do I do that?
[20:58] <iiu7> I get the "in stream 0: 83 >= 42" error, but does that even make sense?
[20:59] <Mavrik> iiu7, try your command with -vn
[21:00] <iiu7> Disabling the video with "-vn" works!
[21:00] <Mavrik> hm
[21:01] <Mavrik> if you try to reencode the video does it fix?
[21:02] <iiu7> How do I do that?
[21:06] <iiu7> If I use " ffmpeg -i foo.mkv -map 0:0 -vcodec libx264 -acodec ac3 bar.mkv" and just re-encode with x264, then it works, but I don't know if that's actually the same as "copy", or if it is then again compressing using x264.
[21:26] <leuhmanu> hello
[21:26] <leuhmanu> somebody for an strange ffmpeg -f image2 issue ?
[21:30] <leuhmanu> I have make an ugly script to convert all motion capture in a video http://paste.pocoo.org/show/538909/
[21:30] <leuhmanu> It works but sometime I get : captures/Sunday-S04//h34-%05d.jpg: No such file or directory
[21:31] <leuhmanu> It should be captures/Sunday-S04//h34-%05d.jpg: No such file or directory
[21:31] <leuhmanu> oups
[21:32] <leuhmanu> it should be ../../**h34-%05d.jpg
[21:32] <leuhmanu> Any ideas ?
[21:36] <leuhmanu> Or maybe there is an other way to do it ?
[21:38] <relaxed> leuhmanu: the problem is your script and not ffmpeg
[21:39] <leuhmanu> my script ? and you know why ?
[21:40] <leuhmanu> date are ok in the tmp file
[21:40] <leuhmanu> and it's ok if I comment ffmpeg and add an echo
[21:42] <newl> leuhmanu: it is always the script
[21:42] <leuhmanu> but where ? :(
[21:43] <relaxed> leuhmanu: From looking at the script it appears you're new to bash scripting. Reading this should help: http://mywiki.wooledge.org/BashGuide
[21:48] <newl> leuhmanu: what is the url to the pastebin
[21:48] <leuhmanu> I had no external resource when I did that ...
[21:48] <leuhmanu> http://paste.pocoo.org/show/538909/
[21:49] <leuhmanu> but thanks I will look again the basic
[21:50] <newl> you don't need to save the results of the grep of the one file to a tmp file and ...
[21:51] <leuhmanu> yes indeed, but witout google :)
[21:51] <newl> maybe say what you want to do - that script was obviously made without any external input ;)
[21:51] <leuhmanu> in fact I have lot a picture in a folder
[21:54] <leuhmanu> like 13h27-00001.jpg ... 13h27-00010.jpg    15h23-00001.jpg ... 15h23-00010.jpg etc
[21:54] <leuhmanu> and I wanted to make a video of each **h**
[21:55] <leuhmanu> and one of all the picture
[22:06] <newl> lc=`ls *-00001.jpg`
[22:06] <newl> echo $lc
[22:09] <newl> use basename to get the $b
[22:09] <newl> ffmpeg -y -r 15 -f image2 -i $lc $b.avi
[22:11] <newl> you 'done < .... '  is a heredoc and is <<< not just <   btw
[22:16] <leuhmanu> mhhh
[22:16] <leuhmanu> thanks I will look :)
[22:16] <mape> Is there any way of getting ffmpeg to produces as high quality gif animations as 'convert'? Seems pix_fmt rgb24 makes them look horrid
[22:19] <newl> leuhmanu: looks like you want all the *-00001.jpg in one 1.avi? ...... *-00010.jpg 10.avi ??
[22:19] <relaxed> mape: I don't think so.
[22:19] <mape> Ok
[22:20] <mape> Too bad, convert does a good job but takes forever
[22:21] <leuhmanu> newl: no, all .jpg in one .avi and for each xx.xx another one
[22:21] <leuhmanu> but I have found a way with mencoder for the first part
[22:25] <newl> in your script you are only grepping for 00001.jpg
[22:25] <leuhmanu> yes and then is use the %05d
[22:25] <newl> if you want . pastebin the ls of the files you want in each avi - i'm kinda confused
[22:27] <newl> i think i get what you want    get each xxhxx   and then make avi of each
[22:28] <newl> each xxhxx can be 00001 -> 000010
[22:31] <newl> more for ya for i in *-00001.jpg; do
[22:31] <newl> that will get the xxhxx  so you won't need the tmpfile
[22:33] <leuhmanu> hum now it's work
[22:33] <leuhmanu> with the same script as before but with change
[22:34] <leuhmanu> http://paste.pocoo.org/show/538955/
[22:34] <newl> <<<  :)
[22:34] <leuhmanu> nop :)
[22:34] <leuhmanu> anymay thank a lot
[22:35] <leuhmanu> but yes indeed I remember now the <<< versus < :/
[22:36] <leuhmanu> have a nice night/day, bye
[22:47] <b_jonas> Can you help me figure out how to use -map or something? I have five input files, and I want to concatenate one audio track from each like 0.1,1.1,2.1,3.2,4.1 to a single audio file. All five input files have two audio tracks.
[22:48] <b_jonas> I can't figure out how to make ffmpeg encode more than one track.
[00:00] --- Mon Jan 23 2012

More information about the Ffmpeg-devel-irc mailing list