[Ffmpeg-devel-irc] ffmpeg.log.20120123

burek burek021 at gmail.com
Tue Jan 24 02:05:02 CET 2012

[00:02] <Ledm> Hi what is the command to convert ogm to other vídeo format?
[00:06] <Ledm> Thanx
[00:37] <netproteus> hi, hope someone can help. for some .mov files I've got the std:error output of ffmpeg is showing "Stream #0.1(eng): Video: h264 (Main), yuv420p, 596x842"  but the output from ffprobe is showing width=608, height=848
[00:37] <netproteus> any idea why/how this could be happening
[00:38] <cbreak> h264 only supports image dimensions that are a multiple of 16
[00:38] <cbreak> if you use something else, it'll probably pad internally
[00:38] <netproteus> ah
[00:39] <cbreak> incidentally, the next bigger multiple of 16 of the small dimension is the big dimension
[00:39] <cbreak> guess who ever made your movie was a noob :)
[00:39] <cbreak> or simply didn't care
[00:40] <netproteus> I suspect both
[00:41] <netproteus> worse is that the actual pixel data is 595x841 and whatever he has used to make the movie has stuck a white row and colum of pixels to fill in
[00:42] <cbreak> uneven widths are bad
[00:42] <cbreak> heights too
[00:42] <cbreak> with yuv420
[00:42] <netproteus> yeah, I need to go back and slap him
[00:42] <cbreak> since for every four pixel, you will get 4 luminance data points (4 grey pixel)
[00:43] <cbreak> but only one big color pixel
[00:56] <durandal_1707> hot to remove complete metadata when transcoding with -map_metadata?
[01:11] <apoc> i'm using libvorbis, I've read that oggenc's -q (0 ... 10) is mapped  in ffmpeg: -aq (0 ... 100) is this true? and whats with -q -1 and -2 is it -aq -10/-20?
[02:53] <Moult> i have a 1200x500px .avi video file. i'd like to convert it such that i can burn it onto a vcd and play on a tv. the problem is that using -target ntsc-vcd does not preserve the quality, and stretching will occur due to 1200x500 not being the correct aspect ratio. how do i keep the aspect ratio the same and just add black padding as well as preserve the quality when converting?
[04:09] <relaxed> Moult: -target ntsc-vcd -vf scale=720:-1 -qscale 3
[04:10] <relaxed> you don't have a dvd player?
[04:11] <Moult> relaxed: i do have a dvd player, but this is just a 60mb file, so i thought i wouldn't need to waste an entire dvd
[04:11] <Moult> relaxed: actually, if dvd gives me better quality, then yes, i really do want a dvd copy :D
[04:12] <Moult> relaxed: i read online that vcd was something like 350px width, if i'm reading your command right, it does 720px width, what am i misunderstanding? (video newbie)
[04:12] <relaxed> then use -target ntsc-dvd, you might be able to burn udf to a regular cd
[04:12] <relaxed> don't use vcd
[04:14] <Moult> relaxed: ok :)
[04:14] <relaxed> do you have a bluray player?
[04:14] <Moult> relaxed: so if i wanted to do the exact same thing as my original question except for dvd format and quality, so i just take your command and replace ntsc-vcd with ntsc-dvd?
[04:14] <relaxed> if so, avchd is what you want.
[04:14] <Moult> relaxed: no, don't have a bluray player
[04:15] <relaxed> Moult: yes to your question
[04:16] <Moult> relaxed: ah, awesome, so was the scale 720 inappropriate for vcd then?
[04:17] <Moult> relaxed: also, i don't see anythiing in your command that would prevent scaling by inserting black padding bars, am i missing something?
[04:18] <relaxed> scale=720:-1,pad=720:480:(ow-iw)/2:(oh-ih)/2
[04:19] <Moult> relaxed: ow and iw are variables, or do i have to replace ow with whatever dvd uses and iw with 1200 and so on?
[04:20] <relaxed> they are but you don't need to change anything.
[04:21] <Moult> relaxed: ok, let me try
[04:22] <Moult> relaxed: does this look ok? ffmpeg -i 1900-2500.avi -target ntsc-dvd -vf scale=720:-1,pad=720:480:(ow-iw)/2:(oh-ih)/2 output.mpg
[04:23] <Moult> relaxed: (unexpected token '(' )
[04:23] <relaxed> -vf 'scale=720:-1,pad=720:480:(ow-iw)/2:(oh-ih)/2'
[04:23] <relaxed> don't forget -qscale 3
[04:25] <Moult> relaxed: ok running ffmpeg -i 1900-2500.avi -target ntsc-dvd -vf 'scale=720:-1,pad=720:480:(ow-iw)/2:(oh-ih)/2' -qscale 3 output.mpg
[04:25] <Moult> relaxed: hopefully it works out fine :) (thanks very much for the handholding)
[04:26] <relaxed> you're welcome
[04:26] <Moult> relaxed: hmm, still seems a little bit stretched vertically - 1200x500 --> 720:480
[04:27] <Moult> relaxed: it needs 90px top and bottom black paddings
[04:27] <Moult> (i think)
[04:34] <Moult> relaxed: also, i'm slightly confused here, the padding (ow-iw)/2 should be 0, because there should  be no horizontal padding, but (oh-ih)/2 should be 90, as if 1200-->720, then 500-->300, so 480-300/2 = 90, but if i replace (oh-ih)/2 with 90, it gives me a input area not within padded area error
[04:37] <relaxed> yes (ow-iw)/2 = 0
[04:39] <relaxed> why do you need to change the padding at all?
[04:39] <relaxed> ntsc dvds are 720X480
[04:39] <Moult> relaxed: because the aspect ratio of the original, 1200x500 is not the same as ntsc-dvd's aspect ratio, 720x480, so in order to prevent vertical stretching, i need to add a vertical padding, yes?
[04:40] <relaxed> pastebin.com your command and all output
[04:40] <relaxed> it's a verb
[04:42] <Moult> relaxed: http://pastebin.com/aL7ug1E2
[04:44] <relaxed> did (oh-ih)/2 work?
[04:44] <Moult> relaxed: it worked, but there is vertical stretching
[04:44] <relaxed> so? it has zero to do with padding
[04:45] <relaxed> and if (oh-ih)/2 = 90 then your command wouldn't fail
[04:45] <Moult> relaxed: yes, which is why i was confused
[04:45] <Moult> relaxed: i thought if i added vertical padding, it wouldn't be vertically stretched?
[04:46] <relaxed> try -vf 'scale=720:-1,pad=720:480:(ow-iw)/2:(oh-ih)/2,setdar=16:9'
[04:47] <relaxed> dvds are either 4:3 or 16:9
[04:47] <Moult> relaxed: ok - just tried - works fine, but now extremely stretched - much, much more than before
[04:48] <relaxed> pastebin the output
[04:48] <Moult> relaxed: http://pastebin.com/KJVkvkdz
[04:52] <relaxed> -vf 'scale=720:356,pad=720:480:(ow-iw)/2:(oh-ih)/2,setdar=16:9'
[04:52] <Moult> relaxed: the input file is 1200x500, which is not 4:3 or 16:9. it is closer to 16:9 though.
[04:53] <relaxed> is that good?
[04:53] <Moult> relaxed: ahh, perfect!
[04:53] <relaxed> yay
[04:53] <Moult> relaxed: thank you very much!
[04:53] <Moult> now time to try burning it to a dvd and testing on the tv :)
[05:16] <Moult> relaxed: looks _absolutely_ perfect! thank you very much!
[05:18] <relaxed> you're welcome
[07:48] <Eren> I'm extracting sound from *.flv. However, I need to get the sound between 01:49:03 - 01:51:40
[07:49] <Eren> is there option that seeks only these interval?
[07:55] <Eren> solved with -ss and -t parameters
[12:33] <likewise> I would like to vertically upscale a video from 1920x540 to 1920x1080 using line doubling, without filtering. How would I do that on the ffmpeg CLI?
[13:43] <ayaka> does vdpau can only be uesd in decode or both encode?
[13:47] <sacarasc> Just decoding.
[13:49] <ayaka> sacarasc, have you see my pasted in mplayer?
[13:49] <ayaka> then dxva can be uesd both decoding and encoding?
[13:49] <sacarasc> Yes, and I don't know what's wrong.
[13:51] <ayaka> sacarasc, maybe it's ffmpeg's problem,becuase mplayer use ffmpeg code
[13:51] <iive> what's the problem?
[13:52] <ayaka> http://pastebin.com/TixUJgt8
[13:52] <ayaka> sacarasc, only this anime can't work,the other h264 work both 180p and not
[13:52] <ayaka> 1080P
[13:54] <iive> vdpau doesn't work for some anime?
[13:55] <ayaka> iive, yes,but use normal h264ffmpeg it works,and in ms,I think I use old ffmpeg lib by potplayer(not inline,I use extra code copiled by myself)it works with vdpau
[13:56] <ayaka> If need,I can send it to you but it's a little big 1.7G
[13:56] <iive> i don't have nvidia card, so it is useless to me.
[13:57] <JEEB> lol potplayer
[13:57] <iive> i assume that the software decoding does work?
[13:59] <JEEB> anyways, unless someone has failed completely if it's 8bit H.264 it should work with the chip, no idea of the VDPAU and driver versions etc. that can have an effect on it all on *nix
[13:59] <ayaka> iive, I change code decoder in potplayer,and ffmpeg software decoding  really works in linux
[14:00] <ayaka> JEEB, the potplayer is used in ms,in my memories it use ffmpeg 6.0,it can see it cpu,without dxva it will be 80%,using it only 5%
[14:01] <JEEB> sense, you are making not
[14:01] Action: JEEB goes take some tea
[14:01] <iive> ayaka:  there are profiles and levels in h264 that indicate how fast hardware you need to decode the stream. some anime groups set them higher than needed.
[14:02] <JEEB> and even then nvidia's hardware should cope with it if it's hardware that can be used with CUVID/VDPAU (unless it's >8bit H.264)
[14:02] <ayaka> iive, I know that,but how to change it?
[14:02] <JEEB> just noting it here
[14:02] <JEEB> :3
[14:02] <iive> ayaka: sorry no idea
[14:03] <ayaka> in fact because of language barried,I can't fully understand what you said,but it may be hardware problem?
[14:07] <ayaka> shall I use vdpauinfo to paste my hardware?
[14:14] <ayaka> http://pastebin.com/SD3H0tMY
[14:15] <ayaka> but another thing I should said vdpau become unstable in recent update
[14:30] <ayaka> sacarasc, iive, JEEB thank you
[15:34] <ultramantis> is there some kinda issue with ffmpeg as to when when i use the git i cant compile it right
[15:35] <ultramantis> libfaac not found   librtmp not found
[15:35] <ultramantis> libvo_aacenc  not found
[16:40] <ultramantis> JEEB,  u here bud
[16:52] <likewise> these external deps?
[16:52] <sacarasc> ultramantis: If you want to use external libraries, you have to install them first.
[16:53] <ultramantis> sacarasc,  like libx264  i need to install x264 right
[16:53] <ultramantis> i did that
[16:54] <sacarasc> But you seem to have not done it for libvo aacenc, librtmp and faac.
[16:54] <ultramantis> right
[16:54] <ultramantis> but im getting
[16:54] <ultramantis> ERROR: libx264 not found
[16:55] <sacarasc> Did you install the latest git x264 and uninstall any version you had before?
[16:55] <ultramantis> yep
[16:55] <ultramantis> should i configure it some way
[16:56] <ultramantis> maybe i didnt configure it correct
[16:56] <sacarasc> What distro are you using?
[16:56] <ultramantis> cgywin
[16:56] <sacarasc> Oh.
[16:56] <sacarasc> Then I haven't a clue.
[16:56] <ultramantis> i would think its the same no?
[16:56] <orib> I'm using libavcodec+libswscale, and upon updating to a recent git build, I started getting the following message:
[16:57] <orib> [swscaler @ 0x10a7f800] Warning: data is not aligned! This can lead to a speedloss
[16:57] <orib> I debugged it, and it is in frames that we allocated by libavcodec itself -- anyone know how to make it allocate frames that are aligned?
[17:49] <Bombo> how can i check if the source.mpg stream has PTS in it? can i somehow generate PTS in the source.mpg non-destructable? or can i check if a mpg stream is "ok"? (for use with x264)
[18:06] <satonio> hi, i'm having problems with mp4 files, if i try to use -ss the result file is not ok
[18:06] <satonio> -ss with acodec copy vcodec copy
[18:07] <satonio> the video starts some seconds after the start of the movie and the audio might be in there or maybe not at all
[18:54] <smjms> realistically, which one is better for about 64-96kbps mono audio, faac or libvorbis?
[18:58] <truk77> Folks, I had an ffmpeg setup that worked fine, creating mp4 videos with aac audio, but after updating to the latest build, I'm getting an aac error:    Failed to open bitstream filter aac_adtstoasc for stream 1 with codec aac: Operation not permitted
[18:59] <truk77> Actually, the full message is: [aac @ 0x1b1ff880] Multiple RDBs per frame with CRC is not implemented. Update your FFmpeg version to the newest one from Git. If the problem still occurs, it means that your file has a feature which has not been implemented.
[18:59] <truk77> Failed to open bitstream filter aac_adtstoasc for stream 1 with codec aac: Operation not permitted
[18:59] <truk77> [mp4 @ 0x1b1fdac0] malformated aac bitstream, use -absf aac_adtstoasc
[18:59] <truk77> av_interleaved_write_frame(): Operation not permitted
[18:59] <truk77> (sorry to spam, didn't mean to put in the line breaks)
[19:54] <truk77> Okay, grabbed a fresh pull from git, seemed to fix the aac issue.
[21:40] <mcbaine1> http://goo.gl/nATCX
[22:10] <nicklovescode> ffmpeg is guessing the duration of my video when I try to convert from fly to mp3. The thing is, it lists the correct duration(34 min) before encoding, but outputs a 3 minute video
[22:10] <nicklovescode> http://pastebin.com/TkZZZw96
[22:14] <relaxed> nicklovescode: your ffmpeg is too old.
[22:16] <relaxed> either use the latest release or check out the latest source using git
[22:16] <nicklovescode> I'm installing the latest git now, I'll give an update when installed. Thanks
[22:17] <nicklovescode> latest from git*
[22:28] <nicklovescode> relaxed: http://pastebin.com/6cvtnzrJ
[22:29] <nicklovescode> didn't seem to change anything
[22:31] <relaxed> is it possible the audio stream is shorter than the video stream?
[22:34] <nicklovescode> it was recorded by an audio recorder. There is no video
[22:34] <nicklovescode> but how would I check?
[22:34] <pasteeater> can you provide a sample?
[22:34] <relaxed> ffprobe -show_streams thirty.flv |less
[22:35] <relaxed> Odd stream, "Stream #0:0: Video: none, 1k tbr, 1k tbn, 1k tbc"
[22:36] <nicklovescode> http://pastebin.com/zmJTqLXN
[22:36] <nicklovescode> I could, one moment
[22:36] <agorman> I'm getting the warning "Estimating duration from bitrate, this may be inaccurate". It estimates the duration at half of what it really is. Is there a way to explicitly set the duration?
[22:39] <nicklovescode> http://recorder.teachontablo.com:1337/RFkGUR12byF.flv
[22:39] <nicklovescode> I could get a much longer one if that would be useful
[22:40] <relaxed> what player are you using that plays it for 34 minutes?
[22:44] <nicklovescode> flow player. I'm running it in the background then running an audio visualization. It's only the audio I care about
[22:45] <pasteeater> agorman: i don't know what you're doing.
[22:45] <pasteeater> use a pastebin site to show your ffmpeg command and the complete console output
[22:47] <ultramantis> really need a straight forward answer on compilein ffmpeg on cygwin  all i keep getting is configure errors with libx264
[22:48] <agorman> pasteeater, http://pastebin.com/sGVyfJre
[22:49] <agorman> I have an MXF file from a P2 camera I'd like to use. The rate between the wrapper and the actual encoding don't match but ffmpeg can't decode it wrapped. So I unwrap it using a program called mxfsplit which loses the wrappers rate. I'm looking for a work around anyway I can get it.
[23:03] <nicklovescode> relaxed: any update? I'm not sure where to even start trying to fix this
[23:05] <pasteeater> agorman: have you tried ffmbc? http://code.google.com/p/ffmbc/
[23:05] <agorman> pasteeater, no I'll take a look, thanks
[23:05] <nicklovescode> http://recorder.teachontablo.com:1337/CJ3B7ars45V.flv is a 15 minute video I just recorded
[23:08] <ultramantis> any help on getting ffmpeg with cygwin would be apprciated here
[23:08] <relaxed> nicklovescode: what happens when you encode CJ3B7ars45V.flv to mp3?
[23:09] <nicklovescode> that one seemed to work strangely enough
[23:09] <nicklovescode> but in previous tests(I've had this problem for about 4 days) it sometimes works in the 10-20 min range. I'll try another
[23:09] <nicklovescode> it's never worked with a 30 min video
[23:10] <pasteeater> when it doesnt work as expected does the output still sound ok?
[23:10] <nicklovescode> yes
[23:11] <pasteeater> so is the problem with flowplayer or ffmpeg?
[23:11] <pasteeater> ultramantis: i think most people use mingw
[23:12] <ultramantis> so cygwin is no good?
[23:12] <pasteeater> i don't know. i'm not a windows user.
[23:12] <pasteeater> https://ffmpeg.org/trac/ffmpeg/wiki/MingwCompilationGuide
[23:12] <nicklovescode> flowplayer plays the 30 min video fine. I use ffmpeg to convert it to mp3, end up with a 3 min video
[23:12] <nicklovescode> I try the same thing with a 10 minute video, converts fine
[23:13] <nicklovescode> in 20 minutes I'll try again with a longer fly and I'll post the results
[23:13] <nicklovescode> flv* haha
[23:13] <pasteeater> i'm not sure what you mean. "convert it to mp3" "end up with a 3 min video". mp3 != video
[23:14] <relaxed> there is no video
[23:14] <pasteeater> and is it ffmpeg or flowplayer assuming it's 3 min?
[23:14] <relaxed> I wonder why it creates a null video stream. A requirement of flashplayer?
[23:15] <nicklovescode> sorry, audio. Everything is audio, video is never recorded. Flow player is only involved when I try playing the flv. When I convert it, it's just ffmpeg
[23:16] <nicklovescode> I'm using a flash media server(I'll cry golden tears when html5 gets mic recording ability) called red5 to record it. It's possible that could be the problem, but I don't think so
[23:16] <pasteeater> ultramantis: also this http://ffmpeg.zeranoe.com/
[23:17] <ultramantis> ya been there a million times today lol
[23:17] <ultramantis> ill try with this mingw
[23:17] <ultramantis> i mean ya theres windows build but i need to compile it
[23:17] <pasteeater> sorry i can't be of more help.
[23:17] <ultramantis> no worries
[23:18] <ultramantis> its my own fault i could easliy just install the windows installer but i wanna mes swith the C file in the source
[00:00] --- Tue Jan 24 2012

More information about the Ffmpeg-devel-irc mailing list