[Ffmpeg-devel-irc] ffmpeg.log.20120124

burek burek021 at gmail.com
Wed Jan 25 02:05:01 CET 2012

[01:44] <agorman> pasteeater, I played around with ffmbc and it seems like it does the exact same thing for that MXF file. Any other ideas come to mind?
[01:45] <pasteeater> agorman: can you explain "ffmpeg can't decode it wrapped"?
[01:46] <pasteeater> can you play the file with ffplay?
[01:46] <agorman> no, it just plays the first frame
[01:47] <pasteeater> what about _0002-G18010201.Stream?
[01:47] <agorman> from googling around it seems like these types of MXFs aren't readable.
[01:48] <agorman> it can decode that but it gets the duration wrong
[01:48] <pasteeater> consider submitting a bug report/feature request https://ffmpeg.org/trac/ffmpeg/
[01:50] <agorman> alright I'll do that, thanks for the help
[04:17] <desti_T2> has ffmpeg crashed when it's at the end of the frame number, not writing anything to disk for 20 minutes but still using cpu cycles?
[04:18] <newl> that don't sound good anyway
[04:22] <desti_T2> hmm...something went wrong, stopped it now (it wasn't crashed, exited clean with q), but the video claims to be 3 time longer than it actually is and sound is broken :-/
[04:23] <newl> what was your command line
[04:23] <shifter1> http://git.videolan.org/?p=ffmpeg.git;a=commit;h=0fec2cb15cc6ff1fcc724c774ec36abadcb7b6ad
[04:23] <shifter1> can someone explain that?
[04:23] <shifter1> why was ffmpeg.c deleted?
[04:25] <desti_T2> newl, http://pastebin.com/1Lm9AGCA
[04:32] <newl> any chance you got mencoder options mixed up in ffmpeg - i don't see the -flags global_header in man ffmpeg
[04:37] <desti_T2> dunno from where i got this option, but i guess ffmpeg would complain about it when it's unknown
[04:54] <ultramantis> anybody have any succes installing ffmpeg with libx264 using cygwin
[04:55] <newl> ffmpeg doesn't complain much
[04:56] <ultramantis> i get every time for the past 10 hours
[04:56] <ultramantis> libx264 not found
[04:56] <newl> (unless you verbose it)
[04:56] <ultramantis> /usr/lib/gcc/i686-pc-cygwin/4.5.3/../../../../i686-pc-cygwin/bin/ld: cannot find -lx264
[04:56] <ultramantis> collect2: ld returned 1 exit status
[04:56] <ultramantis> ERROR: libx264 not found
[04:56] <ultramantis> the end of my log
[04:56] <newl> do you have the libx264 installed ?
[04:56] <newl> .c
[04:57] <ultramantis> yeh
[04:57] <newl> well it ain't finding it
[04:58] <ultramantis> libx264.a is there
[04:58] <ultramantis> i see it now
[04:58] <relaxed> ultramantis: --extra-cflags="-I/path/to/x264/include" --extra-ldflags="-L/path/to/x264/lib"
[04:59] <ultramantis> its here   C:\cygwin\home\Administrator\x264
[04:59] <ultramantis> could u print for me exact please
[05:01] <relaxed> I assume, --extra-cflags="-IC:\cygwin\home\Administrator\x264" --extra-ldflags="-LC:\cygwin\home\Administrator\x264"
[05:01] <ultramantis> and put that in the ./configure of ffmpeg right
[05:01] <relaxed> yes
[05:01] <ultramantis> ill give it a shot
[05:04] <ultramantis> btw relaxed   do i put that just how u put it here
[05:04] <ultramantis> no need to put the .a
[05:04] <ultramantis> it worked
[05:04] <ultramantis> ty ty ty
[05:05] <ultramantis> geez ive been trying to get that to work all dam day
[05:05] <ultramantis> ty so much
[05:06] <relaxed> you're welcome
[05:06] <ultramantis> next quick question if theres other things i want to add do i have to fully run ./configure again
[05:07] <relaxed> include them all in the same command.
[05:08] <ultramantis> at the very end it did
[05:08] <ultramantis> License: nonfree and unredistributable
[05:08] <ultramantis> Creating config.mak and config.h...
[05:08] <ultramantis> WARNING: pkg-config not found, library detection may fail.
[05:08] <ultramantis> did i miss something
[05:14] <relaxed> install pkg-config
[05:15] <relaxed> add --enable-gpl --enable-version3
[05:15] <ultramantis> okk ^^ do those to after i install pkg
[05:17] <relaxed> yes, install pkg-config and then re-run configure with the above added to what you already had.
[05:17] <ultramantis> ok great ty very much
[05:18] <relaxed> why are you compiling it anyway?
[05:19] <ultramantis> so i can mess around with the C file
[05:19] <ultramantis> trying to get it to output a different way to my eggdrop
[06:09] <district> hi. does anyone know whether ffmpeg makes use of h264 hardware decoding on iOS?
[06:10] <relaxed> I doubt it
[09:45] <likewise> what is the "neighbor"  method in swscale when I scale vertically x2?
[10:10] <LexSfX> likewise: it's "nearest neighbor" upscaling.  when it interpolates the position of a pixel while upscaling, it doesn't average a new color, but instead, simply looks at the nearest neighbor to that new pixel and copies its color.
[10:10] <LexSfX> it's the simplest form of upscaling, and it doesn't do any real interpolation.  it looks really bad if you upscale with a fractional value.
[10:11] <LexSfX> it looks good with integer upscaling of video games, imo
[10:14] <likewise> LexSfX: exactly what I need, but when I do x2 vertically, I can expect line 1 to be equal to line 0 (counting from 0)?
[10:14] <LexSfX> yes
[10:14] <likewise> LexSfX: thanks
[10:14] <LexSfX> yw
[10:14] <likewise> LexSfX: I will try that
[11:04] <kriegerod> to set libfaac constant bitrate encoding, is it sufficient to set AVCodecContext.bit_rate and bit_rate_tolerance? Am i obliged to set also rc_max_rate, rc_buffer_size?
[11:32] <ikonia> part
[11:32] <ikonia> oops, sorry
[12:17] <mous16> hi chan
[12:23] <mous16> I extracted VOB files from a fiction dvd, concatenated them and splitted  with ffmpeg at right lenght in episodes, so now I have 10 VOB files, with mpeg2 video and ac3 audio (I used "-vcodec copy -acodec copy"). My tv can read mpeg and mp4, so I've to convert them, but "ffmpeg -i orig.VOB -vcodec copy -acodec copy dest.mp4" produce a scattering video (played on vlc) while the vob play ok. the same with mpeg. How can I do
[12:23] <mous16> to not loose quality?
[12:42] <ultramantis> well almsot had ffmpeg finally working on cygwin  heres the latest error   http://pastebin.com/861jLLxM
[12:54] <zap0> ultramantis, isn't there a config option --enable-x264  or smoething like it?
[12:55] <JEEB> --enable-libx264
[12:56] <ultramantis> ya thats done
[12:59] <ultramantis> im trying  a diff configure ill report back ina hour to see if it fixed
[13:01] <ultramantis> i guess maybe in the --extra-cflags=  --extra-ldflags  maybe path was wrong to x264.a
[13:01] <JEEB> very much possible but not sure how the configure would've passed without it finding the lib
[13:02] <JEEB> unless the configure doesn't actually check for it
[13:03] <ultramantis> hmm got to this point
[13:03] <ultramantis> License: nonfree and unredistributable
[13:03] <ultramantis> Creating config.mak and config.h...
[13:03] <ultramantis> config.asm is unchanged
[13:03] <ultramantis> libavutil/avconfig.h is unchanged
[13:03] <ultramantis> and heres my configure
[13:03] <ultramantis> http://pastebin.com/qAu3Vt0a
[13:04] <JEEB> uhh
[13:04] <JEEB> cygwin takes cygwin paths
[13:04] <JEEB> only mingw takes windows'ish paths AFAIK
[13:04] <ultramantis> any suggestion bud
[13:04] <JEEB> also why are you doing --enable-nonfree if you're not enabling anything nonfree?
[13:07] <JEEB> ultramantis, my only suggestion would be to use cygwin paths in cygwin because that's what it only understands :P
[13:09] <JEEB> everything that is within / of cygwin can be accessed with /derp/herp/derp and outside of it is /cygwdrive/drive_letter/derp/herp/derp
[13:09] <JEEB> *cygdrive
[13:09] <JEEB> as far as I know
[13:09] <JEEB> and as far as I could see, that was within the cygwin tree
[14:31] <ultramantis> so JEEB  --extra-cflags="-IC:\cygwin\usr\local\lib"   and the ld flags needs to be different ?
[14:32] <JEEB> I've given you enough hints damn it
[14:32] <JEEB> stop highlighting me
[14:33] <ultramantis> hints heh  why is it always hints with u guys and not just straight forward answer
[14:34] <JEEB> It was a straightforward fucking answer
[14:34] <JEEB> if it's a cygwin configure USE CYGWIN PATHS
[14:34] <JEEB> <JEEB> everything that is within / of cygwin can be accessed with /derp/herp/derp and outside of it is /cygwdrive/drive_letter/derp/herp/derp
[14:34] <JEEB> <JEEB> and as far as I could see, that was within the cygwin tree
[14:34] <JEEB> I even gave this out
[14:35] <JEEB> how hard is that to grasp?
[14:35] <JEEB> seriously
[14:35] <JEEB> how freaking hard is that to grasp?
[14:35] <ultramantis> well i guess since im not as good as you or many others here its hard
[14:35] <ultramantis> http://pastebin.com/xkwq5Nsv  this was the first way attempted that caused the initial error
[14:36] <JEEB> see those two lines
[14:36] <JEEB> I wrote out
[14:36] <ultramantis> yes
[14:36] <JEEB> it's cygwin, it has its own folder structure
[14:36] <ultramantis> right
[14:36] <JEEB> C:\cygwin\usr\local\lib is within the cygwin tree
[14:36] <JEEB> thus, what does it become?
[14:37] <JEEB> give me your best guess
[14:37] <JEEB> although what on earth did you give x264 as --prefix
[14:37] <JEEB> that should be whatever you would give out there
[14:38] <ultramantis> --prefix i never used
[14:38] <ultramantis> somebody here gave me that last paste i sent and it config and all but the make install failed
[14:38] <JEEB> and you didn't check where x264's compilation put shit?
[14:38] <ultramantis> i didnt know what i was exactly looking for
[14:39] Action: JEEB sighs
[14:39] <ultramantis> C:\cygwin\usr\local\lib\libx264.a   i see
[14:39] <ultramantis> but im sure im wrong
[14:39] <JEEB> ok
[14:39] <JEEB> so you at least know
[14:39] <JEEB> that the library is in there
[14:39] <JEEB> great
[14:39] <JEEB> is it at least a cygwin library?
[14:39] <JEEB> but oh well, that we'll find out
[14:39] <JEEB> now
[14:40] <JEEB> back to the cygwin paths
[14:40] <JEEB> given the two lines I wrote
[14:40] <ultramantis> k
[14:40] <JEEB> what would be the cygwin path for C:\cygwin\usr\local\lib
[14:42] <JEEB> hint: it seems that it is most probably within the cygwin environment so /cygdrive doesn't have to be used
[14:42] <JEEB> "everything that is within / of cygwin can be accessed with /derp/herp/derp"
[14:43] <ultramantis> C:/usr/local/lib/libx264.a     i rlly hate being a moron but thats my guess
[14:43] Action: JEEB slaps
[14:43] Action: ultramantis sighs
[14:43] <JEEB> although almost correct
[14:43] <JEEB> remove the C:
[14:43] <ultramantis> /usr/local/lib/libx264.a     i rlly hate being a moron but thats my guess
[14:44] <JEEB> yes, now do 'ls /that/what/you/just/wrote'
[14:44] <JEEB> in cygwin's terminal
[14:44] <ultramantis> k
[14:45] <ultramantis> $ ls /usr/local/lib/libx264.a
[14:45] <ultramantis> /usr/local/lib/libx264.a
[14:45] <JEEB> yup
[14:45] <JEEB> so yes
[14:45] <JEEB> you have found your path
[14:45] <JEEB> to the file
[14:45] <ultramantis> great
[14:45] <ultramantis> lemme do a quick paste to see if im totally correct
[14:46] <JEEB> so /usr/local/lib/ is the folder
[14:46] <ultramantis> the IC  and LC   does it stay like that or  I  and C followed by  /usr/local/lib/libx264.a
[14:47] <JEEB> uhh
[14:47] <JEEB> adding to include is I
[14:47] <JEEB> and adding to libpaths is L
[14:48] <JEEB> "-L/usr/local/lib
[14:48] <JEEB> "
[14:48] <ultramantis> http://pastebin.com/6Hy0m84G
[14:49] Action: JEEB sighs
[14:49] <JEEB> -L and -I add paths to library and include search paths
[14:49] <JEEB> PATHS
[14:49] <JEEB> not files
[14:49] <ultramantis> --extra-cflags="-I/usr/local/lib/" --extra-ldflags="-L/usr/local/lib/"
[14:50] <JEEB> yes
[14:50] <ultramantis> alrighty ill give it a shot
[14:50] <JEEB> also make a 'make distclean' once
[14:50] <JEEB> so you will clean up before the configure
[14:50] <ultramantis> u asked earlier about nonfree i wanna say it told me i need that but ill try without that
[14:50] <ultramantis> ya ill run that first
[14:50] <JEEB> uuh what
[14:51] <JEEB> it will tell you need it if you try to enable something nonfree
[14:51] <JEEB> but in that command line you were enabling nothing nonfree
[14:51] <ultramantis> right
[14:52] <ultramantis> attempting now
[14:55] <ultramantis> so far so good creating config.mak and configh
[14:58] <JEEB> also, why are you, a person who clearly has not the slightest idea of things, building ffmpeg with libx264?
[14:58] <JEEB> if I may ask
[14:59] <ultramantis> b/c i want to be able to edit the output of the logfile
[14:59] <ultramantis> was on my way to doing it with x264.exe  but then i think i twas u that informed me that it only does video not audio
[14:59] <JEEB> oh right, you're THAT guy
[14:59] <ultramantis> ffmpeg im more familiar with as to actual encodign
[15:00] <ultramantis> onto make install now so far still good
[15:00] <JEEB> and weren't you already told that you're going to have it easier off if you just do a batch/bash/perl/python script of it?
[15:00] <JEEB> uhh
[15:00] <JEEB> why make install
[15:00] <ultramantis> not needed ?
[15:00] <ultramantis> god i really need to hit the books apprently on this shit
[15:01] <JEEB> you haven't even specified where it installs and I'm not even sure you want it to install where it installs by default
[15:01] <JEEB> also, to continue my rant just now "because as far as I am concerned you have not the slightest idea of C or coding altogether"
[15:01] <JEEB> continuation of <JEEB> and weren't you already told that you're going to have it easier off if you just do a batch/bash/perl/python script of it?
[15:01] <ultramantis> about that batch/bash/perl/python script something else i know zero about or to where to even attempt that
[15:02] <JEEB> do you know more or coding in C?
[15:02] <JEEB> *of
[15:02] <ultramantis> no  ive been told a few things to read
[15:02] <ultramantis> thats about it though
[15:02] <JEEB> have you ever programmed anything?
[15:02] <ultramantis> no
[15:02] <JEEB> then give up here
[15:02] <ultramantis> id like to learn though
[15:03] <JEEB> well, if you'd like to learn, have your fun
[15:03] <ultramantis> so this type of script u were talking about should i just research about that then
[15:04] <JEEB> I'm just pretty sure it'd be easier off if you'd use any of the ways of scripting when calling the app and then parsing what it outputs and making your own output out of it
[15:04] <JEEB> that's all I mean
[15:04] <ultramantis> sounds alot easier thats for sure
[15:04] <JEEB> and it wouldn't mean you'd have to learn something about the internals of ffmpeg
[15:05] <JEEB> and you wouldn't have to recompile stuff every time you want to change things :P
[15:05] <ultramantis> right heh
[15:06] <ultramantis> well even though youd prob like to shoot me at this point could u point me in the right direction for this type of script
[15:06] <ultramantis> so im at least on the right path
[15:08] <felixge> Q: How can I tell ffmpeg where to look for x264? (I don't want to install it with make install)
[15:08] <ultramantis> ^^ hehe sounds almost like my questions
[15:09] <JEEB> felixge, I would recommend installing it somewhere with setting the --prefix, and then adding the new L and I paths by setting the --extra-cflags and --extra-ldflags configure options :)
[15:09] <felixge> I tried with --extra-cflags="-I/path/to/x264" --extra-ldflags="-L/path/to/x264"
[15:09] <felixge> but not look
[15:09] <felixge> * luck
[15:10] <felixge> JEEB: ok, so I do have to run install
[15:10] <felixge> let me try that
[15:10] <JEEB> also, are you sure you built the x264 libraries?
[15:10] <JEEB> I'm not sure if you need to do install, but it's just nicer to keep your tools installed in one location (or multiple, but at least installed)
[15:11] <felixge> JEEB: I'm sure I ran `make` and it didn't fail. But I'm trying your suggestion now
[15:11] <felixge> JEEB: thanks
[15:11] <JEEB> uhhh
[15:11] <JEEB> I meant that x264 by default only compiles the command line app
[15:11] <JEEB> y'know
[15:12] <JEEB> you need to enable static or dynamic libs
[15:13] <JEEB> ultramantis, you should look at how you are using whatever ffmpeg outputs on the command line since that's what you seemed to be taking in, and seeing if that limits you to certain scripting etc. things. And then pick what you want and learn it, ask around the channels related to that scripting language etc. And no, I have no interest in your system or what you are doing. Off you go, and have fun. And good luck.
[15:14] <felixge> JEEB: seems like your suggestion was spot on! I ./configure'ed with --prefix=`pwd` and it seems to work just fine now
[15:14] <felixge> (that is, the ffmpeg build doesn't fail right away)
[15:14] <JEEB> and now you have the install directories mixed up with the source
[15:14] <JEEB> asdf
[15:15] <ultramantis> heh thanks JEEB  for all the help apprciate it
[15:15] <JEEB> wouldn't it be prettier to just have /home/herpmyderp/ownapps or something for your own stuff?
[15:16] <felixge> JEEB: agreed. I'll clean this all up a bit afterwards. But right now I'm trading fast for pretty :)
[15:20] <ultramantis> update it fully intalled ty for the paitence with me
[15:20] <ultramantis> installed
[15:34] <felixge> JEEB: when running my ffmpeg, I get: error while loading shared libraries: libx264.so.120: cannot open shared object file
[15:34] <felixge> any idea?
[15:34] <JEEB> felixge, with shared libraries you have to have the library somewhere where the app can find it
[15:34] <JEEB> or well
[15:34] <JEEB> where the SYSTEM finds it
[15:34] <JEEB> LD_LIBRARY_PATH or whatever it was?
[15:35] <JEEB> anyways, I recommend you deal with static libs if you just want to test or use your own build :P
[15:35] <JEEB> shared libs are mostly an annoyance
[15:35] <felixge> setting LD_LIBRARY_PATH seems to work
[15:35] <felixge> setting it to the x264 lib dir that is
[15:35] <JEEB> yes
[15:36] <felixge> JEEB: how would I go about making a static lib?
[15:36] <JEEB> --enable-static?
[15:36] <JEEB> in x264's configure
[15:36] <felixge> for ffmpeg or x264?
[15:36] <felixge> ok
[15:36] <JEEB> and not seeting --enable-shared in ffmpeg's
[15:36] <JEEB> or whatever it was
[15:36] <JEEB> and not setting --enable-shared with x264
[15:37] <felixge> JEEB: ok, so an ffmpeg config like this should work? ./configure --enable-libx264 --enable-libfaac --enable-gpl --enable-nonfree --extra-cflags="-I`pwd`/../x264/include" --extra-ldflags="-L`pwd`/../x264/lib"
[15:37] <JEEB> I have no idea about your -I and -L
[15:37] <JEEB> but I will guess they are correct
[15:37] <JEEB> and yes
[15:37] <JEEB> that should work
[15:38] <felixge> JEEB: well, they worked for my previous attempt. except that setting LD_LIBRARY_PATH whenever I use ffmpeg is a bitch :)
[15:38] <felixge> so I'll try the static approach now
[15:38] <felixge> JEEB: thank you so much
[15:38] <JEEB> yes, and remember that if your application was any bigger you'd probably want to keep the original contents of LD_LIBRARY_PATH
[15:41] <felixge> JEEB: it was empty for me
[15:41] <felixge> before setting it
[15:41] <JEEB> heh
[15:42] <JEEB> I have no idea if it's supposed to be empty or have something in it :D
[15:42] <felixge> not sure if that means it was explicitly set to empty, or that the system also has another default value :)
[15:42] <felixge> me neither
[15:42] <JEEB> well, if it's empty I guess the system looks for the libraries somewhere else
[15:42] <JEEB> or more like, looks for where the libraries are somewhere else
[17:48] <Guest63637> may sound a little stupid but can I know how Oxelon media player uses ffmpeg without being released in GPL?
[17:49] <Guest63637> converter*
[17:49] <Mavrik> it's perfectly legal if their ffmpeg build is redistributable and they're not actually linking against it but just invoking it
[17:50] <JEEB> Also, ffmpeg can be built as LGPL
[17:50] <JEEB> where they at max have to release sources for ffmpeg in case of dynamic linking, and sources of ffmpeg + object files in case of static linking
[17:51] <Guest63637> so Oxelon only ends up invoking ffmpeg from command line, thats all it does? assuming I can ignore things about the GUI
[17:52] <Mavrik> I don't know what oxelon does :)
[17:54] <JEEB> Guest63637, it's perfectly legal if the application uses LGPL ffmpeg. Only some parts of ffmpeg are GPL
[17:54] <JEEB> AND
[17:54] <JEEB> if it releases sources for the ffmpeg part
[17:54] <JEEB> (and in case of static linking the object files for the rest)
[17:54] <Mavrik> That's unlikely however since X264 is GPL :)
[17:55] <JEEB> x264 now has payware license as well
[17:55] <Guest63637> can you tell me something about this x264 ive been hearing about it a lot
[17:55] <JEEB> in any case, if it's clearly one of those cases where it's using GPL ffmpeg and doesn't give a <beep> then it's one of the usual ones
[17:55] <Mavrik> JEEB, how does that licence play with the LGPL?
[17:55] <JEEB> Mavrik, the heck I know but does the app necessarily use x264 via ffmpeg?
[17:55] <JEEB> x264 has rather good APIs for just the video encoding
[17:56] <JEEB> Guest63637, the best H.264 encoder available
[17:56] <JEEB> now used in some payware applications as well
[17:56] <Mavrik> JEEB, that's the naive easy implementation I'd think of first
[17:56] <JEEB> well, you'd actually have to take a look at the damn application to actually check the situation :P
[17:56] <JEEB> I'm just saying that unless you take a look at the damn application you can't say one way or another
[17:56] <JEEB> that's all
[17:57] <Mavrik> JEEB, well, you can say if LGPL and x264 payware licenses can coexist :)
[17:57] <Mavrik> which is what I was getting at
[17:58] <Mavrik> no need to bash the poor application now ;)
[17:58] <JEEB> eh
[17:58] <JEEB> you'd have to ask someone else about the LGPL + x264 payware license tbqh. Because I'm not that good in basing stuff on if an LGPL application links something else :P The other way is more simple
[17:58] <JEEB> ask on #x264 or something
[17:59] <JEEB> because LGPL's meaning is just that must be able to switch the library to something else if you want
[17:59] <Mavrik> I'll google it later, it's just idle curiosity for something that's probably useful to know :9
[18:00] <Mavrik> since I had some very interesting problems trying to put together some proprietary libraries with some GPL ones in same piece of software -_-
[18:00] <JEEB> GPL is a completely separate issue
[18:00] <JEEB> LGPL is quite different
[18:00] <JEEB> GPL and proprietary is a no go
[18:01] <boo> I'm streaming video from dvb-t usb stick to red5 rtmp, but ffmpeg crashes when I change larger res ( 220x120), the CPU is 100%, but load avg is 0.0 - 0.08 andthe ffmpeg stops decoding. http://pastebin.com/fXUL8v8y log generated with strace, any suggestions?
[18:41] <pk__> does ffmpeg uses all the processors by default?
[18:42] <Generic_Dumbass> pk__: it does for me.
[18:42] <Mavrik> that depends on the encoder
[18:43] <Mavrik> my experiences show that in most cases it doesn't :)
[18:43] <pk__> hahah
[18:43] <Mavrik> so just add the -threads parameters
[18:43] <pk__> right
[18:43] <pk__> ok
[18:50] <boo> Can anyone please help me?
[18:51] <Mavrik> boo, that's probably a question for developers :\
[18:52] <Mavrik> boo, you can try using -vf scale filter but that probably won't help much
[18:53] <boo> mvrik, I changed the res to small ~ 100x100 that previously worked now doesn't work, so I assume that the parameters are wrong for that (codec)
[18:53] <Mavrik> boo, if you'll paste non-strace output of the crashing ffmpeg with command line we might help
[18:54] <Mavrik> *might be able to
[18:54] <boo> Mavrik ok, btw here's how I run it
[18:54] <boo> ffmpeg -y -vcodec h264 -i /dev/dvb/adapter0/dvr0 -isync -ac 1 -s 220x124 -r 20 -ar 44100 -ab 40000 -f flv rtmp://tooth.beberry.lv/oflaDemo/streams/live
[18:54] <Mavrik> huh.
[18:55] <Mavrik> boo, stop using h264, use libx264 and move the -vcodec after -i specification
[18:57] <boo> Mavrik, now different error appeared, but similarly - ffmpeg closed fast. http://pastebin.com/puAvzgtt
[18:58] <Mavrik> hmm, which command line did you use?
[18:59] <boo> Mavrik, sorry about the last line forgot to remove
[18:59] <boo> Mavrik, sorry about the last line forgot to remove wgetpaste
[18:59] <boo> ffmpeg -y -i /dev/dvb/adapter0/dvr0 -vcodec libx264 -isync -ac 1 -s 220x124 -r 20 -ar 44100 -ab 40000 -f flv rtmp://tooth.beberry.lv/oflaDemo/streams/live
[19:00] <Mavrik> boo, ffmpeg is sensitive to command-line order, so try also moving -isync before -i, and if doesn't work ADD -vcodec h264 back before -i
[19:04] <boo> Mavrik, that's wierd, unknown encoder h264
[19:04] <boo> http://pastebin.com/NdS0W1EP
[19:05] <Mavrik> why did you change it back to h264?
[19:05] <Mavrik> -vcodec after "-i " specifies the encoder to use and ffmpeg doesn't have a stable h264, you need to use libx264
[19:05] <Mavrik> -vcodec before "-i" tells ffmpeg which video DEcoder should it use for stream
[19:06] <Mavrik> and those are named differently (you can see them in ffmpeg -codecs)
[19:07] <boo> Mavrik "nd if doesn't work ADD -vcodec h264 back before -i" didn't read it carefully, so I have to put h26 before i and libx.. after i? correct?
[19:07] <Mavrik> yea
[19:08] <boo> Mavrik http://pastebin.com/QEEgk3ft
[19:10] <Mavrik> [mp2 @ 0x8fd64d0] incomplete frame
[19:10] <Mavrik> Error while decoding stream #0.1
[19:10] <Mavrik> something is wrong with your audio input
[19:11] <boo> Mavrik, hhmmn, should be ok. It's being taken from dvb-t stick.. Is there a chance to ignore that?
[19:12] <Mavrik> well, mp2 decoder fails
[19:12] <Mavrik> do you have AAC input by any chance?
[19:13] <Mavrik> (you're also not specfying the output audio encoding and it's jsut dumping raw audio which probably isn't what you want)
[19:14] <boo> Mavrik what do you mean by 'do I have AAC inputy by any chance'?
[19:14] <Mavrik> does your input have AAC audio instead of MP2?
[19:16] <boo> Marvik, don't know. I can send you a short file made by cat /dev/dvb/adapter0/dvr0 > bu     and you could see that. Well it's an dvb-t signal, that's all I know
[19:17] <Mavrik> well
[19:17] <Mavrik> you should check that first really
[19:17] <Mavrik> I find it unlikely you have H264 with MP2
[19:17] <boo> Mavrik how to do that?
[19:19] <boo> Mavrik http://beberry.lv/up/u/bu this is the cat file. Don't have an extension, because I didn't knew how to call it
[19:20] <boo> [18:17] <boo> Mavrik how to do that? [18:19] <boo> Mavrik http://beberry.lv/up/u/bu this is the cat file. Don't have an extension, because I didn't knew how to call it
[19:24] <Mavrik-> sorry, I fell off
[19:24] <Mavrik-> boo, anyway, if you have a new-type DVB-T with MPEG-4
[19:24] <Mavrik-> then your audio is probably AAC not MP2
[19:24] <Mavrik-> that's why the MP2 decoder fails
[19:24] <boo> Mavrik, yes, it should be mpeg-4
[19:24] <Mavrik-> boo, so try adding "-acodec aac" before "-i"
[19:25] <Mavrik-> and also add "-acodec libfaac" after "-i" :)
[19:28] <boo> Mavrik unknown encoder libfaac
[19:28] <boo> Should I add use flag and emerge ffmpeg
[19:28] <boo> ?
[19:30] <Mavrik-> boo, do you have libvo_aacenc by any chance?
[19:30] <boo> Mavrik ffmpeg -formats ?
[19:31] <Mavrik-> boo, -codecs
[19:31] <boo> Mavrik, no I don't
[19:32] <boo> Mavrik, which one better to emerge?
[19:32] <Mavrik-> boo, libvo_aacenc is probably better
[19:32] <boo> Mavrik- just add libvo_aacenc to use flags and emerge ffmpeg?
[19:33] <Mavrik-> boo, don't use Gentoo, can't help you there
[19:33] <Mavrik-> but probably
[19:33] <Mavrik-> check the use flags.
[20:26] <ryaxnb> hi
[20:26] <ryaxnb> i have a 25fps MKV
[20:26] <ryaxnb> i want a 23.975 fps mkv
[20:26] <ryaxnb> but i don't want to convert, that would take forever
[20:26] <ryaxnb> i just want to make it play 1/24 slower
[20:27] <ryaxnb> and make that the "official" marked fps of the file
[20:27] <ryaxnb> so that any player will support that.
[20:27] <ryaxnb> how do you do that?
[20:40] <NOTaMango> personally i'd use mkvtools for that, not ffmpeg
[20:40] <NOTaMango> specifically mkvmerge
[21:10] <rsts> Hi. While compiling gnash with ffmpeg I get:libavcodec.a(lpc_mmx.o): relocation R_X86_64_PC32 against symbol `ff_pd_1' error.
[21:11] <rsts> can anybody explain what's wrong and how can it be fixed?
[21:14] <boo> Hei, I'm trying to solve the problem that ffmpeg stops working when decoding dvb-t stream and sendig it to rstp. http://pastebin.com/dnJ7u9Wh the parameters and this is the error http://pastebin.com/HivNwsxz  could you recomend what to do? Signal probalby is mpeg-4
[21:36] <boo> Anyone? The problem is still here.. http://pastebin.com/mbWrBubg
[22:25] <boo> Hei, I'm trying to solve the problem that ffmpeg stops working when decoding dvb-t stream and sendig it to rstp. http://pastebin.com/Xwd4Hm2F  could you recomend what to do? Signal probalby is mpeg-4
[22:30] <pasteeater> boo: can you explain "stops working"?
[22:31] <boo> pasteeater, it's in pastebin.. ffmpeg just closes, I'm back in bash again
[22:33] <pasteeater> looks like a decoding issue
[22:33] <boo> pasteeater, I assume. But cannot find what's wrong. don't know even where to start..
[22:34] <pasteeater> can you show the output of: ffmpeg -y -isync -vcodec h264 -pix_fmt yuv420p -s 720x576 -i /dev/dvb/adapter0/dvr0
[22:36] <pasteeater> can you also try ffmpeg git? no need to install. just plain ./configure and make and then run the resulting binary
[22:36] <boo> Sure! http://pastebin.com/VTg0jap6
[22:36] <boo> ths is the first thing you asked
[22:37] <boo> pasteeater what do you mean by that git? What should I do?
[22:38] <pasteeater> one more: ffmpeg -y -isync -vcodec h264 -pix_fmt yuv420p -s 720x576 -i /dev/dvb/adapter0/dvr0 -f null /dev/null
[22:39] <brontosaurusrex> i have a command that is working fine: ffmpeg -y -i "$out.m4a" -i "$files" -pix_fmt yuv420p -pass 2 -passlogfile "$out.log" $options2pass -acodec copy "$out.mp4"
[22:40] <brontosaurusrex> will this always take $out.m4a for audio or there are surprises waiting?
[22:40] <boo> pasteeater, ffmpeg -y -isync -vcodec h264 -pix_fmt yuv420p -s 720x576 -i /dev/dvb/adapter0/dvr0 -f null /dev/null doesn't stop, should I stop it?
[22:41] <pasteeater> boo: i wanted to see if
[22:41] <pasteeater> [mp2 @ 0x98028c0] incomplete frame
[22:41] <pasteeater> showed up again
[22:42] <brontosaurusrex> and the question 2 would be: matrox i-frame only, 4:2:2 mpeg2 of some sort, packed in avi container <- no way to transcode to anything, any ideas?
[22:42] <pasteeater> boo: does ffmpeg quit every time or just on occasion?
[22:43] <boo> pasteeater, http://pastebin.com/sWcrDWHb it didn't cancel by itself so I stopped, when it starts to show the info about frames, time etc, nothing goes wrong
[22:43] <boo> pasteeater, now on every occasion, during the day I had a little bit different options, then it quited rarely..
[22:43] <pasteeater> brontosaurusrex: what does ffmpeg say about it? ffmpeg -i martoxfile.avi
[22:43] <boo> pasteeater, not rarely, but ~ 80% of times
[22:44] <brontosaurusrex> pasteeater, oh, i don't have one handy here, was just asking, if that is known problem
[22:45] <pasteeater> i don't know, but if you find any samples that ffmpeg can't decode you should add a feature request on the bug tracker.
[22:45] <pasteeater> boo: what did you change so it quits more often?
[22:46] <brontosaurusrex> pasteeater, ok
[22:46] <boo> pasteeater, don't know, but it wasn't relavant, I think. I can try to find, but most likely not. I think that in the beginning the size of frame wXh affected that, if < 200 then it was ok for a short period of time, but it quited anyway
[22:48] <ROKO__> hello
[22:48] <ROKO__> i tryed this cmdline
[22:48] <ROKO__> mpeg -f alsa -i pulse -f x11grab -r 30 -s 1024x768 -i :0.0 -acodec pcm_s16le -vcodec libx264 -vpre lossless_ultrafast -threads 0 output.mkv
[22:49] <ROKO__> but get error -> File for preset 'lossless_ultrafast' not found
[22:49] <ROKO__> what is missing
[22:49] <ROKO__> ?
[22:49] <ROKO__> gentoo linux amd64
[22:49] <pasteeater> ROKO__: you probably need the newer syntax
[22:49] <ROKO__> newer ?
[22:50] <pasteeater> -vcodec libx264 -preset ultrafast -crf 0 output.mkv
[22:50] <boo> pasteeater, is there a way to find the cause of the problem?
[22:55] <boo> pasteeater still here?
[22:56] <brontosaurusrex> pasteeater, how about the 1st question, mapping is correct, but aim not sure why, clues?
[22:56] <brontosaurusrex> *i'am
[22:57] <ROKO__> thanks
[23:12] <boo> Can any one please help solve the problems of ffmpeg? during decoding it stops working. probably something to do with codecs. don't know even what to check..
[23:13] <Tjoppen> you'll need to pastebin some output
[23:13] <Tjoppen> "it stopped working" isn't saying much
[00:00] --- Wed Jan 25 2012

More information about the Ffmpeg-devel-irc mailing list