[Ffmpeg-devel-irc] ffmpeg.log.20120126

burek burek021 at gmail.com
Fri Jan 27 02:05:01 CET 2012

[00:46] <indigo> hi
[00:47] <indigo> I'm trying to get a help to compile lastest ffmpeg in mingw32
[00:48] <indigo> it keeps giving an error saying I need mingw32-runtime >=3.15 but I cannot find any mingw32-runtime >=3.15 release!
[00:52] <newl> http://sourceforge.net/projects/mingw/files/MinGW/Base/mingw-rt/
[00:53] <indigo> thanks
[00:59] <boo> Is there anyone here? I think that I have found the problem of my ffmpeg crashing, but I don't know the solution
[01:01] <newl> strace it - maybe it is something easy to see  and use verbose in your command line ... which is what btw?
[01:17] <boo> new1 are you talking to me?
[01:19] <boo> new1 Facts - if I save the dvb-t stream with 'cat' to a file and paralel decode it with ffmpeg then nothing crashes. BUT if I encode dirrectly from dvb-t stick, then it crashes ~5.2 seconds +/- 2 ms  so one guy suggested adding -analyzeduration 1500000000
[01:20] <boo> new1 wuwhu, now it didn't crash for 10,3 seconds..
[01:20] <boo> new1 need to find a way to ignore that 'analyzeduration' ... because you cannot add infinite value
[02:03] <indigo> well
[02:04] <indigo> I installed mingwrt-3.15.2 and ffmpeg ./configure keep telling me I need >=3.15
[02:05] <indigo> I recompile the entire mingw32 package via the sh script
[02:06] <newl> what is the configure line you are using -
[02:07] <indigo> ./configure --enable-cross-compile --arch=x86 --target-os=mingw32 --disable-shared --enable-static --enable-version3
[02:07] <boo> new1 no Ideas about mine problem?
[02:09] <newl> boo nope
[02:09] <indigo> it should be fine,
[02:09] <boo> new1 don't know anything about analyzeduration ?
[02:10] <indigo> check_cpp_condition _mingw.h "defined (__MINGW64_VERSION_MAJOR) || (__MINGW32_MAJOR_VERSION > 3) \
[02:10] <indigo>                                       || (__MINGW32_MAJOR_VERSION == 3 && __MINGW32_MINOR_VERSION >= 15)" ||
[02:10] <indigo>                 die "ERROR: MinGW runtime version must be >= 3.15."
[02:10] <indigo> it search in _mingw.h
[02:11] <indigo> but WHICH _mingw.h?
[02:12] <newl> add a  --cross-prefix=i686-mingw32-
[02:12] <newl> ymmv
[02:13] <newl>  boo nope
[02:15] <indigo> I found my mistake
[02:15] <indigo> I never removed the old version
[02:15] <newl> always helps
[02:15] <indigo> and instead installing the newer in the same di9rectoty
[02:15] <newl> godo
[02:15] <newl> doog
[02:15] <newl> good
[02:16] <indigo> I installed in /usr/minw232 instead /usr/mingw32
[02:16] <indigo> :D
[02:17] <newl> is it in the $PATH?
[02:17] <indigo> yes
[02:18] <indigo> PATH=$PATH:/usr/mingw32
[02:19] <newl> a good ffmpeg.exe is only good if it works with wine - forget about testing on a win machine :)
[02:19] <Zeranoe> If I don't modify the source code for FFmpeg at all, and build for LGPL, does the source code need to still be "linked" or mentioned? Does it need to be packaged with the build?
[02:19] <newl> you selling your product for beaucoup yen?
[02:21] <indigo> ok, I fixed the mingw installation path
[02:21] <indigo> now let's do it again
[02:22] <indigo> doesn't work
[02:22] <indigo> to be shure i
[02:22] <indigo> updatedb
[02:22] <indigo> then locate _mingw.h
[02:23] <indigo> then cat /path/to/_mingw.h
[02:23] <indigo> and I can see it's 3.15.2
[02:23] <indigo> but nope
[02:23] <indigo> it's in /usr/mingw32/include
[02:26] <Zeranoe> indigo: Are you cross compiling?
[02:26] <indigo> yes
[02:26] <indigo> I'm on a debian
[02:26] <Zeranoe> what toolchain are you using?
[02:26] <newl> use the extra --extra-cflags='-I/mingw/include' --extra-ldflags='-L/mingw/lib'
[02:27] <indigo> ok, I'll try
[02:28] <indigo> ./configure --enable-cross-compile --arch=x86 --target-os=mingw32 --disable-shared --enable-static --enable-version3 --extra-cflags='-I/root/mingw/include' --extra-ldflags='-L/root/mingw/lib'
[02:28] <indigo> ERROR: MinGW runtime version must be >= 3.15.
[02:28] <Zeranoe> indigo: Can you post your config.log on pastebin.com?
[02:29] <indigo> give me a minute
[02:30] <indigo> maybe I solved
[02:30] <indigo> oh yeeeeeah
[02:31] <indigo> it was NOT /root/mingw/include BUT /root/mingw32/include
[02:33] <indigo> I have different errors this time, but I can handle them
[02:33] <indigo> thanks a lot
[02:33] <indigo> goodbye
[02:43] <_klk_> ladies and gentlemen, can ffmpeg transcode from h264 in mkv container to m2ts for burning onto a bluray?
[04:30] <shevy> Can I disable audio somehow?
[04:30] <shevy> I have a .mp4 file and want to only keep the video data
[04:30] <shevy> and discard audio
[04:33] <shevy> found it
[04:33] <shevy> -an
[04:55] <burek> shevy -an
[04:55] <burek> yes :)
[06:10] <Ginks> is there a way that I can place a scrolling marquee in a movie?
[06:10] <Ginks> like: "This movie is copyright Ginks, 2012"
[07:03] <sosman> I have some motion JPEG AVI (straight from digicam).  When I use ffmpeg -i foo.avi foo.mpg they are 4x smaller but noticeable pixelation.  Any suggestions on command line for improving the quality (I don't mind sacrificing compression).
[07:48] <grepper> default bitrate is 200 kbps, so you should indicate the bitrate.
[08:15] <cbreak-work> if you want h.264, consider a crf encode
[08:17] <grepper> yeah, your line is making mpeg1 so your compression could probably not get worse :)
[08:19] <Ginks> is there a way that I can place a scrolling marquee in a movie?
[08:23] <cbreak-work> text?
[08:24] <cbreak-work> ffmpeg has the drawtext filter if you configured it with --enable-libfreetype
[10:08] <Ginks> yah, text
[10:09] <Ginks> I found that filter, seems pretty complicated for what I need to do
[10:09] <Ginks> I'll see if I can figure it out
[10:09] <cbreak-work> drawtext is power :)
[10:19] <Ginks> basically I just want to scroll "This movie is copyright Ginks, 2012" a couple times thoughout the video across the top
[10:19] <Ginks> is that doable cbreak-work?
[10:21] <cbreak-work> yeah. Think so. It has temporaly dependent x-y
[10:21] <cbreak-work> don't ask me how :)
[10:37] <sosman> cbreak-work: thanks, crf 22 did the trick.
[10:39] <sosman> if I want to replace the audio in an mp4 file with the tracks in a separate .aac file how can I specify copy vs transcode please?
[10:39] <sosman> I tried ffmpeg -i a.aac -i v.mp4 new.mp4
[10:39] <JEEB> -acodec copy
[10:40] <sosman> But it was compressed quite a bit.
[10:40] <Mavrik> -codec:a copy
[10:40] <Mavrik> or -acodec copy
[10:40] <Mavrik> depending on which version you have :)
[10:40] <Mavrik> Morning everyone by the way :)
[10:40] <sosman> evening
[10:40] <sosman> version 0.7.8
[10:41] <Mavrik> just do -acodec copy to copy audio stream
[10:41] <Mavrik> if there's an audio stream in the source mp4 file you'll probably have to use -map as well
[10:41] <sosman> yes there is
[10:44] <Mavrik> then if you want to replace the audio you'll probably have to specify -map mappings for streams you want to keep
[10:53] <mrAZ> hi, input.mov is dvvideo, yuv420p, bitrate: 31041 kb/s, i am trying to lower bitrate with -vcodec dvvideo -b 1000k, but output is again bitrate: 27972 kb/s. what is the problem?
[10:53] <sosman> So far I have:
[10:54] <sosman> ffmpeg -i foo2.mp4 -i bg.aac -vcodec copy -acodec copy -map 0:v -map 1:a  bg3.mp4
[10:54] <Mavrik> mrAZ, you can't change bitrate of DV, it has a static compression
[10:54] <Mavrik> sosman, that should work :)
[10:54] <mrAZ> Mavrik: thx, i will try to use something i can put in .mov
[10:54] <sosman> but I get stuff like [aac @ 0x1b411a0] channel element 0.0 is not allocated
[10:54] <sosman> [h264 @ 0x1b3ed80] missing picture in access unit
[10:55] <Mavrik> mrAZ, that would be H.264 ^^
[10:55] <Mavrik> sosman, that's... interesting
[10:55] <sosman> indeed
[10:56] <Mavrik> especially since it shouldn't even be trying to decode the aac
[10:56] <Mavrik> -map 0:v:0 -map 1:a:0?
[10:57] <sosman> same
[10:57] <Mavrik> can you paste the whole ffmpeg output to some pastebin so we can see if anything else goes wrong? :)
[10:57] <sosman> ok
[10:58] <sosman> Any command I can run on the input files to check my assumptions?
[10:58] <Mavrik> ffprobe
[10:58] <Mavrik> to see what's in them
[10:58] <Mavrik> and ffplay to see if ffmpeg can actually decode and play them
[10:59] <sosman> I straight away get errors with ffprobe on the mp4 file so I'll hang fire on the paste till I sort that out.
[11:00] <sosman> vlc plays it fine though
[11:00] <Mavrik> sosman, try doing just ffmpeg -i foo2.mp4 -vcodec copy -an test.mp4
[11:00] <Mavrik> and see if the test.mp4 file is playable
[11:00] <mrAZ> Mavrik: how does it go in ffmpeg? Unknown encoder 'h264'. normaly i use mplayer and mp4box for that.
[11:00] <Mavrik> mrAZ, something like -vcodec libx264 -preset slow -b 1000k
[11:01] <sosman> works fine with ffplay
[11:01] <Mavrik> sosman, should be fine then, there seems to be an ffmpeg bug report because of that message
[11:05] <mrAZ> Unrecognized option 'preset', and if i skip that : use an encoding preset (vpre) ... parameters such as bit_rate ...
[11:05] <Mavrik> ugh
[11:05] <Mavrik> your ffmpeg is ancient :)
[11:05] <Mavrik> I suggest udating it before you continue.
[11:07] <mrAZ> FFmpeg version SVN-r0.5.1-4:0.5.1-1ubuntu1.2 ... is that already ancient?
[11:07] <Mavrik> libx264 didn't really work very well with old ffmpeg versions
[11:07] <Mavrik> mrAZ, current version is 0.9.1 :)
[11:16] <sacarasc> ackjewt: It's been ancient for a long time. ;p
[11:47] <IamTrying> I have wmv file which is converted to flv works but i can not do it to "WEBM" i get this error: https://gist.github.com/1682200
[11:52] <Mavrik> IamTrying, you're trying to encode audio to 11050Hz with 1 channel which libvorbis encoder doesn't support
[11:52] <Mavrik> IamTrying, also, you probably shouldn't be using -sameq, it doesn't do that you (probably) think it does
[11:54] <IamTrying> Mavrik, ok thank you when i used this its doing now something. But will this drop the quality? e.g: $ ffmpeg -sameq -i file.wmv -ar 22050 output.webm
[11:55] <Mavrik> for audio, probably not, since your input is 11025
[11:55] <Mavrik> for video, you're probably losing quality because you're not specifying any settings and ffmpeg is defaulting to built-in
[11:58] <IamTrying> Thank you, much clear now what was the issue.
[11:59] <Mavrik> IamTrying, http://www.virag.si/2012/01/webm-web-video-encoding-tutorial-with-ffmpeg-0-9/
[12:00] <Mavrik> IamTrying, this may help you
[12:00] <IamTrying> OK
[12:17] <armetiz> hi there
[12:18] <armetiz> I'm using ffmpeg ince 2 days..So i'm a newbe on it.
[12:18] <armetiz> I'm trying to encode master video file to different bitrate, it's okay for size, etc etc..
[12:18] <armetiz> But I have a problem ( the last one ), about color...
[12:19] <armetiz> The encoded ffmpeg video is color less regarding the original file..
[12:19] <armetiz> Do you have any clue ?
[12:20] <armetiz> I have build ffmpeg & x264 from master SVN / GIT.
[12:20] <armetiz> I have compile x264 with default option
[13:04] <ackjewt> sacarasc: Huh?
[13:05] <sacarasc> Sorry, I failed at reading, and thus tab completing.
[13:09] <ackjewt> Ah. Im getting used to it
[13:34] <armetiz> I'm trying to use some video filter, like pad
[13:34] <armetiz> and I have no result..
[13:34] <armetiz> or "Input area XXXXX not within the padded area XXXXX or zero-sized"
[13:35] <armetiz> do you have any clue ?
[13:35] <Mavrik_> obviously you pass wrong parameter to the filter.
[13:35] <armetiz> I have try the ffmpeg example
[13:35] <armetiz> and the video output is the same as without pad..
[13:36] <armetiz> I want to add pad on left / right from a 4:3 to a 16:9
[13:36] <Mavrik_> well
[13:36] <Mavrik_> ffmpeg tells you clearly
[13:36] <Mavrik_> your input area for padding isn't valid
[13:36] <Mavrik_> you passed wrong parameters to the padding filter for your video.
[13:36] <Mavrik_> go read the documentation again and check what each parameter does.
[13:37] <armetiz> oki
[13:37] <armetiz> i'll read the documentation again
[14:05] <undercash> hello
[14:05] <undercash> i have updated my ffmpeg
[14:05] <undercash> http://pastebin.com/QSLigsum
[14:05] <undercash> but now it seems my command script won't work anymore..
[14:06] <undercash> ffmpeg -i "testcc.avi" -y -acodec libfaac -ar 44100 -ab 96k -ac 2 -s 640x360 -vcodec libx264 -preset medium -profile baseline -level 3.0 -crf 30 -threads 8 -f ipod -f ipod mobiletest.mp4
[14:06] <undercash> something changed since july?
[14:07] <Mavrik> maybe.
[14:07] <Mavrik> maybe you should post the actual error.
[14:07] <undercash> here is output http://pastebin.com/bPv73nFz
[14:08] <undercash> yes ;)
[14:08] <Mavrik> [NULL @ 0x181f680] Unable to parse option value "baseline"
[14:08] <Mavrik> ah, yes, known problem
[14:08] <Mavrik> undercash, parameter collision between libfaac and libx264
[14:08] <Mavrik> undercash, use -profile:v baseline
[14:09] <undercash> seems to works!
[14:09] <undercash> hope i dont meet any other stuff , thanx
[14:22] <undercash> hmm i have been installing this "Local" version of ffmpeg for vlc use
[14:22] <undercash> now i start a conversion via script and i get 16 threads.. like if ffmpeg was running double
[14:58] <armetiz> Hi there again
[14:59] <armetiz> I'm sorry, but I have read the documentation many times without any success
[14:59] <armetiz> I still don't understand how video filter "pad" work...
[17:18] <boo> When decoding and streaming video from dvb-t stick to rtmp ffmpeg always quits, at ~ 5.2 seconds, don't know why is this, the only thing that I found out is that by adding -analyzeduration 1500000000 I can extend the running time till 10.3 seconds.. Can anyone of you help me? I'm running ffmpeg witht this method - http://pastebin.com/ZFQcbp5H
[17:20] <boo> If I save the dvb-t stream to a file with 'cat' and paralel read it with ffmpeg, everything is ok
[18:04] <fluXx> Im on Debian using a compiled ffmpeg. If I download VLC from the Debian repos can I use my own ffmpeg binaries and just use VLC as a front end for playback. At times I do use ffplay.
[18:04] <fluXx> Don't mind compiling VLC if that is needed.
[18:06] <JEEB> I think you'll have to compile your own
[18:06] <JEEB> if you want to use the ffmpeg you compiled
[18:06] <JEEB> also, I recommend that if you compile by yourself that you use the 1.2 branch :)
[18:06] <JEEB> which is about to be released as far as I know, and probably supports newer libav* libraries
[18:07] <malinens> hi guys~! I have problems with ffmpeg live transcoding. input stream is x264 level 4.1 but output streams are level 3.0. I get about 5 seconds video freeze at the beginning (sound plays normally) ior green srtifacts at the beginning. what could be the problem?
[18:08] <fluXx> JEEB yeah don't really see a point of having cruft on my system. Hmm I am using ffmpeg version N-32328-g23934e5 not sure what you mean by 1.2
[18:08] <JEEB> VLC version 1.2
[18:08] <fluXx> ahh
[18:08] <JEEB> it seems to be in release candidate
[18:09] <JEEB> it also seems to have its own branch on the git repository
[18:09] <JEEB> thus, 1.2 branch
[18:10] <fluXx> Ill toss it into a VM and give it a spin. If I like the binaries I make I put automate (script) the entire bundle to be compile with a cron job.
[18:10] <JEEB> sounds good enough
[18:10] <fluXx> Thx for the feedback.
[18:21] <boo> anyone? :(
[18:25] <boo> anyone having info about analyzeduration?
[18:56] <elkng> I want to cut audio from 1:0 to the end, what the option I should use ?
[18:58] <snapper> hi
[19:03] <boo> Anyone? Help with analyze duratioN?
[19:17] <arbin> does ffplay usually have trouble selecting audio streams for playback?
[19:18] <arbin> I'm running ffplay -ss 00:01:49 -t 00:20:45 -ast 2 video_file.ext and it crashes, even though there are three audio streams
[19:18] <arbin> only seems to happen on 50% of the files
[19:34] <elkng> what the percentage of ffmpeg's use on piracy videos ?
[19:35] <snapper> doubt you could get an accurate answer for that elkng
[20:17] <Bombo> i encoded this: http://www.file-upload.net/download-4062198/video.mpg.html with "x264 --preset superfast --crf23 -o video.mp4 video.mpg" and result is this: http://www.file-upload.net/download-4062023/video.mp4.html but it wont mux (e.g. ffmpeg): "ffmpeg -i video.mp4 -vcodec copy muxed.mp4" error is: "[mp4 @ 025EC020] Application provided invalid, non monotonically increasing dts to muxer in stream 0: -7200 >= -7200 ...
[20:17] <Bombo> ... av_interleaved_write_frame(): Invalid argument" 1. why 2. what can i do to mux the video.mp4?
[20:19] <madsage> ahh sweet. ffmpeg channel
[20:20] <Bombo> tried muxing with l-smash "muxer -i video.mp4 -o video_muxed.mp4" -> "Error: failed to open input file."
[20:23] <madsage> i'm using ffmeg to rtmp stream to wowza, all my webapp players require a filename. any clue how i provide this? i want to use jwplayer but i cant figure out what to use for filename. it wants a filename with the rtmp stream url.
[20:23] <madsage> ffmeg/ffmpeg
[20:24] <madsage> i'm pretty green with this stuff. if that wasnt obvious. heh
[20:25] <madsage> my ffmpeg command like looks like this.   ffmpeg -i /root/usenet/done/Up/Up.mkv -threads 8 -vcodec libx264 -vpre slow -vb 500000 -strict experimental -acodec aac -ab 128000 -ar 48000 -ac 2 -f flv rtmp://
[20:25] <madsage> command line^
[20:26] <madsage> anybody around have any clue what i'm trying to do?
[20:30] <Mavrik> you're trying to use archaic version of ffmpeg with broken AAC encoder to stream live video :P
[20:31] <Mavrik> the problem with "player requiring filename" is something you need to solve in Wowza documentation
[20:36] <madsage> archaic version of ffmpeg?
[20:36] <madsage> FFmpeg version 0.6.1
[20:39] <Mavrik> yeah, that's even older than what ships with Ubuntu and even that one is old ;)
[20:41] <madsage> ahh ok. i can build from svn. this is what was in the yum RHEL 5.7 repo
[20:43] <madsage> my second problem is studdering. maybe newer version will help. seems to play HD nice for about 20secs and the stream hickups. but i was goign to try a differnt player. when i ran into the filename issue.
[20:43] <madsage> my machine is dual quad 2.66ghz with 16gig ram. shouldnt have any problem
[20:44] <madsage> okay first things first. upgrade ffmeg then search for the filename issue
[20:44] <madsage> thanks Mavrik, i have a direction
[20:48] <madsage> i'll try ffmpeg-0.9.1
[20:49] <Mavrik> madsage, yeah, I'm streaming to Wowza with MPEG-TS intead of RTMP, seems more stable
[20:49] <Mavrik> as for filename usage... go check Wowza mpeg-ts tutorial, it shows clearly how to access the live stream
[20:49] <madsage> ok cool. i appreciate your help. thanks
[20:56] <undercash> mavrick you can stream using ffmpeg?
[20:57] <Mavrik> yes.
[20:57] <undercash> but you need ffmpeg-mt no?
[20:57] <undercash> i m curious how it could work to stream to justin tv
[20:58] <undercash> since i can make vlc to do the job
[20:58] <undercash> cannot*
[20:58] <Mavrik> undercash, no, afaik ffmpeg-mt doesn't exist anymore
[20:58] <undercash> so any recent ffmpeg built can stream
[20:58] <Mavrik> depends on which format and container you need
[20:58] <undercash> you could give me an exemple of a command
[20:58] <undercash> i need to mux on mpeg ts too
[20:59] <undercash> }'}:rtp{dst=,port=1234,mux=ts,caching=4000,ttl=12,group=10,sdp
[20:59] <madsage> sweet, built nice and clean..  ffmpeg version 0.9.1
[20:59] <undercash> what i use for vlc..
[20:59] <undercash> no idea how this would translate with ffmpeg though
[20:59] <undercash> but it s pretty interesting
[21:00] <Mavrik> madsage, don't forget codecs you need :P
[21:01] <madsage> Mavrik, enable via configure? i was going to ask.. assumed maybe default configure file would be set for standard usage
[21:01] <Mavrik> madsage, well, if you don't have headers for libx264, libfaac or anything else you want to use it's not going to enable them
[21:02] <Mavrik> and IIRC it doesn't enable them even if you have them by default
[21:02] <madsage> yeah ok
[21:02] <Mavrik> (not sure about the last one)
[21:02] <madsage> i was goign to build and try
[21:02] <madsage> i believe i have all the dev headers installed
[21:02] <Mavrik> madsage, as I said, don't forget libx264 and libfaac
[21:03] <Mavrik> (or libvo_aacenc instead of libfaac)
[21:05] <madsage> oh yeah it helps to read
[21:05] <madsage> - Non system dependencies (e.g. libx264, libvpx) are disabled by default.
[21:06] <Mavrik> madsage, there's a great ubuntu guide in the topic ;)
[21:06] <madsage> yeah i'm using cent but should help. thanks
[21:14] <pasteeater> undercash: ffmpeg-mt was merged into ffmpeg some time ago.
[21:14] <undercash> hi pasteeater
[21:14] <undercash> ok
[21:14] <pasteeater> and i've used ffmpeg with justin.tv before, but that was just a video of my boring desktop
[21:15] <undercash> guess i should read the book ;)
[21:15] <undercash> i see
[21:15] <undercash> u remember of a command line maybe?
[21:15] <pasteeater> madsage: https://ffmpeg.org/trac/ffmpeg/wiki/CentosCompilationGuide
[21:17] <madsage> ahh ok cool. thanks for that
[21:17] <pasteeater> undercash: not really, but i'll try it...if i remember my login
[21:17] <undercash> i should look for rtp ffmpeg streaming i guess
[21:19] <undercash> assuming i find that working command i ll still have the problem of the sdp file , because I use jtvlc to send the stream to justin
[21:19] <undercash> unless ffmpeg can create this file
[21:23] <Mavrik> undercash, ffmpeg creates the SDP file when you start streaming
[21:23] <Mavrik> however I suggest you check if you can to RTSP, MPEG-TS(UDP) or RTMP which is easier to configure
[21:23] <undercash> yes i m reading that
[21:23] <undercash> if it creates sdp , it should be working
[21:31] <pasteeater> where do you find the stream key in justin.tv now? they've changed things since i logged in last time
[21:32] <pasteeater> ah, it's in http://www.justin.tv/broadcast/adv_other
[21:36] <undercash> yes
[21:36] <pasteeater> undercash: this worked fine for me: ffmpeg -f x11grab -r 30 -s 1024x720 -i :0.0 -c:v libx264 -preset ultrafast -crf 28 -f flv rtmp://live.justin.tv/app/<stream key>
[21:36] <undercash> wjen u chose destock streaming u have the key there
[21:37] <undercash> where is your input on this command?
[21:37] <pasteeater> -i :0.0
[21:37] <undercash> i need to put ffplay to play a file right?
[21:43] <Viper550> Are there FFmpeg binaries for 64-bit Windows?
[21:44] <Mavrik> Viper550, yeah, Zeranoe builds his here: http://ffmpeg.zeranoe.com/builds/
[21:45] <pasteeater> undercash: maybe something like this ffmpeg -i IronMan.mkv -c:v libx264 -preset fast -crf 32 -vf scale=iw/2:-1 -c:a libmp3lame -aq 7 -ar 44100 -f flv rtmp://live.justin.tv/app/<stream key>
[21:45] <pasteeater> my net connection is shit, so you'll need to tweak it to something less mental
[21:45] <pasteeater> workedforme
[21:46] <pasteeater> or use a video that's already good to go instead of re-encoding on the fly like my example
[21:47] <madsage> ffmpeg version N-37192-g88d84dd
[21:47] <madsage> wth is this. from trunk or something?
[21:48] <madsage> i used git clone
[21:48] <madsage> must be really new. =]
[21:50] <pasteeater> yes. N-<revision number>-<git hash>
[21:51] <undercash> thanks pasteeater
[21:51] <undercash> no luck yet but
[21:52] <madsage> pasteeater, thanks
[21:52] <madsage> was just currios
[21:58] <madsage> pasteeater, your cent compile url was a HUGE help. saved me hours. thank you
[22:00] <pasteeater> madsage: good. it's a wiki page, so anyone should feel free to modify/update/improve it.
[22:04] <madsage> worked like a champ, and all latest library releases
[22:04] <madsage> which all mine were old
[22:09] <undercash> [rtmp @ 0x217b020] Cannot read RTMP handshake response
[22:09] <undercash> rtmp://live.justin.tv/app/xxxxxx: Input/output error
[22:09] <undercash> it doesn't write any error using;    ffmpeg -i "input.mp4" -c:v libx264 -preset ultrafast -crf 28 -f flv rtmp://live.justin.tv/app/xxxx
[22:10] <undercash> but it doesnt do anything either
[22:21] <madsage> what does -crf32 do
[22:21] <madsage> err  -crf 32
[22:22] <madsage> i was lookign at the example pasted in the channel a few minutes ago
[22:22] <madsage> anyways i'm getting an error:  Error while opening encoder for output stream #0:1 - maybe incorrect parameters such as bit_rate, rate, width or height
[22:23] <madsage> when i try to use an mkv
[22:23] <madsage> ffmpeg -i Up.mkv -c:v libx264 -preset slow -vb 500000 -crf 32 -c:a libmp3lame -aq 7 -ar 44100 -f flv rtmp://
[22:24] <madsage> works with a .mp4 file, very nicely
[22:24] <madsage> oh i see it. i think
[22:25] <madsage> [libmp3lame @ 0x186eef40] Invalid number of channels 6, must be <= 2
[22:25] <Mavrik> madsage, -crf sets quality
[22:25] <undercash> crf define a flexible bitrate
[22:25] <madsage> ahh ok
[22:25] <Mavrik> madsage, don't use it with -vb because they can't be used together
[22:25] <madsage> i fixed the 6 channel
[22:25] <madsage> -ac 2
[22:25] <Mavrik> madsage, either you set bitrate or constant quality (crf)
[22:26] <madsage> crf should work well?
[22:26] <madsage> i'll try it
[22:26] <Mavrik> madsage, people usually prefer CRF
[22:26] <madsage> and the value 32?
[22:26] <Mavrik> because it makes files of similar quality
[22:26] <Mavrik> it's awful
[22:26] <Mavrik> start with ~25
[22:26] <madsage> ok
[22:26] <Mavrik> if your increase it, the quality worsens, if you lower it the quality gets better
[22:27] <madsage> its working =]
[22:27] <madsage> frame=  323 fps= 23 q=30.0 size=    1043kB time=00:00:10.63 bitrate= 803.1kbits/s
[22:27] <undercash> paasteater maybe it s because my rtmp port seems to be closed
[22:27] <madsage> ahh it just studdered :\
[22:27] <boo> trying to emerge ffmpeg http://pastebin.com/GxmJPuKH
[22:28] <boo> Mavrik, finally, you are here! :) so, I realized that if I set  -analyzeduration 1500000000 then the decoding stops not at 5.2 seconds, but at 10.3, so there's something related to that analyze thing
[22:29] <Mavrik> boo, that just means it pre-buffers a larger chunk of data to analyze it :)
[22:30] <boo> Mavrik, can you disable that analyzing? or doesn't it give somekind of a hint where's the problem
[22:38] <madsage> Mavrik, hey when you get a chance, you mentioned using MPEG-TS instead of RTMP and a wowza tutorial. i've searched and find that tutorial. i'll keep looking maybe its my keywords.
[22:39] <madsage> btw, i have the RTMP stearm lookign pretty nice now!  10x better just upgrading my tools
[22:39] <madsage> stearm/stream
[22:46] <madsage> man this looks so sweet. and it only studdered once. i'm doing the encoding and streaming from the same machine tho. oh and i forgot. i have assigned threads yet. i have a max of 8
[22:46] <madsage> have/havnt
[22:47] <madsage> one of our graphics guys just said it looks like blueray. i guess thats a compliment
[22:57] <jermy> boo/Mavrik: Remember there are two values related to analyzing - one for time, one for size
[23:00] <jermy> (size probably being probesize)
[23:28] <madsage> if i use -bufsize command and i buffering everything before output? so thsi should help with any studdering (inputt not keeping up with output)
[23:28] <madsage> and/am
[23:28] <madsage> the docs just say 'Set video buffer verifier buffer size (in bits).'
[23:30] <madsage> also one more question.  -aq which intiger is higher quality  1 or 10
[23:38] <boo> madsage, where from and how do you stream it? jermy, mn any ideas how to fix my ffmpeg from failing?
[23:39] <madsage> i'm streaming from a file
[23:39] <madsage> to wowza media server via RTMP
[23:40] <madsage> ffmpeg -i Up.mkv -threads 8 -c:v libx264 -preset fast -crf 20 -c:a libmp3lame -aq 7 -ar 44100 -ac 2 -f flv -bufsize 524288 rtmp://
[23:41] <madsage> Up.mkv is my media
[23:41] <madsage> and rtmp:// is where wowza media server pickup the feed
[23:41] <boo> madsage, why decided to take wowza, not red5? Was it difficult to set it up?
[23:42] <boo> madsage, I understand, I'm streaming dvb-t stick data to my rtmp server, have trouble with ffmpeg stopping because of the fact that input is a stream..
[23:42] <madsage> no pretty easy, and according to research i've done. wowza is the best as far as stability and load handling. my project will be used in production with some heavy loads
[23:43] <madsage> ahh, i havnt used ffmpeg with external input yet
[23:43] <madsage> i've seen some examples in my readings
[23:43] <madsage> googling around
[23:44] <madsage> you use red5? how is that one
[23:44] <madsage> i didnt even try it.
[23:45] <madsage> that was goign to be my alternative if i couldnt secure the wowza license
[23:45] <madsage> company i work for forked out for it
[23:46] <boo> madsage, setting up was 3sec, but I havn't configured it yet. Still sometimes seems that it acts wierd, Isn't wowza free?
[23:47] <madsage> wowza is comercial
[23:47] <madsage> they do have a 30day demos
[23:47] <boo> oh
[23:48] <boo> madsage I hate that input stream.. http://pastebin.com/vRAsWZCs if you don't have that analyzeduration, then ffmpeg manages to decode 5.2 seconds. if I set the analyze, then it fails at 10.3 sec
[23:50] <madsage> so you using a cam or what kind of media
[23:50] <boo> usb dvb-t stick
[23:50] <madsage> ahh ok
[23:50] <madsage> linux?
[23:50] <boo> yes
[23:51] <madsage> yeah you are using the /dev/whatever in the input path i take it
[23:51] <boo> could be that ffmpeg doesn't recognize some of the settings, therefore by trying to find some info it fails..
[23:52] <madsage> or are you piping the dvb device to another device
[23:52] <madsage> like some of the media centers do, myth comes to mind
[23:53] <boo> madsage, directly from the dvb-t stick to ffmpeg and then to red5
[23:53] <undercash> pasteeater do you know where ffmpeg create the sdp file?
[23:54] <madsage> boo, wish i could help with that. maybe see how mytv handles those devices. might be worth a look.
[23:55] <madsage> mythtv^
[23:55] <madsage> or maybe i'm complicating it too.
[23:55] <boo> madsage, will try to look around, this is driving me crazy for the 3rd day
[23:56] <madsage> i believe mythTV pipes the signal to a special device so as to seperate some of the otehr controls. like channel changing etc
[23:56] <madsage> if i'm not mistaken
[23:56] <madsage> ffmplayer maybe seeing that stuff i dont know
[23:56] <madsage> er ffmpeg
[23:58] <boo> should find a way to store for example ~ 10mb of that stream from dvb-t stick on hdd and then ffmpeg would take info from that
[00:00] --- Fri Jan 27 2012

More information about the Ffmpeg-devel-irc mailing list