[Ffmpeg-devel-irc] ffmpeg-devel.log.20120127

burek burek021 at gmail.com
Sat Jan 28 02:05:03 CET 2012

[00:24] <durandal_1707> hmm, why hflip is only tested for some pixfmts?
[00:27] <michaelni> it should be tested for all that it supports 
[01:05] <durandal_1707> Compn: you have videc.dll?
[01:05] <Compn> uhhh
[01:09] <durandal_1707> it is for fourcc VDEC
[01:09] <Compn> i dont see it on my drive
[01:09] <Compn> i'll have to look what installer installs it
[01:09] <Compn> do you have vdec sample ?
[01:11] <durandal_1707> Compn: downloaded sample from usual location
[01:11] <durandal_1707> vdec.avi in V-codecs, from 1996 year
[01:11] <Compn> oh cool
[01:11] <Compn> wonder when that showed up
[01:12] <durandal_1707> if ever manage to RE something ...
[01:14] <Compn> give me a few mins durandal_1707 , i'll try to locate dll again
[01:15] <Compn> durandal_1707 : ftp://ftp.logitech.com/pub/techsupport/quickcam/color/
[01:20] <Compn> and heres the dll file
[01:45] <durandal_1707> Compn: sending files via irc actually works?
[01:47] <Compn> it does if you hit accept butto n
[01:47] <Compn> want me to send again ?
[01:48] <durandal_1707> no need
[02:26] <CIA-108> ffmpeg: 03Martin Storsjö 07master * r8801fac365 10ffmpeg/tools/ismindex.c: 
[02:26] <CIA-108> ffmpeg: ismindex: Fix build on mingw
[02:26] <CIA-108> ffmpeg: Signed-off-by: Martin Storsjö <martin at martin.st>
[02:26] <CIA-108> ffmpeg: 03Alex Converse 07master * rd2ee8c1779 10ffmpeg/libavformat/matroskadec.c: 
[02:26] <CIA-108> ffmpeg: matroskadec: Pad AAC extradata.
[02:26] <CIA-108> ffmpeg: Found-by: Mateusz "j00ru" Jurczyk and Gynvael Coldwind
[02:26] <CIA-108> ffmpeg: CC: libav-stable at libav.org
[02:26] <CIA-108> ffmpeg: 03Janne Grunau 07master * rb3461c29c1 10ffmpeg/libavformat/utils.c: 
[02:26] <CIA-108> ffmpeg: lavf: prevent infinite loops while flushing in avformat_find_stream_info
[02:26] <CIA-108> ffmpeg: If no data was seen for a stream decoder are returning 0 when fed with
[02:26] <CIA-108> ffmpeg: empty packets for flushing. We can stop flushing when the decoder does
[02:26] <CIA-108> ffmpeg: not return delayed delayed frames anymore. Changes try_decode_frame()
[02:26] <CIA-108> ffmpeg: return value to got_picture or negative error.
[02:26] <CIA-108> ffmpeg: CC: libav-stable at libav.org
[02:26] <CIA-108> ffmpeg: 03Paul B Mahol 07master * r7de9af65c7 10ffmpeg/tests/ (lavf-regression.sh ref/lavf/xwd): 
[02:26] <CIA-108> ffmpeg: fate: add XWD image regression test
[02:26] <CIA-108> ffmpeg: Signed-off-by: Diego Biurrun <diego at biurrun.de>
[02:27] <CIA-108> ffmpeg: 03Alex Converse 07master * rdac56d9ce0 10ffmpeg/libavcodec/qdm2.c: 
[02:27] <CIA-108> ffmpeg: qdm2: Check data block size for bytes to bits overflow.
[02:27] <CIA-108> ffmpeg: Found-by: Mateusz "j00ru" Jurczyk and Gynvael Coldwind
[02:27] <CIA-108> ffmpeg: CC: libav-stable at libav.org
[02:27] <CIA-108> ffmpeg: 03Alex Converse 07master * r9adf25c1cf 10ffmpeg/libavcodec/smacker.c: 
[02:27] <CIA-108> ffmpeg: smacker: Sanity check huffman tables found in the headers.
[02:27] <CIA-108> ffmpeg: Found-by: Mateusz "j00ru" Jurczyk and Gynvael Coldwind
[02:27] <CIA-108> ffmpeg: CC: libav-stable at libav.org
[02:27] <CIA-108> ffmpeg: 03Michael Niedermayer 07master * r01fcbdf9ce 10ffmpeg/: (log message trimmed)
[02:27] <CIA-108> ffmpeg: Merge remote-tracking branch 'qatar/master'
[02:27] <CIA-108> ffmpeg: * qatar/master:
[02:27] <CIA-108> (4 lines omitted)
[10:00] <Tjoppen> bcoudu: what do you think about ignoring MaterialPackage and just looking for LinkedPackageUID in EssenceContainerData and just use the linked SourcePackage?
[10:02] <bcoudu> Tjoppen, that could be possible
[10:02] <Tjoppen> I got a fun sample at work with improperly linked SourceTracks, which got me thinking along those lines
[10:02] <Tjoppen> though it looks like I can nag them
[10:02] <bcoudu> although material is supposed to be the reference
[10:02] <Tjoppen> yeah. akin to MOV EDLs
[10:03] <Tjoppen> though we don't support StartPosition etc. atm :)
[10:03] <bcoudu> do people mess with startposition ? :)
[10:03] <Tjoppen> I ran mxf2dot on the file -> 15 MaterialTracks point to the same audio SourceTrack, including the video MaterialTrack :\
[10:04] <Tjoppen> so I'm going send a little note to them along the lines of "fix your muxer"
[10:04] <Tjoppen> I dunno. no one really uses MXF for what it's supposed to be used for AFAICT
[10:06] <Tjoppen> I could see one use case though: cutting out clips with sub-GOP precision
[10:07] <Tjoppen> odd. the file seems to have been written by MXF4mac. I thought they knew this stuff well enough to not make mistakes like these
[10:22] <bcoudu> true
[10:24] <Tjoppen> analysis sent. hopefully whomever is responsible fixes their code
[10:25] <Tjoppen> -ignore_mp AVOption could be useful. I'm not terribly concerned yet though
[11:41] <kierank> Compn: "i wish i could predict x264 merging with ffmpeg. that would be fun. then maybe x262 and xvp8."
[11:41] <kierank> x262 won't be merging with x264 fwiw
[11:41] <kierank> it's too unwieldy to maintain already
[13:06] <Compn> kierank : i meant x262  + ffmpeg
[13:11] <burek> something is broken with libaacplus in new ffmpeg, it gives segfault.. I'll need to investigate further with gdb
[15:27] <burek> is this a bug in configure script or I'm doing something wrong? http://pastebin.com/7Un8X4vp
[17:45] <durandal_1707> burek: perhaps it is looking for files in /usr/lib?
[17:46] <burek> hm, im pretty sure i apt-get removed all the stuff I compiled myself, but thanks, I'll check again
[17:46] <durandal_1707> this may (not) help: --extra-ldflags=-L/usr/local/lib
[17:46] <burek> oh, cool :)
[17:47] <burek> that way it first looks into /usr/loca/lib?
[17:47] <durandal_1707> it looks also in /usr/local/lib
[17:48] <burek> ok, I'll try that too
[17:49] <burek> bingo
[17:49] <burek> you're the man :D
[17:49] <burek> thanks! :beer:
[20:59] <ubitux> michaelni: it seems the max duration analysis is triggered by the fact that first_dts == AV_NOPTS_VALUE
[21:00] <ubitux> it also seems that not only mp3 are affected, but flac as well (and maybe more)
[21:06] <ubitux> the pts/dts stuff is really obscure to me
[21:06] <ubitux> and the heuristic in that file looks very complex
[21:06] <ubitux> do you have a hint on what i should look for?
[21:07] <nevcairiel> hm, do raw audio files like flac even come with timestamps?
[21:08] <ubitux> is flac really a raw audio file?
[21:08] <ubitux> iirc it can contains metadata and such
[21:08] <nevcairiel> hm
[21:08] <nevcairiel> i guess it can
[21:08] <ubitux> what makes it a "raw audio file" then?
[21:08] <ubitux> only one stream, and flac?
[21:09] <nevcairiel> dunno. I think of all files that contain only audio that way, for playback they don't need timestamps as every audio frame has a well defined duration (unlike video)
[21:09] <ubitux> mmh ok
[21:10] <nevcairiel> easy enough to check the flac demuxer and see if it fills pts/dts
[21:10] <nevcairiel> nope, it does not
[21:10] <ubitux> yep seems not
[21:11] <ubitux> so maybe the audio check could be removed here?: if(st->first_dts == AV_NOPTS_VALUE && (st->codec->codec_type == AVMEDIA_TYPE_VIDEO || st->codec->codec_type == AVMEDIA_TYPE_AUDIO)) 
[21:11] <nevcairiel> for real container formats it would still make sense, i suppose
[21:11] <ubitux> i guess it would break a lot of things here&
[21:12] <nevcairiel> mp3 doesnt even output full frames, it just always gives you 1024 bytes, relying on the parser to figure it out
[21:14] <ubitux> there is a parser check just above
[21:14] <nevcairiel> maybe a format flag would be helpful to identify such formats where waiting for a timestamp is useless
[21:14] <ubitux> but it doesn't seem to be triggered with the mp3
[21:15] <nevcairiel> flag on the demuxer, i mean
[21:15] <ubitux> mmh
[21:15] <ubitux> i remember a NOTIMESTAMP flag or something
[21:15] <ubitux> AVFMT_NOTIMESTAMPS
[21:15] <nevcairiel> oh right, that exists already
[21:16] <ubitux> the only decoder using it seems to be the ico one
[21:17] <nevcairiel> sounds reasonable to use it to disable the dts check in the probe function
[21:18] <ubitux> ok
[21:23] <ubitux> http://pastie.org/3265443
[21:23] <ubitux> this seems to do the trick
[21:24] <ubitux> thank you nevcairiel 
[21:28] <ubitux> mmh unfortunately this breaks some seeking
[21:29] <ubitux> (with mp2)
[21:32] <nevcairiel> hm, it does?
[21:35] <ubitux> yes http://pastie.org/3265511
[21:42] <ubitux> saste: oh you're here :)
[21:43] <ubitux> saste: as i said on ffmpeg-devel, i tried to copy_props in the filter_samples callback to fix the -t being ignored with ffmpeg
[21:43] <ubitux> as well as copying pts/dts in the samples ref
[21:44] <ubitux> but it didn't help
[21:44] <ubitux> i'm sure i'm just missing something to do in the that callback
[21:44] <ubitux> because it works before the rewriting with libswr
[21:44] <ubitux> any idea what could it be?
[22:58] <saste> ubitux: debugging debugging debugging
[23:01] <ubitux> ok :)
[23:44] <burek> can I get some more help with building ffmpeg as a static library
[23:44] <burek> I've managed to build the basic thing, without much external libraries
[23:44] <burek> and I noticed I don't have 'alsa' in indevs/outdevs
[23:45] <burek> so I checked config.log and these were the errors I've got: http://pastebin.com/e6hW0B2E
[23:45] <burek> this is how I configured all that: http://pastebin.com/Ld1SZWPX
[23:47] <burek> btw, I have libasound.a and libasound.la in /usr/lib
[00:00] --- Sat Jan 28 2012

More information about the Ffmpeg-devel-irc mailing list