[Ffmpeg-devel-irc] ffmpeg.log.20120127

burek burek021 at gmail.com
Sat Jan 28 02:05:01 CET 2012

[00:02] <madsage> that might be an option
[00:04] <boo> madsage, dumb q, but would it be possible to create an flv stream which would be at least watchable ( the quality) and would be streamed with ~ 30-40kb/s? :) I think there should, no problems with streeming perfect webcam video over skype..
[00:29] <michaelni> Welcome to the FFmpeg USER support channel | Development channel: #ffmpeg-devel | For bug reports, read: http://bit.ly/cqvkhs | Ubuntu compilation guide: http://bit.ly/3xSE5 | FFmpeg 0.10 is released | For x264 encoding use -preset and/or -tune and/or -profile | FFmpeg forum: http://ffmpeg.test-lab.ch/ | Prores lives! | This channel is publically logged
[00:30] <ubitux> better with the /topic :)
[00:41] <madsage> hey i have a problem. i am streaming a file via ffmpeg to wowza. it seems when ffmpeg finished encoding the wowza server stream stops. like ffmpeg is goign to fast
[01:04] <pasteeater> madsage: aq value is dependent on the encoder. for example the values will be different for libmp3lame and libfaac.
[01:05] <pasteeater> as for libmp3lame -aq is mapped to 'lame -V'
[01:06] <pasteeater> and for libfaac -aq is mapped to 'faac -q'
[01:06] <pasteeater> see http://wiki.hydrogenaudio.org/index.php?title=LAME#Detailed_explanation_.28long_answer.29
[01:06] <pasteeater> lower value is higher quality for libmp3lame -aq
[01:07] <pasteeater> undercash: no, i know nothing of sdp and rtmp
[01:07] <undercash> oki
[01:07] <undercash> it worked partially for me
[01:07] <undercash> just think i have a problem with rtmp port
[02:31] <Tony_V> so i'm trying to make a qcif (176x144) 3gp video for mobile using a 608x344 source video. the output still isn't coming out in widescreen
[02:32] <Tony_V> this is the command i'm using:
[02:32] <Tony_V> ffmpeg -i input.mp4 -f 3gp -s qcif -aspect 16:9 -vf scale=176:144 -vcodec h263 -b 200k -ar 24000 -ac 2 -acodec libfaac -ab 64k output.3gp
[02:32] <Tony_V> can anybody help a brotha out?
[02:33] <Tony_V> i think 608x344 for widescreen would be 176x100
[03:20] <pasteeater> Tony_V: -f 3gp -vf scale=176:-1
[03:55] <Tony_V> thanks pasteeater but it seems like i am getting this now:
[03:55] <Tony_V> [h263 @ 0x51ee20] The specified picture size of 176x100 is not valid for the H.263 codec.
[03:55] <Tony_V> Valid sizes are 128x96, 176x144, 352x288, 704x576, and 1408x1152. Try H.263+.
[04:36] <arbin_> Tony_V, try padding it out
[04:43] <DeezGz> hello every body
[05:22] <DeezGz> anyone in here
[09:04] <morteza> Hi can anyone help me ?
[09:04] <morteza> http://pastebin.com/4HjFy4dw
[09:05] <morteza> I can not convert wmv stream to .ffm
[09:05] <morteza> I want feed ffserver
[09:21] <morteza> any help for this paste bin: http://pastebin.com/4HjFy4dw
[09:21] <DeezGz> pastbin not valid
[09:22] <morteza> it's expired I think.
[09:22] <DeezGz> linux or windows
[09:22] <morteza> linux
[09:22] <DeezGz> do u have all the codec compiled
[09:23] <morteza> http://pastebin.com/B44EjSWW
[09:24] <morteza> I tried other commands changing vprofile or size with no success
[09:25] <DeezGz> i see
[09:25] <morteza> I want to feed ffserver
[09:25] <morteza> ;)
[09:28] <morteza> DeezGz may I ask for your help?
[09:28] <DeezGz> i dont know if i can help
[09:28] <DeezGz> is this a never ending stream?
[09:28] <morteza> yes
[09:29] <DeezGz> brb
[09:29] <morteza> I can convert it if I add -f mpegts but ffserver does not accept it
[09:32] <DeezGz> is ffm mp4 format?
[09:33] <morteza> how should I know?:D
[09:34] <DeezGz> lets google it to see
[09:34] <morteza> I couldn't find what is ffm
[09:36] <DeezGz> wait u where trying this huh?
[09:36] <DeezGz> ffmpeg -i "mmsh://" http://localhost:8090/imamhossein.ffm
[09:37] <morteza> yes
[09:37] <DeezGz> try this : ffmpeg -i "mmsh://" imamhossein.ffm
[09:37] <DeezGz> ffmped does not have a http server, and i wouldnt trust it to up load
[09:37] <morteza> its working now
[09:38] <morteza> :)
[09:38] <morteza> thank you. can you help me on ffserver?
[09:38] <DeezGz> i can try never used it befor
[09:39] <morteza> You know, I want to restream to rtsp and http
[09:39] <morteza> let me try it to see if I have any problem. I tried before with no success.
[09:39] <DeezGz> ok let see, u using ubuntu or what linux
[09:40] <DeezGz> do u have vlc?
[09:41] <morteza> ubuntu
[09:41] <morteza> I tried VLC
[09:41] <morteza> but it can not decode wmv3
[09:41] <morteza> I compiled both ffmpeg and vlc
[09:41] <DeezGz> ok wait one sec
[09:41] <morteza> I could get ffmpeg decode wmv3 but vlc can not decode it.
[09:41] <morteza> ok.
[09:44] <DeezGz> ok still looking brb
[09:48] <DeezGz> you said ffserver
[09:48] <morteza> yes
[09:48] <DeezGz> ok let me look
[09:49] <morteza> I could get ffserver running but I can not get rtsp out of it!
[09:52] <armetiz> Hi there,
[09:52] <morteza> Hi
[09:52] <armetiz> I'm trying to script ffmpeg encoding inside a Sheel script.
[09:52] <DeezGz> ask hi see if he can help
[09:52] <morteza> he has a problem for himself;) :D
[09:53] <DeezGz> hello armetiz, do u know how to work ffserver to stream a rstp stream
[09:53] <armetiz> I transform some 4/3 to 16/9 adding some pad. It work fine with static value and with specific input size / output size.
[09:53] <armetiz> DeezGz, I donno
[09:53] <DeezGz> ok
[09:54] <DeezGz> thx
[09:54] <armetiz> And I want to know If ffmpeg generate "variable" that can be reused concerning widthXheight of video input.
[09:54] <armetiz> I say this, because I have see that -vf & pad can be used with some variables.
[09:55] <armetiz> like in_w or in_h..
[09:56] <armetiz> DeezGz, I'm using HTTP server with x264 code-shop module to stream videos.
[09:56] <DeezGz> ok
[09:56] <DeezGz> linux right
[09:57] <armetiz> yes
[09:57] <armetiz> unix based I guess
[09:58] <DeezGz> yea i dont know about the var, i think it is possible with ffmeg
[09:58] <DeezGz> its for the web right
[09:59] <armetiz> I'm looking on google.. But, all resultat that I got is about using ffmpeg information about video & shell extraction. But, it's not so easy as ffmpeg solution :p
[09:59] <DeezGz> sorry morteza i am look for ffserver for win, i dont feel like lunching my vm and compileing ffmpeg and ffserver right now
[10:00] <DeezGz> yea documentation is all over the place in et languge
[10:01] <morteza> DeezGz Its not a problem with win or linux
[10:01] <morteza> :)
[10:01] <morteza> anyway thank you for your help
[10:02] <morteza> why do you need to compile ffserver or ffmpeg?
[10:02] <DeezGz> i dont have a unix env to help you
[10:02] <morteza> aha.
[10:02] <DeezGz> my vlc cond decode the stream just fine
[10:03] <DeezGz> but yours has a codec that wasnt compile for you vlc
[10:03] <morteza> yes in my own desktop ubuntu I can use vlc to decode wmv
[10:03] <DeezGz> so u can
[10:03] <DeezGz> ???
[10:03] <morteza> but in server I can not. I don't know what is happening
[10:03] <morteza> ( In my own ubuntu desktop I can, in my server with ubuntu server I can not )
[10:04] <morteza> I tried many libraries, compiling from source, installing from repositories
[10:04] <morteza> but couldn't get vlc decoding wmv
[10:04] <DeezGz> yea got to compile your self with the right depen and the right switches
[10:05] <DeezGz> its a pain and the ass
[10:06] <morteza> I'm wondering why two ubuntu systems with same versions differ;)
[10:06] <DeezGz> what do u mean
[10:07] <DeezGz> like server vs desktop version
[10:07] <DeezGz> its the packages it comes with that all
[10:07] <morteza> the only difference is x11
[10:08] <morteza> I installed all other libraries related to audio and video
[10:08] <morteza> like gstreamer
[10:08] <DeezGz> yea a package its more then that too
[10:08] <morteza> maybe.
[10:08] <DeezGz> you have to have the right codecs from speacial repos to work or compile with the right switchs
[10:09] <DeezGz> very very time consuming, you have to right a compile script to get it right
[10:09] <DeezGz> do u have a windows machine anywhere
[10:10] <morteza> I have but it's not a server
[10:10] <morteza> dual boot with my laptop
[10:10] <DeezGz> i doesnt have to be
[10:10] <DeezGz> use it with vlc stream
[10:11] <DeezGz> it
[10:11] <DeezGz> it will work without the hassales
[10:11] <morteza> aha. I know.
[10:12] <morteza> I can do it from my desktop ubuntu as I said.
[10:17] <DeezGz> ok go to rtsp://
[10:17] <DeezGz> im streaming your stream from windows
[10:17] <morteza> yeah it's working
[10:18] <morteza> :(
[10:18] <DeezGz> so either use you desk top or win for now
[10:18] <DeezGz> but the server has to compile the right codec for it to work
[10:18] <DeezGz> if u can do vlc, it can do it all
[10:20] <morteza> Thank you for your attention
[10:20] <morteza> it really helped.
[10:21] <DeezGz> thank you
[11:09] <X0n> hi, I have a flv file 1024x720 and I want to resize it to 512x, is it possible to do it without loose to much quality ? thanks
[11:10] <Mavrik> well... yeah
[11:10] <X0n> oups it's 1024x576
[11:10] <X0n> and just want to divide this video /2
[11:10] <Mavrik> X0n, you'll have to reencode the video though
[11:11] <Mavrik> X0n, check the bitrate of your current video
[11:11] <Mavrik> then do something like
[11:11] <Mavrik> ffmpeg -i <file>.flv -codec:v libx264 -preset slow -b:v <bitrate> -vf scale=iw/2:ih/2 -codec:a copy output.flv
[11:12] <X0n> Mavrik, wow ;) how can I know bitrate ? (I'm noob with videos)
[11:12] <Mavrik> um
[11:12] <Mavrik> X0n, approx. (filesize in KB * 8) / (seconds of length)
[11:13] <X0n> Mavrik, ok Mavrik I try this thanks a lot
[11:13] <Mavrik> X0n, sadly there's no better way of determining the bitrate
[11:13] <Mavrik> X0n, also, since you're cutting the video size in half you can lower bitrate... try using just 60% or so of the number so you get a smaller file :)
[11:14] <X0n> Mavrik, ok I'll try this
[11:14] <X0n> Mavrik, bitrate can be 33245 kb/s ?
[11:15] <Mavrik> yeah but that's really really high :D
[11:15] <Mavrik> for 512xsomethin take something like 700k
[11:15] <Mavrik> or even less :)
[11:16] <X0n> ok
[11:16] <X0n> I try
[11:16] <Mavrik> (don't forget the k)
[11:16] <X0n> ffmpeg: unrecognized option '-codec:v'
[11:16] <X0n> hum
[11:16] <Mavrik> er
[11:16] <Mavrik> just how old is your ffmpeg? :)
[11:17] <X0n> FFmpeg version SVN-r0.5.6-4:0.5.6-3 <== debian stable
[11:17] <X0n> I'll try on ubuntu
[11:17] <X0n> same
[11:18] <X0n> FFmpeg version 0.6.4-4:0.6.4-0ubuntu0.11.04.1
[11:18] <Mavrik> pre-packaged FFmpegs are old
[11:18] <Mavrik> X0n, use -vcodec instead of "codec:v", -acodec instead of "codec:a"
[11:18] <X0n> ok
[11:19] <X0n> ffmpeg: unrecognized option '-preset'
[11:19] <X0n> unlucky
[11:19] <Mavrik> ok, update your ffmpeg
[11:19] <Mavrik> if it's so old that it doesn't recognise -preset, your libx264 output will be garbage
[11:19] <Mavrik> check the topic for guide, current version is 0.10
[11:19] <X0n> I'll grab git one
[11:19] <Mavrik> grab release/0.10 branch, masters can be unstable
[11:20] <X0n> oki
[12:43] <haled> do I need to compile ffmpeg myself to enable -acodec libmp3lame (Ubuntu)?
[12:47] <X0n> thx Mavrik it's works like a charm
[12:48] <Mavrik> haled, I think you just need the "-extra" libav versions from restricted repos
[14:00] <morteza> hi
[14:00] <morteza> It seems I don't have default presets for ffmpeg to use with vpre
[14:01] <morteza> -vpre hq or any other one does not work
[14:02] <Mavrik> new versions use -preset
[14:02] <Mavrik> to use libx264 built-in presets
[14:02] <Mavrik> update ffmpeg and use taht
[14:05] <morteza> I use -vprofile baseline
[14:06] <morteza> but ffmpeg says default configs broken
[14:06] <morteza> use vpre
[14:07] <Mavrik> yes
[14:07] <Mavrik> because your FFMpeg is REALLY old
[14:08] <morteza> I just compiled it!
[14:08] <Mavrik> well
[14:08] <Mavrik> morteza, http://www.virag.si/2012/01/web-video-encoding-tutorial-with-ffmpeg-0-9/
[14:10] <morteza> Mavrik I want to convert a video from wmv3 to h264 with ffserver
[14:10] <morteza> may I pastebin the config and ask you to take a look?
[14:11] <mdsh> Can I use the movie filter to load image2 style pngs?
[14:11] <mdsh> I thought -vf movie=text%04d.png:f=image2 would work
[14:12] <mdsh> but it doesn't: [movie @ 0xb6a59a0] Failed to avformat_open_input 'text/text%04d.png'
[14:18] <morteza> http://pastebin.com/muxL8DRJ
[15:28] <burek> morteza, use newer ffmpeg
[15:29] <burek> also, try libaacplus instead of just aac
[15:29] <burek> you can use hiQ audio at bitrates as low as 32kbps
[15:35] <madsage> libaacplus huh is that a better codec than using libmp3lame? thats problably apples and oranges?
[15:35] <madsage> i went to libmp3lame from aac
[15:37] <madsage> i'm having another issue. seems my ffmpeg stream to my wowza server finishes before the live stream from wowza and causes the wowza server to end premature. how do i deal with that.
[15:38] <madsage> i'd appreciate any feedback if anybody has resolved or ran into this
[15:39] <madsage> i'm using rmtp:
[15:47] <burek> madsage, libaacplus is the future today
[15:47] <burek> youtube is using it
[15:47] <burek> aac+ is not same as aac
[15:47] <madsage> ok cool
[15:48] <madsage> i'll re-compile with it
[15:48] <madsage> any idea on my second question?
[15:49] <madsage> the ffmpeg stream finishing before the wowza live stream output?
[15:50] <burek> libaacplus: http://tipok.org.ua/ru/node/17
[15:51] <burek> madsage
[15:51] <burek> can you please use pastebin.com, to show your command line and its output?
[15:51] <madsage> yeah its just one line
[15:51] <madsage> ffmpeg -i /usr/local/WowzaMediaServer/content/Extremists.m4v -threads 0 -c:v libx264 -preset slow -crf 25 -c:a libmp3lame -aq 5 -ar 44100 -ac 2 -f flv rtmp://
[15:51] <burek> try ffmpeg -re -i ..
[15:52] <madsage> then wowza picks up the stream and broadcasts it rtmp on the wan interface
[15:52] <madsage> is it a buffer issue with wowza?
[15:52] <madsage> ffmpeg seems to be doing its job
[15:53] <madsage> too good almost. heh
[15:53] <madsage> i prolly need to consult with wowza on this one
[15:53] <madsage> ok
[15:54] <madsage> trying -re
[15:54] <madsage> hope its that simple]
[15:55] <madsage> i'm a noob at this stuff so pardon my ignorance
[15:55] <madsage> were learning
[15:56] <madsage> ahh already i can tell its differnt. two connects are in sync, they were not prior
[15:56] <madsage> connects/connections
[15:57] <madsage> they are within milliseconds atleast
[15:58] <madsage> it stopped again :\
[15:58] <burek> wait
[15:58] <burek> it stopped because
[15:59] <burek> it reached the end of file
[15:59] <burek> what's wrong with that
[15:59] <madsage> yes
[15:59] <madsage> well the wowza media server detects no more input and didnt finish what was streamed to it
[15:59] <burek> do you want to loop the input
[15:59] <madsage> i will yes
[15:59] <burek> -loop 1
[16:00] <madsage> ok cool. i was thinking of doing it in a bash script
[16:00] <madsage> but thats a nicer option
[16:00] <burek> ffmpeg --help has a lot of nice options :D
[16:00] <madsage> hehe sorry
[16:00] <burek> also this http://ffmpeg.org/ffmpeg.html
[16:00] <madsage> i'll read more too
[16:01] <burek> ok :)
[16:02] <madsage> is there any other options for streams that wont be intended to loop? or thats goign to be a function of wowza past this point.
[16:02] <madsage> obviously ffmpeg is doing what it is supposed to
[16:04] <burek> well, I'm not sure if I understand
[16:04] <burek> but
[16:04] <burek> ffmpeg sends stream to wowza
[16:04] <burek> and when the connection closes
[16:04] <burek> wowza ends the stream too?
[16:04] <burek> right?
[16:04] <madsage> yes
[16:05] <burek> so, what is your expected behavior?
[16:05] <madsage> it seems wowza detects end of ffmpeg stream and decides the stream is done
[16:05] <burek> and it isn't?
[16:05] <madsage> well i'm thinking its buffered and should continue to end of buffer
[16:06] <madsage> but again, i understand this is goign to be a function of wowza more than likely
[16:06] <burek> how much of a stream is lost?
[16:06] <madsage> like in some cases 70%
[16:06] <madsage> my box is that fast it appears
[16:06] <burek> -re will make ffmpeg read its input more slow, like real-time
[16:06] <madsage> that fast with the encoding
[16:07] <burek> and not to read all and burst into the stream
[16:07] <madsage> yeah i added that i got further
[16:07] <madsage> but still finished at about 50%
[16:07] <burek> so, i'm not sure why do you lose 70% of the stream
[16:07] <burek> it would be a good idea to ask wowza support team :)
[16:08] <madsage> yeah i appreciate the help, thought maybe somebody had ran into this before
[16:08] <burek> ok :) :beer:
[16:08] <madsage> and might have an idea. ffmpeg is doing a fine job
[16:08] <madsage> ok man, enjoy that beer. wish i could buy you one for your help
[16:09] <burek> :)
[16:18] <morteza> Any opensource program like wowza?
[16:19] <morteza> what do you recommend?
[16:24] <burek> ffserver? :)
[16:24] <burek> vlc
[16:25] <morteza> I tried VLC it's buggy in linux
[16:25] <morteza> it can not decode wmv3 even when it has codecs
[16:26] <morteza> anyway, if ffserver or vlc can do the job why one pay $996 for wowza?
[16:34] <FunkyELF> I just upgraded ffmpeg versions on Fedora 16.  I can no longer use -acodec libfaac .... but I noticed I can use -acodec aac if I use -strict experimental
[16:34] <FunkyELF> is this using the same encoder?... for -acodec did libfaac got renamed to aac?
[16:35] <burek> morteza, did you use git version of vlc?
[16:35] <burek> FunkyELF, if you can, compile your ffmpeg
[16:35] <burek> and use libaacplus
[16:35] <burek> its WAY better
[16:38] <morteza> yes
[16:39] <morteza> burek I used latest ffmpeg and vlc from git
[16:39] <morteza> to compile
[16:39] <morteza> I still get this http://pastebin.com/muxL8DRJ
[16:39] <burek> well, I don't know then.. If vlc can't play it, then it's skinny chance to find something that's open source to work
[16:40] <FunkyELF> burek, I compiled it
[16:40] <burek> morteza, that pastebin doesn't show anything
[16:40] <burek> it's just cmd line + ffserver config
[16:41] <FunkyELF> burek, I have a little cheat sheet that used to work and then I could use -acodec libfaac.  Now it doesn't work, so I'm wondering if -acodec aac is the same as -acodec libfaac used to be
[16:41] <burek> i think libfaac support has been dropped
[16:41] <burek> you can read changelog
[16:41] <burek> ctrl+f "libfaac"
[16:43] <morteza> http://pastebin.com/UgGzCUzp
[16:43] <morteza> sorry it was a wrong link;)
[16:43] <morteza> I want to setup ffserver with this feed
[16:43] <FunkyELF> burek, from "version 0.4.9-pre1:" I see "- AAC encoding with libfaac"
[16:44] <FunkyELF> burek, this is how I build ffmpeg on Fedora http://pastebin.ca/2106802
[16:46] <burek> let me see
[16:47] <burek> morteza, drop vprofile, use profile
[16:47] <burek> also read x264 --help
[16:48] <burek> (to see profiles, presets and tunes
[16:48] <burek> FunkyELF, I'm not sure
[16:48] <burek> if that's the latest git version of ffmpeg
[16:49] <burek> however
[16:49] <burek> you can try typing ./configure --help | grep libaacplus
[16:49] <burek> wait, you want libfaac support?
[16:54] <FunkyELF> burek, I just rebuilt it without the "--with faac" flag and it still lets me use -acodec aac when I add -strict experimental
[16:55] <JEEB> -acodec aac is ffaac, which is libavcodec's internal aac encoder
[16:55] <JEEB> which also happens to not really great
[16:56] <FunkyELF> so libaacplus is what I want?
[16:56] <JEEB> if you want HE-AACv2
[16:56] <FunkyELF> I'm just not sure how that maps to the rpmbuild command
[16:56] <JEEB> not all devices can take HE-AAC to begin with
[16:56] <FunkyELF> I want something so that my android phone can play converted videos
[16:56] <JEEB> ok
[16:56] <JEEB> just use ffaac then
[16:56] <FunkyELF> I used to use libfaac
[16:56] <JEEB> it'll be OK as long as the bitrate's not too low
[16:57] <JEEB> you can still use it
[16:57] <FunkyELF> don't know what happened or why it stopped working
[16:57] <JEEB> --enable-nonfree in the configure
[16:57] <JEEB> and --enable-libfaac
[16:58] <FunkyELF> I see --enable-libfaac listed in my configuration (the thing it prints out every time you run ffmpeg) but then I get Unknown encoder 'libfaac'
[16:59] <JEEB> then it wasn't built with it
[16:59] <FunkyELF> I also see --enable-nonfree
[16:59] <FunkyELF> so it was built with it, but then it still says Unknown encoder 'libfaac'
[16:59] <JEEB> it would be easier to see if you had the config.log out of that build
[16:59] Action: FunkyELF runs sudo updatedb
[16:59] <JEEB> in any case, -acodec libfaac should work
[17:00] <JEEB> or wait
[17:00] <JEEB> how the hell can you have libfaac in a repository?
[17:00] <JEEB> it's non-free
[17:00] <JEEB> you can't possibly give out binaries with it enabled
[17:00] <JEEB> you'd have to build it yourself
[17:00] <FunkyELF> JEEB, I added the rpmfusion repo
[17:01] <FunkyELF> I don't see any files named config.log
[17:01] <JEEB> I have absolutely no idea what that is, but if they're still giving out binaries with libfaac they're doing it wrong
[17:01] <JEEB> and it might be that they just got wiser
[17:01] <JEEB> and disabled libfaac from the binaries
[17:01] <JEEB> :P
[17:02] <FunkyELF> I isntalled faac from rpmfusion-nonfree, then I built ffmpeg myself using rpmbuild --rebuild ffmpeg*.src.rpm --with faac
[17:02] <FunkyELF> pretty sure I got the binaries from rpmfusion-nonfree
[17:04] <JEEB> libfaac -- possibly. Anyways, you might want to list the available codecs in your compile
[17:04] <JEEB> there was a switch for that IIRC
[17:05] <FunkyELF> ffmpeg -codecs | fpaste
[17:05] <FunkyELF> http://fpaste.org/w1Sg/
[17:07] <morteza> burek, I drop -vprofile and used -profile baseline with no success. I don't know what's wrong with it
[17:13] <relaxed> -profile:v baseline
[17:15] <burek> FunkyELF, AAC is the ancient version of audio codec (v0), AAC-LC is its successor (v1) and AAC-HE(v2) is the aac+ which also youtube uses
[17:15] <burek> if you want to have brilliant audio quality, use aac+ (but its not GPL, if you need that)
[17:16] <burek> it's way better than mp3 too
[17:16] <JEEB> AAC-HE(v2) is the aac+ which also youtube uses <- as far as I know, it doesn't
[17:16] <burek> whatever
[17:16] <burek> every video I've downloaded, was using he-aac
[17:16] <JEEB> orly
[17:16] <burek> it's preety much the majority
[17:16] <JEEB> I think they used mostly LC-AAC
[17:16] <burek> well use VLC to see the audio codec info
[17:17] <burek> 90% is aac+
[17:17] <burek> if not 100%
[17:17] <burek> morteza
[17:17] <burek> can you please use pastebin.com, to show your command line and its output?
[17:19] <relaxed> all the stuff I have downloaded from youtube is LC
[17:19] <burek> ok let's see
[17:19] <burek> let me open the frontpage of youtube
[17:20] <burek> and see a random video info
[17:22] <burek> hm.. it appears AAC-LC
[17:22] <burek> i dont understand now..
[17:23] <JEEB> it might use HE-AAC for very low bitrate things where the recepient can always take in HE-AAC
[17:23] <JEEB> but I haven't seen such yet
[17:23] <morteza> burek let me tell you what I'm doing and I will use pastebin
[17:24] <burek> i really cant figure out what happened
[17:24] <morteza> I'm trying to feed ffserver with a live stream. its mmsh in wmv3 format
[17:24] <burek> i started using aac+ because of that
[17:24] <burek> and now it appears as if i was wrong all the time
[17:25] <morteza> and I want to get rtsp output to play it on android
[17:25] <burek> and i know what i saw
[17:25] <relaxed> burek: everything youtube streams is encoded on the fly. maybe they changed their policy and that's why you don't see it anymore.
[17:25] <JEEB> anyways, if HE-AAC sounds good enough for you and you like the low bitrates -- nothing bad with that
[17:25] <burek> well who wouldn't like low bitrates? :)
[17:26] <burek> i do have a good bandwidth, but not everyone has :)
[17:26] <JEEB> those people who want the actual sound -- not something that sounds "good" yet isn't the same thing
[17:26] <JEEB> and don't start giving me that bullshit any more thank you
[17:26] <morteza> burek here is my ffserver config
[17:26] <morteza> http://pastebin.com/ddR2x99L
[17:26] <JEEB> enjoy it yourself but don't try to push it down everyone's throat
[17:26] <burek> JEEB, I don't know your experience with aac+, but aac+ doesn't sound "good" it sounds extraordinary
[17:27] <burek> I tested it with classical music which is the hardest thing to efficiently encode
[17:27] <morteza> burek and this is the command I use to feed ffserver ;
[17:27] <morteza> ffmpeg -i "mmsh://" -vcodec libx264 -vprofile baseline -level 1 -b:v 64k -s 240x160 -strict experimental -acodec aac -ac 1 -ab 24k -f mpegts
[17:27] <burek> considering its spectral range
[17:27] <JEEB> also, it's very much possible what relaxed said, but to be honest I didn't see anything PC-related get HE-AAC
[17:27] <burek> it sounded identical to the original
[17:27] <JEEB> mobile stuff might be getting HE-AAC, _but_ I do remember getting the usual artifacts there with the lowest bitrate level
[17:28] <JEEB> whatever it is, it's not what you think it is
[17:28] <burek> and if you are actually comparing aac-lc and aac-he, I think he-aac will beat it like 5-6 time
[17:28] <burek> morteza, vlc can do that too, I know
[17:28] <Mavrik> <JEEB> whatever it is, it's not what you think it is
[17:28] <Mavrik> JEEB, would you care to explain that?
[17:29] <JEEB> it is not his super special HE-AAC
[17:29] <morteza> burek I know vlc can, I did it before. but this time I can not get vlc working, decoding wmv3
[17:29] <JEEB> as far as I could think of by the artifacts
[17:29] <morteza> I don't know what's wrong with it.
[17:29] <burek> what artifacts?
[17:29] <JEEB> Mavrik, burek is this guy who keeps recommending HE-AAC(v2) to everyone and their mom
[17:30] <burek> well I wouldn't do it if it wasn't this good
[17:30] <Mavrik> JEEB, yeah, I know...
[17:30] <burek> what's wrong in suggesting people the good stuff?
[17:30] <JEEB> it is good for what it's meant for, that's all I mean
[17:30] <Mavrik> JEEB, I'm actually using the AAC+ on my low-bitrates as well... I'm just wondering what you meant with "it isn't what you think it is"
[17:30] <JEEB> Mavrik, he thought youtube is all HE-AAC
[17:31] <Mavrik> getting some insights about AAC+ is kinda hard... I did notice that AAC+ tends to sound better on really low bitrates
[17:31] <Mavrik> ah, ok
[17:31] <JEEB> also, yes -- HE-AAC is my recommendation for low bitrates.
[17:32] <burek> wait
[17:32] <JEEB> The thing is, though, that it isn't an accurate'ish depiction. Anyone who can actually bother to read what the encoder does can tell you that. It's just good at getting a relatively similar sound to you with low bitrates, that is what it is for.
[17:32] <burek> what exactly do you mean by "low bitrates"
[17:32] <JEEB> anything under 96-64kbps
[17:32] <burek> yes but
[17:32] <burek> are you talking about input or output
[17:32] <JEEB> huh
[17:32] <JEEB> you really are there in the woods
[17:33] <JEEB> now go get some coffee and come sit back
[17:33] <burek> if I get a superb audio quality at 32kbps output, what can possibly be wrong in that?
[17:33] <Mavrik> mhm
[17:33] <burek> it's like when you say for 7zip "it is good for what it's meant for, that's all I mean"
[17:33] <Mavrik> JEEB, any insights what to use for higher bitrates? It seems to me LC-AAC is prevalent there
[17:33] <burek> you get a small file (which was your goal after all)
[17:34] <burek> aka low bitrates
[17:34] <JEEB> Mavrik, some good LC-AAC encoder (qt, nero) or Aotuv's vorbis
[17:34] <morteza> where can I find all available options for ffserver?
[17:34] <Mavrik> I was afraid you're going to say that ^^ :)
[17:34] <burek> morteza, http://ffmpeg.org/ffserver.html
[17:35] <burek> i just don't understand who would want "higher bitrates" when one can get 32kbps?
[17:35] <JEEB> You get an audio image that sounds close enough for you burek -- that's all. If that is all you're after and you are ready to sacrifice both decoder compatibility as well as actual closeness to the source (instead of just mimicing similar sounds -- although that's what they all do in a way), we have nothing to discuss here
[17:35] <burek> it's like you want a bigger file when testing compressions software
[17:36] <relaxed> morteza: the setting you need to use is "-profile:v baseline", not "-profile baseline".
[17:36] <JEEB> someone who knows the AAC specs please put it in more technical terms for burek please
[17:36] <burek> no need
[17:36] <burek> I really don't see the point of it
[17:37] <Mavrik> anyway, more importantly: anyone managed to test the new ffmpeg thumbnail filter? :)
[17:37] <JEEB> or tell me that I'm incorrect and that HE-AAC(v2) is overall optimized for various scenarios where closer replication is needed instead of just "something that sounds similar"
[17:37] <burek> :)
[17:38] <burek> whatever man :) what ever you find better for your own usage :)
[17:38] <Mavrik> JEEB, honestly, isn't that what pretty much all lossy compression algorithms do? :)
[17:38] <JEEB> Of course
[17:38] <JEEB> but HE-AAC, esp. the first spec -- seems to have really been just optimized to give out a similar'ish sound with too big artifacts on low bitrates
[17:39] <JEEB> I'm less knowledge'able about the second spec, but I don't think it differs much as their area is similar
[17:40] <burek> well that's what i ask you all the time
[17:40] <burek> what do you mean by "on low bitrates"
[17:40] <Mavrik> JEEB, the second spec just adds something similar to "joint stereo", where you store the audio as a mono track with deltas for other channels
[17:41] <Mavrik> so again it's really just made for low-bitrate usage with nothing to gain when you need actual replication of original sound
[17:42] <burek> would anyone care to explain what do you mean by "low-bitrate usage"
[17:43] <burek> to me it sounds just like flac, just the output is way more compressed
[17:44] <Mavrik> burek, use cases when achieving low bitrate with decent sound quality is more important than achieving maximum sound quality
[17:44] <burek> that's the problem
[17:44] <burek> I'm not talking about "decent"
[17:44] <burek> man, the quality is extraordirany
[17:44] <burek> I compressed classical music
[17:44] <Mavrik> the quality is OK :)
[17:45] <burek> which sounded the same as original
[17:45] <burek> is that "decent" enough?
[17:45] <JEEB> it's decent enough if you can't spare more bits
[17:45] <burek> why would you want to spare more bits?
[17:45] <burek> to create a 7zip compressor which produces bigger output files? :D
[17:45] <JEEB> you're comparing lossy and lossless compression here
[17:46] <burek> yeah, i was ironic
[17:46] <burek> in case you didn't notice
[17:46] <JEEB> ask someone who has dealt with the internals of that codec and see if that person would use it for quality purposes
[17:46] <JEEB> and preferably someone with his foot on the ground
[17:46] <Mavrik> burek, because sometimes you just need more quality than HE-AAC+ can provide
[17:46] <JEEB> or want to achieve it
[17:46] <Mavrik> yeah
[17:46] <JEEB> not to mention that in most cases the audio bitrate iis already small
[17:47] <Mavrik> either you have a better sound system, or other requirements
[17:47] <JEEB> it's when the audio bitrate gets to be 1/2 of video bitrate or so
[17:47] <Mavrik> or your stream is even more complex
[17:47] <burek> ok, never mind
[17:47] <JEEB> when you want to start thinking about compressing it more because it makes no sense if the video is the main part
[17:48] <burek> i respect your opinions, although i don't agree, but ok
[17:48] <burek> diversity makes world the better place anyway :)
[17:49] <JEEB> when your video bitrates are 1000kbps+ the difference between a 192kbps audio track and 32kbps audio track is no longer that big
[17:49] <JEEB> heck, for DVD backups where the AC3 track is 320kbps+ I'd prolly leave it too
[17:49] <Mavrik> btw, how does AC3 match up to MP3/LC-AAC?
[17:50] <JEEB> crap IIRC
[17:50] <JEEB> now, when we have a specific need of getting video + audio into, say, 300kbps
[17:50] <burek> well in that case, why not use flac?
[17:50] <JEEB> that's where HE-AAC shines
[17:50] <burek> why bother with aac-lc
[17:50] <Mavrik> burek, because you don't have a decoder available
[17:50] <JEEB> because FLAC breaks the camel's back
[17:50] <JEEB> because you'll end up with 700kbps+
[17:50] <burek> or any other lossless audio encoder
[17:50] <burek> for that matter
[17:50] <JEEB> at least in most of my audio tracks that are  2ch
[17:51] <JEEB> you end up doubling and almost getting to the video bitrate
[17:51] <burek> if you need brilliant audio quality, 100% of the original, use lossless audio encoder
[17:51] <burek> no biggie
[17:51] <JEEB> of course, but the audio is not the main thing here
[17:52] <JEEB> we can spare some extra bits, but there's an amount that just takes it beyond diminishing returns usually
[17:52] <JEEB> more than 320kbps-500kbps for 2ch f.ex.
[17:52] <JEEB> unless you are doing something where the audio has to be sample-exact
[17:53] <burek> ok, but generally speaking, if you don't care about bitrates, use lossless encoder, if you do care, you most definitely want aac+
[17:53] <burek> if you want to be picky, use something in between
[17:54] <burek> but that discards it as generally usable
[17:55] <JEEB> basically, "everything is relative" is the name of the case.
[17:55] <JEEB> there is no one magic pill for everything, unless you are ready to make some kind of sacrifice for it
[17:56] <JEEB> thus I just rather select my tools depending on the case
[17:56] <burek> ok :)
[18:08] <haled> how do I undefine the movie aspect in h.264 ?
[18:12] <madsage> there are switches and scaling ratios for that
[18:12] <madsage> google for some examples
[18:14] <madsage> i have a question about audio quality  -aq <integer)  which is better 1 or 10 and what are the limits. is it 1-10? the docs arnt clear about this. it just says to use an integer
[18:14] <burek> madsage, what -acodec are you using
[18:14] <madsage> my hearing sux. they both sound teh same
[18:14] <madsage> wll i'm currently using libmp3lame
[18:15] <burek> then use -ar 128k or -ar 256k
[18:15] <madsage> but i'm goign to switch to libaacplus by recomendation from you.
[18:15] <haled> madsage, there is a -scale switch to define a ratio but none to remove it
[18:15] <burek> libaacplus is not gpl, just so you know
[18:15] <burek> if you are going to distribute your binaries, you'll need to pay the license
[18:15] <burek> if you are just encoding
[18:15] <burek> you are good to go
[18:16] <madsage> ahh ok. so -aq doesnt do anything with libmp3lame
[18:16] <burek> :)
[18:16] <JEEB> it's worse than that burek
[18:16] <JEEB> it's not (L)GPL compatible
[18:16] <madsage> yeah just encoding
[18:16] <JEEB> you can't distribute it
[18:16] <burek> then you're ok
[18:16] <madsage> it will reside on my server. nowhere else
[18:16] <JEEB> not even if you "pay the license"
[18:16] <burek> no problems then :)
[18:16] <JEEB> unless you get a license that lets you re-license the code
[18:16] <JEEB> which is unlikely
[18:17] <JEEB> anyways, just being pedantic as usual
[18:17] <madsage> by the way i am using libmp3lame -aq 10 -ar 44100 -ac 2
[18:17] <burek> ok, so no distribution of binaries, just the media :)
[18:17] <madsage> so i can just drop the -aq 10
[18:17] <burek> yes
[18:18] <JEEB> and if you really want to be pedantic, unless there are some clauses in the AAC licensing that you can encode/distribute content encoded in the format for free, there'd be the licensing problem overall :P
[18:18] <madsage> is libmp3lame decent? or should i try the libaacplus
[18:18] <JEEB> which depends on your country, legislation and so on
[18:18] <madsage> i am looking for the best quality at the lowest bitrate
[18:18] <JEEB> same for mp3 of course
[18:18] <relaxed> madsage: -aq does work with libmp3lame
[18:18] <madsage> relaxed, oh it does? which is better 1 or 10, and what is the limits.
[18:19] <madsage> i prolly want to start in the middle
[18:19] <relaxed> -aq 0 == lame's V 0
[18:19] <madsage> oh.. volume?
[18:19] <relaxed> no, vbr
[18:19] <madsage> oh oh. doh
[18:20] <madsage> heh sorry, i'm really that green
[18:20] <madsage> so 0 is best and 10 would be least?
[18:21] <relaxed> man lame
[18:22] <madsage> i'll look it up. i dont want to wear out my welcome with stupid questions. i tried the ffmpeg docs it says to use an integer is all
[18:23] <relaxed> I believe it uses the same settings as lame's -V, so consult the man its page
[18:23] <relaxed>  /the man its/its man/
[18:24] <paideia> hi, trying to extract the frames of movie 4 in http://www.pnas.org/content/early/2012/01/10/1115323109/suppl/DCSupplemental
[18:24] <madsage> aye, thank you relaxed
[18:25] <paideia> with ffmpeg, but it just exports the first frame repeatedly
[18:25] <madsage> ok that was easy
[18:25] <madsage> There are 10 compression levels defined,
[18:25] <madsage> ranging from 0=lowest compression to 9 highest compression
[18:25] <paideia> seemingly only vlc can play it nicely
[18:25] <madsage> -V5 resulting in files averaging 132 kbps, -V2 averaging 200 kbps
[18:25] <paideia> mplayer does not do it
[18:26] <paideia> and mencoder fails when attempting to convert it too
[18:26] <paideia> any suggestions?
[18:27] <morteza> can vlc stream on rtsp for android ?
[18:29] <JEEB> yes, as far as I know it can do rtsp streaming. I remember finding an example by googling
[18:30] <JEEB> might or might not contain android, but it was rtsp for sure
[18:30] <JEEB> (I think the example was for the N900)
[19:26] <mgeary> so , i recently compiled from svn, and now i'm getting "encoder 'aac' is experimental and might produce bad results" messages. How do i add that '-strict experimental' flag to override this?
[19:27] <mgeary> or does that need to be added at compile time?
[19:27] <mgeary> aha
[19:28] <mgeary> hrm. okay, well that's not working. What's a good fallback acodec?
[19:30] <relaxed> compiled from git?
[19:30] <mgeary> believe so
[19:30] <mgeary> that is, it was either from git or svn
[19:30] <mgeary> but yes, self-compiled
[19:31] <relaxed> pastebin the command and all output
[19:32] <mgeary> http://pastebin.com/YHUXN3JU
[19:33] <relaxed> ... -f mp4 out.m4v
[19:33] <mgeary> same response
[19:34] <relaxed> then use -b:v $videobitrate and -b:a $audiobitrate
[19:36] <relaxed> If you still get the "[ipod @ 0x10180fa00] malformated aac bitstream, use -absf aac_adtstoasc" error then update your source and rebuild. I believe that bug has been fixed.
[19:36] <mgeary> ah, ok. i actually just realized i have to go out to flv/mp3, so i'm dodging the issue at the moment
[19:36] <mgeary> but i'll try that in a bit
[19:37] <relaxed> omit -vpre medium because it is the default and libx264 profiles are now called with "-preset $profile"
[19:38] <relaxed> libx264 presets*
[19:38] <relaxed> I really screwed that up
[19:38] <relaxed> omit -vpre medium because it is the default and libx264 presets are now called with "-preset $preset"
[19:42] <mgeary> hahah
[19:42] <mgeary> thanks
[19:52] <relaxed> mgeary: next time you compile ffmpeg add libvo-aacenc support
[20:02] <DeezGz> hello ffmpegers
[20:02] <madsage> man i'm fustrated. i open a stream on wowza in stream manager. player connects.. i start ffmpeg its all good until its done. ahead of the the live stream from teh server and it somehow closes the stream. does it send some signal to close the stream? thsi isnt making sense
[20:03] <madsage> or am i just retarded
[20:07] <mgeary> that's a dangerous question to ask
[20:11] <madsage> heh
[20:12] <madsage> ffmpeg is workign great.
[20:12] <madsage> my streaming shit is not cooperating
[20:12] <relaxed> MrNaz: you around?
[21:12] <LiroXIV> Okay, I'm making a little VB.net app that takes in a input file, an output location, and will call ffmpeg (as a shell command) to encode the video
[21:12] <LiroXIV> I need a single FFmpeg command that will encode a video file into WebM with audio
[21:14] <Mavrik> LiroXIV, http://www.virag.si/2012/01/webm-web-video-encoding-tutorial-with-ffmpeg-0-9/
[22:14] <LiroXIV> Okay, I tried this 64-bit Windows binary of ffmpeg with a certain string of commands. When it tries to start actually encoding, it crashes
[22:27] <r0b-> hello anyone here?
[22:31] <r0b-> trying to stream a webcam off a server using ffmpeg
[22:40] <r0b-> :(
[22:47] Action: r0b- cant make ffmpeg stream
[22:48] <ehsan_> Hi I need to put video width into a variable so I can crop the video by half in a bash script.what shall I do?
[22:53] <ehsan_> Hi isnt there crop in ffplay
[22:53] <ehsan_> ?
[23:36] <marteo> hello !
[23:37] <marteo> I read the man page and didn't find what i was looking for, so i assume it simply does not exist, but i'll ask anyway :
[23:38] <marteo> is there some kind of "slow, repeated, double-checked" mode while uncompressing videos (essentially poorly encoded webms with h264 video)
[23:40] <marteo> because some frames do not appear correctly (green squares, that kind of thing)
[23:40] <marteo> (i point out those videos were terribly encoded by other people in my local newscast association)
[23:49] <burek> so, what is your overall goal marteo ?
[23:50] <burek> to decompress the video as good as possible?
[23:50] <marteo> uncompressing these videos to DV, as accurately as possible, to work again on them (with Premiere, etc.)
[23:51] <burek> you can try ffmpeg -re -i <input> ...
[23:51] <burek> that will make ffmpeg read input in real-time mode
[23:51] <burek> i.e. not as fast as possible
[23:51] <burek> but I'm not sure if that will help a lot
[23:52] <marteo> yeah, because a simple ffmpeg -i input -target pal-dv output already works at 2 frames / sec.
[23:52] <marteo> let me try anyway
[23:53] <burek> you might wanna try then to output to png images (uncompressing the input effectively)
[23:53] <burek> ffmpeg -i ... -f image2 output%04d.png
[23:55] <marteo> what the hell
[23:55] <marteo> allright, i guess i get it
[23:56] <marteo> does the command output each frame exactly, independantly ?
[23:57] <marteo> because I get something like 200 files per second of input
[23:58] <marteo> which would explains some of the trouble i went through
[23:58] <burek> well, 25fps
[23:58] <burek> should be
[23:58] <burek> or 50fps
[23:58] <burek> but 200 fps...
[23:58] <burek> that's just too much
[23:58] <burek> try with -re
[00:00] --- Sat Jan 28 2012

More information about the Ffmpeg-devel-irc mailing list