[Ffmpeg-devel-irc] ffmpeg.log.20120129

burek burek021 at gmail.com
Mon Jan 30 02:05:01 CET 2012

[00:02] Action: DelphiWorld compiling dss
[00:10] <niro> Hi, when you're creating a jpeg with ffmpeg, eg. ffmpeg -f video4linux2 -i /dev/video0 -o image2 image.jpeg
[00:10] <niro> how can you specify the jpeg quality?
[00:10] <Mavrik> -qscale I think
[00:12] <niro> let me give that a go
[00:13] <Mavrik> -qscale 1 should be "best" quality
[00:14] <niro> ok, i have take one at qscale 0.1
[00:14] <niro> now for 255
[00:14] <relaxed> 1 - 39 is the range
[00:15] <relaxed> er, 31
[00:16] <niro> relaxed, i tried setting it to 0 initially, and it came up and said qscale must be set between >0.0 or <=255
[00:16] <niro> and, i've ran it with 0.1 and 255, and the quality is noticeably different
[00:17] <niro> so thank you for the help :)
[00:18] <niro> now i just need to change that into a percentage
[00:18] <relaxed> any reason you want jpg over png?
[00:20] <niro> only because it's been requested in the specification i've been provided with
[02:08] <plut0> whats a good audio codec i can use to save some disk space for home videos. right now i'm using libmp3lame and it's pretty good, just wondering if theres something better
[04:00] <plut0> i'm using ffmpeg -acodec copy on a flv file, the output has no audio. what am i doing wrong?
[04:03] <relaxed> pastebin the command and output
[04:09] <plut0> http://pastebin.com/Cc8Rh4qr
[04:11] <relaxed> the output lists the audio stream. did you try playing it with ffplay?
[04:11] <plut0> i tried vlc and mplayer
[04:13] <relaxed> what are you doing with this output? putting it on the web?
[04:13] <plut0> nah just playing it locally
[04:16] <relaxed> then I would recommend -acodec flac output.mkv
[04:16] <plut0> looks like its a bug with version 0.9.1
[04:17] <plut0> 0.7.8 works fine with the same source file and cli options
[04:19] <relaxed> then a bug report is in order
[07:09] <fling> what is sample format?
[07:09] <fling> -f alsa -ac 2 -i hw:0,0
[07:09] <fling> [alsa @ 0x24c4780] cannot set sample format 0x10000 2 (Invalid argument)
[07:10] <fling> relaxed: hello :p
[07:39] <DeezGz> whats up guys
[07:59] <fling> i have alsa xrun if i use slower, veryslow x264 presets or if i use 40mbps+ bitrate and a file is stored locally
[08:00] <fling> no xrun if i use ultrafast lossless preset and the output file is on NFS :[
[08:00] <fling> should i increase buffers or something?
[08:05] <fling> if i use pcm_s16le + mkv container i have:
[08:05] <fling> [matroska @ 0x1a6b770] Application provided invalid, non monotonically increasing dts to muxer in stream 1: 752 >= 752
[08:05] <fling> av_interleaved_write_frame(): Invalid argument
[08:06] <fling> if i use pcm_s16le + libx264 + avi container, i have desync
[08:06] <fling> libx264 + libvorbis are fine with any container...
[08:15] <fling> what is encoder name for flac?
[08:16] <fling> oh, it is flac :]
[08:19] <fling> noone is here?
[08:21] <fling> how to set flac compression level?
[09:07] <fling> no xruns with 0.7.8
[09:07] <fling> also second streaming output works with 0.7.8
[09:07] <fling> 0.9.1 and 1.0 are totally broken
[09:12] <fling> test script > http://paste.pocoo.org/show/542556/
[10:31] <shevy> hmmm
[10:31] <shevy> ffmpeg -i foo.mp4  -r 1 -pix_fmt rgb24 animated.gif
[10:31] <shevy> the quality kinda is very very bad. lots of pixels
[10:33] <Mavrik> "gif"?
[14:15] <knowtheory> Hey folks i'm looking for some guidance.  I've been trying to convert a WAV i recorded into ogg vorbis and having essentially no success either through an interface like audacity, or through ffmpeg directly.  The wav is 38 secs long, but ffmpeg keeps producing files that are anywhere form 27s long to 44s, depending on how i tweak the settings.
[14:15] <knowtheory> Are there other tools anyone has used to get better conversion, or are there things i should be particularly paying attention to in the conversion process that i might be missing
[14:16] <knowtheory> (aside from bitate and sampling)
[14:18] <Mavrik> if the lenght of audio file isn't correct, then you're passing wrong input sample rate
[14:19] <knowtheory> Mavrik: see i find that puzzling because it happens both w/ ffmpeg, and with audacity (and audacity certainly knows what the sample rate is).  Audacity reports that the sample rate for the file is 44100
[14:19] <Mavrik> well, obviously it isn't if your length isn't correct :)
[14:19] <Mavrik> how did you record it?
[14:20] <knowtheory> Yep, fair enough, i recorded it using audacity off of the internal mic on my macbook pro
[14:21] <Mavrik> it could be that your stereo settings aren't right
[14:22] <knowtheory> ah, i hadn't thought of that. i'll dig around then
[14:22] <knowtheory> the original file is mono&
[14:22] <knowtheory> so i'll have to see how ffmpeg handles that.
[14:23] <Mavrik> just make sure you're passing those parameters before the "-i" parameters
[14:24] <knowtheory> Mavrik: ah, does ffmpeg infer settings off of the file specified w/ -i otherwise?
[14:24] <Mavrik> yeah
[14:24] <Mavrik> knowtheory, for example if you say "-ac 1 -i <input>.wav" that meant "interpret input file as mono"
[14:24] <knowtheory> cool, thanks for the heads up
[14:25] <Mavrik> knowtheory, but "-i <input>.wav -ac 1" will mean "convert file TO mono"
[14:25] <Mavrik> same for sample rate etc.
[14:25] <knowtheory> Ahh, okay, right that makes sense.
[14:26] <knowtheory> that also explains the error i just got :D
[14:26] <knowtheory> gotta move -acodec libvorbis after the -i file.wav
[14:28] <Mavrik> ^^
[14:28] <knowtheory> Well thanks Mavrik that gives me additional direction to tinker with
[14:28] <knowtheory> i'll see if i can get it sorted out
[14:46] <shevy> Mavrik yeah, I tried to convert a .mp4 video, 3 seconds clip, without audio, to an animated .gif file
[14:46] <shevy> it would have become my new avatar for forums!
[14:47] <shevy> but somehow, it was all blurry and way too large anyway
[14:47] <shevy> then I realized, I am a total noob when it comes to ffmpeg really, and did something else. like watch youtube video clips of freerunners, parcours and tricksters ... :P
[15:14] <burek> shouldn't ffmpeg figure out what the format of the audio is if you only run something like: ffmpeg -i audio.wav -acodec  ... output...
[15:18] <sacarasc> It does...
[16:42] <maister> Having some issues with the new avcodec_encode_audio2(). I can't seem to fill the AVFrame correctly. Any hints on how to do it properly?
[19:00] <j-b> hello.
[19:01] <j-b> How am I supposed to set the quality for jpeg for encoding?
[19:03] <Mavrik> -qscale
[19:03] <Mavrik> 1 being the best
[19:03] <Mavrik> 39 (afaik) being the worse
[19:03] <j-b> by the API.
[19:04] <j-b> How do we do that through the API?
[19:05] <Mavrik> what API?
[19:05] <maister> libavcodec I guess? :P
[19:05] <peace_> where i have to go to speak with avconv dev
[19:05] <Mavrik> I see. Check AVCodecContext structure.
[19:06] <iive> #libav
[19:09] <littlebit> hello people, i have a 3d movie where the screen is devided into 2 sections, is there a way how to convert that into a normal one??
[19:12] <JEEB> you can crop off one of the views
[19:12] <JEEB> and resize to matching aspect ratio
[19:12] <JEEB> and that way convert it to a "normal" clip
[19:16] <littlebit> the movie that i have is side by side
[19:16] <littlebit> and would be great if you could tell me the command that i have put int
[19:16] <littlebit> o
[19:17] <Mavrik> It would be nice if someone told me how to be rich in 1 step too.
[19:19] <littlebit> lol k
[19:20] <littlebit> i agree
[19:21] <Mavrik> littlebit, basically, look for "crop" video filter
[19:21] <Mavrik> in ffmpeg libavfilter documentation
[19:22] <peace_> but .... to get the same quality of input is there an option ?
[19:28] <littlebit> Mavrik: thanks ill look at it
[19:28] <Mavrik> peace_, what?
[19:29] <peace_> Mavrik: i want to convert a video with the same bitrate of input
[19:29] <peace_> same resolution same audio bitrate
[19:29] <peace_> same frequency
[19:29] <peace_> just change the codec
[19:30] <Mavrik> ok.
[19:30] <Mavrik> now where seems to be the problem?
[19:31] <peace_> i don't know how to do that , i used before sameq but it seems i can't find anymore on ffmpeg doc
[19:32] <peace_> ffmpeg -i stuff stuffout does video with bad video bitrate
[19:32] <peace_> so...
[19:37] <Mavrik> peace_, -sameq doesn't do that
[19:37] <Mavrik> and you can't do that automatically
[19:37] <Mavrik> you'll have to calculate average bitrate from filesize
[19:37] <Mavrik> but I very much doubt exactly the same bitrate in another format is what you want
[19:38] <peace_>  wtf this sucks
[19:39] <Mavrik> well, not having cars run on seawater sucks too
[23:26] <orbisvicis> im compiling ffmpeg, the opencore amr* options only apply to some uncommon formats, right?
[23:28] <orbisvicis> and x264 is only for encoding..
[23:46] <Brance> hello
[23:46] <Brance> anyone here
[23:46] <Brance> i have some issue
[23:46] <Brance> with compily ffmpeg
[23:46] <Brance> Centos5
[23:47] <Brance> if someone is willing to help
[23:47] <Brance> i try with librtmp
[23:47] <Brance> but no luck
[23:47] <Brance> it says it's not found
[23:48] <Brance> and log says
[23:48] <burek> can you please use pastebin.com, to show your command line and its output?
[23:48] <Brance> gcc -D_ISOC99_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_POSIX_C_SOURCE=200112 -D_XOPEN_SOURCE=600 -std=c99 -fomit-frame-pointer -pthread -c -o /tmp/ffconf.HHT20165.o /tmp/ffconf.bDS20157.c
[23:48] <Brance> gcc -Wl,--as-needed -o /tmp/ffconf.dZD20161 /tmp/ffconf.HHT20165.o -lopencore-amrwb -lopencore-amrnb -lmp3lame -lfaac -lm -pthread -lz
[23:48] <Brance> check_pkg_config librtmp librtmp/rtmp.h RTMP_Socket
[23:48] <Brance> check_func_headers librtmp/rtmp.h RTMP_Socket -I/usr/local/include -I/usr/kerberos/include -L/usr/local/lib -L/usr/kerberos/lib -lrtmp -lssl -lcrypto -ldl -lz
[23:48] <Brance> check_ld cc -I/usr/local/include -I/usr/kerberos/include -L/usr/local/lib -L/usr/kerberos/lib -lrtmp -lssl -lcrypto -ldl -lz
[23:48] <Brance> check_cc -I/usr/local/include -I/usr/kerberos/include -L/usr/local/lib -L/usr/kerberos/lib
[23:48] <Brance> BEGIN /tmp/ffconf.bDS20157.c
[23:48] <Brance>     1	#include <librtmp/rtmp.h>
[23:48] <Brance>     2	long check_RTMP_Socket(void) { return (long) RTMP_Socket; }
[23:48] <Brance>     3	int main(void) { return 0; }
[23:48] <Brance> END /tmp/ffconf.bDS20157.c
[23:48] <Brance> gcc -D_ISOC99_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_POSIX_C_SOURCE=200112 -D_XOPEN_SOURCE=600 -std=c99 -fomit-frame-pointer -pthread -I/usr/local/include -I/usr/kerberos/include -L/usr/local/lib -L/usr/kerberos/lib -c -o /tmp/ffconf.HHT20165.o /tmp/ffconf.bDS20157.c
[23:48] <Brance> ERROR: librtmp not found
[23:48] <burek> omg...
[23:48] <Brance> sorry
[23:48] <burek> can you please use pastebin.com, to show your command line and its output?
[23:48] <Brance> :(
[23:49] <Brance> http://pastebin.com/uKkvgmyw
[23:49] <Brance> :D
[23:49] <Brance> so?
[23:51] <Brance> comeone
[23:51] <Brance> anyone?
[23:51] <burek> be patient
[23:52] <burek> are you using debian?
[23:52] <burek> or ubuntu
[23:52] <Brance> red hat
[23:52] <Brance> RHEL
[23:52] <Brance> Centos
[23:52] <burek> it seems you dont have librtmp-dev installed
[23:53] <Brance> locate rtmp.h
[23:53] <Brance> usr/local/lib/librtmp/rtmp.h
[23:53] <Brance> i have it there
[23:54] <burek> all these too? -lrtmp -lssl -lcrypto -ldl -lz
[23:54] <Brance> how to do that
[23:54] <Brance> ?
[23:54] <burek> i dont know, i dont use centos :)
[23:56] <burek> anyway, I think you are still missing development version of librtmp
[23:56] <burek> try to google for it
[23:56] <burek> how to obtain/compile it
[23:56] <Brance> but i have installed via rpm
[23:56] <burek> what cmd did you use to install it
[00:00] --- Mon Jan 30 2012

More information about the Ffmpeg-devel-irc mailing list