[Ffmpeg-devel-irc] ffmpeg.log.20121022

burek burek021 at gmail.com
Tue Oct 23 02:05:01 CEST 2012

[00:34] <_stclaws> I am trying to compile ffmpeg with rtmp support. I first build rtmpdump. But when doing configure of ffmpeg I get: ERROR: librtmp not found. Any idea why?
[01:05] <iive> _stclaws: check config.log
[01:12] <_stclaws> iive: I tried everything I could think of.
[01:12] <iive> _stclaws: the config.log should contain the failed check, together with the reason for the failure.
[01:13] <_stclaws> It just ends with : check_pkg_config librtmp librtmp/rtmp.h RTMP_Socket
[01:13] <_stclaws> ERROR: librtmp not found
[01:14] <iive> looks like you installed only the library and the -dev with the headers is missing
[01:15] <iive> can you find rtmp.h somewhere in your filesystem? /usr/include/librtmp/rtmp.h ?
[01:15] <_stclaws> librtmp is here: /usr/local/include/librtmp
[01:16] <_stclaws> I thought all would be included with rtmpdump
[01:16] <iive> redhad doesn't include /usr/local in their defaults, so you may try specifying it as additional include path.
[01:18] <iive> try: --extra-cflags=-I/usrl/local/include
[01:21] <iive> oops, /usr/local/include ....
[01:22] <_stclaws> iive: tried that path but nope (yes usr)
[01:23] <_stclaws> I read somewhere that pkg-config had something to do with it
[01:23] <iive> same error in the config.log?
[01:23] <iive> can you pastebin a little bit more from the end?
[01:25] <_stclaws> http://pastebin.com/U9tEbivS
[01:26] <_stclaws> and my config line: http://pastebin.com/3L6j6Kn6
[01:49] <_stclaws> I did add PKG_CONFIG_PATH=/usr/local/lib/pkgconfig because that's where librtmp.pc is
[01:51] <_stclaws> Am I supposed to install librtmp-dev also although I did install rtmpdump?
[02:06] <hypnocat> when i try to ffplay an mp3, instead of playing it, ffplay displays a new window with a spectrogram of the mp3
[02:07] <hypnocat> why does it do that?  and how can i get it to just play the file?
[02:07] <sacarasc_> It should also be playing it.
[02:08] <hypnocat> ah.. i see that it was.. but just through alsa, not jack
[02:09] <hypnocat> how can i turn off the spectrogram display?
[02:11] <sacarasc_> Why would you want to?
[02:11] <hypnocat> i don't want an extra window to appear, or for ffplay to waste extra processing power displaying it
[02:11] <hypnocat> it's distracting, annoying, and wasteful
[02:12] <sacarasc_> Minimise it, and if it's wasteful, your computer is either really, really old or you're overly sensitive to waste...
[02:13] <hypnocat> my computer is old
[02:16] <_stclaws> Ok, I am stumped, it is getting late, and I guess I soon give up...
[02:22] <iive> _stclaws: sorry, I got to do other things.
[02:22] <iive> installing in /usr/local usually indicates you compiled yourself, so -dev package may not work
[02:23] <iive> good call with the pkg config path, but i assume it didn't work either?
[02:23] <iive> try to call it directly.
[02:29] <iive> e.g. pkg-config --cflags --libs librtmp
[02:29] <iive> the configure actually uses pkg-config --exists librtmp
[02:29] <iive> but that returns true/false to the script.
[02:30] <iive> i must try rtmp myself. maybe tomorrow.
[02:36] <_stclaws> when I try to call it directly it complains that libssl is not found
[02:37] <_stclaws> it is in /usr/lib/pkgconfig/libssl.pc . So I add that path to PKG_CONFIG_PATH. But still saying Package 'libssl', required by 'librtmp', not found
[02:55] <_stclaws> Crap, I just forgot to do export of PKG_CONFIG_PATH :)
[03:10] <_stclaws> thanks for the help, iive!
[03:15] <_stclaws> Does anyone know what the proper syntax is for the "listen" and "rtmp_live" parameters of the rtmp protocol?
[04:39] <zelozelos> i have another question about codec and ffmpg. if i was to output to mp4 then change to wmv, will i save some file size?
[06:56] <mark4o> _stclaws: ffmpeg -rtmp_live 1 ... / ffmpeg -rtmp_listen 1 ...
[06:57] <mark4o> _stclaws: I think rtmp://...?listen&timeout=... may also work
[07:02] <smjm> what's a good lossless video format?
[10:13] <_stclaws> I am receiving a rtmp stream from a fms server, but the stream is now and then "renewed" since the fms source is switched. I want ffmpeg to just go on but it thinks the stream ended and exits. Does anyone know how to just keep it up listening and receiving indefinitely?
[10:13] Last message repeated 1 time(s).
[10:13] <_stclaws> sorry twice
[10:17] <Exatrive> Hello.. have a question.. is there any way to have ffmpeg streams not enter a container. I'm capturing audio/video but mp4 doesn't support pcm_s16le audio so I will get a error if I try to capture. Instead I would like to have video go into the mp4 but audio go to another .wav in realtime.
[10:18] <Tjoppen> Exatrive: look at the documentation for -map
[10:19] <Exatrive> I did look at the map function.. but its not too clear if this will allow it to map the channel to bypass the first container. I will look again and see what I can do...
[10:27] <cjhmdm> hello, I'm trying to build the latest ffmpeg from source following the ubuntu compilation guide and am having trouble during the make step for fdk-aac
[10:27] <cjhmdm> this is the error I'm getting on make: libtool: link: more than one -exported-symbols argument is not allowed
[10:27] <cjhmdm> make: *** [libfdk-aac.la] Error 1
[10:41] <saste> cjhmdm, looks like an autohell libfdk issue
[10:41] <cjhmdm> saste: autohell?
[10:42] <saste> cjhmdm, autohell = autotools (autoconf, automake, libtool, etc.)
[10:43] <cjhmdm> saste: any way I can resolve it?
[10:43] <saste> cjhmdm, ask to libfdk devs, they will be more qualified to help
[10:46] <cbsrobot> cjhmdm: did you get the source from git ?
[10:47] <cjhmdm> cbsrobot: yes, I'm following the guide, line for line here: https://ffmpeg.org/trac/ffmpeg/wiki/UbuntuCompilationGuide
[10:47] <cbsrobot> these are the exported symbols: https://github.com/mstorsjo/fdk-aac/blob/master/fdk-aac.sym
[10:48] <cbsrobot> campare it to your fdk-aac.sym
[10:49] <cjhmdm> https://gist.github.com/3930424
[10:49] <cbsrobot> maybe you can debug it in the makefile
[10:49] <cbsrobot> after the autoreconf step
[10:49] <cjhmdm> it's telling me I can't have more than 1 exported-symbol
[10:50] <cjhmdm> my fdk-aac.sym file is the same as the one you linked
[10:50] <cjhmdm> unless I'm blind heh
[10:51] <cbsrobot> just before this line https://github.com/mstorsjo/fdk-aac/blob/master/Makefile.am#L32
[10:51] <cbsrobot> see if you can find it in the Makefile
[10:52] <cjhmdm> libfdk_aac_la_LDFLAGS = -version-info 0:1:0 -no-undefined \
[10:52] <cjhmdm>     -export-symbols $(top_srcdir)/fdk-aac.sym
[10:53] <cbsrobot> what does your shell say about "echo $LDFLAGS"
[10:53] <cjhmdm> nothing
[10:53] <cjhmdm> no return
[10:54] <cbsrobot> see line 384 in your Makefile
[10:54] <cjhmdm> what I don't get is why the trouble all of a sudden.. I've built, rebuilt and updated ffmpeg on this machine around 6 times over the past year with no problem
[10:55] <cbsrobot> maybe you can print the export-symbols jut before that
[10:55] <cjhmdm> although, I do blieve the fdk-aac step is new
[10:55] <cjhmdm> line 384 in my makefile is:    $(MPEGTPDEC_DIR)/tpdec_latm.cpp \
[10:56] <Exatrive> I'm still not having any luck with the map option.. the audio stream still want to be saved in the mp4 file... with a copy of the audio in the .wav
[10:56] <cbsrobot> cjhmdm: search for export-symbols
[10:56] <Exatrive> I'm trying to capture video to mp4, and audio to .wav seperatly with no luck.
[10:57] <cjhmdm> cbsrobot: line 297: -export-symbols $(top_srcdir)/fdk-aac.sym
[10:57] <cjhmdm> the whole line:
[10:57] <cjhmdm> libfdk_aac_la_LDFLAGS = -version-info 0:1:0 -no-undefined \
[10:57] <cjhmdm>     -export-symbols $(top_srcdir)/fdk-aac.sym
[11:01] <cjhmdm> go figure.. compiles just fine on a fresh machine with the same hardware and os as the other machine (but with only base system and necessary build tools).. but all dev tool versions are the same, so can I deduce that it's conflicting with another package on the system?
[11:03] <cbsrobot> cjhmdm: search for "all:" in the makefile
[11:04] <cbsrobot> and put "@echo $(libfdk_aac_la_LDFLAGS)" after that line
[11:04] <cbsrobot> run make again
[11:04] <cjhmdm> cbsrobot: all: all-am
[11:04] <cbsrobot> see what it prints
[11:04] <cbsrobot> yes
[11:04] <cjhmdm> Makefile:484: *** target pattern contains no `%'.  Stop.
[11:04] <cbsrobot> without the quotes
[11:04] <cbsrobot> @echo $(libfdk_aac_la_LDFLAGS)
[11:05] <cjhmdm> I didn't put quotes :P
[11:05] <cjhmdm> all: all-am
[11:05] <cjhmdm> @echo $(libfdk_aac_la_LDFLAGS)
[11:05] <cbsrobot> with a tab in fron
[11:05] <cjhmdm> ahh
[11:05] <cbsrobot> *front
[11:06] <cjhmdm> https://gist.github.com/3930510
[11:07] <cbsrobot> in your shell
[11:07] <cbsrobot> wait
[11:07] <cjhmdm> that was the output after adding that line to the makefile and running make
[11:09] <cbsrobot> add "@echo $(LINK)"
[11:09] <cbsrobot> after the other line
[11:09] <cbsrobot> and show me the output
[11:09] <mkozjak> hello
[11:09] <cjhmdm> so the above line then @echo $(LINK) below it? tabbed also?
[11:09] <cbsrobot> yes
[11:09] <cjhmdm> same output
[11:10] <cjhmdm> wait, I think there's a bit more on there
[11:10] <mkozjak> i have a problem with building the latest snapshot or git versions of ffmpeg where i get http://pastebin.com/raw.php?i=AGvrTcBq
[11:10] <mkozjak> echo $LD_LIBRARY_PATH says /usr/local/lib:
[11:10] <cjhmdm> cbsrobot: https://gist.github.com/3930534
[11:11] <cbsrobot> mkozjak: make clean
[11:11] <mkozjak> x264 built with Command line options: "--enable-pic" "--enable-shared" "--extra-cflags=-march=native"
[11:11] <cjhmdm> cbsrobot: nevermind.. it is the same output
[11:11] <cbsrobot> make clean && make
[11:11] <mkozjak> cbsrobot: yeah, doesn't help
[11:11] <cbsrobot> cjhmdm: swap the two lines
[11:11] <mkozjak> make clean  && make distclean && make -j20
[11:11] <cjhmdm> cbsrobot: all: all-am
[11:11] <cjhmdm>         @echo $(LINK)
[11:11] <cjhmdm>         @echo $(libfdk_aac_la_LDFLAGS)
[11:12] <cjhmdm> same output
[11:13] <_stclaws> Could anyone point me to a good tutorial for how to do HTTP Live Streaming with ffmpeg? From an incoming live rtmp stream.
[11:14] <cbsrobot> cjhmdm: hmmm
[11:14] <cjhmdm> cbsrobot:
[11:14] <cjhmdm> err.. yeah, hmm heh
[11:14] <cbsrobot> I show you my output
[11:14] <cjhmdm> the weirdest thing is, when running make on the new machine, the output is entirely different
[11:14] <cbsrobot> -version-info 0:1:0 -no-undefined -export-symbols ./fdk-aac.sym
[11:14] <cjhmdm> and it compiles fine
[11:15] <cbsrobot>  /bin/sh ./libtool --silent --tag=CC --mode=link gcc -g -O2 -o all
[11:15] <cjhmdm> but the only other thing on the 'old' machine is wowza media server
[11:15] <cbsrobot> firts line is @echo $(libfdk_aac_la_LDFLAGS)
[11:15] <cjhmdm> and the needed libs for building ffmpeg
[11:15] <cbsrobot> second $(LINK)
[11:16] <cbsrobot> try to figure out where in the makefile it adds the second export-symbols
[11:16] <mkozjak> can i somehow define to configure where the system should look for libx264.so?
[11:17] <cbsrobot> cjhmdm: search for libfdk_aac_la_LDFLAGS and see how it is created
[11:18] <wyuka> hi
[11:18] <cjhmdm> cbsrobot: ok
[11:18] <wyuka> any of the ffvp8 devs around?
[11:20] <cjhmdm> cbsrobot:  what I don't get is this also... this is the output on the old machine: https://gist.github.com/3930568 --- this is the output on the new machine: https://gist.github.com/3930561 --- the 2 machines are identical in every way. The only difference is the old machine has other packages (unrelated to building ffmpeg) installed
[11:21] <cbsrobot> ~/ffmpeg/libvpx ?
[11:21] <cjhmdm> cbsrobot: libfdk_aac_la_LDFLAGS = -version-info 0:1:0 -no-undefined \
[11:21] <cjhmdm>     -export-symbols $(top_srcdir)/fdk-aac.sym
[11:21] <cbsrobot> cjhmdm: wrong copy paste ?
[11:22] <cjhmdm> no, that's where libfdk_aac_la_LDFLAGS is created
[11:22] <cbsrobot> see https://gist.github.com/3930561
[11:22] <cbsrobot> wrong paste
[11:22] <cjhmdm> err yeah
[11:22] <cjhmdm> lol
[11:22] <cjhmdm> one sec
[11:24] <cjhmdm> this is the proper output on the new machine: https://gist.github.com/3930586
[11:24] <cbsrobot> you need to make clean on this machine first
[11:25] <cjhmdm> the old or new?
[11:25] <cbsrobot> new
[11:25] <wyuka> michaelni: ping
[11:25] <cjhmdm> I just followed the guide heh
[11:26] <cjhmdm> same output after running make clean heh
[11:26] <wyuka> i am working on an algorithm that generates intermediate frames using the motion compensation information during decoding
[11:26] <wyuka> i need some help with the source code for h264.c
[11:27] <cbsrobot> wyuka: check #ffmpeg-devel
[11:28] <wyuka> oh okay
[11:30] <cjhmdm> cbsrobot: oh well.. I'll try not to stress it heh.. just forces me to set up the new processing server anyway. I just hate not being able to figure out why something is broken heh
[11:32] <cjhmdm> cbsrobot: thanks for trying to help either way
[11:32] <cbsrobot> np
[11:59] <_stclaws> I need to set up ffmpeg to receive multiple consecutive rtmp live streams and re-encoding them into one single stream. Can anyone suggest the best way for doing that?
[12:05] <Element9> What do I have to enable while configuring for building to get WMV2 encoding?
[12:05] <Element9> --enable-wmv2 alone apparently isn't enought. here are all of the options I'm using if it's relevant: http://pastebin.com/u7XV393g
[12:06] <Exatrive> I figured out the mapping.. omg... my command line looks like a mess with all this mapping but at least it works.. lol
[12:07] <cbsrobot> Element9: maybe --enable-encoder=h263
[12:08] <Element9> cbsrobot: oh, that's why h263 got enabled by itself :) and I disabled it explicitely
[12:08] <Element9> cbsrobot: thanks. I'll try that
[12:08] <cbsrobot> np
[12:20] <gst-kaps> how do i make sure ffplay plays single channel files as single single & keep the sample rate as it is ?
[13:49] <arpu> hello is it possible to select a stream with the hex data like #0:1[0x45]
[13:50] <_stclaws> has anyone here done HTTP Live Streaming with ffmpeg?
[13:51] <ubitux> yes
[13:51] <ubitux> http://ffmpeg.org/ffmpeg.html#segment_002c-stream_005fsegment_002c-ssegment
[13:51] <ubitux> _stclaws: look for "HLS" here
[13:52] <ubitux> arpu: isn't this a program id?
[13:53] <arpu> hmm could be the problem is if i restart ffmpeg the order of the streams (more audio streams) is different
[13:58] <_stclaws> ubitux: I am just making my first tests but can't get the video to play on the web page. Can you see anything wrong here: http://pastebin.com/9tKdL7cJ
[13:58] <_stclaws> ubitux: This is the page with the test video:
[14:01] <_stclaws> ubitux: This was my ffmpeg command line: http://pastebin.com/HyRmtXgC
[14:21] <_stclaws> Is this normal output when you do hls streaming from ffmpeg: http://pastebin.com/E55BLSrh
[14:32] <ubitux> arpu: http://ffmpeg.org/ffmpeg.html#Stream-specifiers-1
[14:32] <ubitux> look for "program id"
[14:33] <arpu> ubitux,  thx
[14:33] <ubitux> _stclaws: ffplay '' works for me
[14:34] <arpu> i will try  maybe like -v:p:0x45 ?
[14:34] <_stclaws> Ok, now I get video. But it only shows up after I stop streaming.
[14:35] <_stclaws> While ffmpeg is working and outputting the .ts and .m3u8 nothing plays on the web
[14:36] <ubitux> arpu: select for what?
[14:36] <ubitux> _stclaws: you need a player on front
[14:37] <ubitux> or you need to just output a standalone webm
[14:37] <arpu>  Stream #0:0[0x44](deu): Audio: mp3 ([3][0][0][0] / 0x0003), 44100 Hz, stereo, s16, 128 kb/s
[14:37] <arpu>     Stream #0:1[0x45]: Video: h264 (High) ([27][0][0][0] / 0x001B), yuv420p, 720x576 [SAR 64:45 DAR 16:9], 25 fps, 25 tbr, 90k tbn, 50 tbc
[14:38] <ubitux> arpu: i mean, for -map?
[14:38] <saste> _stclaws, did you try the +live flag?
[14:42] <_stclaws> for the rtmp in ffmpeg, yes. The input is no problem. The problem is that the player on my web page cannot see the output until the streaming stops.
[14:43] <_stclaws> ubitux: I am using the <video> tag. Isn't that enough?
[14:43] <ubitux> depends on the browser
[14:43] <_stclaws> ios
[14:43] <_stclaws> safari
[14:44] <ubitux> i don't know that browser
[14:44] <ubitux> i though most of the browsers were able to play only mp4 & webm
[14:44] <ubitux> dunno about the playlist contents
[14:44] <_stclaws> well the browser plays it ok, but only after I close the stream.
[14:45] <_stclaws> It's as if the files need to close first or something.
[14:46] <_stclaws> I am streaming to the iphone. That's why I am doing this.
[14:47] <_stclaws> ubitux: You said you could see the video. Can you see me now holding a cup in my hand?
[14:48] <ubitux> i see gray artefacts
[14:48] <_stclaws> any image at all?
[14:49] <ubitux> sure i see your face
[14:49] <_stclaws> no cup?
[14:50] <ubitux> http://b.pkh.me/_stclaws.jpg
[14:50] <ubitux> this is what i see.
[14:50] <_stclaws> interesting. so you actually see the live stream
[14:51] <_stclaws> what client do you use for looking
[14:51] <ubitux> 14:33:53 <@ubitux> _stclaws: ffplay '' works for me
[14:51] <_stclaws> ok, cool. so it is something wrong with my web page then
[14:51] <_stclaws> thanks
[14:51] <_stclaws> got any sound?
[14:52] <_stclaws> oh wait, i don't think you do. anyway.
[16:47] <dv_> hello
[16:47] <dv_> I see some ARM optimizations for the libavcodec h264 decoder
[16:47] <dv_> but how good are these optimizations? is there still a lot of room for improvement, or has the maximum been reached?
[16:48] <JEEB> I'd say in general !IA32/x86_64 is not really optimized /that/ much
[16:48] <JEEB> so if you know ARM assembly, kick yourself out
[16:48] <dv_> okay, because on a cortex-A8, a 640x480 24 fps h264 baseline video takes about 95% CPU usage when decoding
[16:49] <dv_> (cortex-a8 running at 720mhz)
[16:49] <JEEB> well, that sentence by itself makes no sense unless you note that you are indeed limiting the decoding to ~24fps
[16:50] <dv_> i did. it is a video I generated
[16:50] <dv_> specifically with 24 fps
[16:50] <JEEB> uuhh
[16:50] <dv_> oh wait
[16:50] <dv_> now I get it :)
[16:50] <dv_> yes, it is limited to 24 fps
[16:50] <JEEB> ok, and it gets to 95% there
[16:51] <dv_> yeah, a few % idle remain
[16:51] <JEEB> feel free to see what kind of room for optimization you have
[16:52] <dv_> also, any other profile completely overwhelms the cpu, but thats not really surprising
[18:37] <stclaws_> does anyone know what the parameters "listen" and "live" for rtmp actually do? I can't find any descriptions of them except that they have something to do with live streams.
[19:04] <Simex> Anyone around who would like to help me with a application I'm working on?
[19:05] <Simex> I'm working on a application that acts as a ffmpeg wrapper so that Linux users can run ffmpeg easily without knowing the command syntax
[20:07] <RunawayDevil> Hail
[20:08] <RunawayDevil> Hey guys, there is a bug in the libass? When I open the HUD to see the converted file .srt to .ass is everything wrong
[20:09] <RunawayDevil> EVERYTHING. the grammar, I mean, it should be correct like it was when I used .srt (ocidental latin 1)
[20:13] <diegoviola> hi
[20:13] <diegoviola> what kind of frame rate should i use for desktop capture?
[20:13] <diegoviola> screencasting
[20:14] <diegoviola> i'm using webm
[20:32] <diegoviola> f**
[20:32] <diegoviola> ffmpeg is segfaulting for me
[20:32] <diegoviola> ffmpeg version 1.0 Copyright (c) 2000-2012 the FFmpeg developers
[20:32] <diegoviola> when using x11grab feature
[20:43] <diegoviola> strange
[20:43] <diegoviola> the x11grab dies only when i screencast firefox
[20:43] <diegoviola> when i do everything else it's ok
[20:46] <llogan> diegoviola: that's weird.
[20:47] <Simex> Anyone around who would like to help me with a application I'm working on?
[20:47] <Simex> I'm working on a application that acts as a ffmpeg wrapper so that Linux users can run ffmpeg easily without knowing the command syntax
[20:48] <llogan> Simex: that will be a busy task due to all of the ffmpeg versions floating out there and the various syntax changes...or do you mean via the API?
[20:49] <Simex> Really?
[20:50] <Simex> Mainly for Ubuntu in the beginning though
[20:50] <llogan> ubuntu doesn't use FFmpeg
[20:50] <Simex> It uses avconv I know
[20:51] <Simex> But luckily I haven't come across any syntax problems
[20:52] <llogan> it would be easier to either support one version, like a certain package from a certain distro in a certain repository, or distribute/include ffmpeg with your app.
[20:52] <Simex> Maybe I will distribute it with it
[20:52] <Simex> I have to for Windows
[20:53] <llogan> make sure to read http://ffmpeg.org/legal.html
[20:53] <Simex> I'm not really working on the packaging at the moment
[20:53] <Simex> At the moment users should download ffmpeg their self but it is far from done
[20:53] <Simex> Would you like to try it?
[20:54] <llogan> did you talk with the WinFF guys (Big Matt, etc)? They will probably have good ideas.
[20:54] <llogan> sure, i'll try it
[20:54] <Simex> It is Java
[20:54] <llogan> i don't have java installed.
[20:54] <Simex> http://jenkins.marlinc.nl/job/2STREAM/ is where you can download it
[20:54] <Simex> OpenJRE is fine
[20:55] <rbennacer> hey guys , is there a way to repair a corrupted mp4? when i use the ffmpeg -i , i get  [mov,mp4,m4a,3gp,3g2,mj2 @ 0x62d650] moov atom not found
[20:55] <diegoviola> fflogger: http://pastie.org/5099617
[20:56] <llogan> Simex: i can just look at the code. where in github can i view the code that tells ffmpeg what to do?
[20:57] <Simex> https://github.com/MMS-Projects/2stream/blob/develop/src/net/mms_projects/tostream/encoders/Ffmpeg.java#L44
[20:58] <Simex> Then it uses https://github.com/MMS-Projects/2stream/blob/develop/src/net/mms_projects/tostream/managers/DeviceManager.java#L161 to do some input device selecting
[20:58] <llogan> diegoviola: does it crash only when using libvpx as the encoder (as you are now)?
[21:00] <diegoviola> llogan: nope
[21:00] <llogan> rbennacer: generally, no. or at least not with ffmpeg.
[21:00] <diegoviola> llogan: take a look: http://pastie.org/5099644
[21:01] <llogan> why did you --disable-debug?
[21:04] <diegoviola> llogan: you talking to rbennacer or me?
[21:04] <diegoviola> I'm using ffmepg from archlinux
[21:05] <llogan> that was for you
[21:06] <diegoviola> oh, i have no idea how archlinux devs built ffmpeg
[21:06] <diegoviola> i'm using their package
[21:06] <llogan> a gdb output would be useful.
[21:07] <llogan> and you can see if ffmpeg-git in AUR also seg faults
[21:07] <diegoviola> ok
[21:08] <rbennacer> what is the best way to repair mp4 file that have no moov atom?
[21:09] <llogan> diegoviola: (or just get the code, ./compile --enable-gpl, make. no need to install)
[21:09] <llogan> *./configure
[21:10] <brontosaurusrex> rbennacer: perhaps qt-quickstart
[21:11] <cbsrobot> rbennacer: that's not easy
[21:11] <cbsrobot> there are some apps doing it
[21:11] <cbsrobot> but to my knowlage ffmpeg cant (atm)
[21:11] <rbennacer> i am jsut missing the moov atom in my metatdata though
[21:11] <cbsrobot> qt-faststart is only for moving the moov atom to the boginning of the file
[21:12] <diegoviola> llogan: ok, i will try that, thanks
[21:12] <cbsrobot> normally the metadata is in the moov atom
[21:12] <cbsrobot> not the other way round
[21:13] <cbsrobot> what atoms do you have ?
[21:13] <rbennacer> i don't know
[21:13] <rbennacer> how can i check?
[21:14] <cbsrobot> hexedit
[21:14] <rbennacer> ok let me check
[21:14] <cbsrobot> :P
[21:14] <cbsrobot> you know what a hexeditor is ?
[21:15] <rbennacer> yes
[21:15] <rbennacer> :)
[21:16] <rbennacer> i jsut did a hexedit on my file
[21:16] <rbennacer> i am not sure i can find the atoms i have
[21:16] <rbennacer> hahhaha
[21:17] <cbsrobot> does vlc play it ?
[21:17] <cbsrobot> maybe you could try http://www.videohelp.com/tools/My-MP4Box-GUI
[21:17] <cbsrobot> though I never used it
[21:31] <llogan> diegoviola: i'm unable to duplicate the issue using the same arch package.
[21:33] <diegoviola> llogan: weird
[21:43] <diegoviola> llogan: it must be an issue with the driver maybe?
[21:43] <diegoviola> i'm on nouveau
[21:43] <diegoviola> video driver
[21:49] <llogan> diegoviola: you need to A) test ffmpeg git master, and/or B) get a gdb output from your crashing ffmpeg
[21:49] <llogan> http://ffmpeg.org/bugreports.html
[21:49] <llogan> gdb info in that link
[21:49] <llogan> you may have to recompile the package via ABS without --disable-debug
[21:49] <diegoviola> ok
[21:54] <llogan> diegoviola: it is easy to test git-master: http://pastebin.com/YfdzxpaE
[21:55] <diegoviola> ok i'll give that a try in a min
[21:55] <diegoviola> thanks
[21:56] <diegoviola> just been busy with something else here as well (unrelated to ffmpeg)
[21:56] <diegoviola> :)
[21:56] <diegoviola> i appreciate your help
[21:56] <llogan> i forgot: sdl libxfixes
[21:56] <llogan> add those to your pacman line
[21:57] <undercash> hi
[21:57] <undercash> anybody has a little idea how to transform this bash script in php
[21:57] <undercash> http://pastebin.com/qDhb2VcZ
[21:57] <undercash> it s to launch a playlist using the browser so i dont give server credentials..
[21:58] <llogan> no, but you may want to add "-pix_fmt yuv420p"
[21:59] <undercash> not looking to improve my ffmpeg command right now but thanks :)
[21:59] Action: llogan hits ctrl+z
[22:00] <llogan> this isn't really the channel for such questions
[22:00] <undercash> really..
[22:00] <undercash> i had to try..
[22:01] <dTal> undercash: you know, you can still invoke bash scripts using CGI
[22:01] <dTal> there's not neccesarily any benefit to porting to PHP
[22:10] <Igneom> could someone help me with a compile error?
[22:12] <Igneom> anyone?
[22:18] <llogan> Igneom: use a pastebin service to show your configure line and any useful errors.
[22:21] <Igneom> here it is http://pastebin.com/eH6aWL76
[22:23] <llogan> Igneom: you have two different versions of x264 installed simultaneously in two different places
[22:25] <llogan> why --enable-memalign-hack?
[22:27] <Igneom> i was just following a tut on ffmpeg.org
[22:28] <llogan> which one?
[22:28] <Igneom> whereis command would find the other place where it could have the other x264 installed?
[22:28] <Igneom> http://ffmpeg.org/trac/ffmpeg/wiki/UbuntuCompilationGuide this one
[22:29] <llogan> enable-memalign-hack isn't shown there
[22:29] <llogan> your configure options are very different than the guide
[22:30] <Igneom> now i remember i mixed the configure options form that guide and from this guide http://www.grafxsoftware.com/faq.php/HOW-TO-install-ffmpeg-Mplayer-mencoderFLVtool2-and-Yamdi-on-Plesk-Linux-based-server/1/16/
[22:31] <llogan> a terrible idea
[22:31] <Igneom> this second guide also gives the same error
[22:32] <llogan> that's an awful guide. outdated and used shitty configure options.
[22:33] <llogan> symlink libraries? messy.
[22:33] <Igneom> so the best one to use is from ffmpeg.org?
[22:33] <llogan> that one is kept up to date and should not be using dumb options
[22:33] <llogan> but now you have to clean up the mess from the other guide
[22:34] <Igneom> yeah, well i'm installing it on a vps, so i think it would be easier to make a complete reset than finding and correcting a lot of mistakes
[22:35] <llogan> if that's not a pain in the ass, then go for it
[22:36] <Igneom> won't be, i thought that this could get a little complicated , so it is almost the first thing i was doing on the vps, just have to harden the ssh again and it's all good to go
[22:37] <Igneom> anyway, thanks for the help llogan
[22:38] <llogan> good luck
[22:38] <Igneom> just one last question, the guide is for ubuntu, and i'm using debian, will all the dependencies listed work on debian?
[22:41] <llogan> which debian?
[22:42] <Igneom> 6.0
[22:42] <llogan> the hardy version might be better: https://ffmpeg.org/trac/ffmpeg/wiki/UbuntuCompilationGuideHardy
[22:43] <llogan> it's missing some stuff though like fdk-aac
[22:44] <Igneom> if i compile the missing things and add the correct flags on the ffmpeg configure options, it should work right?
[22:45] <llogan> actually it appears only fdk-aac is missing
[22:45] <llogan> which you may not need if you don't need an AAC encoder (and ffmpeg has one anyway, but people say it's not that great)
[22:47] <Igneom> well the things i need are meconder, mplayer,  ffmpeg (with support to jpeg, gif, png, freetype, h264, lame, xvid, mad, win32codecs, dv, 3gp, mp4, theora), yamdi or flvtool2 and mediainfo
[22:48] <llogan> the guide won't install freetype support in ffmpeg. and i just removed theora instructions seconds ago (see Hardy guide history if you need it)
[22:49] <llogan> and by support, do you mean decoding or encoding?
[22:51] <Igneom> i think both for most of them, dunno, it's for a tube like site, and tht's what it says as requirements on the script site
[00:00] --- Tue Oct 23 2012

More information about the Ffmpeg-devel-irc mailing list