[Ffmpeg-devel-irc] ffmpeg.log.20140403

burek burek021 at gmail.com
Fri Apr 4 02:05:01 CEST 2014

[00:31] <kevin123> is there a reason why rtp streaming is working fine from my laptop, but rtmp streaming isn't?
[00:31] <kevin123> I keep seeing this error: Problem accessing the DNS. (addr: vdgami)
[00:31] <kevin123> and : Unknown error occurred
[00:34] <kevin123> sacarasc, thanks! here's my exact command/output http://pastebin.com/jpZjmrtB
[00:36] <sacarasc> Hmm, it looks like it is trying to use "user" as the address. :\
[00:37] <kevin123> yeah, it's weird right?
[00:38] <kevin123> it doesn't recognize 'rtmp' but it does recognize 'rtp'
[00:38] <sacarasc> You'll have to wait for someone who knows more about this than me.
[00:38] <kevin123> yet, in the ffmpeg -protocols output it says it supports rtmp
[00:38] <kevin123> for both input and output
[00:38] <kevin123> ok, thanks for trying
[00:51] <gamax92> Is it possible to have mpdecimate list all the duplicated frames it removed, like their frame number
[01:27] Last message repeated 1 time(s).
[01:27] <kevin123> does anyone know why ffmpeg is parsing my rtmp url incorrectly? I'm running version 2.2
[01:27] <kevin123> here's the debug output: http://pastebin.com/4URPcHRH
[01:27] <kevin123> in particular it parses the host name as the user "Parsed host    : user"
[01:28] <kevin123> for a given rtmp url such as this: rtmp://user:pass@stream.sportslive24.net:1935/live/flv:sportstest
[01:28] <kevin123> any help would be greatly appreciated :)
[01:29] <kevin123> oh it also parses the protocol as 0
[01:29] <kevin123> Parsed protocol: 0
[01:33] <gamax92> meh, I guess I'll just dump all the frames out myself and write a program to compare the old video to the new video.
[01:36] <gamax92> oh, i can increase the log level, then parse that log.
[01:41] <gamax92> alright, debug level works
[02:04] <voip_> hello guys
[02:05] <voip_> can you check pls whats wrong ? http://pastebin.com/SRB4C9U4
[02:07] <sacarasc> First, you're running it as root. That is bad.
[02:10] <Moussekateer> I'm used the 01-Apr-2014 and 31-Mar-2014 builds of ffmpeg to try to remux an mkv video to an mp4 and ffmpeg always crashes at the end with a "Assertion next_dts >= 0 failed at /home/kyle/software/ffmpeg/source/ffmpeg-git/libavformat/movenc.c:623" error
[02:10] <Moussekateer> I've*
[02:11] <Moussekateer> Is that a hardcoded path in the source that's causing the issue?
[02:51] <voip_> can you check pls whats wrong ? http://pastebin.com/SRB4C9U4
[02:55] <sacarasc> First, you're running it as root. That is bad.
[03:30] <voip_> sacarasc, i klnow, but its not root problem
[04:08] <Temper> can ffmpeg convert livestreams?
[04:33] <c_14> Usually, yes.
[08:02] <tztz> Hi
[08:13] <tztz> ist es möglich ein mjpeg stream (mit variabler framerate) aufzuzeichnen und dabei auf eine konstante framerate zu bringen?
[08:13] <tztz> und so das aufzeichendauer = video länge wird
[09:14] <cbreak-work> I have a very weird problem. When decoding a movie with ffmpeg, a few of the rightmost pixel get cut off.
[09:14] <cbreak-work> this seems to be caused by the conversion from YUV to RGB
[09:17] <cbreak-work> it doesn't happen with the command line ffmpeg, but it does happen when I use libswscale directly
[09:33] <dannyzb> what format does youtube use for streaming ? (pseudo , HLS or RTMP ) ?
[09:53] <cbreak-work> weird...
[09:53] <cbreak-work> the source video is 852 pixel wide, if I just color convert it, I lose pixel, but if I upscale it to 864 then I get all the data (just distorted of course)
[09:57] <spaam> dannyzb: DASH
[10:02] <dannyzb> spaam: thx
[10:02] <dannyzb> how do i encode for dash in ffmpeg? whats the container format ?
[10:04] <cbreak-work> it works if I disable optimizations
[10:10] <cbreak-work> hmm... Seems to be an undocumented limitation of ffmpeg
[10:10] <cbreak-work> but I wonder why it works with the command line and not the library itself
[11:45] <tztz> how it is possible to record a mjpeg stream with variable framerate, to a vidoe with a const framerate?
[13:14] <superware> what does it mean if av_write_frame returns -22?
[15:31] <rsevero> Hi. I'm trying to capture audio and video from a Dazzle DVC 100 capture board. Major problem: no sound at all. No errors either, just complete silence. Tried with ffmpeg 1.2.6 and 2.2.
[15:32] <rsevero> In VLC I have sound. And here is the strange part: after using VLC a little, ffmpeg's capture has sound. Suggestions?
[15:38] <rsevero> Sorry. Here it is: http://pastie.org/8991332
[15:38] <rsevero> See that the video used 2287kB and the audio only 6kB.
[15:39] <klaxa|work> >[alsa @ 0x121a500] ALSA buffer xrun.
[15:39] <klaxa|work> this might be related
[15:40] <klaxa|work> otherwise it seems to be recording audio from hw:2,0
[15:40] <klaxa|work> is that the correct device?
[15:40] <klaxa|work> i personally prefer pulseaudio, but that's just me
[15:40] <klaxa|work> i never ran into alsa buffer xruns anymore though
[15:41] <rsevero> The alsa buffer xrun happens sometimes and sometimes it doesn't, no matter if the final file will have sound or not.
[15:41] <rsevero> hw:2,0 is the right device.
[15:41] <klaxa|work> hmm yeah it should introduce stutter at max
[15:42] <klaxa|work> sadly, i know too little about alsa to be of much help
[15:42] <rsevero> I believe I'm dealing with the same problem as https://lists.ffmpeg.org/pipermail/ffmpeg-user/2013-March/014289.html
[15:43] <rsevero> Unfortunatelly the above thread never got to a "SOLVED" state.
[15:45] <klaxa|work> ah, are the alsa mixer settings wrong for you too?
[15:45] <klaxa|work> after running ffmpeg that is
[15:47] <tztz> how it is possible to record a mjpeg stream with variable framerate, to a vidoe with a constant framerate and correct length?
[15:47] <rsevero> Well, no.
[15:47] <rsevero> I don't have exactly the same problem.
[15:47] <klaxa|work> hmm... that's weird for sure
[15:47] <klaxa|work> arecord works?
[15:48] <rsevero> I've just tried the "use VLC a little before capturing" trick and it worked again.
[15:48] <rsevero> Let me try it. Just a moment.
[15:48] <klaxa|work> tztz: maybe the fps video filter will help, see: http://ffmpeg.org/ffmpeg-filters.html#fps-1
[15:50] <tztz> if i fixed the output framerate the length of the video changes with camaera framerate
[15:50] <klaxa|work> what have you tried so far?
[15:50] <tztz> somtime there 5 fps  somtimes 10fps
[15:51] <tztz> i fixed input framerate and output framerate and -vsync 1
[15:51] <klaxa|work> can you pastebin your commands and ffmpeg's output and link it here?
[15:52] <rsevero> arecord has the same issue as ffmpeg: no sound before using VLC. Sound ok after using VLC.
[15:53] <klaxa|work> do the alsamixer settings change after using vlc?
[15:54] <tztz> ffmpeg -vsync 1 -f mjpeg -r 8 -i ''  -s 640x480 -r 8 Robo2.avi
[15:55] <tztz> record for 10min  output change from 12min to 8min
[15:55] <klaxa|work> didn't you say you want to change variable framerate to fixed framerate?
[15:55] <klaxa|work> in that case you shouldn't force a framerate for the input stream
[15:56] <tztz> and without fixed framerate ffmpeg tries 25fps
[15:56] <rsevero> klaxa|work: No, the line capture level remains at 35.
[15:56] <rsevero> Increasing it to 100 changes nothing on ffmepg capture.
[15:57] <rsevero> arecord -l
[15:57] <klaxa|work> tztz: hmm... can you run: ffmpeg -i '' -c copy -t 20 test.mjpeg and then pastebin what ffprobe test.mjpeg outputs?
[15:57] <klaxa|work> rsevero: that is pretty weird
[15:58] <klaxa|work> apparently vlc must be doing something differently
[15:58] <rsevero> Welcome to my strange world ;) I bet you are right. How could I find out what exactly?
[15:59] <klaxa|work> no clue, how are you recording with vlc?
[15:59] <rsevero> With VLC I'm just watching from the same capture board.
[15:59] <klaxa|work> well how do you open the stream? what devices do you use?
[15:59] <klaxa|work> i think vlc prints that in the terminal
[16:00] <tztz> currently i cant capture stream,  .... in 2h
[16:01] <klaxa|work> do you have a copy of the stream? not encoded but in mjpeg?
[16:02] <rsevero> Nothing useful from VLC: http://pastebin.com/CXnpGJH9
[16:03] <rsevero> It just works...
[16:03] <klaxa|work> is there a way to increase verbosity of vlc?
[16:03] <rsevero> Will try.
[16:04] <tztz> in the capture stream ther no timeinformation ...ok
[16:04] <tztz> Unrecognized option 'c'
[16:04] <tztz> Failed to set value 'copy' for option 'c'
[16:04] <klaxa|work> what version of ffmpeg are you running tztz?
[16:04] <klaxa|work> run ffmpeg -version
[16:04] <klaxa|work> don't paste everything in the channel please
[16:05] <rsevero> I believe vlc is using pulse.
[16:05] <rsevero> Will try it on ffmpeg.
[16:07] <klaxa|work> ah that would make sense
[16:07] <klaxa|work> if pulse is already using the alsa device, it can't be used by anything else (afaik)
[16:07] <klaxa|work> that should raise an error though... hmm...
[20:04] <voip_> hello
[20:05] <voip_> why i cant restream video and getting error :av_interleaved_write_frame(): Invalid argument
[20:05] <voip_> http://pastebin.com/hUGdTGag
[20:16] <llogan> voip_: it probably works with a local file, so make sure your UDP output is reachable and valid
[20:16] <llogan> http://ffmpeg.org/ffmpeg-protocols.html#udp
[20:16] <llogan> oh, udp. i know nothing of that.
[20:17] <voip_> llogan, my UDP output is reachable and valid
[20:17] <llogan> does it work when encoding to a local file?
[20:19] <voip_> llogan, i dndnt try, bud when i changing input its works
[20:48] <rsevero> In case anyone is interested in the "ffmpeg recording without sound on s DVC 100", the solution is to call "v4l2-ctl --set-ctrl=mute=0" before recording.
[00:00] --- Fri Apr  4 2014

More information about the Ffmpeg-devel-irc mailing list