[Ffmpeg-devel-irc] ffmpeg.log.20140406

burek burek021 at gmail.com
Mon Apr 7 02:05:01 CEST 2014

[00:29] <Daron> Can someone help me to transcode live input and to transcode it(h264) and  forwarding it to rtmp. I have it already working but after a while it will give problems.
[01:16] <DASPRiD> greetings, just a short question. i have the following code which is meant to create a timelapse, prepend it with a splash screen and add audio from a separate file to it. everything basically works, except that the audio channel is not encoded into the video: https://gist.github.com/DASPRiD/fa5d8fac28b9710d7a39
[01:17] <DASPRiD> i supposed that it was because of the map option, but adding "-map 2:0" to it gives me an error "unknwon encoder '2'"
[01:21] <c_14> That would be because of the "-c:a 2" you have in the 4th to last line.
[01:22] <DASPRiD> oh
[01:22] <DASPRiD> guess that should be -ac
[01:23] <DASPRiD> thx, apparently i looked at the completely wrong place for the error, hehe
[01:23] <DASPRiD> mh, and now ffmpeg doesnt know libfdk_aac, hmpf
[01:24] <c_14> ffmpeg -codecs | egrep '^ .EA'
[01:26] <DASPRiD> there's aac and libvo_aacenc
[01:26] <DASPRiD> i guess using them will be fine?
[01:27] <c_14> It depends, iirc libfdk_aac provides better quality but you can always try it.
[01:28] <DASPRiD> yeah, ffmpeg wiki says the same
[01:28] <DASPRiD> c_14, okay, seems to work now, thanks. just one question. do you have any idea if the first step here could be skipped and done with a single ffmpeg call? https://gist.github.com/DASPRiD/b702749fda0858569613
[01:29] <smo_> hi i have loooot of erros when transcoding a live rtsp stream: what can do this ? http://pastebin.com/RBsA4yPN
[01:29] <smo_> tried many ffmpeg same thing...
[01:37] <c_14> DASPRiD: You might be able to, but I wouldn't know how.
[02:23] <Affy> Hallo, hallo. Anyone here?
[02:25] <iive> !hello
[02:25] <Affy> Hiya.
[02:26] <Affy> Got some...issues installing ffmpeg, actually. Silly, but...well, just won't go.^^
[02:26] <iive> don't ask to ask, just ask. If somebody knows the answer, they might answer.
[02:26] <iive> what issues.
[02:26] <iive> (i was going to leave...)
[02:27] <Affy> Sorry. Well, it's a Ubuntu 12.04 x64 server...I did basic ./ffmpeg, but that seems to do nothing. I tried some other stuff...and nowhere.
[02:27] <Affy> If you'd like to leave, go ahead. I don't want to waste your time.
[02:27] <c_14> Affy: Tried https://trac.ffmpeg.org/wiki/UbuntuCompilationGuide ?
[02:27] <sacarasc> Affy: ./ffmpeg would try to execute the executable called 'ffmpeg' in the current directory, is that what you want to do?
[02:28] <Affy> Well, yeah...what I'm looking to do is install it. I have no version atm.
[02:28] <Affy> Pulled up guide...1 sec.
[02:28] <Affy> I downloaded the latest...that's what I was trying to install.
[02:28] <sacarasc> One of them?
[02:29] <Affy> Sickle.
[02:29] <Affy> The stable one he recommended below the latest.
[02:29] <iive> n8 ppl
[02:29] <Affy> Good night.
[02:29] <Affy> Too late. -_-
[02:30] <Affy> Going through compilation guide now.
[02:56] <Affy> Seems to have...worked.
[02:56] <Affy> ffmpeg version 2.2.git
[02:56] <Affy> built on Apr  6 2014 02:49:24 with gcc 4.6 (Ubuntu/Linaro 4.6.3-1ubuntu5)
[02:56] <Affy> configuration: --prefix=/home/affy/ffmpeg_build --extra-cflags=-I/home/affy/ffmpeg_build/include --extra-ldflags=-L/home/affy/ffmpeg_build/lib --bindir=/home/affy/bin --extra-libs=-ldl --enable-gpl --enable-libass --enable-libfdk-aac --enable-libmp3lame --enable-libopus --enable-libtheora --enable-libvorbis --enable-libvpx --enable-libx264 --enable-nonfree
[02:56] <Affy> libavutil      52. 74.100 / 52. 74.100
[02:56] <Affy> libavcodec     55. 57.100 / 55. 57.100
[02:56] <Affy> libavformat    55. 36.101 / 55. 36.101
[02:56] <Affy> libavdevice    55. 11.100 / 55. 11.100
[02:56] <Affy> libavfilter     4.  3.100 /  4.  3.100
[02:56] <Affy> libswscale      2.  6.100 /  2.  6.100
[02:56] <Affy> libswresample   0. 18.100 /  0. 18.100
[02:56] <Affy> libpostproc    52.  3.100 / 52.  3.100
[02:56] <c_14> Waaaa, next time pastebin, please.
[02:56] <klaxa> use pastebin the nex-- yeah
[02:57] <Affy> Sorry. Every time I write anything it's an error. Maybe this reply is an error too.
[02:58] <c_14> Can you pastebin the full command and output of what you're trying to do.
[02:59] <Affy> http://pastebin.com/8Qw9SQhZ
[02:59] <Affy> Just checking version after an install.
[02:59] <Affy> Looks like everything's all right.^^
[02:59] <c_14> looks fine to me
[03:00] <Affy> I was just using the paste to show that I finished...'cause I had issues before.
[03:00] <Affy> Thanks for the help...*scrolls up*...errr...
[03:00] <Affy> You, actually, c_14...also sacarasc and @@ive.
[03:01] <c_14> np
[03:02] <Affy> Yeah, thanks.^^Thanks. Best of luck and an enjoyable end of the weekend to all.
[03:58] <SirCmpwn> until recently, I was able to use -vf "scale=trunc(in_w/2)*2:trunc(in_h/2)*2" to ensure that a file would have an even width and height
[03:58] <SirCmpwn> this does not appear to be working any more
[03:59] <SirCmpwn> in fact, -vf scale even with hardcoded parameters doesn't appear to help
[03:59] <klaxa> huh?
[03:59] <klaxa> pastebin please
[04:00] <SirCmpwn> https://gist.github.com/SirCmpwn/7aeabe5779a2ac44b606
[04:00] <klaxa> that doesn't seem to be related to the video filter
[04:00] <klaxa> same output with -loglevel debut please
[04:01] <SirCmpwn> https://gist.github.com/SirCmpwn/329f81831383d55c8e99
[04:01] <klaxa> also consider either putting both video filters in one command or use a filter complex (which i have come to love since yesterday)
[04:01] <SirCmpwn> ah, dropping yadif does help
[04:02] <klaxa> >[graph 0 input from stream 0:0 @ 0x1730e80] Setting 'video_size' to value '622x337'
[04:02] <klaxa> this looks wrong regardless
[04:03] <klaxa> oh wait, that's the input
[04:03] <klaxa> >Stream #0:0, 0, 1/90000: Video: h264, yuv420p, 622x337, 1/100, q=-1--1, 90k tbn, 100 tbc
[04:03] <klaxa> but this can't work
[04:03] <SirCmpwn> it works if I merge yadif and scale into the same -vf
[04:03] <klaxa> why are you using yadif on a gif btw=
[04:03] <klaxa> ?
[04:04] <SirCmpwn> was decided on through an automated procedure
[04:04] <SirCmpwn> tried to detect interlacing and passed
[04:05] <klaxa> ah
[04:05] <klaxa> using yadif before scaling is probably a good idea too
[04:06] <SirCmpwn> alright
[04:06] <klaxa> to use the same thing as a filter complex use -filter_complex "[0:v:0]yadif[deint]; [deint]scale=trunc(in_w/2)*2:trunc(in_h/2)*2" instead of -vf
[04:07] <SirCmpwn> as much as I'd love to do that
[04:07] <SirCmpwn> the actual filters in use are determined programatically
[04:07] <SirCmpwn> and that is much harder to put together
[04:07] <klaxa> ah probably
[04:11] <SirCmpwn> https://github.com/MediaCrush/MediaCrush/commit/94e0d4b86ef880ee9e2a26033a39ee0e8ab1ad6e
[04:37] <dhaval2712> So there's this.. the -to , -ss and the -t flags basically aren't working.
[04:37] <dhaval2712> http://pastebin.com/DJjppUML Oh sorry forgot the apste
[04:38] <klaxa> you are using avconv and not ffmpeg, see #libav
[04:38] <dhaval2712> c_14: So? Can you help me?
[04:39] <klaxa> not sure you should put quotes around the time either
[04:39] <dhaval2712> Hang on, klaxa, what does that mean?
[04:39] <klaxa> :I
[04:39] <dhaval2712> Ah.
[04:40] <dhaval2712> I tried it in ffmpeg in Fedora as well, that wasn't working either.
[04:41] <c_14> I'd get rid of the quotes around the time, also having -ss twice is rather redundant. Unless of course -ss is additive, in which case it would still be better to only have one -ss.
[04:41] <c_14> better as in easier to comprehend
[04:41] <dhaval2712> Tried both.
[04:41] <klaxa> ah, no i see what he's trying to do
[04:41] <klaxa> quick look-ahead before decoding
[04:41] <dhaval2712> There's a large flac file, I'm trying to extract the individual songs from it.
[04:42] <klaxa> *seek
[04:42] <dhaval2712> I tried to simply extract it, that didn't work either.
[04:42] <klaxa> see: https://trac.ffmpeg.org/wiki/Seeking%20with%20FFmpeg
[04:43] <dhaval2712> I tried to set the duration, didn't work.
[04:44] <c_14> Have you tried getting rid of the quotes around the time?
[04:45] <dhaval2712> I did.
[04:45] <dhaval2712> And I used -t. It worked!
[04:45] <dhaval2712> Thank you so very much!
[04:45] <dhaval2712> exit
[04:46] <c_14> I'm glad I helped?
[05:23] <absolutezeroff> Hello. Complete newbie here, I'd just like to know: what is a simple way to use ffmpeg to record video + audio from the desktop and write to a locally hosted stream using ffserver? I have everything installed and am running it on xubuntu.
[10:28] <FedoraUser> hi friends
[10:28] <FedoraUser> can I use ffmpeg to scan for mask marker and insert an image in its place?
[10:51] <FedoraUser> I don't know if it was clear what I wanted, so here is the example: http://i59.tinypic.com/mt5ls4.png
[10:52] <FedoraUser> I am not asking how exactly should I do it, just general pointers, what filters should I look into etc...
[11:07] <Mavrik> do we know of any OCR library for DVB subtitle recogniion?
[11:31] <EcoGiko> Hello, I have a problem with compiling ffmpeg with libvpx. These are the commands I am using and my path. https://dpaste.de/PWWZ
[11:33] <EcoGiko> https://dpaste.de/KcQn - forgot to mention the error itself...
[11:52] <EcoGiko> hello?
[12:06] <sacarasc> So, compiling libvpx does nothing at all?
[12:07] <fling> I need to join multiple videos together
[12:07] <fling> but how to take only few seconds with offset from each video with a single command?
[12:08] <fling> I don't want to split them to smaller ones first
[12:10] <fling> not possible?
[12:10] <EcoGiko> sacarasc: I think so
[12:10] <fling> all the files are encoded with the same huffyuv codec, same geometry, ar, framerate and no sound
[12:11] <fling> sacarasc: Hello. :>
[12:11] <EcoGiko> sacarasc: I am currently trying to compile it using this guide: http://wiki.webmproject.org/ffmpeg/building-with-libvpx
[12:14] <EcoGiko> sacarasc: but the problem persists...
[12:14] <sacarasc> EcoGiko: What is the output of ./configure for libvpx?
[12:15] <sacarasc> fling: I have no idea.
[12:15] <sacarasc> Which is why I said nothing. :D
[12:15] <EcoGiko> sacarasc: https://dpaste.de/uLWa
[12:16] <sacarasc> And then it says nothing at all really for make?
[12:17] <EcoGiko> sacarasc: then I make it and the last line says: make[1]: Nothing to be done for `all'.
[12:17] <EcoGiko> sacarasc: https://dpaste.de/P31b
[12:26] <EcoGiko> any help?
[12:39] <nell> hi
[12:40] <EcoGiko> hi
[13:03] <EcoGiko> Hello, I have a problem with compiling ffmpeg with libvpx. These are the commands I am using and my path, also the config.log - https://dpaste.de/uvwK
[14:52] <Sander_> Hi, i have some problems with mapping and to get my stream stable working. http://pastebin.com/cS5FNb2y
[15:20] <l_r> hello
[15:21] <l_r> i keep getting this warning when recording audio + video
[15:21] <l_r> [alsa @ 0x1d0ffb0] ALSA buffer xrun. 147kB time=00:00:03.04 bitrate= 396.2kbits/s
[15:21] <l_r> do you have any idea?
[15:21] <l_r> it happens every secon
[15:23] <l_r> do dd if=/dev/video0 bs=256k | ffmpeg -f alsa -ac 1 -ar 22050 -i hw:1,0 -loglevel verbose -analyzeduration 1 -f h264 -r 13 -i - -c:v copy -strict experimental -c:a pcm_s16le -f flv rtmp://myserver
[15:23] <l_r> that's the command
[15:42] <mr-foobar> hi all, trying out command line editing with ffmpeg. Here's what I want to achieve ... make a continuous video into a sequence of frames
[15:43] <mr-foobar> can I extract a frame and loop it a few seconds in a single line, with some filter magic ? I know I can do it in two lines
[18:10] <Affy> I successfully compiled and installed ffmpeg using https://trac.ffmpeg.org/wiki/UbuntuCompilationGuide, but I can't seem to actually find it. rutorrent can't, and it's not in /usr/bin/ffmpeg. Any ideas where?
[18:11] <c_14> If you followed the wiki, in $HOME/bin
[18:12] <Affy> Aha. User bin. Reading the conclusion of the guide is sometimes useful...
[18:14] <Affy> -_- Thansk again.
[18:14] <c_14> np
[18:14] <Affy> Thanks* Gee. Can't even spell.
[18:15] <Affy> Thanks and Thansk...both.
[20:22] <absolutezeroff> Hello. I'm trying to do something with ffserver, but when I try it gives me an HTTP Error 404 http://pastie.org/8998712
[20:22] <absolutezeroff> This is my ffserver.conf http://pastie.org/8998715
[20:23] <absolutezeroff> http://pastie.org/8998716 and this is the command i use to try to output to ffserver
[20:43] <TakaradaService> Hello, I'm trying to make a slideshow out of pictures in a folder with the following line : "ffmpeg.exe -r 1/5 -i image%03d.png -vcodec libx264 out.mp4" but my output only has the four last files of folder
[20:43] <TakaradaService> Is there something obvious I'm missing ?
[20:45] <TakaradaService> Oh nevermind, found the problem
[20:45] <TakaradaService> One of the images isn't the same size
[21:10] <hannes3> hey, i am not sure what happened. i was successfully making a video out of still frames and an audio track before but if i do it now, media players first play the audio and only later start the video. i used: ffmpeg -i frames/%04d.png -i music.mp3 -vcodec libx264 -crf 25 -preset veryfast -pix_fmt yuv420p -acodec copy out.mkv
[21:10] <hannes3> did anything change recently in an update?
[21:10] <hannes3> i use ffmpeg version 2.2 on archlinux
[22:21] <t4nk311> Hello
[22:22] <t4nk311> I'm trying to use ffmpeg but I don't know where the file to convert goes, can anyone help?
[22:23] <hannes3> you need to be more verbose what exactly you are trying to do and how
[22:24] <t4nk311> I'm wanting to convert a file, so I use the command line, but it shows me this http://gyazo.com/be955d53802368435460ffff1c22e8c7 where do I put the original file to convert it
[22:26] <hannes3> you have to be in the same directory as the original file or supply the full/relative path to it
[22:26] <t4nk311> I see
[22:27] <t4nk311> Could you post me an example. It doesn't seem to be working.
[22:29] <hannes3> "ffmpeg -i ../source.mkv out.mkv" or "ffmpeg -i /home/me/somefile.mkv /mnt/somewhereelse/out.mkv"
[22:32] <EcoGiko> Hello, I have a problem with compiling ffmpeg with libvpx. These are the commands I am using and my path, also the config.log - https://dpaste.de/uvwK
[22:34] <klaxa> EcoGiko, your libvpx seems to be too old?
[22:35] <EcoGiko> klaxa: I just downloaded from source
[22:35] <klaxa> >/tmp/ffconf.p4xCZ1mb.c:1:29: fatal error: vpx/vpx_decoder.h: No such file or directory
[22:36] <klaxa> let's look at the configuration again... one sec
[22:37] <klaxa> hmm... are you sure libvpx is correctly compiled and installed?
[22:37] <klaxa> because it looks correct
[22:42] <klaxa> EcoGiko?
[22:42] <EcoGiko> klaxa: yeah?
[22:42] <klaxa> did you check the stuff?
[22:43] <klaxa> is there an include directory in your ffmpeg_build directory?
[22:43] <EcoGiko> klaxa: yes there is
[22:43] <klaxa> if so there *should* be vpx/vpx.h if it was correctly installed
[22:43] <EcoGiko> klaxa: there isn't a vpx.h
[22:44] <EcoGiko> encoders, decoders, images, integer, vp8 stuff but not vpx.h
[22:44] <klaxa> also, --extra-ldflags="-I$HOME/Programs/ffmpeg_build/lib" should be --extra-ldflags="-L$HOME/Programs/ffmpeg_build/lib"
[22:44] <klaxa> ah, vpx_decoder.h and such?
[22:45] <EcoGiko> yeah
[22:46] <klaxa> weird that ffmpeg reports that it can't find the files then
[22:46] <klaxa> can you run configure again and change the --extra-ldflags while at it?
[22:47] <EcoGiko> klaxa: oh wow, I replaced the flag -I with -L and it worked
[22:47] <klaxa> ah good
[22:48] <EcoGiko> now I will make it and install it
[22:49] <EcoGiko> klaxa: thanks a lot, I have been waiting for 13 hours for a response...
[22:49] <klaxa> woah
[22:49] <klaxa> well...
[22:49] <EcoGiko> all is well when it ends well
[22:50] <klaxa> compiler and linker flags are not really trivial (although these pretty much are)
[22:59] <EcoGiko> klaxa: what does the nonfree flag do?
[22:59] <klaxa> enable non-free encoders and decoders probably?
[23:00] <klaxa> >  --enable-nonfree         allow use of nonfree code, the resulting libs
[23:00] <klaxa> >                           and binaries will be unredistributable [no]
[23:10] <rjp421> is there some special way to pipe audio from a transcode in linux? Unable to find a suitable output format for 'pipe:'....  using cmd: 'avconv -i "urltoshoutcaststream" -acodec pcm_s16le -ar 22050 -ac 1 -' on debian7 and raspberry pi
[23:11] <klaxa> a) use -f to force a format, in your case either -f rawaudio or -f wav or something similar
[23:11] <klaxa> b) you are using avconv, see #libav
[23:12] <rjp421> ok ty, i use ffmpeg mainly it just warned to use avconv so i did
[23:33] <DoomBoom> hey, I'm trying to convert gifs to webm's, but the output always turns out to be a 1 frame-long webm when I test it in Firefox
[23:33] <DoomBoom>  terminal output: http://pastebin.com/ymSPH8XV input file: https://dl.dropboxusercontent.com/u/26359447/Poland%20modern%20border%20history.gif output file: https://dl.dropboxusercontent.com/u/26359447/output.webm
[23:33] <DoomBoom> do I have to add some option so it takes the whole gif?
[23:35] <absolutezeroff> funny i found a guide for this on 4chan of all places
[23:35] <absolutezeroff> http://boards.4chan.org/g/res/41212767
[23:36] <DoomBoom> actually I tried that too, same result
[23:36] <DoomBoom> well, I tried that with avconv
[23:37] <DoomBoom> I also tried it with deprecated ffmpeg but that didn't work at all
[23:37] <klaxa> did you try with proper ffmpeg
[23:37] <klaxa> ?
[23:37] <DoomBoom> I noticed this: "Duration: 00:00:00.04" on the input file info, which makes me think avconv isn't getting the gif correctly
[23:37] <DoomBoom> I'll try ffmpeg again
[23:39] <EcoGiko> DoomBoom: try running ffmpeg directly from the bin folder ./ffmpeg, I got the same problem, all my stuff were 0.04 in duration
[23:39] <DoomBoom> it fails when I use the options that the 4chan thread recommends, and it does exactly the same as avconv when I supply no options except input and output files
[23:39] <klaxa> no problems here: http://dedi.klaxa.eu/public/Poland%20modern%20border%20history.webm
[23:40] <klaxa> looks really bad there for a second though
[23:40] <DoomBoom> something must be wrong on this end then
[23:40] <klaxa> although crf is set to 4
[23:40] <EcoGiko> is there a way for me to replace the avconv ffmpeg with the real ffmpeg?
[23:41] <klaxa> compile from source?
[23:41] <klaxa> afaik the libraries are not 100% compatible
[23:41] <DoomBoom> running ffmpeg from /usr/bin does the same as running it normally
[23:42] <klaxa> what?
[23:42] <klaxa> you are probably not using ffmpeg then
[23:42] <EcoGiko> good night, I am off
[23:44] <DoomBoom> oh
[23:44] <DoomBoom> I just installed ffmpeg from the debian repositories
[23:44] <klaxa> that is avconv
[23:44] <klaxa> see #libav in that case
[23:44] <DoomBoom> ah
[23:45] <DoomBoom> damn debian
[23:46] <DoomBoom> thanks anyway
[23:52] <absolutezeroff> ah
[00:00] --- Mon Apr  7 2014

More information about the Ffmpeg-devel-irc mailing list