[Ffmpeg-devel-irc] ffmpeg.log.20140414

burek burek021 at gmail.com
Tue Apr 15 02:05:01 CEST 2014

[00:05] <dwirc> I've tried the "-shortest" option, but when placing before the input (where I believe it is supposed tobe), I get the following error:
[00:05] <dwirc> Option shortest (finish encoding within shortest input) cannot be applied to input file
[00:06] <dwirc> Moving the "-shortest" option AFTER the input, ffmpeg executes, however when the input stops FFMPEG hangs again.
[00:13] <Hello71> reduce it to the most basic test case
[00:24] <dwirc> roger that
[00:25] <dwirc> Here is the pastebin with the command line, and full output:
[00:25] <dwirc> http://pastebin.com/QAwbK3xK
[00:40] <xlys> Maybe I'm just not looking for it properly, but when I run ffmpeg -i file I get a lot of file info, but as far as I can see the container format is not outputted. If I have a video file with no extension, can ffmpeg tell me what the container format is (what the right extension would be)?
[00:42] <clever> xlys: 'file' may identify it
[00:43] <xlys> clever: The program file? I thought about that, but it only says         Video 13-04-14: MPEG sequence, v2, program multiplex
[00:43] <xlys> ?
[00:43] <clever> ah
[00:44] <clever> not sure then, my only guess would maybe be mpegts, program stream
[00:49] <xlys> clever: Okay, thanks! :)
[01:33] <dwirc> Any thoughts on why this would be happening with my source?  Or is there any better way to detect a lack of input and have FFMPEG stop?
[02:05] <SirCmpwn> trying to use -progress
[02:05] <SirCmpwn> but ffmpeg won't do anything at all if I do
[02:05] <SirCmpwn> it just exits immediately
[02:05] <SirCmpwn> ffmpeg -progress -i Hatsune\ Miku\ Live\ Party\ in\ Kansai\ Part\ 1.mkv -to 00:25:51 output.mkv
[02:12] <llogan> SirCmpwn: i've never tried that option, but the author, Nicholas, may provide some information on ffmpeg-user mailing list
[02:12] <SirCmpwn> llogan: thanks
[03:41] <Ertain> Hello everyone.  I have a webm file that I'm trying to split up.  I'm using the command, "avconv -i file.webm -sameq -ss 00:03:20 -t 00:03:28 output.webm", but that doesn't work.  It only moves up to the 00:03:20 part of the video, and then just puts the rest of the stream into "output.webm."
[03:43] <klaxa> for avconv support see #libav
[03:45] <Ertain> Thanks, klaxa.
[04:16] <Jinx> I have a MOV with corrupted audio which I have repaired into a WAV file. How can I mux my original video (which still includes audio) but give it the new audio from the WAV file?
[04:17] <Jinx> My efforts thus far have yielded a "Seems stream 0 codec frame rate differs from container frame rate"... which occurs regardless of whether the WAV is 44.1 or 48khz
[05:16] <riveter> I'm trying to convert an h264 stream to pngs and am getting unacceptable lag.  Is there a command line option that would tell it to only process iframes?
[06:44] <pzich> is there any tmp file cleanup I should be doing for an aborted or failed encode?
[08:27] <AndrzejL> is winff official ffmpeg frontend? I am asking coz I am looking for a nice set of x264 / mkv presets and cannot find them and I am to lazy or would I say I dont have sufficient knowledge to create them myself ;D.
[08:28] <AndrzejL> I have the official presets from winff site - I am looking for something more then that
[08:38] <diesel420> AndrzejL, i am not sure if it is the right place to ask, if you use winff and want a nice x264 preset. i never used winff and maybe i just dont understand your question properly.
[08:38] <diesel420> but my favorite x264 preset would be: --preset=placebo --tune=film --profile=high --aq-mode=2 --me=umh --merange=32
[08:39] <diesel420> is off of topic and i apologize for it ;)
[08:52] <AndrzejL> diesel420: nah you're fine - if winff is not officialy supported by ffmpeg then I am looking in a wrong place - hence my question :) - will try figuring something out - I always do ;D
[09:15] <kcynice> hello, its my first usage of ffmpeg. I want to reduce the output file size of my arm-linux. I only decode frames from a mp4 video with mpeg4 encoding. any compiling configure idea?
[09:16] <kcynice> i use the example code, demuxing-decoding.c, the output file size is up to 11M, eventhough i stripped it
[09:23] <ubitux> kcynice: start with --disable-everything, and add what you need
[09:24] <ubitux> typically --enable-demuxer=mp4 --enable-decoder=h264 --enable-encoder=mpeg4 ... --enable-protocol=file,pipe
[09:25] <ubitux> ofc other codecs are possible with mp4, depends on what you want to support
[09:36] <kcynice> thans ubitux, i will paste my configure, and the test result
[09:43] <kcynice> ubitux, what's --enable-protocol meant, i only native file, no other streams, such as network,pipe, etc
[09:43] <ubitux> then just enable file
[09:48] <kcynice> there is no mp4 demuxer, i use mpegvideo, right?
[09:48] <kcynice> for my last try, i got a failure at av_format_open_input,  i did not know which option affected on it.
[10:07] <kcynice> ubitux, i use the same configure options, but got the the same failure for arm, failed at avformat_open_input. any help?
[10:08] <ubitux> what's your configure ligne?
[10:08] <ubitux> line*
[10:11] <kcynice> --disable-everything --enable-demuxer=mpegvideo --enable-decoder=mpeg4 --enable-protocol=file
[10:12] <ubitux> you want "mov" as demuxer
[10:13] <ubitux> you sure you have mpeg4 and not h264 in your mp4(s)?
[10:18] <kcynice> Im sure not h264 within it, but, the configure works well for pc version
[10:19] <kcynice> use mplayer play the original video and got an output:
[10:20] <kcynice> Selected video codec: [ffodivx] vfm: ffmpeg (FFMpeg MPEG-4)
[10:21] <ubitux> can you pastebin a ffprobe of your input file?
[10:21] <kcynice> OK. hang on.
[10:23] <kcynice> done. at http://pastebin.com/Eyiny7MP
[10:24] <ubitux> and so with the mov demuxer it doesn't help?
[10:45] <`Fibz> i have a dumbphone, the Pantect Crux. im trying to convert video to watch on this device. in windows i need just use windows movie maker. i've been trying all day in linux and it just doesnt want to play anything i encode with openshot
[10:45] <`Fibz> any suggestions?
[10:46] <ubitux> where is the ffmpeg question?
[10:46] <`Fibz> how to use
[10:46] <ubitux> you want me to paste the whole manual on irc?
[10:46] <`Fibz> no just some suggestions on codec, container and settings
[10:47] <ubitux> well, what does your device supports?
[10:47] <`Fibz> supposedly mpeg, mp4 and wmv,
[10:48] <ubitux> what about the codecs?
[10:48] <`Fibz> do you have any suggestions about how i can go about finding this out?
[10:48] <ubitux> read the specs of your device
[10:49] <ubitux> you can try to ffprobe a file that works as well
[10:49] <`Fibz> it says what i said. mpeg, mp4 and wmv
[10:49] <ubitux> http://trac.ffmpeg.org/wiki/x264EncodingGuide#Compatibility here are some examples for other devices
[10:49] <`Fibz> thank you
[10:50] <kcynice> its returned value was 0xBEBBB1B7,  but i do not know what's it meant
[10:50] <ubitux> return value of what?
[10:52] <kcynice> avformat_open_input
[10:56] <ubitux> av_err2str()
[11:03] <kcynice> i got it: Error:Invalid data found when processing input
[11:57] <anshul_> kcynice,look whether data is valid. ;)
[12:04] <kcynice> anshul_, i was puzzled by that, because it works find for pc version
[12:07] <anshul_> you mean fine on another pc's
[12:35] <kcynice> no, the operation failed on arm-linux, ok for pc-linux
[12:43] <ubitux> with the same options?
[12:43] <ubitux> or you mean a full featured x86 buld vs your partial arm build?
[13:04] <mr-foobar> how do you delete a particular region, -ss t, in the video using ffmpeg ?
[13:21] <kcynice> ubitux, i have to leave now, im not sure i have time to enter here later. thanks for your help, anshul_ , too
[13:21] <kcynice> have funs
[15:50] <dwirc> Is there any way to have ffmpeg exit if an RTSP source stops sending data, or drops the TCP connection entirely? (Yes TCP - forcing the connection to TCP instead of UDP).
[18:25] <wickwire> Hi guys, I've been asked to implement a server-client demo for RTP/RTCP and video (h264). Since I'm new to this kind of technology, would it be possible for anyone here to confirm if ffmpeg is a good starting point for this, and if so, where to begin reading...?
[18:25] <wickwire> I've already downloaded ffmpeg's source code
[18:26] <wickwire> and have been reading several forums and guides online, but without much progress
[18:26] <wickwire> I've also found out about oRTP, an open source library using with linphone - got it to work, but for audio only
[18:28] <wickwire> to be noted, I was thinking about using ffmpeg in the hopes of understanding how this can be done, and possibly not have to use the whole of ffmpeg to do it but just the essential bits
[18:49] <barnoux> hello
[18:49] <barnoux> i need to install the last version of ffmpeg on a gentoo distro, do you have a tutorial for that?
[18:55] <klaxa> https://trac.ffmpeg.org/wiki/CompilationGuide
[18:55] <quup> barnoux: can't you just unmask and emerge?
[18:57] <barnoux> quup, i will try but does this version include the libfdk_aac ??
[19:00] <quup> no idea
[23:49] <naggi> Hello! :)
[23:50] <naggi> Just wonder, is there any program you guys know where i can take an MP4 file and see how its encode'd so i just can copy those settings and encode myself with those?
[00:00] --- Tue Apr 15 2014

More information about the Ffmpeg-devel-irc mailing list