[Ffmpeg-devel-irc] ffmpeg.log.20140420

burek burek021 at gmail.com
Mon Apr 21 02:05:01 CEST 2014

[01:13] <xreal> Is there an easy way to build ffmpeg on Windows with libfdk_aac ?
[01:16] <klaxa> depends on how you define easy
[01:17] <xreal> klaxa: A nice "how to" without too much knowledge... I'm a linux guy :)
[01:18] <klaxa> you will need to compile libfdk-aac for windows and then compile ffmpeg and link it against your libdfk-aac libraries you built
[01:19] <xreal> klaxa: I think, I'll install vbox with debian for this... sounds more easy.
[01:19] <xreal> And another question: I want to transcode some FLV files to MP4. As I've read, it's best to use this "-vcodec copy -acodec copy" or that "-codec: copy" to create an intermidiate FLV file first and use MP4Box to create the final MP4 (for compatibility reason). Is this still "up to date"?
[01:19] <xreal> The FLV contain MP4 and AAC streams.
[01:19] <klaxa> don't know about compatibility, try to use the mp4 muxer from ffmpeg first maybe?
[01:20] <klaxa> also if you are copying the codecs it's more remuxing and less transcoding
[01:20] <xreal> klaxa: exactly, sorry. How can I use ffmpeg's muxer?
[01:20] <klaxa> ffmpeg -i input.flv -c copy output.mp4
[01:20] <klaxa> as easy as that
[01:21] <xreal> klaxa: 1 sec :)
[01:23] <xreal> klaxa: Works, but ffmpeg is used to playback. So this isn't a real test :)
[01:23] <xreal> klaxa: MP4Box support things like qt-faststart.
[01:24] <klaxa> so does ffmpeg
[01:25] <xreal> klaxa: I think, most of the documentations are reports on the web are quite outdated :(
[01:26] <xreal> klaxa: can I make ffmpeg show details of my mp4 ?
[01:26] <klaxa> try ffprobe for that
[01:27] <tachoknight> in case anyone comes across this in a search, this is how I created a 20 second clip from a jpeg and added a in and out fade:
[01:27] <tachoknight> ffmpeg -loop 1 -r 23.976 -i test.jpg -t 00:00:20 -vf 'fade=t=in:st=5.5:d=1.5, fade=out:0:400' test.mp4
[01:27] <klaxa> also, see: http://www.ffmpeg.org/ffmpeg-formats.html#Options-3
[01:29] <xreal> klaxa: Here are the results. http://pastie.org/private/3yifgp7lf6wyadjtslmipg
[01:29] <xreal> I wonder, why datarate has changed.
[01:30] <klaxa> might be muxing overhead
[01:30] <klaxa> usually bitrate is calculated by filesize/time
[01:31] <klaxa> if the container has less overhead, it will come out as a lower number
[01:31] <xreal> klaxa: Ah, ok.
[01:32] <xreal> klaxa: What do you think about this one? -codec copy -map 0 -movflags +faststart
[01:32] <klaxa> well try it out
[01:32] <klaxa> and see if it does what you want it to do
[01:33] <xreal> klaxa: works again... I think, I need to get another player. Mine used ffmpeg to plackback.
[01:33] <xreal> uses*
[01:33] <klaxa> what kind of player is that?
[01:33] <klaxa> because most players somehow rely on libav* from ffmpeg
[01:34] <klaxa> on linux at least
[01:34] <klaxa> there are a lot that don't though
[01:34] <xreal> klaxa: it's a codec collection for Windows.
[01:34] <klaxa> maybe it's not most players after all
[01:34] <xreal> MediaPlayer Home with a common codec collection.
[01:35] <xreal> Hm... ffprob doesn't give pretty much details on mp4.
[01:35] <klaxa> try mediainfo
[01:36] <xreal> k
[01:36] <klaxa> also what codec pack? CCCP? KCP?
[01:36] <klaxa> what was the other good one?
[01:37] <xreal> klaxa: 1 sec
[01:37] <xreal> klaxa: K-Lite.
[01:37] <xreal> mediainfo also doesn't give info about moov :(
[02:12] <xreal> Is it possible to set details when creating MP4 files, like Title, Copyright etc. ?
[02:16] <klaxa> xreal: https://ffmpeg.org/ffmpeg.html#Main-options see -metadata
[02:16] <xreal> klaxa: Thanks again.
[02:23] <xreal> klaxa: Hmm. Is this wrong? -metadata:s:a:1 handler_name="abc"
[02:23] <klaxa> i don't know, i never use metadata
[05:56] <gustavo_brazil> hey guys, how to record my skype talks with ffmpeg ?
[08:00] <tm512> so is x264 lossless actually lossless or not? someone in here was telling me that it isn't, but other places are saying otherwise
[08:01] <tm512> x264 -qp 0 -preset ultrafast gives much better compression than huffyuv
[08:02] <tm512> 89809 kb/s yuv444p vs 210999 kb/s yuv422p
[08:15] <blippyp_> tm512: was just looking into that again (not sure where I first read about it) - I may have informed you improperly - I think it's considered 'not lossless' because converting from rgb to yuv color space generates some lost data. However if you convert rgb to yuv444, then apparently there is no loss (ie - is in fact lossless). So keeping that in mind, you can use libx264 and still get some compression, while still keeping a lossless encodi
[08:17] <tm512> there's still loss in color from going from rgb to yuv, it affects things like console text colors
[08:18] <tm512> unless mplayer is further downsampling to 420
[08:18] <blippyp_> that would be my guess: here's the reference to what I was explaining: https://trac.ffmpeg.org/wiki/x264EncodingGuide
[08:19] <blippyp_> look at the bottom of the page: Why doesn't my lossless output look lossless?
[08:22] <tm512> it would be lossless if the source was yuv
[08:22] <tm512> but after i have it in yuv, i could infinitely reencode without loss, right?
[08:23] <tm512> since all the colors are already in yuv space
[08:25] <blippyp_> it's IS lossless when converting from rgb to yuv444 - the colors may be 'off' from the conversion, but there is no drop in quality - do a test - convert from rgv to yuv444, then convert that file back into rgb again - do you colors go back to normal? I'm betting they do and that what you're noticing is a side effect from the conversion. This is what I was trying to explain to you earlier - About the conversion messing up the colors - That 
[08:29] <tm512> well no after the colors have been converted (rounded, truncated) or whatever to yuv the original rgb data is lost forever right
[08:29] <tm512> I mean it's converted to rgb in my media player
[08:30] <blippyp_> ignore what you're 'seeing' - your player might be fooling you - do a quick test like I said...
[08:30] <blippyp_> if the video looks normal to you have converting back from yuv to rgb again, then you KNOW that the data is still there
[08:31] <blippyp_> it's just being displayed differently - to correct it you would likely need to run the video through a hue filter to change the hsv values (to whatever you need) to get it back to what it looked like when it was rgb
[08:32] <blippyp_> this would be a very minor change (like lowering saturation by one or brightness by one, maybe both)
[08:33] <blippyp_> as an example of what I'm talking about - check out this page: http://www.infognition.com/VirtualDubFilters/color_correction.html
[08:33] <blippyp_> I still haven't found one for rgb to yuv444 yet though
[08:34] <tm512> anyway using 444 should give me more color information to work with to change around with filters, so that's nice
[08:39] <blippyp_> tm512: You'll probably like this page (it seems to have some answers for you) http://ffmpeg-users.933282.n4.nabble.com/RGB-YUV-color-shift-td4654294.html
[10:04] <sor_> is there a way to record the full desktop but in a smaller screen insteed of full size? -- i know i scan scale afte just want to know if i can do it during -- thanks
[10:18] <blippyp_> sor: -s 640x480 (put this just before or after you declare your codecs for saving and it will resize the video) - not really sure what you mean though or if this answers your question - if not, please be more specific...
[10:21] <sor_> thanks will try
[10:21] <tm512> doing the colormatrix filter shouldn't mess things up when youtube processes the video right?
[10:23] <sor_> blippyp_, it's square and -s 640:-1 doesn't work
[10:23] <blippyp_> tm512: yeah, I thought that would be what you'd do - no, I would expect youtube to leave it be - as long as you stay within their limits (like the suggested encoding page I sent you to earlier today) then your video should stay basically the same when tyey're done re-encoding it they way the want/different formats etc.... Although you might see a difference between one format compared to another - not sure, I haven't tested that - but I wo
[10:23] <blippyp_> sor: please be more specific, what do you mean it's square?
[10:24] <blippyp_> sor: also, not sure if -1 works with the -s switch
[10:24] <sor_> blippyp_,  i have 1280x800 so 640x480 doesn't show full screen
[10:25] <sor_> it should be 640:-1 but that doesn't work unless i recode it after
[10:26] <blippyp_> sor: k - I'm still not understanding your problem I think - I assume you've used -vf "scale=640:-1" ?
[10:26] <blippyp_> and this isn't doing what you want?
[10:27] <sor_> blippyp_,  crap forgot th = --- thanks
[10:27] <blippyp_> cool
[10:27] <sor_> :)
[10:31] <tm512> blippyp_: well, interestingly, without the filter colors overall are more accurate
[10:31] <blippyp_> maybe you need to 'tweak' the filter more/less?
[10:31] <blippyp_> are you just copy/pasting it or did you put some thought into what it's doing?
[10:32] <tm512> it's really really close if I don't use the filter
[10:32] <tm512> some colors seem to get messed up no matter what
[10:32] <blippyp_> to be honest, I would leave it be - smarter minds than us have set these things as a default for reasons unknown to the masses....  ;)
[10:33] <tm512> overall I'm happy with the quality of this though
[10:33] <blippyp_> I understand it's frustrating that it's not 'identical' to your source, but no one will notice - my opinion
[10:34] <blippyp_> i can certainly relate (not about the color variance) but when I first started uploading to youtube it frustrated me to NO END that the resulting video on youtube looked like horrid shit compared to my beautiful encoding I did... Took a lot of research and time to finally accept that they were just destroying it and there was little to nothing I could do about it....
[10:39] <jonascj> Hi all. I run a ffserver with config http://pastebin.com/gyzWkNnL . On a feed machine I run: "ffmpeg -v verbose -r 10 -s 320x240 -f video4linux2 -i /dev/video0 http://host.com:8090/webcam.ffm" but receive a pixel format error: http://pastebin.com/0DjAkAr6
[10:39] <jonascj> I have been asking about this in here previously but I've failed to correct the error.
[10:40] <jonascj> the command works perfectly if I substitute "http://host.com:8090/webcam.ffm" with "file.mp4". So I assume my ffmpeg is working.
[10:41] <jonascj> Someone in here told me to put PixelFormat in my ffserver.conf file, but ffserver says "incorrect keyword" when I place "PixelFormat ..." in the stream section of the config file.
[10:42] <tm512> blippyp_: thanks for the help though. I'm gonna get to sleep
[10:42] <tm512> good night
[10:43] <blippyp_> no problem tm512
[10:43] <blippyp_> night
[10:45] <jonascj> Together with another helpful person in here I thought that maybe video4linux2 library support wasn't there, but compiling with --enable-libv4l2 does not make a difference. With out without that directive the command I've justed posted works with a file output and fails with ffserver feed/stream output.
[10:46] <blippyp_> jonascj: what pixel format are you trying to switch it to?
[10:47] <jonascj> blippyp_: to tell you the truth I didn't think much about pixel formats when I first started out trying to get this working. So I am not trying anything specific besides getting some images through to my ffserver. I will convert it to what ever that requires :)
[10:48] <blippyp_> I haven't used it before (and so far am not finding much documentation)
[10:48] <jonascj> last time I discussed this with someone in here (a few days ago) I did not fully understand who (ffserver or ffmpeg) complains about this.
[10:48] <jonascj> blippyp_: what haven't you used before? ffserver with ffmpeg or yuvxx pixel formats?
[10:49] <blippyp_> try setting it to yuv420p
[10:49] <blippyp_> I've used ffserver, but it was ages ago - I never had to switch the pixel format with it...
[10:49] <blippyp_> I did very limited testing - got it work and moved onto other things
[10:50] <blippyp_> if yuv420p works, but you're looking for better quality, there are other options (give your settings I'm assuming you not caring about that issue too much)
[10:51] <blippyp_> god I'm typing like a moron today
[10:53] <blippyp_> is there a reason why you're using mjpeg?
[10:55] <blippyp_> yuv might not work with that - maybe try a pixel format of rgb8 (256 colors) or rgb24(like 60,000 colors I think)
[10:57] <jonascj> blippyp_: I am very novice ot htis. I just saw a collegue of mine monitoring our 3d printer with a webcam hooked up to a windows pc with some windows webcam software. To view the webcam feed he connected to the computer with the webcam using Teamviewer. That just made me want to look into streaming.
[10:58] <jonascj> and everyone seemed to be using ffmpeg and ffserver to get webcam feeds of off raspberrypi's and similar.
[10:58] <blippyp_> you're on the right track, ffserver will do that for you
[10:58] <blippyp_> yeah, it's common - ffmpeg/utils are really powerful and under-appreciated by so many people
[10:58] <jonascj> mjpeg was just what a lot of people used because it has native support in many browsers. So it can be directly embedded as an image in a webpage etc.
[10:59] <blippyp_> ah...
[10:59] <jonascj> blippyp_: if I wanted the feed in a mediaplayer I suppose I could use something else.
[10:59] <blippyp_> it looks like yuv420p should work with mjpeg - I'd go with that one
[11:01] <jonascj> no matter what I specify using "-pix_fmt x" with my ffmpeg command (on the computer running the webcam) I get the same error back. That yuyv422 is not supported.
[11:01] <blippyp_> you mean -pix_fmts?
[11:01] <blippyp_> with an s
[11:02] <jonascj> blippyp_: but I am confused as to whether it should be an ffmpeg or ffserver setting. The manual kind of suggest that the settings of the ffserver is "pushed" to the ffmpeg when ffmpeg connects to ffserver.
[11:03] <jonascj> https://ffmpeg.org/ffmpeg.html this say thta -pix_fmts is to list available pixel formats and that -pix_fmt is to specify pixel format...
[11:03] <blippyp_> good enough
[11:03] <blippyp_> couldn't remember
[11:03] <jonascj> :)
[11:03] <blippyp_> did you change it to yuv420p?
[11:03] <blippyp_> it's complaining about yuv422?
[11:04] <blippyp_> if that's the case change it to the one it's complaing about instead - see what that does
[11:04] <jonascj> "ffmpeg -pix_fmt yuv420p -f video4linux2 -i /dev/video0 http://wuhtzu.dk:8090/webcam.ffm" this still says "[mjpeg @ 0x2c57260] Specified pixel format yuyv422 is invalid or not supported". so maybe I fail to specify it properly
[11:05] <blippyp_> use ffmpeg -pix_fmt yuyv422 -f .....
[11:06] <blippyp_> are you using windows/linux/osx?
[11:06] <jonascj> ffserver and ffmpeg on linux
[11:06] <blippyp_> duh - v4l2 - should have known
[11:07] <jonascj> :)
[11:07] <blippyp_> did that fix it?
[11:07] <jonascj> what bothers me is that "ffmpeg -pix_fmt yuv420p -f video4linux2 -i /dev/video0 /tmp/lol.mp4" works just fine (looks like crap, but I get some video recorded)
[11:08] <jonascj> nope, I cannot get it to reply anything else than "[mjpeg @ 0x2c57260] Specified pixel format yuyv422  is invalid or not supported"
[11:08] <blippyp_> run ffmpeg -pix_fmts|grep yuyv422
[11:08] <blippyp_> did it display?
[11:09] <blippyp_> should say IO... yuyv422      3       16
[11:09] <jonascj> yup, I get "IO... yuyv422                3            16"
[11:09] <jonascj> :P
[11:09] <blippyp_> hmmm
[11:09] <blippyp_> what is your pixelformat setting in the ffm file?
[11:10] <blippyp_> I never used the ffm files
[11:10] <blippyp_> so I'm searching in the dark with you on that issue
[11:10] <jonascj> blippyp_: http://pastebin.com/gyzWkNnL is my config. If I put "PixelFormat" into the stream seciton (where the manual says it should be) I get "incorrect keyword PixelFormat" from my ffserver
[11:10] <blippyp_> I looked up PixelFormat, it is a setting
[11:11] <blippyp_> you must be using it wrong - I haven't been able to find a good example of that yet....
[11:11] <jonascj> the <Feed> and <Stream> setting is just taken from the sample config file
[11:11] <jonascj> but yeah, maybe I should scrap my ffserver.conf file and start over following another example
[11:12] <jonascj> or not mixing the sample config file with suggestions from random guides
[11:12] <blippyp_> I think it has something to do with mjpeg
[11:12] <blippyp_> I've never worked with that format before
[11:12] <c_14> According to ffmpeg -h encoder=mjpeg: Supported pixel formats: yuvj420p yuvj422p yuvj444p
[11:12] <blippyp_> from your previous posts - I'd assume that it's using yuyv422, but clearly that isn't the case - not sure why it's mentioning that at all - unless I'm missing something
[11:13] <blippyp_> k - use one of those with your ffmpeg command instead
[11:13] <blippyp_> your'e not specifically altering the pixelformat in your ffm file, so it should stick with something standard
[11:14] <blippyp_> with only three options, it should be easy to determine which one it's defaulting to
[11:14] <jonascj> ffmpeg -pix_fmt yuvj420p -f video4linux2 -i /dev/video0 http://wuhtzu.dk:8090/webcam.ffm
[11:15] <jonascj> that gives the same error about yuyv442
[11:15] <jonascj> *yuyv422
[11:16] <blippyp_> maybe the issue with with v4l2
[11:16] <jonascj> but is it a setting missing from my ffserver.conf file then or is it on the ffmpeg side? ffmpeg says the input stream (from /dev/video0) is "Stream #0:0: Video: rawvideo (YUY2 / 0x32595559), yuyv422, 320x240,"
[11:16] <blippyp_> maybe it's converting it
[11:16] <c_14> What I'd also try is instead of using -pix_fmt as an input option, use it as an output option.
[11:16] <blippyp_> what happens if you remove the -pix_fmt option altogether from your ffmpeg command? same error?
[11:17] <jonascj> c_14: that is some basic stuff I do not know about. Does -pix_fmt mean different things depending on where you give the argument?
[11:17] <jonascj> I would have assumed there was an "-input_pix_fmt" and "-output_pix_fmt", but that of couse is not the case. So then I assumed that "-pix_fmt" always meant one thing (output for example)
[11:18] <blippyp_> I think he's saying to try this: ffmpeg -f v4l2 -i /dev/video- http://wh......... -pix_fmt yuyv422
[11:18] <jonascj> blippyp_: yeah, so the position (in the argument list) of arguments give them different meanings?
[11:18] <c_14> Yes.
[11:18] <blippyp_> yes - very much so with ffmpeg
[11:18] <jonascj> blippyp_: without pix_fmt altogether gives the same error
[11:19] <blippyp_> I think he might be right, I'm thinking it will work for you...
[11:20] <c_14> From what I can see from the ffmpeg output you posted recently, ffmpeg is detecting that your webcam uses yuyv422 and then uses that as an output pix_fmt, but mjpeg doesn't like yuyv422. So I'd try using -pix_fmt yujv422p as an output option.
[11:22] <blippyp_> yeah, if it doesn't work - do what c_14 just said... yujv422p should be compatible (I don't know where it's getting the yuyv422 - probably from v4l2, but I don't have a clue)
[11:22] <jonascj> "ffmpeg -f video4linux2 -i /dev/video0 http://wuhtzu.dk:8090/webcam.ffm -pix_fmt yuvj422p" still gives this "yuyv422 not supported" error.
[11:23] <jonascj> c_14: I think you are right. the ffmpeg output clealy states that the webcam input is yuyv422 and if nothing is done that it probably also the output format
[11:23] <c_14> Can you give us the output, maybe with -loglevel debug? I want to know why ffmpeg is choosing yuyv422 instead of what -pix_fmt is specifying.
[11:23] <blippyp_> yeah, I'm curious myself
[11:23] <blippyp_> glad you knew how to get that
[11:25] <jonascj> with debug level:http://pastebin.com/Q2R4QstR
[11:25] <blippyp_> I can see it in his original output
[11:25] <blippyp_> it is coming from v4l2 I think
[11:27] <jonascj> this worries me a bit: "Incompatible pixel format '(null)' for codec 'mjpeg', auto-selecting format '(null)'"
[11:28] <blippyp_> maybe try ffmpeg -f v4l2 -pix_fmt yuvj422p -i ......
[11:28] <jonascj> do you guys know why it works when I specify another output than my ffserver. E.g. if I just output to "file.mp4"?
[11:28] <jonascj> is that becuase the fileoutput is happy with whatever pixelformat ffmpeg outputs whereas mjpeg (on the ffserver) is not happy about it?
[11:29] <c_14> I'd think so. Have you tried writing to a local file forcing -c:v mjpeg -f mjpeg output ?
[11:29] <blippyp_> because the mp4 format doesn't have a problem with the yuv420p format
[11:29] <blippyp_> (I think)
[11:31] <jonascj> this works fine: "ffmpeg -loglevel debug -f v4l2 -pix_fmt yuvj422p -i /dev/video0 /tmp/lol.mjpg -c:v mjpeg -f mjpeg"
[11:31] <blippyp_> yeah - then converting the v4l2 feed is what needed to be done
[11:31] <blippyp_> v4l2 was screwing it all up for you
[11:32] <blippyp_> oh wait - you saved locally
[11:32] <jonascj> but that local command still had "-f v4l2" (an input option?)
[11:32] <blippyp_> now try the same command, but the way you were doing it before
[11:32] <blippyp_> yes, but by putting the pix_fmt option directly after the v4l2 format you were converting the pixel format for v4l2
[11:33] <jonascj> "ffmpeg -loglevel debug -f v4l2 -pix_fmt yuvj422p -i /dev/video0 http://wuhtzu.dk:8090/webcam.ffm -c:v mjpeg -f mjpeg" this still fails with "yuyv422 not supported"
[11:33] <jonascj> so maybe it is the ffserver after all.
[11:34] <blippyp_> hmmm
[11:34] <blippyp_> I think it is
[11:35] <blippyp_> you've tried converting the pixel format in every way that I can think of locally - it must be on the server side
[11:35] <jonascj> http://sirlagz.net/2013/01/07/how-to-stream-a-webcam-from-the-raspberry-pi-part-3/ what I'm trying to do seems to work out of the box for this guy
[11:36] <jonascj> without having the word "pixel", "format", "pix" or "fmt" in either ffmpeg command or ffserver config
[11:36] <jonascj> blippyp_: I'll try another ffserver. maybe try to install it locally and see if that helps
[11:37] <blippyp_> the last two commands you tried pretty much ensures that there's something wrong with your ffm file from what I can tell...
[11:37] <blippyp_> but like I said, I've never used them, so I can't really offer what's wrong with it specifically
[11:38] <jonascj> ARGH, it works on my local ffserver
[11:38] <jonascj> so maybe it is just the version of ffsserver on my remote machine
[11:38] <blippyp_> this may be a stupid question - but is it firewalled without the port open?
[11:39] <blippyp_> give me a second, I'm gonna try setting this up myself now (I'm getting as frustrated as you)  ;)
[11:40] <jonascj> blippyp_: It is iptable'd. I muts admit I haven't checked logs or iptables config because the ffserver (debug log output) says "New connection"
[11:41] <jonascj> blippyp_: so I assumed that the connection was successful since the ffserver log showed "new connection". The debug output from ffmpeg also showed "webcam.ffm downloaded successfully". So I do not think it is a firewall problem
[11:41] <blippyp_> I agree, that sounds like it's connecting
[11:41] <c_14> What version of ffserver do you have on the remote?
[11:43] <jonascj> "FFserver version SVN-r0.5.10-4:0.5.10-1" is what ffmpeg says when I give it no arguments. It was just what came with "apt-get install ffmpeg" on the remote ubuntu 12.04 machine
[11:43] <Mavrik> wow.
[11:44] <Mavrik> which dusty corner of a museum did you get that from
[11:44] <c_14> You might want to download a newer version/compile from source&
[11:44] <blippyp_> yeah - I agree
[11:45] <jonascj> I will try that right away. Debian or Ubuntu also have this weird ffmpeg vs avconv thing going on
[11:46] <jonascj> Also, sadly, both firefox and chrome just try to download my mjpeg stream/image. Maybe I should be looking for another good way to embed it
[11:48] <blippyp_> jonascj: sorry, didn't notice the time - I gotta go hide easter-eggs for my daugher before she wakes up - I wish I could stick around more - hope you figure it out...
[11:49] <jonascj> blippyp_: I think it was the version of ffmpeg on the remote machine. I feel quite confident that updating it will resolve my issue (since I've got it working, apart from some browser issues, locally)
[11:49] <jonascj> Thank you for all your help!
[11:50] <c_14> np
[11:52] <jonascj> an .swf stream on my local machine confirmed that the principle setup is working
[11:52] <jonascj> I just need to update my remote machine and figure out what the most friendly stream format is (mjpeg, swf etc.)
[11:54] <jonascj> c_14: any recommendations there? I am looking to embed the streamoutput in something like a webpage (local system for monitoring some 3d printers).
[13:10] <blippyp_> jonascj: you still around?
[13:18] <c_14> He timed out at 12:12
[13:21] <blippyp_> c_14: yeah I noticed... should have been paying more attention... Just wanted to let him know it was working for me using mjpeg
[13:21] <blippyp_> but I have the latest version
[13:29] <makara> hi. Any idea how I can demux WMV on Linux?
[13:30] <blippyp_> makara: be more specific on what you mean?
[13:32] <makara> blippyp_, WMV seek is terrible, and the videos I. I want to convert to MKV without re-encoding
[13:32] <makara> the videos I have are mono
[13:32] <blippyp_> don't think you can do that
[13:32] <blippyp_> you can do it with mp4, but I don't think you can do that with wmv
[13:36] <makara> why not?
[13:36] <blippyp_> different codecs
[13:36] <blippyp_> I just tried it
[13:36] <blippyp_> it pulled the audio, but no video
[13:36] <blippyp_> hold on
[13:37] <blippyp_> I might be wrong
[13:37] <blippyp_> are you on linux?
[13:37] <blippyp_> do you have mediainfo
[13:38] <blippyp_> I just ran mediainfo on my wmv and it says it's in mpeg4 format, so that can be re-muxed with a bitstream
[13:38] <blippyp_> I'm testing it now
[13:39] <makara> linux yes
[13:39] <blippyp_> get mediainfo and run that on one of your wmv files and see what it says for the codec
[13:41] <blippyp_> no, I don't think you can, it doesn't seem to be working
[13:42] <blippyp_> even if I try going to mp4 it doesn't work - maybe I'm doing something wrong
[13:42] <makara> blippyp_, this works: avconv -i dom.wmv -acodec copy -vcodec copy dom.mkv
[13:42] <blippyp_> really?
[13:43] <blippyp_> that wasn't working for me...
[13:43] <makara> yeah, I'm surprised
[13:43] <blippyp_> good enough
[13:43] <blippyp_> glad it's working for you :)
[13:44] <makara> blippyp_, http://pastebin.com/PgGWWFUN
[13:44] <makara> the output of `avprobe dom.wmv`
[13:45] <blippyp_> maybe because you're using avcon?
[13:45] <makara> avconv version 0.8.10-6:0.8.10-0ubuntu0.13.10.1, Copyright (c) 2000-2013 the Libav developers
[13:45] <makara> and a fairly recent version
[13:45] <blippyp_> yeah I'm using the latest ffmpeg
[13:46] <makara> blippyp_, OS ?
[13:46] <blippyp_> people think they're alike, but they aren't (not saying that's the issue in this case though - and I've never used avcon)
[13:46] <blippyp_> arch
[13:46] <blippyp_> I pulled my ffmpeg from github
[13:46] <makara> well, doesn't get better than that
[13:47] <blippyp_> yeah it does...  :(
[13:47] <blippyp_> I'm trying to re-compile it with frei0r enabled, but haven't had any luck so far...  :(
[13:47] <blippyp_> not sure why
[13:48] <blippyp_> it's probably something obvious and I'm too stupid to figure it out...  ;)
[13:51] <makara> i swear by packet managers
[13:51] <blippyp_> well, that's what I'm using - the aur
[13:51] <makara> debian is the best thing since chocolate
[13:51] <blippyp_> but i never find an ffmpeg with frei0r enabled...
[13:52] <blippyp_> so I downloaded the source and compiled it all myself
[13:52] <blippyp_> didn't get any errors during the compiling, but running it gives me segment faults
[13:52] <blippyp_> I think I'm just having some weird conflic of some kind
[13:53] <blippyp_> This is my output when I run ffempg: http://pastebin.com/3nDCiq3k
[13:53] <blippyp_> My problem is where it says WARNING: library configuration mismatch...
[13:54] <blippyp_> Basically, I have conflicting libraries in my system or something - Just not sure how to resolve it
[13:55] <makara> blippyp_, why you on Arch?
[13:55] <blippyp_> because I like it?
[13:56] <blippyp_> everything is always up to date, my computers basically suck and can't be bothered with compiling everything myself
[13:56] <blippyp_> arch keeps everthing nice and new for me
[13:57] <blippyp_> this is the first and only time I've ever run into something that I couldn't get
[13:57] <blippyp_> I was always running into problems with other installations because nothing was updated enough
[13:57] <makara> oh
[13:57] <blippyp_> I think the problem with this instance though is that my system is TOO updated???
[13:58] <makara> that's why they call it `unstable`
[13:58] <blippyp_> not really sure, maybe I did something wrong - clearly I don't know...  :(
[13:58] <blippyp_> nah
[13:58] <blippyp_> it's not unstable
[13:58] <blippyp_> trust me - been using it for 4 years now
[13:58] <blippyp_> it never breaks
[13:58] <blippyp_> I just updated my system(s) for the first time in over a year - nothing wrong happened
[13:59] <blippyp_> the key to using arch is to check the archlinux.org site before updating - ALWAYS
[13:59] <blippyp_> if there are any known issues that can occur - they will be spelled out in black and white and how to fix them. Usually very easy, requiring a couple of steps. A monkey could do it
[14:00] <blippyp_> And it's rare to need to do this
[14:02] <makara> now I'm trying to turn this single channel into stereo without re-encoding
[14:02] <blippyp_> I doubt you'll get away with that... ;)
[14:02] <blippyp_> audio encodes fast though
[14:02] <makara> i tried with the switch "-ac 2" but it re-encoded with libvorbis
[14:02] <blippyp_> you got the video - that's easily the worst part done
[14:03] <makara> http://trac.ffmpeg.org/wiki/AudioChannelManipulation
[14:03] <makara> there's this line, but it's only for an audio file `ffmpeg -i input.mp3 -filter_complex "[0:a][0:a]amerge[aud]" -map "[aud]" output.m4a`
[14:03] <makara> using the amerge filter
[14:04] <blippyp_> if you have to use a filter, I'm guessing it would insist on re-encoding it
[14:08] <blippyp_> gotta go makaa - my daughter will be up soon for easter and I need to take a shower (need to clean up for pictures) - she's only two, so it's kind of a big deal for her today...  ;)
[14:08] <blippyp_> good luck - but I'm guessing you'll need to re-encode the audio...
[14:12] <makara> blippyp_, cheers b
[14:12] <makara> happy easter
[14:50] <xreal> Why can't I set tracknames seperatly for video and audio with ffmpeg? I tried anything :(
[15:04] <makara> any way to create joint stereo aac? I'm converting from mono
[15:04] <Mavrik> what you're asking makes no sense :)
[15:04] <Mavrik> there's no joint stereo AAC
[15:06] <makara> oh ok
[15:07] <makara> Mavrik, its just that my converted video files are twice the size
[15:07] <makara> when I convert audio to 64k the sound is bad
[15:07] <Mavrik> well
[15:07] <makara> so I do aac 128k
[15:07] <Mavrik> are you setting quality properly :)
[15:07] <Mavrik> also, quality depends on which AAC encoder you're using
[15:07] <Mavrik> HE-AACv2 gives usually better results at 64k
[15:08] <makara> avconv -i dom.wmv -c:a aac -strict experimental -b:a 128k -vcodec copy dom.mkv
[15:09] <makara> Mavrik, i would have to compile avconv to get HE-AACv2
[15:09] <Mavrik> well
[15:09] <Mavrik> avconv isn't ffmpeg.
[15:09] <Mavrik> so *shrug*
[15:12] Action: xreal goes crazy about metadata :(
[15:13] <JEEB> makara, the binary distributable encoders can't do any sort of HE-AAC (IIRC), so you'd have to compile either libav or ffmpeg yourself with fraunhofer's fdk-aac yourself, yes
[15:14] <xreal> Is there a good tutorial to convert DVD streams (with permission) to XviD using ffmpeg? I haven't done it for 6 years and used AutoGK for that before :D
[15:15] <makara> JEEB, should I uninstall the debian version first?
[15:15] <JEEB> makara, not necessary, as long as you have your own binary in front of the installed packaged one in PATH, you should be fine
[15:15] <xreal> This doesn't work: "ffmpeg -i INPUT -metadata:s:a:1 title="test" OUTPUT"
[15:42] <xreal> Anyone with an idea, why this doesn't work: "ffmpeg -i INPUT -metadata:s:a:1 title="test" OUTPUT"
[15:44] <makara> JEEB, I cloned libav, configured it with `./configure --enable-libfdk_aac --enable-nonfree --enable-gpl`, make and make install
[15:45] <makara> ah, its working
[15:46] <makara> that wasn't that hard
[15:47] <JEEB> -profile:a <the profile's name> should be the way to set the profile wanted, although I think fdk-aac by default sets some kind of HE profile in case of low enough bit rate
[15:47] <JEEB> also, #libav for libav, #ffmpeg is ffmpeg's channel :) Some people here are rather touchy about the subject (I personally help wherever my knowledge can be of help).
[15:53] <xreal> JEEB: But there's not #avconv :)
[15:54] <JEEB> the channels are for the projects, not the apps :)
[15:59] <makara> JEEB, i'm following http://trac.ffmpeg.org/wiki/AACEncodingGuide
[16:00] <JEEB> yes, that generally matches
[16:00] <makara> they suggest a bitrate switch as well as / as part of the profile switch
[16:00] <JEEB> some encoders auto-switch depending on the bit rate given
[16:00] <JEEB> but you can also set a profile manually
[16:01] <makara> aac_he works, but I get an error with aac_he_v2
[16:01] <JEEB> a "profile not found" kind of thing, or something else?
[16:01] <xreal> Anyone with an idea, why this doesn't work: "ffmpeg -i INPUT -metadata:s:a:1 title="test" OUTPUT"
[16:02] <makara> oh, i see v2 doesn't handle mono
[16:04] <makara> xreal, what about it doesn't work?
[16:07] <xreal> makara: It doesn't name give name to audio/video track.
[16:07] <xreal> I tried -metadata:s:a:1 | -metadata:s:a:0 | -metadata:s:v:1 |-metadata:s:v:0
[16:07] <xreal> makara: I need mp4box to fix it.
[16:14] <makara> xreal, try s:a.1
[16:16] <xreal> dot? nice, 1 sec
[16:18] <xreal> makara: Nope, doesn't work. Player still only gives the handler_name "SoundHandler".
[16:18] <makara> xreal, then I think there's something wrong with your player
[16:18] <makara> both avprobe and vlc see the track name
[16:19] <xreal> makara: which avprobe settings do you use?
[16:19] <makara> avprobe name-of-file
[16:20] <xreal> I wonder, why it works with MP4Box. Need to compare the MP4s.
[16:23] <xreal> makara: latest avprobe with "name-of-file" doesn't even return the handler. Let me post it.
[16:25] <xreal> makara: http://pastie.org/9095452
[16:25] <xreal> better to read: http://pastie.org/pastes/9095452/text
[16:40] <xreal> Ah, I think this is the problem: I'm using it with -c:v copy -c:a copy. Perhaps ffmpeg/avconv changes the metainfo to the source?!
[17:02] <xreal> seems to be a bug
[17:19] <xreal> I've used a debugger. ffmpeg *always* writes SoundHandler... you can't overwrite this. it's hardcoded!
[18:22] <xreal> when using FFMPEG to encode XVID, is XVID lib really used or is it just a fourcc stored ?
[18:22] <sacarasc> Depends on which codec you use.
[18:22] <sacarasc> libxvid is xvid.
[18:23] <sacarasc> Or was it xvidcore?
[18:23] <sacarasc> There is an actual one, though.
[18:24] <xreal> sacarasc: oh, don't know. "-c:v mpeg4 -vtag xvid" :)
[18:24] <sacarasc> That is just setting the fourcc.
[18:25] <sacarasc> The -vtag option is what does that.
[18:25] <xreal> Uh, that's the example in ffmpeg.org's wiki to do Xvids :D
[18:25] <xreal> sacarasc: Could you give me a hint, how to use the codec?
[18:25] <sacarasc> XviD is just a MPEG4 ASP encoder.
[18:25] <xreal> sacarasc: Ah, here: c:v libxvid
[18:26] <xreal> sacarasc: I know, they are compatible. But doesn't XviD has some tweakings from the standard?
[18:28] <xreal> my god, libxvid seems to be single core :D
[18:28] <JEEB> welcome to early 2000s :P
[18:28] <JEEB> and no, it doesn't have "tweakings from the standard"
[18:29] <xreal> JEEB: why does it exist then?
[18:29] <JEEB> anyways, I'm surprised you even chose to encode with xvid
[18:29] <xreal> JEEB: old DVD player
[18:29] <JEEB> xreal, because it was a fork of divx that was open source for a while
[18:29] <JEEB> and it was the only mpeg-4 part 2 encoder for a while
[18:29] <xreal> JEEB: I know, but it's like MP3: many encoders with different quality
[18:29] <JEEB> they're generally on a similar'ish base
[18:30] <JEEB> at least the lavc and xvid
[18:30] <JEEB> it's just that xvid is regarded as simpler to use
[18:32] <xreal> xvid has been updated some days ago to 1.3.3 ah multi-core has been added in 1.3.1
[20:24] <kittonian> hi all. i'm needing to convert a bunch of avi files to m4v and was wondering if there was any way to speed things up. i'm only getting about 30-40 fps because it's doing a full a/v re-encode for each file (taking forever). I tried just changing the container but of course that didn't work because the avi audio is mp3.
[20:25] <kittonian> i'm using -c:v libx264 -preset slow -crf 20 -c:a libvo_aacenc -b:a 128k
[20:33] <c_14> You could try copying the video instead of reencoding it.
[20:33] <c_14> That would be your main bottleneck.
[20:43] <kittonian> cool. i'll give it a shot
[20:44] <xreal> I really can't understand, why I can't set audio/video stream title when doing stream copy.
[20:48] <kittonian> can't copy the video stream. i get the pts has no value error and the video is all jumpy
[20:49] <kittonian> the only way it comes out perfect is with the command i'm already using. guess i'll just have to wait for the encode to happen in realtime.
[20:49] <kittonian> thank anyway
[20:49] <kittonian> *thanks
[21:07] <xreal> Uh, what's that?  Stream #0:3(und): Data: none (rtp  / 0x20707472), 11 kb/s (default)
[21:21] <kittonian> someone around that can give me a hand writing a batch processing script for all of these conversions? sitting and waiting for each one to be done at this pace is taking forever
[21:21] <kittonian> i've looked at a bunch of examples but haven't found one that will work for this situation
[21:22] <kittonian> on mac os x btw
[21:23] <c_14> for i in *.avi; do ffmpeg input_options -i "$i" output_options "${i%avi}avi"; done
[21:23] <c_14> Should work, but no guarantees.
[21:23] <c_14> That second avi should be an m4v
[21:23] <xreal> Anyone with an idea, how to change metadata for video & audio streams which using "copy stream" ?
[21:24] <kittonian> c_14: ha. that's the example i found
[21:24] <kittonian> i need to be able to specify an input and output directory and then have it do one conversion at a time until the entire directory has been converted
[21:25] <kittonian> the same filenames can be used for both the input and output files. just the extension change from avi to m4v
[21:25] <c_14> for i in /path/to/input/dir/*.avi; do ffmpeg input_options -i "$i" output_options "/path/to/output/dir/${i%avi}m4v"; done
[21:27] <kittonian> does this look right?
[21:27] <kittonian> http://pastebin.com/vg8xSbUu
[21:28] <c_14> $OUTDIR has to be ${OUTDIR}
[21:28] <c_14> Other than that, it should be fine.
[21:29] <kittonian> not the same for INDIR?
[21:29] <c_14> You might want to get rid of the escapes in the pathnames though and just quote the variable declaration.
[21:29] <c_14> You only need it for the output because you're appending a string after it.
[21:29] <c_14> You might need it for INDIR, it wouldn't hurt though.
[21:29] <kittonian> you lost me on the variable declaration
[21:30] <c_14> Just make it ${INDIR} as well, it shouldn't hurt and may prevent errors.
[21:30] <kittonian> and what about a . before m4v?
[21:30] <c_14> Don't need it because you aren't deleting the . before the avi that you're deleting.
[21:30] <kittonian> ahh
[21:31] <kittonian> and this will do one conversion at a time, not try to do all of them at once right?
[21:31] <c_14> yep
[21:31] <kittonian> cool, let me give it a shot
[21:34] <kittonian> got a bunch of "no such file or directory" errors due to the long path names in INDIR and OUTDIR
[21:36] <c_14> Could you replace the do line with do echo "$i" "${OUTDIR}/${i%avi}m4v" and see if the output it gives you is the actual location of the files?
[21:38] <kittonian> just tried that. it's not seeing it all as a single path, it's seeing it as a bunch of different paths
[21:42] <c_14> for i in ${INDIR}/*.avi; do echo "$i" "${OUTDIR}/${i%avi}m4v"; done
[21:42] <c_14> That works for me.
[21:45] <kittonian> do you have " around the path variables?
[21:46] <kittonian> and are you still escaping all the spaces?
[21:46] <c_14> Yes.
[21:46] <c_14> No.
[21:46] <c_14> INDIR="/media/path/places"
[21:46] <c_14> OUTDIR="/media/otherpath/out"
[21:46] <kittonian> INDIR="/something's wrong/with/the/path"
[21:46] <kittonian> that's what i have (there are special characters in some of the folder names)
[21:47] <kittonian> every space and special character is being treated as a separate path
[21:48] <clever> for i in "${INDIR}/*.avi";
[21:49] <clever> i think this will solve it
[21:49] <c_14> That won't glob though.
[21:50] <clever> hmmm, yeah, it treats it as a single argument
[21:50] <c_14> Put the quotes only around indir like so: "${INDIR}"/*.avi
[21:50] <c_14> That works.
[21:50] <clever> yep
[21:50] <clever> c2d ~ # for x in "/media/videos/4tb/dcc/"*;do echo $x;done
[21:50] <clever> lists every file&dir in there
[21:51] <kittonian> hmm, closer
[21:51] <kittonian> it's trying to do all the files at one time
[21:51] <kittonian> and it's still not finding the correct output file to use
[21:51] <kittonian> should the quotes on the OUTDIR be different as well?
[21:52] <c_14> "${OUTDIR}"/"${i%avi}m4v"
[21:52] <clever> i see what your trying to do, let me try applying it to my video heap
[21:52] <c_14> I dislike escaping things. :(
[21:53] <clever> c2d ~ # for x in "/media/videos/4tb/dcc/"*mkv;do echo "$x" ${x%mkv}avi;done
[21:53] <clever> prints out every mkv file, and its avi pair
[21:53] <clever> one pair per line
[21:53] <clever> /media/videos/4tb/dcc/Rise.of.the.Continents.S01E04.Australia.720p.HDTV.x264-DHD.mkv /media/videos/4tb/dcc/Rise.of.the.Continents.S01E04.Australia.720p.HDTV.x264-DHD.avi
[21:54] <c_14> You should probably quote the ${x%mkv} part in case your filenames have spaces.
[21:54] <clever> yeah, if i toss it at ls, all hell break loose
[21:54] <clever> c2d ~ # for x in "/media/videos/4tb/dcc/"*mkv;do ls -lh "$x" "${x%mkv}avi";done
[21:55] <clever> now its only one error per pair, since the avi versions dont exist
[22:13] <kittonian> sorry about that. didn't mean to disappear. had to show the house we're selling :)
[22:21] <kittonian> you guys still with me?
[22:21] <c_14> ye, have you tried it with the new quoting yet?
[22:23] <kittonian> i have not. which quoting would you like me to try?
[22:23] <c_14> Put the quotes only around indir like so: "${INDIR}"/*.avi
[22:23] <c_14> "${OUTDIR}"/"${i%avi}m4v"
[22:23] <c_14> And outdir like so^
[22:23] <kittonian> ok, one sec
[22:25] <kittonian> nope
[22:25] <kittonian> it's treating both INDIR and OUTDIR as one long path
[22:26] <kittonian> and still trying to do all files at once
[22:27] <kittonian> http://pastebin.com/P7udTFbg
[22:34] <c_14> http://sprunge.us/FgXO
[22:34] <c_14> That works for me.
[22:38] <kittonian> so far so good. it's converting the first file. this will take a little bit until we can see if it moves onto the next, but awesome thus far!
[22:39] <kittonian> thank you
[22:39] <c_14> np
[22:39] <kittonian> it'll be about 30 minutes or so before we can see if all is well. i'll post back in a bit
[22:39] <c_14> kk
[22:42] <xreal> Anyone with an idea, how to change metadata for video & audio streams which using "copy stream" ? Neither -metadata:s:a:1 title="test" nor -metadata:s:a.1 title="test" works :/
[22:44] <c_14> Have you tried just -metadata title="test" ?
[22:45] <xreal> c_14: I don't want it for the file, I want to name the streams. Like "Camera 1" and "Audio Cam 1" etc.
[22:45] <xreal> brb 5 minutes (ofen in kitchen)
[22:57] <xreal> re
[22:57] <xreal> c_14: mp4box can do it, but it creates crazy MP4s sometimes.
[22:58] <c_14> Have you tried it without the trailing ":1" ? I'd like to know if it's failing completely or just failing on that stream specifically.
[22:58] <xreal> c_14: 1 sec
[23:00] <xreal> c_14: Nope. Doesn't work.
[23:00] <xreal> c_14: check the output of probe http://pastie.org/pastes/9095452/text
[23:05] <c_14> Try it with a :0 instead of a :1
[23:06] <c_14> Hmm, weird.
[23:06] <c_14> For me it works with mkv, but not with mp4.
[23:08] <blippyp_> not sure where I read this: but ffmpeg apparently is broken for metadata - it also works differently depending on the container
[23:08] <xreal> blippyp_: oh damn
[23:09] <blippyp_> what container are you using xreal? it worked for mkv's for c_14 - try that one
[23:09] <xreal> blippyp_: I'm using mp4
[23:09] <blippyp_> try mkv
[23:09] <xreal> blippyp_: but I need mp4 :)
[23:09] <xreal> but let me try
[23:09] <blippyp_> just try it
[23:10] <blippyp_> if it works then you know that's probably the case (if you believe me...)  ;)
[23:10] <xreal> yep. it works :(
[23:10] <blippyp_> sorry dude
[23:10] <blippyp_> that's probably your problem...  :(
[23:11] <blippyp_> bu I could be wrong - I think it happened ONCE before...  ;)
[23:11] <xreal> Is mp4 such outdated that nobody cates about it?
[23:11] <xreal> cares*
[23:11] <blippyp_> no - I think the metadata stuff isn't 'standardized' - google around - you'll get more reliable information about it than I could give ya
[23:12] <xreal> blippyp_: with mp4box it works as expected, but it sometimes creates crazy files with multiple audio tracks
[23:13] <xreal> blippyp_: But I understand what you mean :D
[23:13] <blippyp_> like I said - it's not standardized - and when I read about it people were complaining about ffmpeg being broken for metadata - I'm guessing it's a shot in the dark - an 'unreliable' issue....
[23:14] <blippyp_> for lack of better words - I'm going off of hazy memories of an article I read once - so like I said you should google around, you'll get better and much informative information about it...
[23:14] <xreal> blippyp_: wikipedia says: "MP4 files can contain metadata as defined by the format standard, and in addition, can contain Extensible Metadata Platform (XMP) metadata"
[23:15] <xreal> so it can contain metadata, but it's not standardized?
[23:15] <blippyp_> you forget that I stated that people were complaining about ffmpeg being 'broken' about the metadata....
[23:15] <blippyp_> just because mp4's are suppose to have the ability for that metadata doesn't mean that ffmpeg has been designed for it yet
[23:16] <blippyp_> I can't prove any of this - but you just saw it with your own eyes... you be the judge
[23:18] <xreal> blippyp_: I think, most of the guys want details, like "episode" etc. My needs are too special :(
[23:18] <xreal> Nobody cares about the video stream's name :)
[23:18] <blippyp_> ffmpeg might not be what you want then...
[23:19] <xreal> blippyp_: <ducks himself> what's the alternative?
[23:19] <c_14> It's open source, just patch it in ;)
[23:19] <blippyp_> you can probably do the encoding and stuff - 'the hard part' with ffpeg and then use a different program to attach the metadata you want afterwards though
[23:19] <blippyp_> there's always that too...  ;)
[23:19] <xreal> blippyp_: that's what I am doing right now
[23:19] <blippyp_> have fun with that btw... haha
[23:19] <xreal> ffmpeg: I am encoding the files, splitting them
[23:19] <xreal> then I push them in mp4box
[23:20] <xreal> But MP4box adds unknown streams sometimes: Stream #0:3(und): Data: none (rtp  / 0x20707472), 11 kb/s (default)
[23:20] <blippyp_> see if ffmpeg will rip them out
[23:20] <xreal> What's in the data stream at 11 kb/s ?
[23:20] <xreal> blippyp_: using raw ?
[23:21] <blippyp_> ffmpeg is suppose to 'copy' the metadata from the source - maybe it will keep the changes you made
[23:21] <blippyp_> round and round you go... kinda a shitty situation
[23:21] <xreal> blippyp_: Is there also a way to remove the metadata from the source?
[23:21] <blippyp_> not sure
[23:22] <blippyp_> when you copy the video - it apparently takes the metadata with it - but to extract just the metadata I don't know
[23:22] <xreal> What I don't like about mp4box: it adds dates.
[23:22] <xreal> Since I'm on Windows, I can't recompile modded sources that easy as on Linux.
[23:22] <blippyp_> maybe that's part of the metadata 'standard' for mp4?
[23:23] <xreal> blippyp_: but 11 kb/s is pretty much.
[23:24] <blippyp_> sorry xreal - I gotta go - only came downstairs for a smoke - got a easter party to go to now with my daughter - good luck
[23:24] <xreal> ok thanks. happy eastern
[23:24] <blippyp_> no problem and happy easter to you guys too
[23:30] <kittonian> c_14: it finished the first file and has successfully moved on to the next one. this is great. thanks again for all your efforts.
[23:30] <c_14> np
[23:41] <xreal> damn, libmp3lame doesn't write MP3 tag...
[00:00] --- Mon Apr 21 2014

More information about the Ffmpeg-devel-irc mailing list