[Ffmpeg-devel-irc] ffmpeg.log.20140424

burek burek021 at gmail.com
Fri Apr 25 02:05:01 CEST 2014

[00:00] <sacarasc> Bray90820: -ss 2 as either an input or output option (forget which does the accurate seeking) should do it.
[00:00] <blippyp> yes, but it should still be keeping the right aspect no?
[00:00] <xreal> blippyp: no, it *has* to be distorted.
[00:00] <Bray90820> blippyp: what do you mean
[00:00] <blippyp> it's not the same as resizing the video to 16:9
[00:00] <blippyp> yes - distorted, but not stretched
[00:00] <xreal> blippyp: but that's what they did, I think.
[00:01] <blippyp> the concept works better if you had a device like my camera you might understand what I mean more
[00:01] <xreal> blippyp: they just have put the 16:9 signal on a 4:3 DVD.
[00:01] <blippyp> probably because you already degraded it I guess
[00:01] <blippyp> I figured it had an algorithm to help resize without destroying the image
[00:01] <xreal> blippyp: it's not my fault :)
[00:02] <Bray90820> sacarasc: i don't really know what you mean by that
[00:02] <blippyp> no - maybe you need to switch your setsar and setdar - did you try that - I'd give it a go just to make sure
[00:02] <blippyp> it's a confusing concept
[00:02] <c_14> Bray90820: https://trac.ffmpeg.org/wiki/Seeking%20with%20FFmpeg
[00:02] <c_14> Read, learn, profit.
[00:03] <xreal> Nice... handbreak doesn't support distortion/stretching. So I *need* to use ffmpeg anyway :)
[00:04] <blippyp> Bray90820: keep in mind though with that link c_14 gave you - as soon as you implement accurate seeking - you will not simply splice the video - it will need to re-encode it
[00:07] <Bray90820> blippyp: could I just put it in a different container
[00:07] <blippyp> the container doesn't matter - as soon as you implement accurate seeking it will re-encode the entire video your making
[00:08] <blippyp> some codecs might not even allow for quick splicing regardless
[00:09] <blippyp> geez guys - went through the trouble to make a video of my cartoon example and not a single comment??? I promise - I take constructive criticism well....
[00:10] <Bray90820> Nevermind i found a different way to do it
[00:10] <blippyp> Bray90820: how's that?
[00:10] <Bray90820> When I import it i can choose custom start and ending times
[00:11] <blippyp> import it into what? what software are you using?
[00:11] <Bray90820> I am actually using dvd shrink on windows
[00:11] <c_14> blippyp: the degradation makes the snow in the bottom vid turn into cobwebs
[00:12] <blippyp> oh - so you were going to re-encode it anyways then...
[00:12] <Bray90820> Well no dvd shrink was going to copy it over with no compression
[00:12] <Bray90820> as a vob
[00:14] <blippyp> c_14: not sure I'm understanding what you mean?
[00:14] <Bray90820> Basically dvd shrink is just removing the encryption then copying the files over
[00:15] <blippyp> like it just looks like cobwebs instead of snow?
[00:15] <Bray90820> Basically dvd shrink is just going to remove the encryption then copy the files over
[00:16] <c_14> Due to the distortion, the snow takes on the appearance of cobwebs. L
[00:17] <c_14> With the way it's spread out and the holes.
[00:17] <sacarasc> I don't l;ike DVD shrink. I use a combination of RipIt4Me and DVD Decrypter.
[00:17] <blippyp> yeah, there isn't much I can do about that... with a filter like this you kind of need to 'tweak' it as you use it - basically use different settings for each scene.
[00:18] <Bray90820> sacarasc: dvd shrink seems to be the best i can find
[00:18] <blippyp> I also seriously decreased the video size to save on time - If I apply the filter to a higher resolution, it generally turns out much better - then I take that higher resoultion image and resize it down - I haven't tested it yet, but I'm sure that resizing the cartoon down ends up in a much better video...  The more quality you use to begin with makes a much better drawing
[00:19] <sacarasc> Get RipIt4Me and DVD Decrypter set up and it's 1 button ripping.
[00:19] <Mista_D> can't see http traffic when using `-progress http://127.0.01/`  http://pastebin.ca/2701710
[00:19] <Bray90820> sacarasc: what format are the videos in
[00:19] <sacarasc> IFO and vobs.
[00:20] <Bray90820> Can it keep the man feature in one file or does it split it into 1GB files
[00:20] <sacarasc> It splits them, this is for archival, I guess.
[00:21] <sacarasc> I think you can make it merge them, though.
[00:22] <Bray90820> sacarasc: with dvd shrink i can keep them in one file and i need that because plex doesn't recognize Video_TS
[00:22] <sacarasc> You can rip it as an ISO if you want, with it, too.
[00:22] <blippyp> Mista_D: I've never used that - but I gotta ask the obvious - you must have something serving on port 80 ready to read that data?
[00:23] <Mista_D> blippyp: its just a listenning port, there's nginx. Listener is not setup yet, just want to see the format of the data.
[00:23] <Bray90820> sacarasc: Well i rip tv shows and it's much easier to select indevigual episodes when it's not one file and the metadata is pulled as well
[00:24] <blippyp> I can't find any documentation on that parameter except in the man page...
[00:24] <Mista_D> blippyp: same here...
[00:24] <blippyp> Well there would need to be a server ready to receive that data on port 80 to read it.... and then spit it back out onto the page....
[00:25] <blippyp> Unless it's suppose to serve itself? I know ffserver will do that...
[00:25] <Mista_D> blippyp: server it there, using NGINX. FFmpeg wont start unless it handshakes with HTTP server.
[00:25] <blippyp> so there is a 'connection' happening that you're aware of?
[00:29] <blippyp> like you're just feeding data to the sever, but the server has to have 'code' there ready to receive and spit that data back out.... something that obvioulsy can use sockets (like php)
[00:29] <blippyp> *obviously
[00:29] <Mista_D> blippyp: got it, had to use "-i any" in tcpdump, there's nothing setup on nginx but traffic was going to it...
[00:30] <blippyp> so you're seeing the progress information on now?
[00:30] <blippyp> that's weird? I don't get it
[00:31] <xreal> man, I just figured it out!
[00:31] <Mista_D> need to setup the web server to handle it now. But FFmpeg progress works.
[00:31] <xreal> avconv is completly behaving different than ffmpeg.
[00:31] <blippyp> oh I see
[00:31] <blippyp> where did you read about the 'any' option?
[00:31] <xreal> avconv: scale=iw*2:ih/2 => distortion as expected | ffmpeg: just scaling
[00:31] <Mista_D> blippyp: had too many interfaces on the box, was not monitoring the right interface...
[00:32] <blippyp> oh you're using avconv - I don't think ffmpeg has that - I don't see it in the man page anyways...
[00:32] <Mista_D> blippyp: `tcpdump -D`
[00:33] <xreal> blippyp: no, I am using ffmpeg. ffmpeg *had* it, there are many tutorials.
[00:33] <xreal> I think, they removed it after forking.
[00:33] <xreal> setdar/setsar doesn't work in avconv :)
[00:33] <xreal> but it works in ffmpeg
[00:33] <sor_> anyone no how to get fflpay to keep updatting source file (refreash)
[00:34] <blippyp> Mista_D: you're a networker?
[00:34] <blippyp> never used tcpdump before - neat
[00:34] <Mista_D> blippyp: not really. but it is a neat tool.
[00:35] <blippyp> well clearly you know a few things - do you sniff packets? and protocols on the network?
[00:35] <Bray90820> Would this work to convert the file to flac
[00:35] <Bray90820> ffmpeg -i '/home/aaron/Desktop/VIDEO_TS/file.VOB' -metadata TITLE=file file.flac
[00:36] <Mista_D> blippyp: sometimes use Wireshark, but its not FFmpeg related, usually live streaming troubleshooting.
[00:37] <blippyp> cool - I've use wireshark (I suck at it) but I've used it...
[00:39] <Bray90820> So would the script i sent work?
[00:41] <blippyp> not sure - try it - you might need to add -c:a flac before the final filename??? (not sure, never used it - but I'm looking at an example, and that's all they've done)
[00:42] <Bray90820> It keeps telling me ffmpeg not found but i correctly used the script a week ago
[00:42] <blippyp> well - it's not in your path now - you did something with it
[00:43] <blippyp> either find it and add it to your path or go to wherever it is and run your script there
[00:43] <Bray90820> Well pretty much the only thing i did was update ubuntu from 13.10 to 14,04
[00:43] <blippyp> oh, then it should be in your path I would think
[00:44] <Bray90820> Then i have no idea what's going on
[00:44] <blippyp> try this
[00:44] <blippyp> run sudo updatedb
[00:45] <blippyp> it will take a second if you have it installed
[00:46] <blippyp> it will either error or seem like nothing happened, just kind of paused
[00:47] <Bray90820> that seemed to not do much of anything
[00:47] <Bray90820> http://pastebin.com/raw.php?i=v1rP8eGV
[00:47] <blippyp> did it error though?
[00:47] <llogan> sor_: you've asked that at least 5 times. try the ffmpeg-user mailing list.
[00:47] <Bray90820> The link has the terminal output
[00:47] <blippyp> yup that's good
[00:48] <blippyp> you have it
[00:48] <blippyp> now run: locate ffmpeg
[00:49] <blippyp> locate ffmpeg|grep bin  - that might be better
[00:49] <blippyp> find it?
[00:50] <blippyp> it's probably in /usr/bin
[00:50] <blippyp> or at least should be
[00:51] <llogan> Bray90820: 14.04 does not supply ffmpeg or the "ffmpeg" counterfeit, AFAIK.
[00:52] <blippyp> so it didn't find it?
[00:52] <blippyp> oh
[00:52] <blippyp> that's right you're on ubuntu
[00:52] <blippyp> you want avconv I think
[00:52] <llogan> no
[00:53] <llogan> or http://trac.ffmpeg.org/wiki/UbuntuCompilationGuide
[00:53] <blippyp> haha
[00:53] <blippyp> the man has spoken
[00:53] <Bray90820> llogan: Even if the libav tools package?
[00:54] <llogan> if you want to use third part tools and forks you'll have to get help at their help resources
[00:54] <llogan> *third-party
[00:54] <Bray90820> Hum
[00:55] <Bray90820> then do you have another script that will convert to flac without loosing audio quality
[00:55] <llogan> the static build is easy. just download, extract, and run. in your script supply the full path to the new ffmpeg
[00:55] <llogan> why do you want flac?
[00:55] <llogan> (sorry, i didn't completely follow the discussion)
[00:55] <blippyp> it's all the 'rage' with these kids these days...  ;)
[00:56] <Bray90820> llogan: i am converting a dvd to a loseless audio file
[00:56] <llogan> "ffmpeg -i input output.flac" is the most basic command
[00:57] <Bray90820> llogan: ffmpeg isn't available in 14.04 as you mentioned
[00:57] <blippyp> so basically you had it right Bray - but you don't have ffmpeg, which is your problem
[00:58] <Bray90820> Well the libav tools package is installed
[00:58] <llogan> what's that have to do with ffmpeg?
[01:00] <blippyp> Bray did you download the static build he linked you to yet?
[01:00] <Bray90820> Doesn't the libav tools package include ffmpeg
[01:00] <Bray90820> blippyp: was just about to
[01:00] <llogan> not anymore. it used to provide a fake ffmpeg from a fork.
[01:01] <llogan> http://blog.pkh.me/p/13-the-ffmpeg-libav-situation.html
[01:01] <Bray90820> ok
[01:01] <Bray90820> How would i install teh static ffmpeg
[01:02] <llogan> you don't need to install it
[01:02] <llogan> just download, extract, and execute
[01:02] <Bray90820> Well then how would i put it in my path so the script will work
[01:03] <llogan> /full/path/to/ffmpeg -i input ... output
[01:03] <blippyp> just copy it to your /usr/bin folder
[01:03] <Bray90820> ok
[01:07] <Bray90820> Thanks
[01:07] <Bray90820> It works now
[01:28] <xreal> Does anyone know a demo DVD, which contains subtitles?
[15:13] <superc2_> hi. just trying to install a very basic avserver and followed the howtos... but I'm not able to see anything when opening a stream.
[15:13] <superc2_> how can I see whats going wrong or missing?
[15:15] <klaxa|work> already sounds like you are using avconv and not ffmpeg, in that case see #libav
[15:15] <superc2_> so avserver is running... and I used 'avconv -i file.mp4 http://...:8090/test1.ffm' to stream the file to avserver
[15:16] <klaxa|work> see #libav for avconv support
[15:16] <superc2_> ah, I was not sure there was a difference... I tried the same with ffserver first... but didn't work either
[15:17] <klaxa|work> unless you compiled it yourself, installed a different package actually packing ffmpeg or downloaded a static build, you are still using avconv
[15:34] <blippyp> klaxalwork: Good read - I had no idea they were such dicks, I've been aware of the confusion of the fork for a while - But I can't believe they still took the name Libav after all that - That's just mind-boggling....
[15:35] <superc2_> mh. actually I was just looking for a small streaming solution... avserver was installed with the debian package 'ffmpeg'... very confusing
[15:36] <blippyp> superc2_: it is confusing to those who aren't aware - it's understandable...
[16:56] <droetker> Hello. I am trying to download a ism/manifest. How do I download the second best quality and not the best. (qualitylevel index 1 instead of 0)
[16:57] <sacarasc> I may be missing something, but how is this related to ffmpeg?
[16:57] <droetker> i am trying to convert the ism manifest to mp4/mkv using mkv
[16:58] <droetker> using ffmpeg*
[16:58] <klaxa|work> looking at google it yields some silverlight results
[16:59] <droetker> yes, ism manifests are microsoft iis streams.
[16:59] <droetker> Playing in silverlight/moonlight.
[17:04] <klaxa|work> droetker: what have you been doing so far?
[17:13] <droetker> ffmpeg -i ismlink -vcodec copy -acodec copy output.mkv
[17:14] <droetker> ismdownloader downloads the file, but can only do so in the highest quality available.
[17:14] <klaxa|work> and that works for the highest quality?
[17:14] <droetker> Yes.
[17:14] <klaxa|work> is ismdownloader a different tool?
[17:14] <droetker> yes
[17:16] <klaxa|work> so ffmpeg generally supports the manfest files?
[17:19] <droetker> hm
[17:20] <droetker> the other file was ismv
[17:20] <droetker> this is .ism/manifest
[17:20] <droetker> MAybe ffmpeg just doesnt support manifests.
[17:25] <klaxa|work> ismv is with payload already, it contains an actual video stream
[17:25] <klaxa|work> at least it appears so
[17:25] <klaxa|work> yes pretty sure
[17:25] <klaxa|work> i downloaded some files from http://playready.directtaps.net/smoothstreaming/
[17:26] <klaxa|work> the .ismv files contain the videos, the Manifest most likely contains "links" to those .ismv files
[17:35] <klaxa|work> also, apparently ffmpeg cannot parse the manifest file (i would have been quite surprised if it could)
[17:35] <klaxa|work> >data/Manifest: Invalid data found when processing input
[18:26] <Voicu> hello, can someone explain how pts' and timebases work?
[18:27] <Voicu> if I set the timebase of a video stream to 1/30 (i.e. 30 fps) what do I need to set the pts values to ?
[18:27] <Voicu> is it microseconds or microseconds / 30 or what?
[18:39] <Jonas_> Does somebody know how I can speed my video?
[18:44] <c_14> Jonas_: https://trac.ffmpeg.org/wiki/How%20to%20speed%20up%20/%20slow%20down%20a%20video ?
[18:47] <Jonas_> I get the error: unrecognized option 'filter:v'
[18:58] <Brolan> I am trying to convert a '.AA' file into something useable. I have tried [-i book.aa book.mp3] but that has only done pic related: http://i.4cdn.org/adv/1398358300240.jpg
[18:59] <Brolan> something about unable to find codec parameters
[19:07] <c_14> Brolan: I'm pretty sure ffmpeg does not support the audible audio format.
[19:07] <c_14> Especially since it usually has DRM.
[19:08] <Brolan> ah. Thanks I'll figure it out elsewhere then. Thanks though!
[19:08] <c_14> And Jonas_ the pastebin was for you.
[19:08] <c_14> s/pastebin/pastebin request
[19:09] <Jonas_> heres my console output: http://pastie.org/9108687
[19:10] <c_14> You are using libav. libav support is in #libav
[19:10] <blippyp> Jonas_ use -vf instead
[19:11] <Jonas_> -vf instead of -filter:v ?
[19:11] <blippyp> yup
[19:12] <Jonas_> ok this works
[19:12] <Jonas_> thanks
[19:13] <blippyp> np
[19:26] <blippyp> c_14: just curious - but why would you send Jonas to #libav for a legitimate ffmpeg question? am I missing something?
[19:27] <c_14> His pastie lines 2-4
[19:28] <blippyp> ah - I get it - it's a falsie...  ;)
[19:29] <blippyp> should have have noticed the obiouvs deprecated notice - my bad
[19:30] <c_14> Nah, it's fine. I would have helped him, but -filter:v worked on my end.
[19:31] <blippyp> never used it that way - always -fv or -complex_filter (although there's a much shorter version for that one but I never remember it for some reason)
[19:31] <blippyp> is -filter:v simple or complex?
[19:56] <ross_> Hey everyone
[19:56] <ross_> I have a newbie question if anyone can help..im running ffmpeg on windows, I'm no sure how to add the current time to the output filename
[19:58] <Mavrik> you'll have to probabl use batch variable / script for that
[19:58] <Mavrik> something like http://stackoverflow.com/questions/1192476/windows-batch-script-format-date-and-time
[19:58] <ross_> didint ffmpeg had option like %t for time?
[19:59] <klaxa> -t
[19:59] <ross_> The problem is that I'm segmenting live stream into chunks of 1hr each, and I need the time for that
[19:59] <klaxa> oh dunno bout that
[20:00] <Mavrik> ross_, hmm
[20:01] <ross_> Mavrik, my other option is to loop and call ffmpeg everytime and set the time myself using batch, but I thought ffmpeg has something built in
[20:02] <ross_> plus it can result in data loss between transition which I dont wanna do
[20:02] <Mavrik> um
[20:02] <Mavrik> I don't really understand your issue
[20:02] <Mavrik> you want to change filename... without restarting ffmpeg_
[20:02] <Mavrik> ?
[20:03] <ross_> i'm using -f segment to save a livestream, i want to save it as play_2014_24_4_2_03_44.mpg insteaed of play_004.mpg
[20:03] <Mavrik> ah, ok
[20:03] <ross_> instead of counters, I want to use system time as filenames
[20:03] <Mavrik> I've never used HLS segmenter, so you'll have to wait for someone else :)
[20:04] <ross_> kk, thanks
[20:08] <Mavrik> looking at source it seems timestamp is only implemented in image output
[20:08] <Mavrik> but I haven't looked at HLS :-
[20:08] <Mavrik> /
[20:11] <ross_> ohh interesting
[20:12] <ross_> the segment doucmentation states that it uses the same output filename pattern as image2
[20:12] <ross_> do you know how I would set it in case of an image?
[20:12] <ross_> https://ffmpeg.org/ffmpeg-formats.html#segment_002c-stream_005fsegment_002c-ssegment
[20:42] <blippyp> ross: I think you want to do something like this? ffmpeg -i video.mp4 test/img%4d-${DATE=$(date +"%Y_%m_%d_%H_%M")}.png
[20:44] <blippyp> assuming you're in linux...
[20:48] <ross_> Hi blippyp
[20:48] <ross_> im on windows
[20:49] <blippyp> not sure if you can do it in windows - give ma second
[20:50] <blippyp> check this out: http://stackoverflow.com/questions/7727114/batch-command-date-and-time-in-file-name
[20:51] <blippyp> same idea
[20:56] <ross_> hmmm
[20:56] <ross_> thanks for helping out blippyp, but the problem is that i want to use this with -f segment
[20:57] <ross_> what I mean is, i want the segmented 1 hour long videos to have the corresponding time values
[20:58] <blippyp> then why did you post the date and not just the time? I don't get it?
[21:02] <klaxa> blippyp: the problem is different from what you think
[21:02] <klaxa> your command will change the name on shell level
[21:02] <klaxa> he needs to change the name according to the time/date on ffmpeg's output-file level
[21:03] <blippyp> doesn't the segmenter break apart the files in chunks - and he wants to name the files according to the time that segment ended I guess...???
[21:03] <blippyp> what would a date have anything to do with that?
[21:04] <klaxa> > i want to save it as play_2014_24_4_2_03_44.mpg insteaed of play_004.mpg
[21:07] <blippyp> I don't know - I'm confused - I gotta go though - good luck ross, sorry I couldn't help ya...
[21:07] <ross_> haha np thanks
[21:07] <ross_> i wanna do something like play_%H_%m_%s.mpg as output file
[21:07] <ross_> for a segmented output
[22:02] <xreal> "-vf scale=" always keeps ratio in ffmpeg... what's wrong here?
[22:07] <klaxa> nothing?
[22:13] <xreal> klaxa: it keeps ratio here... but it shouldn't.
[22:14] <klaxa> >The scale filter forces the output display aspect ratio to be the same of the input, by changing the output sample aspect ratio.
[22:14] <klaxa> http://ffmpeg.org/ffmpeg-filters.html#scale-1
[22:16] <xreal> force_original_aspect_ratio=disable :D
[22:53] <albator> why do i have segfault when i concat with files including a ' in the filename?
[22:54] <c_14> Are you escaping correctly?
[23:07] <haptiK> Hello. I'm sure this has been asked a million times, but after searching google for a few hours I'm drawing a blank: Unknown encoder 'libx264'. Could someone point me in the right direction? (centos6) thanks.
[23:10] <haptiK> I followed the following guide: https://trac.ffmpeg.org/wiki/CentosCompilationGuide
[23:11] <iive> haptiK: when you run ffmpeg configure, do you see libx264 as successfully detected ?
[23:12] <c_14> Or what does ffmpeg -encoders | grep libx264 give you?
[23:15] <haptiK> http://pastebin.com/K4EKQfTp
[23:15] <haptiK> i compiled with --enable-libx264
[23:15] <haptiK> and x264 is installed
[23:18] <c_14> ffmpeg isn't registering x264 as an encoder for whatever reason. Do you have configure output?
[23:18] <haptiK> yes one second
[23:29] <haptiK> http://paste.ubuntu.com/7325391/
[23:29] <haptiK> thats the output from the entire build script (sorry for delay, couldn't find a pastebin that would accept all that text)
[23:36] <c_14> Do you have the script (I think this is a script managing it) somewhere? Because if you can see at line 7117 Enabled encoders: it never lists libx264.
[23:37] <haptiK> you're asking for the script i threw together ?
[23:38] <c_14> Ye.
[23:38] <haptiK> its basically just all the commands throwin in from https://trac.ffmpeg.org/wiki/CentosCompilationGuide
[23:38] <haptiK> thrown in*
[23:38] <haptiK> one sec
[23:39] <haptiK> http://pastebin.com/G54H5KJ3
[23:40] <haptiK> i cut off some stuff from the header, assume $DIR means something
[23:40] <c_14> Add a \ after ./configure
[23:40] <c_14> Line 81
[23:41] <haptiK> oh ffs are you kidding me
[23:41] <haptiK> *facepalm*
[23:41] <blippyp> haha
[23:41] <c_14> And I'd get rid of the \ on line 98
[23:41] <blippyp> happens to the best of us...  ;)
[23:41] <c_14> 93
[23:41] <haptiK> okay rerunning the script
[00:00] --- Fri Apr 25 2014

More information about the Ffmpeg-devel-irc mailing list