[Ffmpeg-devel-irc] ffmpeg.log.20140425

burek burek021 at gmail.com
Sat Apr 26 02:05:01 CEST 2014

[00:02] <haptiK> okay so i actually moved all the configuration options on to one line
[00:02] <haptiK> and it's still not showing up in ffmpeg -encoders | grep libx264
[00:03] <haptiK> after running the complete build script again
[00:03] <haptiK> any idea what to try next?
[00:04] <haptiK> I've seen something about libavcodec-extra-53 in some forums, but that appears to be ubuntu related
[00:04] <haptiK> not to mention it looks like its for avconv not ffmpeg
[00:06] <c_14> Could you paste the last ~2000 lines of the script output/the part which starts with install prefix up until the Creating config.mak, config.h, and doc/config.texi... ?
[00:06] <c_14> Just so I can check the new configure output for ffmpeg
[00:07] <haptiK> okay, i'll rerun it again because I didn't save to an output file. oops.
[00:07] <haptiK> thanks for your time by the way
[00:08] <c_14> No problem, I hope I can help.
[00:45] <haptiK> c_14 what line am I looking for?
[00:46] <haptiK> i just psated the whole thing again
[00:46] <haptiK> im not entirely sure what you're looking for, i messaged you the link. i hope you don't mind.
[00:46] <c_14> It's fine, though you might want to post it here in case other people want to check as well.
[00:47] <c_14> Ok, according to the configure output libx264 has been compiled in and is also an encoder.
[00:48] <c_14> What exactly was the problem again/have you tried encoding using -c:v libx264 again?
[00:48] <haptiK> yes one second
[00:50] <haptiK> http://pastebin.com/29ibfaig
[00:51] <haptiK> that's basically what im dealing with (forgot the file extension in one of the commands)
[00:54] <c_14> Normally after "configuration:" there should be a list of the config options, in this case the important one being --enable-libx264. I don't see that in the output for this paste.
[00:55] <c_14> Does ffmpeg -version return anything for configuration: ?
[00:55] <haptiK> checking
[00:55] <haptiK> http://pastebin.com/WE2e09D0
[00:56] <haptiK> it doesn't appear to be there
[00:56] <haptiK> again
[01:00] <c_14> Is /root/bin in your $PATH ?
[01:00] <c_14> Maybe try starting ffmpeg directly as /root/bin/ffmpeg
[01:01] <c_14> (I'm just going to ignore the fact that you probably shouldn't be running ffmpeg as root here)
[01:01] <haptiK> http://pastebin.com/9wgV2VdT
[01:01] <c_14> /usr/local/bin is before /root/bin in the path.
[01:02] <c_14> And since the skript went haywire a while ago, you have the old ffmpeg binary in /usr/local/bin
[01:02] <c_14> So (I'm assuming) it's still executing that one.
[01:02] <haptiK> http://pastebin.com/r9Rx3mGY
[01:02] <haptiK> =D
[01:03] <c_14> That looks much better.
[01:03] <haptiK> \0/
[01:03] <haptiK> okay let me try to encode that
[01:03] <haptiK> how would you suggest i remove the old version
[01:03] <haptiK> so i don't have to specify the path
[01:04] <c_14> You can either remove them manually (fun). Or enter the ffmpeg source directory, run ./configure and then make uninstall
[01:05] <haptiK> okay thank you
[01:05] <haptiK> i may have more question if you don't mind but not now
[01:05] <haptiK> i need a break from this :)
[01:06] <c_14> If I'm around and I can help, I will.
[01:06] <jkli> hi all :)
[01:06] <haptiK> thank you so much for your help and your time. it's been a long time since i've used irc, and its really great to know quality help is still out there.
[01:06] <c_14> No problem.
[01:07] <jkli> I finally got nginx-rtmp working, but the first seconds from the mp4 files are often green screens, after a few seconds the image turns out fine and when i seek back to the beginning, it is also fine again
[01:07] <jkli> seeing that this channel has many video encoding pros, I was wondering what effect most likely causes those green screens in the initial loading
[01:08] <jkli> oh all vids are encoding using ffmpeg and x264 newest build
[01:08] <c_14> If I remember correctly, mp4 files have metadata spread throughout the file so the green screen could be due to the player not having enough metadata to play the file correctly yet, but I'm not entirely sure.
[01:09] <c_14> But you might want to wait until somebody comes along who knows more about that sort of thing than me.
[01:12] <jkli> well i encoded them with movflags faststart
[01:12] <jkli> to move the index to the beginning
[01:12] <jkli> shouldnt it move all metadata to the beginning as well?
[01:15] <c_14> Well, there goes my idea.
[01:18] <jkli> i read somewhere that greenscreens are caused by framedrops
[01:19] <c_14> They can be, but that wouldn't explain why you're only getting packet loss in the first few seconds.
[01:30] <haptiK> Does anyone know anything about GMP4 files?
[01:30] <haptiK> [avi @ 0x386bd00] Could not find codec parameters for stream 0 (Video: none (GMP4 / 0x34504D47), 320x240, 419 kb/s): unspecified pixel format
[01:37] <iive> haptiK: GeoVision Advance Mpeg4... you might have some luck if you find a way to force it as xvid
[01:40] <haptiK> yes they are files from geovision
[01:41] <haptiK> would you mind suggesting how to do what you describe?
[01:41] <haptiK> also there is POS metadata which overlays the video i'd like to be able to keep that as well
[02:04] <iive> sorry... maybe there is -fourcc option, i don't know.
[04:43] <DrewM> When encoding to VP8 the wiki says you should both use CRF and also tell it to target a bitrate. Why is that? Is it because there are no ways to make the encoder move quickly or slowly as in X264?
[07:31] <xecycle> Hi.  I have an ASS subtitle with fancy effects, but it renders very slow when played.  I tried burning it into video by ass filter, and it did work; but transcoding the original video is quite time consuming.  Is it practical in this case to render the subtitle into a picture-based format and use it without transcoding the original video?
[12:23] <termos> I created my own transcoder using libffmpeg, but when it's running it takes up 100% cpu on all cores. But the ffmpeg program only takes up about 40% on all cores. I haven't debugged that much yet but does anything come to mind to someone here?
[12:24] <termos> They are both running main profile and fast preset on x264 with fdk_aac audio.
[13:31] <superc2_> hi... still trying to get a very basic streaming server running... in the meanwhile removed avserver and downloaded the latest tarball of ffmpeg, compiled from sources
[13:32] <superc2_> however when I try to stream a file to ffserver I get 'segmentation fault'
[13:34] <klaxa> avserver is part of avconv, see #libav
[13:35] <superc2_> yes... thats why I said that I REMOVED avserver
[13:35] <klaxa> ah sorry
[13:35] <superc2_> so I'm trying my luck with ffmpeg now
[13:35] <klaxa> can you pastebin what you did?
[13:37] <superc2_> http://pastebin.com/Ys1kQ005
[13:37] <klaxa> oh? that is weird
[13:38] <klaxa> can you run that with valgrind?
[13:38] <superc2_> basically I just followed this short howto: http://www.alkannoide.com/2013/07/04/play-with-ffserver-a-quick-overview/
[13:38] <klaxa> just prepend valgrind to the command, if you don't already have valgrind, install it
[13:41] <superc2_> http://pastebin.com/UXZh9q6G
[13:42] <klaxa> >Address 0x10 is not stack'd, malloc'd or (recently) free'd
[13:43] <klaxa> this sure as hell doesn't look right
[13:43] <superc2_> so maybe I shoulr try another tarball?
[13:43] <klaxa> maybe compile from git source
[13:43] <klaxa> if it still happens, file a bugreport
[13:47] <superc2_> while I'm recompiling... actually is ffserver able to switch between multiple sources and generate new input sources (I think feeds) on the fly or by connecting to a mysql db?
[13:48] <klaxa> good question, i don't know
[13:48] <superc2_> so actually what I want to achieve is that there are multiple users sending a video stream to the server and then a software connects one of the feeds and switches it to an output stream
[13:48] <superc2_> or is there a better solution to achieve this?
[15:36] <artista_frustrad> I'm trying to convert a .VOB file to mp4 but the duration on the metadata is about 20 minutes short of the actual duration of the video. The converted video ends up being the size of the metadata duration. Is there a way to convert the video to the correct duration?
[15:39] <blippyp> paste your exact command to pastebin.com or similiar site then post the link
[15:40] <c_14> And all output
[17:32] <Daghdha> Hello, i have a gif with 38 frames. If i convert it to seperate frames using ffmpeg.exe -i aa.gif f%4d.png i end up with 216 frames. The gif however only has 37 frames. How can i have it output the exact number of frames. I have other gif images that do go correct. I have opened the gif in Photoshopped and confirmed it indeed only has 37 frames.
[17:33] <Daghdha> I am familiar with -r, but don't want to apply it to all gifs. I just want each frame stored in the gif once.
[17:35] <robin___> Hello everyone. I am having troube understanding why a PCM Wav file with a duration of exactly 17 seconds, when converted to m4a/aac get a duration of 17.05 seconds and a start time of 0.046440 seconds. any help appreciated
[17:40] <ubitux> Daghdha: -vsync vfr or something like that i suppose
[17:41] <Daghdha> It's all spanish to me ubitux, i will have a look in the manual and check vsync info. thanks
[17:41] <ubitux> juste add -vsync vfr to your cmd line
[17:42] <Daghdha> i did, seems folden. Thanks :)
[17:43] <Daghdha> ^golden
[18:03] <stolenhubcaps> Is it possible to use ffmpeg to get video from v4l2 then reencode it into several formats for streaming? (mjpeg over http, some kind of html5 friendly format), and perhaps a couple resolutions? Ideally it'd be possible to turn off unused encoders if theres no viewers/etc
[18:07] <randomguy123> yo, is there a way to stream theora/ogg from ffmpeg??
[18:10] <stolenhubcaps> ffmpeg seems to be like an octopus, it has lots of arms that can do cool stuff, but it seems to require some research to teach it to use those arms :(
[18:13] <randomguy123> i see from wiki that ffmpeg isn't on the list of theora/ogg capable streamers: http://en.wikipedia.org/wiki/Theora#Streaming
[18:14] <c_14> randomguy123: https://trac.ffmpeg.org/wiki/Streaming%20media%20with%20ffserver#StreamingTheoravideowithVorbisaudioinOggformat
[18:14] <randomguy123> i need to write some code to make it stream. On input I have either h264 or raw yuv. I have only like a day or two to do it. I'm more or less familiar with ffmpeg
[18:15] <randomguy123> (libavcodec/avformat), but if I need to use vlc I'd like to find out before I start messing with ffmpeg
[18:16] <stolenhubcaps> randomguy123: I'd check -codecs, i see  D.V.L. theora               Theora
[18:17] <c_14> stolenhubcaps: Everything up to streaming yes. Streaming should work, but it depends a lot on your setup.
[18:17] <randomguy123> what does D.V.L. mean?
[18:17] <c_14> Decode Video Lossy
[18:17] <randomguy123> decoder/video... ??
[18:17] <randomguy123> ah, ok
[18:18] <randomguy123> no, i know that ogg/theora are obviously supported. The question is about streaming
[18:18] <c_14> What do you mean with streaming, something like ffserver?
[18:18] <randomguy123> i'm not familiar with ogg, but I think it's well designed for streaming.
[18:19] <randomguy123> meaning like live tv stream, not simple playback of pre-recorded ogg file from disk over a network.
[18:21] <c_14> ffmpeg can take input from a live source, encode it and then stream the output somewhere, but it can only stream it to a server it cannot act as the server itself.
[18:21] <c_14> Do you have a streaming server (the thing the clients connect to) or do you need one?
[18:28] <stolenhubcaps> c_14: Pretty much i have some software that can either use the v4l2 device or an mjpeg 'stream'.  I need to be able to view the v4l2 video somehow and still feed that program. Never been able to get v4l2_loopback or such to work tho
[18:29] <stolenhubcaps> git clone git://git.savannah.gnu.org/grub.git
[18:34] <c_14> You can use ffmpeg to grab the v4l2 device, and then output it into a file or fifo so you can view the video while also outputting it to another output. Depending on how the program accepts input you should be able to get it to do what you want.
[18:34] <c_14> try looking at: https://trac.ffmpeg.org/wiki/How%20to%20capture%20a%20webcam%20input and  https://trac.ffmpeg.org/wiki/Creating%20multiple%20outputs
[18:41] <stolenhubcaps> thanks
[22:08] <haptiK> hello. i read that in order to force ffmpeg to pretend the file is different than what it really is i can use -vtab or -tab:v and then specify the format? I believe this forces a different "fourcc"? Is this correct? I've tried doing this, but without mucho success
[22:13] <llogan> haptiK: i think you mean -vtag
[22:15] <haptiK> okay let me look into that
[00:00] --- Sat Apr 26 2014

More information about the Ffmpeg-devel-irc mailing list