[Ffmpeg-devel-irc] ffmpeg.log.20140427

burek burek021 at gmail.com
Mon Apr 28 02:05:01 CEST 2014

[00:23] <ac_slater> hey guys. I'm just really digging into different encoders, etc. It seems MPEG2-TS is special thing. Does it make sense to wrap MJPEG into a MPEG2-TS container? I need MPEG2-TS for MISB metadata. Any help would be awesome. Thanks!
[02:39] <fyp> is this the help channel
[02:40] <fyp> I compile using this guide normally : https://trac.ffmpeg.org/wiki/UbuntuCompilationGuide
[02:40] <fyp> works perfectly until now, since I upgraded to mint 16
[02:40] <fyp> had no choice with the ssl stuff
[02:40] <fyp> can I paste the compilation error in pastebin?
[02:40] <fyp> have some of you guys tell me whats wrong
[02:40] <fyp> pl
[02:40] <fyp> pls
[02:41] <fyp> thing is, weirdly, it worked before, kinda, i couldn't make sudo make checkinstall, so ffmpeg works as commandline but isn't integrated to the packages
[02:42] <fyp> now it wont even compile right...uh
[02:43] <klaxa> yes pastebin your error and preferably your config.log
[02:44] <fyp> where would that config.log be
[02:44] <fyp> i use linux since 2 years, there's still things i'm not 100% un-noobed with
[02:44] <fyp> im wondering if i should just start over with the other packages to install and integrate in ffmpeg first
[02:45] <fyp> cos i could compile it
[02:45] <fyp> the real issue was not being able to make checkinstall it
[02:45] <fyp> so no .deb
[02:45] <fyp> no installation into the system
[02:45] <fyp> just a command line..
[02:45] <klaxa> the config.log will be in the same directory you ran ./configure in
[02:46] <fyp> let me reinstall all those things to compile ffmpeg with first klaxa, then i'll do this
[02:46] <klaxa> alright
[02:47] <fyp> shouldnt be long
[02:47] <fyp> only one takes a while but with make -j its a breeze
[03:08] <fyp> need to reboot, but i'll be back in 2 mins klaxa...the ffmpeg adjuncts are compiling
[03:43] <azk> Is there any way to have ffserver use the original file's size instead of specifying a fixed VideoSize?
[06:08] <fyp> ugh
[06:08] <fyp> the guy who was gonna help me is gone
[06:09] <fyp> i used this guide before in the past no problem
[06:09] <fyp> https://trac.ffmpeg.org/wiki/UbuntuCompilationGuide
[06:10] <fyp> to compile ffmpeg with a lot of useful options in
[06:10] <fyp> but this time, i can't get ffmpeg to install as a package, only can use it as a command line
[06:10] <fyp> because libvpx 1.3.0 won't install correctly
[06:10] <fyp> i'll put whats up on pastebin and waste
[06:10] <fyp> wait
[06:12] <fyp> http://pastebin.com/c20FHVdY
[06:12] <fyp> i used checkinstall like on most everything instead of make and make install and i actually got further
[06:12] <fyp> installation successfull...debian package installation failed
[06:13] <fyp> so i'm not sure if it's in the ffmpeg temp files
[06:13] <fyp> and also, i want to make a deb out of compiling ffmpeg like I used to
[06:13] <fyp> i have a custom made one for my computer but....i changed video card(s) then
[06:13] <fyp> went from a gt 230 geforce to 3 7850HD radeons in crossfire
[06:15] <fyp> gonna try the final ffmpeg step and see if anyone can help, would appreciate it
[06:24] <fyp> i actually donated to this project twice, so, yeah cant prove it, but all conceitedness aside, if this ffmpeg "successfully installs" meaning only a command line works and no deb package gets installed into the system im gonna fuckin go mad
[06:44] <fyp> yeah thats great, can't even pull man ffmpeg
[06:44] <fyp> tells me about the dummmy man 7 undocumented
[07:04] <The_Ball> I'm trying to find out if a security camera puts additional information (like motion detection triggers) in the transport stream. It's a RTSP transport which ffplay reports as containing two streams:     Stream #0:0, 28, 1/90000: Video: h264 (Baseline), yuv420p(tv), 2048x1536 [SAR 1:1 DAR 4:3], 1/180000, 15.17 tbr, 90k tbn, 180k tbc and Stream #0:1, 1, 1/90000: Data: none, 0/1. Is there a way I can dump anything that is being s
[07:04] <The_Ball> ent in the data stream?
[07:06] <The_Ball> Or could there be KLV fields hidden in the h264 stream perhaps. Would -loglevel debug show any embedded KLVs?
[09:32] <jonascj> So I am still playing around with live streaming a webcam for viewing in a web browser. The solution I like best so far is http://phoboslab.org/log/2013/09/html5-live-video-streaming-via-websockets but it I cannot get it to work with low framerates due to some mpeg1/2 or codec limitation.
[09:33] <jonascj> It is an javascript mpeg1/2 decoder which receives the stream from ffmpeg via http, extracts the frames and insert them into an html5 canvas element.
[09:36] <jonascj> My question is could this be done without a conventional video stream (mpeg for example)? Could I just setup ffmpeg to capture single jpeg images and deliver them to a server application which will then process them? 1-10 FPS sounds like something which could be done with such a solution
[10:09] <SpecialEd> Hey guys, recently on ffmpeg I've been getting a lot of "AVC: nal size #######" and "missing picture in access unit with size 42" errors echo'd to my Ubuntu terminal shell when transcoding flash video to x264 mp4.
[10:09] <SpecialEd> The videos still play fine, but its kinda annoying how its basically spamming my terminal session, anyone else encounter this and/or know how I could quiet this down?
[11:35] <stylus_Jack> Hi, how can I get identical or near-identical results for conversions of the same file with the same output settings across different versions/builds of ffmpeg?
[11:44] <stylus_Jack> Output summary: http://pastebin.com/raw.php?i=64xyHB2g
[13:44] <kcynice> hello all, is there a offline api document for downloading?
[13:46] <klaxa> you can build it from the source-tree
[13:47] <kcynice> how to do that?
[13:48] <kcynice> i can't find a doxygen shell script to do it
[13:49] <kcynice> any hints?
[13:50] <kcynice> from configure, i can only find disable-doc, but i have not disable it
[15:52] <azk> Hi, can anyone explain to me the reason ffserver streams default to 160x128 instead of determining the source file size?
[17:48] <Jaska_> [Parsed_overlay_3 @ 0x235d2e0] [framesync @ 0x235d3c8] Buffer queue overflow, dropping.
[17:48] <Jaska_> trying to create 2x2 grid of 2 vids and 2 images..
[17:49] <Jaska_> 2 identical videos at constant framerate 30
[17:50] <Jaska_> so yeah, how do i avoid dropping frames?
[17:51] <Jaska_> 2 rtmp streams -> 1 rtmp stream  2x2 grid
[17:51] <Jaska_> + the jpg's
[17:58] <Jaska_> nvm it will never work anyway
[18:18] <Jaska_> ffmpeg just doesnt like rtmp streams encoded on fly?
[18:35] <Jaska_> ah nevermind thanks -re did the trick
[19:06] <t4nk595> does anyone have experience streaming MP4 input to HLS with ffserver?
[19:18] <randomguy123> i'm trying to stream theora/ogg from ffserver that's being fed by ffmpeg. It doesn't work. What do I need to do? I use mp4 file as an input to ffmpeg, but I get a error right away: av_interleaved_write_frame(): Unknown error
[19:18] <randomguy123> for ffserver config i use: https://trac.ffmpeg.org/wiki/Streaming%20media%20with%20ffserver#StreamingTheoravideowithVorbisaudioinOggformat
[19:19] <randomguy123> for ffmpeg i use this cmd: ffmpeg -i VID.mp4 http://localhost:8090/feed1.ffm
[19:24] <__raven_> hi
[19:26] <__raven_> trying to merge two video/audio-files gives me that error: Application provided invalid, non monotonically increasing dts to muxer in stream 0: 184230 >= 169830 whats that and how to solve?
[19:36] <mleise> I get an error message for some H.264 steam copy with -fflags +genpts (maybe unrelated):
[19:36] <mleise> [NULL @ 0x64b2a0] non-existing SPS 32 referenced in buffering period
[19:37] <mleise> What is a SPS?
[19:37] <jonascj> Hi all. The single jpeg option for ffserver, what is that?
[19:37] <jonascj> https://www.ffmpeg.org/ffserver.html
[19:58] <c_14> mleise: SPS or the Sequence Parameter Set is h264 metainformation that decoders use to decode video files.
[19:58] <c_14> Is that an error (ffmpeg stops running) or a warning (ffmpeg keeps running)
[19:59] <mleise> c_14: it is both... a red ERROR, but it keeps running
[19:59] <mleise> would that mean I could have lost information?
[20:00] <mleise> The source was from PowerDirector 12. Then I ran mkvmerge on it to add chapters.
[20:01] <mleise> Then I noticed severe slowdowns of some parts (I assume GOPs) and ran mkvextract to get back a H.264 elementary stream
[20:01] <c_14> It means that the source file is (at least partially) corrupted (ore just encoded incorrectly). Since you are using stream copy, the resulting stream should be identical to how an h264 decoder sees the first stream. (which may or may not be broken)
[20:02] <c_14> It should be fine though as long as the sps information is stored somewhere else within the file as well.
[20:02] <c_14> You'll probably just get that error every time you try decoding the file.
[20:02] <mleise> Then I ran avcon...err...let's say ffmpeg -f h264 -r 50 -fflags +genpts -i h264file -codec copy out.mp4
[20:03] <c_14> As long as the error isn't fatal and you can play the output, you should be fine.
[20:03] <mleise> hmm, so this error was most likely already in the original .m2ts?
[20:03] <mleise> ok
[20:06] <mleise> c_14: could that be related to the warning in mkvmerge that CTTS is unavailable? Is that part of the SPS or vice versa?
[20:07] <muken> none
[20:13] <c_14> It's similar, but I don't think it's directly related.
[20:14] <c_14> As long as the output looks fine, I wouldn't worry about it.
[21:00] <ScottSteiner_> I'm trying to burn subtitles into a video.  Is it possible to search ahead to a keyframe and then burn the subtitles in, while keeping the same timestamps?  "ffmpeg -ss 00:10:00 -vf 'ass=subs.ass' input.mkv -to 00:00:05 output.mkv" throws an error and putting the filter before the output uses the wrong timestamps
[22:14] <Lokie> hello, i followed this guide: https://trac.ffmpeg.org/wiki/UbuntuCompilationGuide to install ffmpeg. I searched a bit but didn't find an answer. When creating a webm is it possible to add subtitles?
[22:21] <sacarasc> What kind of subtitles? Soft, hard, if soft, what type?
[22:22] <Lokie> on the output should be hardsubs. the input .ass or .srt
[22:22] <sacarasc> Yeah, you should be able to do that, just a sec and I'll bring up a guide.
[22:22] <c_14> https://trac.ffmpeg.org/wiki/How%20to%20burn%20subtitles%20into%20the%20video
[22:22] <sacarasc> c_14 wins. :D
[22:23] <c_14> hihi
[22:23] <Lokie> thx
[22:23] <Lokie> sadly ffmpeg failed to compile properly
[22:23] <Lokie> i will try a static release for the time being
[22:31] <Lokie> is there a reason i should not use the static builds?
[22:34] <c_14> You shouldn't use static builds on the 3rd of every month and on even numbered wednesdays.
[22:34] Action: Lokie takes notes
[22:35] <c_14> As long as the static builds work and have all the features you want, use them.
[22:35] <c_14> If you want more/less features you have to build it yourself.
[22:35] <Lokie> i see
[22:35] <c_14> Also if you need the latest git head, you might need to build it yourself depending on how often the static builds are updated.
[22:36] <Lokie> i followed the guide but got hit with: gcc: internal compiler error: Killed (program cc1)
[22:36] <Lokie>  while building ffmpeg
[22:36] <c_14> That's an interesting error...
[22:36] <Lokie> and since my skills on linux are well lacking ...
[22:38] <c_14> Hmm, according to what I'm reading here, that happens either when gcc has a bug or when it doesn't get enough memory.
[22:38] <Lokie> 128M vps
[22:38] <Lokie> the 2nd i guess
[22:41] <c_14> Could be. If you want to compile it you might want to give it some swap.
[22:45] <Lokie> thx for the help btw c_14
[22:45] <Lokie> i never said that :P
[22:51] <Lokie> must be it
[22:51] <Lokie> another process got killed
[22:51] <Lokie> i think both ram and swap wasn't enough
[22:51] <Lokie> 128+128
[22:51] <c_14> I'd go with at least 512
[22:52] <mleise> You should try the D programming language. It usually doesn't free memory in the compiler right now :)
[22:52] <c_14> Or just use java?
[22:52] <mleise> yeah that's a good fit or OpenVZ with all the virtual memory preallocations!
[22:53] <mleise> Damn, it could be that my problem is https://trac.bunkus.org/ticket/918
[22:55] <Lokie> sadly can't increase it since it's a rented vps
[22:55] <mleise> Probably I should just produce my 4 hour video again and try ffmpeg to create the mkv instead of mkvmerge
[22:55] <Lokie> my main box can, but that's why i got some vps try shit there so i avoid bricking my main box XD
[22:55] <c_14> Lokie: create a swapfile?
[22:56] <mleise> I guess what I don't want is the container to rewrite presentation time stamps. Is that guaranteed for ffmpeg?
[22:56] <Lokie> mm
[22:56] <Lokie> that could work i guess
[22:56] <Lokie> will google
[22:56] <Lokie> thx :)
[22:56] <c_14> I'm not sure there are any guarantees as far as ffmpeg is concerned, but it hasn't broken anything for me yet.
[22:57] <mleise> it only takes a day or two to render the video :D
[22:57] <Lokie> i bet, but i prefer to be 100% i can setup something ok before i do it in the main box
[22:57] <mleise> and yes it was in four parts until I wanted it as one piece to add chapters and align sub titles
[23:18] <SpecialEd>  Hey guys, recently on ffmpeg I've been getting a lot of "AVC: nal size #######" and "missing picture in access unit with size 42" errors echo'd to my Ubuntu terminal shell when transcoding flash video to x264 mp4.
[23:18] <SpecialEd> The videos still play fine, but its kinda annoying how its basically spamming my terminal session, anyone else encounter this and/or know how I could quiet this down?
[00:00] --- Mon Apr 28 2014

More information about the Ffmpeg-devel-irc mailing list