[Ffmpeg-devel-irc] ffmpeg.log.20140114

burek burek021 at gmail.com
Wed Jan 15 02:05:01 CET 2014

[00:34] <i_s> figured it out, my pixel conversion was wrong
[01:02] <thebombzen> sorry 'bout that, testing my IRC client
[02:04] <FunkyELF> I have this file...  http://pastebin.com/iURM9HZd
[02:04] <FunkyELF> I want to encode it with x264 or something to shrink the size.  Also, I want to skip the last 3 seconds of the video.... what command line can I use for that?
[02:06] <relaxed> FunkyELF: ffmpeg -i input -t 05:50:28 ...
[02:07] <FunkyELF> Duration: 00:01:15.18, start: 0.000000, bitrate: 47072 kb/s
[02:08] <relaxed> -t 00:01:12
[02:09] <relaxed> it's HH:MM:SS
[02:09] <FunkyELF> relaxed: okay... I'm looking at the x264 encoding guide
[02:10] <FunkyELF> trying to find a list of all presets
[02:10] <relaxed> x264 --fullhelp
[02:10] <FunkyELF> As a shortcut, you can also list all possible internal presets/tunes for FFmpeg by specifying no preset or tune option at all:
[02:10] <relaxed> or http://mewiki.project357.com/wiki/X264_Settings
[02:10] <FunkyELF> but then that one line doesn't work
[02:11] <FunkyELF> relaxed: I don't have the x264 binary.  I have a static build of ffmpeg
[02:11] <relaxed> then check the url
[02:11] <FunkyELF> okay... when I use handbrake there is a slider for quality
[02:12] <FunkyELF> wondering what the corresponding ffmpeg swich would be
[02:13] <relaxed> https://trac.ffmpeg.org/wiki/x264EncodingGuide  look at -crf
[02:15] <FunkyELF> relaxed: thanks
[02:15] <llogan> FunkyELF: "-preset help" should list presets and tunes
[02:16] <FunkyELF> llogan: ffmpeg -preset help ?
[02:16] <relaxed> doesn't work here
[02:16] <FunkyELF> me neither
[02:17] <llogan> you replace "slow" or whatever with "help"
[02:17] <relaxed> `ffmpeg -preset help` ?
[02:17] <llogan> ffmpeg -y -f lavfi -i nullsrc -f mp4 -preset help /dev/null
[02:18] <llogan> see. easy.
[02:18] <relaxed> that's retarded
[02:18] <llogan> you couldn't tell i was joking...
[02:21] <relaxed> ffmpeg -h encoder=libx264 would be a good place
[02:21] <llogan> it's a libx264 AVoption so "-preset help" has to be invoked via the encoder
[02:24] <llogan> https://trac.ffmpeg.org/wiki/x264EncodingGuide#AdditionalInformationTips is a messy section. i'll blame roger
[02:25] <llogan> and the iOS chart should include refs since level does not modify refs, IIRC
[02:26] <llogan> although maybe that should be considered a bug
[02:37] <bencc> are there rules on allowed resolutions?
[02:38] <bencc> can I have for example 1000/750 in 4:3 aspect ratio and 992/558 in 19:6 aspect ratio?
[02:44] <sacarasc> bencc: Allowed by what?
[02:45] <relaxed> I allow it
[02:47] <bencc> by ffmpeg and display in media players and in the browser
[02:47] <bencc> releaxed: that's because you are relaxed :)
[02:48] <sacarasc> Computers generally don't care about resolutions.
[02:49] <sacarasc> If you were going for a DVD, then you'd have trouble.
[02:49] <bencc> ok. thanks
[03:37] <Fusl> uuuh... dunno if some of you guys speak german in here and if you're awake since it is 3:37am in germany but nevermind, http://www.heise.de/newsticker/meldung/Die-tausend-gestopften-Loecher-des-FFmpeg-2083744.html
[03:38] <Fusl> ah, and here is the english one: http://j00ru.vexillium.org/?p=2211
[03:39] <mocean> Hello, it seems that ffmpeg is only using 1 cpu core. Do I have to do anything specific when converting a file to mp3 to use multicore?
[03:40] <Fusl> try -threads X where X is your number of threads you want to start
[03:41] <Fusl> but i'm not sure it works with mp3
[03:41] <sacarasc> I don't think you can do multi-cored MP3.
[03:41] <sacarasc> You'd have to just run multiple commands.
[03:42] <mocean> hmm
[03:42] <mocean> so ffmpeg --threads 4 ?
[03:43] <Fusl> no, single dash
[03:43] <sacarasc> ffmpeg -i input.flac -threads 4 output.mp3
[03:43] <sacarasc> But it won't do anything. :D
[03:43] <Fusl> it is not supposed to do anything
[03:44] <Fusl> `ps auxwwe` and check if ffmpeg spawns threads there
[03:44] <Fusl> ehm
[03:44] <Fusl> no
[03:44] <Fusl> ps fauxww
[03:45] <Fusl> .. and also check if all of them eat up cpu cycles
[03:52] <mocean> -threads does not seem to make a difference, only one core is used at 100%
[03:52] <sacarasc> [02:41:06] <sacarasc> I don't think you can do multi-cored MP3.
[03:52] <sacarasc> [02:41:18] <sacarasc> You'd have to just run multiple commands.
[03:53] <mocean> I don't understand that statement
[03:53] <mocean> Multi commands to convert an mp3?
[03:53] <sacarasc> Yes. With one command, do one, then do another with a different command at the same time.
[03:57] <mocean> but it's one file that's over a gig in size
[03:59] <sacarasc> You'd probably have it done if you continued single thread when you joined. :D
[04:02] <mocean> it was saying over 2 hours till completion
[04:04] <Fusl> mocean: how about split them up into 4x 30 minutes parts and then concat them?
[04:07] <mocean> I guess that could work
[04:08] <mocean> Surprised that multi threads does not work with mp3, people have had multi core cpu's for a long time now
[04:08] <Fusl> tbh, i'm surprised too :/
[04:15] <Fusl> mocean: idk if there is another automatic and better way of doing this but this is what i used last time: http://sprunge.us/QiQN
[04:25] <mocean> thanks Fusl
[04:25] <Fusl> youre welcome :)
[06:14] <hayuto> how do i get ffmpeg compiled with all the possible options
[06:15] <relaxed> hayuto: do you need all of them?
[06:15] <hayuto> i want it for hls streaming my default ffmpeg installed on server gives syntax error in baseline vprofile
[06:18] <hayuto> http://pastebin.com/V87TYFUT
[06:19] <hayuto> if i delete baseline and acodec it works but it drops frames all the time
[06:19] <hayuto> i tried -s 640x480
[06:20] <relaxed> that version is way too old. FreeBSd ports has the most recent version: http://www.freshports.org/multimedia/ffmpeg/
[06:22] <hayuto> hmm i cant install it im not admin
[06:23] <hayuto> but i can compile from github
[06:23] <hayuto> but theres a lot of options
[06:25] <hayuto> what is the option to enable the movie:movie.avi:loop=1 stuff?
[06:27] <hayuto> lavfi but theres nothing like that
[06:27] <hayuto> ok i try with what i know
[06:32] <relaxed> you can compile it locally but with FreeBSD that will likely be a pain.
[06:33] <relaxed> which FreeBSD version are we talking about? 9.x ?
[06:33] <hayuto> 9.2-STABLE FreeBSD 9.2-STABLE
[06:34] <relaxed> ask the admin to upgrade ffmpeg
[06:34] <hayuto> yeah i did that
[06:34] <relaxed> what did he say? FUUUUUUUUU?
[06:35] <hayuto> =D no they are asleep probably noone answered yet
[06:35] <hayuto> im on their irc channel
[06:35] <hayuto> so im waiting
[06:35] <hayuto> but i tought it would be faster to compile from git.hub
[06:35] <hayuto> but it isnt so easy
[06:36] <hayuto> a lot of things missing on their system or i dont know how point ffmpeg to them or where they are
[06:37] <relaxed> ./configure --extra-cflags="-I/usr/local/include" --extra-ldflags="-L/usr/local/lib"
[06:38] <relaxed> plus whatever you're trying to --enable
[06:47] <relaxed> hayuto: it might be harder if you're in a jail
[06:48] <hayuto> why
[06:49] <relaxed> you might be limited, I've never tried from within one
[06:49] <hayuto> yeah but why i would go to jail
[06:49] <hayuto> =o
[06:49] <relaxed> a freebsd jail, mr. funny man
[06:50] <hayuto> oh
[06:51] <hayuto> i think it must be the options they give on hls site
[06:51] <hayuto> baseline and this sound codec
[06:51] <hayuto> exact same
[06:51] <hayuto> cause now im testing without baseline, also no sound with copy
[06:51] <hayuto> maybe android only can play this baseline profile
[06:52] <hayuto> without it i get terrible framrate
[06:52] <hayuto> if you have android its here
[06:52] <hayuto> i think only chrome beta can play it tough
[06:53] <hayuto> ;/
[07:00] <hayuto> k i try with new version when i can
[07:00] <hayuto> and will report back
[07:39] <llogan> hayuto: you could just try a ffmpeg build from links via ffmpeg download page. should work on *bsd, right? only problem they won't have faac support
[07:40] <llogan> but you can use -acodec aac -strict experimental if you need to
[07:41] <JEEB> both faac and fdk-aac are nonfree so you are not supposed to be able to distribute binaries with them
[08:09] <hayuto> i need to know whats best for html5 and android
[08:12] <Fusl> hayuto: which container format?
[08:15] <hayuto> it generates hayuto-220.ts   hayuto-221.ts   hayuto-222.ts   hayuto-223.ts   hayuto-224.ts   hayuto.m3u8
[08:16] <hayuto> application/vnd.apple.mpegURL         m3u8;
[08:16] <hayuto> video/MP2T                            ts;
[08:18] <hayuto> MPEG transport stream data <- when i do file *.ts
[08:20] <hayuto> it kind of make me think if its releted to android not being ready to play full blown streams yet
[08:20] <hayuto> or its badly encoded
[08:21] <hayuto> the test files on jwplayer6 hls page are played super good and quality but its not real live stream
[08:24] <relaxed> hayuto: what's your command?
[08:25] <hayuto> this /usr/local/bin/ffmpeg -re -i rtmp:// -vcodec libx264 -g 10 -ar 44100 -ac 1 -f flv rtmp://
[08:26] <hayuto> but nginx generetes the files i dont know
[08:26] <hayuto> because i tried /usr/local/bin/ffmpeg -re -i rtmp:// -vcodec libx264 -vprofile baseline -g 10 -acodec libfaac -ar 44100 -ac 1 -f flv rtmp://
[08:26] <hayuto> but it gave error, so now im waiting for new version of ffmpeg
[08:28] <hayuto> yeah it actually dont stream anything
[08:28] <hayuto> nginx captures it and generates this files
[08:28] <hayuto> so you can use them in <video></video>
[08:28] <hayuto> the actual stream is the /live/
[08:29] <relaxed> try -vpre baseline instead of -vprofile baseline and add -crf 16
[08:32] <relaxed> pastebin if you have more errors
[08:37] <hayuto> ok
[08:40] <relaxed> the options have changed so much over various versions that it's hard to remember what worked when.
[08:42] <hayuto> it works, still hangs from time to time
[08:44] <hayuto> but theres nothing in ffmpeg
[08:44] <hayuto> no red text
[08:45] <hayuto> it encodes ok from what i see
[08:45] <hayuto> oh no theres something, [h264 @ 0x807428020] mmco: unref short failure
[08:45] <hayuto> [h264 @ 0x807428020] Missing reference picture
[08:46] <hayuto> drop is only 2
[09:06] <xlinkz0> i've used this in my wrapper class : double fps() { return 1.0 / av_q2d(m_codec->time_base) / FFMAX(m_codec->ticks_per_frame, 1); }
[09:07] <xlinkz0> however it returns 90k for some video file
[09:52] <GT1> Hi guys, I just came back to say thanks for the help and to share my findings
[09:53] <GT1> if you remember I had problem with itsoffset not delaying the audio when used with overlay and all. What I ended up was just adding a little -async 1 to the end of the command which fixed my problem. The audio got to its right place and the video wasn't lagging
[09:53] <ubitux> cool :)
[09:53] <GT1> so If you have similar problem that your audio is not delayed by itsoffset or your overlay image gets lagging, just add this command
[09:54] <GT1> :D I'm soooo happy now :D
[10:00] <GT1> k, I'll be leaving then :) thanks for the help!
[10:17] <Justice> Im trying to stream to twitch however i got some issues. The requirements are frame interval 2 seconds but when using -g 2 and max bitrate to 3M the quality is poor
[10:18] <Justice> removing gop will make the quality better however streaming to twitch after 6-10minutes the stream will get distorted
[10:19] <JEEB> -g is in pictures
[10:19] <JEEB> so you get two-picture gops :P
[10:19] <Justice> oh
[10:19] <JEEB> also do you properly use maxrate and bufsize?
[10:20] <Justice> um using -maxrate 3M and bufsize 3M
[10:20] <Justice> I'm
[10:20] <JEEB> if those are correct for your use case that's correct
[10:20] <Justice> but how can I set Keyframe Interval: 2 seconds ?
[10:20] <JEEB> well, how many pictures per second do you have?
[10:21] <Justice> im setting 30 FPS
[10:21] <JEEB> thus, <seconds>*<pictures per second>
[10:22] <Justice> so gop should be -g 2*30 ?
[10:22] <JEEB> which is?
[10:22] Action: Justice let me bring my calculator up...
[10:22] <Justice> haha 60 but yeah
[10:23] <JEEB> yup
[10:23] <JEEB> that's it
[10:25] <Justice> btw if the bitrate does not achive the maxrate setting is there a reason for that?
[10:25] <Justice> is that network or hardware or both?
[10:27] <Justice> JEEB: http://codepad.org/MstZ1u3m
[10:27] <Justice> should be right ?
[10:29] <JEEB> maxrate and bufsize only limit the bandwidth (of video, methinks)
[10:29] <JEEB> since I think they set the vbv settings in libx264
[10:30] <JEEB> and yes, that looks relatively OK, I would personally build ffmpeg with fdk-aac myself tho and use it to encode AAC
[10:30] <JEEB> also you're using crf, nice
[10:31] <Justice> hm lets see if this works stream is on 7th minute hopefully it wont corrupt
[10:33] <JEEB> if you get corruption it's likely due to something else
[10:33] <Justice> any ideas what?
[10:33] <Justice> Playing with the settings does change how fast the corruption occur though
[10:34] <Justice> before it would just show up at 3minute mark playing with rate and cfr incresed it to 6/11minutes
[10:34] <JEEB> sounds like you're using too much bandwidth or something?
[10:34] <Justice> that or it was just coincidence
[10:34] <JEEB> I really don't know :P
[10:35] <JEEB> since you're using a restreaming service it should set the limits for bandwidth
[10:35] <Justice> i got 250Mbit upload so cannot say it is netowrk issues so maybe twitch thing or my Asus router crying =)
[10:35] <BtbN> which platform are you using?
[10:35] <BtbN> twitch is one huge network issue
[10:36] <Justice> platform as OS or?
[10:36] <BtbN> yeah
[10:36] <Justice> Linux
[10:36] <Justice> Arch to be specific
[10:36] <BtbN> hm, so no OBS for you yet
[10:36] <JEEB> well, look for the bandwidth limitations on your service is all I can say :P
[10:37] <JEEB> also keep an eye on the encoding rate, to make sure you're not getting too slow at any point
[10:38] <Justice> meh corruption
[10:38] <Justice> have a look http://www.twitch.tv/commanderalchemy
[10:39] <JEEB> yeah, just make sure you're actually setting your VBV limits properly, and then make sure your encoding picture rate does not drop while you stream
[10:41] <Justice> encoding rate you meaning fps or?
[10:41] <JEEB> yes, ffmpeg should be keeping the number up updating
[10:42] <Justice> yeah both the fps and bitrate keeps at 30fps and 1100k
[10:44] <Justice> hm must be twitch or something else then?
[10:53] <Fusl> someone knows if i can set the thickness of showwaves dots?
[11:00] <BtbN> Justice, twitch is extremely sensitive with their video. Do they show it as Excelent quality?
[11:01] <Justice> BtbN: Exelent quality?
[11:01] <BtbN> yeah, if they don't they also explain why not
[11:01] <Justice> where does that say that?
[11:02] <BtbN> on your streamer page
[11:03] <Justice> BtbN: hm cannot seem to find anything like that, um channel page or ?
[11:04] <BtbN> your streamer page, not the channel itself
[11:06] <Justice> I must be blind cannot really see it....
[11:06] <GT1> rofl, hi I'm back again :(
[11:06] <GT1> I have a strange notice from ffmpeg
[11:07] <GT1> TIFF tag type (0) is not implemented. Update your FFmpeg version to the newest one from Git. If the problem still occurs, it means that your file has a feature which has not been implemented.***
[11:07] <GT1> any idea?
[11:08] <Fusl> can ffmpeg also do such visualizations like the vlc spectrum one? http://imgur.com/Voe3zFo
[11:08] <Justice> BtbN: you sure its not an exclusive partner thing?
[11:09] <BtbN> no, iz'd noz.
[11:09] <BtbN> it's not
[11:09] <BtbN> it's huge label on your streamer page. It's either green, saying "Excelent" or something else, telling you what's wrong.
[11:10] <GT1> Anyone have an idea why can't my ffmpeg interpret android camera made image? TIFF tag type (0) is not implemented. Update your FFmpeg version to the newest one from Git. If the problem still occurs, it means that your file has a feature which has not been implemented.***
[11:10] <Justice> BtbN: there I found it
[11:10] <Justice> BtbN: its on dashboard
[11:10] <BtbN> yeah, the streamer page
[11:11] <Justice> odd it complains about keyframe interval and bitrate
[11:11] <BtbN> twitch needs an absolutely constant bitrate, and exactly 2 seconds keyframe interval
[11:11] <Justice> BtbN: it should be
[11:12] <GT1> ubitux: are you here?
[11:12] <Justice> BtbN: http://codepad.org/MstZ1u3m those are my settings
[11:12] <ubitux> i'm hiding in the dark
[11:12] <ubitux> Fusl: yes, showspectrum filter
[11:12] <GT1> :)) have you ever encountered something like this? [mjpeg @ 0x404a8230] TIFF tag type (0) is not implemented. Update your FFmpeg version to the newest one from Git. If the problem still occurs, it means that your file has a feature which has not been implemented.***
[11:12] <Fusl> ubitux: the right bottom one is showspectrum but that's not nearly the same spectrum (left one) as in vlc
[11:13] <BtbN> Justice, that's not constant bitrate, as far as i can see
[11:13] <ubitux> Fusl: we don't have a mode like that, patch welcome i'd say
[11:13] <GT1> do I need any special build configuration?
[11:13] <ubitux> GT1: dunno
[11:13] <ubitux> open a ticket
[11:14] <Justice> BtbN: this should help no ? "-minrate 3M -maxrate 3M -bufsize 3M"
[11:14] <BtbN> that's not CBR mode
[11:14] <Fusl> any alternatives? i've read about some gstreamer-tools visualizations which i could use but i need some headless utils which convert via cpu (like ffmpeg)
[11:14] <Justice> BtbN: all documentation I found is that there is no CBR mode
[11:15] <BtbN> x264 does have one, so ffmpeg should forward that somehow
[11:15] <Justice> "There is no native CBR mode, but you can "simulate" a constant bit rate setting by tuning the parameters of ABR:"
[11:15] <ubitux> Fusl: you could add a mode to showspectrum :p
[11:15] <GT1> ubitux: Silly question :P how to add ticket?
[11:16] <ubitux> GT1: http://trac.ffmpeg.org/
[11:16] <Fusl> ubitux: yeah, combined/separate which still don't do the same as vlc's spectrum does :(
[11:19] <Justice> BtbN: acording to https://trac.ffmpeg.org/wiki/x264EncodingGuide#FAQ
[11:20] <Justice> there is no CBR native so min max rate is the onlyway
[11:37] <Justice> BtbN: seems that the stream is exelent until some time and then it gets corruption and it tells me that the keyinterval is at  116.0 seconds even though nothing has changed on my end
[11:39] <allengreen> can vlc's slider works for rtsp url?
[11:42] <Fusl> can someone tell me what i've done wrong here? http://sprunge.us/GSHZ
[11:42] <Fusl> i'm trying to overlay the showwave effect with the avectorscope effect
[11:43] <Mavrik> Fusl, em
[11:43] <Fusl> Mavrik: yes?
[11:43] <Mavrik> you're saying "split audio to two channels and name them [out1] and [a]"
[11:43] <Fusl> OH
[11:43] <Mavrik> and then you're saying "take stuff from [b] ..."
[11:43] <Mavrik> and ffmpeg doesn't like that :P
[11:43] <Fusl> yeah, i forgot to change "2" to "3"
[11:47] <Fusl> hmm... the avectorscope effect seems to generate a black background which completely covers the showwaves filter ... can i change the background of avectorscope to transparent or at least filter out the black color to transparent with another effect?
[11:49] <ubitux> mmh i don't remember if we finally have such filter
[11:49] <ubitux> saste: do we have that color to transparency filter? i don't remember :(
[11:51] <saste> ubitux, color to transparency??
[11:52] <Fusl> saste: i want to overlay 2 generated video streams where the foreground one has a black background-colour which i want to remove so that the background-stream comes through
[11:52] <saste> Fusl: how do you generate the background?
[11:53] <saste> -> foreground
[11:53] <Fusl>  /usr/local/bin/ffmpeg -i mix.mp3 -ab 320k -ac 2 -acodec libmp3lame -ar 48000 -vcodec libx264 -b:v 5M -filter_complex "asplit=3[out1][a][b]; [a]avectorscope=s=1920x1080:zoom=4:rate=24:mode=lissajous_xy,format=yuv420p[scope]; [b]showwaves=s=1920x1080:mode=line[waves]; [waves][scope] overlay [out0]" -map [out0] -map [out1] -preset ultrafast -r 24 -s hd1080 -threads 16 -f avi mix2.avi
[11:53] <saste> avectorscope?
[11:53] <saste> ideally we should have an option to set the foreground color
[11:54] <saste> ahhh!! -> the background color
[11:54] <saste> so you can make it completely transparent
[11:57] <Fusl> however, i also tried "blend=all_mode=overlay:all_opacity=0.7" instead of "overlay" but that doesn't work :/
[12:00] <saste> Fusl, did you read my comment? would an option setting the background color fix the issue?
[12:00] <Fusl> tbh, i really don't know :S
[12:01] <Fusl> how can i test if avectorscope really outputs a black and not a transparent background?
[12:02] <GT1> ubintux: this is what I get
[12:02] <GT1> http://pastebin.com/fkT6CFyP
[12:03] <GT1> and this is the image I try to encode
[12:03] <GT1> https://www.dropbox.com/s/nat0eyagy76tq06/input.jpg
[12:04] <GT1> can somebody test if he can encode this image?
[12:17] <Fusl> saste, ubitux: did it! i had to format the avectorscope effect with "yuva444p" and "lut"(?) it with "c3=128" (50%): /usr/local/bin/ffmpeg -i mix.mp3 -ab 320k -ac 2 -acodec libmp3lame -ar 48000 -vcodec libx264 -b:v 5M -filter_complex "asplit=3[out1][a][b]; [a]avectorscope=s=1920x1080:zoom=4:rate=24:mode=lissajous_xy,format=yuva444p,lut=c3=128[scope]; [b]showwaves=s=1920x1080:mode=line[waves]; [waves][scope]overlay[out0]" -map [out0] -map [out1] -preset
[12:17] <Fusl> ultrafast -r 24 -s hd1080 -threads 64 -f avi mix2.avi ( http://dericed.com/2012/display-video-difference-with-ffmpegs-overlay-filter/ )
[12:29] <Fusl> why isn't ffmpeg using all 64 cores here, althought -threads 64 is set? it only uses 1 core which is the reason it takes a few hours to convert those files O.o
[12:29] <BtbN> not all codes support parallelizing
[12:29] <BtbN> *codecs
[12:30] <Fusl> which do?
[12:30] <Fusl> (i need to upload that video later on youtube)
[12:58] <theholyduck> Fusl, filtering probably isnt multithreaded (just an educated guess)
[12:58] <theholyduck> Fusl, x264 is multithreaded, but, last time i checked, it only supported up to 16 threads?
[13:03] <JEEB> no, it can go over that
[13:03] <JEEB> it depends on the settings of course, and generally you start getting bottlenecks somewhere else in the chain
[13:10] <akovia> Hi, for some reason I can't get "pad" to work. Been following the examples here http://www.ffmpeg.org/ffmpeg-filters.html#pad, but I always get the error "Unable to find a suitable output format for 'pad=1920:1080:0:12:black'
[13:11] <akovia> here is my command
[13:11] <akovia> ffmpeg -i Common-Poster-Errors.mkv pad="1920:1080:0:12:black" ~/Videos/Screencasts/Poster-Errors.mkv
[13:11] <akovia> oh very sorry :(
[13:13] <akovia> http://pastebin.com/K323GYJE
[13:19] <ubitux> akovia: missing -vf btw.
[13:19] <ubitux> but don't use that tool
[13:20] <akovia> tyty!
[14:18] <Justice> is there a reason on why max keyframe interval keeps increesing even though i have set a limit with -g ? when streaming?
[14:18] <Justice> is that packet drops or on my side?
[14:26] <JEEB> Justice, there shall be no GOPs longer than what you set with -g
[14:32] <Justice> hm looking at docs it seems it only sets the minimum interval ?
[14:32] <JEEB> no
[14:32] <JEEB> maximum
[14:32] <JEEB> GOPs can be longer than -g
[14:32] <JEEB> uhh
[14:32] <JEEB> shorter
[14:33] <JEEB> but they can only go as long as -g
[14:33] <Justice> okay hm found also -keyint_min
[14:33] <Justice> guessing thats the min
[14:33] <JEEB> yes
[14:33] <JEEB> but you shouldn't touch that
[14:33] <JEEB> in general only the maximum counts
[14:33] <JEEB> the minimum with x264 is generally same
[14:34] <JEEB> *sane
[14:34] <JEEB> goddamnit
[14:34] <JEEB> what's with the typos
[14:34] <Justice> Thing is im streaming to twitch and after a while it gets distorted and twitch tells me its getting keyinterval att 100 instead
[14:34] <JEEB> then you're pushing something wrong there, and if you've set -g then it's something else
[14:35] <JEEB> because -g is the maximum, there cannot be a longer GOP
[14:35] <Justice> can it change because of packetloss or something?
[14:35] <Justice> here is the script I use, http://pastebin.ubuntu.com/6750469/
[14:35] <Justice> just added min to check if that helps but...
[14:39] <albator> hello
[14:39] <albator> I d like to play my videos slightly slower than normal speed , and I am trying this
[14:40] <albator> -filter:a "atempo=0.85" -filter:v "setpts=1.25*PTS"
[14:40] <albator> but I get audio "asynch"
[14:40] <albator> what can I do?
[14:40] <JEEB> Justice, remove the min :P x264's default is sane. And yes, if it doesn't read all of your packets then of course it can miss an IRAP
[14:40] <JEEB> which is why I noted that you should check the bandwidth limits from the restreamer
[14:42] <Justice> well im streaming from my desktop and my network is 250mbit/s upload so cannot see that, just checked the speed to few servers so its sane there.
[14:42] <JEEB> no I mean
[14:42] <JEEB> whatever the RESTREAMER wants
[14:42] <JEEB> and will be giving out
[14:43] <Justice> restreamer?
[14:43] <JEEB> you -> restreamer -> public
[14:43] <JEEB> capisci?
[14:43] <Justice> yes now I do thing is that wtich tells you what is wrong with stream if something is wrong
[14:43] <JEEB> no just goddamn read the docs
[14:43] <JEEB> they have to say the maxrate and amount of buffer somewhere
[14:43] <JEEB> and that's one of the most common problems, VBV
[14:44] <albator> yes it s on the broadcasting requirement...
[14:44] <albator> but they are idiots...
[14:44] <Justice> 3M is their recomended for 720p
[14:44] <JEEB> recommended what
[14:44] <albator> https://help.justin.tv/entries/25128411-Broadcast-Requirements
[14:44] <Justice> bitrate etc
[14:44] <JEEB> argh
[14:44] <JEEB> seems like you still don't understand
[14:44] <JEEB> even if someone tells you 3M that just means that the maxrate is that
[14:44] <JEEB> you have no idea of buffer size then
[14:45] <Justice> they want CBR so min and max should be the same, and i read that they want a buffer thats equal or higher than bitrate
[14:45] <JEEB> they don't want CBR
[14:45] <JEEB> real CBR does not exist in video world except for very weird circuimstances
[14:46] <Justice> "Mode: Strict CBR"
[14:46] <Justice> thats on their requirements page
[14:46] <JEEB> they just write CBR because many apps call VBV-limited ABR like that
[14:46] <Justice> o.O
[14:46] <JEEB> yes
[14:47] <albator> btw  , any idea on my slowing speed issue? (sorry to ask)
[14:47] <Justice> JEEB: but they complain when the avg bitrate and maximum bitrate is differing so it must be CBR no ?
[14:47] <JEEB> no
[14:47] <JEEB> they want VBV-limited ABR that is within the VBV limitations
[14:48] <JEEB> albator, gotta love it how they say NOTHING about VBV. They just expect that the goddamn tools the user uses already has a preset for the service
[14:48] <JEEB> fuck that
[14:48] <JEEB> with a large wrench
[14:48] <albator> ofc
[14:49] <albator> but this is mainstream.. when u use ffmpeg with command line, you are on your own
[14:49] <albator> and u end up here :D
[14:49] <JEEB> they could at least note their buffering model :P
[14:49] <JEEB> fuckers
[14:49] <Justice> meh its like tripple buffering on vsync i guess then
[14:50] <Justice> they just call it what they want even though its not it...
[14:50] <JEEB> generally you should at the very least get the maxrate and the amount of buffering in either seconds or bits
[14:50] <JEEB> from seconds you can basically calculate the bufsize with <seconds>*<maxrate>
[14:51] <JEEB> and that should be it, but if the fuckers don't give out the info... :V
[14:51] <JEEB> anyways, do also really check that you're encoding fast enough so the encoder is not dropping behind
[14:52] <Justice> well the fps is stable att 30fps
[14:53] <Justice> only that is not getting up enough is the bitrate that is mostly at 1.5M when streaming
[14:54] <Justice> hm i wonder what settings OBS uses for twitch since its opensource it should be somewere maybe git
[14:56] <albator> btw, i broadcast there and I dont use any of those settings you have.. like buffer keyint etc
[14:56] <albator> maxrate..
[14:56] <albator> just saying
[14:56] <Justice> I tried without
[14:56] <Justice> but after a while i get distortion
[14:57] <albator> on the bottom of the picture?
[14:57] <Justice> no whole
[14:57] <albator> hm
[14:57] <Justice> like the pixels are not updated enough
[14:57] <albator> remembers me vlc
[14:57] <JEEB> albator, you need to have VBV or you are DoingItWrong
[14:57] <albator> and jtvlc
[14:57] <JEEB> as in, maxrate and bufsize
[14:58] <JEEB> otherwise the encoder does not limit itself to any bandwidth
[14:58] <albator> i just setup the crf:v
[14:58] <JEEB> yes, exactly
[14:58] <albator> yes and I dont need to
[14:58] <JEEB> eh
[14:58] <JEEB> so you don't want to set any minimum bandwidth that your stream can be watched with?
[14:58] <JEEB> cool story bro
[14:59] <JEEB> basically, under certain circuimstances it _can_ work
[14:59] <albator> well I m reasonable with the crf that's all
[14:59] <albator> yes it does if your files are similar
[14:59] <Justice> what cfr are you using?
[14:59] <JEEB> it does not work, it just /happens/ to work
[14:59] <JEEB> seriously, start using VBV
[14:59] <albator> for 480p mostly 26 , 30 for 720p
[14:59] <JEEB> if your rate is less than the limits, it will not do anything
[14:59] <JEEB> but if you suddenly get changes, maxrate/bufsize will limit the rate
[14:59] <albator> yes I understand
[14:59] <JEEB> no, you do not
[15:00] <JEEB> as long as you don't use it you don't understand
[15:00] <albator> I understand it s to avoid peak in the video bitrate
[15:00] <JEEB> no, it is to make sure that average bit rate never goes over maxrate within the buffer
[15:00] <JEEB> you can have peaks
[15:01] <JEEB> the whole idea of VBV is to enable safe peaks
[15:01] <albator> but i am not using buffer
[15:01] <Justice> JEEB: so to make it vbv just change -maxrate and minrate to vbv-maxrate and same for minrate ?
[15:01] <albator> donno how they manage that on their side
[15:01] <JEEB> Justice, -maxrate and -bufsize are the VBV options
[15:01] <JEEB> albator, THEY DON'T
[15:01] <JEEB> and you are doing it fucking wrong
[15:01] <JEEB> seriously
[15:02] <JEEB> add maxrate and bufsize according to what the restreamer requests
[15:02] <albator> they dont request I think
[15:02] <JEEB> oh they do
[15:03] <albator> btw JEEB, do you know how to slow down a video in synch with audio?
[15:03] <JEEB> now, seriously, please do not spread non-VBV limited streaming setups. People already have very little info on VBV even though it's a simple thing.
[15:03] <albator> sorry to ask again :P
[15:03] <JEEB> albator, modify the PTS?
[15:03] <albator> 	-filter:a "atempo=0.85" -filter:v "setpts=1.25*PTS"
[15:04] <albator> but I get audio out of sync
[15:04] <JEEB> I have no idea about the audio part
[15:04] <JEEB> sorry
[15:04] <JEEB> also
[15:04] <JEEB> 0.85 and 1.25?
[15:04] <JEEB> shouldn't that be 0.75?
[15:04] <albator> audio i think 1= normal speed
[15:04] <albator> PTS = not sure
[15:05] <JEEB> PTS is just a value, it will change depending on where the picture is in the video
[15:05] <JEEB> it's not a tempo
[15:05] <albator> makes it hard to setup
[15:05] <JEEB> but yes, if you x1.25 all PTS values then you will make the clip longer
[15:05] <JEEB> and pictures change slower
[15:05] <Justice> JEEB: what should i change in the script to make it vbv, im looking all round google but everything is conflicting with eachother..
[15:05] <albator> yes
[15:05] <albator> that's the point
[15:05] <JEEB> Justice, just -maxrate and -bufsize
[15:06] <JEEB> those are the VBV settings
[15:06] <JEEB> as I said already
[15:06] <viric> can the pts be used to change A-V offset?
[15:06] <albator> I also put audio slower, but it's not sync..
[15:06] <Justice> JEEB: should i have CRF ?
[15:06] <JEEB> Justice, that's the main rate control mode, VBV has nothing to do with that
[15:06] <JEEB> you can use it with everything but the constant quantizer mode, which you should not use anyways
[15:06] <JEEB> (only meant for development purposes)
[15:07] <Justice> I see
[15:07] <JEEB> basically you use some rate control X and then limit it to your VBV limits with maxrate/bufsize
[15:07] <JEEB> albator, as I noted are you sure the number on the audio side is correct?
[15:08] <JEEB> if you did 1.25 wouldn't it be 0.75?
[15:08] <JEEB> not 0.85
[15:08] <albator> To double the speed of audio:
[15:08] <albator> ffmpeg -i input.mkv -filter:a "atempo=2.0" -vn output.mkv
[15:08] <albator> The atempo filter is limited to using values between 0.5 and 2.0 (so it can slow it down to no less than half the original speed, and speed up to no more than double the input).
[15:08] <albator> so 1 is normal speed I think
[15:09] <albator> 1.25 25% faster
[15:09] <albator> i guess..
[15:10] <albator> oh I see what you mean
[15:10] <albator> let's try ;)
[15:12] <albator> still not good..
[15:13] <JEEB> no idea then :P
[15:14] <albator> yep
[15:14] <albator> maybe I can try using the -r input value
[15:14] <albator> tuning a bit
[15:26] <nahkunt> hi. i used ffmpeg to convert some mp4s to gifs. the problem is the gif filesizes are huge, about 16x larger
[15:26] <nahkunt> anything i can do about that?
[15:32] <ubitux> nahkunt: is your ffmpeg recent enough?
[15:33] <ubitux> if so, try with -pixfmt rgb24
[15:33] <ubitux> -pix_fmt*
[15:35] <nahkunt> ok
[15:36] <nahkunt> ubitux: same size
[15:36] <nahkunt> it said Incompatible pixel format 'rgb24' for codec 'gif', auto-selecting format 'pal8'
[15:37] <ubitux> you're problably not up-to-date
[15:38] <nahkunt> i'm using 2.1.1-3
[15:38] <nahkunt> should i switch to git?
[15:42] <ubitux> should be good enough
[15:42] <ubitux> can you do the paste?
[15:48] <nahkunt> ubitux: http://ix.io/9Rm
[15:49] <ubitux> mmh
[15:49] <ubitux> rgb8 maybe?
[15:51] <nahkunt> ubitux: great! now the gif file is only 6.66x the size of the mp4
[15:51] <ubitux> sounds legit
[15:51] <nahkunt> reckon it would be possible to go lower?
[15:51] <ubitux> you can try playing with the flags
[15:52] <ubitux> try -gifflags -transdiff
[15:52] <ubitux> sometimes it's bigger
[15:52] <ubitux> sometimes it's smaller
[15:52] <ubitux> depending on the source
[15:53] <nahkunt> well thank you sir
[15:54] <ubitux> it won't be as effective as other tools anyway
[15:54] <ubitux> but it should be good enough for most cases
[15:54] <nahkunt> ubitux: maybe i should use ffmpeg to convert the mp4s into pngs and then use imagemagick to create gifs?
[15:54] <ubitux> maybe
[15:54] <ubitux> or improve our encoder :p
[15:55] <ubitux> but you would probably need a 2-pass mode
[16:11] <k0bi> hi i run "C:\ffmpeg"  -i "rtmp://ip/room_5280/90 live=1" -s 250x186 -r 6 c:\tmp\5280\frame%d.jpg and it stuck ofter saying  "hasAudio              FALSE"?
[16:13] <k0bi> any idea?
[16:49] <k0bi> any one a live here?
[16:53] <jnvsor> k0bi: Nope
[16:56] <k0bi> hi <jnvsor>
[16:56] <k0bi> i am trying to extract jpeg from fms
[16:57] <k0bi> ofter running  hi i run "C:\ffmpeg"  -i "rtmp://ip/room_5280/90 live=1" -s 250x186 -r 6 c:\tmp\5280\frame%d.jpg and it stuck ofter saying  "hasAudio              FALSE"?
[16:57] <k0bi> if hasAudio TRUE it works but if its fals it stuck
[16:57] <k0bi> any idea?
[17:03] <jnvsor> k0bi: Sorry, you want to extract a screenshot from the video stream?
[18:02] <mankyd> Howdy! I am attempting to dump the frames from a 32 second long video, but I'm only getting 55 frames. I'm wondering if someone can help.
[18:03] <mankyd> The images in the frames cover the entire extent of the video (its a screen record with lots of redundant frames), but I need fine-grained timing resolution so that I can tell when in the video each frame occurs
[18:03] <mankyd> the command is simply: avconv -i speedindex.mp4 -f image2 image-%5d.jpg
[18:04] <brontosaurusrex> !avconv
[18:07] <mankyd> Please excuse my ignorance, brontosaurausrex, are you implying that this is not the place to ask about avconv?
[18:07] <mankyd> I originally used ffmpeg, it told me "This program is only provided for compatibility and will be removed in a future release. Please use avconv instead."
[18:08] <mankyd> I received the same problem when I used ffmpeg, of course
[18:08] <Mavrik> no, this isn't the place to ask about avconv.
[18:15] <brontosaurusrex> mankyd, what os are you on?
[18:16] <Mavrik> if he's getting that message he's on Ubuntu 12.04, Debian stable or equivalent
[18:17] <brontosaurusrex> or debian perhaps?
[18:36] <albator> is it possible to have an idea, for example, how much setpts=2.0*PTS   is actually slowing down?
[18:36] <albator> and what is the value that doesn't change the speed at all
[19:01] <jnvsor> albator: PTS is the time value of the input, 2*PTS is twice that meaning the video will be half speed
[19:02] <albator> thx
[19:02] <albator> so 0.5 is 2x faster
[19:02] <JEEB> yup
[19:04] <albator> i m trying the filter complexe example but no success atm..
[19:04] <albator> -filter_complex "[0:v]setpts=0.5*PTS[v];[0:a]atempo=2.0[a]" -map "[v]" -map "[a]" output.mkv
[19:18] <coalado> I'd like to have static ffmpeg builds for linux/mac/windows to avoid codec licensing problems (mpeg la etc.) Actually, I only need the option to mux/demux  video and audio files.
[19:19] <coalado> Any tipps how to do this  with as less effort as possible?
[19:35] <grkblood13> I'm trying to transcode a source as close to realtime as possible but it's taking ffmpeg about 5 seconds before it outputs anything. my command is `input_source | ffmpeg -f s16le -ar 8000 -ac 1 -i pipe:0 -acodec pcm_s16le -ar 22050 -ac 1 -bufsize 352k pipe:1`
[19:49] <grkblood> apologies for leaving before, frrenode locked up
[19:52] <grkblood> I'm trying to transcode a input source as close to real time as possible but for whatever reason ffmpeg is waiting atleast 5 seconds before it outputs anything. my cmd is `input_source | ffmpeg -f s16le -ar 8000 -ac 1 -i pipe:0 -acodec pcm_s16le -ar 22050 -ac 1 -bufsize 352k pipe:1`
[19:53] <grkblood> since my bufsize is currently set to the same size as 1 second of samples, shouldn't it start outputting the transcoded data after 1 second and not 5?
[19:53] <SmokedCheese> sup guys
[19:53] <SmokedCheese> I have a video which is chunked and goes live piece by peace. Can I stream it with ffmpeg?
[19:54] <SmokedCheese> *by piece
[19:59] <jnvsor> grkblood: Are you getting a "Do you want to overwrite this file" prompt?
[19:59] <jnvsor> grkblood: add a -y flag to auto overwrite it and that should stop the delay
[20:00] <grkblood> jnvsor: delay is still there with a -y
[20:01] <jnvsor> grkblood: got a pastebin?
[20:02] <grkblood> it outputs the configuration and libs, hangs for about 5 seconds, then starts Input #0, s16le, from 'pipe:0':
[20:02] <grkblood> unfortunately I don't, its on an isolated system and I can't get the pastebin across networks
[20:03] <jnvsor> grkblood: Well, you can either hand type all the stuff that's in there or find a way to copy it over :P
[20:09] <grkblood> jnvsor: weird, I ran the same command on another machine in which I can paste the output to you and it ran almost instantaneously
[20:10] <grkblood> https://gist.github.com/grkblood13/fcf8195e373971ef2669
[20:11] <grkblood> however, on the box that has the delay the input is a live feed and not a wav file
[20:12] <grkblood> same commands and same ffmpeg build, just different input sources
[20:26] <grkblood> ok, I've recreated a test case, the following command takes about 6 to 7 seconds before it starts outputting the transcoded data: wget -O - http://nprdmp.ic.llnwd.net/stream/nprdmp_live01_mp3 | ffmpeg -f s16le -ar 8000 -ac 1 -i pipe:0 -acodec pcm_s16le -ar 22050 -ac 1 -bufsize 352k -f wav -y test.wav
[20:30] <brontosaurusrex> grkblood, do you need to use that wget and pipe?
[20:30] <grkblood> wget no, pipe yes
[20:31] <grkblood> heres the output for that last cmd https://gist.github.com/grkblood13/a4d093dc8df83ad92c91
[20:32] <brontosaurusrex> uhm, so this are two inputs?
[20:32] <brontosaurusrex> one is named pipe and another a pipe
[20:32] <grkblood> brontosaurusrex: here's with no pipe or wget: ffmpeg -f s16le -ar 8000 -ac 1 -i http://nprdmp.ic.llnwd.net/stream/nprdmp_live01_mp3 -acodec pcm_s16le -ar 22050 -ac 1 -bufsize 352k -f wav -y test.wav
[20:32] <brontosaurusrex> and same delay?
[20:33] <grkblood> same delay occurs with that command
[20:33] <brontosaurusrex> and without -bufsize?
[20:33] <grkblood> that link is a NPR stream btw
[20:33] <grkblood> same without bufsize
[20:34] <brontosaurusrex> my guess is that ffmpeg is probing the input for too long
[20:35] <grkblood> so how do we work around that?
[20:36] <brontosaurusrex> not sure exactly, but probably by telling the ffmpeg somehow what that stream is about
[20:37] <brontosaurusrex> but if do something like "ffmpeg -i intranet/file.mp4 test.mp4" the delay will vary
[20:38] <brontosaurusrex> goes from 10s to almost no delay
[20:38] <grkblood> hrm
[20:39] <brontosaurusrex> not sure how that applies to NPR
[20:39] <grkblood> arent we defining the input parameters with these commands: ffmpeg -f s16le -ar 8000 -ac 1 -i
[20:39] <grkblood> which is actually wrong now btw since I changed my source
[20:41] <brontosaurusrex> i meant "ffmpeg -i http://intranet/file.mp4 file.mp4" *
[20:44] <brontosaurusrex> grkblood, so what exactly is the problem with the delay? It starts recording later than you want, or?
[20:44] <grkblood> its an issue because I need to be realtime or as close to realtime as possible
[20:44] <grkblood> a 5 second delay is hardly real time
[20:44] <brontosaurusrex> yeah
[20:49] <brontosaurusrex> cvlc http://nprdmp.ic.llnwd.net/stream/nprdmp_live01_mp3 does work fast btw
[20:50] <brontosaurusrex> but mpv also has delay and some errors
[20:50] <brontosaurusrex> so perhaps you could use cvlc to dump stream
[20:53] <grkblood> that seems like a lot of extra baggage getting vlc involved
[20:56] <brontosaurusrex> dunno; cvlc http://nprdmp.ic.llnwd.net/stream/nprdmp_live01_mp3 --sout=file/mp3:./file.mp3
[20:56] <brontosaurusrex> ^ this is faster than 5 secs
[20:59] <grkblood> k, thanks. Ill play around with that
[21:00] <brontosaurusrex> grkblood, you on debian?
[21:01] <grkblood> nope
[21:01] <grkblood> centos
[21:01] <brontosaurusrex> mkay
[21:03] <grkblood> fixed it
[21:03] <grkblood> start it off with this: ffmpeg -analyzeduration 0
[21:03] <brontosaurusrex> share! :)
[21:03] <brontosaurusrex> right
[21:05] <grkblood> too bad thats not displayed in ffmpeg -h
[21:06] <brontosaurusrex> ffmpeg -analyzeduration 0 -i http://nprdmp.ic.llnwd.net/stream/nprdmp_live01_mp3 -acodec copy out.mp3 ?
[21:08] <grkblood> no, for my original line where I knew the audio source parameters. If you know the parameters for NPR I'm sure it'll work the same.
[21:08] <grkblood> I'll post my cmd
[21:09] <grkblood> input_source | ffmpeg -analyzeduration 0 -f s16le -ar 8000 -ac 1 -i pipe:0 -acodec pcm_s16le -ar 22050 -ac 1 pipe:1
[21:10] <grkblood> input_source is a local binary that outputs raw PCM audio from a local tuner
[21:18] <grkblood> brontosaurusrex: ffmpeg -analyzeduration 0 -f s16le -ar 22050 -ac 1 -i http://nprdmp.ic.llnwd.net/stream/nprdmp_live01_mp3 -acodec pcm_s16le -ar 22050 -ac 1 -f wav -y test.wav
[21:19] <brontosaurusrex> well, cool
[21:20] <brontosaurusrex> mpv/mplayer also has --cache=number
[21:20] <brontosaurusrex> mabye there is something like that in ffmpeg as well
[21:20] <brontosaurusrex> if i do "mpv --cache=32 http://....file" its fast
[21:24] <Golfgeo> Hi all
[21:41] <bourbon> can you compile the ffmpeg binary against pre-compiled ffmpeg libs?
[21:42] <bourbon> that is, if you compile ffmpeg without the executable binaries, can you compile just the ffmpeg executable linked against the library so's?
[21:50] <Golfgeo> is there a way to have a streaming ffmpeg/avconv show what you're streaming on your local machine while it is started with the same command on the command line?
[21:54] <llogan> Golfgeo: we have nothing to do with avconv
[21:55] <llogan> ...but i don't quite understand your question.
[21:56] <Golfgeo> Well, then you can't help... So, thanks and have a great day :)
[22:31] <jedir0x> Are there going to be any inherit problems with encoding H.264 video at 1 frame per second?  WIll most or all players support this properly?
[22:49] <jnvsor> jedir0x: Don't see why not. Worst case scenario you could lower the fps then duplicate frames so you get a 30fps video with 30 times the same frame in a row
[23:08] <thebombzen_> does anyone know how to read a DVD with FFmpeg? What I've been doing for archival is dumping the stream with "mplayer dvd://1 -dumpstream -dumpfile dump.vob" then transcoding dump.vob to H.264 to fit it in less space. Can I do this directly with FFmpeg?
[23:08] <sacarasc> I don't think so.
[00:00] --- Wed Jan 15 2014

More information about the Ffmpeg-devel-irc mailing list