[Ffmpeg-devel-irc] ffmpeg.log.20140115

burek burek021 at gmail.com
Thu Jan 16 02:05:01 CET 2014

[03:33] <jedir0x> I'm having trouble with what i think is setting the proper PTS.  My program is simply encoding and writing video frames to a file.  I'm basing it on the muxing.c example.  I end up with a video that is ~15k frames per second and ~1 second long.  Is this the correct way to set pts on the AVFrame?: frame->pts	+= av_rescale_q(1, videoStream->codec->time_base, videoStream->time_base);
[04:45] <albator> somebody to explain me how this command works? " -filter_complex "[0:v]setpts=0.5*PTS[v];[0:a]atempo=2.0[a]" -map "[v]" -map "[a]""
[04:45] <albator> I really don't know how to set this up
[05:57] <llogan> albator: take the video stream(s) from the first input and apply setpts filter to double video speed. take the audio stream(s) from first input and increase the tempo by 2.
[05:58] <llogan> *by a factor of 2
[06:00] <relaxed> is filter_comples needed with one input?
[06:00] <relaxed> complex*
[06:04] <relaxed> oh, it's needed for multiple input streams and not necessarily input files.
[06:04] <llogan> http://ffmpeg.org/ffmpeg.html#Complex-filtergraphs
[06:05] <llogan> i wonder why vf isn't just replaced with filter_complex
[06:05] <llogan> but i'm not sure of any downsides of using filter_complex on a simple filtergraph
[06:09] <relaxed> I guess the original -vf wasn't well thought out.
[06:09] <relaxed> remember when we had to specify external files in the filter chain
[06:10] <llogan> remember "vhook"?
[06:10] <relaxed> like movie=some_external_files for overlays
[06:11] <relaxed> vhook predated -vf
[06:12] <llogan> i see users still using movie. so i regurgitate FFmpeg Tip #43 about using -filter_complex
[07:29] <jedir0x> somehow all of my video frames look blue
[07:29] <jedir0x> i wonder if i'm messing with sw_scale
[07:29] <relaxed> sounds smurfy
[07:51] <jedir0x> haha, RGBA vs. ARGB
[08:08] <k0bi>  i am trying to extract jpeg from fms
[08:09] <k0bi>  ofter running  hi i run "C:\ffmpeg"  -i "rtmp://ip/room_5280/90 live=1" -s 250x186 -r 6 c:\tmp\5280\frame%d.jpg and it stuck ofter saying  "hasAudio              FALSE"?
[08:09] <k0bi>  if hasAudio TRUE it works but if its false it stuck
[08:09] <k0bi> am i am doing somthing wrong?
[08:10] <relaxed> fms?
[08:10] <k0bi> yes
[08:10] <relaxed> wtf is that?
[08:10] <k0bi> not sure
[08:11] <k0bi> i tring to extrack pictuere from rtmp
[08:11] <k0bi> its works but somtimes its stuck
[08:12] <k0bi> "C:\ffmpeg"  -i "rtmp://ip/room_5280/90 live=1" -s 250x186 -r 6 c:\tmp\5280\frame%d.jpg
[08:12] <k0bi> thats the command line i am using
[08:14] <llogan> yes, that is the command you are using.
[08:15] <k0bi> http://pastebin.com/A9y8rwyS
[08:15] <k0bi> and thats the result
[08:16] <llogan> relaxed: what do you think about adding $HOME/ffmpeg_build/share/man/ to MANPATH in .profile for persistent ffmpeg man action?
[08:16] <relaxed> "rtmp server sent error"
[08:16] <k0bi> yes but if i run on other room it sed that 2
[08:16] <k0bi> qand it working
[08:17] <k0bi> and
[08:17] <relaxed> llogan: that would work
[08:19] <k0bi> http://pastebin.com/ebjUHsL6
[08:19] <k0bi> you see its the same till the line of hasAudio              TRUE
[08:19] <relaxed> llogan: look at `man man`, there's ~/.manpath which might be better
[08:21] <relaxed> instead of having to source .profile
[08:22] <llogan> that seems mo' sane. i'll probably still source .profile for its ~/bin path junk
[08:23] <k0bi> <relaxed> you know this
[08:25] <relaxed> k0bi: what did you do to make it work? I don't understand the issue.
[08:26] <llogan> k0bi: you should use scale filter instead of ss: "-vf scale=250:-1" which will result in 250x188
[08:26] <k0bi> ok i have 2 rooms of fms stream on one room it worknig good but in the other it stuck
[08:29] <k0bi> C:\>"E:\wwwroot\base64Player\ffmpeg"  -i "rtmp://ip/mygirl/room_4738
[08:29] <k0bi> the same result stuck ofter hasAudio              FALSE
[08:30] <k0bi> C:\>"E:\wwwroot\base64Player\ffmpeg"  -i "rtmp://ip/mygirl/room_4738/23 live=1" -vf scale=250:-1  -r 6 c:\tmp\4738\frame%d.jpg
[08:32] <k0bi> i think the problem is becuse of the audio
[08:32] <k0bi> cuz if audio is true is worknig
[08:32] <relaxed> add -map 0:v
[08:33] <__raven_> hi
[08:33] <k0bi> just add and its the same
[08:34] <relaxed> I don't think this is an ffmpeg problem.
[08:34] <k0bi> but the fms work just fine
[08:35] <relaxed> WHAT IS FMS
[08:36] <llogan> since it's "mygirl/room*" I assume "Flesh Media Server"
[08:36] <llogan> I mean "Flash"
[08:37] <__raven_> possible to detect the video content for problems such as fog or too dark picture? any thresholds for sharpness or something like that
[08:38] <k0bi> as i see it on the server i got 10 rooms in all it work ok just in the rooms that has no audio
[08:39] <relaxed> oh, i bet there's some flesh too :)
[08:40] <k0bi> sorry?
[08:40] <llogan> __raven_: not really. you might be able to figure something out with one of many available filters
[08:40] <llogan> http://ffmpeg.org/ffmpeg-filters.html
[08:41] <k0bi> ok so you are saying that used of a filter can fixed my problem
[08:41] <k0bi> and it not with the audio
[08:42] <llogan> k0bi: no. that was directed towards __raven_
[08:42] <llogan> i'm tired. it took me 3 tries to spell "towards"
[08:45] <k0bi> <llogan> can you try to halp me
[08:47] <llogan> k0bi: i'm streaming ignorant. does VLC play the "broken" inputs ok?
[08:48] Action: llogan blames Flesh Media Player
[08:48] <k0bi> yhaa it all work good the fms tream the flash play all good
[08:49] <k0bi> the problem is if i connect the ffmpeg to extrck picture it stuck on roon with no audio
[08:49] <coalado> I'd like to have a ffmpeg build that can be used for mux/demux tasks only. Any Ideas?
[08:50] <relaxed> coalado: the download page has links to ffmpeg static builds
[08:50] <coalado> relaxed:  I know. but they are "too powerfull"
[08:51] <llogan> --enable-weakling
[08:52] <llogan> k0bi: i don't know. you're using librtmp. maybe the native rtmp protocol support will behave differently.
[08:52] <coalado> I do not need any transcoding features -  AND I don't want to ship them due to license questions
[08:52] <llogan> k0bi: i forgot how to tell ffmpeg to use native instead of librtmp. or maybe i never knew.
[08:53] <llogan> k0bi: you might be able to get help on the ffmpeg-user mailing list
[08:55] <k0bi> llogan:ok i will try but mybe we can try here as well
[08:56] <llogan> coalado: "--disable-everything --enable-muxers --enable-demuxers" but that's probably not what you want
[08:57] <coalado> llogan:  this all is pretty new to me, so I don't know if this is what I want ;-P
[08:57] <coalado> I actually need to merge a dash audio and a dash video stream
[08:59] <llogan> the configure options i provided will provide a "ffmpeg build that can be used for mux/demux tasks only"
[08:59] <coalado> ok thanks I'll try it
[09:02] <llogan> coalado: you will probably also want --enable-protocols or --enable-protocol=file and such
[09:02] <llogan> see ./configure --help
[09:25] <k0bi> can i put try chtch like in ffmpeg?
[11:45] <calcifea_> seems that ffmpeg 2.1 does not use -threads on vp9
[11:48] <relaxed> calcifea_: ffmpeg -h encoder=vp9 2>&1| grep Thre
[11:48] <calcifea_> relaxed: threading capabilities are down on every codec
[11:49] <calcifea_> -threads is a encoder option
[11:49] <calcifea_> it works on vp8. try the same command relaxed, same output
[11:49] <relaxed> hmm, you're right
[11:50] <calcifea_> i think that ffmpeg just miss that option about vp9
[11:50] <calcifea_> for some reason
[11:50] <JEEB> I don't think vp9 encoding has any threading yet
[11:50] <calcifea_> it does
[11:50] <JEEB> in libvpx
[11:52] <JEEB> calcifea_, I searched the git logs for "threading" and I can only see decoding multithreading
[11:52] <JEEB> not encoding
[11:52] <JEEB> can you specify a git revision it was added with?
[11:56] <calcifea_> JEEB: i see. thanks
[11:57] <pagioss> hi what is this error and how to resolve Could not find option 'deblockalpha' in any of the FFmpeg subsystems (codec, format, scaler, resampler contexts)
[12:21] <pagioss> anyone!?
[12:23] <average> pagioss: that's kind-of...
[12:23] <average> pagioss: dude, when you want to solve a problem, you present people with some errors or output of FFmpeg
[12:23] <average> pagioss: you don't just say "How do I solve X"
[12:23] <average> like that gives any sort of useful information
[12:34] <Ko_deZ> Hi. I am trying to make a simplistic h264 buffer analyzer and qp analyzer, and trying to avoid decoding the video. We have an encoder supplier that we have some problems with, and I would like to simplify our debugging/testing. I am of course hoping for an easy ride, but if anyone can point me in the right direction, that would help a lot. The data arrives in transport stream, but I can supply it in PES packets, NAL units if nessesary of course.
[14:05] <calcifea> how come that if i transcode a VOB with ffmpeg i get weird visual effect in output?
[14:05] <calcifea> i see the same issue while playing the VOB itself
[14:05] <calcifea> but if i use some ffmpeg front-end i don't get that
[14:18] <calcifea> oh
[14:18] <calcifea> -pix_fmt yuv420p solved
[14:33] <relaxed> calcifea: the vob wasn't in yuv420p?
[14:44] <calcifea> relaxed: it didn't fixed
[14:44] <calcifea> fix nothing
[14:44] <calcifea> i was wrong
[14:47] <calcifea> http://pastebin.com/raw.php?i=v3RFv7Ti
[18:47] <albator> JEEB just to let you know -filter_complex "[0:v]setpts=1.25*PTS[v];[0:4:a]atempo=0.8[a]" -map "[v]" -map "[a]"   for some reasons, audio and video are nearly in sync  with these settings
[18:50] <DeadSix27> anyone knows why vp9 doesnt seem to work in my build? I used this line to configure libvpx: http://pastie.org/8636309, and also enabled it in ffmpeg configure
[18:50] <DeadSix27> according to the output of the libvpx build vp9 should be enabled.
[18:53] <DeadSix27> but looking at "-encoders", theres only:  V..... libvpx               libvpx VP8 (codec vp8)
[18:53] <DeadSix27> is there any configuration flag i have to give ffmpeg?
[18:55] <DeadSix27> (beside enabling libvpx i mean)
[19:01] <thebombzen> configure it and send us your config.log
[19:01] <thebombzen> on a paste service
[19:01] <thebombzen> DeadSix27:
[19:03] <DeadSix27> sec.
[19:04] <DeadSix27> thebombzen: http://pastie.org/private/msjngpu8jvdpvbbqwvc5ag
[19:04] <DeadSix27> just noticed an error at line 272
[19:04] <DeadSix27> or i guess thats one, idk.
[19:05] <DeadSix27> didnt rly touch that, just followed what i rhymed together on SO etc.
[19:06] <thebombzen> don't use --prefix that's the install prefix
[19:06] <thebombzen> use --cross-prefix
[19:06] <thebombzen> that's the prefix where the cross-compile tools are located
[19:07] <thebombzen> do ./configure --help and look under "advanced options (experts only)"
[19:07] <thebombzen> that has cross-compile info
[19:07] <DeadSix27> will do in a sec.
[19:08] <DeadSix27> or in 4 hrs, depending how long when i finish, ill come back to you though.
[19:08] <DeadSix27> until im finished*
[20:28] <sledges> hello
[20:28] <sledges> how can I sync a timestamp (drawtext filter) to a framerate?
[20:30] <tvkid> i want to compress a raw 640x480 video to a < 100Mbps  stream(any format/codec) is it possible to do with a 454MHz ARM(non-cortex) processor with 64MB RAM?
[20:32] <tvkid> i mean minimum processing over the raw stream such that it becomes less than 100 Mbps stream so that i can send a single stream over ethernet
[20:32] <jnvsor> tvkid: Recording my whole screen raw goes less than 100Mbps, have you run into any problems?
[20:35] <tvkid> i was calculating like 640*480*24(bits per pixel)*30 frames per second = 221184000 which is around 221Mbit  no?  am i doing it right
[20:35] <tvkid> jnvsor: ^
[20:38] <tvkid> jnvsor: i am curious how your whole screen raw data takes less than 100Mbit?
[20:43] <DeadSix27> thebombzen: http://pastie.org/private/6vcitrltnjok1evgayz6lw
[20:56] <jnvsor> tvkid: Ah my bad, try libx264 ultrafast - if that doesn't work I don't know what will
[21:24] <thebombzen> tvkid: afaik huffyuv is optimized for fast compression, but it will be hard to read outside of libavcodec land
[21:27] <thebombzen> DeadSix27: that's odd, from ./configure --help it says:   --cross-prefix=PREFIX    use PREFIX for compilation tools []. I'd try putting --enable-cross-compile before everything, but if ./configure doesn't recognize that then I don't know. sorry
[21:27] <thebombzen> also tvkid: yuv420p uses half the space of rgb24
[21:28] <DeadSix27> i use git master
[21:28] <DeadSix27> also tried git experimental
[21:28] <thebombzen> so that would be 110 MBit at 30 fps, which is 88 Mbit at 24 frames per second
[21:30] <thebombzen> also it appears that the next release is 2.1.3, whatever happened to 2.1.2?
[21:31] <llogan> compile issue involving libxavs
[21:35] <DeadSix27> thebombzen: are we sure we talk about the same library, i checked out 1.2.0 1.3.0, and master & experimental?
[21:36] <DeadSix27> that option wasnt in any of them
[21:36] <DeadSix27> nor did it ever say: advanced options (experts only)
[21:36] <DeadSix27> only advanced options
[21:36] <DeadSix27> you sure*
[21:54] <DeadSix27> well gnight.
[22:17] <sledges> figured out: need to use %{pts} and tweak source code to format that as hh:mm:ss:uu ; sadly there's no other easy way to sync the clock
[22:19] <drwx> hey, why does ffmpeg report s32 for 24bit flac files?
[22:19] <drwx>     Stream #0:0: Audio: flac, 96000 Hz, stereo, s32
[22:20] <JEEB> probably because the decoder outputs 32bit for that case
[22:20] <JEEB> do you get the same thing when you actually start decoding the stream? if yes, then the decoder just bit-shifts it to 32bit, no data should be lost
[22:46] <drwx> JEEB: yeah
[23:39] <jedir0x> i'm having a problem with avlib where when creating an mp4 with h264 (no audio stream) the file is corrupt, but there were no errors or problems during encoding (just drawing bitmaps to the AVPicture) - mplayer (and other forgiving players) play it just fine - but it wont play on OSX or on my Android device.  Any ideas on how to go about debugging this?
[23:47] <bgilbert> Hi, I was wondering if there was a way to transcode rtp packets in ffmpeg using only stdin/stdout?
[00:00] --- Thu Jan 16 2014

More information about the Ffmpeg-devel-irc mailing list