[Ffmpeg-devel-irc] ffmpeg.log.20140117

burek burek021 at gmail.com
Sat Jan 18 02:05:01 CET 2014

[00:02] <Guest18902> llogan: the commandset in whole; (trying to get 1080p 3d to a 3ds xl); but, good news i did what u said and the last command has taken
[00:03] <Guest18902> im waiting for it to finish now; once it does; i will -t 00:10:00 00:00:00 and see if i can get the first 10 minutes to take
[00:04] <Guest18902> kinda excited; tried all last night for this to work.. kept gettng beat
[00:05] <Guest18902> gotta try to see what i can do about size.. seems weird a 1080p 3d video is 7.2 gig and the resized/cropped video is about same.
[00:13] <BtbN> i don't get it. Youtube keeps rejecting one part of a video i split in 12 parts... But it looks absolutely fine to me
[00:18] <Guest18902> finishing copying second video (2 ten minutes parts) lets see if ffmpeg came to rescue by letting me watch movie on 3ds xl in 3d =X
[00:22] <JD-50> unsupported video
[00:22] <JD-50> 2 thumbs down =(
[00:53] <Freakshow> folks, does anyone have an insight into the unknown stream index shown in ffprobe output while pointing at an hls source?
[00:53] <Freakshow> example: Stream #0:0: Unknown: none ([21][0][0][0] / 0x0015)
[00:54] <llogan> s/ffmpeg/ffprobe
[00:54] <Freakshow> yeah, sorry about that. hang tight
[00:56] <Freakshow> http://pastebin.com/6jaqtDnP
[00:59] <freezway> so I'm working on a music sorting program using libavformat and need to use it to read the metadata. The problem is some (poorly formed) files I have the metadata in the wrong spots. For example while a good file has the metadata inside input #0 a bad file might have it under Duration inside input#0 (as far as I can tell from ffprobe). I am currently using the metadata found under AVFormatContext->metadata
[00:59] <freezway> is there a better way to do this?
[00:59] <JD-50> freezway: sounds like we both having a battle 2nite
[00:59] <JD-50> =)
[01:00] <freezway> JD-50, working on something similiar or facing the same issue?
[01:03] <JD-50> we'll if something similar is using ffmpeg to solve a problem; then sure
[01:03] <JD-50> -- im trying to convert a 3d video to nintendo 3ds  format
[01:03] <Freakshow> I've updated the paste with the actual command llogan , but it was trivial
[01:04] <Freakshow> ffprobe -v info blah
[01:04] <JD-50> i only got 2d working so far.. and using q=1  the size is horrible
[01:04] <JD-50> using q-15 = awefull looking video
[01:14] <JD-50> god dam.. shit dont wanna give
[01:16] <llogan> Freakshow: did you "Consider increasing the value for the 'analyzeduration' and 'probesize' options"?
[01:16] <llogan> or try a more recent build?
[01:29] <Freakshow> I did not consider the duration or probe size I can certainly look at increasing them
[02:44] <JD-50> dam, this takes a long time on an old laptop.. =/
[03:06] <fundies> whats the best way to dump the audio track from chapter 1-x on a dvd?
[03:17] <dan_> Anyone have some pointers on how I might use ffmpeg to make a video mosaic? By that I mean a NxM grid of videos, all playing the same video except with a variable time lag in between each one, with just the audio of the earliest video playing. (similar to http://www.yooouuutuuube.com/v/?yt=BBAtAM7vtgc&width=192&height=120&flux=0&direction=top_right)
[04:58] <Emmanuel_Chanel> Hello!
[05:00] <fundies> konnichiwa!
[05:05] <Emmanuel_Chanel> I have a problem with the sound on encoding m2ts.
[05:05] <Emmanuel_Chanel> to mp4.
[05:06] <Emmanuel_Chanel> The sound codec is faac. But the ad part that I cannot delete on HDTV2MPEG2 looks to make that trouble happen.
[05:06] <Emmanuel_Chanel> The ad part makes the sound output stop.
[05:15] <Emmanuel_Chanel> Someone knows a good page to tell me how to encode m2ts file into a mkv video?
[06:42] <lethjakman> hey, I'm not sure this is a good place to ask...but I'm trying to figure out how video containers work, I can't seem to find any information on how things are seperated
[06:42] <lethjakman> does anyone know?
[06:42] <lethjakman> information on video codecs woudl be really useful too
[06:56] <llogan> lethjakman: http://superuser.com/a/300997/110524
[06:58] <llogan> Emmanuel_Chanel: ffmpeg -i input.m2ts -c copy -map 0 output.mkv
[06:59] <llogan> dan_: see the overlay filter http://ffmpeg.org/ffmpeg-filters.html#overlay
[06:59] <llogan> https://trac.ffmpeg.org/wiki/Create%20a%20mosaic%20out%20of%20several%20input%20videos
[07:06] <Emmanuel_Chanel> thx.
[08:39] <__raven> i need to detect fog/freeze/dark videos: if there is no special analyze filter perhaps i could use the file size. how to set which vbr settings as extreme as possible to use this "side channel" for analyse?
[13:15] Last message repeated 1 time(s).
[13:18] <quaz0r> Playing: torrents/Ultramagnetic MC's - Critical Beatdown [2004. CD, FLAC]/(21) Ultramagnetic MC's - Mentally Mad .flac
[13:22] <quaz0r> funnylookinhat
[13:22] <quaz0r> how you is
[13:29] <FunnyLookinHat> quaz0r, have we talked before?
[13:29] <FunnyLookinHat> sorry - not remembering your nick
[13:29] <quaz0r> no
[14:27] <sledges> hello, really need your help now:
[14:27] <quaz0r> hi
[14:27] <quaz0r> your mom is fat
[14:28] <sledges> this simple encoding line seems to freeze some players (while seeking):
[14:28] <sledges> ffmpeg -f rawvideo -vcodec rawvideo -s 960x720 -r 60 -pix_fmt yuv420p -i raw.raw -vcodec libx264 -y fromraw.mp4
[14:28] <sledges> i also add audio to it afterwards:
[14:28] <sledges> ffmpeg -i fromraw.mp4 -i output.m4a -vcodec copy -acodec copy final.mp4
[14:29] <sledges> without audio, all works fine
[14:33] <ubitux> complain to the players?
[14:33] <ubitux> is it playable with ffplay?
[14:34] <sledges> it's playable with mplayer
[14:34] <quaz0r> YEP
[14:34] <sledges> crashes on jolla phone native player, and vlc reportedly crashes too
[14:34] <quaz0r> Playing: torrents/Ultramagnetic MC's - Critical Beatdown [2004. CD, FLAC]/(21) Ultramagnetic MC's - Mentally Mad .flac
[14:35] <sledges> continue the can-o-worms: i've complied ffmpeg from git sources
[14:35] <sledges> using https://trac.ffmpeg.org/wiki/UbuntuCompilationGuide
[14:35] <sledges> because i needed latest and greatest ffmpeg features
[14:35] <quaz0r> WUT
[14:35] Action: sledges is thinking of re-encoding on a stable ffmpeg
[14:36] <ubitux> quaz0r: please stop
[14:36] <quaz0r> k
[14:36] <quaz0r> just partyin is all
[14:36] <ubitux> sledges: well, better report a bug to videolan
[14:36] <ubitux> the player is not supposed to crash, whatever the input
[14:36] <sledges> true
[15:54] <bsdwolf> anyone in here using FreeBSD?
[15:54] <bsdwolf> having issues
[15:55] <bsdwolf> ffserver is running, I can stream a prerecorded video. but trying to stream from /dev/video0 crashes
[19:39] <__raven> ping
[20:07] <albator> pong
[20:08] <jnvsor> ping
[21:08] <vmiimu> Hi, I have a input video which is 1920x816 and when I use -target ntsc-dvd -- the output comes out all stretchy; what can I try to get a better output?
[21:09] <vmiimu> Also, I'm new to this and would like to learn the most generic command possible to take any input and convert it to mpg for a dvd while preserving aspect ratio etc. -- is there such a magic option?
[21:19] <jnvsor> vmiimu: mpg container or codec?
[21:24] <vmiimu> jnvsor: how can i determine that? sorry I'm new to this.
[21:26] <vmiimu> jnvsor: the source/input file Codec: H264 - MPEG-4 AVC (part 10) (avc1)
[21:26] <vmiimu> according to vlc -> Current Media Information -> Codec
[21:28] <jnvsor> vmiimu: Well the "container" contains video and audio streams
[21:28] <jnvsor> vmiimu: The streams are encoded with codecs
[21:28] <jnvsor> vmiimu: There is an mpg container (file.mpg) but it only supports old mpeg codecs so it's not very good
[21:29] <vmiimu> jnvsor: the file is .mp4
[21:30] <vmiimu> jnvsor: the input file looks amazing. i'd like a decent looking dvd from it which doesn't look all "stretchy"
[21:30] <vmiimu> is this possible?
[21:31] <jnvsor> vmiimu: Yes, but I don't know what the target option does, it's probably a preset - let me google it :P
[21:31] <vmiimu> I was following instructions here: http://www.lamolabs.org/blog/4582/one-liner-how-to-burn-an-m4v-or-mp4-file-to-a-dvd-under-linux-fedora-centos-rhel-debian-ubuntu/
[21:33] <vmiimu> I also do get this warning: "Incompatible sample format 's16' for codec 'ac3', auto-selecting format 'flt'"
[21:33] <vmiimu> When I run ffmpeg -i input.m4v -target ntsc-dvd output.mpg
[21:34] <jnvsor> Put the full output in pastebin
[21:37] <vmiimu> http://pastebin.com/nBhM4EN3
[21:46] <vmiimu> ok following instructions to compile for debian now....
[22:03] <reactormonk> I'm using this command to stream to twitch, but it's all messed up - ffmpeg complains about VBV underflow. ffmpeg -f x11grab -s 1600x1146 -r 60 -i :0.0+4,23 -f alsa -i pulse -f flv -ac 2 -ar 44100 -vcodec libx264 -g 2 -keyint_min 2 -b 1000k -minrate 1000k -maxrate 1000k -pix_fmt yuv420p -s 1280x720 -preset ultrafast -tune film -crf 23 -acodec libmp3lame -threads 4 -strict normal -bufsize 512k
[22:04] <reactormonk> anything I can change to make it work better?
[22:05] <jnvsor> First, stick the thing in pastebin so we can take a look
[22:05] <reactormonk> the full script?
[22:05] <jnvsor> The command and it's output
[22:07] <reactormonk> http://pastebin.com/3CxmTxP5
[22:07] <reactormonk> the command is the above one - the one that's being executed by the script
[22:13] <jnvsor> reactormonk: No we need the actual ffmpeg command
[22:13] <jnvsor> A quick google says your bs values are off (kb/s vs b/s)
[22:13] <reactormonk> jnvsor, ffmpeg -f x11grab -s 1600x1146 -r 60 -i :0.0+4,23 -f alsa -i pulse -f flv -ac 2 -ar 44100 -vcodec libx264 -g 2 -keyint_min 2 -b 1000k -minrate 1000k -maxrate 1000k -pix_fmt yuv420p -s 1280x720 -preset ultrafast -tune film -crf 23 -acodec libmp3lame -threads 4 -strict normal -bufsize 512k
[22:14] <reactormonk> which two?
[22:17] <jnvsor> Try replacing "1000k" with just "1000" and see what happens
[22:17] <reactormonk> [libx264 @ 0x1ebca80] VBV underflow (frame 77, -79 bits)
[22:17] <reactormonk> [libx264 @ 0x1ebca80] VBV underflow (frame 78, -21823 bits)
[22:18] <jnvsor> reactormonk: Try removing them altogether?
[22:19] <jnvsor> vmiimu: Once you're done compiling, I constructed a filter that should do what you need http://pastebin.com/GRwxAzfr
[22:19] <jnvsor> vmiimu: That should work for any input
[22:23] <reactormonk> works without the nasty bufsize
[22:23] <JEEB> btw, if you want VBV you really don't want to use minrate
[22:23] <jnvsor> reactormonk: I find the libx264 presets are more than enough finetuning
[22:23] <JEEB> -maxrate and -bufsize are what you should use
[22:23] <JEEB> and yes, you need these two for streaming
[22:23] <JEEB> because you're bandwidth limited
[22:24] <JEEB> also holy crap
[22:24] <JEEB> ultrafast and VBV :o
[22:24] <JEEB> that sounds like a very goddamn bad idea
[22:24] <reactormonk> got a better one?
[22:24] <JEEB> unless you've got a LOT of bandwidth
[22:24] <JEEB> if you can't make the preset any slower, no, not really
[22:25] <JEEB> just that the compression is so bad at that level that I'd just rather not do live streaming then
[22:25] <JEEB> unless you have a lot of bandwidth that is
[22:25] <JEEB> list of presets: http://mewiki.project357.com/wiki/X264_Settings#preset
[22:25] <JEEB> and why the hell was your bufsize half of maxrate?
[22:26] <JEEB> (unless the service you're sending that data out to says you have to have a 0.5 second buffer)
[22:26] <JEEB> (a restreaming service or whatever)
[22:26] <jnvsor> A script made the line for him :P
[22:27] <jnvsor> Also, reactormonk: Scaling your video down to 720p on the fly will help with performance too
[22:27] <jnvsor> bandwidth*
[22:27] <JEEB> yeah, I'm pretty sure a half a second buffer is not what that restreamer wants
[22:28] <JEEB> but in any case, getting off ultrafast is the first thing here
[22:28] <JEEB> jnvsor, he already is resizing to 720p as far as I can see
[22:29] <reactormonk> it doesn't really listen to maxrate though
[22:30] <jnvsor> JEEB: Ah my bad, I expected a scale filter :)
[22:31] <JEEB> reactormonk, that's due to your minrate there, which should not be there
[22:31] <JEEB> without you forcing x264 to do something else, x264 nowadays should always be within your vbv limits
[22:31] <JEEB> (vbv = maxrate/bufsize)
[22:32] <JEEB> also wtf at that line
[22:32] <JEEB> it sets both bit rate and crf
[22:32] <JEEB> of which the latter gets used of course (thankfully)
[22:33] <JEEB> anyways, the first thing to do would be to remove the minrate and the -b 1000k , and to try and put the preset at something slower than ultrafast
[22:34] <JEEB> if even the next ones in the list are not fast enough, then I'd just recommend giving up on doing the realtime encoding on that box. If you have other machines on the same network you could just pipe lossless video to them to be encoded and sent out
[22:49] <reactormonk> JEEB, I should have enough power on this machine
[22:52] <JEEB> reactormonk, also holy crap
[22:52] <JEEB> -g 2
[22:52] <JEEB> what the hell or who the hell made these settings
[22:53] <JEEB> + you're encoding 60fps content...
[22:54] <JEEB> remove that -keyint_min , switch -g to 120 or so (I think twitch recommended two second GOPs, and you should have 60 pictures in a GOP)
[22:54] <JEEB> remove -b 1000k , minrate
[22:54] <JEEB> and then push slower the preset
[22:55] <JEEB> after that poke the bufsize because I'm pretty sure you're not supposed to have half-second buffering
[22:55] <JEEB> and actually have someone check your bufsize/maxrate who knows what the actual limits for whatever you're pushing that video to is
[22:56] <reactormonk> set present to slower
[22:56] <obiwahn> hi
[22:57] <obiwahn> what must i do to list all audio streams inside of a video file/container
[23:10] <BtbN> obiwahn: ffprobe file
[23:34] <letoram> I'm a bit stuck debugging a video encoder (using libavcodec/format etc.); the result (MKV, libx264) plays back fine, but seeking behaves odd. Running it through ffprobe shows N/A for duration and bitrate. Remuxing through ffmpeg with -c copy and probe now shows duration/bitrate and seeking works. the pts/dts for each frame of the demuxed and remuxed output is identical.. any suggestions where to look?
[23:45] <caral> Hi, I'm encoding a live rtmp stream from a h264 source with ffmpeg. This works great. But now I try to invoke 'tee' to have 2 Outputs according to the doku. One saved, and the other streamed. I think in my cli http://pastebin.com/wf0QUmC8 is a syntax error. Anybody got a hint where the error is?
[23:46] <obiwahn> BtbN: thank you!
[23:54] <llogan> caral: i believe it is expecting muxer options, not protocol options, but i may be wrong
[23:59] <Fusl> is there a way to "fast forward" a video?
[23:59] <Fusl> like playing it on 50x speed?
[00:00] --- Sat Jan 18 2014

More information about the Ffmpeg-devel-irc mailing list