[Ffmpeg-devel-irc] ffmpeg.log.20140129

burek burek021 at gmail.com
Thu Jan 30 02:05:01 CET 2014

[01:23] <sineb> what resoloution is dvd. I want to scale down from 1920x1080 or 1280x720
[01:25] <sacarasc> http://mplayerhq.hu/DOCS/HTML/en/menc-feat-vcd-dvd.html shows you all the DVD compatible things.
[01:25] <sacarasc> But 1280x720 is too big.
[01:27] <sineb> thanks. will i have to crop my image
[01:27] <sineb> maths makes my mind go blank. im an artistic left brainer
[01:29] <sacarasc> If you're in a NTSC country, `ffmpeg -i input -target ntsc-dvd output` may be enough.
[01:29] <sineb> im pal
[01:30] <sacarasc> -target pal-dvd
[01:30] <sineb> ok so this will drop MPEG2 files
[01:30] <sineb> or in AUDIOTS VIDEOTS
[01:30] <sineb> format
[01:30] <sineb> im probably expecting to much here for it to create a ddvd for me lool
[01:30] <sacarasc> It won't be in vobs.
[01:31] <sineb> but VOBS is just a container right, no other encoding happens
[01:32] <sacarasc> It will encode it to MPEG2, ready for a DVD authoring program.
[01:32] <brianf> you could use dvdstyler to have a more automated thing (and if I recall correctly it uses ffmpeg to convert anyway)
[01:32] <sineb> yea sure thanks, but i was thinking the dvd authoring program does not compress or encode the video audio stream any further does it
[01:33] <brianf> hmm, I don't remember
[01:33] <sineb> I basically have my nans birthday all filmed on my canon 550d in 1920 1080. i was thinking editing it all in AAE and then dumping it to a lossless and then ffmpeg it to MPEG2
[01:41] <brianf> well, I guess you could do that and use these mpeg2 files as input for the dvd tool if the problem is to convert it to AUDIOTS/VIDEOTS.
[02:13] <bencc> does this should work on browsers (Chrome, FF, IE)? ./ffmpeg -i video.avi -c:v libx264 -vf -movflags faststart video.mp4
[02:14] <bencc> I can't play video.mp4 in browsers and not sure what's wrong
[02:14] <bencc> I can play it in vlc
[02:37] <llogan> probably chroma subsampling issue, but impossible to tell without a sample or the console output
[02:37] <bencc> llogan: ok. a sec
[02:40] <bencc> llogan:  http://pastie.org/8677147
[02:53] <thebombzen> has anyone else noticed flickering when using ffmpeg's x11grab device input with an application running OpenGL?
[02:53] <thebombzen> I suspect this is because OpenGL renders directly to the hardware and somewhat bypasses X11, but there might be a way to fix this
[03:10] <didge> How do I get a good binary distribution of ffmpeg for freebsd using pkg ?
[03:10] <didge> I'm trying to work with mp4 and png
[03:14] <llogan> bencc: Use -pix_fmt yuv420p for compatibility with outdated media players
[03:14] <llogan> (that's from the console output)
[08:58] <fundies> any way to make ffmpeg copy only the video stream and all the audio streams regardless of how its mapped?
[09:02] <relaxed> fundies: ffmpeg -i input -map 0:v -map 0:a ...
[09:03] <relaxed> er, ffmpeg -i input -map 0:v -map 0:a -c copy ...
[09:03] <fundies> thatll get all the audio tracks?
[09:03] <relaxed> yes, and all the video streams
[09:07] <fundies> thanks it worked
[09:21] <bencc> llogan: works. thanks
[09:25] <Mavrik> em
[09:25] <Mavrik> not just outdated video players
[09:26] <Mavrik> there's no requirement that any of the players have to support more than yuv420p
[09:39] <bencc> Mavrik: I thought that browsers have new players but without this, the video doesn't play
[09:40] <Mavrik> as I said.
[09:40] <Mavrik> the standard requires ONLY support for yuv420p
[09:40] <bencc> ok
[09:40] <Mavrik> new or not, the player doesn't have to support anything else
[09:40] <Mavrik> and browsers tend to use whatever hardware decoding capability the device has
[09:40] <JEEB> uhh, more like it depends on what profiles the decoder supports :P
[09:40] <JEEB> and then the features are limited to that
[09:42] <JEEB> basically saying "the standard requires ONLY support for 4:2:0" is misleading, because it's the decoder that chooses the features (profile[s]) to support, and then if it wants to be compliant it has to implement what's in the specification
[09:43] <JEEB> if you say that you support high 4:2:2 profile and you then don't implement it? that is not compliant
[09:43] <JEEB> and yes, hardware decoders usually limit themselves to high profile support
[09:43] <JEEB> which is 4:2:0
[09:43] <JEEB> (and main, constrained baseline are subsets of high, so they end up being supported as well)
[10:04] <anshul> Is there any relation of planar sample format and number of channel?
[10:05] <JEEB> no
[10:05] <JEEB> as in, planar doesn't mean a specific channel count or anything like that
[10:05] <JEEB> planar just means that you have separate buffers with each containing a single channel's data
[10:09] <anshul> jeeb do you have master git version if you have line 1331 in libavcodec/utils.c does not make any sense
[10:10] <anshul> in libavcodec/utils.c they have compared avctx->channels == 1 for selecting sample fmt
[10:12] <JEEB> well, with mono you have just a single buffer, just like with interleaved stuff
[10:13] <JEEB> so if (thing_is_mono && the_planar_version_matches) override_sample_fmt
[10:13] <JEEB> because in that case planar and interleaved are the same
[10:13] <JEEB> the general matching is done just before it and the break; would hit there if there was a match (as in, the encoder takes in the context's sample_fmt
[10:18] <anshul> if I am having fltp sample format thing_is _streao so is it not supported by mp2 codec and i have to drop the sample fmt as fltp and make it s16
[10:19] <anshul> are encoder depends on perticular sample_fmt
[10:20] <JEEB> yes, encoders have lists of sample formats they support
[10:21] <JEEB> for example mpegaudioenc_float supports these http://git.videolan.org/?p=ffmpeg.git;a=blob;f=libavcodec/mpegaudioenc_float.c;h=4d4ab2d7fa6677e4952206382de02443f6f898b2;hb=HEAD#l33
[10:21] <JEEB> and mpegaudioenc_fixed supports these http://git.videolan.org/?p=ffmpeg.git;a=blob;f=libavcodec/mpegaudioenc_fixed.c;h=022b6fedd3a621c70c6ad34f89d555e73b797335;hb=HEAD#l24
[10:21] <JEEB> since you mentioned mp2 I noted those two
[10:22] <active8> Hi. I'm having a problem configuring an ffmpeg build with gcc on linux. First it said it can't find librtmp and when I added extra paths, it said "gcc is unable to create an executable file" and finally "C compiler test failed" http://pastebin.com/PzWjQcGK
[10:23] <anshul> jebb, thanks you were my eyes opener
[10:24] <YellowOnion> I have a video that is yuvj420p, but is marked incorrectly (says its yuv420p) how do I set it to yuvj420p and then convert it to yuv420p?
[10:24] <JEEB> I'm pretty sure you don't need -lrtmp in there, that is added when linking to it automagically. Also does librtmp really have no installation since I have noted you are using the source code directory :P
[10:24] <JEEB> also for any errors see config.log
[10:24] <JEEB> that tells you where exactly it failed
[10:24] <JEEB> also, are you sure you need librtmp?
[10:24] <JEEB> ffmpeg has had internal rtmp support for quite a while now
[10:26] <active8> i have rtmpdump installed, but vlc used a special script to install ffmpeg because of lib dependency issues. so I have a crippled ffmpeg and am building a extra one to handle what the crippled one cannot
[10:27] <JEEB> YellowOnion, if it really is full range you could try editing the value in the parameter sets (I will guess this is H.264 ?), although that will require hex editing and reading some of the H.264 specification. Or you have to just force the thing to be interpreted as full range by the filters.
[10:28] <JEEB> oh
[10:28] <JEEB> there's -color_range
[10:28] <YellowOnion> JEEB: its some old school dx50 codec according to VLC, I can current get it to collectly output yuvj420 x264 but I don't want to have to recode again.
[10:30] <JEEB> well, if you wanted to convert it you'd have to re-encode anyways :P
[10:30] <JEEB> but yeah, try -color_range before -i
[10:30] <active8> JEEB. infernal support, eh? I did not catch that fact at ffmpeg.org or elsewher. WTH. Maybe I'll go with it and see if it's built in.
[10:30] <JEEB> active8, it was developed during the libav 2012 summer of code
[10:30] <JEEB> I remember just because I was doing other work during then as well
[10:31] <YellowOnion> JEEB: I mean don't want to have to do 2 encodes and waste a bunch of disk space with lossless.
[10:31] <JEEB> YellowOnion, well try setting -color_range for decoding
[10:31] <JEEB> as in, before -i
[10:31] <JEEB> whatever the value for full range is, that is
[10:31] <YellowOnion> I can't find any docs on that setting anywhere, does it even exist?
[10:32] <JEEB> sure exists http://ffmpeg.org/ffmpeg-all.html
[10:33] <JEEB> and color_range 2 makes ffmpeg -i welp.file output yuvj420p(pc)
[10:33] <JEEB> for a 4:2:0 sample
[10:34] <YellowOnion> ahh sweet thanks
[10:35] <YellowOnion> Still has grey blacks/looks washed out
[10:37] <JEEB> well, I told you how to override the range, anything after that depends on what you do :P
[10:41] <YellowOnion> I've tried a bunch of -vf format=yuv420p and -pix_fmt yuv420p in places and I just can't get it to output non-washed out colours
[10:41] <active8> JJEB. configure says all the rtmp protocols are enabled. I noticed that for enabled indevs, jack is enabled, but not for outdevs. I'm not well versed in jack. Is there any reason I'd want ffmpeg to output to jack like it would to an rtmp server or whatever I might get itchy to try 8) ?
[10:45] <JEEB> I don't even know if there is a jack output avdevice :P And no idea
[10:45] <YellowOnion> I can't think off the top of my head why you would want a outdev for jack
[10:47] <active8> ok JEEB make is an epic fail
[10:49] <active8> input_count and output_count are deprecated - just warnings. A whole slew of errors related to RTMP. I got the source from git://source.ffmpeg.org/ffmpeg . Was that not good?
[10:51] <JEEB> errors sound like you've poked something the wrong way
[10:51] <JEEB> the source code in the git repo should be good at most times
[10:52] <JEEB> you can see it being tested on various systems @ http://fate.ffmpeg.org/
[10:52] <active8> poked?
[10:52] <JEEB> simplify your configuration line and make sure any old things aren't there
[10:52] <JEEB> make distclean
[10:52] <JEEB> configure in a more simple way
[10:53] <JEEB> for example, start with just ./configure which enables a basic LGPLv2 build
[10:53] <JEEB> see that it finishes
[10:53] <JEEB> (yes, that includes the internal RTMP stuff)
[10:53] <JEEB> and then go onwards from that :P
[10:54] <active8> crap. I think I found something i forgot to unpoke
[10:57] <YellowOnion> JEEB: well its not pretty but it works: http://pastebin.com/ZWH4mC7t
[10:59] <JEEB> YellowOnion, that converts the thing to full range first (pix_fmt after -i), then you feed that to another instance which filters like crazy and either does nothing or converts back to limited range depending on how the second instance reads the input :P
[10:59] <Mavrik> JEEB, thanks for correction :)
[11:00] <JEEB> which really doesn't sound like the input was full range, unless swscale does very weird things on the first part. Which is always possible, after all it _is_ swscale
[11:03] <YellowOnion> JEEB: on the original file played in VLC, the starting scene fades in from black, the back values in rgb are 12,16,12, and the entire thing looks washed out during the live action stuff.
[11:04] <YellowOnion> specifying -pix_fmt after (before doesn't work) seems to fix the colors (though I though pix_fmt was suppose to convert)
[11:05] <JEEB> yes, before doesn't work since you're not reading raw pictures
[11:05] <JEEB> which is why there is -color_range
[11:05] <JEEB> and -pix_fmt is /supposed/ to convert
[11:05] <JEEB> swscale is a pile of voodoo poo-poo so you can never know what exactly it does, but I'm pretty sure that widens the range
[11:06] <JEEB> if you actually get a different result from ffmpeg -i welp -pix_fmt yuvj420p than from ffmpeg -color_range 2 -i welp when piping to the next thing, then you know that it's converting
[11:11] <YellowOnion> JEEB: well specifying -pix_fmt yuvj420p gives me a yuvj420p stream with correct colors, and -color_range 2 didn't improve on the situation.
[11:12] <JEEB> in all theory that should be converting though, so the problem then was not what you were originally saying
[11:13] <JEEB> also look at what I actually asked
[11:49] <active8> YellowOnion: thanks for the input on jack
[11:51] <active8> JEEB: thank you! Success. changed the prefix to my build dir and it's all good. have more formats, codecs and protocols than ever. Next time, I'm pouring the caffeine into the compiler instead of my stomach
[11:53] <active8> incidentally, the poked pork was forgetting to remove the --enable-librtmp bit
[14:53] <lkiesow> Trying to create a video out of two still images using:
[14:53] <lkiesow> ffmpeg -y -r 1/20 -i s%1d.jpg -c:v libx264 -filter:v fps=1 -pix_fmt yuv420p out.mp4
[14:53] <lkiesow> Problem: The second image is displayed only one second, not 20. Any idea?
[14:53] <lkiesow> FFmpeg output: http://fpaste.org/72713/39100359/
[16:50] <thebombzen> lkiesow: try using the setpts filter
[16:50] <thebombzen> as in -filter:v setpts=PTS*20
[16:51] <thebombzen> wait... that might not work
[16:51] <thebombzen> ignore that
[17:14] <lkiesow> thebombzen: For now I just duplicated the last image and cut the vide using -t
[17:14] <lkiesow> Not a nice workaround, but did it :)
[17:40] <Orbixx> Is there a video editing suite based on ffmpeg?
[17:40] <Orbixx> Like GUI
[17:40] <Orbixx> Cutting, merging, etc
[17:41] <thebombzen> On Linux you can use kdenlive, but I don't know if it cuts (etc.) with avfilter
[17:41] <thebombzen> also that sucks in the KDE libs which you may or may not want
[17:42] <thebombzen> I do know that it has an FFmpeg decoder/encoder plugin, so it at least has that
[17:45] <jnvsor> Orbixx: Kdenlive uses mlt which is partially based on ffmpeg libs - Blender does user ffmpeg libs mainly
[17:46] <Logicgate> hey guys, libfaac doesn't support the specified bitrate, using 96kbit/s instead
[17:47] <Logicgate> it "hangs" ffmpeg completely
[17:48] <Logicgate> http://pastebin.com/uMKdY5Jj
[17:48] <Logicgate> that's the full output
[17:49] <Logicgate> will specifying the audio encoding flags fix the issue?
[17:50] <sacarasc> Try adding -c:a copy
[17:52] <Logicgate> still hangs
[17:53] <Logicgate> when i say "hangs". It takes 100% cpu and encodes very slowly
[17:54] <sacarasc> That's pretty normal.
[17:54] <sacarasc> Depending on CPU.
[17:54] <Logicgate> nah, the video is 814kb
[17:54] <Logicgate> All other videos don't hang.
[17:54] <Logicgate> Takes 1s to reencode other videos.
[17:55] <Logicgate> Just this one video
[17:55] <Logicgate> i can provide you with the video if you'd like to see
[17:55] <Logicgate> weirdly it says audio bitrate is 35kbps
[18:02] <Logicgate> appending -vsync 2 solved the issue
[18:30] <DeadSix27> when using ffprobe on http sources, and using a short probesize, will it only request that size, or the whole file?
[20:51] <Maverick|MSG> if I have an avi that ffmpeg outputs into an mp4
[20:51] <Maverick|MSG> but it only ouputs 0:30 to 0:60
[20:51] <Maverick|MSG> *outputs
[20:52] <Maverick|MSG> it I then add audio to it how can I tell it to only add the audio from 0:30 to 0:60
[20:53] <llogan> Maverick|MSG: "but it only ouputs 0:30 to 0:60", as in you're experiencing an issue, or you're telling to ffmpeg to do that?
[20:54] <Maverick|MSG> no no,that's on purpose
[20:54] <Maverick|MSG> sorry, should have clarified
[20:54] <llogan> you could probably use the atrim filter
[20:54] <Maverick|MSG> that'll skip the first 30 seconds of the audio?
[20:57] <llogan> Maverick|MSG: http://superuser.com/a/689992/110524
[20:57] <Maverick|MSG> thanks llogan
[21:00] <Maverick|MSG> just for my sanity, if my mp4 is 30 seconds long and the audio I add into it is longer than 20 seconds will the audio get cut off when the video ends?
[21:00] <Maverick|MSG> *longer than 30 seconds
[21:00] <llogan> do you want it to do that?
[21:00] <Maverick|MSG> yeah
[21:01] <Maverick|MSG> that'll happen by default?
[21:01] <Maverick|MSG> or will the resulting mp4 output be as long as the longest input?
[21:01] <llogan> if you're using concat filter then i'm not sure
[21:01] <llogan> otherwise see -shortest
[21:02] <Maverick|MSG> ok
[21:02] <llogan> does the input with video already contain audio? are you wanting to add another audio stream, or combine it with the existing audio?
[21:03] <Maverick|MSG> there is no audio on the video stream to start with
[21:03] <Maverick|MSG> (or if there is it should be replaced by the audio stream of the second input)
[21:05] <llogan> also ive seen people claim that -itsoffset worked for them in this case, but i've never used it
[21:05] <llogan> so i guess you have several methods to try
[21:05] <Maverick|MSG> oh, yeah, i didn't think about itsoffet
[21:31] <ChocolateArmpits> Can anyone help me understand why would P frames of a baseline h264 video be decoded to a blocky mess on a tablet when even a smartphone with less capable processor seems to decode it visually better ?
[21:32] <JEEB> I've had a samsung phone fail at life regarding its HW decoding ASIC
[21:32] <JEEB> so if both use ASICs
[21:33] <JEEB> it could be a problem with one of them just being borked
[21:44] <ChocolateArmpits> I will most likely install android VLC and see how that goes
[21:45] <ChocolateArmpits> Because now it seems my only choice would be to reduce GOP to 8 or lower when framerate is 25
[23:03] <vl4kn0> Hi, I'm using ffmpeg api in my program and it fails on one video (one from ~20) with arithmetic error (floating point exception). gdb backtrack shows it occurs on function ff_mpeg4_set_direct_mv called from avcodec_decode_video2. What could possibly be wrong?
[23:35] <chronic1> Hello
[23:35] <spaam> hello and welcome to #ffmpeg  chronic1
[23:35] <chronic1> I'm trying to size a new HTPC, and have a question about transcoding.  What kind of cpu overhead is involved with transcoding only a container?
[23:39] <llogan> chronic1: are you talking about re-muxing?
[23:41] <chronic1> llogan: Maybe.  Pardon my ignorance....
[23:41] <chronic1> I have a file called aFile.mkv, and it is 264 video.
[23:42] <chronic1> I have a device (chromecast) which can't handle mkv containers, and I need to change the container into something supported.
[23:43] <Hello71> that's not what transcoding means
[23:43] <Hello71> ffmpeg input.mkv -c copy output.whatever
[23:44] <chronic1> Is the situation I'm talking about called re-muxing?
[23:44] <chronic1> And would transcoding be changing something from mpeg2 to mpeg4?
[23:45] <Hello71> pretty much.
[23:45] <Hello71> try google.
[23:45] <llogan> that's usually not a helpful answer
[23:45] <llogan> chronic1: http://ffmpeg.org/ffmpeg.html#Stream-copy
[23:50] <chronic1> Nice.  This sounds like it should have very little impact on a system!
[23:52] <llogan> and i would call converting from one video format to another "re-encoding" since, depending on who you ask, "transcoding" may imply that information from the source bitstream, such as motion vectors, may be (re-)used
[00:00] --- Thu Jan 30 2014

More information about the Ffmpeg-devel-irc mailing list