[Ffmpeg-devel-irc] ffmpeg.log.20150131

burek burek021 at gmail.com
Sun Feb 1 02:05:01 CET 2015

[01:31] <fahadash> hello
[01:32] <fahadash> I have learned to concatenate multiple MP3 files in a series and save it as 1 mp3 using FFMPEG... but I also found out that if I use a simple copy command to concatenate the binary contents of the file and string them together into one file, they still work just as well. What does FFMPEG do different and what is recommended ?
[01:34] <pzich> fahadash: it probably cleans up whatever messed up headers you get by concatenating as binary files
[01:35] <pzich> also, just because *something* can play the concatenated files doesn't mean any player can
[01:35] <fahadash> so you recommend concatenation using ffmpeg as opposed to copying ?
[01:36] <pzich> absolutely
[01:36] <fahadash> Thank you
[12:38] <blade152> Hi everyone !
[12:38] <blade152> 1st i'm sry for my english, i'm french ^^
[12:39] <blade152> i try to convert mov to mp4 file, but it doesnt work, each commands i find on forums failed
[12:39] <__jack__> paste it
[12:40] <blade152> ffmpeg -i myfile copy myfile.mp4
[12:40] <__jack__> something like that may work: ffmpeg -i source.mov -c copy dest.mp4
[12:41] <blade152> Unrecognized option 'c'
[12:41] <blade152> Failed to set value 'copy' for option 'c'
[12:41] <blade152> i'm a novice ^^
[12:44] <__jack__> hum, are you really using ffmpeg ? seems to be avconv
[12:44] <__jack__> you're using ubuntu ?
[12:45] <blade152> i'm using debian 7
[12:45] <blade152> on a dedicated server
[12:45] <__jack__> ok, same issue : the ffmpeg package is a lie, avconv lives there
[12:45] <__jack__> ok
[12:46] <blade152> ups fail i left the chat
[12:46] <__jack__> you may compile ffmpeg from source, or use the ffmpeg from sid/unstable (better solution)
[12:47] <__jack__> add deb http://ftp.fr.debian.org/debian/ unstable main to /etc/apt/sources.list
[12:47] <__jack__> add APT::Default-Release "wheezy"; (if it is not already done) to /etc/apt/apt.conf
[12:47] <__jack__> then aptitude update, aptitude install -t unstable ffmpeg, and there you are
[12:55] <blade152> i hope it will work
[12:55] <blade152> nopw install done, i try the same command for convert ?
[12:56] <__jack__> yes
[12:58] <blade152> it seems ffmepg not install thats weird
[13:01] <relaxed> blade152: http://johnvansickle.com/ffmpeg/
[13:03] <blade152> thank's relaxed and __jack__  i will try this soon
[13:03] <blade152> have a nice day
[14:12] <blade152> i have download the file from git and extract it, but there is no informations about installation in the readme. Where did i need to put the directory ?
[14:27] <relaxed> blade152: you can run ffmpeg from the directory, ./ffmpeg
[14:28] <relaxed> or move it to your shell's path
[14:32] <blade152> Wooow it works :D thank's man !
[14:33] <relaxed> you're welcome
[19:01] <zap0> how do you rotate a video 90º ?
[19:01] <c_14> -vf transpose=1
[19:03] <zap0> i've tried that.   it did not rotate
[19:04] <zap0> ffmpeg.exe -i in.mp4 -vf "transpose=1" out.mp4
[19:05] <c_14> It works for me.
[19:06] <c_14> Pastebin the command output?
[21:06] <kriegerod> hi! i want to make ffmpeg to dump the data stream from MPEG TS. Ffmpeg shows that stream as "unknown" and refuses to "map" it to output, see https://gist.github.com/krieger-od/f9fac489d04463e36ea2
[21:06] <kriegerod> any hints how to do it without patching or coding an app?
[21:09] <c_14> -c:d copy -f data
[21:11] <kriegerod> c_14: thanks for attention, i've tried it, but still it doesn't work. Please check, did i get you right? https://gist.github.com/krieger-od/60e453038f4ecc5f7866
[21:12] <ScottSteiner> Is it possible to burn a subtitle stream into a video using a font attached in the file?
[21:13] <c_14> yes, use the subtitles=file.mkv filter
[21:15] <c_14> kriegerod: hmm
[21:16] <kriegerod> is there an option to treat unknown streams as of data type?
[21:16] <kriegerod> maybe we should add such option
[21:17] <kriegerod> i can share this sample file
[21:17] <kriegerod> it must be just a sample garbage in that stream
[21:19] <kriegerod> c_14: http://whdd.org/test.ts
[21:23] Action: c_14 is going to try locally patching that code path out
[21:23] <c_14> Let's see what happens
[21:31] <ScottSteiner> thanks c_14; is it possible to select which subtitle it is using in that situation?
[21:33] <c_14> :si=
[21:33] <c_14> subtitles=video.mkv:si=1
[21:33] <c_14> for the 1st (second) subtitle stream (probably)
[21:38] <kriegerod> is there a conventional way to mux in a particular binary data stream into MPEG TS to make it appear as "data"-typed stream, available for output with "-c:d copy"
[21:40] <kriegerod> in command line
[21:40] <kriegerod> if possible
[21:51] <c_14> There might be, but I can't seem to find it.
[21:52] <c_14> I can add an arbitrary data stream and mux it to mpegts, but whin I try demuxing it ffmpeg seems to think it's an audio stream and then fails because it isn't.
[21:54] <kriegerod> c_14: i think it's worth a post in ffmpeg-devel, describing my initial issue and your comments
[21:54] <kriegerod> i hope some cool guys come up with easy resolution
[22:59] <kriegerod> c_14: "I can add an arbitrary data stream and mux it to mpegts" - how do you do that in CLI?
[23:00] <kriegerod> c_14: "but whin I try demuxing it ffmpeg seems to think it's an audio" - in my case, with a little patch over ffmpeg_opt.c, it crashes strangely in the place which is actually intended for video streams processing... very strange
[23:13] <kriegerod> uh, updated from upstream git repo and now it crashed for clearer reason
[23:15] <c_14> kriegerod: ffmpeg -i thing.ts -f data -i data -map 0 -map 1 -c copy out.ts
[23:15] <kriegerod> thanks!
[23:17] <kriegerod> indeed, it pretends it's audio
[00:00] --- Sun Feb  1 2015

More information about the Ffmpeg-devel-irc mailing list