[Ffmpeg-devel-irc] ffmpeg.log.20150202

burek burek021 at gmail.com
Tue Feb 3 02:05:01 CET 2015

[03:49] <pentanol> hello,
[03:50] <pentanol> I need help with encoding third audio encoding in avi file
[03:50] <pentanol> for instance first 600 seconds I have nice syncronisation with video, but after that I got unsinc video and audio
[03:51] <pentanol> I use ac3 128Kb/s
[03:51] <pentanol> why that could be?
[03:51] <pentanol> that avi fave has third different languages with audio encoding and one of them fail
[03:52] <pentanol> fave=file*
[05:12] <ac_slater_> hey all, where are the public logs kept?
[05:12] <ac_slater_> (for this channel)
[05:12] <c_14> http://ffmpeg.gusari.org/irclogs/
[05:13] <ac_slater_> c_14: nice, just saw the link on the ffmpeg site. Thanks mate
[08:29] <filterSAC> i have raw videos . i create a mossac screen and all videos are playing....but i want to play this mossac screen using ffplay directlyu rather than using ffmpeg
[08:42] <pentanol> filterSAC you must start from drawbox filter
[09:21] <filterSAC> :pantanol can you please explain how may i start from Drawbox filter
[09:22] <relaxed> filterSAC: it might be easier to use ffmpeg with the opengl output
[09:22] <relaxed> since you already have it working with ffmpeg, I assume
[09:23] <keestu> dear all, sorry to ask very basic question. when i dont need any kind of a playback operations like fast forwarding, rewinding, will RTP protocol suffice for live video streaming over wifi ?
[11:05] <UVV> Hi guys
[11:05] <durandal_1707> hi
[11:05] <UVV> I have a broken mp4 file, which was recorded with ffmpeg -f x11grab -r 2 -s 1600x1200 -i :0.0 -t 00:14:59 -qscale 1 file.mp4
[11:06] <UVV> Now the X11 was killed with Ctrl+Alt+Backspace.
[11:06] <UVV> Is there any clue how could I recover this file.
[11:06] <UVV> I've been searching the Internet for a couple of days already and finally came here :)
[11:07] <UVV> Would appreciate any help
[11:08] <UVV> I tried also this project https://github.com/ponchio/untrunc , but to no avail :(
[12:28] <ManDay> Hello, can I use ffmpeg to stream video from a webcam on an android device into the ethernet?
[12:28] <Mavrik> Ugh
[12:29] <Mavrik> "Yes."
[12:29] <ManDay> Can you expand the quotes?
[12:29] <Mavrik> Depends on how do you think you'll pull that off.
[12:29] <ManDay> I have absolutely no idea about Android, whatsoever
[12:29] <Mavrik> Since Android devices don't have ethernet.
[12:29] <Mavrik> Or webcams.
[12:29] <ManDay> Mavrik: Huh?
[12:29] <Mavrik> Or support arbitrary binaries.
[12:29] <Mavrik> FFmpeg isn't an Andoird app, but FFmpeg libraries do work for usage inside Android apps.
[12:29] <ManDay> Well, I have a Samsung Galaxy Pad here - I'd like to use that as a "walking cam"
[12:30] <ManDay> I'm open for any suggestion that would work, of course
[12:33] <Mavrik> Hmm, check for any existing apps on Play store first :)
[13:31] <ManDay> Mavrik: "IP Webcam" is pretty much what I need
[13:31] <ManDay> It works
[14:06] <ManDay> Mavrik: Juswt curious: What did you mean by "Android has no webcam and no ethernet"?
[14:07] <ManDay> I can use ffmpeg easily to stream video in form of a webcam stream (don't ask me what it is, I just call it that - the protocol for net webcams) from linux, rihgt?
[14:20] <dhead666_> hi, is ffmpeg is the best tool to capture http mpegts stream without a change? for sharing a sample so developers could debug an issue ("non-existing PPS 0 referenced" ends with black screen in player) I need to capture an http mpegts stream from a DVB to IP box, ATM I'm using the following to save the stream, but if I input the create sample.ts back to ffmpeg then the error will not appea
[14:20] <dhead666_> r again : "# ffmpeg -i LINK_TO_STREAM -codec copy -f mpegts sample.ts"
[14:21] <dhead666_> *create -> created
[14:23] <Mavrik> dhead666_, honestly, using curl/tcpdump/etc is way better
[14:23] <Mavrik> since ffmpeg will remux it anyway
[14:24] <dhead666_> Mavrik: thanks, I'll do just that.
[14:24] <Mavrik> I know that I prefer the raw dumped stuff, since VLC and ffmpeg tend to try to "repair" and retimestamp streams and thus usually hide issues :)
[14:31] <dhead666_> Mavrik: alright, thanks, this is actually a sort of a bandage solution for me, I can pipe the stream to ffmpeg before sending to the player :) (though it won't help much with channels switching delay)
[15:03] <RobertNagy> If I'm able to encode 50 fps content in 50 fps without the -re option but it runs slower (~42fps) with the -re option what might be wrong?
[15:05] <Mavrik> hmm
[15:05] <Mavrik> your CPU is too slow?
[15:31] <RobertNagy> well, it can encode it in 50fps...
[15:31] <RobertNagy> if I don't provide -re
[15:31] <RobertNagy> and I've tried lusing faster presets to get cpu at 30-40%
[15:31] <RobertNagy> it seems to be realted to that fact that I'm doing multiple encoding simulatanously in some wierd way.
[16:30] <wiretap1> hi there, i got a bunch of ogg files i want to concat to a file called all_sounds.ogg & the catch is that I need to keep the durations of each ogg file in a txt file in order to know when the next sound will start. can anyone suggest a way to do it?
[16:31] <wiretap1> e.g file1.ogg starts at 00:00:00
[16:31] <wiretap1> file2.ogg starts at 00:01:23
[16:31] <wiretap1> meaning file1 is 1:23 duration
[16:31] <wiretap1> and so on
[16:31] <wiretap1> the last file wont have duration
[18:06] <m-r-r> Hello
[18:07] <m-r-r> When ffmpeg loads an input file, how does it detects the input codecs ? Does it use the file extension or does it looks directely at the file content ? Maybe it uses the MIME database ?!
[18:08] <ramiro> m-r-r: it looks at the file content
[18:10] <bigeast> is the information of the codec signalled in the container, or the codec type can be derived from the bitstream in the container?
[18:10] <m-r-r> ramiro: Okay, thanks :-)
[18:14] <kepstin-laptop> bigeast: to be more accurate, ffmpeg does a bit of all of the above for detecting; the file extension is used for guessing, and it does more advanced probes looking at the contents. For formats it recognizes, it reads information about the codecs from the container.
[18:14] <kepstin-laptop> er, m-r-r ^^
[18:14] <Zerowalker> how do you set what mapping a stream should have when being encoded/muxed into a file with ffmpeg (C++) ?
[18:17] <m-r-r> kepstin-laptop: So, if my extension is missing or invalid, Ffmpeg can still read my file ?
[18:18] <Zerowalker> yeah
[18:18] <kepstin-laptop> m-r-r: in most cases, yes, but in a few tricky cases it might be less accurate at guessing. (for common formats like avi, mkv, mp4, etc. it'll almost always be right)
[18:18] <bigeast> It seems ffmpeg can detect raw bitstream, even without a container like mkv,mp4, etc.
[18:18] <Zerowalker> file extension is just a quicky
[18:19] <kepstin-laptop> bigeast: depends on the format; some bitstreams have identifying characteristics, others don't.
[18:24] <bigeast> kepstin: right, I think it's better to review the source code, and hope I can understand the mechanism better :-D
[18:26] <kepstin-laptop> (mpeg-ts is perhaps one of the more ... interesting ... containers to detect, give that you can start at an arbitrary cut point in the stream and might have to read quite a while before getting a header you can sync on.
[18:26] <kepstin-laptop> )
[18:29] <bigeast> if it's so, just decode it! The only reason we want to know the stream format is to decode it, isn't it?
[18:29] <angrybb> is ffmpeg able to output to  http like vlc does? for example ffmpeg -re -i /path/to/video.file -vcodec copy -acodec copy -f mpegts ?
[18:32] <c_14> angrybb: you can do that and it should post/put the data (not sure which)
[18:34] <bigeast> angrybb: Maybe ffserver is what you need. But I don't know the exact parameters either
[18:54] <Tr4sK> Hi ther
[18:54] <Tr4sK> e
[18:54] <Tr4sK> I'm trying to build ffmpeg througt rmpbuild.
[18:55] <Tr4sK> I got a complain from ./configure
[18:55] <Tr4sK> Unknown option "--host=x86_64-redhat-linux-gnu".
[18:55] <Tr4sK> I saw that the option --host isn't in ./configure --help
[18:56] <JEEB> that's an autoconf setting
[18:56] <JEEB> if you want to use specific tools with specific cross-prefixes you use...
[18:57] <Tr4sK> ok
[18:58] <Tr4sK> JEEB: thanks, that's my second build, worked out of the box on my first test ./configure; make
[18:58] <JEEB> --cross-prefix=x86_64-redhat-linux-
[18:58] <JEEB> that will use specifically x86_64-redhat-linux-*
[18:58] <JEEB> oh wait
[18:58] <JEEB> gnu there too :P
[18:58] <JEEB> but yeah, you get the gist
[18:59] <JEEB> it will then append gcc/ld/g++/whatever after the dash
[18:59] <JEEB> --cross-prefix=x86_64-redhat-linux-gnu-
[18:59] <JEEB> you will have to set --arch and --target-os as well if you start using that of course
[19:00] <bigeast> q
[19:05] <Tr4sK> JEEB: Ok I got it. Do you know how can I tell that to my SPEC file ?
[19:06] <JEEB> no, I have no idea of the variable for that :P
[19:06] <Tr4sK> JEEB: the issue is that I don't know how to tell autoconf to remove the --host option
[19:07] <Tr4sK> through the SPECS file
[19:07] <JEEB> you don't fucking use the thing that automagically tries to use autoconf shit
[19:07] <JEEB> rather call the configure script as usual
[19:07] <JEEB> and maybe set prefix and other things
[19:07] <JEEB> so it installs to the correct spot
[19:14] <angrybb> ok, thanks for info. I have one more question. Is ffserver safe to use or is it obsolete?
[20:03] <witheld> I'm on Ubuntu and trying to configure with ./configure --disable-ffplay --disable-ffprobe --disable-ffserver --enable-libfaac --enable-libmp3lame --enable-libv4l2 --enable-libx264 --enable-x11grab --enable-libpulse --enable-librtmp --enable-gpl --enable-nonfree --disable-yasm  --extra-libs="-lasound"
[20:04] <witheld> But I'm getting "ERROR: librtmp not found using pkg-config" even though that package is installed, and pkg-config is aware of it
[20:04] <JEEB> time to look at config.log :P (pastebin it)
[20:05] <llogan> witheld: or just remove --enable-librtmp. ffmpeg has native support, but i'm not sure if librtmp is better or not
[20:05] <JEEB> the libavformat support should generally be better or on par
[20:06] <llogan> witheld: why --disable-yasm?
[20:06] <JEEB> unless you have built a version with protocol 10 support yourself from DMCA'd sources
[20:06] <JEEB> because he has no idea what that does, most probably
[20:06] <JEEB> :P
[20:06] <witheld> Solved it by looking at that log, thanks
[20:06] <witheld> gnutls wasn't installed
[20:09] <witheld> And building, awesome
[20:10] <JEEB> are you building for something not x86?
[20:10] <JEEB> also let me remind you that if you want to use an aac encoder that requires enable-nonfree I recommend fdk-aac
[20:10] <JEEB> https://github.com/mstorsjo/fdk-aac
[20:10] <JEEB> better than faac and similarly not compatible with (L)GPL as faac :P
[20:11] <Tr4sK> JEEB: thx, it worked :D
[20:11] <JEEB> witheld, basically you should only be using disable-yasm if you are building for something that isn't intel based
[20:12] <Tr4sK> witheld: apt-get install yasm
[20:12] <JEEB> otherwise you will be getting a really high speed penalty
[20:12] <JEEB> because you're effectively disabling most of the handwritten optimizations
[20:38] <MvL> Hi, I'm trying to copy a dts stream and encode the dts stream to ac3 of a mkv file. How do I combine this?
[20:38] <MvL> i can do -c:a ac3 -b:a 640k for converting
[20:49] <MvL> i think i have it!
[20:49] <MvL> with the -map option...
[22:36] <nomnomdeguerre> Hey there. I'm having some trouble streaming a video using ffmpeg and ffserver
[22:36] <nomnomdeguerre> segmentation fault  ffmpeg -i movie.mp4 http://localhost:8090/feed1.ffm
[22:37] <nomnomdeguerre> ffserver is up and running
[22:37] <nomnomdeguerre> and I can play movie.mp4 just fine
[22:38] <klaxa> maybe also include your ffserver.conf
[22:41] <nomnomdeguerre> http://pastebin.com/vjBHahvE
[22:45] <DeadSix27> for a never-before ffmpeg on linux user, are there prebuild ffmpeg binaries of the git?
[22:45] <DeadSix27> (like Zeranoe does on windows)
[22:46] <Mavrik> yep
[22:46] <Mavrik> see topic.
[22:46] <Mavrik> uh
[22:46] <Mavrik> or not.
[22:46] <Mavrik> DeadSix27, ffmpeg homepage, download -> linux -> static builds
[22:47] <klaxa> nomnomdeguerre: wow i don't think that should happen
[22:48] <klaxa> nomnomdeguerre: can you try it again with the latest git?
[22:48] <DeadSix27> :p thx
[22:49] <nomnomdeguerre> I tried it with 2.5.3, and it didn't work, so I'm using 2.5.2 that can be installed with brew (on a mac)
[22:49] <nomnomdeguerre> is there another way I can try to find the issue besides using another version of ffmpeg? perhaps streaming it in another version, or converting it to some other video encoding?
[22:51] <Mavrik> a segfault message really isn't enough to tell you what's wrong
[23:37] <errnick> Hi! Please someome tell me how I can convert videos with the same quality
[23:37] <errnick> I usually first exiftool the source and -b:v #
[23:38] <errnick> but this looks rather awkward
[23:41] <hetii> Ho
[23:41] <hetii> hi :)
[23:42] <hetii> I try play with  some mp4 frame  player.
[23:43] <hetii> Original file that is stored is in such format: http://pastebin.com/cpZ7dzip
[23:43] <klaxa> errnick: "same quality" is very subjective
[23:43] <hetii> based on it i build second file: http://pastebin.com/DtQ8qetr
[23:44] <hetii> by command ffmpeg -i a.avi -s 320x240 -vcodec mjpeg  -acodec adpcm_ima_wav -ab 192k -ar 22050 output.avi
[23:44] <klaxa> it also depends on what codec you want to use
[23:44] <errnick> klaxa: same video bitrate  would be enough :)
[23:44] <hetii> And then my device show that file format is wrong
[23:44] <hetii> any clue how to decode it to the same format
[23:44] <hetii> and then from other video formats?
[23:44] <constantineI> Hello, does anyone have experience converting WTV (Windows Media Center) container format to mpg, etc???
[23:45] <constantineI> I converted it but the audio didn't work
[23:45] <errnick> klaxa: if the bitrate is similar then it can't be much worse - I guess
[23:45] <klaxa> depends on the codec
[23:45] <errnick> klaxa: I'm thinking about theora
[23:46] <klaxa> err... i think theora is pretty obsolete
[23:46] <errnick> GNU team really advertise it
[23:46] <klaxa> hetii: can you explain what exactly  you are trying to do?
[23:47] <klaxa> vp8 and vp9 are both open-source now
[23:47] <errnick> klaxa: now they are in h264
[23:47] <klaxa> if you want a royalty-free video codec those are probably the more sane choices
[23:47] <errnick> royalty-free without messing up the quality :)
[23:48] <hetii> klaxa: I have some player from card like in this site http://www.alternatasha.com/2012/07/hacking-a-video-greeting-card/
[23:48] <hetii> and I try put some youtube movie on it
[23:48] <klaxa> oh that's pretty neat
[23:49] <hetii> for beggining I try reconvert original file that was there to the same file
[23:49] <hetii> to see if ffmpeg are able to genereate the same type of file
[23:49] <hetii> if this success then I will try convert from other type of input
[23:50] <hetii> but as I said currently device show format error on any other file that I put
[23:50] <hetii> expect original one
[23:50] <errnick> klaxa: can I add multiple files to the ffmpeg or I have to use FOR?
[23:51] <klaxa> errnick: what do you want to do? encode multiple vidoes independently? using a loop would probably be easier (so yes, use for)
[23:52] <errnick> I have lots of .MTS files, I'd like to make lots of OGV files
[23:52] <errnick> with the ~same quality
[23:53] <klaxa> hetii: >Duration: 00:00:00.09, start: 0.000000, bitrate: 1284364 kb/s
[23:53] <klaxa> this looks like it's non-standard
[23:53] <klaxa> or not supported or something
[23:53] <klaxa> that's from the original file
[23:53] <hetii> yep
[23:53] <hetii> how to produce such file?
[23:54] <hetii> btw vlc generate segmentation fault when I try play this file by it
[23:54] <klaxa> haha what
[23:54] <hetii> in tomtom its played ok
[23:54] <klaxa> i don't think it will be possible (without a patch) to produce a (seemingly) broken file
[23:55] <hetii> maybe its some way how they protect to put other file types
[23:55] <klaxa> i think the easiest way would probably be to try out that third-party windows tool and see if it runs with wine
[23:55] <klaxa> probably
[00:00] --- Tue Feb  3 2015

More information about the Ffmpeg-devel-irc mailing list