[Ffmpeg-devel-irc] ffmpeg.log.20150204

burek burek021 at gmail.com
Thu Feb 5 02:05:02 CET 2015

[00:05] <fixxxermet> c_14: Mind helping me with a more complete example?  Here is what I'm currently using:  ffmpeg -r 5 -i 'rtsp://$url'  -ab 64k -vcodec copy -vb 448k -s 704x480 -f mpegts udp://
[00:05] <fixxxermet> That /works/, but I can't open that stream with vlc (it just hangs) or with ffplay (no frame! errors)
[00:06] <c_14> just replace udp://* with tcp://
[00:08] <fixxxermet> I was using udp on purpose - does ffmpeg not support udp sockets?
[00:09] <c_14> No, it does. It should work, but I've had lots of weird problems with it for strange reasons, try tcp and see if that works.
[00:14] <fixxxermet> c_14: I thikn I'm almost there, but am missing something probably obvious: https://gist.github.com/kylejohnson/845d4c218844e20f0fd1
[00:17] <c_14> What's with the -f mpeg1video?
[00:18] <fixxxermet> Ok, so I had it backwards.  The receiving side should have ?listen, no?
[00:18] <fixxxermet> c_14: Mistake.  I thought I had 'mpegts' there
[00:24] <fixxxermet> There we go...
[00:24] <fixxxermet> -vcodec copy didn't work, -vcodec libx264 did.
[00:27] <fixxxermet> So, ffserver might be what I need.  If I understand correctly, with just ffmpeg, first I need to have a 'client' listening for a connection.  From there I can output ffmpeg to a tcp stream (where the 'client' is listening)
[00:28] <c_14> Not entirely, ffmpeg can also listen and wait (for one client per tcp stream) if you add the ?listen flag
[00:29] <fixxxermet> ah, indeed it can
[00:33] <fixxxermet> ok, now if I do need more than 1 client
[00:34] <fixxxermet> ffserver then might be a good option
[01:08] <applejack> how would I apply the lowpass/highpass filters to the lfe/center channels in a 5.1 ac3 stream?
[01:10] <c_14> channelsplit highpass/lowpass channeljoin/merge/pan
[01:10] <c_14> something like that probably
[01:11] <c_14> s/channeljoin/join/
[01:11] <applejack> hmm
[01:12] <applejack> can it be done in one pass tho?
[01:12] <c_14> Sure
[01:13] <c_14> Split the channels into separate streams, highpass the ones you want to highpass, lowpass the ones you want to lowpass and join em together again.
[01:14] <applejack> do you just specify the filters in that order on the command line, or do you have to create a filter map
[01:14] <c_14> Create a filter_complex
[01:14] <applejack> ahh
[01:14] <c_14> With at least 3 filterchains
[02:49] <DX099> #libreoffice
[02:53] <pentanol> hello
[02:53] <pentanol> someone here?
[02:53] <DX099> might not be of great helpo
[02:54] <pentanol> I've trouble with synchronisation audio and video streams, after 600 seconds of the movie I get unsynchronisation and audio listen unhit video stream
[02:55] <pentanol> I have third audio streams and this happen only with one audio stream
[02:56] <DX099> pentanol, complete noob here but did you change framerate ?
[02:58] <pentanol> yes, I did 192 and 128kb/s
[02:58] <pentanol> that's ac3 audio stream in avi file
[02:59] <pentanol> I don't remember all command, I have that at home.
[02:59] <pentanol> and I have 3 movie with that trouble
[03:00] <relaxed> well, it's hard to troubleshoot if we don't know what you did.
[03:00] <pentanol> I just pul third audio track from another movie to that and get stuck after ~600 sec out of the movie
[04:00] <_maz> hi I see at https://trac.ffmpeg.org/wiki/Create%20a%20video%20slideshow%20from%20images  I can create a video slideshow. I would like to display specific images at specific times(rather than regular intervals) and add them to an uncompressed WAV file of a specific duration. is this possible?
[04:48] <c_14> You can try using the duration option in the concat demuxer, and if that doesn't work specify each of the images separately as inputs and loop 1, then trim each to the duration you want and use the concat filter to concat.
[05:16] <_maz> thanks c_14 will look into concat and the separate looping idea
[05:21] <pzich> anyone know how to pass multiple quality streams to twitch?
[07:17] <voltagex> I'm trying to build ffmpeg as a static binary on Debian, I'm getting "unable to find libass/fontconfig" even with a custom pkgconfig path - http://sprunge.us/AOJI, fontconfig.pc exists
[07:44] <Tze_> Hi - is it possible for FFPLAY to play out video while graphically displaying the audio volume? something like this: http://imgur.com/ZFI27pL
[07:58] Last message repeated 1 time(s).
[09:27] <h4ni> Hello
[09:27] <h4ni> i have a question about this wiki  https://trac.ffmpeg.org/wiki/CompilationGuide/Ubuntu
[09:27] <h4ni> what i must do to install ffmpeg in /usr/local/bin ?
[09:31] <h4ni> any help?
[11:35] <emilsedgh> guys, I have 3 ffmpeg commands running. however, all 32 cores on my server are busy
[11:35] <emilsedgh> is this normal? they all have like 10% CPU usage
[11:36] <emilsedgh> and I see many many ffmpeg commands in my htop. I assume they are threads?
[14:17] <c_14> emilsedgh: Depending on what you're doing with it, ffmpeg threads pretty well. So yes, probably normal.
[14:18] <emilsedgh> thank you c_14.
[14:18] <emilsedgh> one of the commands pushes an mp4 file to rtmp server.
[14:19] <emilsedgh> then two other commands re-encode the rtmp to lower bitrates and push it to another rtmp streams
[14:20] <c_14> voltagex: have you tried setting PKG_CONFIG_PATH ?
[14:20] <c_14> emilsedgh: you can limit the number of threads ffmpeg uses, but normally it's nothing you should be worried about.
[14:20] <emilsedgh> c_14: thanks a lot man :)
[14:56] <RobertNagy> is it possible to capture 4 audio streams from blackmagic using the directshow device in ffmpeg?
[15:05] <c_14> If you can capture 1 stream, then probably yes.
[15:17] <ramiro> RobertNagy: there should be support for decklink directly, without using dshow
[15:17] <RobertNagy> I don't think there is on windows
[15:20] <ramiro> RobertNagy: it should. have you tried?
[15:20] <RobertNagy> Not in a while.
[15:21] <RobertNagy> I will try again
[15:24] <ramiro> it was implemented late last year
[15:46] <relaxed> RobertNagy: does "ffmpeg -devices" list it?
[15:46] <RobertNagy> Indeed it does
[15:46] <RobertNagy> wow, I've totally missed it
[15:47] <RobertNagy> thx
[15:48] <ramiro> RobertNagy: it's quite new =)
[16:00] <RobertNagy> hm, it seems to only do output
[16:08] <ramiro> RobertNagy: how old is your build of FFmpeg?
[16:09] <RobertNagy> Dec 30
[16:18] <Harzilein> hi
[16:20] <Harzilein> when i reencode already somewhat lossy h264 material in hd resolution to h263, the result looks a bit worse than when i reencode an sd source (only have xvid here). any idea what might make the decoded xvid smoother compared to the scaled h264? what filter should i try?
[16:25] <jojek> Hi guys, I have a following question:
[16:25] <jojek> I have some video file in which audio is some unknown to ffmpeg format: g722.1 (incorrectly recognized as aac):
[16:25] <jojek> Input #0, mpegts, from 'input.ts':
[16:25] <jojek>   Duration: 00:00:34.00, start: 71056.228111, bitrate: 179 kb/s
[16:25] <jojek>   Program 1
[16:25] <jojek>     Stream #0:0[0x21]: Video: h264 (Main) ([27][0][0][0] / 0x001B), yuv420p(tv, bt709), 1280x720, 10 fps, 12.50 tbr, 90k tbn, 20 tbc
[16:25] <jojek>     Stream #0:1[0x22]: Audio: aac (SSR) ([146][0][0][0] / 0x0092), mono, fltp, 789 kb/s
[16:25] <jojek> Is it possible to extract this very track as binary data, without any processing? Then I could obviously try to convert this track with different tool. I am using ffmpeg in version N-69498-g7620d48. Or maybe someone has an idea how to decode g722.1 with ffmpeg?
[16:28] <c_14> try -map 0:1 -c copy -f data out
[16:31] <jojek> hi c_14, thank you for your attention. Here is the output:
[16:31] <jojek> http://pastebin.com/cxnDUqm1
[16:32] <c_14> using -c:a adpcm_g722 before the -i ?
[16:33] <c_14> eh, s/^/try/
[16:34] <jojek> You mean something like that?
[16:34] <jojek> ffmpeg -i input.ts -map 0:1 -c:a adpcm_g722 -c copy -f data out
[16:35] <c_14> before the -i
[16:35] <c_14> ffmpeg -c:a adpcm_g722 -i input.ts
[16:37] <jojek> http://pastebin.com/7ZbDJrU0
[16:37] <jojek> Still no luck, although you made a difference ;)
[16:38] <c_14> Do you know the samplerate of the stream?
[16:39] <jojek> I am afraid not, but probably there is a finite number of possibilities to try.
[16:39] <c_14> Try supplying -ar 44100 as an input option
[16:39] <c_14> (before the -i)
[16:41] <jojek> It says that option sample_rate not found. Does it mean that adpcm_g722 doesn't accept that and you can only set bitrate?
[16:42] <c_14> Switch the output part to -map 0:1 -c:a adpcm_g722 -ar 44100 out.mkv
[16:42] <c_14> maybe forcing it for the output will help
[16:44] <jojek> Here is the ouput: http://pastebin.com/y6jFzQxC
[16:46] <c_14> -time_base 1/44100 <- not sure if that'll help or if it's even correct, but try adding it as an output option
[16:46] <jojek> I got error while splitting the argument list as option not found.
[16:47] <jojek> So indeed it is not possible to do that. Interesting
[16:49] <c_14> mhm, might be time to open a bug report. I kind of wish ffmpeg had a way to just extract a stream as without checking validity for anything...
[16:49] <jojek> I see
[16:49] <jojek> would it help you if you had an original file?
[16:50] <jojek> Or maybe it's just pointless...
[16:50] <c_14> I don't know much about the internals of audio codecs, but if you can attach it to the bug report/updload it to the samples ftp and mention that on the bug report it'll help the developer who'll look at the ticket
[16:51] <jojek> I see
[16:51] <jojek> Can I ask you one more thing?
[16:52] <jojek> Is it possible to attach a text file to, let's say, wav file? I.e. by muxing them together and then retrieve it just like that?
[16:55] <c_14> Muxing it is easy, but demuxing it is a problem because of what I mentioned above about extracting invalid streams.
[16:55] <c_14> though, there is a codec for text
[16:55] <c_14> So it should work
[16:55] <jojek> Jeez, I see... So there is no simple way of saying: treat it as binary data?
[16:56] <c_14> None I know of, sadly.
[16:56] <c_14> Mux it in with `ffmpeg -i file -c:a text -i text -c copy outfile'
[16:57] <c_14> If it really is text it should be able to work with it. ffmpeg just can't work with data it doesn't know about (that I know of).
[16:59] <jojek> Am I doing again something wrong? http://pastebin.com/zErS9HNd
[17:05] <c_14> I think bintext is a video codec of some weeird sort, try using -c:a text---- wait, I just found the bin_data codec
[17:05] <c_14> Try the file with the g722 , with -c:a bin_data as input option
[17:06] <jojek> It's still hate me ;)  http://pastebin.com/XKe7uxmm
[17:07] <c_14> Input option, before the -i
[17:08] <c_14> And just -c
[17:08] <c_14> not -c:a
[17:08] <c_14> actuall
[17:08] <c_14> do -c:0:1 bin_data
[17:08] <c_14> that should work
[17:08] <c_14> *actually
[17:09] <c_14> ffmpeg -c:0:1 bin_data -i input.ts -c:0:1 copy -f data out
[17:09] <c_14> probably
[17:10] <c_14> might have to change it a bit
[17:10] <c_14> Never tried it before though.
[17:10] Action: c_14 hopes it works
[17:24] <Phlarp> Is it possible to set up an image overlay filter to scale/animate?
[17:35] <FilterComplex> Hello
[17:35] <FilterComplex> I have a problem with filtercomplex
[17:35] <jojek> I see c_14
[17:36] <FilterComplex> I'm trying to run something like this: ffmpeg  -i overlay_1.ts -i raw_1.ts -c:v libx264 -filter_complex_script "filter_complex.txt" -y -r 29.97 -pix_fmt yuv420p out_1.ts
[17:37] <FilterComplex> in filter complex file I have: [1:0] format=rgba [1sared]; [0:0] setsar=sar=1, format=rgba [0rgbd]; [0rgbd][1sared]blend=all_mode='overlay':all_opacity=0.8,format=yuva422p10le
[17:37] <FilterComplex> I get this error: First input link top parameters (size 846x360, SAR 0:1) do not match the corresponding second input link bottom parameters (846x360, SAR 1:1)
[17:38] <FilterComplex> When I change the filter_complex to : [1:0] setsar=sar=1,format=rgba [1sared]; [0:0] format=rgba [0rgbd]; [0rgbd][1sared]blend=all_mode='overlay':all_opacity=0.8,format=yuva422p10le
[17:38] <FilterComplex> I get this: First input link top parameters (size 846x360, SAR 1:1) do not match the corresponding second input link bottom parameters (846x360, SAR 0:1)
[17:40] <FilterComplex> the funny part is that this was working perfectly 1 day ago... And I need to launch tomorrow :/
[17:41] <FilterComplex> can anyone help?
[17:41] <FilterComplex> any opinion?
[17:44] <kepstin-laptop> FilterComplex: simplest fix would probably be to put the setsar filter on both inputs
[17:51] <FilterComplex> kepstin-laptop so something like this: [1:0] setsar=sar=1, format=rgba [1rgbd]; [0:0] setsar=sar=1, format=rgba [0rgbd]; [0rgbd][1sared]blend=all_mode='overlay':all_opacity=0.8,format=yuva422p10le ?
[17:52] <FilterComplex> kepstin-laptop so something like this: [1:0] setsar=sar=1, format=rgba [1rgbd]; [0:0] setsar=sar=1, format=rgba [0rgbd]; [0rgbd][1rgbd]blend=all_mode='overlay':all_opacity=0.8,format=yuva422p10le ?
[21:04] <fixxxermet> I'm starting to get the hang off ffserver.  I have two feeds, and each feed has two streams (one webm, and one h264).  I can open all 4 streams with vlc and ffplay
[21:04] <fixxxermet> Does anyone have experience with live streaming in firefox with the <video> tag?  It works in chromium, but not in firefox
[21:09] <kepstin-laptop> fixxxermet: what format are you using? firefox explicitly does not (and will not) support playing mpeg-ts. I'm a bit surprised about webem not working tho.
[21:12] <fixxxermet> kepstin-laptop: flv with libx264, and webm with libvpx (Format and VideoCodec, respectively)
[21:13] <kepstin-laptop> well, flv won't work in firefox unless you have a flash player :) The only container it supports for h264 video is mp4 (which cannot be used for live streaming)
[21:14] <kepstin-laptop> I'm a bit surprised chromium would allow that
[21:15] <fixxxermet> Chromium is using the webm streams, not the flv streams
[21:15] <PoeticallyEvil> Hi, I'm trying to concatenate 10+ songs (.flac) into one file, I use this command: ffmpeg -f concat -i mylist.txt -c copy output.flac. mylist.txt looks like so: "file './01 - Alternate World.flac'\nfile './02 - Lost It To Trying.flac' [...]". The ffmpeg output looks fine: "size=  251423kB time=00:41:39.77 bitrate= 823.9kbits/s", however playing the file stops at 2:55 (first file lasts 04:14) ?
[21:15] <kepstin-laptop> if you really want to get live streaming working in firefox html5 video, you'd probably have to do dash streaming with a javascript dash library that uses the browser media source extensions.
[21:15] <fixxxermet> kepstin-laptop: I'm investigating that as well - just seeing how far I can take straight-up html5 <video>
[21:15] <fixxxermet> So for webm...  Format = webm, VideoCodec = libvpx.  /should/ that work in ff?
[21:16] <PoeticallyEvil> It stops with "End of file".
[21:17] <kepstin-laptop> fixxxermet: assuming you're using vp8 and not vp9, yeah. But I dunno how firefox handles live webm.
[21:17] <kepstin-laptop> in theory, live webm should be indistinguishable from webm that just doesn't have an index, but i've had issues with unindexed webms not working properly in browsers before.
[21:18] <kepstin-laptop> although I thought that was in chrome and not firefox...
[21:46] <PoeticallyEvil> Huh, the " -c copy " is unnecessary, and actually what made the thing go wrong. "ffmpeg -f concat -i mylist.txt output.flac" works perfectly.
[21:47] <PoeticallyEvil> If someone would consider it useful to mention this here: https://trac.ffmpeg.org/wiki/Concatenate.
[21:47] <PoeticallyEvil> Then again, I'm concatenating one stream only (and not two as in a .mkv)... ?
[21:48] <PoeticallyEvil> Anyhow, peace.
[22:09] <fixxxermet> kepstin-laptop: I'ev actually got it working now.  Was an issue with the hostname, not with ffmpeg
[22:11] <BtbN> As far as i'm aware, live streaming without flash doesn't work in any browser except safari on mac.
[22:12] <c_14> It works with webm. At least, I remember it working with webm at one point.
[22:13] <BtbN> Twitch would love to get rid of flash. But they can't, because browser support is severely lacking.
[22:16] <c_14> Browsers and video has always been lacking.
[22:17] <BtbN> static video is mostly fine now
[22:17] <BtbN> but live streaming is the next big problem
[22:18] <BtbN> It's pretty much allways done with h264
[22:18] <BtbN> So for webm, live streaming services would have to transcode everything
[22:19] <c_14> I personally just try and convince the server to give me an hls link and then watch it externally.
[22:19] <BtbN> That's quite a complex process on twitch, but it's possible
[22:20] <BtbN> It's quite common to watch ads on twitch though, and those only work when you watch via web
[22:20] <c_14> It shouldn't really be that hard to splice those into the video though.
[22:21] <BtbN> It is. As it's their flash video player which loads and handles them.
[22:22] <BtbN> Even their own hls web player(Which only works on Android/iOS and Safari on Mac) doesn't show ads.
[22:24] <c_14> Sure, but implementing ads for hls shouldn't be that hard. It'd be easiest if they showed ads to all clients at the same time though, not sure how they handle that.
[22:26] <c_14> I mean, you'd just need to point the playlist entries at the ad files instead of the video files. Should even be possible on a per-user basis if each user got their own hls link.
[23:24] <gcl_5cp> is posible edit metadata in original file? i mean, without make a new file like "ffmpeg -i org.mp4 ... new.mp4"
[23:26] <c_14> No
[23:26] <c_14> Unless you like hex editors.
[23:39] <gcl_5cp> but in vlc i do manually
[23:41] <c_14> What do you consider "metadata". There are some editors that can edit certain types of metadata, but ffmpeg does not support writing to the same input.
[23:44] <gcl_5cp> you are right, is not the tool. python-mutagen seem to be perfect
[00:00] --- Thu Feb  5 2015

More information about the Ffmpeg-devel-irc mailing list