[Ffmpeg-devel-irc] ffmpeg.log.20150205

burek burek021 at gmail.com
Fri Feb 6 02:05:01 CET 2015

[00:48] <techtopia> hey guys, my cable company lets me watch videos and shows on demand, i just tried downloading one of them and was going to re encode it
[00:48] <techtopia> but the video is black and there is no audio
[00:48] <techtopia> anyone know whats up
[00:49] <techtopia> http://pastebin.com/wExEYA5D
[00:49] <techtopia> the video and audio are their but they don't play back
[01:38] <macmichael01> I have a .m2ts file containing LPCM audio. Is it possible to mux the audio into a MKV container? When I try, I get this message: No wav codec tag found for codec pcm_bluray.
[01:40] <macmichael01> http://pastie.org/9887554
[01:44] <c_14> try switching -acodec copy to -c:a pcm_s16le
[01:44] <c_14> Or if you want to keep it closer to the original, use pcm_s16be
[01:47] <macmichael01> Does that transcode the audo into the new container or mux it? Also if the audio is 24 bit I would need to change that number to 24?
[01:47] <c_14> transcode, yep
[01:48] <macmichael01> ok Ill try that out. Whats the difference between le and be?
[01:48] <c_14> little endian vs big endian
[01:48] <macmichael01> duh gatcha thanks!
[02:43] <pentanol> hello everyone.
[02:43] <pentanol> Im here with question about unsynchronisation audio and video channals
[02:44] <pentanol> what I did:
[02:44] <pentanol> ffmpeg -i /mnt/xfs/mov_de/HP_undRerSteinDerWeisen.ac3 -ss 3 -i "concat:vts_02_1.avi|vts_02_2.avi|vts_02_3.avi|vts_02_4.avi|vts_02_5.avi|vts_02_6.avi|vts_02_7.avi|vts_02_8.avi"  -t 600 -map 1:0 -map 1:1 -map 1:2 -map 0:0 -vcodec copy -acodec copy -y HP_undRerSteinDerWeisen.avi
[02:44] <pentanol> I got audio\video unsynch after 2-3 minutes of the movie
[02:45] <pentanol> also I did reencoding:
[02:45] <pentanol> ffmpeg -i /mnt/xfs/mov_de/HP_undRerSteinDerWeisen.ac3 -ss 3 -i "concat:vts_02_1.avi|vts_02_2.avi|vts_02_3.avi|vts_02_4.avi|vts_02_5.avi|vts_02_6.avi|vts_02_7.avi|vts_02_8.avi"  -t 600 -map 1:0 -map 1:1 -map 1:2 -map 0:0 -vcodec copy -acodec ac3 -ac 2 -ar 192kb -y HP_undRerSteinDerWeisen.avi
[02:50] <techtopia> you will
[02:50] <techtopia> transcode to a transport stream
[02:50] <techtopia> then concat
[02:50] <techtopia> or use somthing else to merge the files,
[02:52] <pentanol> transcode to a transport stream- what do you mean by that?
[02:52] <pentanol> ac3 file is already encodded
[02:52] <pentanol> I have only vob's for concat
[02:53] <techtopia> ignore the audio for now
[02:53] <pentanol> In first I should do the concat and then add new audio stream to avi file?
[02:53] <pentanol> I did like that
[02:53] <pentanol> but anyway I get wrong synch
[02:54] <techtopia> ffmpeg -i file_01.avi -c copy -bsf:v h264_mp4toannexb -f mpegts file_out_01.ts
[02:54] <techtopia> do that on them all
[02:54] <pentanol> i.e. make concat for audio and video separately and then merge third audios and one video?
[02:54] <techtopia> then concat the ts's
[02:54] <techtopia> and it will remain in sync
[02:54] <techtopia> then transcode back
[02:54] <techtopia> or just use another app
[02:55] <techtopia> ac3 just copy /b 1.ac3 + 2.ac3 + 3.ac3 out.ac3
[02:55] <techtopia> like that then mux back in later
[02:56] <pentanol> when it trouble with video stream?
[02:56] <pentanol> but with ather audio streams I don;t found this trouble
[02:56] <techtopia> im saying deal with the audio and video seperatly
[02:56] <techtopia> then mux back together when done
[02:56] <pentanol> ok, I will try
[02:57] <pentanol> after I made .ts I can do mpeg2video after that?
[02:59] <pentanol> techtopia: but why this not works with just mpeg2video? onlt for h264_mp4toannexb ?
[02:59] <pentanol> only*
[03:25] <voltagex> c_14: are you still around?
[03:25] <c_14> ye
[03:26] <voltagex> re my compile issue - PKG_CONFIG_PATH is set
[03:27] <voltagex> sorry for the delay in response
[03:28] <voltagex> original issue was - I'm trying to build ffmpeg as a static binary on Debian, I'm getting "unable to find libass/fontconfig" even with a custom pkgconfig path - http://sprunge.us/AOJI, fontconfig.pc exists.
[03:33] <c_14> How did you build/install fontconfig?
[03:34] <voltagex> uhh...
[03:35] <voltagex> crap, no access to the build machine
[03:35] <voltagex> I built it normally with a prefix to put it in the ffmpeg_build path
[03:35] <c_14> Did you build it statically?
[03:35] <voltagex> yes
[03:36] <voltagex> I'll make clean and try again in about 4 hours
[03:39] <c_14> Can you then also test `./configure --prefix=/home/voltagex/ffmpeg_build --extra-cflags='-I$HOME/ffmpeg_build/include -static' --extra-ldflags='-L$HOME/ffmpeg_build/lib -static' --enable-static --disable-shared --disable-ffserver --disable-doc --pkg-config-flags=--static --enable-fontconfig' ?
[03:39] <c_14> Since it looks like the problem is with fontconfig, lets make sure that works first and then work our way up from there.
[03:40] <voltagex> ah right
[03:40] <c_14> Oh, and I'll probably be in bed in 4 hours. Just highlight me and I'll look at it when I have time.
[03:40] <voltagex> yeah no worries
[03:41] <c_14> Also, if the above configure doesn't work, could you paste the output of that config.log as well as how you compiled fontconfig, and the output of `pkg-config --cflags --libs --static fontconfig'
[03:44] <relaxed> voltagex: my static builds have ass support http://johnvansickle.com/ffmpeg/
[03:57] <techtopia> should a keyfile.key be like, clientKey=0000000000000000000000000 or just be like this 000000000000000000000 ?
[03:57] <techtopia> 0's not being the real key
[04:00] <techtopia> which ever way i do it, ffmpeg errors http://pastebin.com/8kCsGhiT
[04:03] <techtopia> hmm i found more keys
[04:03] <techtopia> serverKey_internal_ASV3=b3091aa3eb501b5b660c8ef2fedf7068-7941729fbce73339b8c18853077d482f-0-32
[04:03] <techtopia> ^ is that an aes key
[04:03] <techtopia> looks too long
[04:07] <techtopia> hmm now with the other keys it just crashes ffmpeg on this line
[04:07] <techtopia> Format lrc detected only with low score of 5, misdetection possible!
[04:07] <techtopia> no one ever downloaded aes encrypted video with ffmpeg before ?
[04:12] <relaxed> techtopia: I have not. Did you use -cryptokey ?
[04:13] <relaxed> or,  ffmpeg -h full|less +/^crypto
[04:15] <relaxed> or, man ffmpeg-all|less +/^'   crypto'
[06:22] <applejack> I can't work this out...
[06:24] <applejack> take a stereo source, upmix to 5.1, channelsplit, apply highpass/lowpass to CTR/LFE, join...
[06:25] <applejack> I've got the upmix/split/join
[06:25] <applejack> but [LFE]lowpass says too many inputs to lowpass
[06:26] <applejack> in this: http://pastebin.com/JxxzEVHB
[06:28] <applejack> bleh, nm
[10:16] <RobertNagy> The concat decoder. Shouldn't it sort the input files by start_time, e.g. when the file order loops around back to 000?
[10:23] <minimoo> Morning, "Error when opening encoder for output stream
[10:23] <minimoo> any idea how to diagnose that?
[10:23] <minimoo>  it's only happening on a particular type of import file (vcode: tscc(camtasia) -> h264)
[10:24] <minimoo> now this would be a lot easier if windows copy/paste hadn't stopped working:P
[10:29] <termos> I'm trying to mux smoothstreaming with libffmpeg, it works fine for a stream with just video but once I include audio everything plays at twice the speed of what it should
[10:30] <termos> doing the same but just for flv and mp4 works just fine
[10:30] <termos> it also works with ffmpeg from the command line, so I must be doing something wrong? Anyone have some ideas?
[10:31] <minimoo> relaxed: http://imgur.com/x01TH9F
[10:31] <minimoo> (that's the pastebin output in a rather unconventional format due to windows clipboard being crap :P)
[10:32] <relaxed> minimoo: add -pix_fmt yuv420p
[10:33] <relaxed> "baseline profile doesn't support 4:4:4"
[10:33] <minimoo> ok, that obviously works - so erm, 4:4:4 is some weird import format in this case?
[10:34] <minimoo> (i.e. how do I detect this type of video
[10:34] <minimoo> i'm assuming from the comment I don't always want to use the -pix_fmt yuv420p ?
[10:35] <relaxed> most likely you do, but ffmpeg tries to use the input color space if the encoder supports it
[10:36] <minimoo> i'vve been encoding videos a in 'internal school you-tube' type thing for 3 years with those arguments now, and this has only just come up - so i'm just wondering if the fix is to always add -pix_fmt yuv420p or only in some cases :)
[10:37] <minimoo> or equally, if ffmpeg's moved on and the command line i'm using is a bit dumb, feel free to say
[10:39] <relaxed> minimoo: -pix_fmt yuv420p is safe for what it sounds like you're doing.
[10:40] <minimoo> right, will do that then :
[10:40] <minimoo> Thanks again - pretty sure you was the dude that helped about a 12-18 months ago when I was last yaer :0
[10:41] <relaxed> you're welcome
[11:21] <applejack> does this look right? : http://pastebin.com/uD8tnvAC
[11:24] <applejack> meant to upmix a stereo audio channel to ac3 5.1
[13:06] <relaxed> applejack: did you try only using -ac 6
[13:09] <applejack> relaxed: yea, that only copies the stereo sound to FL and FR
[13:09] <applejack> the rest of them are silent
[13:10] <relaxed> ok, I was just curious if it worked
[13:12] <applejack> I think my delay was too long tho, and the differential on the back speakers was too high too
[17:54] <Mista-D> is there a way to do -vcodec copy but to trim CBR bitrate padding?
[17:55] <JEEB> if the padding is within the nal units, nope
[17:55] <JEEB> if it's null packets in an mpeg-ts stream, then it should be possible
[18:28] <Taylor__> Howdy howdy everyone
[18:29] <FML> Can anyone help me with a problem I am having? Ive ran out of resources and I'm on a deadline and I can't figure out the problem...
[18:29] <FML> woe is me
[18:37] <FML> Sooooo yeah?
[18:41] <c_14> If you described the problem someone might be able to help you.
[18:41] <FML> Cool
[18:52] <FML> okay, one second, I'm checking all my facts so I can pin point the issue
[19:30] <FML> Hey I'm trying to combine a .ivf video file with a .opus audio file into an mp4, but all I get is video and a screeching audio for about a second then nothing on the final product, here is what I'm using to combine the two videos "ffmpeg -i outside_50.ivf -i outside_50.opus -r 15 video2.mp4"
[19:30] <FML> ideas?
[19:31] <JEEB> that's re-encoding your shit to whatever the defaults are in a random ffmpeg version, that's the first thing I want to note
[19:31] <JEEB> anyways, post full terminal output into a pastebin as well
[19:31] <JEEB> and link here
[19:36] <klmno> q:how can I tell if my reply was received at ffmpeg-devel at ffmpeg.org ?
[19:38] <klmno> I did add myself on bcc, and the email went out, but there is no update on the email list, and I got no notification from the email list
[19:38] <c_14> https://ffmpeg.org/pipermail/ffmpeg-devel/ Check the archives?
[19:38] <klmno> I did, and it is not there
[19:39] <klmno> I se this is for general q, I will move to ffmpeg-devel IRC
[19:41] <FML> klmno: here ya go http://pastebin.com/LGApMgtX
[19:44] <klmno> what does that have to do with my q?
[19:45] <FML> Oh sorry klmno
[19:45] <FML> haha
[19:45] <FML> I meant JEEB
[19:45] <FML> JEEB: here you go JEEB http://pastebin.com/LGApMgtX
[19:46] <JEEB> is 15fps the original frame rate of the video stream?
[19:48] <FML> no, but if I try to change it then I get stuck in a building phase that can last hours.
[19:49] <JEEB> uhh
[19:49] <JEEB> so what is the source frame rate :P
[19:49] <JEEB> probably not the 90fps seen in the input side if I guess :P
[19:50] <FML> one sec JEEB let me check the code in the JS files, we are getting those two files from a server and they are coded to something around 15 fps but let me confirm
[19:50] <JEEB> if they are VFR, good luck and have fun :P
[19:51] <FML> So when a user uploads a video to the server the fps is 15
[19:55] <JEEB> then move -r 15 to before -i :P
[19:58] <FML> still the same problem :( loud screetching of audio for maybe a second, then only video
[20:03] <JEEB> does it sound OK with ffmpeg -i hurr.opus out.wav ?
[20:07] <FML> So I just tried it again...and it works....wtf hahaha
[20:08] <FML> let me try a set of new files to see what happens
[20:16] <FML> ffmpeg -threads 8 -r 25 -loop 1 -i offline.png -t 5.00 -pix_fmt yuv420p -vcodec libx264 -b:v 1500k -s -1:240 -y offline.mp4
[20:16] <FML> oops
[20:16] <FML> ignore that
[20:21] <FML> ffmpeg -threads 8 -r 15 -loop 1 -i offline.png -t 5.00 -pix_fmt yuv420p -vcodec libx264 -b:v 1500k -s 320:240 -aspect 1.3333 -y offline.mp4
[20:22] <FML> damn it sorry guys, I'm getting my terminal windows all mixed up haha last one I swear
[20:48] <iksik> hello
[21:06] <jjohn> Ahoy, guy. I am having a weird problem with ffmpeg on Linux when I try to record my screen and my audio.
[21:06] <jjohn> guys*
[21:07] <jjohn> When I am encoding at 30 FPS (output), the audio stutters a lot to the point of not being present, and I get "ALSA buffer xrun" errors all the time.
[21:07] <jjohn> But when I am encoding at 60 FPS (output - input is 60 FPS always), everything runs fine.
[21:08] <jjohn> And no, I didn't mix them up.
[21:09] <jjohn> I am running on linux (Gentoo, kernel version 3.18.5), ffmpeg version was pullsed from git: N-69056-g3cfd07a
[21:15] <ChocolateArmpits> hello, can anyone tell if audio passing through a filtergraph is handled in float or it's native sample format ?
[21:15] <gsd> i'm trying to stream a video to an html5 video player - is it possible to tell ffmpeg to only process a particular byte-range?
[21:31] <klmno> clear
[23:07] <micechal> Does ffplay provide decent performance and is recommended for general usage, or should I be better off using some player which uses ffmpeg as an backend, such as mpv?
[00:00] --- Fri Feb  6 2015

More information about the Ffmpeg-devel-irc mailing list