[Ffmpeg-devel-irc] ffmpeg.log.20150206

burek burek021 at gmail.com
Sat Feb 7 02:05:01 CET 2015

[00:50] <nathanpickles> I'm trying to combine two video files into 1 side by side video file. I'm trying to get them to playback in sync. http://hastebin.com/enovamacen.md
[00:52] <c_14> The problem being?
[00:53] <nathanpickles> c_14: So, the 2 videos were recorded at the same time. They are each about 40 seconds long.
[00:55] <nathanpickles> c_14: I want to delay one video by a time delta given by the difference between the start time of both videos
[00:59] <c_14> Either trim the front of the later video, or concat a short color=black in front of the earlier.
[01:03] <nathanpickles> c_14: I have the creation times for each video (from ffmpeg -i) 2015-02-04 21:27:07 and 2015-02-04 21:27:11. How would I add color=black to the first 4 seconds to the second video?
[01:05] <c_14> What are the dimensions of the second video?
[01:05] <nathanpickles> c_14: http://hastebin.com/ukudeneyur.avrasm
[01:06] <nathanpickles> c_14: Dimensions... one sec
[01:07] <nathanpickles> c_14: 1920x1080 for the second video
[01:07] <nathanpickles> the one on the right
[01:08] <nathanpickles> c_14: Here are the details on each: http://hastebin.com/gugagafojo
[01:08] <nathanpickles> 1280x720 for the first one
[01:08] <c_14> `ffmpeg -i 20150204_132628_109.mp4 -i movie=VID_20150204_132628.mp4 -filter_complex "[0:v]scale=iw/2:ih/2,pad=2*iw:ih[left];color=black:duration=4:s=1920x1080[b];[b][1]concat=n=2:v=1:a=0,scale=iw/3:ih/3 [right]; [left][right] overlay=main_w/2:0 [out]" -b:v 768k Output2.mp4'
[01:08] <c_14> ^should do it
[01:10] <nathanpickles> movie=VID_20150204_132628.mp4: No such file or directory ?
[01:10] <c_14> eh, oops
[01:10] <c_14> get rid of the movie=
[01:11] <nathanpickles> Output pad "default" with type video of the filter instance "Parsed_overlay_5" of overlay not connected to any destination
[01:11] <nathanpickles> do i need to pu [left] ?
[01:11] <c_14> I should pay more attention, add -map '[out]' somewhere before Output2.mp4 and after the filtergraph
[01:12] <c_14> That should be it anyway.
[01:12] <nathanpickles> It's good to know this is possible
[01:12] <nathanpickles> I am trying to automat the process.
[01:12] <nathanpickles> Is this the filter graph? "[0:v]scale=iw/2:ih/2,pad=2*iw:ih[left];color=black:duration=4:s=1920x1080[b];[b][1]concat=n=2:v=1:a=0,scale=iw/3:ih/3 [right]; [left][right] overlay=main_w/2:0 [out]"
[01:12] <c_14> yep
[01:13] <nathanpickles> got a couple errors: http://hastebin.com/itofaxotot.vbs
[01:14] <nathanpickles> c_14: http://hastebin.com/itofaxotot
[01:14] <nathanpickles> sorry
[01:14] <c_14> 65536/65536 != 1/1 eh
[01:15] Action: c_14 smells floats
[01:16] <c_14> `ffmpeg -i 20150204_132628_109.mp4 -i VID_20150204_132628.mp4 -filter_complex "[0:v]scale=iw/2:ih/2,pad=2*iw:ih,setsar=1[left];color=black:duration=4:s=1920x1080[b];[1]setsar=1[n];[b][n]concat=n=2:v=1:a=0,scale=iw/3:ih/3 [right]; [left][right] overlay=main_w/2:0 [out]" -map '[out]' -b:v 768k Output2.mp4'
[01:16] <c_14> Try that
[01:31] <nathanpickles> c_14: pretty close, just not getting audio
[01:31] <c_14> You wanted audio?
[01:31] <c_14> From which file?
[01:31] <c_14> Both?
[01:31] <c_14> Mixed?
[01:32] <nathanpickles> just the left file
[01:32] <c_14> add a -map 0:a somewhere before Output2.mp4 and after the inputs
[01:32] <nathanpickles> mixed could be interesting
[01:35] <c_14> If you want mixed, add [0:a][1:a]amix[a] to the end of the filtergraph (after the [out], separated with a ';'), and -map '[a]' somewhere after the filtergraph and before the output file
[01:39] <nathanpickles> c_14: Thank you very much! You have been super helpful
[01:41] <c_14> np
[06:45] <SBait> anyone used dshow inputs and any good atdiagnosing input erros avail for help?
[06:47] <SBait> [NULL @ 0000000008659180] Unable to find a suitable output format for 'audio=Lin
[06:47] <SBait> e in at rear panel (Blue) (R'
[06:47] <SBait> audio=Line in at rear panel (Blue) (R: Invalid argument
[06:48] <SBait> stream encodes fine if i process without the video, and the video process fine without the audio, but join the 2, and = dramas
[06:52] <SBait> fmpeg -f dshow -i video="Timeleak HD Capture": -s pal -aspect 16:9 -vcodec libx264 -b:v 550000: audio="Line in at rear panel (Blue) (R" -acodec libvo_aacenc -af aresample = async = 1 -application lowdelay -ac 2 -f matroska -content_type matroska icecast://source:hackme@internalIP:port/stream.mkv
[09:00] <Nopik> hi all
[09:02] <Nopik> so I'm piping some audio to the ffserver, and it seems that the audio filters get ignored. This doesn't work (filter is not applied): ffmpeg -i tcp:// -af "compand=0.3|0.3:0.8|0.8:-90/-90|-70/-70|-60/-20|0/0:0.01:-5:-45:0.4" http://localhost:8090/feed.ffm (I also tried with -filter_complex), but then I change the output to -f mp3 - | ffmpeg -i
[09:02] <Nopik> - http://localhost:8090/feed.ffm it works and filter is applied
[09:03] <Nopik> so, at worst i can live with extra ffmpeg, but I'd prefer to get rid of it (it is live streaming over multiple channels, so my server is maxing out cpu already, adding dozen of 'empty' ffmpeg instances is definitely not helping
[09:04] <Nopik> any idea how to optimize that?
[09:24] <__julian> hi
[09:25] <__julian> I do run a ffmpeg transcode from an mpeg2 rtsp stream to mpeg2 udp using ffmpeg command line tool. is there a way to dynamically overwrite aspect ratio without restarting ffmpeg?
[10:48] <ariscop> are there any container formats that can store metadata with a pts? worst case i could use a subtitle format but would rather not
[17:04] <applejack> how do I embed an srt file as a subtitle stream in an mkv container while converting an avi with video and audio to mkv ?
[17:06] <applejack> ffmpeg -i video.avi -i sub.srt -c:v copy -c:a ac3 -c:s copy video.mkv <-- thinks the .srt file is an audio track type mp3 ?!??
[17:07] <applejack> however, I can merge it into the mkv with mkvmerge if I omit the srt from ffmpeg
[17:08] <applejack> but that makes it a two step operation
[17:15] <relaxed> applejack: ffmpeg version?
[17:25] <applejack> 2.2.12
[17:37] <applejack> no matter what I try, the srt is  treated as an mp3
[17:46] <relaxed> applejack: also, that version is fairly old. You might compile a more recent version or http://johnvansickle.com/ffmpeg/
[17:51] <relaxed> gcl_5cp: edit the h264 wiki and add it
[17:51] <applejack> relaxed: http://pastie.org/9892543
[17:52] <relaxed> try again
[17:52] <applejack> huh?
[17:53] <relaxed> did you look at the link?
[17:53] <applejack> yea
[17:54] <relaxed> yeah what? It says there's nothing there.
[17:54] <relaxed> hmm, now it's there...how odd
[17:55] <relaxed> applejack: "file sub.srt" returns?
[17:56] <relaxed> did you open sub.srt to see if it was text?
[17:57] <applejack> : sub.srt: Little-endian UTF-16 Unicode text, with CRLF, CR line terminators
[17:59] <applejack> relaxed : sub.srt is in utf-16, so it looks binary-ish
[18:01] <relaxed> try, ffmpeg -i movie.avi -i sub.srt -map 0 -map 1:s -c:v copy -c:a copy -c:s copy out.mkv
[18:02] <applejack> Stream map '1:s' matches no streams.
[18:03] <applejack> hah
[18:03] <relaxed> ok, ffmpeg -i movie.avi -f srt -i sub.srt -map 0 -map 1 -c copy out.mkv
[18:04] <applejack> iconv utf16 -> utf8 sub.srt > subs.srt fixed it
[18:04] <applejack> so ffmpeg don't like UTF16
[18:05] <relaxed> ah, I wonder if 2.5.3 has that problem?
[18:06] <relaxed> ubitux: ^^
[18:06] <ubitux> it should work
[18:06] <ubitux> -f srt should be omitted too
[18:06] <applejack> even on 2.2.12
[18:06] <ubitux> can i get the sample?
[18:07] <ubitux> it's a recent feature
[18:07] <ubitux> utf16 is supported
[18:07] <relaxed> well, I was trying to forse it since it was detected as an mp3
[18:07] <relaxed> force*
[18:07] <applejack> ubitux: did you want the subtitle file?
[18:07] <ubitux> yes please
[18:09] <applejack> ubitux: http://www.mrhansen.id.au/sub.srt
[18:11] <ubitux> works fine here
[18:12] <applejack> 2.5.3?
[18:12] <ubitux> yes
[18:12] <applejack> figures,.... lol
[18:13] <ubitux> http://pastie.org/pastes/9892584/text
[18:13] <ubitux> 757e4659848ac36c4408bf58bc429f3e  sub.srt
[18:13] <ubitux> test.avi generated with ffmpeg -f lavfi -i testsrc=d=30 -y test.avi
[18:14] <applejack> yea,. and notice: [srt @ 0x7fa535904fa0] UTF16 is automatically converted to UTF8, do not specify a character encoding
[18:14] <applejack> i'll just iconv them
[18:22] <ubitux> applejack: but... it works?
[18:22] <ubitux> it's not an error
[18:46] <applejack> ubitux: yea,. but I'm stuck with 2.2.12
[18:47] <ubitux> ah, ok
[18:47] <ubitux> too bad for you :)
[18:47] <applejack> yea
[18:47] <ubitux> suse?
[18:47] <applejack> gentoo
[18:48] <ubitux> you have a masked one :p
[18:48] <applejack> hard masked i think
[18:50] <applejack> i put media-video/ffmpeg ** in package.accept_keywords, which got me 2.2.12, up from 1.2.11
[18:51] <JEEB> applejack, they're hard masked because of rare things. I wouldn't be surprised if you were all right if you went all the way to the latest :P
[18:51] <ubitux> 2.2 is almost 1yr old too
[18:52] <JEEB> basically, the chance of hitting something with 2.2->2.5 is pretty miniscule at this point
[20:14] <Mista-D> JEEB: its in NAL, thanks anyways.  ( a day later : )
[22:51] <heffer2k02> Hello. I'm trying to write an MP4 file from a sequence of h264 frames. It seems to write everything out correctly, but clearly I'm missing something. The error I get when doing ffmpeg -i file.mp4 is "Could not find codec parameters for stream 0 (Video: h264 (avc1 / 0x31637661), none, 1280x720, 4941 kb/s): unspecified pixel format". Now in my code I have set pix_fmt=AV_PIX_FMT_YUV420P, although I'm in the dark a bit here. Is the compl
[22:51] <heffer2k02> aint coming from failure to read stuff from the h264 stream? Or a misconfiguration in the container?
[22:52] <llogan> heffer2k02: are you using the libraries or the cli tool?
[22:52] <heffer2k02> libraries.
[22:52] <llogan> your best bet for an answer is probably the libav-user mailing list.
[22:52] <heffer2k02> ok, thanks.
[22:52] <llogan> the mailing list for the FFmpeg libraries...
[22:53] <llogan> but stick around in case a library user is hanging around
[23:12] <hotwings> hey fellas. i have a video that was encoded in 4 segments.  seg1.mp4, seg2.mp4, seg3.mp4, seg4.mp4... how would i use ffmpeg to join those files consecutively without any re-encoding? the video in them is h264, the audio is ac3
[00:00] --- Sat Feb  7 2015

More information about the Ffmpeg-devel-irc mailing list