[Ffmpeg-devel-irc] ffmpeg.log.20150207

burek burek021 at gmail.com
Sun Feb 8 02:05:02 CET 2015

[00:12] <llogan> hotwings: possibly the concat demuxer
[00:12] <llogan> http://ffmpeg.org/ffmpeg-formats.html#concat
[00:12] <llogan> https://trac.ffmpeg.org/wiki/Concatenate
[00:38] <konbon> Howdy. Is it possible to encode flac to mp3 via ssh using ffmpeg?
[00:42] <c_14> Why would that be a problem?
[01:00] <konbon> Not sure if it's even possible, tbh.
[01:00] <konbon> Was wondering before I install it on my server.
[01:00] <konbon> I'll find some tuts and see if it works out.
[01:09] <c_14> ffmpeg -i flac out.mp3
[01:10] <c_14> https://trac.ffmpeg.org/wiki/Encode/MP3
[01:10] <c_14> have fun
[01:17] <konbon> ty sir
[01:29] <hotwings> llogan - it looks like concat works for my needs, thanks
[01:31] <hotwings> konbon - ffmpeg can be used as command line so anything you can do from the/a gui should be possible on the command line
[01:31] <konbon> oh cool
[01:31] <konbon> never really used it, tbh
[01:32] <konbon> Just encoded my backed up music from flac to mp3 just to save some space.
[01:32] <konbon> 1TB can go by easily these days
[01:33] <alyawn> join /#ffmpeg-devel
[01:33] <alyawn> lol... long day
[01:50] <konbon> pc decided to die for a bit
[01:50] <konbon> back now
[01:52] <heffer2k02> when writing an h264 stream, should i make a call to av_write_frame for each of the SPS and PPS? Or should they just be included along with the data of the first IDR?
[02:10] <Seb_Sob> hello, anyone here?
[02:11] <klaxa> no
[02:11] <klaxa> (yes)
[02:11] <c_14> ((no))
[02:11] <Seb_Sob> i have a problem concating 2 mp4 files
[02:11] <Seb_Sob> could anyone help ?
[02:12] <Seb_Sob> its in android though
[02:13] <klaxa> well can you state your problem more precise?
[02:14] <klaxa> "i have a problem" is pretty general
[02:14] <klaxa> *precisely even
[02:15] <Seb_Sob> http://pastebin.com/s1HqGZ88
[02:16] <Seb_Sob> well the output is just 0bytes so there must be something wrong
[02:17] <klaxa> can you get ffmpeg's output?
[02:17] <klaxa> (stderr)
[02:17] <Seb_Sob> one mp4 is just a cropped mp4 of a video on my phone, the other one is an mp4 made of a frame image and layed with music
[02:17] <llogan> scripts are not supported here. we need the actual command and the complete console output
[02:17] <Seb_Sob> oh okay
[02:18] <Seb_Sob> no i don't have the ffmpeg's output :s
[02:18] <Seb_Sob> it doesn't generate an error, it just produces an mp4 with 0 bytes
[02:19] <llogan> then we are at an impasse
[02:19] <Seb_Sob> but i have another question than: what parameters must be equal for both mp4's in order to concat correctyle? like frame size, etc..
[02:20] <Seb_Sob> because the documentaion says: "As you can infer from this example, multiple types of input are supported, and anything readable by ffmpeg should work. The inputs have to be of the same frame size, and a handful of other attributes have to match."
[02:20] <llogan> http://ffmpeg.org/ffmpeg-filters.html#concat
[02:21] <Seb_Sob> i could try unsafe mode
[02:23] <llogan> you must now be referring to the concat demuxer, although your script was using the concat filter
[02:23] <Seb_Sob> yeah im confused
[02:23] <Seb_Sob> i have both mp4 files with audio so i should use the demuxer?
[02:26] <relaxed> Seb_Sob: https://trac.ffmpeg.org/wiki/Concatenate
[02:26] <Seb_Sob> i was using this : http://i.gyazo.com/f3db1db0c6ab5a38b24976c5f640fda9.png
[02:26] <llogan> that's the concat filter
[02:27] <llogan> it required re-encoding, but sometimes you need to re-encode
[02:27] <relaxed> MP4Box -cat 1.mp4 -cat 2.mp4 -new combined.mp4
[02:27] <Seb_Sob> thats mp4Box
[02:27] <Seb_Sob> don't have that on android
[02:28] <relaxed> oh
[02:28] <llogan> give the demuxer a try. if it doesn't work then use the concat filter
[02:28] <Seb_Sob> im using the ffmpeg4android_lib
[02:28] <Seb_Sob> ok
[02:28] <Seb_Sob> but the demuxer, is it possible without first writing to a file?
[02:28] <llogan> i don't know what ffmpeg4android_lib is, but 3rd party stuff is not supported here
[02:29] <Seb_Sob> oh thought it was official
[02:29] <Seb_Sob> its basicly so that i can perform commands on android
[02:29] <Seb_Sob> the syntax is the same
[02:30] <relaxed> is it just ffmpeg compiled for android?
[02:30] <Seb_Sob> yeah kind of
[02:30] <Seb_Sob> im writing a mobile app, i need do crop vids and concat them
[02:31] <Seb_Sob> the first part works great, but its the concat that drives me crazy :(
[02:31] <Seb_Sob> i don't know how to write it to a file.txt
[02:31] <Seb_Sob> so im looking for a method ffmpeg -f concat -i mylist.txt -c copy output without the .txt part
[02:32] <Seb_Sob> is it possible?
[02:32] <llogan> if you need to crop them too, then use the crop and concat filters
[02:33] <llogan> about the "without the .txt part", yes, probably. http://trac.ffmpeg.org/wiki/Concatenate#Instructions
[02:33] <relaxed> Seb_Sob: my android phone has echo and cat
[02:34] <Seb_Sob> In case you wonder: i crop my video, that gives me part1.mp4, then from that part1.mp4 i take the last frame and i create a 7second .mp4 layered with an mp3 audio and a .png watermark.
[02:34] <relaxed> and /system/bin/sh
[02:34] <Seb_Sob> ah ok
[02:34] <relaxed> be sure and avoid bashisms, though
[02:35] <Seb_Sob> what exacly is the difference between stream level and file level?
[02:36] <Seb_Sob> i have two .mp4 files, is that stream level?
[02:38] <Seb_Sob> btw i tried : ffmpeg -i input1.mp4 -c copy -bsf:v h264_mp4toannexb -f mpegts intermediate1.ts
[02:38] <Seb_Sob> but then intermediate1.ts gives me a black screen, with only audio...
[02:39] <relaxed> what about when you mux back to mp4?
[02:40] <Seb_Sob> when i concat the 2 .ts files it gives me a 0bytes .mp4
[02:40] <Seb_Sob> ffmpeg -i "concat:intermediate1.ts|intermediate2.ts" -c copy -bsf:a aac_adtstoasc output.mp4
[02:43] <relaxed> ffmpeg version?
[02:44] <Seb_Sob> no idea :s
[02:45] <Seb_Sob> this is what i use: http://androidwarzone.blogspot.be/2011/12/ffmpeg4android.html
[02:48] <relaxed> I would see if it works on your desktop, and if it does you'll have to seek support from that guy on why his software doesn't
[02:49] <Seb_Sob> yeah probably
[02:49] <Seb_Sob> i'll try that tomorrow, i need some sleep now, thanks for the help
[04:24] <techtopia> ffmpeg -t 60 -i test.mkv -c copy sample.mkv
[04:24] <techtopia> i use this command to cut a 60 second segment out of a video
[04:24] <techtopia> is there someway i can tell ffmpeg to cut it out after an hour into the video
[04:24] <techtopia> instead of the first 60 seconds
[04:34] <grepper> techtopia: combine with -ss 3600
[04:35] <grepper> or -ss 00:01:00
[05:04] <techtopia> thanks grepper
[05:54] <grepper> techtopia: if you have a recent enough ffmpeg it will do a fast accurate seek with the -ss AFTER the -i FILE
[05:54] <grepper> afaik
[05:55] <grepper> oh, sorry, maybe that really means that the -ss BEFORE the -i FILE will be accurate
[05:56] Action: grepper should have kept quiet about that
[05:58] <grepper> yep, that's it, just did a test
[05:59] <grepper> time ffmpeg -ss 00:01:00 -i VTS_07_1.VOB -frames 1 -y before-i.jpg
[05:59] <grepper> real	0m0.026s
[05:59] <grepper> time ffmpeg -i VIDEO_TS/VTS_07_1.VOB -ss 00:01:00  -frames 1 -y after-i.jpg
[05:59] <grepper> real	0m2.610s
[06:00] <grepper> $ diff -s before-i.jpg after-i.jpg
[06:00] <grepper> Files before-i.jpg and after-i.jpg are identical
[10:56] <fling> How to mix two files together?
[10:56] <fling> Both has video and audio
[10:57] <fling> I want to have two video and two audio in the output
[10:57] <fling> or atleast a single video and two audios
[10:57] Action: fling can't figure out how to do so with -map when two files with multiple streams involved
[10:59] <fling> Ok, looks like I figured it out, thanks to this page -> http://ffmpeg.org/ffmpeg.html#Advanced-options
[11:03] <fling> How to set language for a stream?
[11:06] <fling> &with -metadata
[11:14] <fling> subtitles time!
[11:14] <fling> How can I add regions?&
[12:06] <gdrc> hello.
[12:06] <mcnesium> on osx i am trying to use ffmpeg v2.5.3 with the parameter -pass 2 to check out quality improvements of two-pass encoding, but it only replies Additional information: rc_twopass_stats_in requires at least two packets
[12:07] <mcnesium> this is when trying to encode .webm video from a set of jpeg files
[12:08] <mcnesium> heres the full command qmin=0;qmax=50;ffmpeg -i test/%09d.jpg -r 24 -quality best -cpu-used 0 -threads 2 -qmin $qmin -qmax $qmax -pass 2 -an -vf scale=480:480 -y test_$qmin-$qmax.webm;
[12:08] <mcnesium> can i use that pass 2 parameter here at all?
[12:12] <Mavrik> um, you do know that you have to first run with -pass 1 to generate the info file right?
[13:07] <techtopia> hey guy's
[13:08] <techtopia> trying to download some videos off some servers, which both have the same key file
[13:08] <techtopia> some of their servers are regular http connections, some use port 443 and are ssl connections
[13:09] <techtopia> ffmpeg has no problem with the regular connections but when i tell it to download from the one's using ssl i get 403 errors
[13:09] <techtopia> tried throwing the open ssl dll's in the ffmpeg folder but that didn't work
[13:09] <techtopia> anyone got any ideas
[13:54] <smurdnomad> hi all
[13:55] <smurdnomad> i'm trying to put a watermark on a little clip with -filter_complex filter
[13:56] <smurdnomad> all works fine with landscape videos, but when I use it with portrait video, the output video is in landscape mode ... someone already has this issue ?
[13:57] <smurdnomad> ffmpeg -i bb.mov -i watermark.png -filter_complex overlay aa.mp4
[14:03] <techtopia> use -s resolution
[14:03] <techtopia> for what ever your video resolution is
[14:04] <smurdnomad> can you explain a little bit with an example, i'm new in ffmpeg :)
[14:04] <smurdnomad> (and french ^^)
[14:07] <techtopia> like ffmpeg -i bb.mpv -iwatermark.png -filter_complex overlay -s 800x1600 -aa.mp4
[14:07] <techtopia> manually specify the output resolution you want
[14:07] <Seb_Sob> hey all, is it possible to create a zoom in animation for a specific duration, start zoom level, end zoom level?
[14:09] <smurdnomad> just tried your solution techtopia, but the video is still in landscape but is resolution portrait (I don't know if you see what I mean ...)
[14:10] <techtopia> my resolution was just an example
[14:10] <techtopia> you need to set whatever the resolution of the output device is going to be
[14:10] <techtopia> you also need to be feeding it a portrait video if you want a portrait output
[14:11] <smurdnomad> yes I understand, but the video is not really in portrait mode like the input one (it looks like a portrait mode but the image is just flattened from the edge ....)
[14:12] <smurdnomad> but still rotated
[14:42] <Seb_Sob> zoompan: -vf "zoompan=z='min(zoom+0.0015,1.5)':d=125", are the quotes needed? , does anyone know what the d=125 stand for ? Thanks
[14:47] <Seb_Sob> because this doesn't work:
[14:47] <Seb_Sob> "ffmpeg -loop 1 -i " + imagePath + " -vf zoompan=z=min(zoom+0.0015,1.5):d=125 -c:v libx264 -r 30 -s 640x360 -t 7 -pix_fmt yuv420p " + outputFileName;
[14:48] <Seb_Sob> anyone knows?
[15:13] <gdrc> Seb_Sob: are you on android?
[18:28] <|some1l> hi
[18:28] <|some1l> I use .avi container for output. I noticed ffmpeg doesn't write duplicate frames into file, it uses 0byte framesize. Is there an option to force to write duplicate frames into output?
[18:39] <AlmondPotato> Even with -vf select='between(t\,141\,764)', it's still outputting the first bit of video
[20:05] <gdrc> I'm having trouble merging two video: https://gist.github.com/gderaco/a429c2c384fb24da6763 - stackoverflow doesn't help
[20:32] <gdrc> anyone guys?
[21:10] <django> Is there a way I can detect dupe frames in linux by command?
[00:00] --- Sun Feb  8 2015

More information about the Ffmpeg-devel-irc mailing list