[Ffmpeg-devel-irc] ffmpeg.log.20150208

burek burek021 at gmail.com
Mon Feb 9 02:05:01 CET 2015

[00:30] <lkiesow> gdrc: Did you mean to concatenate the videos? -> https://trac.ffmpeg.org/wiki/Concatenate
[00:31] <gdrc> lkiesow, yeah. found the problem: java
[00:34] <lkiesow> ok, good
[00:49] <REASY> Hello
[00:50] <REASY> Why avcodec_decode_video2() return value < 0 0xbebbb1b7
[00:50] <REASY> Thanks :)
[00:58] <REASY> This code means "Invalid data found when processing input"
[07:08] <applejack> how do I reencode a movie that has mistakenly been encoded in the wrong aspect?
[07:08] <applejack> it's too tall, so I need to add black bars top and bottom
[07:09] <applejack> it's really in 1.5, instead of 1.777
[07:11] <techtopia> is the source video no longer available
[07:11] <applejack> no
[07:11] <applejack> it's now in 720x480
[07:14] <applejack> would it suffice to reencode it with ffmpeg -i movie.mkv -c:v h264 -c:a copy -aspect 3:2 fixed.mkv ?
[07:23] <applejack> indeed, but with -aspect 2.35
[07:30] <relaxed> applejack: you can copy the video stream and change the aspect with matroska
[07:31] <relaxed> or correct the aspect during playback
[07:33] <applejack> relaxed: might try fixing the aspect in matroska
[07:33] <applejack> it'll certainly be quicker
[07:34] <relaxed> ffmpeg -i movie.mkv -map 0 -c copy -aspect 2.35 out.mkv
[07:34] <applejack> why -map 0 ?
[07:34] <applejack> ohh
[07:34] <applejack> all streams
[07:34] <applejack> not just the first of each
[07:34] <applejack> nope,. no fix
[07:36] <relaxed> which version? it worked for me.
[07:37] <applejack> ffmpeg -i movie.mkv -c:v mpeg2video -b:v 9000k -c:a copy -aspect 2.35 out.mkv
[07:37] <applejack> that fixes it
[07:37] <applejack> version,... uhmm,.. latest stable, 2.5.3 iirc
[07:38] <applejack> the c:v copy makes it open up with side bars
[07:39] <applejack> but still out of aspect in full screen
[07:39] <relaxed> which player?
[07:39] <relaxed> I tested with ffplay and mpv
[07:40] <applejack> window$ media player 12
[07:41] <relaxed> try vlc
[07:42] <applejack> it's the same on my stb
[07:42] <applejack> where I really will be playing it
[07:42] <applejack> out of aspect still with -codec copy
[07:43] <relaxed> then if you have the video source I would encode again with the correct AR
[07:43] <applejack> telstra t-box
[07:43] <relaxed> why are you changing the AR anyway?
[07:45] <applejack> it was encoded inthe wrong aspect
[07:46] <applejack> so it's stretched up/downwards
[08:00] <applejack> and no, I don't have the original source
[08:49] <Akagi201> Does someone have tried to write a CMakeLists.txt file for ffmpeg
[09:54] <jongq> hello everybody , how can i find ffserver.exe and thanks ?
[10:02] <jongq> i see just ffserver Documentation not de binary in the ffmpeg site
[11:13] <becks2> hi, when running the script from this page, I'm getting "Data stream encoding not supported yet (only streamcopy)" - what's wrong with it? http://askubuntu.com/questions/247961/normalizing-video-volume-using-avconv
[11:46] <becks2> never mind, solved it by changing the mappings :)
[16:51] <glphvgacs> i keep getting Unrecognised option show_region
[16:53] <glphvgacs> https://bpaste.net/show/c5b058d619ec
[16:53] <glphvgacs> old ffmpeg or missing compile time flag?
[16:53] <c_14> Most probably too old
[16:54] <glphvgacs> 1.2.6-r1
[16:54] <glphvgacs> i see a commit here:
[16:54] <glphvgacs> http://ffmpeg.org/pipermail/ffmpeg-cvslog/2011-August/039422.html
[16:55] <glphvgacs> should i upgrade?
[16:55] <c_14> > --disable-x11grab --di
[16:55] <c_14> Just going to throw that one out there...
[16:55] <glphvgacs> thanks
[16:56] <c_14> But yeah, do update.
[16:56] <c_14> as well
[16:57] <glphvgacs> 2.2.12 is the latest unmasked on gentoo
[16:57] <c_14> You can probably unmask the other ones as well, the likelihood of one of your packages not working with the newest version is very low.
[16:58] <glphvgacs> would you recommend 2.5.* series? i see 2.5.3
[16:59] <glphvgacs> and i guess i can switch to clang build with link time optimisations
[16:59] <Guest87614> can i grab screenshots every x seconds starting at x time? i can't find the exact command for that
[16:59] <c_14> glphvgacs: go with at least 2.5.3
[17:00] <c_14> Guest87614: I'm not sure -ss works with x11grab... you can try it though
[17:00] <Guest87614> i tried it
[17:00] <Guest87614> it complains about bad frame rate
[17:01] <Guest87614> it means it thinks  i want one frame, but i actually want it to continue grabbing
[17:02] <c_14> pastebin your command line so I can see what you have currently
[17:03] <Guest87614> -ss x -i file -f image2 -r 1/120 out%d.jpg
[17:04] <Guest87614> i guess i can just run some numbers and tell it to go to specific frames manually one command at a time
[17:05] <Guest87614> is there a way to get this to work with a dvdr? ie. video_ts?
[17:05] <glphvgacs> c_14: clang doesn't accept --cpu=host, do you know what's the equivalent of that?
[17:06] <c_14> glphvgacs: I have no idea.
[17:07] <c_14> Guest87614: it should just work.
[17:07] <Guest87614> c_14: pardon? which post are you replyiung to?
[17:08] <c_14> both, actually. Your command works just fine for me.
[17:08] <Guest87614> it takes shots every 2 minutes starting at a given time?
[17:12] <glphvgacs> c_14: i can turn off cpu flag detection in gentoo's build system (ebuild) and leave that to ffmpeg's configure script. would that be in good form?
[17:12] <glphvgacs> c_14: here is code where they pass cpu flags in gentoo:
[17:13] <glphvgacs> https://bpaste.net/show/e9fb99d0f5fe
[17:13] <c_14> glphvgacs: you can probably leave that to ffmpeg, ye
[17:20] <gdrc> Hello. I'm using ffmpeg 2.4.2 for video building on android. It's extremely slow (testing with S4 wich has ARMv7_NEON processor). For all operation I use 'threads 5 -preset ultrafast' wich help a bit to reduce time. What can I do more? Using last version of ffmpeg? Thanks.
[17:30] <Seb_Sob> Hi, is it possible to fade out the last 2 seconds of a video?
[17:30] <Seb_Sob> (i dont know how many frames it is)
[17:31] <c_14> Only if you know how long the video is.
[17:31] <Seb_Sob> dam :(
[17:31] <Seb_Sob> n*
[17:31] <Seb_Sob> thanks
[21:05] <zoomshorts> Hello, I was wondering if there is an audio filter that can lower the volume of one stream while another one is active.
[21:06] <zoomshorts> For example im recording from two inputs, my soundcard and loopback, so when I speak into my microphone I want to lower the volume of loopback then raise it again when I'm done talking
[21:07] <zoomshorts> -f alsa -ac 2 -i plug:\"dsnoop:Loopback,1,0\" \ -f alsa -ac 2 -i plug:\"dsnoop:PCH,0,0\" \
[21:07] <zoomshorts> are the inputs
[21:07] <zoomshorts> -filter_complex "[1:0] [2:0] amerge=inputs=2" \
[21:08] <zoomshorts> is the filter I am using to merge them now
[21:10] <zoomshorts> and this is a livestream to an rtmp server so I can't do anything too laggy, thanks.
[21:20] <zoomshorts> oh lol the term im looking for is crossfade
[00:00] --- Mon Feb  9 2015

More information about the Ffmpeg-devel-irc mailing list