[Ffmpeg-devel-irc] ffmpeg.log.20150214

burek burek021 at gmail.com
Sun Feb 15 02:05:01 CET 2015

[01:23] <YaMoonSun> Dunno what I did wrong. Works fine from m4a to aac http://pastebin.com/d1d43W8H
[01:36] <YaMoonSun> Actually, now that I look, it converted one of the songs twice and mislabeled it.
[01:38] <llogan> and aac_adtstosc is a typo
[01:59] <YaMoonSun> Fuck, thanks, I'm swapping to batch files
[02:46] <YaMoonSun> The last m4a in my .bat file refuses to copy the .aac - Says no output file specified.
[03:04] <YaMoonSun> Nevermind, my dumb ass..
[03:04] Action: YaMoonSun shakes his head
[05:45] <m4t> hey is there a way to have ffmpeg switch files every so often
[05:45] <m4t> as in, rotate security cam footage from an rtsp steam
[05:49] <m4t> i guess i could do -t <seconds>, but when i do that it just hangs after the specified number of seconds
[06:48] <DaneC> Hello, would someone mind helping me with a newb problem? :)
[06:50] <DaneC> I'm trying to convert an image (jpeg/png, whichever is easiest) to various pixel formats. Some of them work but others I get an error  "unable to find suitable output format". How do I fix this?
[07:22] <YaMoonSun> Shouldn't transcode from jpeg, use png as your source, just saying.
[07:34] <hts-NOOB> hey anyone online who may be able to help with my dodgy setup?
[07:34] <hts-NOOB> [NULL @ 00000000085d8ce0] Unable to find a suitable output format for 'audio=Tim
[07:34] <hts-NOOB> eleah HD Capture'
[07:40] <hts-NOOB> http://pastebin.com/m2M5HDXv
[07:42] <hts-NOOB> also, dhsow log shows video source as "Video: rawvideo (YUY2 / 0x32595559), yuyv422, 720x480, 59.94", yet it should read as Pal settings
[07:45] Action: YaMoonSun wishes he could
[07:45] <hts-NOOB> thx man
[07:46] Action: YaMoonSun didn't do anything though D=
[07:46] <hts-NOOB> its most likely some error ive made
[07:46] <YaMoonSun> Is dshow to capture your cam?
[07:46] <hts-NOOB> hd source
[07:46] <YaMoonSun> I know that feeling - I was messing up my .bat files earilier.
[07:47] <hts-NOOB> the hdmi capture card, i cannot seem to get ffmpeg to detect the audio, so i plugged in analog and have got a step further
[07:48] <hts-NOOB> the dshow filters have same name for audio and vidio
[07:48] <YaMoonSun> Damn, nice, doing game capturing?
[07:48] <hts-NOOB> yep
[07:48] <hts-NOOB> trying to setup for my mate
[07:49] <hts-NOOB> hes mad keen gamer, me not so much unfortunately
[07:49] <YaMoonSun> Pfft, I wish I had more experience with such things. I mean, I'm a gamer too, but I've never had to use a capture card. I'd presume they come with software.
[07:49] <hts-NOOB> my personal opinion, is the discrepency between the hdmi detected as ntsc, and i guess the analog will be 25 fps(pal)
[07:50] <YaMoonSun> I don't know if you've every heard of OBS, but it may work also.
[07:50] <hts-NOOB> the card has software and drivers(for the one i have anyhow)
[07:51] <YaMoonSun> Ouch, what game are you trying to record
[07:51] <hts-NOOB> kk thx. i tried vlc, and picture is awsome, but again, no audio detected
[07:52] <hts-NOOB> oh wait, not sure ive tried vlc now that i have analog plugged in
[07:53] <hts-NOOB> brb
[07:53] Action: YaMoonSun wishes you luck
[08:00] <hts-NOOB> lol, runs and crashes pc - complete lockup
[08:00] <hts-NOOB> brb, need to reboot and update vlc
[08:13] <YaMoonSun> That's fucked man. You ran it from VLC you said?
[08:53] <hts-NOOB> YaMoonSun>, yeah, i can open to play with vlc on local, plays fine, select to stream via http, and lockup
[09:06] <YaMoonSun> Neat. Ever look at OBS?
[09:30] <hts-NOOB> not yet mate, sorry reading google
[10:08] <hts-NOOB> bbl
[14:38] <DaneC> Trying to convert png to various raw formats, but some of the raw pixel formats give me an "unsuitable output format" error, anything I can try?
[19:15] <m4t> hey, when using -t parameter with an rtsp:// input, is it possible to have ffmpeg exit at the end of the specified time?
[19:15] <m4t> because it just hangs.
[20:02] <circ-user-Pcdjw> Hi, could anyone help me out by pointing out what's wrong in this command: http://pastebin.com/sySdtkWx
[20:03] <circ-user-Pcdjw> I'm not very familiar with FFMPEG
[20:04] <circ-user-Pcdjw> and am getting "Unable to find a suitable output format for 'fps=fps=1/600' fps=fps=1/600: Invalid argument"
[20:13] <circ-user-Pcdjw> Anyone ... please ?
[20:51] <c_14> get rid of that fps part, it's not valid in its current location
[21:04] <sakujo> is "SDL support               no" (and opencl disabled) bad for Kodi Home Theatre?
[21:05] <JEEB> how would kodi use either of those :P
[21:05] <JEEB> also I thought kodi used some crappy fork with random hacks in it?
[21:06] <sakujo> it certainly might
[21:06] <sakujo> they are very emotional about how distros ship libav as being gross and their ffmpegs being weird or whatnot
[21:06] <sakujo> and only their ffmpeg being officially supported
[21:07] <sakujo> the issue here is i have no clue what the simple directmedia layer does
[21:07] <sakujo> or wait i do
[21:07] <sakujo> it controls stuff on low level
[21:07] <JEEB> well I'd consider their ffmpeg being the weird one :P
[21:07] <sakujo> yeah i was just paraphrasing :p
[21:08] <JEEB> also they loudly herped a derp when an old VDPAU thing was removed which was crap, and replaced with a better interface
[21:08] <sakujo> hmm so it really would not matter if ffmpeg has SDL support or not i suppose
[21:08] <JEEB> generally I have a very negative impression of the whole project
[21:08] <sakujo> that is a shame
[21:08] <JEEB> but not that I know of any better project in that space
[21:08] <sakujo> it is very huge, i think it is inevitable that a lot of negative things come to light
[21:08] <JEEB> so while it's shit, I guess you're stuck with it in that feature space
[21:09] <sakujo> i would be lying if i did not get disappointed at least a few times, but something that huge cannot cater to every demographic
[21:09] <JEEB> but yes, neither opencl or sdl support should have any relation to playback :P
[21:09] <sakujo> at least not all the time
[21:09] <JEEB> well, I'm more derping about the fact of how little care they give on the lavf/lavc/etc libraries' upstream, and that it's a very "ugh I do this now. ugh I am right" kind of project
[21:09] <JEEB> :P
[21:10] <JEEB> but I'm just a grumpy multimedia person
[21:11] <sakujo> nah as a debian user i can relate
[21:12] <sakujo> "now don't let me get started on debian" (/s)
[21:13] <JEEB> well personally I can see the debian libav maintainer being quite good compared to some other things
[21:13] <JEEB> I mean, he mostly had to fix dozens of packages to get newer versions in because other upstreams wouldn't do it
[21:13] <JEEB> that's the reason why gentoo still has latest libav and ffmpeg versions hard-masked
[21:14] <JEEB> whatever you might think of FFmpeg/Libav, I personally have no issues regarding how the Debian Libav maintainer did his job during updates for it
[21:14] <JEEB> because it's a shitty job, having to update all the things to latest APIs
[21:15] <JEEB> and once again, there's the gentoo case where that shit is still going on
[21:15] <JEEB> (latest versions of FFmpeg/Libav being hardmasked)
[21:17] <Mavrik> mhm, well libav API does change quite a bit
[21:18] <JEEB> well, they do keep old APIs for at least one release
[21:18] <JEEB> and it doesn't happen too often that a release happens there
[21:18] <Mavrik> True, but remember, we're talking about projects that still link to ffmpeg 0.8 or smthn :D
[21:18] <JEEB> well, yeah. old releases have old shit
[21:19] <JEEB> debian generally is actually pretty fast with Libav
[21:19] <JEEB> considering that it's a single person poking everything depending on it
[21:19] <Mavrik> Talking to the guy who maintained Cinelerra for a while was rather fun.
[21:19] <Mavrik> Until it affected his sanity too much
[21:19] <JEEB> I think libav 9 was... half a year+
[21:19] <JEEB> yeah, I'm surprised the Debian Libav maintainer is keeping his cool
[21:19] <JEEB> libav 10 was I think a bit less
[21:20] <JEEB> I complained to the gentoo guy some time ago and he just ragequit
[21:20] <JEEB> "nobody understands my issues and how this is not just my problem!"
[21:20] <Mavrik> Personally I think linking to libav dynamically is just crazy
[21:21] <JEEB> dynamic linking is ok, but at this point if you want to support some mostly unmaintained crap as a distro, you should distro multiple versions
[21:21] <JEEB> but that seems to be a no-go
[21:21] <JEEB> "we did that once for audacity, I don't want to do it again"
[21:22] <Mavrik> meh, that sounds like the lesson every package management software has to learn at some point
[21:22] <Mavrik> ALWAYS pin your dependencies to the version your software is compiled/released at
[21:22] Action: Mavrik came from Go meetup where they learned that the hard way... again.
[21:23] <JEEB> the package management software has supported multiple API versions of stuff for ages as long as the soname is set
[21:23] <JEEB> but it seems like security people are hard against that
[21:23] <JEEB> "the more shit we poke out the more shit we have to look out for here at security >:|"
[22:13] <m4t> is there a way to minimize the long delay when starting the recording of an rtsp stream?
[22:16] <m4t> hrm i guess it seems to still record even though it doesn't output the stream info
[22:17] <BtbN> It's propably probing for codec infos
[22:17] <BtbN> how long is the delay?
[22:19] <m4t> 30s
[22:19] <m4t> is it estimating stream duration?
[22:20] <m4t> my main issues are with the '-t' option. both linux64 static builds hang at the end of duration
[22:20] <m4t> and the debian wheezy package seems to just ignore the parameter.
[22:21] <m4t> took 64s to start this time
[22:23] <BtbN> Try to set a low -analyzeduration
[22:24] <BtbN> But iirc default is 5 seconds
[22:24] <BtbN> So 30 seconds is strange and propably a diffrent problem
[22:24] <BtbN> what does it putput when you set the loglevel to debug?
[22:24] <BtbN> *output
[22:25] <m4t> we'll see in 5min :-)
[22:26] <m4t> [rtsp @ 0x32d9160] Probe buffer size limit 5000000 reached
[22:26] <m4t> then it starts
[22:27] <m4t> -probesize does it
[22:29] <m4t> yeah it still blows right past -timelimit
[22:56] <m4t> i can't get debian avconv to convert this ulaw stream to aac either
[22:56] <m4t> audio comes up 0kb
[22:56] <m4t> libmp3lame works fine
[23:02] <m4t> i'll just use the static release and prefix ffmpeg with a 'timeout -s INT <time>'
[00:00] --- Sun Feb 15 2015

More information about the Ffmpeg-devel-irc mailing list